MPLS High Availability Configuration Guide, Cisco IOS XE Release 3S
AToM Graceful Restart
Downloads: This chapterpdf (PDF - 1.2MB) The complete bookPDF (PDF - 2.91MB) | The complete bookePub (ePub - 374.0KB) | Feedback

AToM Graceful Restart

AToM Graceful Restart

The AToM Graceful Restart feature assists neighboring devices that have nonstop forwarding (NSF), stateful switchover (SSO), and graceful restart (GR) for Any Transport over Multiprotocol Label Switching (AToM) to recover gracefully from an interruption in service. AToM GR functions strictly in helper mode, which means it helps other devices that are enabled with the NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature to recover. If the device with AToM GR fails, its peers cannot help it recover. AToM GR is based on the MPLS Label Distribution Protocol (LDP) Graceful Restart feature.

Keep the following points in mind when reading this document:

  • The AToM GR feature described in this document refers to helper mode.
  • For brevity, the NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature is called AToM SSO/NSF in this document.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for AToM Graceful Restart

Any Transport over Multiprotocol Label Switching (AToM) must be configured.

Restrictions for AToM Graceful Restart

  • Any Transport over Multiprotocol Label Switching (AToM) graceful restart (GR) is supported in strict helper mode.
  • MPLS Label Distribution Protocol (LDP) GR cannot be configured on label-controlled ATM (LC-ATM) interfaces.
  • On some hardware platforms, Tag Distribution Protocol (TDP) sessions are not supported. Only LDP sessions are supported.

Information About AToM Graceful Restart

How AToM Graceful Restart Works

Any Transport over Multiprotocol Label Switching Graceful Restart (AToM GR) works in strict helper mode, which means it helps a neighboring Route Processor (RP) that has AToM nonstop forwarding (NSF) and stateful switchover (SSO) to recover from a disruption in service without losing its MPLS forwarding state. The disruption in service could result from a TCP or User Datagram Protocol (UDP) event or the SSO of an RP. AToM GR is based on the MPLS Label Distribution Protocol (LDP) Graceful Restart feature, which preserves forwarding information for AToM circuits during an LDP session interruption. When the neighboring device establishes a new session, the LDP bindings and MPLS forwarding state are recovered.

How to Configure AToM Graceful Restart

Configuring AToM Graceful Restart

There is no Any Transport over Multiprotocol Label Switching (AToM)-specific configuration for AToM Graceful Restart (GR). You enable the Label Distribution Protocol (LDP) GR to assist a neighboring device configured with AToM nonstop forwarding (NSF) and stateful switchover (SSO) to maintain its forwarding state while the LDP session is disrupted.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip cef distributed

    4.    mpls ldp graceful-restart

    5.    exit

    6.    show mpls l2transport vc detail


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip cef distributed


    Example:
    Device(config)# ip cef distributed
     

    Enables distributed Cisco Express Forwarding.

     
    Step 4 mpls ldp graceful-restart


    Example:
    Device(config)# mpls ldp graceful-restart
     

    Enables the device to protect the LDP bindings and MPLS forwarding state during a disruption in service.

    • AToM GR is enabled globally. When you enable AToM GR, it has no effect on existing LDP sessions. New LDP sessions that are established can perform AToM GR.
     
    Step 5 exit


    Example:
    Device(config)# exit
     

    Exits to privileged EXEC mode.

     
    Step 6 show mpls l2transport vc detail


    Example:
    Device# show mpls l2transport vc detail
     

    Displays detailed information about AToM virtual circuits (VCs).

     

    Configuration Examples for AToM Graceful Restart

    Example: Configuring AToM Graceful Restart

    The following example shows a Fast Ethernet VLAN over Multiprotocol Label Switching (MPLS) configuration. PE1 is configured with Any Transport over MPLS Graceful Restart (AToM GR). PE2 is configured with AToM nonstop forwarding (NSF) and stateful switchover (SSO). The commands for configuring AToM GR and NSF/SSO are shown in bold.

    PE1 with AToM GR

    PE2 with AToM NSF/SSO

    ip cef distributed
    !
    mpls label protocol ldp
    mpls ldp graceful-restart
    mpls ldp router-id Loopback0
    !
    pseudowire-class atom
    encapsulation mpls
    !
    interface Loopback0
     ip address 10.1.1.2 255.255.255.255
    !
    interface FastEthernet2/1/1
     no ip address
    !
    interface FastEthernet2/1/1.2
     description “xconnect to PE2”
     encapsulation dot1Q 2 native
     xconnect 10.2.2.2 1002 pw-class mpls
    !
    ! IGP for MPLS
    router ospf 10
    log-adjacency-changes
    auto-cost reference-bandwidth 1000
    network 10.1.1.2 10.0.0.0 area 0
    network 10.1.1.0 10.0.0.255 area 0
    
    redundancy
     mode sso
    ip cef distributed
    !
    mpls label protocol ldp
    mpls ldp graceful-restart
    mpls ldp router-id Loopback0
    !
    pseudowire-class atom
    encapsulation mpls
    !
    interface Loopback0
     ip address 10.2.2.2 255.255.255.255
    !
    interface FastEthernet0/3/2
     no ip address
    !
    interface FastEthernet0/3/2.2
     description “xconnect to PE1”
     encapsulation dot1Q 2
     xconnect 10.1.1.2 1002 pw-class mpls
    !
    ! IGP for MPLS
    router ospf 10
    log-adjacency-changes
    nsf cisco enforce global
    auto-cost reference-bandwidth 1000
    network 10.2.2.2 10.0.0.0 area 0
    network 10.1.1.0 10.0.0.255 area 0

    Examples: Verifying AToM Graceful Restart Recovery from an LDP Session Disruption

    The following examples show the output of the show mpls l2transport vc command during normal operation and when a Label Distribution Protocol (LDP) session is recovering from a disruption.

    The following example shows the status of the virtual circuit (VC) on PE1 with Any Transport over Multiprotocol Label Switching Graceful Restart (AToM GR) during normal operation:

    Device# show mpls l2transport vc
    
    Local intf     Local circuit        Dest address    VC ID      Status
    -------------  -------------------- --------------- ---------- ----------
    Fa2/1/1.2      Eth VLAN 2           10.2.2.2         1002       UP

    The following example shows the status of the VC on PE1 with AToM GR while the VC is recovering from an LDP session disruption. The forwarding state for the circuit remains as it was before the disruption.

    Device# show mpls l2transport vc
    
    Local intf     Local circuit        Dest address    VC ID      Status
    -------------  -------------------- --------------- ---------- ----------
    Fa2/1/1.2      Eth VLAN 2           10.2.2.2         1002       RECOVERING
    

    The following example shows the status of the VC on PE1 with AToM GR after the LDP session disruption was cleared. The AToM label bindings were advertised within the allotted time and the status returned to UP.

    Device# show mpls l2transport vc
    
    Local intf     Local circuit        Dest address    VC ID      Status
    -------------  -------------------- --------------- ---------- ----------
    Fa2/1/1.2      Eth VLAN 2           10.2.2.2         1002       UP
    

    The following example shows the detailed status of the VC on PE1 with AToM GR during normal operation:

    Device# show mpls l2transport vc detail
    
    Local interface: Fa2/1/1.2 up, line protocol up, Eth VLAN 2 up
      Destination address: 10.2.2.2, VC ID: 1002, VC status: up
        Preferred path: not configured
        Default path: active
        Tunnel label: imp-null, next hop point2point
        Output interface: Se2/0/2, imposed label stack {16}
      Create time: 1d00h, last status change time: 1d00h
      Signaling protocol: LDP, peer 10.2.2.2:0 up
        MPLS VC labels: local 21, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description: "xconnect to PE2"
      Sequencing: receive disabled, send disabled
      VC statistics:
        packet totals: receive 3466, send 12286
        byte totals:   receive 4322368, send 5040220
        packet drops:  receive 0, send 0
    

    The following example shows the detailed status of the VC on PE1 with AToM GR while the VC is recovering.

    Device# show mpls l2transport vc detail
    
    Local interface: Fa2/1/1.2 up, line protocol up, Eth VLAN 2 up
      Destination address: 10.2.2.2, VC ID: 1002, VC status: recovering
        Preferred path: not configured
        Default path: active
        Tunnel label: imp-null, next hop point2point
        Output interface: Se2/0/2, imposed label stack {16}
      Create time: 1d00h, last status change time: 00:00:03
      Signaling protocol: LDP, peer 10.2.2.2:0 down
        MPLS VC labels: local 21, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description: "xconnect to PE2"
      Sequencing: receive disabled, send disabled
      VC statistics:
        packet totals: receive 20040, send 28879
        byte totals:   receive 25073016, send 25992388
        packet drops:  receive 0, send 0
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    MPLS AToM and LDP commands

    Cisco IOS Multiprotocol Label Switching Command Reference

    MPLS LDP graceful restart

    “MPLS LDP Graceful Restart” module in the MPLS: High Availability Configuration Guide (part of the Multiprotocol Label Switching Configuration Guide Library)

    Configuring AToM

    “Any Transport over MPLS” module in the MPLS: Layer 2 VPNs Configuration Guide (part of the Multiprotocol Label Switching Configuration Guide Library)

    Nonstop forwarding and stateful switchover for AToM

    “NSF SSO Any Transport over MPLS and AToM Graceful Restart” module in the MPLS: High Availability Configuration Guide (part of the Multiprotocol Label Switching Configuration Guide Library)

    High availability commands

    Cisco IOS High Availability Command Reference

    MIBs

    MIBs

    MIBs Link

    MPLS Label Distribution Protocol MIB Version 8 Upgrade

    To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

    http:/​/​www.cisco.com/​go/​mib

    RFCs

    RFCs

    Title

    RFC 3036

    LDP Specification

    RFC 3478

    Graceful Restart Mechanism for Label Distribution

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for AToM Graceful Restart

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for AToM Graceful Restart

    Feature Name

    Releases

    Feature Information

    AToM Graceful Restart

    12.0(29)S

    12.2(33)SRA

    12.2(33)SXH

    12.4(11)T

    Cisco IOS XE Release 2.3

    The AToM Graceful Restart feature assists neighboring devices that have nonstop forwarding (NSF), stateful switchover (SSO), and graceful restart (GR) for Any Transport over Multiprotocol Label Switching (AToM) to recover gracefully from an interruption in service. AToM GR functions strictly in helper mode, which means it helps other devices that are enabled with the NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature to recover. If the device with AToM GR fails, its peers cannot help it recover. AToM GR is based on the MPLS Label Distribution Protocol (LDP) Graceful Restart feature.

    In Cisco IOS Release 12.0(29)S, this feature was introduced.

    In Cisco IOS Release 12.2(33)SRA, support was added for the Cisco 7600 series routers.

    In Cisco IOS Release 12.2(33)SXH, this feature was integrated into the release.

    In Cisco IOS Release 12.4(11)T, this feature was integrated into the release.

    In Cisco IOS Release XE 2.3, this feature was implemented on the Cisco ASR 1000 Series Aggregation Services Routers.

    This feature uses no new or modified commands.