MPLS High Availability Configuration Guide, Cisco IOS XE Release 3S (Cisco ASR 1000)
AToM Graceful Restart
Downloads: This chapterpdf (PDF - 1.19MB) The complete bookPDF (PDF - 2.92MB) | The complete bookePub (ePub - 375.0KB) | Feedback

AToM Graceful Restart

AToM Graceful Restart

The AToM Graceful Restart feature assists neighboring routers that have nonstop forwarding (NSF), stateful switchover (SSO) and graceful restart (GR) for Any Transport over MPLS (AToM) to recover gracefully from an interruption in service. AToM GR functions strictly in helper mode, which means it helps other routers that are enabled with the NSF/SSO: Any Transport over MPLS and AToM Graceful Restart feature to recover. If the router with AToM GR fails, its peers cannot help it recover. AToM GR is based on the MPLS Label Distribution Protocol (LDP) Graceful Restart feature.

Keep the following points in mind when reading this document:

  • The AToM GR feature described in this document refers to helper mode.
  • The NSF/SSO: Any Transport over MPLS and AToM Graceful Restart feature is supported in Cisco IOS Releases 12.2(25)S and 12.2(33)SRA. For brevity, the NSF/SSO: Any Transport over MPLS and AToM Graceful Restart feature is called AToM SSO/NSF in this document.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About AToM Graceful Restart

How AToM Graceful Restart Works

AToM GR works in strict helper mode, which means it helps a neighboring route processor that has AToM NSF/SSO to recover from a disruption in service without losing its MPLS forwarding state. The disruption in service could result from a TCP or User Datagram Protocol (UDP) event or the stateful switchover of a route processor. AToM GR is based on the MPLS LDP Graceful Restart feature, which preserves forwarding information for AToM circuits during an LDP session interruption. When the neighboring router establishes a new session, the LDP bindings and MPLS forwarding state are recovered. For more information related to how the LDP Graceful Restart feature works, see the MPLS LDP Graceful Restart feature module.

How to Configure AToM Graceful Restart

Configuring AToM Graceful Restart

There is no AToM-specific configuration for AToM GR. You enable LDP GR to assist a neighboring router configured with AToM NSF/SSO to maintain its forwarding state while the LDP session is disrupted.

Before You Begin
  • See the MPLS LDP Graceful Restart document for information about how LDP GR works and how you can customize it for your network.
  • Configure AToM. For information about setting up or configuring AToM, see the Any Transport over MPLS document.

Note


  • AToM GR is supported in strict helper mode.
  • AToM NSF/SSO is supported in Cisco IOS Release 12.2(25)S and 12.2(33)SRA.
  • Tag Distribution Protocol (TDP) sessions are not supported. Only LDP sessions are supported.
  • MPLS LDP GR cannot be configured on label-controlled ATM (LC-ATM) interfaces.
>

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip cef [distributed]

    4.    mpls ldp graceful-restart


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip cef [distributed]


    Example:
    Router(config)# ip cef distributed
     

    Enables Cisco Express Forwarding.

     
    Step 4 mpls ldp graceful-restart


    Example:
    Router(config)# mpls ldp graceful-restart
     

    Enables the router to protect the LDP bindings and MPLS forwarding state during a disruption in service.

    AToM GR is enabled globally. When you enable AToM GR, it has no effect on existing LDP sessions. New LDP sessions that are established can perform AToM GR.

     

    Configuration Examples for AToM Graceful Restart

    AToM Graceful Restart Configuration Example

    The following example shows an Ethernet VLAN over MPLS configuration. PE1 is configured with AToM Graceful Restart. PE2 is configured with AToM NSF/SSO. The commands for configuring AToM GR and NSF/SSO are shown in bold.

    PE1 with AToM GR

    PE2 with AToM NSF/SSO

    ip cef
    !
    mpls label protocol ldp
    mpls ldp graceful-restart
    mpls ldp router-id Loopback0
    !
    pseudowire-class atom
    encapsulation mpls
    !
    interface Loopback0
     ip address 10.1.1.2 255.255.255.255
    !
    interface FastEthernet5/1/1
     no ip address
    !
    interface FastEthernet5/1/1.2
     description “xconnect to PE2”
     encapsulation dot1Q 2 native
     xconnect 10.2.2.2 1002 pw-class mpls
    !
    ! IGP for MPLS
    router ospf 10
    log-adjacency-changes
    auto-cost reference-bandwidth 1000
    network 10.1.1.2 10.0.0.0 area 0
    network 10.1.1.0 10.0.0.255 area 0
    
    redundancy
     mode sso
    ip cef
    !
    mpls label protocol ldp
    mpls ldp graceful-restart
    mpls ldp router-id Loopback0
    !
    pseudowire-class atom
    encapsulation mpls
    !
    interface Loopback0
     ip address 10.2.2.2 255.255.255.255
    !
    interface Ethernet3/3
     no ip address
    !
    interface Ethernet3/3.2
     description “xconnect to PE1”
     encapsulation dot1Q 2
     xconnect 10.1.1.2 1002 pw-class mpls
    !
    ! IGP for MPLS
    router ospf 10
    log-adjacency-changes
    nsf enforce global
    auto-cost reference-bandwidth 1000
    network 10.2.2.2 10.0.0.0 area 0
    network 10.1.1.0 10.0.0.255 area 0

    AToM Graceful Restart Recovering from an LDP Session Disruption Example

    The following examples show the output of the show mpls l2transport vccommand during normal operation and when an LDP session is recovering from a disruption.

    The following example shows the status of the VC on PE1 with AToM GR during normal operation:

    Router# show mpls l2transport vc
    Local intf     Local circuit        Dest address    VC ID      Status
    -------------  -------------------- --------------- ---------- ----------
    Fa5/1/1.2      Eth VLAN 2           10.2.2.2         1002       UP
    

    The following example shows the status of the VC on PE1 with AToM GR while the VC is recovering from an LDP session disruption. The forwarding state for the circuit remains as it was before the disruption.

    Router# show mpls l2transport vc
    Local intf     Local circuit        Dest address    VC ID      Status
    -------------  -------------------- --------------- ---------- ----------
    Fa5/1/1.2      Eth VLAN 2           10.2.2.2         1002       RECOVERING
    

    The following example shows the status of the VC on PE1 with AToM GR after the LDP session disruption was cleared. The AToM label bindings were advertised within the allotted time and the status returned to UP.

    Router# show mpls l2transport vc
    Local intf     Local circuit        Dest address    VC ID      Status
    -------------  -------------------- --------------- ---------- ----------
    Fa5/1/1.2      Eth VLAN 2           10.2.2.2         1002       UP
    

    The following example shows the detailed status of the VC on PE1 with AToM GR during normal operation:

    Router# show mpls l2transport vc detail
    Local interface: Fa5/1/1.2 up, line protocol up, Eth VLAN 2 up
      Destination address: 10.2.2.2, VC ID: 1002, VC status: up
        Preferred path: not configured
        Default path: active
        Tunnel label: imp-null, next hop point2point
        Output interface: Se4/0/3, imposed label stack {16}
      Create time: 1d00h, last status change time: 1d00h
      Signaling protocol: LDP, peer 10.2.2.2:0 up
        MPLS VC labels: local 21, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description: "xconnect to PE2"
      Sequencing: receive disabled, send disabled
      VC statistics:
        packet totals: receive 3466, send 12286
        byte totals:   receive 4322368, send 5040220
        packet drops:  receive 0, send 0
    

    The following example shows the detailed status of the VC on PE1 with AToM GR while the VC is recovering.

    Router# show mpls l2transport vc detail
    Local interface: Fa5/1/1.2 up, line protocol up, Eth VLAN 2 up
      Destination address: 10.2.2.2, VC ID: 1002, VC status: recovering
        Preferred path: not configured
        Default path: active
        Tunnel label: imp-null, next hop point2point
        Output interface: Se4/0/3, imposed label stack {16}
      Create time: 1d00h, last status change time: 00:00:03
      Signaling protocol: LDP, peer 10.2.2.2:0 down
        MPLS VC labels: local 21, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description: "xconnect to PE2"
      Sequencing: receive disabled, send disabled
      VC statistics:
        packet totals: receive 20040, send 28879
        byte totals:   receive 25073016, send 25992388
        packet drops:  receive 0, send 0
    

    Additional References

    The following sections provide references related to AToM GR.

    Related Documents

    Related Topic

    Document Title

    MPLS LDP graceful restart

    MPLS LDP Graceful Restart

    Configuring AToM

    Any Transport over MPLS

    Nonstop forwarding and stateful switchover for AToM

    NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

    Standards

    Standards

    Title

    No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

    MIBs

    MIBs

    MIBs Link

    MPLS Label Distribution Protocol MIB Version 8 Upgrade

    To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

    http:/​/​www.cisco.com/​go/​mibs

    RFCs

    RFCs

    Title

    RFC 3036

    LDP Specification

    RFC 3478

    Graceful Restart Mechanism for Label Distribution

    Technical Assistance

    Description

    Link

    The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

    To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

    Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​techsupport

    Feature Information for AToM Graceful Restart

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for AToM Graceful Restart

    Feature Name

    Releases

    Feature Information

    AToM Graceful Restart

    12.0(29)S 12.2(33)SRA 12.4(11)T 12.2(33)SXH

    In 12.0(29)S, this feature was introduced.

    In 12.2(33)SRA, support was added for the Cisco 7600 series routers.

    In 12.4(11)T, this feature was integrated into the release.

    In 12.2(33)SXH, this feature was integrated into the release.