IPv6 Addressing and Basic Connectivity Configuration Guide, Cisco IOS XE Release 3S (Cisco ASR 1000)
IPv6 Anycast Address
Downloads: This chapterpdf (PDF - 1.14MB) The complete bookPDF (PDF - 2.95MB) | The complete bookePub (ePub - 473.0KB) | The complete bookMobi (Mobi - 527.0KB) | Feedback

IPv6 Anycast Address

IPv6 Anycast Address

An IPv6 anycast address is an address that is assigned to a set of interfaces that typically belong to different nodes. Anycast addresses are syntactically indistinguishable from unicast addresses, because anycast addresses are allocated from the unicast address space.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About IPv6 Anycast Address

IPv6 Address Type: Anycast

An anycast address is an address that is assigned to a set of interfaces that typically belong to different nodes. A packet sent to an anycast address is delivered to the closest interface (as defined by the routing protocols in use) identified by the anycast address. Anycast addresses are syntactically indistinguishable from unicast addresses, because anycast addresses are allocated from the unicast address space. Assigning a unicast address to more than one interface makes a unicast address an anycast address. Nodes to which the anycast address is assigned must be explicitly configured to recognize that the address is an anycast address.


Note


Anycast addresses can be used only by a device, not a host, and anycast addresses must not be used as the source address of an IPv6 packet.


The figure below shows the format of the subnet device anycast address; the address has a prefix concatenated by a series of zeros (the interface ID). The subnet device anycast address can be used to reach a device on the link that is identified by the prefix in the subnet device anycast address.

Figure 1. Subnet Device Anycast Address Format

How to Configure IPv6 Anycast Address

Configuring IPv6 Anycast Addressing

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    tunnel mode ipv6ip [6rd | 6to4 | auto-tunnel | isatap]

    5.    tunnel source { ip address | ipv6-address | interface-type interface-number }

    6.    ipv6 address { ipv6-prefix/prefix-length | prefix-name sub-bits/prefix-length }

    7.    ipv6 address ipv6-prefix/prefix-length anycast


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Device(config)# interface tunnel0
     

    Specifies an interface type and number, and places the device in interface configuration mode.

     
    Step 4 tunnel mode ipv6ip [6rd | 6to4 | auto-tunnel | isatap]


    Example:
    Device(config-if)# tunnel mode ipv6ip 6to4
     

    Configures a static IPv6 tunnel interface.

     
    Step 5 tunnel source { ip address | ipv6-address | interface-type interface-number }


    Example:
    Device(config-if)# tunnel source GigabitEthernet1
     

    Sets the source address for a tunnel interface. The address used here is the one assigned to Ethernet interface 1.

     
    Step 6 ipv6 address { ipv6-prefix/prefix-length | prefix-name sub-bits/prefix-length }


    Example:
    Device(config-if)# ipv6 address 2001:db8:A00:1::1/64
     

    Configures an IPv6 address and enables IPv6 processing on an interface.

     
    Step 7 ipv6 address ipv6-prefix/prefix-length anycast


    Example:
    Device(config-if)# ipv6 address 2002:db8:c058::/128 anycast
     

    Specifying the ipv6 address anycast command adds an IPv6 anycast address.

     

    Configuration Examples for IPv6 Anycast Address

    Example: Configuring IPv6 Anycast Addressing

     interface tunnel0
       tunnel mode ipv6ip 6to4
       tunnel source ethernet1
       ipv6 address 2001:0db8:1::1/64
       ipv6 address 2002:0db8:6301::/128 anycast
      !
      interface gigabitethernet1
       ip address 10.0.0.1 255.255.255.0
       ip address 192.88.99.1 255.255.255.0 secondary 
     

    Additional References for IPv6 Source Guard and Prefix Guard

    Related Documents

    Related Topic

    Document Title

    IPv6 addressing and connectivity

    IPv6 Configuration Guide

    IPv4 addressing

    IP Addressing: IPv4 Addressing Configuration Guide

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    IPv6 commands

    Cisco IOS IPv6 Command Reference

    Cisco IOS IPv6 features

    Cisco IOS IPv6 Feature Mapping

    Standards and RFCs

    Standard/RFC

    Title

    RFCs for IPv6

    IPv6 RFCs

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for IPv6 Anycast Address

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for IPv6 Anycast Address

    Feature Name

    Releases

    Feature Information

    IPv6: Anycast Address

    12.2(25)SEA

    12.2(25)SG

    12.2(33)SRA

    12.2(33)SXH

    12.3(4)T

    15.0(2)SG

    Cisco IOS XE Release 2.1

    3.2.0SG

    An anycast address is an address that is assigned to a set of interfaces that typically belong to different nodes. Anycast addresses are syntactically indistinguishable from unicast addresses, because anycast addresses are allocated from the unicast address space.

    The following commands were introduced or modified: ipv6 address anycast, show ipv6 interface.