IP Routing: RIP Command Reference, Cisco IOS XE Release 3SE (Catalyst 3850 Switches)
RIP Commands
Downloads: This chapterpdf (PDF - 1.41MB) The complete bookPDF (PDF - 755.0KB) | Feedback

RIP Commands

RIP Commands

auto-summary (RIP)

To restore the default behavior of automatic summarization of subnet routes into network-level routes, use the auto-summary command in router configuration mode. Todisable this function and send subprefix routing information across classful network boundaries, use the no form of this command.

auto-summary

no auto-summary

Syntax Description

This command has no arguments or keywords.

Command Default

Enabled (the software summarizes subprefixes to the classful network boundary when crossing classful network boundaries).

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Route summarization reduces the amount of routing information in the routing tables.

RIP Version 1 always uses automatic summarization. If you are using RIP Version 2, you can turn off automatic summarization by specifying the no auto-summary command. Disable automatic summarization if you must perform routing between disconnected subnets. When automatic summarization is off, subnets are advertised.

Examples

In the following example, network numbers are not summarized automatically:

router rip
 version 2
 no auto-summary

bfd all-interfaces

To enable Bidirectional Forwarding Detection (BFD) for all interfaces participating in the routing process, use the bfd all-interfaces command in router configuration or address family interface configuration mode. To disable BFD for all neighbors on a single interface, use the no form of this command.

bfd all-interfaces

no bfd all-interfaces

Syntax Description

This command has no arguments or keywords.

Command Default

BFD is disabled on the interfaces participating in the routing process.

Command Modes

Router configuration (config-router)

Address family interface configuration (config-router-af)

Command History

Release

Modification

12.2(18)SXE

This command was introduced.

12.0(31)S

This command was integrated into Cisco IOS Release 12.0(31)S.

12.4(4)T

This command was integrated into Cisco IOS Release 12.4(4)T.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

Cisco IOS XE Release 2.1

This command was integrated into Cisco IOS Release XE 2.1 and implemented on the Cisco ASR 1000 Series Aggregation Services Routers.

12.2(33)SRE

This command was modified. Support for IPv6 was added.

15.0(1)M

This command was modified. The bfd all-interfaces command in named router configuration mode was replaced by the bfd command in address family interface mode.

15.1(2)T

This command was modified. Support for IPv6 was added.

Cisco IOS XE Release 3.3

This command was modified. Support for the Routing Information Protocol (RIP) was added.

15.2(4)S

This command was modified. Support for IPv6 was added.

Cisco IOS XE Release 3.7S

This command was modified. Support for IPv6 was added.

Usage Guidelines

There are two methods to configure routing protocols to use BFD for failure detection. To enable BFD for all interfaces, enter the bfd all-interfaces command in router configuration mode. In Cisco IOS Release 12.4(24)T, Cisco IOS 12.2(33)SRA, and earlier releases, the bfd all-interfaces command works in router configuration mode and address family interface mode.

In Cisco IOS Release 15.0(1)M and later releases, the bfd all-interfaces command in named router configuration mode is replaced by the bfd command in address family interface configuration mode. Use the bfd command in address family interface configuration mode to achieve the same functionality as that of the bfd all-interfaces command in router configuration mode.

Examples

The following example shows how to enable BFD for all Enhanced Interior Gateway Routing Protocol (EIGRP) neighbors:

Router> enable
Router# configure terminal
Router(config)# router eigrp 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable BFD for all Intermediate System-to-Intermediate System (IS-IS) neighbors:

Router> enable
Router# configure terminal
Router(config)# router isis tag1
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable BFD for all Open Shortest Path First (OSPF) neighbors:

Router> enable
Router# configure terminal
Router(config)# router ospf 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable BFD for all EIGRP neighbors, using the bfd command in address family interface configuration mode:

Router> enable
Router# configure terminal
Router(config)# router eigrp my_eigrp
Router(config-router)# address family ipv4 autonomous-system 100
Router(config-router-af)# af-interface FastEthernet 0/0
Router(config-router-af)# bfd

The following example shows how to enable BFD for all Routing Information Protocol (RIP) neighbors:

Router> enable
Router# configure terminal
Router(config)# router rip
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable IPv6 BFD for all IS-IS neighbors, in address family interface configuration mode:

Router> enable
Router# configure terminal
Router(config)# router isis
Router(config-router)# address family ipv6
Router(config-router-af)# bfd all-interfaces
Router(config-router-af)# end

Related Commands

Command

Description

bfd

Sets the baseline BFD session parameters on an interface.

default-metric (RIP)

To set default metric values for Routing Information Protocol ( RIP), use the default-metric command in router configuration mode. To return to the default state, use the no form of this command.

default-metric number-value

no default-metric [number-value]

Syntax Description

number-value

Default metric value.

Command Default

Built-in, automatic metric translations, as appropriate for each routing protocol

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

T he default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.

Examples

The following example shows a router in autonomous system 109 using both the RIP and the Open Shortest Path First (OSPF) routing protocols. The example advertises OSPF-derived routes using RIP and assigns the OSPF-derived routes a RIP metric of 10.

router rip
 default-metric 10
 redistribute ospf 109

Related Commands

Command

Description

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.

ip rip authentication key-chain

To enable authentication for Routing Information Protocol (RIP) Version 2 packets and to specify the set of keys that can be used on an interface, use the ip rip authentication key-chain command in interface configuration mode. To prevent authentication, use the no form of this command.

ip rip authentication key-chain name-of-chain

no ip rip authentication key-chain [name-of-chain]

Syntax Description

name-of-chain

Enables authentication and specifies the group of keys that are valid.

Command Default

No authentication is provided for RIP packets.

Command Modes


Interface configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

If no key chain is configured with the key-chain command, no authentication is performed on the interface (not even the default authentication).

Examples

The following example configures the interface to accept and send any key belonging to the key chain named trees:

ip rip authentication key-chain trees

Related Commands

Command

Description

key chain

Enables authentication for routing protocols.

ip rip receive version

To specify a Routing Information Protocol ( RIP) version to receive on an interface basis, use the ip rip receive version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip receive version [1] [2]

no ip rip receive version

Syntax Description

1

(Optional) Accepts only RIP Version 1 packets on the interface.

2

(Optional) Accepts only RIP Version 2 packets on the interface.

Command Default

This command is disabled by default.

Command Modes


Interface configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured. You can configure the interface to accept both RIP versions.

Examples

The following example configures the interface to receive both RIP Version 1 and Version 2 packets:

ip rip receive version 1 2

The following example configures the interface to receive only RIP Version 1 packets:

ip rip receive version 1

Related Commands

Command

Description

key chain

Enables authentication for routing protocols.

ip rip authentication key-chain

Enables authentication for RIP Version 2 packets and specifies the set of keys that can be used on an interface.

ip rip send version

Specifies a RIP version to send on an interface basis.

version

Specifies a RIP version used globally by the router.

ip rip send version

To specify a Routing Information Protocol ( RIP) version to send on an interface basis, use the ip rip send version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip send version [1] [2]

no ip rip send version

Syntax Description

1

(Optional) Sends only RIP Version 1 packets out the interface.

2

(Optional) Sends only RIP Version 2 packets out the interface.

Command Default

This command is disabled by default.

Command Modes


Interface configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured.

Examples

The following example configures the interface to send both RIP Version 1 and Version 2 packets out the interface:

ip rip send version 1 2

The following example configures the interface to send only RIP Version 2 packets out the interface:

ip rip send version 2

Related Commands

Command

Description

ip rip receive version

Specifies a RIP version to receive on an interface basis.

version

Specifies a RIP version used globally by the router.

ip split-horizon (RIP)

To enable the split horizon mechanism, use the ip split-horizon command in interface configuration mode. To disable the split horizon mechanism, use the no form of this command.

ip split-horizon

no ip split-horizon

Syntax Description

This command has no arguments or keywords.

Command Default

Default behavior varies with media type.

Command Modes


Interface configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

For all interfaces except those for which either Frame Relay or Switched Multimegabit Data Service (SMDS) encapsulation is enabled, the default condition for this command is ip split-horizon; in other words, the split horizon feature is active. If the interface configuration includes either the encapsulation frame-relay or encapsulation smds command, then the default is for split horizon to be disabled. Split horizon is not disabled by default for interfaces using any of the X.25 encapsulations.


Note


For networks that include links over X.25 packet switched networks (PSNs), the neighbor router configuration command can be used to defeat the split horizon feature. You can as an alternative explicitly specify the no ip split-horizon command in your configuration. However, if you do so you must similarly disable split horizon for all routers in any relevant multicast groups on that network.



Note


If split horizon has been disabled on an interface and you want to enable it, use the ip split-horizon command to restore the split horizon mechanism.



Note


In general, changing the state of the default for the ip split-horizon command is not recommended, unless you are certain that your application requires a change in order to properly advertise routes. If split horizon is disabled on a serial interface (and that interface is attached to a PSN), you must disable split horizon for all routers and access servers in any relevant multicast groups on that network.


Examples

The following simple example disables split horizon on a serial link. The serial link is connected to an X.25 network.

interface serial 0
 encapsulation x25
 no ip split-horizon

Related Commands

Command

Description

neighbor (RIP)

Defines a neighboring router with which to exchange routing information.

ip summary-address rip

To configure a summary aggregate address under an interface for the Routing Information Protocol (RIP), use the ip summary-address rip command in interface configuration mode. To disable summarization of the specified address or subnet, use the no form of this command.

ip summary-address rip ip-address ip-network-mask

no ip summary-address rip ip-address ip-network-mask

Syntax Description

ip-address

IP address to be summarized.

ip-network-mask

IP network mask that drives route summarization for the specified IP address.

Command Default

RIP automatically summarizes to classful network boundaries.

Command Modes


Interface configuration

Command History

Release

Modification

12.0(6)T

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

The ip summary-address rip command is used to summarize an address or subnet under a specific interface. RIP automatically summarizes to classful network boundaries. Only one summary address can be configured for each classful subnet.

Examples

In the following example the major network is 10.0.0.0. The summary address 10.2.0.0 overrides the autosummary address of 10.0.0.0, so that 10.2.0.0 is advertised out Ethernet interface 1 and 10.0.0.0 is not advertised.


Note


If split horizon is enabled, neither autosummary nor interface summary addresses (those configured with the ip summary-address rip command) are advertised.


interface Ethernet1
 ip address 10.1.1.1 255.255.255.0
 ip summary-address rip 10.2.0.0 255.255.0 
 exit
router rip
 network 10.0.0.0
 end

Related Commands

Command

Description

auto-summary (RIP)

Restores the default behavior of automatic summarization of subnet routes into network-level routes.

ip split-horizon (RIP)

Enables the split horizon mechanism.

offset-list (RIP)

To add an offset to incoming and outgoing metrics to routes learned via Routing Information Protocol (RIP), use the offset-listcommand in router configuration mode. To remove an offset list, use the no form of this command.

offset-list { access-list-number | access-list-name } { in | out } offset { interface-type | interface-number }

no offset-list { access-list-number | access-list-name } { in | out } offset { interface-type | interface-number }

Syntax Description

access-list-number

Standard access list number to be applied. Access list number 0 indicates all access lists. If offset is 0, no action is taken. For IGRP, the offset is added to the delay component only.

access-list-name

Standard access list name to be applied.

in

Applies the access list to incoming metrics.

out

Applies the access list to outgoing metrics.

offset

Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken.

interface-type

(Optional) Interface type to which the offset list is applied.

interface-number

(Optional) Interface number to which the offset list is applied.

Command Default

This command is disabled by default.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

10.3

The interface-type and interface- number arguments were added.

11.2

The access-list-name argument was added.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

The offset value is added to the routing metric. An offset list with an interface type and interface number is considered extended and takes precedence over an offset list that is not extended. Therefore, if an entry passes the extended offset list and the normal offset list, the offset of the extended offset list is added to the metric.

Examples

In the following example, the router applies an offset of 10 to the delay component of a router only to access list 21:

offset-list 21 out 10

In the following example, the router applies an offset of 10 to routes learned from Ethernet interface 0:

offset-list 21 in 10 ethernet 0

router rip

To configure the Routing Information Protocol (RIP) routing process, use the route r rip command in global configuration mode. To turn off the RIP routing process, use the no form of this command.

router rip

no router rip

Syntax Description

This command has no arguments or keywords.

Command Default

No RIP routing process is defined.

Command Modes


Global configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Examples

The following example shows how to begin the RIP routing process:

router rip

Related Commands

Command

Description

network (RIP)

Specifies a list of networks for the RIP process.

timers basic (RIP)

To adjust Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To restore the default timers, use the no form of this command.

timers basic update invalid holddown flush

no timers basic

Syntax Description

update

Rate (in seconds) at which updates are sent. This is the fundamental timing parameter of the routing protocol. The default is 30 seconds.

invalid

Interval of time (in seconds) after which a route is declared invalid; it should be at least three times the value of the updateargument. A route becomes invalid when there is an absence of updates that refresh the route. The route then enters into a holddown state. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. The default is 180 seconds.

holddown

Interval (in seconds) during which routing information regarding better paths is suppressed. It should be at least three times the value of the updateargument. A route enters into a holddown state when an update packet is received that indicates the route is unreachable. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. When holddown expires, routes advertised by other sources are accepted and the route is no longer inaccessible. The default is 180 seconds.

flush

Amount of time (in seconds) that must pass before the route is removed from the routing table; the interval specified should be greater than the value of the invalid argument. If it is less than this sum, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. The default is 240 seconds.

Command Default

No RIP network timers are adjusted.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2S, 12.4T

This command was enhanced to allow for the explicit specification of timers for an address family (VRF).

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

The basic timing parameters for RIP are adjustable. Because RIP is executing a distributed, asynchronous routing algorithm, these timers must be the same for all routers and access servers in the network.


Note


The current and default timer values can be seen by inspecting the output of the show ip protocols EXEC command. The relationships of the various timers should be preserved as described previously.


In addition, an address family can have explicitly specified timers that apply to that address-family (or VRF) only. The timers basic command must be specified for an address family or the system defaults for the timers basic command are used regardless of what is configured for RIP routing. The VRF does not inherit the timer values from the base RIP configuration. The VRF will always use the system default timers unless explicitly changed using the timers basic command.

Examples

The following example sets updates to be broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the suppression period, the route is flushed from the routing table.

router rip
 timers basic 5  15  15  30 

Note


By setting a short update period, you run the risk of congesting slow-speed serial lines. A short update period can be a concern on faster-speed Ethernets and T1-rate serial lines. Also, if you have many routes in your updates, you can cause the routers to spend an excessive amount of time processing updates.


The following example show adjusting address family timers.

router rip
 version 2
 timers basic 5 10 15 20
 redistribute connected
 network 5.0.0.0
 default-metric 10
  no auto-summary
  !
  address-family ipv4 vrf foo
  timers basic 10 20 20 20
  redistribute connected
  network 10.0.0.0
  default-metric 5
  no auto-summary
  version 2
  exit-address-family
  !
  address-family ipv4 vrf bar
  timers basic 20 40 60 80
  redistribute connected
  network 20.0.0.0
  default-metric 2
  no auto-summary
  version 2
  exit-address-family
 !

validate-update-source

To have the Cisco IOS software valida te the source IP address of incoming routing updates for Routing Information Protocol (RIP) and Interior Gateway Routing Protocol (IGRP) routing protocols, use the validate-update-sourcecommand in router configuration mode. To disable this function, use the no form of this command.

validate-update-source

no validate-update-source

Syntax Description

This command has no arguments or keywords.

Command Default

The behavior of this command is enabled by default.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.\

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

This command is applicable only to RIP and IGRP. The software ensures that the source IP address of incoming routing updates is on the same IP network as one of the addresses defined for the receiving interface.

Disabling split horizon on the incoming interface will also cause the system to perform this validation check.

For unnumbered IP interfaces (interfaces configured asIP unnumbered), no checking is performed.

Examples

The following example configures a router not to perform validation checks on the source IP address of incoming RIP updates:

router rip
 network 10.105.0.0
 no validate-update-source

version

To specify a Routing Information Protocol (RIP) version used globally by the router, use the version command in router configuration mode. To restore the default value, use the no form of this command.

version { 1 | 2 }

no version

Syntax Description

1

Specifies RIP Version 1.

2

Specifies RIP Version 2.

Command Default

The software receives RIP Version 1 and Version 2 packets, but sends only Version 1 packets.

Command Modes


Router configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

To specify RIP versions used on an interface basis, use the ip rip receive version and ip rip send version commands.

Examples

The following example enables the software to send and receive RIP Version 2 packets:

version 2

Related Commands

Command

Description

ip rip receive version

Specifies a RIP version to receive on an interface basis.

ip rip send version

Specifies a RIP version to send on an interface basis.

show ip protocols

Displays the parameters and current state of the active routing protocol process.