IP Routing: OSPF Configuration Guide, Cisco IOS Release 12.4T
OSPF Shortest Path First Throttling
Downloads: This chapterpdf (PDF - 130.0KB) The complete bookPDF (PDF - 1.81MB) | Feedback

OSPF Shortest Path First Throttling

OSPF Shortest Path First Throttling

Last Updated: October 27, 2011

The OSPF Shortest Path First Throttling feature makes it possible to configure SPF scheduling in millisecond intervals and to potentially delay shortest path first (SPF) calculations during network instability. SPF is scheduled to calculate the Shortest Path Tree (SPT) when there is a change in topology. One SPF run may include multiple topology change events.

The interval at which the SPF calculations occur is chosen dynamically and is based on the frequency of topology changes in the network. The chosen interval is within the boundary of the user-specified value ranges. If network topology is unstable, SPF throttling calculates SPF scheduling intervals to be longer until topology becomes stable.

Feature Specifications for OSPF Shortest Path First Throttling

Feature History

Release

Modification

12.2(14)S

This feature was introduced.

12.0(23)S

This feature was integrated into Cisco Release 12.0(23)S.

12.2(15)T

This feature was integrated into Cisco IOS Release 12.2(15)T.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn . You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Information About OSPF SPF Throttling

Shortest Path First Calculations

SPF calculations occur at the interval set by the timers throttle spfcommand. The wait interval indicates the amount of time to wait until the next SPF calculation occurs. Each wait interval after that calculation is twice as long as the previous one until the wait interval reaches the maximum wait time specified.

The SPF timing can be better explained using an example. In this example the start interval is set at 5 milliseconds (ms), the wait interval at 1000 milliseconds, and the maximum wait time is set at 90,000 milliseconds.

timers throttle spf 5 1000 90000

The figure below shows the intervals at which the SPF calculations occur so long as at least one topology change event is received in a given wait interval.

Figure 1 SPF Calculation Intervals Set by the timers throttle spf Command


Notice that the wait interval between SPF calculations doubles when at least one topology change event is received during the previous wait interval. Once the maximum wait time is reached, the wait interval remains the same until the topology stabilizes and no event is received in that interval.

If the first topology change event is received after the current wait interval, the SPF calculation is delayed by the amount of time specified as the start interval. The subsequent wait intervals continue to follow the dynamic pattern.

If the first topology change event occurs after the maximum wait interval begins, the SPF calculation is again scheduled at the start interval and subsequent wait intervals are reset according the parameters specified in the timers throttle spfcommand. Notice in the figure below that a topology change event was received after the start of the maximum wait time interval and that the SPF intervals have been reset.

Figure 2 Timer Intervals Reset after Topology Change Event


How to Configure OSPF SPF Throttling

Configuring OSPF SPF Throttling

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type slot / port

4.    ip address ip-address mask [secondary]

5.    exit

6.    router ospf process-id

7.    network network-number [mask | prefix-length]

8.    timers throttle spf spf-start spf-hold spf-max-wait

9.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type slot / port


Example:

Router(config)# interface ethernet 1/1/1

 

Enters interface configuration mode for the interface specified.

 
Step 4
ip address ip-address mask [secondary]


Example:

Router(config-if)# ip address 192.168.0.2 255.255.255.0

 

Sets a primary or secondary IP address for an interface.

 
Step 5
exit


Example:

router# exit

 

Exits interface configuration mode.

 
Step 6
router ospf process-id


Example:

Router(config)# router ospf 1

 

Configures an OSPF routing process.

 
Step 7
network network-number [mask | prefix-length]


Example:

Router(config-router)# network 192.168.0.0 0.0.255.255 area 0

 

Configures the subnet number and mask for a Dynamic Host Configuration Protocol (DHCP) address pool on a Cisco IOS DHCP Server.

 
Step 8
timers throttle spf spf-start spf-hold spf-max-wait


Example:

Router(config-router)# timers throttle spf 10 4800 90000

 

Sets OSPF throttling timers.

 
Step 9
end


Example:

Router(config-router)# end

 

Exits configuration mode.

 

Verifying SPF Throttle Values

To verify SPF throttle timer values, use the show ip ospf command. The values are displayed in the lines that begin, "Initial SPF schedule delay...," "Minimum hold time between two consecutive SPFs...," and "Maximum wait time between two consecutive SPFs...."

Router# show ip ospf
 Routing Process "ospf 1" with ID 10.10.10.2 and Domain ID 0.0.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an autonomous system boundary router
 Redistributing External Routes from,
    static, includes subnets in redistribution
Initial SPF schedule delay 5 msecs 
 Minimum hold time between two consecutive SPFs 1000 msecs 
 Maximum wait time between two consecutive SPFs 90000 msecs 
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 4. Checksum Sum 0x17445 
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm last executed 19:11:15.140 ago 
        SPF algorithm executed 28 times
        Area ranges are
        Number of LSA 4. Checksum Sum 0x2C1D4 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

The table below describes the show ip ospf display fields and their descriptions.

Table 1 show ip ospf Field Descriptions

Field

Description

Routing process "ospf 201" with ID 192.42.110.200

Process ID and OSPF router ID.

Supports ...

Number of types of service supported (Type 0 only).

It is ...

Possible types are internal, area border, or autonomous system boundary.

Summary Link update interval

Specifies summary update interval in hours:minutes:seconds, and time until next update.

External Link update interval

Specifies external update interval in hours:minutes:seconds, and time until next update.

Redistributing External Routes from

Lists of redistributed routes, by protocol.

SPF calculations

Lists start, hold, and maximum wait interval values in milliseconds.

Number of areas

Number of areas in router, area addresses, and so on.

SPF algorithm last executed

Shows the last time an SPF calculation was performed in response to topology change event records.

Link State Update Interval

Specifies router and network link-state update interval in hours:minutes:seconds, and time until next update.

Link State Age Interval

Specifies max-aged update deletion interval, and time until next database cleanup, in hours:minutes:seconds.

Configuration Examples for OSPF SPF Throttling

Throttle Timers Example

This example shows a router configured with the start, hold, and maximum interval values for the timers throttle spf command set at 5, 1,000, and 90,000 milliseconds, respectively.

router ospf 1
 router-id 10.10.10.2
 log-adjacency-changes
 timers throttle spf 5 1000 90000 
 redistribute static subnets
 network 21.21.21.0 0.0.0.255 area 0
 network 22.22.22.0 0.0.0.255 area 00

Additional References

For additional information related to OSPF, refer to the following references:

Related Documents

Related Topic

Document Title

OSPF commands

Cisco IOS IP Routing: OSPF Command Reference

OSPF configuration tasks

"Configuring OSPF" module in the Cisco IOS IP Routing Protocols Configuration Guide

Standards

Standards

Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

MIBs

MIBs

MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFCs

Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2011 Cisco Systems, Inc. All rights reserved.