IP Routing: OSPF Configuration Guide, Cisco IOS Release 12.4T
OSPF ABR Type 3 LSA Filtering
Downloads: This chapterpdf (PDF - 87.0KB) The complete bookPDF (PDF - 1.81MB) | Feedback

OSPF ABR Type 3 LSA Filtering

OSPF ABR Type 3 LSA Filtering

Last Updated: October 27, 2011

The OSPF ABR Type 3 LSA Filtering feature extends the ability of an ABR that is running the OSPF protocol to filter type 3 link-state advertisements (LSAs) that are sent between different OSPF areas. This feature allows only packets with specified prefixes to be sent from one area to another area and restricts all packets with other prefixes. This type of area filtering can be applied out of a specific OSPF area, into a specific OSPF area, or into and out of the same OSPF areas at the same time.

History for the OSPF ABR Type 3 LSA Filtering Feature

Release

Modification

12.0(15)S

This feature was introduced.

12.2(4)T

This feature was integrated into Cisco IOS Release 12.2(4)T.

12.2(4)T3

Support for the Cisco 7500 series was added in Cisco IOS Release 12.2(4)T3.

12.2(8)T

Support for the Cisco 1710, 1721, 3631, 3725, 3745 and IGX 8400 series URM was added in Cisco IOS Release 12.2(8)T.

12.2(11)T

Support for the Cisco AS5300, AS5400, and AS5800 series was integrated into Cisco IOS Release 12.2(11)T.

12.2(28)SB

This feature was integrated into Cisco IOS Release 12.2(28)SB.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Benefits

The OSPF ABR Type 3 LSA Filtering feature gives the administrator improved control of route distribution between OSPF areas.

Restrictions

Only type 3 LSAs that originate from an ABR are filtered.

Related Features and Technologies

This feature is an extension of the OSPF routing protocol. For more information about configuring OSPF and configuring route summarization and filtering, refer to the "OSPF" module of the Cisco IOS IP Configuration Guide, Release 12.4 and the Cisco IOS IP Routing Protocols Command Reference, Release 12.4T.

Configuration Tasks

See the following sections for configuration tasks for the OSPF ABR Type 3 LSA Filtering feature. Each task in the list is identified as either required or optional:

Configuring OSPF ABR Type 3 LSA Filtering

SUMMARY STEPS

1.    Router(config)# router ospf process-id

2.    Router(config-router)# area area-id filter-list prefix prefix-list-name in

3.    Router(config-router)# exit

4.    Router(config)# ip prefix-list list-name [seq seq-value] deny | permit network/len [ge ge-value] [le le-value]


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# router ospf process-id 

Configures the router to run an OSPF process.

 
Step 2
Router(config-router)# area area-id filter-list prefix prefix-list-name in 

Configures the router to filter interarea routes into the specified area.

 
Step 3
Router(config-router)# exit 

Exits router configuration mode and returns to global configuration mode.

 
Step 4
Router(config)# ip prefix-list list-name [seq seq-value] deny | permit network/len [ge ge-value] [le le-value] 

Creates a prefix list with the name specified for the list-name argument.

 

Configuring OSPF ABR Type 3 LSA Filtering

To filter interarea routes out of a specified area, use the following commands beginning in router configuration mode:

SUMMARY STEPS

1.    Router(config)# router ospf process-id

2.    Router(config-router)# area area-id filter-list prefix prefix-list-name out

3.    Router(config-router)# exit

4.    Router(config)# ip prefix-list list-name [seq seq-value] deny | permit network/len [ge ge-value] [le le-value]


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# router ospf process-id 

Configures the router to run an OSPF process.

 
Step 2
Router(config-router)# area area-id filter-list prefix prefix-list-name out 

Configures the router to filter interarea routes out of the specified area.

 
Step 3
Router(config-router)# exit 

Exits router configuration mode and returns to global configuration mode.

 
Step 4
Router(config)# ip prefix-list list-name [seq seq-value] deny | permit network/len [ge ge-value] [le le-value] 

Creates a prefix list with the name specified for the list-name argument.

 

Verifying OSPF ABR Type 3 LSA Filtering

To verify that the OSPF ABR Type 3 LSA Filtering feature has been configured, use the show ip ospf command in the EXEC mode. The show ip ospf command will show that this feature has been enabled by listing the area filter as "in" or "out." The following is sample output from the show ip ospf command:

router# show ip ospf 1
  Routing Process "ospf 1" with ID 172.16.0.1
  Supports only single TOS(TOS0) routes
  Supports opaque LSA
  It is an area border router
  SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
  Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
  Number of external LSA 0. Checksum Sum 0x0
  Number of opaque AS LSA 0. Checksum Sum 0x0
  Number of DCbitless external and opaque AS LSA 0
  Number of DoNotAge external and opaque AS LSA 0
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  External flood list length 0
     Area BACKBONE(0)
         Number of interfaces in this area is 2
         Area has no authentication
         SPF algorithm executed 6 times
         Area ranges are
            10.0.0.0/8 Passive Advertise
         Area-filter AREA_0_IN in
         Area-filter AREA_0_OUT out
         Number of LSA 5. Checksum Sum 0x29450
         Number of opaque link LSA 0. Checksum Sum 0x0
         Number of DCbitless LSA 0
         Number of indication LSA 0
         Number of DoNotAge LSA 0
         Flood list length 0
     Area 1
         Number of interfaces in this area is 1
         Area has no authentication
         SPF algorithm executed 4 times
         Area ranges are
         Area-filter AREA_1_IN in
         Area-filter AREA_1_OUT out
         Number of LSA 6. Checksum Sum 0x30100
         Number of opaque link LSA 0. Checksum Sum 0x0
         Number of DCbitless LSA 0
         Number of indication LSA 0
         Number of DoNotAge LSA 0
         Flood list length 0

Monitoring and Maintaining OSPF ABR Type 3 LSA Filtering

Command

Purpose

Router# show ip prefix-list

Displays information about a prefix list or prefix list entries.

Configuration Examples

The following configuration example output shows interarea filtering that is applied to both incoming and outgoing routes:

Router(config)# router ospf 1
 log-adjacency-changes
 area 1 filter-list prefix AREA_1_OUT out
 area 3 filter-list prefix AREA_3_IN in
 network 10.0.0.0 0.255.255.255 area 3
 network 172.16.1.0 0.0.0.255 area 0
 network 192.168.0.0 0.255.255.255 area 1
!
ip prefix-list AREA_1_OUT seq 10 permit 10.25.0.0/8 ge 16
ip prefix-list AREA_1_OUT seq 20 permit 172.20.20.0/24
!
ip prefix-list AREA_3_IN seq 10 permit 172.31.0.0/16
!

Additional References

The following sections provide references related to OSPF ABR Type 3 LSA Filtering.

Related Documents

Related Topic

Document Title

Configuring OSPF ABR Type 3 LSA Filtering

Configuring OSPF ABR Type 3 LSA Filtering

OSPF commands: complete command syntax, command mode, command history, command defaults, usage guidelines, and examples

Cisco IOS IP Routing: OSPF Command Reference

Standards

Standard

Title

None

--

MIBs

MIB

MIBs Link

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC

Title

None

--

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2011 Cisco Systems, Inc. All rights reserved.