IP Multicast: Multicast Resiliency Configuration Guide, Cisco IOS XE Release 3S
Multicast Live-Live
Downloads: This chapterpdf (PDF - 1.25MB) The complete bookPDF (PDF - 2.32MB) | The complete bookePub (ePub - 290.0KB) | Feedback

Multicast Live-Live

Multicast Live-Live

The Multicast Live-Live feature delivers two multicast streams with the same content over diverse paths in the network. This functionality reduces packet loss due to network failures on any one of the paths.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Multicast Live-Live

  • The Multicast Live-Live feature requires multitopology Interior Gateway Protocol (IGP) support.

Restrictions for Multicast Live-Live

  • Multicast traffic splitting and merging is the responsibility of the application. Applications that use multicast technology include video conferencing, corporate communications, distance learning, and distribution of software, stock quotes, and news.
  • Multicast Live-Live is supported for the IPv4 multicast address family.
  • Multicast Live-Live is supported for global Virtual Routing and Forwarding (VRF).
  • Multicast Live-Live is supported for Protocol Independent Multicast Source-Specific Multicast (PIM-SSM) mode and PIM Sparse Mode (PIM-SM).
  • Multicast Live-Live is supported for the Intermediate System-to-Intermediate System (IS-IS) IGP.

Information About Multicast Live-Live

Overview of Multicast Live-Live

This feature delivers two multicast streams with the same content over diverse paths in the network. This functionality reduces packet loss due to network failures on any one of the paths. The feature uses multitopology IGP technology in order to deliver the two streams over diverse paths.

The Multicast Live-Live feature can be divided into three distinct processes as shown in the figure. The processes are visually separated by vertical lines in the figure.

  • The first process consists of splitting the multicast stream into dual streams. The splitting is performed by the application.
  • The second process consists of transmitting the dual streams over the network. Topology selection for transmitting these dual streams can be done in two different ways:
    • Multicast topology selection by group range: This action allows multicast Reverse Path Forwarding (RPF) lookups to perform the RPF check against more than one RPF topology.
    • Multicast topology selection by source prefix: This action allows the replication of routes from more than one (unicast) topology into multicast topology.
  • The third process consists of merging the streams that have been split. The merging is performed by the application.
Figure 1. Overview of Multicast Live-Live

How to Configure Multicast Live-Live

Configuring a Multicast Topology

Perform this task to configure a multicast topology.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip multicast-routing

    4.    ip multicast rpf multitopology

    5.    global-address-family ipv4 multicast

    6.    topology { base | topology-name }

    7.    Repeat Step 6 to configure another global topology instance.

    8.    exit

    9.    interface type number

    10.    ip address ip-address mask [secondary [vrf vrf-name]]

    11.    ip pim sparse-dense-mode

    12.    ip router isis

    13.    topology ipv4 [multicast | unicast] { topology-name [disable] | base}

    14.    exit

    15.    Repeat Steps 9 through 14 for each interface to be configured.

    16.    end


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip multicast-routing


    Example:
    Device(config)# ip multicast-routing
     

    Enables IP multicast routing.

     
    Step 4 ip multicast rpf multitopology


    Example:
    Device(config)# ip multicast rpf multitopology
     

    Enables multicast RPF lookup in multiple topologies.

     
    Step 5 global-address-family ipv4 multicast


    Example:
    Device(config)# global-address-family ipv4 multicast
     

    Enters global address family configuration mode to configure a topology.

     
    Step 6 topology { base | topology-name }


    Example:
    Device(config-af)# topology live-A
     

    Configures a global topology instance.

     
    Step 7 Repeat Step 6 to configure another global topology instance.  

    --

     
    Step 8 exit


    Example:
    Device(config-af)# exit
     

    Exits global address family configuration mode and returns to global configuration mode.

     
    Step 9 interface type number


    Example:
    Device(config)# interface Gigabitethernet 1/0
     

    Enters interface configuration mode for the specified interface type and number.

     
    Step 10 ip address ip-address mask [secondary [vrf vrf-name]]


    Example:
    Device(config-if)# ip address 10.1.1.1 255.255.255.0
     

    Sets a primary or secondary IP address for an interface.

     
    Step 11 ip pim sparse-dense-mode


    Example:
    Device(config-if)# ip pim sparse-dense-mode
     

    Enables PIM sparse dense mode on the interface.

     
    Step 12 ip router isis


    Example:
    Device(config-if)# ip router isis
     

    Configures an Intermediate System-to-Intermediate System (IS-IS) routing process for IP on the interface.

     
    Step 13 topology ipv4 [multicast | unicast] { topology-name [disable] | base}


    Example:
    Device(config-if)# topology ipv4 multicast live-A
     

    Configures a topology instance on an interface.

     
    Step 14 exit


    Example:
    Device(config-if)# exit
     

    Exits interface configuration mode and returns to global configuration mode.

     
    Step 15 Repeat Steps 9 through 14 for each interface to be configured.  

    --

     
    Step 16 end


    Example:
    Device(config)# end
     

    Ends the current configuration session and returns to privileged EXEC mode.

     

    Enabling a Multicast Topology Under IGP

    Perform this task to enable a multicast topology under IGP.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    router isis

      4.    net net1

      5.    metric-style wide [transition] [level-1 | level-2 | level-1-2]

      6.    address-family ipv4 multicast

      7.    topology topology-name tid number

      8.    end

      9.    configure terminal

      10.    ip multicast topology {multicast | unicast} topology-name tid topology-number

      11.    Repeat Step 10 to assign an additional multicast identifier to a topology.

      12.    ip multicast rpf select topology {multicast | unicast} topology-name access-list-number

      13.    Repeat Step 12 to specify an additional topology for an RPF lookup.

      14.    ip access-list {standard | extended} {access-list-name | access-list-number }

      15.    permit protocol {{ source-addr source-wildcard } | object-group object-group-name | any | host { address | name }} {destination-addr destination-wildcard } | object-group object-group-name | any | host {address | name }}

      16.    Repeat Steps 14 and 15 to enumerate an additional (S,G) mroute entry if required.

      17.    end


    DETAILED STEPS
        Command or Action Purpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 router isis


      Example:
      Device(config)# router isis
       

      Enables the IS-IS routing protocol and specifies an IS-IS process.

       
      Step 4 net net1


      Example:
      Device(config-router)# net 49.1234.1234.1234.00
       

      Configures an IS-IS network entity (NET) for the routing process.

       
      Step 5 metric-style wide [transition] [level-1 | level-2 | level-1-2]


      Example:
      Device(config-router)# metric-style wide
       

      Configures a device running IS-IS so that it generates and accepts only new-style type, length, value objects (TLVs).

       
      Step 6 address-family ipv4 multicast


      Example:
      Device(config-router)# address-family ipv4 multicast
       

      Enters router address family configuration mode under IS-IS router configuration mode.

       
      Step 7 topology topology-name tid number


      Example:
      Device(config-router-af)# topology live-A tid 10
       

      Enables a multicast topology under IGP.

       
      Step 8 end


      Example:
      Device(config-router-af-topology)# exit
       

      Returns to privileged EXEC mode.

       
      Step 9 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 10 ip multicast topology {multicast | unicast} topology-name tid topology-number


      Example:
      Device(config)# ip multicast topology multicast live-A tid 100
       

      Assigns a multicast topology identifier to a topology.

       
      Step 11 Repeat Step 10 to assign an additional multicast identifier to a topology.  

      --

       
      Step 12 ip multicast rpf select topology {multicast | unicast} topology-name access-list-number


      Example:
      Device(config)# ip multicast rpf select topology multicast live-A 111
       

      Associates a multicast topology with a multicast group that has a specific (S,G) mroute entry. The notation of (S,G), pronounced “S comma G,” enumerates a shortest path tree where S is the IP address of the source and G is the multicast group address.

       
      Step 13 Repeat Step 12 to specify an additional topology for an RPF lookup.  

      --

       
      Step 14 ip access-list {standard | extended} {access-list-name | access-list-number }


      Example:
      Device(config)# ip access-list extended 111
       

      Specifies a (S,G) mroute entry using IP access list.

       
      Step 15 permit protocol {{ source-addr source-wildcard } | object-group object-group-name | any | host { address | name }} {destination-addr destination-wildcard } | object-group object-group-name | any | host {address | name }}


      Example:
      Device(config-ext-nacl)# permit ip any 225.1.1.1 0.0.0.0
       

      Set conditions in the named IP access list that will permit (S,G) mroute entry multicast packets.

       
      Step 16 Repeat Steps 14 and 15 to enumerate an additional (S,G) mroute entry if required.  

      --

       
      Step 17 end


      Example:
      Device(config-ext-nacl)# end
       

      Returns to privileged EXEC mode.

       

      Verifying the Configuration of Multicast Live-Live

      Perform this task to verify the configuration of the Multicast Live-Live feature.

      SUMMARY STEPS

        1.    enable

        2.    show ip multicast topology [{multicast | unicast} topology-name]


      DETAILED STEPS
        Step 1   enable

        Enables privileged EXEC mode.

        • Enter your password if prompted.

        Device> enable
        Step 2   show ip multicast topology [{multicast | unicast} topology-name]

        Enter the show ipmulticast topologycommand to display multicast topology information:



        Example:
        Device# show ip multicast topology multicast live-A
        Topology: ipv4 multicast live-A
        TID: 1
         Extended IP ACL: 101
        Associated VPN VRF is IPv4 default

        Configuration Examples for Multicast Live-Live

        Example Configuring Multicast Live-Live

        The following example shows how to configure the Multicast Live-Live feature. In the example, two multicast topologies are enabled under IGP, the multicast topologies are assigned a topology identifier, and each multicast topology identifier is associated with a multicast group that has a specific (S,G) mroute entry.

        ip multicast-routing
        ! Enable multi-topology mode 
        ip multicast rpf multitopology
        ! Create 2 IPv4 multicast topologies 
        global-address-family ipv4 multicast 
          topology live-A
          topology live-B
        interface Gigabitethernet 1/0
         ip address 10.1.1.1 255.255.255.0
         ip pim sparse-dense-mode
         ip router isis
         topology ipv4 multicast live-A
        interface Gigabitethernet 2/0
         ip address 2.2.2.2 255.255.255.0
         ip pim sparse-dense-mode
         ip router isis
         topology ipv4 multicast live-B
        router isis
         net 49.1234.1234.1234.00
          metric-style wide
          address-family ipv4 multicast 
          ! CLIs to enable 2 multicast topologies under IGP
          topology live-A tid 10
          topology live-B tid 20
        ! CLIs to assign multicast tid to topology
        ip multicast topology multicast live-A tid 100
        ip multicast topology multicast live-B tid 200
        ! CLIs to specify topology for RPF lookup
        ip multicast rpf select topology multicast live-A 111 
        ip multicast rpf select topology multicast live-B 122 
        ! Use IP access-list extended to specify (S, G)
        ip access-list extended 111 
         permit ip any   225.1.1.1 0.0.0.0 
        ip access-list extended 122 
         permit ip any   239.1.1.1 0.0.0.0

        Additional References

        Related Documents

        Related Topic

        Document Title

        Cisco IOS commands

        Cisco IOS Master Commands List, All Releases

        Overview of the IP multicast technology area

        IP Multicast Technology Overview

        Concepts, tasks, and examples for configuring an IP multicast network using PIM

        Configuring a Basic IP Multicast Network

        IP multicast commands: complete command syntax, command mode, defaults, command history, usage guidelines, and examples

        Cisco IOS IP Multicast Command Reference

        Standards

        Standard

        Title

        No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

        --

        MIBs

        MIB

        MIBs Link

        No new or modified MIBs are supported.

        To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

        http:/​/​www.cisco.com/​go/​mibs

        RFCs

        RFC

        Title

        No new or modified RFCs are supported, and support for existing standards has not been modified.

        --

        Technical Assistance

        Description

        Link

        The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        Feature Information for Multicast Live-Live

        The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

        Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

        Table 1 Feature Information for Multicast Live-Live

        Feature Name

        Releases

        Feature Information

        Multicast Live-Live

        Cisco IOS XE Release 3.2S

        15.2(3)T

        The Multicast Live-Live feature delivers two multicast streams with the same content over diverse paths in the network. This functionality reduces packet loss due to network failures on any one of the paths.

        The following commands were introduced or modified: debug ip multicast topology, ip multicast rpf select topology, ip multicast topology, show ip multicast topology.