IP Multicast: LSM Configuration Guide, Cisco IOS XE Release 3S
MLDP In-Band Signaling/Transit Mode
Downloads: This chapterpdf (PDF - 1.19MB) The complete bookPDF (PDF - 2.94MB) | The complete bookePub (ePub - 683.0KB) | Feedback

MLDP In-Band Signaling/Transit Mode

MLDP In-Band Signaling/Transit Mode

This module contains information for configuring Multicast Label Distribution Protocol (MLDP) in-band signaling to enable the MLDP core to create (S,G) or (*,G) state without using out-of-band signaling such as Border Gateway protocol (BGP) or Protocol Independent Multicast (PIM).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for MLDP In-Band Signaling

  • MLDP in-band signaling supports SOURCE-SPECIFIC MULTICAST (SSM) multicast traffic only.
  • MLDP in-band signaling is not supported in the same VRF for which Rosen Model MLDP-based MVPN or GRE-based MVPN is configured.

Information About MLDP In-Band Signaling/Transit Mode

MLDP In-Band Signaling/Transit Mode

Multicast Label Distribution Protocol (MLDP)-supported multicast VPN (MVPN) allows VPN multicast streams to be aggregated over a VPN-specific tree. No customer state is created in the MLDP core;, there is only state for default and data multicast distribution trees (MDTs). In certain scenarios, the state created for VPN streams is limited and does not appear to be a risk or limiting factor. In these scenarios, MLDP can build in-band MDTs that are transit Label Switched Paths (LSPs).

Trees used in a VPN space are MDTs. Trees used in the global table are transit point-to-multipoint (P2MP) or multipoint-to-multipoint (MP2MP) LSPs. In both cases, a single multicast stream (VPN or not) is associated with a single LSP in the MPLS core. The stream information is encoded in the Forwarding Equivalence Class (FEC) of the LSP. This is in-band signaling.

MLDP in-band signaling uses access control lists (ACLs) with the range of the multicast (S, G) to be transported by the MLDP LSP. Each multicast channel (S, G) maps, one-to-one, to each tree in the in-band tree. The (S,G) join is registered in the Multicast Routing Information Base (MRIB), which is a client of MLDP. Each MLDP LSP is identified by the FEC of [(S,G) + RD], where RD is the Route Distinquisher (RD) obtained from BGP. This differs from MLDP-based MVPN, where the identity is in a FEC of [MDT #, VPN ID, Tree #]).

The ingress Provider Edge (PE) device uses the FEC to decode the stream information and associate the multicast stream with the LSP (in the FEC). This service model is only applicable for transporting Protocol Independent Multicast (PIM) source-specific multicast (SSM) traffic. There is no need to run PIM over the LSP because the stream signaling is done in-band.

The MLDP In-Band Signaling/Transit Mode feature is supported on IPv4 and IPv6 networks. MLDP in-band signaling and MLDP-based MVPN cannot be supported in the same VRF.

How to Configure MLDP In-Band Signaling/Transit Mode

Enabling In-Band Signaling on a PE Device

Before You Begin
  • VRF instances for in-band signaling must be configured.
  • Access control lists (ACLs) for controlling streams must be configured.
SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    Use one of the following commands:

    • ip multicast [vrf vrf] mpls mldp [range acl]
    • ipv6 multicast [vrf vrf] mpls mldp


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
              
     
    Enables privileged EXEC mode.
    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
              
     

    Enters global configuration mode.

     
    Step 3 Use one of the following commands:
    • ip multicast [vrf vrf] mpls mldp [range acl]
    • ipv6 multicast [vrf vrf] mpls mldp


    Example:
    Device (config)# ip multicast vrf vrf1 mpls mldp
              
    Device (config)# ipv6 multicast vrf vrf1 mpls mldp
     
    Brings up the MLDP MRIB process and registers MLDP with the MRIB.
    • To enable in-band signaling globally, use this command without the vrf vrf keyword and argument combination.
    • IPv4 only: To identify streams for in-band signaling, use this command with the range keyword on the egress PE.
     

    Additional References

    Related Documents

    Related Topic

    Document Title

    IPv6 addressing and connectivity

    IPv6 Configuration Guide

    Cisco IOS commands

    Cisco IOS Master Commands List, All Releases

    IP multicast commands

    Cisco IOS IP Multicast Command Reference

    IPv6 commands

    Cisco IOS IPv6 Command Reference

    Cisco IOS IPv6 features

    Cisco IOS IPv6 Feature Mapping

    Standards and RFCs

    Standard/RFC

    Title

    RFCs for IPv6

    IPv6 RFCs

    MIBs

    MIB

    MIBs Link

    To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

    http:/​/​www.cisco.com/​go/​mibs

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Configuration Examples for MLDP In-Band Signaling/Transit Mode

    Example: In-Band Signaling on PE1

    PE1# show running-config 
    Building configuration...
    
    Current configuration : 8247 bytes
    !
    ! Last configuration change at 12:44:13 IST Thu Nov 15 2012
    !
    
    hostname PE1
    !
    mls ipv6 vrf
    !
    vrf definition vrf1
     rd 1:1
     vpn id 1:1
     route-target export 1:1
     route-target import 1:1
     !
     address-family ipv4
      route-target export 1:1
      route-target import 1:1
     exit-address-family
     !
     address-family ipv6
      route-target export 1:1
      route-target import 1:1
     exit-address-family
    !
    
    ip multicast-routing 
    ip multicast-routing vrf vrf1 
    ip multicast hardware-switching replication-mode egress
    ip multicast mpls mldp
    ip multicast vrf vrf1 mpls mldp
    !
    !
    !
    ipv6 unicast-routing
    ipv6 multicast-routing
    ipv6 multicast-routing vrf vrf1
    ipv6 multicast rpf use-bgp
    ipv6 multicast mpls source Loopback0
    ipv6 multicast mpls mldp
    ipv6 multicast vrf vrf1 rpf use-bgp
    ipv6 multicast vrf vrf1 mpls source Loopback0
    ipv6 multicast vrf vrf1 mpls mldp
    !
    !
    vtp domain cisco
    vtp mode off
    mpls label protocol ldp
    mpls ldp graceful-restart
    mls flow ip interface-full
    no mls flow ipv6
    mls rate-limit multicast ipv4 igmp 100 10
    mls cef error action reset
    mls mpls tunnel-recir
    multilink bundle-name authenticated
    !
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    no diagnostic bootup level
    !
    redundancy
     main-cpu
      auto-sync running-config
     mode sso
    !
    
    vlan internal allocation policy ascending
    vlan access-log ratelimit 2000
    !
    interface Loopback0
     ip address 1.1.1.1 255.255.255.255
     ip pim sparse-mode
     ip ospf 100 area 0
     ipv6 address 1::1:1:1/64
     ipv6 enable
    !
    .
    .
    .
    !
    interface GigabitEthernet2/0/0.1
     encapsulation dot1Q 2
     vrf forwarding vrf1
     ip address 192.0.2.1 255.255.255.0
     ip pim sparse-mode
     ip igmp version 3
     ipv6 address FE80::10:1:1 link-local
     ipv6 address 2001:DB8::/64
     ipv6 enable
    !
    interface GigabitEthernet2/0/0.2000
     encapsulation dot1Q 2000
     ip address 192.0.2.2 255.255.255.0
     ip pim sparse-mode
     ip igmp version 3
     ipv6 address 2001:DB8:0:1/64
     ipv6 enable
    !
    .
    .
    .
    interface GigabitEthernet2/0/12
     ip address 192.0.2.3 255.255.255.0
     ip pim sparse-mode
     ip ospf 100 area 0
     ipv6 address 2001:DB8::/64
     ipv6 enable
     mpls ip
     mpls label protocol ldp
     no mls qos trust
    !
    !
    !
    router ospf 100
     router-id 1.1.1.1
    !
    router bgp 100
     bgp log-neighbor-changes
     neighbor 2.2.2.2 remote-as 100
     neighbor 2.2.2.2 update-source Loopback0
     neighbor 3.3.3.3 remote-as 100
     neighbor 3.3.3.3 update-source Loopback0
     neighbor 4.4.4.4 remote-as 100
     neighbor 4.4.4.4 update-source Loopback0
     !
     address-family ipv4
      redistribute static
      redistribute connected
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community both
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community both
      neighbor 4.4.4.4 activate
      neighbor 4.4.4.4 send-community both
     exit-address-family
     !
     address-family vpnv4
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
      neighbor 4.4.4.4 activate
      neighbor 4.4.4.4 send-community extended
     exit-address-family
     !
     address-family ipv4 mdt
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
      neighbor 4.4.4.4 activate
      neighbor 4.4.4.4 send-community extended
     exit-address-family
     !
     address-family ipv6
      redistribute connected
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 2.2.2.2 send-label
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
      neighbor 3.3.3.3 send-label
      neighbor 4.4.4.4 activate
      neighbor 4.4.4.4 send-community extended
      neighbor 4.4.4.4 send-label
     exit-address-family
     !
     address-family vpnv6
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
      neighbor 4.4.4.4 activate
      neighbor 4.4.4.4 send-community extended
     exit-address-family
     !
     address-family ipv4 vrf vrf1
      redistribute connected
     exit-address-family
     !
     address-family ipv6 vrf vrf1
      redistribute connected
     exit-address-family
    !
    no ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    ip pim ssm default
    ip pim mpls source Loopback0
    ip pim vrf vrf1 ssm default
    ip pim vrf vrf1 mpls source Loopback0
    ip route 192.0.2.25 255.255.255.255 7.37.0.1
    !
    !
    mpls ldp router-id Loopback0 force
    !
    !
    !
    end

    Example: In-Band Signaling on PE2

    PE2# show running-config 
    Building configuration...
    
    Current configuration : 7609 bytes
    !
    ! Last configuration change at 13:18:45 IST Thu Nov 15 2012
    !
    hostname PE2
    !
    mls ipv6 vrf
    !
    vrf definition vrf1
     rd 1:1
     vpn id 1:1
     route-target export 1:1
     route-target import 1:1
     !
     address-family ipv4
      route-target export 1:1
      route-target import 1:1
     exit-address-family
     !
     address-family ipv6
      route-target export 1:1
      route-target import 1:1
     exit-address-family
    !
    .
    .
    .
    !
    ip multicast-routing 
    ip multicast-routing vrf vrf1 
    ip multicast hardware-switching replication-mode egress
    ip multicast mpls mldp
    ip multicast vrf vrf1 mpls mldp
    !
    !
    !
    ipv6 unicast-routing
    ipv6 multicast-routing
    ipv6 multicast-routing vrf vrf1
    ipv6 multicast rpf use-bgp
    ipv6 multicast mpls source Loopback0
    ipv6 multicast mpls mldp
    ipv6 multicast vrf vrf1 rpf use-bgp
    ipv6 multicast vrf vrf1 mpls source Loopback0
    ipv6 multicast vrf vrf1 mpls mldp
    !
    !
    vtp domain isbu-devtest
    vtp mode off
    mpls label protocol ldp
    mpls ldp graceful-restart
    mls flow ip interface-full
    no mls flow ipv6
    mls cef error action reset
    multilink bundle-name authenticated
    !
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    diagnostic bootup level minimal
    !
    redundancy
     main-cpu
      auto-sync running-config
     mode sso
    !
    !
    !
    interface Loopback0
     ip address 4.4.4.4 255.255.255.255
     ip pim sparse-mode
     ip ospf 100 area 0
     ipv6 enable
    !
    .
    .
    .
    !
    interface GigabitEthernet3/0/3.1
     encapsulation dot1Q 2
     vrf forwarding vrf1
     ip address 192.0.2.1 255.255.255.0
     ip pim sparse-mode
     ip igmp version 3
     ipv6 address FE80::30:1:1 link-local
     ipv6 address 2001:DB8::/64
     ipv6 enable
    !
    interface GigabitEthernet3/0/3.2000
     encapsulation dot1Q 2000
     ip address 192.0.2.2 255.255.255.0
     ip pim sparse-mode
     ip igmp static-group 232.1.1.1 source 50.0.0.2
     ip igmp version 3
     ipv6 address 2001:DB8:0:1/64
     ipv6 enable
    !
    .
    .
    .
    !
    interface GigabitEthernet4/15
     ip address 192.0.2.3 255.255.255.0
     ip pim sparse-mode
     ip ospf 100 area 0
     ipv6 address 2001:DB8::/64
     ipv6 enable
     mpls ip
     mpls label protocol ldp
    !
    .
    .
    .
    !
    interface Vlan1
     no ip address
     shutdown
    !
    router ospf 100
     router-id 4.4.4.4
    !
    router bgp 100
     bgp log-neighbor-changes
     neighbor 1.1.1.1 remote-as 100
     neighbor 1.1.1.1 update-source Loopback0
     neighbor 2.2.2.2 remote-as 100
     neighbor 2.2.2.2 update-source Loopback0
     neighbor 3.3.3.3 remote-as 100
     neighbor 3.3.3.3 update-source Loopback0
     !
     address-family ipv4
      redistribute static
      redistribute connected
      neighbor 1.1.1.1 activate
      neighbor 1.1.1.1 send-community both
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community both
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community both
     exit-address-family
     !
     address-family vpnv4
      neighbor 1.1.1.1 activate
      neighbor 1.1.1.1 send-community extended
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
     exit-address-family
     !
     address-family ipv4 mdt
      neighbor 1.1.1.1 activate
      neighbor 1.1.1.1 send-community extended
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
     exit-address-family
     !
     address-family ipv6
      redistribute connected
      neighbor 1.1.1.1 activate
      neighbor 1.1.1.1 send-community extended
      neighbor 1.1.1.1 send-label
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 2.2.2.2 send-label
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
      neighbor 3.3.3.3 send-label
     exit-address-family
     !
     address-family vpnv6
      neighbor 1.1.1.1 activate
      neighbor 1.1.1.1 send-community extended
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-community extended
      neighbor 3.3.3.3 activate
      neighbor 3.3.3.3 send-community extended
     exit-address-family
     !
     address-family ipv4 vrf vrf1
      redistribute connected
     exit-address-family
     !
     address-family ipv6 vrf vrf1
      redistribute connected
     exit-address-family
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    ip pim ssm default
    ip pim mpls source Loopback0
    ip pim vrf vrf1 ssm default
    ip pim vrf vrf1 mpls source Loopback0
    ip route 192.0.2.25 255.255.255.255 7.37.0.1
    !
    !
    mpls ldp router-id Loopback0 force
    !
    !
    .
    .
    .
    !
    !
    end

    Feature Information for MLDP In-Band Signaling/Transit Mode

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for MLDP In-Band Signaling/Transit Mode

    Feature Name

    Releases

    Feature Information

    MLDP In-Band Signaling/Transit Mode

    15.3(1)S

    Cisco IOS XE 3.8S

    Multicast Label Distribution Protocol (MLDP) in-band signaling supports point-to-multipoint (P2P) and multipoint-to-multipoint (MP2MP) Label Switched Paths (LSPs) and enables the MLDP core to create (S,G) or (*,G) state without using out-of-band signaling such as Border Gateway Protocol (BGP) or Protocol Independent Multicast (PIM). This feature is supported for IPv4 and IPv6 multicast groups.

    The following commands were introduced or modified: ip multicast mpls mldp, ipv6 multicast mpls mldp.