IP Addressing: DHCP Configuration Guide, Cisco IOS XE Release 3S (Cisco ASR 1000)
Configuring the Cisco IOS XE DHCP Client
Downloads: This chapterpdf (PDF - 137.0KB) The complete bookPDF (PDF - 1.54MB) | The complete bookePub (ePub - 1.26MB) | Feedback

Configuring the Cisco IOS XE DHCP Client

Configuring the Cisco IOS XE DHCP Client

Last Updated: December 13, 2012

Cisco IOS XE Dynamic Host Configuration Protocol (DHCP) client software provides the flexibility to include various configuration options for the DHCP client. A DHCP client is defined as an Internet host using DHCP to obtain configuration parameters such as an IP address. This module describes the concepts and tasks needed to configure the Cisco IOS XE DHCP client.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Information About the DHCP Client

DHCP Client Operation

DHCP provides a framework for passing configuration information to hosts on a TCP/IP network. A DHCP client is an Internet host using DHCP to obtain configuration parameters such as an IP address. The figure below shows the basic steps that occur when a DHCP client requests an IP address from a DHCP server. The client, Host A, sends a DHCPDISCOVER broadcast message to locate a DHCP server. A DHCP server offers configuration parameters (such as an IP address, a MAC address, a domain name, and a lease for the IP address) to the client in a DHCPOFFER unicast message.

Figure 1 DHCP Request for an IP Address from a DHCP Server


A DHCP client may receive offers from multiple DHCP servers and can accept any one of the offers; however, the client usually accepts the first offer it receives. Additionally, the offer from the DHCP server is not a guarantee that the IP address will be allocated to the client; however, the server usually reserves the address until the client has had a chance to formally request the address.

The client returns a formal request for the offered IP address to the DHCP server in a DHCPREQUEST broadcast message. The DHCP server confirms that the IP address has been allocated to the client by returning a DHCPACK unicast message to the client.

DHCP Client Overview

The configurable DHCP client functionality allows a DHCP client to use a user-specified client identifier, class identifier, or suggested lease time when requesting an address from a DHCP server.

Configuration parameters and other control information are carried in tagged data items that are stored in the options field of the DHCP message. The DHCP client provides flexibility by allowing the following options to be configured for a DHCP client:

  • Option 12--This option specifies the name of the client. The name may or may not be qualified with the local domain.
  • Option 51--This option is used in a client request (DHCPDISCOVER or DHCPREQUEST) to allow the client to request a lease time for the IP address.
  • Option 55--This option allows the DHCP client to request certain options from the DHCP server. The ip dhcp client request command allows the system administrator to turn off some of the requested options, thus removing them from the request list.
  • Option 60--This option allows the user to configure the vendor class identifier string to use in the DHCP interaction.
  • Option 61--This option is used by DHCP clients to specify their unique identifier. DHCP servers use this value to index their database of address bindings. This value is expected to be unique for all clients in an administrative domain.

How to Configure the DHCP Client

Configuring the DHCP Client

Perform this task to configure the DHCP client.

Cisco routers running Cisco IOS XE software include DHCP server and relay agent software, which are enabled by default. Your router can act as both the DHCP client and DHCP server. Use the ip address dhcp interface command to obtain IP address information for the configured interface.

Before You Begin

You must configure the ip dhcp client commands before entering the ip address dhcp command on an interface to ensure that the DHCPDISCOVER messages that are generated contain the correct option values. The ip dhcp client commands are checked only when an IP address is acquired from DHCP. If any of the ip dhcp client commands are entered after an IP address has been acquired from DHCP, it will not take effect until the next time the router acquires an IP address from DHCP. This means that the new configuration will only take effect after the ip address dhcp command commandhas been configured.


SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    ip dhcp client client-id {interface-name| ascii string| hex string}

5.    ip dhcp client class-id {string| hex string}

6.    ip dhcp client lease days [hours][minutes]

7.    ip dhcp client hostname host-name

8.    [no] ip dhcp client request option-name

9.    ip address dhcp

10.    exit

11.    ip dhcp compatibility lease-query client {cisco | standard}


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface GigabitEthernet 0/0/1

 

Configures an interface type and enters interface configuration mode.

 
Step 4
ip dhcp client client-id {interface-name| ascii string| hex string}


Example:

Router(config-if)# ip dhcp client client-id ascii mytest1

 

(Optional) Specifies the client identifier.

  • When you specify the no form of this command, the configuration is removed and the system returns to using the default form. It is not possible to configure the system to not include a client identifier.
 
Step 5
ip dhcp client class-id {string| hex string}


Example:

Router(config-if)# ip dhcp client class-id my-class-id

 

(Optional) Specifies the class identifier.

 
Step 6
ip dhcp client lease days [hours][minutes]


Example:

Router(config-if)# ip dhcp client lease 2

 

(Optional) Configures the duration of the lease for an IP address that is requested from a DHCP client to a DHCP server.

 
Step 7
ip dhcp client hostname host-name


Example:

Router(config-if)# ip dhcp client hostname router1

 

(Optional) Specifies or modifies the host name sent in the DHCP message.

 
Step 8
[no] ip dhcp client request option-name

Example:

Router(config-if)# no ip dhcp client request tftp-server-address

 

(Optional) Configures a DHCP client to request an option from a DHCP server.

  • The option name can be tftp-server-address, netbios-nameserver, vendor-specific, static-route, domain-name, dns-nameserver, or router. By default, all these options are requested. The no form of the command instructs the system to not request certain options.
 
Step 9
ip address dhcp


Example:

Router(config-if)# ip address dhcp

 

Acquires an IP address on an interface from DHCP.

 
Step 10
exit


Example:

Router(config-if)# exit

 

(Optional) Exits interface configuration mode.

 
Step 11
ip dhcp compatibility lease-query client {cisco | standard}


Example:

Router(config)# ip dhcp compatibility lease-query client standard

 

(Optional) Configures a DHCP client to send a lease query according to RFC 4388 standard.

 

Troubleshooting Tips

To verify the configuration, you can use the debug dhcp detail EXEC command to display the DHCP packets that were sent and received. To display the server side of the DHCP interaction, use the debug ip dhcp server packets command.

Configuration Examples for the DHCP Client

Configuring the DHCP Client Example

The figure below shows a simple network diagram of a DHCP client on an Ethernet LAN.

Figure 2 Topology Showing DHCP Client with GigabitEthernet Interface


On the DHCP server, the configuration is as follows:

ip dhcp pool 1
 network 10.1.1.0 255.255.255.0
 lease 1 6 

On the DHCP client, the configuration is as follows on interface GigabitEthernet 0/0/0:

interface GigabitEthernet 0/0/0
 ip address dhcp

This configuration allows the DHCP client to acquire an IP address from the DHCP server through GigabitEthernet interface 0/0/0.

Customizing the DHCP Client Configuration Example

The following example shows how to customize the DHCP client configuration with various options on GigabitEthernet interface 0/0/1:

interface GigabitEthernet 0/0/1
 ip dhcp client client-id ascii my-test1
 ip dhcp client class-id my-class-id
 ip dhcp client lease 0 1 0
 ip dhcp client hostname sanfran
 no ip dhcp client request tftp-server-address
 ip address dhcp

Additional References

The following sections provide references related to the DHCP client.

Related Documents

Related Topic

Document Title

DHCP commands: complete command syntax, command modes, command history, defaults, usage guidelines, and examples.

Cisco IOS IP Addressing Services Command Reference

DHCP conceptual information

"DHCP Overview" module

DHCP server configuration

"Configuring the Cisco IOS XE DHCP Server" module

DHCP server on-demand address pools

"Configuring the DHCP Server On-Demand Address Pool Manager" module

DHCP relay agent configuration

"Configuring the Cisco IOS XE DHCP Relay Agent" module

DHCP advanced features

"Configuring DHCP Services for Accounting and Security" module

Standards

Standards

Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

--

MIBs

MIBs

MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS XE software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFCs

Title

RFC 2131

Dynamic Host Configuration Protocol

RFC 2132

DHCP Options and BOOTP Vendor Extensions

Technical Assistance

Description

Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport

Feature Information for the Cisco IOS XE DHCP Client

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for the Cisco IOS XE DHCP Client

Feature Name

Releases

Feature Configuration Information

DHCP Client

Cisco IOS XE Release 2.3

A DHCP client is defined as an Internet host using DHCP to obtain configuration parameters such as an IP address.

The following command was introduced by this feature: ip address dhcp

Configurable DHCP Client

Cisco IOS XE Release 2.3

The configurable DHCP client functionality allows a DHCP client to use a user-specified client identifier, class identifier, or suggested lease time when requesting an address from a DHCP server.

The following commands were introduced by this feature: ip dhcp client class-id, ip dhcp client client-id, ip dhcp client hostname, ip dhcp client lease, ip dhcp client request

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.