Guest

Support

IP over IPv6 Tunnels

Hierarchical Navigation

  • Viewing Options

  • PDF (1.2 MB)
  • Feedback
IP over IPv6 Tunnels

IP over IPv6 Tunnels

IPv6 supports IP over IPv6 tunnels, which includes the following:

  • Generic routing encapsulation (GRE) IPv4 tunnel support for IPv6 traffic—IPv6 traffic can be carried over IPv4 GRE tunnels using the standard GRE tunneling technique that is designed to provide the services to implement any standard point-to-point encapsulation scheme. The primary use of GRE tunnels is for stable connections that require regular secure communication between two edge devices or between an edge device and an end system. The edge devices and the end systems must be dual-stack implementations.
  • GRE support over IPv6 transport—GRE has a protocol field that identifies the passenger protocol. GRE tunnels allow Intermediate System-to-Intermediate System (IS-IS) or IPv6 to be specified as a passenger protocol, which allows both IS-IS and IPv6 traffic to run over the same tunnel.
  • VRF-aware IPv4/IPv6 over IPv6 tunnels - Virtual Routing and Forwarding (VRF)-aware tunnels are used to connect customer networks separated by untrusted core networks or core networks with different infrastructures (IPv4 or IPv6).

Information About IP over IPv6 Tunnels

GRE IPv4 Tunnel Support for IPv6 Traffic

IPv6 traffic can be carried over IPv4 GRE tunnels using the standard GRE tunneling technique that is designed to provide the services to implement any standard point-to-point encapsulation scheme. As in IPv6 manually configured tunnels, GRE tunnels are links between two points, with a separate tunnel for each link. The tunnels are not tied to a specific passenger or transport protocol but, in this case, carry IPv6 as the passenger protocol with the GRE as the carrier protocol and IPv4 or IPv6 as the transport protocol.

The primary use of GRE tunnels is for stable connections that require regular secure communication between two edge devices or between an edge device and an end system. The edge devices and the end systems must be dual-stack implementations.

GRE Support over IPv6 Transport

GRE has a protocol field that identifies the passenger protocol. GRE tunnels allow Intermediate System-to-Intermediate System (IS-IS) or IPv6 to be specified as a passenger protocol, which allows both IS-IS and IPv6 traffic to run over the same tunnel. If GRE did not have a protocol field, it would be impossible to distinguish whether the tunnel was carrying IS-IS or IPv6 packets. The GRE protocol field makes it desirable to tunnel IS-IS and IPv6 inside GRE.

How to Configure IP over IPv6 Tunnels

The following tasks describe how to configure an IPv6 tunnel. IPv6 or IPv4 packets can be forwarded on this tunnel.

Configuring GRE IPv6 Tunnels

Perform this task to configure a GRE tunnel on an IPv6 network. GRE tunnels can be configured to run over an IPv6 network layer and transport IPv6 and IPv4 packets through IPv6 tunnels.

Before You Begin

When GRE IPv6 tunnels are configured, IPv6 addresses are assigned to the tunnel source and the tunnel destination. The tunnel interface can have either IPv4 or IPv6 addresses (this is not shown in the task below). The host or device at each end of the configured tunnel must support both IPv4 and IPv6 protocol stacks.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    tunnel source {ipv6-address | interface-type interface-number}

    5.    tunnel destination ipv6-address

    6.    tunnel mode gre ipv6

    7.    end


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface tunnel tunnel-number


    Example:
    Device(config)# interface tunnel 0
     

    Specifies a tunnel interface and number and enters interface configuration mode.

     
    Step 4 tunnel source {ipv6-address | interface-type interface-number}


    Example:
    Device(config-if)# tunnel source ethernet 0
     

    Specifies the source IPv6 address or the source interface type and number for the tunnel interface.

    • If an interface type and number are specified, the interface must be configured with an IPv6 address.
    Note   

    Only the syntax used in this context is displayed. For more details, see the IPv6 Command Reference.

     
    Step 5 tunnel destination ipv6-address


    Example:
    Device(config-if)# tunnel destination 2001:0DB8:0C18:2::300
     

    Specifies the destination IPv6 address for the tunnel interface.

    Note   

    Only the syntax used in this context is displayed. For more details, see the IPv6 Command Reference.

     
    Step 6 tunnel mode gre ipv6


    Example:
    Device(config-if)# tunnel mode gre ipv6
     

    Specifies a GRE IPv6 tunnel.

    Note   

    The tunnel mode gre ipv6 command specifies GRE as the encapsulation protocol for the tunnel interface. Only the syntax used in this context is displayed. For more details, see the IPv6 Command Reference.

     
    Step 7 end


    Example:
    Device(config-if)# end
     

    Exits interface configuration mode and returns to privileged EXEC mode.

     

    Configuration Examples for IP over IPv6 Tunnels

    Example: IPv6 over IPv6 Tunnel

    Example: Configuring CE1

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:1::1/64
     no shutdown
     exit
    !
    
    ipv6 route 2001:DB8:2:5::/64 2001:DB8:2:1::2
    ipv6 route 2001:DB8:2:9::/64 2001:DB8:2:1::2
    !
    		

    Example: Configuring PE1

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ipv6 address
     ipv6 address 2001:DB8:2:9::1/64
     tunnel source 2001:DB8:2:2::1
     tunnel mode ipv6
     tunnel destination 2001:DB8:2:4::2
     exit
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:1::2/64
     no shutdown
     exit
    !
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::1/64
     no shutdown
     exit
    !
    
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:2::2
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:2::2
    ipv6 route 2001:DB8:2:5::/64 Tunnel0 2001:DB8:2:9::2
    
    		

    Example: Configuring PE2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ipv6 address
     ipv6 address 2001:DB8:2:9::2/64
     tunnel source 2001:DB8:2:4::2
     tunnel mode ipv6
     tunnel destination 2001:DB8:2:2::1
     exit
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:5::1/64
     no shutdown
     exit
    !
    interface Ethernet0/1
     no ipv6 address
     ipv6 address 2001:DB8:2:4::2/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:4::1
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:4::1
    ipv6 route 2001:DB8:2:1::/64 Tunnel0 2001:DB8:2:9::1
    
    		

    Example: Configuring CE2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:5::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:1::/64 2001:DB8:2:5::1
    ipv6 route 2001:DB8:2:9::/64 2001:DB8:2:5::1
    !
    
    

    Example: Configuring Core Device 1

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet1/0
     no ipv6 address
     no shutdown
     ipv6 address 2001:DB8:2:3::1/64
     exit
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:3::2
    
    

    Example: Configuring Core Device 2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/1
     no ip address
     ipv6 address 2001:DB8:2:4::1/64
     no shutdown
     exit
    !
    interface Ethernet1/0
     no ip address
     ipv6 address 2001:DB8:2:3::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:3::1
    
    
    

    Example: IPv4 over IPv6 Tunnel

    Example: Configuring CE1

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.1.1 255.255.255.0
     no shutdown
     exit
    !
    ip route 192.168.5.0 255.255.255.0 192.168.1.2
    ip route 192.168.9.0 255.255.255.0 192.168.1.2
    !
    		

    Example: Configuring PE1

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ip address
     ip address 192.168.9.1 255.255.255.0
     tunnel source 2001:DB8:2:2::1
     tunnel destination 2001:DB8:2:4::2
     tunnel mode ipv6
     exit
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.1.2 255.255.255.0
     no shutdown
     exit
    !
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::1/64
     no shutdown
     exit
    !
    
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:2::2
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:2::2
    ip route 192.168.5.0 255.255.255.0 Tunnel 0 192.168.9.2
    
    		

    Example: Configuring PE2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ip address
     ip address 192.168.9.2 255.255.255.0
     tunnel source 2001:DB8:2:4::2
     tunnel destination 2001:DB8:2:2::1
     tunnel mode ipv6
     exit
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.5.1 255.255.255.0 
     no shutdown
     exit
    !
    interface Ethernet0/1
     no ipv6 address
     ipv6 address 2001:DB8:2:4::2/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:4::1
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:4::1
    ip route 192.168.1.0 255.255.255.0 Tunnel 0 192.168.9.1
    
    		

    Example: Configuring CE2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.5.2 255.255.255.0 
     no shutdown
     exit
    !
    ip route 192.168.1.0 255.255.255.0 192.168.1.2
    ip route 192.168.9.0 255.255.255.0 192.168.1.2
    
    !
    
    

    Example: Configuring Core Device 1

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet1/0
     no ipv6 address
     no shutdown
     ipv6 address 2001:DB8:2:3::1/64
     exit
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:3::2
    
    
    

    Example: Configuring Core Device 2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/1
     no ip address
     ipv6 address 2001:DB8:2:4::1/64
     no shutdown
     exit
    !
    interface Ethernet1/0
     no ip address
     ipv6 address 2001:DB8:2:3::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:3::1
    
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    IPv6 commands

    Cisco IOS IPv6 Command Reference

    IPv6 addressing and connectivity

    IPv6 Configuration Guide

    Cisco IOS IPv6 features

    Cisco IOS IPv6 Feature Mapping

    Standards and RFCs

    Standard/RFC

    Title

    RFCs for IPv6

    IPv6 RFC

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for IP over IPv6 Tunnels

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for IP over IPv6 Tunnels

    Feature Name

    Releases

    Feature Information

    IP over IPv6 Tunnels

    12.2(30)S

    12.2(33)SRA

    12.3(7)T

    12.4

    12.4(2)T

    15.0(1)S

    Cisco IOS XE Release 2.1

    15.1(1)SY

    Cisco IOS XE Release 3.2SE

    IP over IPv6 Tunnels feature is supported.

    The following commands were introduced or modified: tunnel destination, tunnel mode ipv6, tunnel mode gre ipv6, tunnel source.