Interface and Hardware Component Configuration Guide, Cisco IOS XE Release 3S (ASR 1000)
Manually Configured IPv6 over IPv4 Tunnels
Downloads: This chapterpdf (PDF - 1.25MB) The complete bookPDF (PDF - 3.84MB) | The complete bookePub (ePub - 1.16MB) | Feedback

Manually Configured IPv6 over IPv4 Tunnels

Manually Configured IPv6 over IPv4 Tunnels

This feature provides support for manually configured IPv6 over IPv4 tunnels. A manually configured tunnel is equivalent to a permanent link between two IPv6 domains over an IPv4 backbone.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About Manually Configured IPv6 over IPv4 Tunnels

Overlay Tunnels for IPv6

Overlay tunneling encapsulates IPv6 packets in IPv4 packets for delivery across an IPv4 infrastructure (a core network or the figure below). By using overlay tunnels, you can communicate with isolated IPv6 networks without upgrading the IPv4 infrastructure between them. Overlay tunnels can be configured between border devices or between a border device and a host; however, both tunnel endpoints must support both the IPv4 and IPv6 protocol stacks. IPv6 supports the following types of overlay tunneling mechanisms:

  • Manual
  • Generic routing encapsulation (GRE)
  • IPv4-compatible
  • 6to4
  • Intrasite Automatic Tunnel Addressing Protocol (ISATAP)
Figure 1. Overlay Tunnels


Note


Overlay tunnels reduce the maximum transmission unit (MTU) of an interface by 20 octets (assuming that the basic IPv4 packet header does not contain optional fields). A network that uses overlay tunnels is difficult to troubleshoot. Therefore, overlay tunnels that connect isolated IPv6 networks should not be considered a final IPv6 network architecture. The use of overlay tunnels should be considered as a transition technique toward a network that supports both the IPv4 and IPv6 protocol stacks or just the IPv6 protocol stack.


Use the table below to help you determine which type of tunnel that you want to configure to carry IPv6 packets over an IPv4 network.

Table 1 Suggested Usage of Tunnel Types to Carry IPv6 Packets over an IPv4 Network

Tunneling Type

Suggested Usage

Usage Notes

Manual

Simple point-to-point tunnels that can be used within a site or between sites.

Can carry IPv6 packets only.

GRE- and IPv4- compatible

Simple point-to-point tunnels that can be used within a site or between sites.

Can carry IPv6, Connectionless Network Service (CLNS), and many other types of packets.

IPv4- compatible

Point-to-multipoint tunnels.

Uses the ::/96 prefix. We do not recommend using this tunnel type.

6to4

Point-to-multipoint tunnels that can be used to connect isolated IPv6 sites.

Sites use addresses from the 2002::/16 prefix.

6RD

IPv6 service is provided to customers over an IPv4 network by using encapsulation of IPv6 in IPv4.

Prefixes can be from the SP’s own address block.

ISATAP

Point-to-multipoint tunnels that can be used to connect systems within a site.

Sites can use any IPv6 unicast addresses.

Individual tunnel types are discussed in detail in this document. We recommend that you review and understand the information about the specific tunnel type that you want to implement. When you are familiar with the type of tunnel you need, see the table below for a summary of the tunnel configuration parameters that you may find useful.

Table 2 Tunnel Configuration Parameters by Tunneling Type

Tunneling Type

Tunnel Configuration Parameter

Tunnel Mode

Tunnel Source

Tunnel Destination

Interface Prefix or Address

Manual

ipv6ip

An IPv4 address, or a reference to an interface on which IPv4 is configured.

An IPv4 address.

An IPv6 address.

GRE/IPv4

gre ip

An IPv4 address.

An IPv6 address.

IPv4- compatible

ipv6ip auto-tunnel

Not required. These are all point-to-multipoint tunneling types. The IPv4 destination address is calculated, on a per-packet basis, from the IPv6 destination.

Not required. The interface address is generated as ::tunnel-source/96.

6to4

ipv6ip 6to4

An IPv6 address. The prefix must embed the tunnel source IPv4 address.

6RD

ipv6ip 6rd

An IPv6 address.

ISATAP

ipv6ip isatap

An IPv6 prefix in modified eui-64 format. The IPv6 address is generated from the prefix and the tunnel source IPv4 address.

IPv6 Manually Configured Tunnels

A manually configured tunnel is equivalent to a permanent link between two IPv6 domains over an IPv4 backbone. The primary use is for stable connections that require regular secure communication between two edge devices or between an end system and an edge device, or for connection to remote IPv6 networks.

An IPv6 address is manually configured on a tunnel interface, and manually configured IPv4 addresses are assigned to the tunnel source and the tunnel destination. The host or device at each end of a configured tunnel must support both the IPv4 and IPv6 protocol stacks. Manually configured tunnels can be configured between border devices or between a border device and a host. Cisco Express Forwarding switching can be used for IPv6 manually configured tunnels, or Cisco Express Forwarding switching can be disabled if process switching is needed.

How to Enable Manually Configured IPv6 over IPv4 Tunnels

Configuring Manual IPv6 Tunnels

Before You Begin

With manually configured IPv6 tunnels, an IPv6 address is configured on a tunnel interface, and manually configured IPv4 addresses are assigned to the tunnel source and the tunnel destination. The host or device at each end of a configured tunnel must support both the IPv4 and IPv6 protocol stacks.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    Enter one of the following commands:

    • ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}
    • ipv6 address ipv6-prefix/prefix-length [eui-64]

    5.    tunnel source {ip-address | interface-type interface-number}

    6.    tunnel destination ip-address

    7.    tunnel mode ipv6ip

    8.    end


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface tunnel tunnel-number


    Example:
    Device(config)# interface tunnel 0
     

    Specifies a tunnel interface and number, and enters interface configuration mode.

     
    Step 4 Enter one of the following commands:
    • ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}
    • ipv6 address ipv6-prefix/prefix-length [eui-64]


    Example:
    Device(config-if)# ipv6 address 3ffe:b00:c18:1::3/127
     
    Specifies the IPv6 network assigned to the interface and enables IPv6 processing on the interface.
    • If you specify the eui-64 keyword, the software configures an IPv6 address for an interface and enables IPv6 processing on the interface using an EUI-64 interface ID in the low-order 64 bits of the address.
    Note   

    See the “Implementing IPv6 Addressing and Basic Connectivity” module for more information on configuring IPv6 addresses.

     
    Step 5 tunnel source {ip-address | interface-type interface-number}


    Example:
    Device(config-if)# tunnel source gigabitethernet 0/0/0
     

    Specifies the source IPv4 address or the source interface type and number for the tunnel interface.

    • If an interface is specified, the interface must be configured with an IPv4 address.
     
    Step 6 tunnel destination ip-address


    Example:
    Device(config-if)# tunnel destination 192.168.30.1
     

    Specifies the destination IPv4 address or hostname for the tunnel interface.

     
    Step 7 tunnel mode ipv6ip


    Example:
    Device(config-if)# tunnel mode ipv6ip
     

    Specifies a manual IPv6 tunnel.

    Note   

    The tunnel mode ipv6ip command specifies IPv6 as the passenger protocol and IPv4 as both the encapsulation and transport protocol for the manual IPv6 tunnel.

     
    Step 8 end


    Example:
    Device(config-if)# end
     

    Returns to privileged EXEC mode.

     

    Configuration Examples for Manually Configured IPv6 over IPv4 Tunnels

    Example: Configuring Manual IPv6 Tunnels

    The following example configures a manual IPv6 tunnel between router A and router B. In the example, tunnel interface 0 for both router A and router B is manually configured with a global IPv6 address. The tunnel source and destination addresses are also manually configured.

    Router A Configuration

    interface gigabitethernet 0/0/0
     ip address 192.168.99.1 255.255.255.0
    interface tunnel 0
     ipv6 address 3ffe:b00:c18:1::3/127
     tunnel source gigabitethernet 0/0/0
     tunnel destination 2001:DB8:1111:2222::1/64
     tunnel mode ipv6ip

    Router B Configuration

    interface gigabitethernet 0/0/0
     ip address 192.168.30.1 255.255.255.0
    interface tunnel 0
     ipv6 address 3ffe:b00:c18:1::2/127
     tunnel source gigabitethernet 0/0/0
     tunnel destination 2001:DB8:1111:2222::2/64
     tunnel mode ipv6ip

    Example: IPv6 over GRE IPv4 Tunnel

    Example: Configuring CE1

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ip address
     ipv6 address 2001:DB8:2:1::1/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:1::2
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:1::2
    !
    

    Example: Configuring PE1

    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ip address
     ipv6 address 2001:DB8:2:4::1/64
     tunnel source 10.22.22.22
     tunnel destination 10.44.44.44
     exit
    !
    interface Ethernet0/0
     no ip address
     ipv6 address 2001:DB8:2:1::2/64
     no shutdown
     exit
    !
    interface Ethernet1/1
     no ip address
     ip address 10.22.22.22 255.255.255.0
     no shutdown
     exit
    !
    ip route 10.44.44.0 255.255.255.0 10.22.22.23
    ipv6 route 2001:DB8:2:2::/64 Tunnel0 2001:DB8:2:4::2
    
    

    Example: Configuring PE2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ipv6 address
     ipv6 address 2001:DB8:2:4::2/64
     tunnel source 10.44.44.44
     tunnel destination 10.22.22.22
     exit
    !
    interface Ethernet0/0 no ipv6 address
     ipv6 address 2001:DB8:2:2::1/64
     no shutdown
     exit
    !
    interface Ethernet1/0
     no ip address
     ip address 10.44.44.44 255.255.255.0
     no shutdown
     exit
    !
    ip route 10.22.22.0 255.255.255.0 10.44.44.43
    !
    ipv6 route 2001:DB8:2:1::/64 Tunnel0 2001:DB8:2:4::1
    !
    
    

    Example: Configuring CE2

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:2::2/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:1::/64 2001:DB8:2:2::1
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:2::1
    !
    
    

    Example: Configuring Device X

    !
    interface Ethernet1/0
     no ip address
     ip address 10.44.44.43 255.255.255.0
     no shutdown
     exit
    !
    interface Ethernet1/1
     no ip address
     ip address 10.22.22.23 255.255.255.0
     no shutdown
     exit
    !
    
    
    

    Example: Verifying the Tunnel Configuration

    From CE1

    Device# ping ipv6 2001:db8:2:2::2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2001:DB8:2:2::2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/43 ms
    
    Device# ping ipv6 2001:db8:2:2::2 source 2001:db8:2:1::1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2001:DB8:2:2::2, timeout is 2 seconds:
    Packet sent with a source address of 2001:DB8:2:1::1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    
    

    From PE1

    Device# show tunnel interface
    
    Tunnel0
       Mode:GRE/IP, Destination 10.44.44.44, Source 10.22.22.22
       IP transport: output interface Ethernet1/1 next hop 10.22.22.23
       Application ID 1: unspecified
       Linestate - current up
       Internal linestate - current up, evaluated up
       Tunnel Source Flags: Local
       Transport IPv4 Header DF bit cleared
       OCE: IP tunnel decap
       Provider: interface Tu0, prot 47
         Performs protocol check [47]
         Protocol Handler: GRE: opt 0x0
           ptype: ipv4 [ipv4 dispatcher: punt]
           ptype: ipv6 [ipv6 dispatcher: from if Tu0]
           ptype: mpls [mpls dispatcher: drop]
           ptype: otv [mpls dispatcher: drop]
           ptype: generic [mpls dispatcher: drop]
    There are 0 tunnels running over the EON IP protocol
    There are 0 tunnels running over the IPinIP protocol
    There are 0 tunnels running over the NOSIP protocol
    There are 0 tunnels running over the IPv6inIP protocol
    There are 0 tunnels running over the RBSCP/IP protocol
    
    Device# show ip route 10.44.44.44
    
    Routing entry for 10.44.44.0/24
      Known via "static", distance 1, metric 0
      Routing Descriptor Blocks:
      * 10.22.22.23
          Route metric is 0, traffic share count is 1
    
    Device# debug ipv6 icmp
    
      ICMP Packet debugging is on
    *Jan  1 10:57:37.882: ICMPv6: Sent R-Advert, Src=FE80::A8BB:CCFF:FE00:5200, Dst=FF02::1
    *Jan  1 11:00:18.634: ICMPv6: Received R-Advert, Src=FE80::A8BB:CCFF:FE00:5200,Dst=FF02::1
    
    
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    IPv6 addressing and connectivity

    IPv6 Configuration Guide

    Cisco IOS commands

    Cisco IOS Master Commands List, All Releases

    IPv6 commands

    Cisco IOS IPv6 Command Reference

    Cisco IOS IPv6 features

    Cisco IOS IPv6 Feature Mapping

    Standards and RFCs

    Standard/RFC

    Title

    RFCs for IPv6

    IPv6 RFCs

    MIBs

    MIB

    MIBs Link

    To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

    http:/​/​www.cisco.com/​go/​mibs

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for Manually Configured IPv6 over IPv4 Tunnels

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 3 Feature Information for Manually Configured IPv6 over IPv4 Tunnels

    Feature Name

    Releases

    Feature Information

    IPv6 Tunneling: Manually Configured IPv6 over IPv4 Tunnels

    Cisco IOS XE Release 2.1

    A manually configured tunnel is equivalent to a permanent link between two IPv6 domains over an IPv4 backbone.

    The following commands were introduced or modified: tunnel destination, tunnel ipv6ip, tunnel source.