Broadband Access Aggregation and DSL Configuration Guide, Cisco IOS XE Release 3S
Controlling Subscriber Bandwidth
Downloads: This chapterpdf (PDF - 1.36MB) The complete bookPDF (PDF - 5.18MB) | The complete bookePub (ePub - 1.08MB) | Feedback

Controlling Subscriber Bandwidth

Contents

Controlling Subscriber Bandwidth

The Dynamic Subscriber Bandwidth Selection (DBS) feature enables wholesale service providers to sell different classes of service to retail service providers by controlling bandwidth at the ATM virtual circuit (VC) level. ATM quality of service (QoS) parameters from the subscriber domain are applied to the ATM PVC on which a PPP over Ethernet (PPPoE) or PPP over ATM (PPPoA) session is established.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Controlling Subscriber Bandwidth

A Cisco ASR 1000 series router must have the following shared port adapters (SPAs) installed to enable DBS:

  • SPA-3XOC3-ATM-V2
  • SPA-1XOC3-ATM-V2
  • SPA-1XOC12-ATM-V2

Restrictions for Controlling Subscriber Bandwidth

The DBS feature does not support the following:

  • Switched virtual circuits (SVC)
  • ATM port adapters installed in a Cisco ASR 1000 series router
  • When changing QoS values dynamically on a VC, there can be some duration (in milliseconds) during which traffic on the VC is dropped.

Information About Controlling Subscriber Bandwidth

Traffic-Shaping Parameters

Using DBS you can set the ATM permanent virtual circuit (PVC) traffic-shaping parameters to be dynamically changed based on the RADIUS profile of a PPPoE or PPPoA user logging in on the PVC. If the user is the first user on a given PVC, the RADIUS profile values override the default values of the PVC. If users already exist on the PVC, the new value overrides the existing configuration only if it is higher than the existing value. If multiple PPPoE sessions are allowed on a subscriber VC, the highest peak cell rate (PCR) and sustainable cell rate (SCR) of all the sessions are selected as the PCR and SCR, respectively, of the VC.

You can apply DBS QoS parameters per user as well as per domain. If you apply DBS QoS parameters under a domain profile, all users in that profile are assigned the same DBS QoS parameters. These parameters are assigned to the RADIUS profile for that domain. You can also apply distinctive DBS QoS parameters via the RADIUS user profile.

Traffic-shaping parameters can be locally configured by Cisco IOS command-line interface (CLI) in VC-mode, VC-class, range mode, or PVC-in-range mode. These parameters have a lower priority and are overridden by the shaping parameters specified in the domain service profile. Traffic-shaping parameters that are CLI-configured at the VC class interface or subinterface level are treated as the default QoS parameters for the PVCs to which they apply. These parameters are overridden by the domain service profile QoS parameters of the domain the user is logged in to. If no VC class is configured, the default is the unspecified bit rate (UBR).

When a network access server (NAS) sends a domain authorization request and receives an affirmative response from the RADIUS server, this response may include a "QoS-management" string via vendor-specific attribute (VSA) 26 for QoS management in the NAS. The QoS management values are configured as part of the domain service profile attributes on the RADIUS server. These values contain PCR and SCR values for a particular user or domain. If the QoS specified for a domain or user cannot be applied on the PVC to which the session belongs, the session is not established.

Changing PVC traffic parameters because of new simultaneous PPPoE sessions on the PVC does not cause existing PPPoE sessions that are already established to disconnect. Changing domain service profile QoS parameters on the RADIUS server does not cause traffic parameters to automatically change for PVCs that have existing sessions.

When you enter the dbs enable or no dbs enable command to configure or unconfigure DBS, existing sessions are not disconnected. If you have a session that has been configured for DBS and you configure the no dbs enable command on a VC, additional sessions that are configured will display DBS-configured QoS values until the first new session is up. After the first session is brought up, the VC has default and locally configured values. If you configure the dbs enable command after multiple sessions are already up on the VC, all sessions on that VC have DBS QoS parameters.

Benefits of Controlling Subscriber Bandwidth

DBS provides the following benefits:

  • Wholesale service providers can provide different bandwidth options to their retail service provider customers, such as ISPs and enterprises.
  • Subscribers can choose between enhanced and basic service, with a fixed billing plan for each service.

How to Control Subscriber Bandwidth

Configuring DBS Under a VC Class

Perform the following task to configure DBS under a VC class.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    vc-class atm vc-class-name

    4.    dbs enable


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 vc-class atm vc-class-name


    Example:
    Router(config)# vc-class atm class1
     

    Creates an ATM VC class and enters ATM VC class configuration mode.

    • A VC class can be applied to an ATM interface, subinterface, or VC.
     
    Step 4 dbs enable


    Example:
    Router(config-vc-class)# dbs enable
     

    Applies DBS QoS parameters.

     

    Configuring DBS on a PVC

    Perform the following task to configure DBS for a PVC.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface atm number [point-to-point | multipoint]

      4.    pvc [name] vpi /vci

      5.    dbs enable

      6.    protocol pppoe


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface atm number [point-to-point | multipoint]


      Example:
      Router(config)# interface atm 5/0.1 multipoint
       

      Specifies an ATM interface or subinterface and enters interface configuration mode.

       
      Step 4 pvc [name] vpi /vci


      Example:
      Router(config-if)# pvc 2/101
       

      Specifies an ATM PVC and creates or assigns a name to an ATM PVC, and enters interface-ATM-VC configuration mode.

      Note   

      The arguments vpi and vci cannot both be set to 0; if one is 0, the other cannot be 0.

       
      Step 5 dbs enable


      Example:
      Router(config-if-atm-vc)# dbs enable
       

      Applies DBS QoS parameters.

       
      Step 6 protocol pppoe


      Example:
      Router(config-if-atm-vc)# protocol pppoe
       

      Specifies PPPoE as the protocol of the ATM PVC.

       

      Configuring DBS on a Range of PVCs

      Perform this task to configure DBS for a range of PVCs.

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    interface atm number [point-to-point | multipoint]

        4.    range[range-name] pvc start-vpi / start-vci end-vpi /end-vci

        5.    dbs enable


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Router# configure terminal
         

        Enters global configuration mode.

         
        Step 3 interface atm number [point-to-point | multipoint]


        Example:
        Router(config)# interface atm 5/0.1 multipoint
         

        Specifies an ATM interface or subinterface and enters interface configuration mode.

         
        Step 4 range[range-name] pvc start-vpi / start-vci end-vpi /end-vci


        Example:
        Router(config-subif)# range pvc 0/101 0/500 class-range pppoe
         

        Defines a range of ATM PVCs and enables PVC range configuration mode.

         
        Step 5 dbs enable


        Example:
        Router(config-if-atm-vc)# dbs enable
         

        Applies DBS QoS parameters.

         

        Configuring DBS on a PVC Within a PVC Range

        Perform this task to configure DBS for a specific PVC within a range of PVCs.

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    interface atm number [point-to-point | multipoint]

          4.    range [range-name] pvc start-vpi / start-vci end-vpi / end-vci

          5.    in-range [pvc-name] [[vpi /]vci]

          6.    dbs enable


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Router> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Router# configure terminal
           

          Enters global configuration mode.

           
          Step 3 interface atm number [point-to-point | multipoint]


          Example:
          Router(config)# interface atm 5/0.1 multipoint
           

          Specifies an ATM interface or subinterface and enters interface configuration mode.

           
          Step 4 range [range-name] pvc start-vpi / start-vci end-vpi / end-vci


          Example:
          Router(config-subif)# range pvc 0/101 0/500 class-range pppoe
           

          Defines a range of ATM PVCs and enables PVC range configuration mode.

           
          Step 5 in-range [pvc-name] [[vpi /]vci]


          Example:
          Router(config-if-atm-range)# pvc-in-range pvc1 3/104
           

          Defines an individual PVC within a PVC range and enables PVC-in-range configuration mode.

           
          Step 6 dbs enable


          Example:
          Router(config-if-atm-range-pvc)# dbs enable
           

          Applies DBS QoS parameters.

           

          Configuring the RADIUS Attributes for DBS

          You can apply DBS QoS parameters per user as well as per domain. If you apply DBS QoS parameters under a domain profile, all users in that profile are assigned the same DBS QoS parameters. These parameters are assigned to the RADIUS profile for that domain. You can also apply distinctive DBS QoS parameters via the RADIUS user profile.

          Configure the RADIUS attributes listed in this section in the user or domain profiles on the authentication, authorization, and accounting (AAA) server. The user or domain profile is downloaded from the AAA server as part of user authentication.

          The QoS management string for DBS has the following syntax:

          Cisco-Avpair = atm:peak-cell-rate=155000
          Cisco-Avpair = atm:sustainable-cell-rate=155000
          

          You must configure the PCR. Configuring the SCR is optional. If you configure only the PCR, the ATM service type is an unspecified bit rate (UBR). If you specify both the SCR and the PCR, the ATM service type is a variable bit rate nonreal-time (VBR-nrt) connection.

          If the peak rate is greater than the maximum rate permitted on the ATM physical interface, the PCR applied on the ATM PVC is set to the maximum rate. If the specified PCR is less than the minimum rate, then the PCR applied on the ATM PVC is the minimum rate.

          If the sustainable-cell-rate (in Kbps) applied exceeds the maximum for the interface, the session is rejected.


          Note


          DBS cannot change service categories such as from UBR to VBR-nrt. For details, see the table in Configuring Dynamic Suscriber Services .


          Verifying DBS


          Note


          The configuration examples in this section explain the PPPOE termination using a VPDN group.


          SUMMARY STEPS

            1.    Enter the show atm pvc vpi / vcicommand to view details about ATM PVCs or VCs:

            2.    Enter the show atm pvc dbscommand to display information about ATM PVCs that have DBS QoS parameters applied:

            3.    Enter the show running-config command to verify that DBS QoS parameters have been applied. If you enter the dbs enable or the no dbs enablecommand, it appears in the output of the show running-config command. If you enter the default dbs enablecommand, it does not appear.


          DETAILED STEPS
            Step 1   Enter the show atm pvc vpi / vcicommand to view details about ATM PVCs or VCs:

            Example:
            Router# show atm pvc 0/75
            ATM1/0.4:VCD:1, VPI:0, VCI:75
            UBR, PeakRate:149760
            AAL5-LLC/SNAP, etype:0x0, Flags:0xC20, VCmode:0x0
            OAM frequency:0 second(s), OAM retry frequency:1 second(s)
            OAM up retry count:3, OAM down retry count:5
            OAM Loopback status:OAM Disabled
            OAM VC state:Not Managed
            ILMI VC state:Not Managed
            PA TxRingLimit:40 particles
            PA Rx Limit:1600 particles
            InARP frequency:15 minutes(s)
            Transmit priority 4
            InPkts:18, OutPkts:21, InBytes:1263, OutBytes:1476
            InPRoc:18, OutPRoc:3
            InFast:0, OutFast:0, InAS:0, OutAS:0
            InPktDrops:0, OutPktDrops:0/0/0 (holdq/outputq/total)
            CrcErrors:0, SarTimeOuts:0, OverSizedSDUs:0, LengthViolation:0,
            CPIErrors:0
            Out CLP=1 Pkts:0
            OAM cells received:0
            F5 InEndloop:0, F5 InSegloop:0, F5 InAIS:0, F5 InRDI:0
            F4 InEndloop:0, F4 InSegloop:0, F4 InAIS:0, F4 InRDI:0
            OAM cells sent:0
            F5 OutEndloop:0, F5 OutSegloop:0, F5 OutRDI:0
            F4 OutEndloop:0, F4 OutSegloop:0, F4 OutRDI:0
            OAM cell drops:0
            Status:UP
            PPPOE enabled.
            DBS enabled.
            
            Step 2   Enter the show atm pvc dbscommand to display information about ATM PVCs that have DBS QoS parameters applied:

            Example:
            Router# show atm pvc dbs
                        VCD /                                      Peak  Avg/Min Burst
            Interface   Name       VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells
            Sts
            1/0.7      3            0    75   PVC    MUX      VBR    2000    700   94
            UP
            
            Step 3   Enter the show running-config command to verify that DBS QoS parameters have been applied. If you enter the dbs enable or the no dbs enablecommand, it appears in the output of the show running-config command. If you enter the default dbs enablecommand, it does not appear.

            Example:
            Router# show running-config
            Building configuration...
            Current configuration : 2902 bytes
            !
            version 12.2
            no service single-slot-reload-enable
            service timestamps debug uptime
            service timestamps log uptime
            no service password-encryption
            !
            hostname host1
            !
            aaa new-model
            !
            !
            aaa authentication ppp default group radius
            aaa authorization network default group radius 
            aaa session-id common
            !
            username usera password 0 password0
            username lac password 0 password1
            username lns password 0 password2
            username nrp1 password 0 password3
            username user1 password 0 password4
            username nrp1-3 password 0 password5
            username xyz@abc.com password 0 password6
            ip subnet-zero
            !
            !
            ip host dirt 172.69.1.129
            ip host boot 172.19.192.254
            !
            vpdn enable
            !
            vpdn-group lac
             request-dialin
              protocol l2f
              domain pepsi.com
             initiate-to ip 10.1.1.5 
             local name lac
            !
            vpdn-group pppoe_terminate
             accept-dialin
              protocol pppoe
              virtual-template 1
             pppoe limit per-mac 2000
             pppoe limit per-vc 2000
            !         
            !
            !
            !
            !
            !
            !
            !
            !
            vc-class atm pppoa
              encapsulation aal5mux ppp Virtual-Template2
              dbs enable
            !
            vc-class atm pppoe
              dbs enable
              protocol pppoe
            !
            interface Loopback1
             no ip address
            !
            interface FastEthernet0/0
             ip address 10.0.74.211 255.255.255.0
             duplex half
             no cdp enable
            !
            interface ATM1/0
             no ip address
             no ip route-cache
             no ip mroute-cache
             no atm ilmi-keepalive
             atm voice aal2 aggregate-svc upspeed-number 0
            !
            interface ATM1/0.4 point-to-point
             ip address 10.1.1.6 255.255.255.0
             no ip route-cache
             no ip mroute-cache
             pvc 0/75 
              dbs enable
              protocol pppoe
             !
            !
            interface ATM1/0.5 point-to-point
             ip address 10.1.1.6 255.255.255.0
             no ip route-cache
             no ip mroute-cache
             pvc 0/85 
             !
            !
            interface ATM1/0.7 point-to-point
             ip address 10.1.1.6 255.255.255.0
             no ip route-cache
             no ip mroute-cache
             pvc 0/95 
              class-vc pppoa
              ubr 5000
             !
            !
            interface ATM1/0.10 point-to-point
             no ip route-cache
             no ip mroute-cache
             range pvc 0/101 0/500
              class-range pppoe
             !
              pvc-in-range 0/102
               no dbs enable
              !
            !
            interface Virtual-Template1
             ip unnumbered Loopback1
             ip mtu 1492
             no keepalive
             peer default ip address pool local_pool
             ppp authentication chap
            !
            interface Virtual-Template2
             ip address negotiated
             ip mtu 1492
             peer default ip address pool local_pool
             ppp authentication chap
            !
            interface Virtual-Template10
             ip address 192.168.11.1 255.255.255.0
             no keepalive
             peer default ip address pool p3
             ppp authentication chap
            !
            interface Virtual-Template11
             ip address negotiated
             no keepalive
             ppp chap hostname host1
             ppp chap password password1
            !
            ip local pool p3 192.168.0.0 192.170.12.250
            ip local pool local_pool 150.10.3.1 150.10.10.250
            ip default-gateway 10.0.74.1
            ip classless
            ip route 10.0.0.0 10.0.0.0 10.0.74.1
            ip route 10.107.164.0 255.255.255.0 FastEthernet0/0
            no ip http server
            !
            !
            !
            radius-server host 172.18.0.0 auth-port 1645 acct-port 1646
            radius-server retransmit 3
            radius-server key cisco
            call rsvp-sync
            !
            !
            mgcp profile default
            !
            !
            gatekeeper
             shutdown
            !
            !
            line con 0
            line aux 0
            line vty 5 15
            !
            !
            end
            

            Monitoring DBS

            Use the commands listed below to monitor DBS:

            Command

            Purpose

            debug atm events

            Displays the normal set of ATM events when a session comes up or goes down.

            debug atm errors

            Displays protocol errors and error statistics associated with VCs.

            debug atm status

            Displays changes in the status of a VC when a session comes up or goes down or when the VC configuration is changed.

            debug ppp authentication

            Displays authentication protocol messages, including Challenge Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges.

            debug ppp error

            Displays protocol errors and error statistics associated with PPP connection negotiation and operation.

            debug ppp negotiation

            Enables debugging of PPP negotiation process.

            debug radius

            Displays detailed debugging information associated with RADIUS.

            debug vpdn event

            Displays Layer 2 tunneling protocol (L2TP) errors and events that are a part of normal tunnel establishment or shutdown for VPDNs.

            debug vpdn l2x-errors

            Displays Layer 2 forwarding protocol (L2F ) and L2TP errors that prevent tunnel establishment or normal operation.

            debug vpdn 12x-events

            Displays L2F and L2TP events that are part of tunnel establishment or shutdown.

            debug vpdn pppoe-errors

            Displays PPPoE protocol errors that prevent a session from being established or errors that cause an established session to be closed.

            debug vpdn pppoe-events

            Displays PPPoE protocol messages about events that are part of normal session establishment or shutdown.

            show atm pvc

            Displays all ATM PVCs and traffic information.

            show atm pvc dbs

            Displays ATM PVCs that have DBS QoS parameters applied.

            show atm vc detailed

            Displays information about ATM PVCs and SVCs.

            show interfaces virtual-access

            Displays status, traffic data, and configuration information about a specified virtual access interface.

            Configuration Examples for Controlling Subscriber Bandwidth

            Configuring DBS for a VC Class Example

            In the following example, DBS QoS parameters have been applied to a VC called "cisco":

            vc-class atm cisco
             dbs enable

            Configuring DBS for a PVC Example

            In the following example, DBS QoS parameters have been applied on a PVC called "cisco":

            interface atm0/0/0.5 point-to-point
             ip address 10.0.0.0 255.255.255.0
             pvc cisco 0/100
             dbs enable
             protocol pppoe

            Configuring DBS for a Range of PVCs Example

            In the following example, DBS QoS parameters have been applied on a range of PVCs. The range is named "cisco range" and has a start-vpi of 0, a start-vci of 50, an end-vpiof 0, and an end-vci of 70:

            interface atm0/0/0.1 multipoint
             ip address 10.0.0.0 255.255.255.0
             range cisco pvc 0/50 0/70
             dbs enable

            Configuring DBS for a PVC Within a PVC Range Example

            In the following example, DBS parameters have been applied on PVC 60, which is part of the PVC range called "cisco":

            interface atm0/0/0.1 multipoint
             range cisco pvc 0/50 0/70
             pvc-in-range 0/60
             dbs enable

            Configuring RADIUS Attributes Examples

            The following example shows how to configure RADIUS attributes for a domain profile for DBS:

            cisco.com  Password = "cisco", Service-Type = Outbound
                 Service-Type = Outbound,
                 Cisco-Avpair = "vpdn:tunnel-id=tunnel33",
                 Cisco-Avpair = "vpdn:tunnel-type=l2tp",
                 Cisco-Avpair = "vpdn:l2tp-tunnel-password=password2",
                 Cisco-Avpair = "vpdn:ip-addresses=172.16.0.0",
                 Cisco-Avpair = "atm:peak-cell-rate=155000",
                 Cisco-Avpair = "atm:sustainable-cell-rate=155000"
            

            The following example shows how to configure RADIUS attributes for a user profile for DBS:

            user1@cisco.com Password = "userpassword1", Service-Type = Outbound
                 Service-Type = Outbound,
                 Cisco-Avpair = "atm:peak-cell-rate=155000",
                 Cisco-Avpair = "atm:sustainable-cell-rate=155000"

            Additional References

            Related Documents

            Related Topic

            Document Title

            Cisco IOS commands

            Cisco IOS Master Commands List, All Releases

            Cisco Subscriber Edge Services Manager

            Cisco Subscriber Edge Services Manager

            Access Point Name Manager

            APN Manager Application Programming Guide

            RADIUS configuration

            "Configuring RADIUS" chapter of the Cisco IOS Security Configuration Guide

            RADIUS attributes

            "RADIUS Attributes" appendix to the Cisco IOS Security Configuration Guide

            Broadband access aggregation concepts

            " Understanding Broadband Access Aggregation" module

            Tasks for preparing for broadband access aggregation

            " Preparing for Broadband Access Aggregation" module

            Broadband access commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

            "Wide-Area Networking Commands" in the Cisco IOS Wide-Area Networking Command Reference

            Standards

            Standards

            Title

            None

            --

            MIBs

            MIBs

            MIBs Link

            None

            To locate and download MIBs for selected platforms, Cisco IOS XE software releases, and feature sets, use Cisco MIB Locator found at the following URL:

            http:/​/​www.cisco.com/​go/​mibs

            RFCs

            RFCs

            Title

            None

            --

            Technical Assistance

            Description

            Link

            The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

            To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

            Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

            http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

            Feature Information for Controlling Subscriber Bandwidth

            The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

            Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

            Table 1 Feature Information for Controlling Subscriber Bandwidth

            Feature Name

            Releases

            Feature Configuration Information

            Dynamic Subscriber Bandwidth Selection (DBS)

            Cisco IOS XE Release 2.5

            This feature enables wholesale service providers to sell different classes of service to retail service providers by controlling bandwidth at the ATM virtual circuit (VC) level. ATM quality of service (QoS) parameters from the subscriber domain are applied to the ATM PVC on which a PPPoE or PPPoA session is established.