Broadband Access Aggregation and DSL Configuration Guide, Cisco IOS XE Release 3S (ASR 1000)
Broadband High Availability Stateful Switchover
Downloads: This chapterpdf (PDF - 1.39MB) The complete bookPDF (PDF - 5.19MB) | The complete bookePub (ePub - 1.08MB) | Feedback

Broadband High Availability Stateful Switchover

Contents

Broadband High Availability Stateful Switchover

The Cisco IOS XE Broadband High Availability Stateful Switchover feature provides the capability for dual Route Processor systems to support stateful switchover of Point-to-Point Protocol over X (PPPoX, where X designates a family of encapsulating communications protocols such as PPP over Ethernet [PPPoE], PPP over ATM [PPPoA], PPPoEoA, PPPoEoVLAN implementing PPP) sessions, thus allowing applications and features to maintain a stateful state while system control and routing protocol execution is transferred between an active and a standby processor.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Broadband High Availability Stateful Switchover

The stateful switchover (SSO) and nonstop forwarding (NSF) features must be enabled. For more information about SSO, see the "Stateful Switchover" module. For more information about NSF, see the "Configuring Nonstop Forwarding" module.

Restrictions for Broadband High Availability Stateful Switchover

SSO is supported only on High Availability (HA) network devices.

Information About Broadband High Availability Stateful Switchover

Feature Design of Broadband High Availability Stateful Switchover

Prior to the implementation of the Broadband High Availability Stateful Switchover feature, unplanned control plane and dataplane failures resulted in service outages and network downtime for PPPoX sessions. Cisco HA features, including SSO, enable network protection by providing fast recovery from such failures. The Broadband High Availability Stateful Switchover feature eliminates a source of outages by providing for stateful switchover to a standby processor while continuing to forward traffic. SSO protects from hardware or software faults on an active Route Processor (RP) by synchronizing protocol and state information for supported features with a standby RP, ensuring no interruption of sessions or connections if a switchover occurs.

The SSO feature takes advantage of RP redundancy by establishing one of the RPs as the active processor, designating the other RP as the standby processor, and then synchronizing critical state information between them. Following an initial (bulk) synchronization between the two processors, SSO dynamically maintains RP state information between them. A switchover from the active to the standby processor occurs when the active RP fails, when it is removed from the networking device, or when it is manually taken down for maintenance. The standby RP then takes control and becomes the active RP, preserving the sessions and connections for the supported features. At this time, packet forwarding continues while route convergence is completed on the newly active RP. A critical component of SSO and Cisco HA technology is the cluster control manager (CCM) that manages session re-creation on the standby processor. The Broadband High Availability Stateful Switchover feature allows you to configure subscriber redundancy policies that tune the synchronization process. For more information, see the Configuring Subscriber Redundancy Policy for Broadband HA Stateful Switchover.

The Broadband High Availability Stateful Switchover feature works with the Cisco NSF and SSO HA features, to maintain PPPoX sessions. NSF forwards network traffic and application state information so that user session information is maintained after a switchover.

For information about High Availability and stateful switchover, see the "High Availability Overview" chapter in the Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide .

Supported Broadband Aggregation Protocols

The Broadband High Availability Stateful Switchover feature set supports the broadband aggregation protocols described in the following sections:

SSO PPPoA

The Broadband High Availability Stateful Switchover feature delivers stateful switchover capability for PPP over ATM (PPPoA) sessions during Route Processor switchover.

SSO L2TP

The L2TP HA Session SSO/ISSU on a LAC/LNS feature provides a generic stateful switchover/In Service Software Upgrade (SSO/ISSU) mechanism for Layer 2 Tunneling Protocol (L2TP) on a Layer 2 Access Concentrator (LAC) and a Layer 2 Network Server (LNS). This feature preserves all fully established PPP and L2TP sessions during an SSO switchover or an ISSU upgrade or downgrade.

SSO PPPoE

The Broadband High Availability Stateful Switchover feature delivers stateful switchover capability for PPP over Ethernet (PPPoE) subscriber access sessions, including PPPoE, PPPoEoVLAN, and PPPoEoQinQ.

SSO RA-MLPS VPN

The Broadband High Availability Stateful Switchover feature delivers stateful switchover capability for PPPoX terminated into remote access (RA)-Multiprotocol Label Switching (MPLS) VPN or PPPoX into MPLS VPN sessions during processor switchover.

The figure below shows a typical broadband aggregation HA deployment with SSO functionality.

Figure 1. Broadband Aggregation High Availability Deployment

Benefits of Broadband High Availability Stateful Switchover

  • Reduces operating costs associated with outages.
  • Delivers higher service levels to subscribers.
  • Improves network availability.
  • Promotes continuous connectivity, lower packet loss, and consistent path flow through nodes providing specific network services.
  • Mitigates service disruptions, reduces downtime costs, and increases operational efficiency.

How to Configure Broadband High Availability Stateful Switchover

Configuring Subscriber Redundancy Policy for Broadband HA Stateful Switchover

Perform this task to configure subscriber redundancy policy for HA SSO capability for broadband subscriber sessions.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    subscriber redundancy { bulk limit { cpu percent delay seconds [ allow sessions ] | time seconds } | dynamic limit cpu percent delay seconds [ allow sessions ] | delay seconds | rate sessions seconds }

    4.    exit


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 subscriber redundancy { bulk limit { cpu percent delay seconds [ allow sessions ] | time seconds } | dynamic limit cpu percent delay seconds [ allow sessions ] | delay seconds | rate sessions seconds }


    Example:
    Router(config)# subscriber redundancy bulk limit cpu 75 delay 20 allow 30
     

    (Optional) Configures subscriber redundancy policy.

    • bulk --Configures bulk synchronization redundancy policy.
    • limit --Specifies the limit for the synchronization.
    • cpu percent --Specifies a CPU busy threshold value as a percentage. Range is from 0 to 100; default is 90.
    • delay seconds --Specifies the minimum amount of time, in seconds, that a session must be ready before bulk or dynamic synchronization occurs. Range is from 1 to 33550.
    • allow sessions --(Optional) Specifies the minimum number of sessions to synchronize once the CPU busy threshold is exceeded and the specified delay is met. Range is from 1 to 2147483637; default is 25.
    • dynamic --Configures a dynamic synchronization redundancy policy.
    • rate sessions seconds --Specifies the number of sessions per time period for bulk and dynamic synchronization.
      • sessions--Range is from 1 to 32000; default is 250.
      • seconds--Range in seconds is from 1 to 33550; default is 1.
     
    Step 4 exit


    Example:
    Router(config)# exit
     

    Exits global configuration mode and returns to privileged EXEC mode.

     

    Verifying and Troubleshooting Subscriber Redundancy Policy for Broadband HA Stateful Switchover

    To view the configuration, use the show running-config command. Sample output is available at Configuration Examples for Broadband High Availability Stateful Switchover.

    SUMMARY STEPS

      1.    show ccm clients

      2.    show ccm sessions

      3.    show ppp subscriber statistics

      4.    show pppatm statistics

      5.    show pppoe statistics

      6.    show vpdn redundancy

      7.    show vpdn history failure

      8.    show pppatm redundancy

      9.    show pppoe redundancy

      10.    debug pppatm redundancy

      11.    debug pppoe redundancy


    DETAILED STEPS
      Step 1   show ccm clients


      Example:
      This command is useful for troubleshooting the CCM synchronization component. This command displays information about the CCM, which is the HA component that manages the capability to synchronize session launch on the standby processor of a redundant processor HA system. 

      Active Route Processor



      Example:
      Router# show ccm clients
      CCM bundles sent since peer up:
      Sent Queued for flow control 
      Sync Session 16000 0 
      Update Session 0 0 
      Active Bulk Sync End 1 0 
      Session Down 0 0 
      ISSU client msgs 346 0 
      Dynamic Session Sync 0 0 
      Unknown msgs 0 0 
      Client events sent since peer up: 
      PPP 144000 
      PPPoE 96002 
      VPDN FSP 0 
      AAA 64000 
      PPP SIP 0 
      LTERM 16000 
      AC 0 
      L2TP CC 0 
      SSS FM 16000 
      VPDN LNS 0 

      Standby Route Processor



      Example:
      Router# show ccm clients
       
      CCM bundles rcvd since last boot: 
      Sync Session 16000 
      Update Session 0 
      Active Bulk Sync End 1 
      Session Down 0 
      ISSU client msgs 173 
      Dynamic Session Sync 0 
      Unknown msgs 0 
      Client events extracted since last boot: 
      PPP 144000 
      PPPoE 96002 
      VPDN FSP 0 
      AAA 64000 
      PPP SIP 0 
      LTERM 16000 
      AC 0 
      L2TP CC 0 
      SSS FM 16000 
      VPDN LNS 0 
      
      Step 2   show ccm sessions

      This command is useful for troubleshooting the CCM synchronization component. This command shows information about sessions managed by CCM.

      Active Route Processor



      Example:
      Router# show ccm sessions 
      Global CCM state: CCM HA Active - Dynamic Sync 
      Global ISSU state: Compatible, Clients Cap 0x9EFFE 
      Current Bulk Sent Bulk Rcvd 
      ----------- ----------- ----------- 
      Number of sessions in state Down: 0 0 0 
      Number of sessions in state Not Ready: 0 0 9279 
      Number of sessions in state Ready: 0 0 6721 
      Number of sessions in state Dyn Sync: 16000 16000 0 
      Timeout: Timer Type Delay Remaining Starts CPU Limit CPU Last 
      ------------ -------- --------- ----------- --------- -------- 
      Rate 00:00:01 - 64 - - 
      Dynamic CPU 00:00:10 - 0 90 0 
      Bulk Time Li 00:08:00 - 1 - - 
      RF Notif Ext 00:00:01 - 475 - - 

      Standby Route Processor



      Example:
      Router# show ccm sessions
       
      Global CCM state: CCM HA Standby - Collecting 
      Global ISSU state: Compatible, Clients Cap 0x9EFFE 
      Current Bulk Sent Bulk Rcvd 
      ----------- ----------- ----------- 
      Number of sessions in state Down: 0 0 0 
      Number of sessions in state Not Ready: 0 0 8384 
      Number of sessions in state Ready: 16000 0 7616 
      Number of sessions in state Dyn Sync: 0 0 0 
      Timeout: Timer Type Delay Remaining Starts CPU Limit CPU Last 
      ------------ -------- --------- ----------- --------- --------
      Rate 00:00:01 - 0 - - 
      Dynamic CPU 00:00:10 - 0 90 0 
      Bulk Time Li 00:08:00 - 1 - - 
      RF Notif Ext 00:00:01 - 0 - - 
      
      Step 3   show ppp subscriber statistics

      This command is useful for reviewing PPPoX session statistics. Use the show ppp subscriber statistics command to display a cumulative count of PPP subscriber events and statistics, and to display an incremental count since the clear ppp subscriber statistics command was last issued.

      The following is sample output from the show ppp subscriber statistics command:



      Example:
      Router# show ppp subscriber statistics
      PPP Subscriber Events          TOTAL         SINCE CLEARED
      Encap                          5             5
      DeEncap                        0             0
      CstateUp                       7             7
      CstateDown                     4             4
      FastStart                      0             0
      LocalTerm                      7             7
      LocalTermVP                    0             0
      MoreKeys                       7             7
      Forwarding                     0             0
      Forwarded                      0             0
      SSSDisc                        0             0
      SSMDisc                        0             0
      PPPDisc                        0             0
      PPPBindResp                    7             7
      PPPReneg                       3             3
      RestartTimeout                 5             5
      PPP Subscriber Statistics      TOTAL         SINCE CLEARED
      IDB CSTATE UP                  4             4
      IDB CSTATE DOWN                8             8
      APS UP                         0             0
      APS UP IGNORE                  0             0
      APS DOWN                       0             0
      READY FOR SYNC                 8             8
      
      Step 4   show pppatm statistics

      This command is useful for obtaining statistics for PPPoA sessions. Use the show pppatm statistics command to display a total count of PPPoA events since the clear pppatm statisticscommand was last issued.

      The following example displays PPPoA statistics:



      Example:
      Router# show pppatm statistics
      	4000 : Context Allocated events
      	3999 : SSS Request events
      	7998 : SSS Msg events
      	3999 : PPP Msg events
      	3998 : Up Pending events
      	3998 : Up Dequeued events
      	3998 : Processing Up events
      	3999 : Vaccess Up events
      	3999 : AAA unique id allocated events
      	3999 : No AAA method list set events
      	3999 : AAA gets nas port details events
      	3999 : AAA gets retrived attrs events
      	68202 : AAA gets dynamic attrs events
      	3999 : Access IE allocated events
      
      Step 5   show pppoe statistics

      This command is useful for reviewing PPPoX session statistics. Use the show pppoe statistics command to display a cumulative count of PPPoE events and statistics, and to display an incremental count since the clear pppoe statistics command was last issued.

      The following is sample output from the show pppoe statistics command:



      Example:
      Router# show pppoe statistics
      PPPoE Events                   TOTAL         SINCE CLEARED
      ------------------------------ ------------- -------------
      INVALID                        0             0
      PRE-SERVICE FOUND              0             0
      PRE-SERVICE NONE               0             0
      SSS CONNECT LOCAL              0             0
      SSS FORWARDING                 0             0
      SSS FORWARDED                  0             0
      SSS MORE KEYS                  0             0
      SSS DISCONNECT                 0             0
      CONFIG UPDATE                  0             0
      STATIC BIND RESPONSE           0             0
      PPP FORWARDING                 0             0
      PPP FORWARDED                  0             0
      PPP DISCONNECT                 0             0
      PPP RENEGOTIATION              0             0
      SSM PROVISIONED                0             0
      SSM UPDATED                    0             0
      SSM DISCONNECT                 0             0
      PPPoE Statistics               TOTAL         SINCE CLEARED
      ------------------------------ ------------- -------------
      SSS Request                    0             0
      SSS Response Stale             0             0
      SSS Disconnect                 0             0
      PPPoE Handles Allocated        0             0
      PPPoE Handles Freed            0             0
      Dynamic Bind Request           0             0
      Static Bind Request            0             0
      
      Step 6   show vpdn redundancy

      Use this command to verify the failure of any L2TP tunnels.



      Example:
      Router# show vpdn redundancy
       
      L2TP HA support: Silent Failover 
      L2TP HA Status: 
      Checkpoint Messaging on: FALSE 
      Standby RP is up: TRUE 
      Recv'd Message Count: 0 
      L2TP Tunnels: 2/2/2/0 (total/HA-enabled/HA-est/resync) 
      L2TP Sessions: 10/10/10 (total/HA-enabled/HA-est) 
      L2TP Resynced Tunnels: 0/0 (success/fail) 
      
      Step 7   show vpdn history failure

      Use this command to verify the failure of any VPDN groups.



      Example:
      Router# show vpdn history failure
       
      % VPDN user failure table is empty 
      
      Step 8   show pppatm redundancy

      Use the show pppatm redundancy command to display the PPPoA HA sessions summary. The following is sample output from the show pppatm redundancy command from a Cisco 10000 series router standby processor:



      Example:
      Router-stby# show pppatm redundancy
      0 : Session recreate requests from CCM
      0 : Session up events invoked
      0 : Sessions reaching PTA
      0 : Sessions closed by CCM
      0 : Session down events invoked
      0 : Queued sessions waiting for base hwidb creation
      0 : Sessions queued for VC up notification so far
      0 : Sessions queued for VC encap change notification so far
      0 : VC activation notifications received from ATM
      0 : VC encap change notifications received from ATM
      0 : Total queued sessions waiting for VC notification(Encap change+VC Activation)
      
      Step 9   show pppoe redundancy

      This command is useful for reviewing PPPoX session statistics. Use the show pppoe redundancy command to display statistics and events for PPPoE sessions. This command gives a cumulative count of PPPoE events and statistics, and an incremental count since the clear pppoe redundancy command was last issued.

      The following is sample output from the show pppoe redundancy command from a Cisco 10000 series router standby processor:



      Example:
      Router-stby# show pppoe redundancy
      12 Event Queues
      size max kicks starts false suspends ticks(ms)
      9 PPPoE CCM EV 0 1 2 3 1 0 20
      Event Names
      Events Queued MaxQueued Suspends usec/evt max/evt
      1* 9 Recreate UP 2 0 1 0 1500 3000
      2* 9 Recreate DOWN 0 0 0 0 0 0
      3* 9 VC Wait UP 0 0 0 0 0 0
      4* 9 VC Wait Encap 0 0 0 0 0 0
      Sessions waiting for Base Vaccess: 0
      Sessions waiting for ATM VC UP: 0
      Sessions waiting for Auto VC Encap 0 
      
      Step 10   debug pppatm redundancy

      Use the debug pppatm redundancy command to display CCM events and messages for PPPoA sessions on HA systems. This command is generally used only by Cisco engineers for internal debugging of CCM processes. The following is sample output from the debug pppatm redundancy command from a Cisco 10000 series router active processor:



      Example:
      Router# debug pppatm redundancy
      PPP over ATM redundancy debugging is on
      
      Step 11   debug pppoe redundancy

      Use the debug pppoe redundancy command to display CCM events and messages for PPPoE sessions on HA systems. This command is generally used only by Cisco engineers for internal debugging of CCM processes.



      Example:
      Router# debug pppoe redundancy
      Nov 22 17:21:11.327: PPPoE HA[0xBE000008] 9: Session ready to sync data 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PADR, length = 58 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SESSION ID, length = 2 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SWITCH HDL, length = 4 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SEGMENT HDL, length = 4 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PHY SWIDB DESC, length = 20 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = VACCESS DESC, length = 28 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: Sync collection for ready events 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PADR, length = 58 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SESSION ID, length = 2 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SWITCH HDL, length = 4 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SEGMENT HDL, length = 4 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PHY SWIDB DESC, length = 20 
      Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = VACCESS DESC, length = 28

      Configuration Examples for Broadband High Availability Stateful Switchover

      Example Configuring Broadband High Availability Stateful Switchover

      The following example shows how to configure the Broadband High Availability Stateful Switchover feature:

      Router# configure terminal
      Router(config)# subscriber redundancy bulk limit cpu 75 delay 20 allow 30
      Router(config)# exit
      

      The following is a sample configuration of PPPoX terminated into an RA-MPLS network with SSO. Commands that appear in the configuration task tables for this feature but that do not appear in the running configuration output are configured for their default settings.

      Router# show running-config
      hostname Router
      !
      boot-start-marker
      boot system bootflash:packages.conf !
      enable password cisco
      !
      aaa new-model
      !
      !
      aaa authentication ppp default local
      !
      !
      !
      aaa session-id common
      ppp hold-queue 80000
      ip subnet-zero
      no ip gratuitous-arps
      no ip domain lookup
      ip vrf vrf1
        rd 1:1
        route-target export 1:1
        route-target import 1:1
      !
      no ip dhcp use vrf connected
      !
      !
      !
      !
      no subscriber policy recording rules
      

      The following lines show the subscriber redundancy policy configuration:

      subscriber redundancy dynamic limit cpu 90 delay 10 
      subscriber redundancy bulk limit cpu 90 delay 10 
      subscriber redundancy rate 4000 1 
      subscriber redundancy delay 10 
      no mpls traffic-eng 
      mpls ldp graceful-restart 
      mpls ldp router-id Loopback100 
      no virtual-template snmp 
      no issu config-sync policy bulk prc 
      no issu config-sync policy bulk bem 
      !
      redundancy mode sso
      username cisco password 0 cisco
      !
      bba-group pppoe grp1
        virtual-template 1
      !
      bba-group pppoe grp2
        virtual-template 2
      !
      bba-group pppoe grp3
        virtual-template 3
      !
      bba-group pppoe grp4
        virtual-template 4
      !
      bba-group pppoe grp5
        virtual-template 5
      !
      bba-group pppoe grp7
        virtual-template 7
      !
      bba-group pppoe grp8
        virtual-template 8
      !
      bba-group pppoe grp6
        virtual-template 6
      !
      !
      interface Loopback0
        ip vrf forwarding vrf1
        ip address 10.1.1.1 255.255.255.255
      !
      interface Loopback100
        ip address 192.168.0.1 255.255.255.255
      !
      interface FastEthernet0/0/0
        ip address 192.168.2.26 255.255.255.0
        speed 100
        full-duplex
      !
      interface GigabitEthernet1/0/0 
      no ip address 
      load-interval 30 
      ! 
      interface GigabitEthernet1/0/0.1 
      encapsulation dot1Q 2 
      pppoe enable group grp1 
      ! 
      ! 
      interface GigabitEthernet1/0/0.2 
      encapsulation dot1Q 2 
      pppoe enable group grp2 
      ! 
      ! 
      interface GigabitEthernet1/0/1 
      no ip address 
      ! 
      interface GigabitEthernet1/0/1.1 
      encapsulation dot1Q 2 
      pppoe enable group grp3
      ! 
      ! 
      interface GigabitEthernet1/0/1.2 
      encapsulation dot1Q 2 
      pppoe enable group grp4 
      ! 
      ! 
      interface GigabitEthernet1/0/2 
      no ip address 
      ! 
      interface GigabitEthernet1/0/2.1 
      encapsulation dot1Q 2 
      pppoe enable group grp5 
      ! 
      ! 
      interface GigabitEthernet1/0/2.2 
      encapsulation dot1Q 2 
      pppoe enable group grp6 
      ! 
      ! 
      interface GigabitEthernet1/0/3 
      no ip address 
      ! 
      interface GigabitEthernet1/0/3.1 
      encapsulation dot1Q 2 
      pppoe enable group grp7
      ! 
      ! 
      interface GigabitEthernet1/0/3.2 
      encapsulation dot1Q 2 
      pppoe enable group grp8 
      ! 
      interface GigabitEthernet7/0/3 
      no ip address 
      !
      interface GigabitEthernet8/0/0
        mac-address 0011.0022.0033
        ip vrf forwarding vrf1
        ip address 10.1.1.2 255.255.255.0
        negotiation auto
      !
      interface GigabitEthernet8/1/0
        ip address 10.1.1.1 255.255.255.0
        negotiation auto
        mpls ip
      !
      interface Virtual-Template1
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool1
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      interface Virtual-Template2
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool2
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      interface Virtual-Template3
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool3
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      interface Virtual-Template4
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool4
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      interface Virtual-Template5
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool5
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      interface Virtual-Template6
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool6
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      interface Virtual-Template7
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool7
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      interface Virtual-Template8
        ip vrf forwarding vrf1
        ip unnumbered Loopback0
        no logging event link-status
        peer default ip address pool pool8
        no snmp trap link-status
        keepalive 30
        ppp authentication pap
      !
      router ospf 1
        log-adjacency-changes
        nsf
        network 10.1.1.0 0.0.0.255 area 0
        network 224.0.0.0 0.0.0.255 area 0
      !
      router bgp 1
        no synchronization
        bgp log-neighbor-changes
        bgp graceful-restart restart-time 120
        bgp graceful-restart stalepath-time 360
        bgp graceful-restart
        neighbor 224.0.0.3 remote-as 1
        neighbor 224.0.0.3 update-source Loopback100
        no auto-summary
        !
        address-family vpnv4
        neighbor 224.0.0.3 activate
        neighbor 224.0.0.3 send-community extended
        exit-address-family
        !
        address-family ipv4 vrf vrf1
        redistribute connected
        redistribute static
        no auto-summary
        no synchronization
        exit-address-family
      !
      ip local pool pool2 10.1.1.1 10.1.16.160 
      ip local pool pool3 10.13.1.1 10.13.16.160 
      ip local pool pool4 10.14.1.1 10.14.16.160 
      ip local pool pool5 10.15.1.1 10.15.16.160 
      ip local pool pool6 10.16.1.1 10.16.16.160 
      ip local pool pool7 10.17.1.1 10.17.16.160 
      ip local pool pool8 10.18.1.1 10.18.16.160 
      ip classless !
      !
      no ip http server
      !
      !
      arp 10.20.1.1 0020.0001.0001 ARPA
      arp vrf vrf1 10.20.1.1 0020.0001.0001 ARPA !
      !
      !
      line con 0
      line aux 0
      line vty 0 4
        password cisco
      !
      exception crashinfo file bootflash:crash.log !
      end
      

      Additional References

      Related Documents

      Related Topic

      Document Title

      Cisco IOS commands

      Cisco IOS Master Command List, All Releases

      Cisco IOS Broadband Access Aggregation and DSL commands

      Cisco IOS Broadband Access Aggregation and DSL Command Reference

      High Availability

      "High Availability Overview" chapter in the Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide

      Performing an ISSU

      The following chapters in the Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide :

      • "Cisco IOS XE Software Package Compatibility for ISSU"
      • "In Service Software Upgrade (ISSU)"

      Broadband ISSU

      "Broadband High Availability In Service Software Upgrade" module

      Stateful switchover

      "Stateful Switchover" module

      Configuring nonstop forwarding

      "Configuring Nonstop Forwarding" module

      Layer 2 Tunnel Protocol

      Layer 2 Tunnel Protocol Technology Brief" module

      Standards

      Standard

      Title

      No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

      --

      MIBs

      MIB

      MIBs Link

      None

      To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

      http:/​/​www.cisco.com/​go/​mibs

      RFCs

      RFC

      Title

      No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

      --

      Technical Assistance

      Description

      Link

      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for Broadband High Availability Stateful Switchover

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for the Broadband High Availability Stateful Switchover Feature

      Feature Name

      Releases

      Feature Information

      SSO--PPPoA

      Cisco IOS XE Release 3.3S

      In Cisco IOS XE Release 3.3S, this feature was implemented on ASR 1000 Series Routers.

      The Broadband High Availability Stateful Switchover feature delivers stateful switchover capability for PPP over ATM (PPPoA) sessions during RP switchover.

      The following commands were introduced or modified: subscriber redundancy, debug pppatm redundancy, debug pppoe redundancy, show pppoe redundancy, show pppatm statistics.

      SSO--PPPoE

      Cisco IOS XE Release 2.1

      Cisco IOS XE Release 2.5

      In Cisco IOS XE Release 2.1, this feature was implemented on ASR 1000 Series Routers.

      This feature uses the SSO--PPPoE feature to provide the capability for dual Route Processor systems to support stateful switchover of PPPoX sessions and allow applications and features to maintain state while system control and routing protocol execution is transferred between an active and a standby processor.

      The following commands were introduced or modified: clear ppp subscriber statistics, clear pppoe statistics, debug pppoe redundancy, show ccm clients, show ccm sessions, show ppp subscriber statistics, show pppoe statistic, subscriber redundancy.