Broadband Access Aggregation and DSL Configuration Guide, Cisco IOS Release 12.4T
1-Port ADSL WAN Interface Card for Cisco 2600 Series and Cisco 3600 Series Routers
Downloads: This chapterpdf (PDF - 149.0KB) The complete bookPDF (PDF - 2.8MB) | Feedback

1-Port ADSL WAN Interface Card for Cisco 2600 Series and Cisco 3600 Series Routers

1-Port ADSL WAN Interface Card for Cisco 2600 Series and Cisco 3600 Series Routers

Last Updated: December 5, 2011

This document describes the 1-port Asymmetric Digital Subscriber Line (ADSL) WAN Interface Card (WIC) (WIC-1ADSL) feature for Cisco 2600 series and Cisco 3600 series routers in Cisco IOS Release xx.x(x)X. It describes the benefits of the new feature, supported platforms, configuration, related documents, and provides command reference information.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for 1-Port ADSL WAN Interface Card

A 1-Port ADSL WIC must be installed in the router to match the DSL service to be configured.

Restrictions for 1-Port ADSL WAN Interface Card

  • The ADSL WAN interface card does not support dual latency. When the ADSL link is intended to support both voice and data traffic simultaneously, the link should be configured for either all fast-path data or all interleave data with an interleave depth of zero to insure that latency is minimized. In addition, the total supported data rate must be reduced to adjust for the reduced coding gain, which is usually present with high-latency traffic.
  • The ADSL WAN interface card does not support available bit rate (ABR) class of service (CoS).
  • For the Cisco 2600 series routers, the ADSL WAN interface card should be inserted only into on-board WIC slots or 2W network modules. This card does not function properly in older network modules.
  • For the Cisco 3600 series routers, the ADSL WAN interface card should be inserted only into on-board WIC slots or 2W, 1FE2W, 2FE2W, or 1FE1R2W network modules. This card does not function properly in older network modules.
  • When using AAL2, analog voice is not supported. Voice calls should come through a digital voice card, such as the NM-HDV.
  • VoATM is supported in both AAL2 and AAL5 modes on the Cisco 2600 series and Cisco 3600 series.
  • VoATM AAL2 and AAL5 are supported only if voice and data use separate permanent virtual circuits (PVCs).
  • VoATM AAL2 supports digital voice (T1/E1) only, while VoATM AAL5 supports both analog and digital voice.
  • VoIP is not supported unless the ADSL WIC carries only voice traffic (with no data). The QoS features necessary for VoIP and data sharing the same PVC, or different PVCs on the same interface, are not supported yet. These features include LLQ, LFI, and tx-ring tuning.

Information About 1-Port ADSL WAN Interface Card

ADSL WAN Interface Card

The ADSL WAN interface card is a 1-port WAN interface card (WIC) for the Cisco 2600 series and Cisco 3600 series routers. The card provides asymmetric digital subscriber line (ADSL) high-speed digital data transfer between a single customer premises equipment (CPE) subscriber and the central office.

The ADSL WIC is compatible with the Alcatel Digital Subscriber Loop Access Multiplexer (DSLAM) and the Cisco 6130, Cisco 6160, and Cisco 6260 DSLAMs with Flexi-line cards. It supports Asynchronous Transfer Mode (ATM) Adaptation Layer 2 (AAL2) and AAL5 for the Cisco 2600 series and Cisco 3600 series platforms for both voice and data service.

The general topology is shown in the figure below.

Figure 1 General Topology for ADSL WIC



Note


ADSL is a last-mile access technology, which has an asymmetrical data rate running over a single copper wire pair.

Benefits

  • Enables business class broadband service with voice integration, scalable performance, flexibility, and security.
  • Aggregates both ADSL and other transport options into a single box.
  • Provides both POTS and ADSL high-speed digital data transmissions between the customer premises equipment (CPE) and the central office (CO).
  • Supports ITU G.992.1 (or G.DMT, which specifies full-rate ADSL).
  • Supports and complies with ANSI T1.413 issue 2, and ITU G.992.1 (G.DMT for full-rate ADSL).
  • Supports ATM AAL2 and AAL5 services on the Cisco 2600 series and Cisco 3600 series platforms.
  • Supports applications (including VoATM voice), ATM class of service (variable bit rate-nonreal time [VBR-NRT], variable bit rate-real time [VBR-rt], and unspecified bit rate [UBR]) and up to 23 virtual circuits on a WIC.
  • Provides ATM traffic management to enable service providers to manage their core ATM network infrastructures.

How to Configure 1-Port ADSL WAN Interface Card

Features used on the ADSL WAN interface card must also be configured on the DSLAM. See the documentation for the specific DSLAM for information about configuring features.

Configuring the ADSL Port on the ADSL WAN Interface Card

To configure an ADSL port on the ADSL WAN interface card, complete the following steps:

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface atm slot/port

4.   ip addressIP-address

5.    pvc [ name ] vpi/vci

6.    protocol ipIP-address

7.    vbr-rtpeak-rate average-rate burst

8.    encapsulation aal2 | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap

9.    exit

10.    dsl operating-mode ansi-dmt | auto | itu-dmt | splitterless

11.    Router(config-if)# no shutdown

12.    exit

13.   exit

14.    show interface atm 1/0


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface atm slot/port


Example:

Router(config)# interface atm0/1

 

Enters ATM configuration mode for the ATM interface in the specified slot and port.

 
Step 4
ip addressIP-address


Example:

Router(config-if)# ip address 10.1.1.1 255.0.0.0

 

Assigns an IP address to the ADSL ATM interface.

 
Step 5
pvc [ name ] vpi/vci


Example:

Router(config-if)# pvc 10/100

 

Enters atm-virtual-circuit (interface-atm-vc) configuration mode, and configures a new ATM PVC by assigning a name (optional) and virtual path identifier (VPI)/virtual channel identifier (VCI) numbers.

The default traffic shaping is UBR; the default encapsulation is AAL5+LLC/SNAP.

 
Step 6
protocol ipIP-address


Example:

Router(config-if-vc)# protocol ip 10.1.1.2 broadcast

 

(Optional) Enables IP connectivity and create a point-to-point IP address for the virtual circuit (VC).

 
Step 7
vbr-rtpeak-rate average-rate burst


Example:

Router(config-if-vc)# vbr-rt 672 672 512

 

(Optional) Configures the PVC for real-time variable bit rate (VBR) traffic shaping.

  • Peak rate --Peak information rate (PIR)
  • Average rate --Average information rate (AIR)
  • Burst --Burst size in cells
 
Step 8
encapsulation aal2 | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap


Example:

Router(config-if-vc)# encapsulation aal2

 

(Optional) Configures the ATM adaptation layer (AAL) and encapsulation type.

  • aal2 --AAL2
  • aal5ciscoppp --Cisco PPP over AAL5
  • aal5mux --AAL5+MUX
  • aal5nlpid --AAL5+NLPID
  • aal5snap --AAL5+LLC/SNAP (the default)
 
Step 9
exit


Example:

Router(config-if-vc)# exit

 

Exits from interface-atm-vc configuration mode.

 
Step 10
dsl operating-mode ansi-dmt | auto | itu-dmt | splitterless


Example:

Router(config-if)# dsl operating-mode ansi-dmt

 

Configures the ADSL interface to operate in a specified mode:

  • ansi-dmt --ANSI full rate mode per T1.413 (ITU G.DMT Issue 1)
  • auto --Automatic detection mode
  • itu-dmt --ITU full rate mode (ITU G.DMT Issue 1)
  • splitterless --G.lite mode per ITU G.992.2
Caution   

This command is for testing or lab environments only. Using a configuration other than the default configuration for the DSL operating mode can lead to unpredictable behavior on the ADSL line.

 
Step 11
Router(config-if)# no shutdown

Example:

Router(config-if)# no shutdown

 

Activates the ATM interface.

 
Step 12
exit


Example:

Router(config-if)# exit

 

Exits from ATM interface configuration mode.

 
Step 13
exit


Example:

Router(config)# exit

 

Exits from global configuration mode.

 
Step 14
show interface atm 1/0


Example:

Router# show interface atm0/1

 

Verifies the ATM interface configuration.

 

Verifying ATM Configuration

Use the following commands to verify configuration:

  • To verify current configuration and to view the status for all controllers, use the show running-config command.
  • To view ATM controller statistics, use the show controllers atm slot/port command.
  • To verify the PVC status, use the show atm vc command. Make sure that active PVCs are up.
  • To help identify ATM related events as they are generated, use the debug atm events command.
  • To indicate what interfaces are having trouble, use the debug atm errors command.
  • To identify an entry for the ATM interface you configured and to show an entry for the ATM slot/port you configured, use the show ip route command.
  • To display the configured list of ATM static maps to remote hosts on an ATM network, use the show atm map command.
  • To view the status of ATM interface, use the show interface atm slot/port command. Make sure that ATM slot/port and line protocol is up, as shown in the following example:
Router# show interface atm1/0
ATM1/0 is up, line protocol is up 
  Hardware is DSLSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 2560 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Keepalive not supported 
  Encapsulation(s):AAL5 AAL2, PVC mode
  24 maximum active VCs, 256 VCs per VP, 2 current VCCs
  VC idle disconnect time:300 seconds
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters 03:16:00
  Queueing strategy:fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
     2527 packets input, 57116 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     10798 packets output, 892801 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
Router# show atm vc
            VCD /                                      Peak  Avg/Min Burst
Interface   Name       VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts
1/0.3      2            9    36   PVC    MUX      UBR     800                UP
1/0.2      1            9    37   PVC    SNAP     UBR     800                UP
Router# show controllers atm 1/0
Interface ATM1/0 is up
  Hardware is DSLSAR (with Alcatel ADSL Module)
IDB:    62586758  Instance:6258E054  reg_dslsar:3C810000  wic_regs:3C810080
PHY Inst:62588490  Ser0Inst:62573074  Ser1Inst: 6257CBD8  us_bwidth:800     
Slot:   1         Unit:    1         Subunit:  0         pkt Size:4496    
VCperVP:256       max_vp:  256       max_vc:   65536     total vc:2       
rct_size:65536     vpivcibit:16        connTblVCI:8         vpi_bits:8       
vpvc_sel:3         enabled: 0         throttled:0       
WIC    Register   Value      Notes
---------------   ---------- ----------
FPGA Dev ID (LB)  0x44       'D'
FPGA Dev ID (UB)  0x53       'S'
FPGA Revision     0x99       
WIC Config Reg    0x45       WIC / VIC select = WIC; 
                             CTRLE addr bit 8 = 1; 
                             OK LED on; 
                             LOOPBACK LED off; 
                             CD LED on; 
WIC Config Reg2   0x07       Gen bus error on bad ADSL access
Int 0 Enable Reg  0x03       ADSL normal interrupt enabled
                             ADSL error interrupt enabled

Configuration Examples for 1-Port ADSL WAN Interface Card

VoATM over AAL2 on the ATM Interface Example

The following example shows a Cisco 2600 series router configured for VoATM over AAL2 on the ATM interface with an ADSL card:

Router# 
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname host1
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
ip host host2 225.255.255.224
!
no mgcp timer receive-rtcp
call rsvp-sync
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1 type e&m-wink-start
 ds0-group 1 timeslots 2 type e&m-wink-start
.
.
.
ds0-group 23 timeslots 24 type e&m-wink-start
!
controller T1 1/1
 framing esf
 linecode b8zs
!
interface Ethernet0/0
 ip address 1.6.46.119 255.255.255.224
 half-duplex
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
!
interface ATM0/1
 ip address 10.1.1.1 255.0.0.0
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 pvc 10/100 
  vbr-rt 672 672 512
  encapsulation aal2
 !
 pvc 10/200 
  protocol ip 10.1.1.2 broadcast
  encapsulation aal5snap
 !
 dsl operating-mode ansi-dmt
 no fair-queue
!
interface Ethernet0/1
 no ip address
 shutdown
!
ip classless
ip route 223.255.254.254 255.255.255.224 Ethernet0/0
no ip http server
!
!
snmp-server engineID local 000000090200003080477F20
snmp-server manager
!
voice-port 1/0:0
 local-alerting
 timeouts wait-release 3
 connection trunk 3001 
!
voice-port 1/0:1
 local-alerting
 timeouts wait-release 3
 connection trunk 3002 
.
.
.
voice-port 1/0:23
 local-alerting
 timeouts wait-release 3
 connection trunk 3024 
 shutdown
!
dial-peer cor custom
!
dial-peer voice 3001 voatm
 destination-pattern 3001
 called-number 4001
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 31
 codec aal2-profile ITUT 1 g711ulaw
 no vad
!
dial-peer voice 3002 voatm
 destination-pattern 3002
 called-number 4002
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 32
 codec aal2-profile custom 100 g726r32
 no vad
!
dial-peer voice 3003 voatm
 destination-pattern 3003
 called-number 4003
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 33
 codec aal2-profile ITUT 7 g729abr8
 no vad
.
.
.
dial-peer voice 3024 voatm
 destination-pattern 3024
 called-number 3024
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 54
 codec aal2-profile ITUT 7 g729abr8
 no vad
!
dial-peer voice 1 pots
 destination-pattern 4001
 port 1/0:0
!
dial-peer voice 2 pots
 destination-pattern 4002
 port 1/0:1
.
.
.
dial-peer voice 24 pots
 destination-pattern 4024
 port 1/0:23
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

VoATM over AAL5 on the ATM Interface Example

The following example shows a Cisco 2600 series router configured for VoATM over AAL5 on the ATM interface with an ADSL card.

Router#
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname u2621
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
!
memory-size iomem 15
voice-card 1
!
ip subnet-zero
!
no ip finger
no ip domain-lookup
!
no mgcp timer receive-rtcp
call rsvp-sync
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
controller T1 1/1
!
!
interface ATM0/0
 ip address 12.0.0.1 255.255.255.224
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 dsl operating-mode auto
 no fair-queue
!
!
interface FastEthernet0/0
 ip address 1.7.73.1 255.255.255.224
 duplex auto
 speed auto
!
!
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.224
 load-interval 30
 duplex auto
 speed auto
!
ip classless
ip route 223.255.254.0 255.255.255.224 FastEthernet0/0
no ip http server
!
!
snmp-server engineID local 0000000902000002163DB260
snmp-server packetsize 4096
snmp-server manager
!
voice-port 1/0:0
!
dial-peer cor custom
!
!
dial-peer voice 5 pots
 destination-pattern 777...
 port 1/0:0
 prefix 777
! 
! 
dial-peer voice 100 voatm
 destination-pattern 888....
 session target atm0/0 pvc 0/72
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Additional References

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Vice configuration

  • Cisco IOS Voice, Video, and Fax Configuration Guide , Release 12.2
  • Cisco IOS Voice, Video, and Fax Command Reference , Release 12.2

Configuring IP

Cisco IOS IP Configuration Guide , Release 12.2

Configuring ATM

"Configuring ATM" in the Wide-Area Networking Configuration Guide, Release 12.2.

Configuring a DSLAM

Configuration Guide for Cisco DSLAMs with NI-2

Installing Cisco 2600 series hardware

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/index.htm http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/index.htm

Installing Cisco 3600 series hardware

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis3600/index.htm

Standards

Standard

Title

ITU-T G.991.2

Single-pair high-speed digital subscriber line (SHDSL) transceivers

ANSI T1.413 issue 2

ADSL features

ITU 992.1

G.DMT

MIBs

MIB

MIBs Link

  • None

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC

Title

None

--

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for 1-Port ADSL WAN Interface Card

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for 1-Port ADSL WAN Interface Card

Feature Name

Releases

Feature Information

1-Port ADSL WAN Interface Card

12.1(3)XJ 12.1(5)YB 12.2(2)T 12.2(4)T

This feature is supported on Cisco 2600 series and Cisco 3600 series routers.

The following commands were introduced or modified: show diag, show dsl interface atm.

Glossary

ABR--available bit rate.

ADSL--asymmetric digital subscriber line (ADSL) available through several telecommunications carriers to accommodate the need for increased bandwidth for Internet access and telecommuting applications.

ATM --Asynchronous Transfer Mode. International standard for cell relay in which multiple service types (such as voice, video, or data) are conveyed in fixed-length (53-byte) cells. Fixed-length cells allow cell processing to occur in hardware, thereby reducing transit delays. ATM is designed to take advantage of high-speed transmission media such as E3, SONET, and T3.

CLI--command line interface.

CO--central office, or local exchange (local switch), which terminates individual local telephone subscriber lines for switching, and connects to the public network. Known as a class 5 switch office. For example, 5ESS by Lucent and DMS 100 by Nortel.

CPE--customer premise equipment, including devices such as channel service units (CSUs)/data service units (DSUs), modems, and ISDN terminal adapters, required to provide an electromagnetic termination for wide-area network circuits before connecting to the router or access server. This equipment was historically provided by the telephone company, but is now typically provided by the customer in North American markets.

DSL--digital subscriber line available through several telecommunications carriers to accommodate the need for increased bandwidth for Internet access and telecommuting applications.

FXO--foreign exchange office. A FXO interface connects to a central office.

FXS--foreign exchange station: A FXS interface connects directly to a standard telephone, supplying ring voltage, dial tone, etc.

G.SHDSL--multirate symmetrical high-speed digital subscriber line.

PVC--permanent virtual circuit.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2011 Cisco Systems, Inc. All rights reserved.