Application Visibility and Control Configuration Guide, Cisco IOS XE Release 3S (Cisco ASR 1000)
Easy Performance Monitor
Downloads: This chapterpdf (PDF - 386.0KB) | Feedback

Easy Performance Monitor

Table Of Contents

Easy Performance Monitor

Finding Feature Information

Contents

Information About Easy Performance Monitor

Easy Performance Monitor

Profile

Traffic Monitor

Context

How to Configure Easy Performance Monitor

Configuring Easy Performance Monitor

Verifying Easy Performance Monitor Configuration

Verifying Configuration

Verifying Profile

Verifying Context

Debugging Easy Performance Monitor Configuration

Debugging Context

Debugging Profile

Troubleshooting Easy Performance Monitor

Configuration Examples for Configuring Easy Performance Monitor

Example: Configuring a Performance Monitor Context with Default ART, Media, and URL Traffic Monitors

Example: Configuring a Performance Monitor Context With Media Traffic Monitor for Ipv6 Ingress and IPv4 Egress

Example: Configuring a Performance Monitor Context on Multiple Interfaces

Example: Verifying the Complete Configuration for a Performance Monitor Context

Additional References

Related Documents

Technical Assistance

Feature Information for Easy Performance Monitor


Easy Performance Monitor


First Published: July 30, 2013

The Easy Performance Monitor chapter describes how to configure Easy Performance Monitor (ezPM) for Application Visibility and Control (AVC).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Easy Performance Monitor" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Information About Easy Performance Monitor

How to Configure Easy Performance Monitor

Verifying Easy Performance Monitor Configuration

Debugging Easy Performance Monitor Configuration

Troubleshooting Easy Performance Monitor

Configuration Examples for Configuring Easy Performance Monitor

Additional References

Feature Information for Easy Performance Monitor

Information About Easy Performance Monitor

Easy Performance Monitor

Profile

Traffic Monitor

Context

Easy Performance Monitor

The Easy Performance Monitor (Easy perf-mon or ezPM) feature provides an express method of provisioning monitors. This new mechanism adds functionality and does not affect the existing methods for provisioning monitors.

EzPM does not provide the full flexibility of the traditional perf-mon configuration model but provides `profiles' that represent typical deployment scenarios. On selecting a profile and specifying a few parameters, ezPM provides the remaining provisioning information.

With Cisco IOS XE Release 3.10S, the Easy perf-mon feature includes Application Experience profile which contains five monitors, namely, application-response-time, application-traffic-stats, conversation-traffic-stats, media, and url.

Profile

A profile is a pre-defined set of traffic monitors that can be enabled or disabled for a context. A profile also includes an exporter template. For Cisco IOS XE Release 3.10S, only the Application Experience profile is supported.

Traffic Monitor

A traffic monitor is a pre-defined performance monitor configuration that is used for collecting a set of metrics on a specific traffic. This is based on typical configuration that we recommend.

The following objects are defined for both IPv4 and IPv6, and optionally for ingress/egress traffic:

Perf-mon flow record

Match fields (including AOR indication if/where applicable)

Collect fields

Perf-mon flow monitor

Cache type

Cache size (factor that is adjusted per platform)

Cache timeout (active, inactive, and synchronized)

History size

Classification - definition of traffic that is monitored by the perf-mon flow monitor

Sampler - type and value

Each traffic monitor defines the parameters that can be modified. During configuring the traffic monitor, the CLI displays the keywords based on the parameters that can be modified.

Context

A context represents a performance monitor policy map that is attached to an interface in ingress and egress directions. A context contains the information about the traffic-monitor that has to be enabled. When a context is attached to an interface, two policy-maps are created, one each in ingress and egress directions. Depending on the direction specified in the traffic monitor, the policy-maps are attached in that direction and the traffic is monitored. You can modify the context to override pre-defined directions.

You can create multiple contexts based on a single profile with different traffic monitors, different exporters, and different parameters for every selected traffic monitor.

An ezPM context can be attached to multiple interfaces. Only one context can be attached to an interface.

You can modify the ezPM context only when the context is not attached to an interface. To detach the context from an interface, use the no performance monitor context context-name command.

How to Configure Easy Performance Monitor

Configuring Easy Performance Monitor

Configuring Easy Performance Monitor

SUMMARY STEPS

1. enable

2. configure terminal

3. performance monitor context context-name profile application-experience

4. exporter destination {hostname | ipaddress} source interface interface-type number [port port-value transport udp vrf vrf-name]

5. (Optional) Repeat Step 4 to configure additional exporters.

6. traffic monitor {application-response-time | application-traffic-stats | conversation-traffic-stats | media [egress | ingress] | url} [[cache-size max-entries] | [class-and class-name] | ipv4 | ipv6]

7. Repeat Step 6 to configure additional traffic monitor parameters.

8. exit

9. interface interface-type number

10. performance monitor context context-name

11. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Device> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3 

performance monitor context context-name profile application-experience

Example:

Device(config)# performance monitor context perf-mon-test profile application-experience

Enters performance monitor configuration mode, creates a context with application-experience profile.

Step 4 

exporter destination {hostname | ipaddress} source interface interface-type number [port port-value transport udp vrf vrf-name]

Example:

Device(config-perf-mon)# exporter destination 10.1.1.1 source interface GigabitEthernet0/0/0 port 1 transport udp vrf vpn1

Attaches the exporter to the context and configures exporter parameters.

Step 5 

(Optional) Repeat Step 4 to configure each exporter.

Step 6 

traffic monitor {application-response-time | application-traffic-stats | conversation-traffic-stats | media [egress | ingress] | url} [[cache-size max-entries] | [class-and class-name] | ipv4 | ipv6]

Example:

Device(config-perf-mon)# traffic monitor media egress cache-size 70 class-and cln ipv6

Configures the traffic monitor to monitor the specified metrics.

Step 7 

Repeat Step 6 to configure each traffic monitor parameter.

Step 8 

exit

Example:

Device(config-perf-mon)# exit

Exits performance monitor configuration mode and enters global configuration mode.

Step 9 

interface interface-type number

Example:

Device(config)# interface gigabitethernet 0/1/0

Enters interface configuration mode.

Step 10 

performance monitor context context-name

Example:

Device(config-if)# performance monitor context perf-mon-test

Configures the specified performance monitor context on the interface.

Step 11 

exit

Example:

Device(config-perf-mon)# exit

Exits interface configuration mode and enters global configuration mode.

Verifying Easy Performance Monitor Configuration

All show commands related to a context are active only when the context is attached to a minimum one interface.

Verifying Configuration

Verifying Profile

Verifying Context

Verifying Configuration

Command
Description

show running-configuration performance-monitor context

Displays ezPM configuration of the specified context. If a context name is not specified, all contexts are displayed.


Verifying Profile

Command
Description

show performance monitor profile profile-name

Displays profile information of all traffic monitors available and the active status of traffic monitors.

show performance monitor profile profile-name traffic-monitor traffic-monitor-name

Displays profile information such as records, monitors, and default classification for a specific traffic monitor.


Verifying Context

Command
Description

show performance-monitor context context-name configuration

Displays all configuration of the specified context. This command can be used to convert the auto configuration to the traditional configuration.

show performance-monitor context context-name summary

Displays the information about the enabled traffic monitors and the interfaces to which they are attached.

show performance-monitor context context-name interface interface-name

Displays the information about the performance monitor interface. The output is the same as the show policy-map type performance-monitor interface command.

show performance-monitor context context-name traffic-monitor traffic-monitor-name cache

Displays performance monitor cache information. The output is similar to performance-monitor cache.

show performance-monitor context context-name traffic-monitor traffic-monitor-name history

Displays performance monitor history information. The output is similar to performance-monitor history.

show performance-monitor context context-name traffic-monitor traffic-monitor-name aggregate

Displays performance monitor aggregate information. The output is similar to performance-monitor aggregate.

show performance-monitor context context-name exporter

Displays the operational information about the exporters attached to the specified context.


Debugging Easy Performance Monitor Configuration

Debugging Context

Debugging Profile

Debugging Context

Command
Description

debug performance monitor context info

Debug context information.

debug performance monitor context error

Debug context error.


Debugging Profile

Command
Description

debug performance monitor profile info

Debug profile information.

debug performance monitor profile error

Debug profile error.


Troubleshooting Easy Performance Monitor

If no records are exported, you can use the show performance monitor context context-name traffic-monitor traffic-monitor-name cache command to check if any records exist in the cache after the traffic is sent. The output displays any records that changed from current entries to flow-aged status on reaching the cache timeout. To see the records in the cache, use the show performance monitor cache detail command.

If no records are added to the cache, you can use the show performance monitor context context-name interface interface-name command to check if the class-maps that originated automatically by ezPM are receiving the packets.

Use the show performance monitor context context-name configuration command to verify the configuration that originated from ezPM. See Configuration Examples for Configuring Easy Performance Monitor

Configuration Examples for Configuring Easy Performance Monitor

Example: Configuring a Performance Monitor Context with Default ART, Media, and URL Traffic Monitors

Example: Configuring a Performance Monitor Context With Media Traffic Monitor for Ipv6 Ingress and IPv4 Egress

Example: Configuring a Performance Monitor Context on Multiple Interfaces

Example: Verifying the Complete Configuration for a Performance Monitor Context

Example: Configuring a Performance Monitor Context with Default ART, Media, and URL Traffic Monitors

The following example shows how to configure a performance monitor context to monitor the traffic metrics for ART, media, and URL:

Device# configure terminal
Device(config)# performance monitor context perf-mon-test profile application-experience
Device(config-perf-mon)# exporter destination 10.10.1.1 source interface 
GigabitEthernet0/0/0 port 15 transport udp vrf in-vrf
Device(config-perf-mon)# traffic monitor application-response-time 
Device(config-perf-mon)# traffic monitor media 
Device(config-perf-mon)# traffic monitor url
Device(config-perf-mon)# exit
Device(config)# interface gigabitethernet 0/1/0
Device(config-if)# performance monitor context perf-mon-test
Device(config-if)# exit

Example: Configuring a Performance Monitor Context With Media Traffic Monitor for Ipv6 Ingress and IPv4 Egress

The following example shows how to configure a performance monitor context with traffic monitor enabling the media metrics for ipv6 traffic in ingress and ipv4 traffic in egress:

Device# configure terminal
Device(config)# performance monitor context perf-mon-test profile application-experience
Device(config-perf-mon)# exporter destination 10.10.1.1 source interface 
GigabitEthernet0/0/0 port 15 transport udp vrf in-vrf
Device(config-perf-mon)# traffic monitor meida ingress ipv6
Device(config-perf-mon)# traffic monitor media egress ipv4
Device(config-perf-mon)# exit
Device(config)# interface gigabitethernet 0/1/0
Device(config-if)# performance monitor context perf-mon-test
Device(config-if)# exit

Example: Configuring a Performance Monitor Context on Multiple Interfaces

The following example shows how to configure a performance monitor context on multiple interfaces:

Device# configure terminal
Device(config)# interface gigabitethernet 0/1/0
Device(config-if)# performance monitor context perf-mon-test
Device(config-if)# exit
Device(config)# interface gigabitethernet 0/2/0
Device(config-if)# performance monitor context perf-mon-test
Device(config-if)# exit

Example: Verifying the Complete Configuration for a Performance Monitor Context

The following example shows the complete underlying configuration of a performance monitor context that uses all traffic monitors. This configuration demonstrates how ezPM builds the configuration by applying the Application Experience profile definition to the context.

Device(config)# show running-config performance monitor context reference
 
   
!
performance monitor context reference profile application-experience
exporter destination 5.4.3.2 source Ethernet0/0.1 
 traffic-monitor all
!
Device# show performance monitor context reference configuration 
!===============================================================================
!                 Equivalent Configuration of Context reference                !
!===============================================================================
!Exporters
!==========
!
flow exporter reference-1
description performance monitor context reference exporter
destination 5.4.3.2
source Ethernet0/0.1
transport udp 4739
export-protocol ipfix
template data timeout 300
option c3pl-class-table timeout 300
option c3pl-policy-table timeout 300
option interface-table timeout 300
option vrf-table timeout 300
option sampler-table timeout 300
option application-table timeout 300
option application-attributes timeout 300
option sub-application-table timeout 300
!
!Access Lists
!=============
ip access-list extended reference-conv_ipv4_tcp
permit tcp any any
!
ipv6 access-list reference-conv_ipv6_tcp
permit tcp any any
!
ip access-list extended reference-conv_ipv4_udp
permit udp any any
!
ipv6 access-list reference-conv_ipv6_udp
permit udp any any
!
ip access-list extended reference-art_ipv4_tcp
permit tcp any any
!
ipv6 access-list reference-art_ipv6_tcp
permit tcp any any
!
ip access-list extended reference-media_ipv4_udp
permit udp any any
!
ipv6 access-list reference-media_ipv6_udp
permit udp any any
!
ip access-list extended reference-url_ipv4_tcp
permit tcp any any
!
ipv6 access-list reference-url_ipv6_tcp
permit tcp any any
!
!Class-maps
!===========
class-map match-any reference-app_ts
match protocol dns
match protocol dht
!
class-map match-any reference-conv_ts_ipv4
match access-group name reference-conv_ipv4_tcp
match access-group name reference-conv_ipv4_udp
!
class-map match-any reference-conv_ts_ipv6
match access-group name reference-conv_ipv6_tcp
match access-group name reference-conv_ipv6_udp
!
class-map match-all reference-art_ipv4
match access-group name reference-art_ipv4_tcp
!
class-map match-all reference-art_ipv6
match access-group name reference-art_ipv6_tcp
!
class-map match-any reference-media_app
match protocol telepresence-media
match protocol rtp
!
class-map match-all reference-media_ipv4_in
match access-group name reference-media_ipv4_udp
match class-map reference-media_app
!
class-map match-all reference-media_ipv4_out
match access-group name reference-media_ipv4_udp
match class-map reference-media_app
!
class-map match-all reference-media_ipv6_in
match access-group name reference-media_ipv6_udp
match class-map reference-media_app
!
class-map match-all reference-media_ipv6_out
match access-group name reference-media_ipv6_udp
match class-map reference-media_app
!
class-map match-any reference-url_app
match protocol napster
match protocol gotomypc
match protocol yahoo-messenger
match protocol tunnel-http
match protocol baidu-movie
match protocol flashmyspace
match protocol directconnect
match protocol audio-over-http
match protocol skype
match protocol video-over-http
match protocol pando
match protocol flashyahoo
match protocol msn-messenger
match protocol flash-video
match protocol webthunder
match protocol vnc-http
match protocol activesync
match protocol irc
match protocol realmedia
match protocol gmail
match protocol google-earth
match protocol gnutella
match protocol rtmpt
match protocol http
match protocol ms-update
match protocol rtsp
match protocol http-alt
match protocol share-point
match protocol binary-over-http
match protocol ms-sms
match protocol megavideo
!
class-map match-all reference-url_ipv4
match access-group name reference-url_ipv4_tcp
match class-map reference-url_app
!
class-map match-all reference-url_ipv6
match access-group name reference-url_ipv6_tcp
match class-map reference-url_app
!
class-map match-all reference-art_url_ipv4
match class-map reference-art_ipv4
match class-map reference-url_ipv4
!
class-map match-all reference-art_url_ipv6
match class-map reference-art_ipv6
match class-map reference-url_ipv6
!
!Samplers
!=========
!Records and Monitors
!=====================
!
flow record type performance-monitor reference-app_ts_in
description ezPM record
match routing vrf input
match ipv4 version
match ipv4 protocol
match interface input
match flow direction
match application name account-on-resolution
collect ipv4 dscp
collect interface output
collect counter bytes long
collect counter packets
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
!
!
flow monitor type performance-monitor reference-app_ts_in
record reference-app_ts_in
exporter reference-1
cache entries 1000
cache timeout synchronized 60
!
!
flow record type performance-monitor reference-app_ts_out
description ezPM record
match routing vrf input
match ipv4 version
match ipv4 protocol
match interface output
match flow direction
match application name account-on-resolution
collect ipv4 dscp
collect interface input
collect counter bytes long
collect counter packets
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
!
!
flow monitor type performance-monitor reference-app_ts_out
record reference-app_ts_out
exporter reference-1
cache entries 1000
cache timeout synchronized 60
!
!
flow record type performance-monitor reference-conv_ts_ipv4
description ezPM record
match routing vrf input
match ipv4 protocol
match application name account-on-resolution
match connection client ipv4 address
match connection server ipv4 address
match connection server transport port
collect ipv4 dscp
collect ipv4 ttl
collect interface input
collect interface output
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
collect connection server counter bytes long
collect connection server counter packets long
collect connection client counter bytes long
collect connection client counter packets long
!
!
flow monitor type performance-monitor reference-conv_ts_ipv4
record reference-conv_ts_ipv4
exporter reference-1
cache entries 6250
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-conv_ts_ipv6
description ezPM record
match routing vrf input
match ipv6 protocol
match application name account-on-resolution
match connection client ipv6 address
match connection server transport port
match connection server ipv6 address
collect ipv6 dscp
collect ipv6 hop-limit
collect interface input
collect interface output
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
collect connection server counter bytes long
collect connection server counter packets long
collect connection client counter bytes long
collect connection client counter packets long
!
!
flow monitor type performance-monitor reference-conv_ts_ipv6
record reference-conv_ts_ipv6
exporter reference-1
cache entries 6250
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-art_ipv4
description ezPM record
match routing vrf input
match ipv4 protocol
match application name account-on-resolution
match connection client ipv4 address
match connection server ipv4 address
match connection server transport port
collect ipv4 dscp
collect ipv4 ttl
collect interface input
collect interface output
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
collect connection delay response to-server sum
collect connection server counter responses
collect connection delay response to-server histogram late
collect connection delay network to-server sum
collect connection delay network to-client sum
collect connection client counter packets retransmitted
collect connection delay network client-to-server sum
collect connection delay application sum
collect connection delay application max
collect connection delay response client-to-server sum
collect connection transaction duration sum
collect connection transaction counter complete
collect connection server counter bytes long
collect connection server counter packets long
collect connection client counter bytes long
collect connection client counter packets long
!
!
flow monitor type performance-monitor reference-art_ipv4
record reference-art_ipv4
exporter reference-1
cache entries 2250
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-art_ipv6
description ezPM record
match routing vrf input
match ipv6 protocol
match application name account-on-resolution
match connection client ipv6 address
match connection server transport port
match connection server ipv6 address
collect ipv6 dscp
collect ipv6 hop-limit
collect interface input
collect interface output
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
collect connection delay response to-server sum
collect connection server counter responses
collect connection delay response to-server histogram late
collect connection delay network to-server sum
collect connection delay network to-client sum
collect connection client counter packets retransmitted
collect connection delay network client-to-server sum
collect connection delay application sum
collect connection delay application max
collect connection delay response client-to-server sum
collect connection transaction duration sum
collect connection transaction counter complete
collect connection server counter bytes long
collect connection server counter packets long
collect connection client counter bytes long
collect connection client counter packets long
!
!
flow monitor type performance-monitor reference-art_ipv6
record reference-art_ipv6
exporter reference-1
cache entries 2250
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-media_ipv4_in
description ezPM record
match routing vrf input
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match transport rtp ssrc
match interface input
collect ipv4 dscp
collect ipv4 ttl
collect transport packets lost counter
collect transport rtp jitter maximum
collect interface output
collect counter bytes long
collect counter packets
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect application name
collect connection new-connections
collect transport rtp payload-type
collect transport rtp jitter mean sum
!
!
flow monitor type performance-monitor reference-media_ipv4_in
record reference-media_ipv4_in
exporter reference-1
cache entries 4000
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-media_ipv6_in
description ezPM record
match routing vrf input
match ipv6 protocol
match ipv6 source address
match ipv6 destination address
match transport source-port
match transport destination-port
match transport rtp ssrc
match interface input
collect ipv6 dscp
collect ipv6 hop-limit
collect transport packets lost counter
collect transport rtp jitter maximum
collect interface output
collect counter bytes long
collect counter packets
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect application name
collect connection new-connections
collect transport rtp payload-type
collect transport rtp jitter mean sum
!
!
flow monitor type performance-monitor reference-media_ipv6_in
record reference-media_ipv6_in
exporter reference-1
cache entries 4000
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-media_ipv4_out
description ezPM record
match routing vrf input
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match transport rtp ssrc
match interface output
collect ipv4 dscp
collect ipv4 ttl
collect transport packets lost counter
collect transport rtp jitter maximum
collect interface input
collect counter bytes long
collect counter packets
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect application name
collect connection new-connections
collect transport rtp payload-type
collect transport rtp jitter mean sum
!
!
flow monitor type performance-monitor reference-media_ipv4_out
record reference-media_ipv4_out
exporter reference-1
cache entries 4000
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-media_ipv6_out
description ezPM record
match routing vrf input
match ipv6 protocol
match ipv6 source address
match ipv6 destination address
match transport source-port
match transport destination-port
match transport rtp ssrc
match interface output
collect ipv6 dscp
collect ipv6 hop-limit
collect transport packets lost counter
collect transport rtp jitter maximum
collect interface input
collect counter bytes long
collect counter packets
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect application name
collect connection new-connections
collect transport rtp payload-type
collect transport rtp jitter mean sum
!
!
flow monitor type performance-monitor reference-media_ipv6_out
record reference-media_ipv6_out
exporter reference-1
cache entries 4000
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-url_ipv4
description ezPM record
match routing vrf input
match ipv4 protocol
match application name account-on-resolution
match connection client ipv4 address
match connection server ipv4 address
match connection server transport port
collect ipv4 dscp
collect ipv4 ttl
collect interface input
collect interface output
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
collect application http uri statistics
collect connection delay response to-server sum
collect connection server counter responses
collect connection delay response to-server histogram late
collect connection delay network to-server sum
collect connection delay network to-client sum
collect connection client counter packets retransmitted
collect connection delay network client-to-server sum
collect connection delay application sum
collect connection delay application max
collect connection delay response client-to-server sum
collect connection transaction duration sum
collect connection transaction counter complete
collect connection server counter bytes long
collect connection server counter packets long
collect connection client counter bytes long
collect connection client counter packets long
collect application http host
!
!
flow monitor type performance-monitor reference-url_ipv4
record reference-url_ipv4
exporter reference-1
cache entries 1000
cache timeout synchronized 60 export-spread 15
!
!
flow record type performance-monitor reference-url_ipv6
description ezPM record
match routing vrf input
match ipv6 protocol
match application name account-on-resolution
match connection client ipv6 address
match connection server transport port
match connection server ipv6 address
collect ipv6 dscp
collect ipv6 hop-limit
collect interface input
collect interface output
collect timestamp sys-uptime first
collect timestamp sys-uptime last
collect connection new-connections
collect connection sum-duration
collect application http uri statistics
collect connection delay response to-server sum
collect connection server counter responses
collect connection delay response to-server histogram late
collect connection delay network to-server sum
collect connection delay network to-client sum
collect connection client counter packets retransmitted
collect connection delay network client-to-server sum
collect connection delay application sum
collect connection delay application max
collect connection delay response client-to-server sum
collect connection transaction duration sum
collect connection transaction counter complete
collect connection server counter bytes long
collect connection server counter packets long
collect connection client counter bytes long
collect connection client counter packets long
collect application http host
!
!
flow monitor type performance-monitor reference-url_ipv6
record reference-url_ipv6
exporter reference-1
cache entries 1000
cache timeout synchronized 60 export-spread 15
!
!Policy-maps
!============
policy-map type performance-monitor reference-in
parameter default account-on-resolution
class reference-app_ts
  flow monitor reference-app_ts_in
class reference-art_url_ipv4
  flow monitor reference-url_ipv4
class reference-art_url_ipv6
  flow monitor reference-url_ipv6
class reference-art_ipv4
  flow monitor reference-art_ipv4
class reference-art_ipv6
  flow monitor reference-art_ipv6
class reference-url_ipv4
  flow monitor reference-url_ipv4
class reference-url_ipv6
  flow monitor reference-url_ipv6
class reference-media_ipv4_in
  flow monitor reference-media_ipv4_in
class reference-media_ipv6_in
  flow monitor reference-media_ipv6_in
class reference-conv_ts_ipv4
  flow monitor reference-conv_ts_ipv4
class reference-conv_ts_ipv6
  flow monitor reference-conv_ts_ipv6
!
policy-map type performance-monitor reference-out
parameter default account-on-resolution
class reference-app_ts
  flow monitor reference-app_ts_out
class reference-art_url_ipv4
  flow monitor reference-url_ipv4
class reference-art_url_ipv6
  flow monitor reference-url_ipv6
class reference-art_ipv4
  flow monitor reference-art_ipv4
class reference-art_ipv6
  flow monitor reference-art_ipv6
class reference-url_ipv4
  flow monitor reference-url_ipv4
class reference-url_ipv6
  flow monitor reference-url_ipv6
class reference-media_ipv4_out
  flow monitor reference-media_ipv4_out
class reference-media_ipv6_out
  flow monitor reference-media_ipv6_out
class reference-conv_ts_ipv4
  flow monitor reference-conv_ts_ipv4
class reference-conv_ts_ipv6
  flow monitor reference-conv_ts_ipv6
!
!Interface Attachments
!======================
interface Ethernet0/0
service-policy type performance-monitor input reference-in
service-policy type performance-monitor output reference-out
!

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for Easy Performance Monitor

Table 1 lists the release history for this feature.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 1 Feature Information for Easy Performance Monitor 

Feature Name
Releases
Feature Information

Easy Performance Monitor

Cisco IOS XE Release 3.10S

This feature was introduced.