Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide
Configuring the 4-Port Serial Interface SPA
Downloads: This chapterpdf (PDF - 630.0KB) The complete bookPDF (PDF - 13.93MB) | Feedback

Table of Contents

Configuring the 4-Port Serial Interface SPA

Configuration Tasks

Configuring the 4-Port Serial Interface SPA

Specifying the Interface Address on a SPA

Verifying the Configuration

Show Commands

Using the ping Command to Verify Network Connectivity

Using loopback Commands

Optional Configurations

Configuring Timing Signals

Inverting the Clock Signal

Configuring NRZI Format

Configuring Cyclic Redundancy Checks

Configuring Encapsulation

Configuring Distributed Multilink PPP

Configuring MLFR

Configuring Multipoint Bridging

Configuring Bridging Control Protocol Support

Configuring BCP on MLPPP

FRF.12 Guidelines

LFI Guidelines

FRF.12 LFI Guidelines

Saving the Configuration

Verifying the Interface Configuration

Verifying Per-Port Interface Status

Configuration Examples

Inverting the Clock Signal Configuration Example

NRZI Format Configuration Example

Cyclic Redundancy Checks Configuration Example

Encapsulation Configuration Example

Distributed Multilink PPP Configuration Example

MLFR Configuration Example

Bridging Control Protocol Support Configuration Example

BCP on MLPPP Configuration Example

Configuring the 4-Port Serial Interface SPA

This chapter provides information about configuring the 4-Port Serial Interface Shared Port Adapter (SPA) on the Cisco 7600 series router. It includes the following sections:

For information about managing your system images and configuration files, refer to the Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.2 and Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 publications.

For more information about the commands used in this chapter, refer to the Cisco IOS Software Releases 15.0SR Command References and to the Cisco IOS Software Releases 12.2SX Command References . Also refer to the related Cisco IOS Release 12.2 software command reference and master index publications. For more information, see the “$paratext>” section.

Configuration Tasks

This section describes how to configure the 4-Port Serial Interface SPA for the Cisco 7600 series router and includes information about verifying the configuration.

It includes the following topics:

Configuring the 4-Port Serial Interface SPA

To configure the 4-Port Serial Interface SPA, complete these steps:

 

Command
Purpose

Step 1

Router# configure terminal

Enters global configuration mode.

Step 2

Router(config)# interface serial slot/subslot/port

Selects the controller to configure and enters interface configuration mode.

Step 3

Router(config-if)# ip address address mask

Sets the IP address and subnet mask.

  • address—IP address
  • mask—Subnet mask

Step 4

Router(config-if)# clock rate bps

Configures the clock rate for the hardware to an acceptable bit rate per second (bps).


NoteEach port should first be connected with the appropriate cable before attempting full configuration. Some commands are enabled only based upon the cable type connected to the port.



NoteThe bandwidth of each interface is 2 MB by default; setting the clock rate does not change the interface bandwidth. Cisco recommends that you configure the bandwidth value with the clock rate command at the DCE and DTE side.



NoteA clock rate of 2016 does not appear in the configuration because it is the default value.


Specifying the Interface Address on a SPA

SPA interface ports begin numbering with “0” from left to right. Single-port SPAs use only the port number 0. To configure or monitor SPA interfaces, you need to specify the physical location of the SIP, SPA, and interface in the CLI (command-line-interface). The interface address format is slot / subslot / port , where:

  • slot —Specifies the chassis slot number in the Cisco 7600 series router where the SIP is installed.
  • subslot —Specifies the secondary slot of the SIP where the SPA is installed.
  • port —Specifies the number of the individual interface port on a SPA.

The following example shows how to specify the first interface (0) on a SPA installed in the first subslot of a SIP (0) installed in chassis slot 3:

Router(config)# interface serial 3/0/0
 

For more information about identifying slots and subslots, see the “Identifying Slots and Subslots for SIPs, SSCs, and SPAs” section.

Verifying the Configuration

After configuring the new interface, use the show commands to display the status of the new interface or all interfaces, and use the ping and loopback commands to check connectivity. This section includes the following subsections:

Show Commands

The table below shows the show commands you can use to verify the operation of the 4-Port Serial Interface SPA. Sample displays of the output of selected show commands appear in the section that follows. For complete command descriptions and examples, refer to the publications listed in the “$paratext>” section.


NoteThe outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


 

Command
Purpose
Router# show version
or
Router# show hardware

Displays system hardware configuration, the number of each interface type installed, Cisco IOS software version, names and sources of configuration files, and boot images.

Router# show controllers

Displays all the current interface processors and their interfaces.

Router# show controllers serial

Displays serial line statistics.

Router# show diagbus slot

Displays types of port adapters installed in your system and information about a specific port adapter slot, interface processor slot, or chassis slot.

Router# show interfaces type port-adapter-slot-number/
interface-port-number

Displays status information about a specific type of interface (for example, serial) in a Cisco 7600 series router.

Router# show protocols

Displays protocols configured for the entire system and for specific interfaces.

Router# show running-config

Displays the running configuration file.

Router# show startup-config

Displays the configuration stored in NVRAM.

Verification Examples

The following is an example of a show version command with the 4-Port Serial Interface SPA:

Router# show version
Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9_DBG-M), Version 12.2(nightly.SR070910) NIGHTLY BUILD, synced to rainier RAINIER_BASE_FOR_V122_33_SRA_THROTTLE
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 10-Sep-07 22:48 by cuotran
 
ROM: System Bootstrap, Version 12.2(17r)S2, RELEASE SOFTWARE (fc1)
 
PE1 uptime is 18 hours, 23 minutes
Uptime for this control processor is 18 hours, 23 minutes
System returned to ROM by reload at 13:30:48 IST Thu Sep 13 2007 (SP by reload)
System image file is "disk1:s72033-adventerprisek9_dbg-mz.autobahn76_091007"
Last reload type: Normal Reload
 
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
 
If you require further assistance please contact us by sending email to
export@cisco.com.
 
cisco WS-C6506 (R7000) processor (revision 3.0) with 983008K/65536K bytes of memory.
Processor board ID TBM06330552
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from power-on
2 SIP-200 controllers (8 Serial)(2 ATM)(4 Channelized T3)(1 Channelized OC3/STM-1).
1 SIP-400 controller (1 POS)(2 Channelized OC3/STM-1).
2 Virtual Ethernet interfaces
74 Gigabit Ethernet interfaces
8 Serial interfaces
2 ATM interfaces
1 Packet over SONET interface
4 Channelized T3 ports
3 Channelized STM-1 ports
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.
 
65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102
 

The following is an example of a show hardware command with the 4-Port Serial Interface SPA:

Router# show hardware
Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9_DBG-M), Version 12.2(nightly.SR070910) NIGHTLY BUILD, synced to rainier RAINIER_BASE_FOR_V122_33_SRA_THROTTLE
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 10-Sep-07 22:48 by cuotran
 
ROM: System Bootstrap, Version 12.2(17r)S2, RELEASE SOFTWARE (fc1)
 
PE1 uptime is 18 hours, 23 minutes
Uptime for this control processor is 18 hours, 23 minutes
System returned to ROM by reload at 13:30:48 IST Thu Sep 13 2007 (SP by reload)
System image file is "disk1:s72033-adventerprisek9_dbg-mz.autobahn76_091007"
Last reload type: Normal Reload
 
 
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
 
If you require further assistance please contact us by sending email to
export@cisco.com.
 
cisco WS-C6506 (R7000) processor (revision 3.0) with 983008K/65536K bytes of memory.
Processor board ID TBM06330552
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from power-on
2 SIP-200 controllers (8 Serial)(2 ATM)(4 Channelized T3)(1 Channelized OC3/STM-1).
1 SIP-400 controller (1 POS)(2 Channelized OC3/STM-1).
2 Virtual Ethernet interfaces
74 Gigabit Ethernet interfaces
8 Serial interfaces
2 ATM interfaces
1 Packet over SONET interface
4 Channelized T3 ports
3 Channelized STM-1 ports
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.
 
65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102
 

The following is an example of a show controllers serial command with the 4-Port Serial Interface SPA:

Router# show controller serial 3/1/1
 
Serial3/1/1 - (SPA-4XT-SERIAL) is up
Encapsulation : Frame Relay
Cable type: RS-232 DTE
mtu 1500, max_buffer_size 1524, max_pak_size 1608 enc 84
loopback: Off, crc: 16, invert_data: Off
nrzi: Off, idle char: Flag
tx_invert_clk: Off, ignore_dcd: Off
rx_clockrate: 552216, rx_clock_threshold: 0
serial_restartdelay:60000, serial_restartdelay_def:60000
 
RTS up, CTS up, DTR up, DCD up, DSR up

NoteThe acronyms are defined as follows: RTS (Request to Send); CTS (Clear To Send); DTR (Data Transmit Ready); DCD (Data Carrier Detect); DSR (Data Set Ready).


The following is an example of a show diagbus command with the 4-Port Serial Interface SPA:

Router# show diagbus 4
Slot 4: Logical_index 8
4-subslot SPA Interface Processor-200 controller
Board is analyzed ipc ready
HW rev 1.1, board revision A0
Serial Number: JAB0929078S Part number: 73-8272-08
 
Slot database information:
Flags: 0x2004 Insertion time: 0x2DC096C4 (07:47:58 ago)
 
Controller Memory Size:
384 MBytes CPU Memory
127 MBytes Packet Memory
511 MBytes Total on Board SDRAM
Cisco IOS Software, cwlc Software (sip1-DW-M), Version 12.2(nightly.SR070820) NIGHTLY BUILD, synced to rainier RAINIER_BASE_FOR
 
SPA Information:
subslot 4/0: SPA-4XT-SERIAL (0x55A), status: ok
 

The following is an example of a show interfaces serial command with the 4-Port Serial Interface SPA:

Router# show interfaces serial2/0/0
Serial 5/1/0 is up, line protocol is up
Hardware is SPA-4T
Internet address is 192.168.33.1/29
MTU 4470 bytes, BW 8000 Kbit, DLY 100 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive not set
Clock Source Internal.
Last input 00:00:01, output 00:00:00, output hang never
Last clearing of "show interface" counters 1h
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 parity
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 applique, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
 

The following are examples of the show protocol command with the 4-Port Serial Interface SPA:

Router# show protocol
Global values:
Internet Protocol routing is enabled
POS1/2/0 is up, line protocol is up
GigabitEthernet3/1 is down, line protocol is down
GigabitEthernet3/2 is administratively down, line protocol is down
GigabitEthernet3/3 is down, line protocol is down
GigabitEthernet3/4 is administratively down, line protocol is down
GigabitEthernet3/5 is administratively down, line protocol is down
GigabitEthernet3/6 is administratively down, line protocol is down
GigabitEthernet3/7 is up, line protocol is up
Internet address is 200.0.0.100/24
GigabitEthernet3/8 is administratively down, line protocol is down
GigabitEthernet3/9 is administratively down, line protocol is down
GigabitEthernet3/10 is administratively down, line protocol is down
GigabitEthernet3/11 is administratively down, line protocol is down
GigabitEthernet3/12 is administratively down, line protocol is down
GigabitEthernet3/13 is administratively down, line protocol is down
GigabitEthernet3/14 is administratively down, line protocol is down
GigabitEthernet3/15 is administratively down, line protocol is down
GigabitEthernet3/16 is administratively down, line protocol is down
GigabitEthernet3/17 is administratively down, line protocol is down
GigabitEthernet3/18 is administratively down, line protocol is down
GigabitEthernet3/19 is administratively down, line protocol is down
GigabitEthernet3/20 is administratively down, line protocol is down
GigabitEthernet3/21 is administratively down, line protocol is down
Router# show protocol | i Serial4/
Serial4/0/0 is administratively down, line protocol is down
Serial4/0/1 is administratively down, line protocol is down
Serial4/0/2 is administratively down, line protocol is down
Serial4/0/3 is administratively down, line protocol is down
Serial4/2/0 is administratively down, line protocol is down
Serial4/2/1 is administratively down, line protocol is down
Serial4/2/2 is administratively down, line protocol is down
Serial4/2/3 is administratively down, line protocol is down
 
The following is an example of a show running-config command with the 4-Port Serial Interface SPA:
 
Router# show running-config serial
Router# show running interface ser4/0/0
Building configuration...
 
Current configuration : 54 bytes
!
interface Serial4/0/0
no ip address
shutdown
end
 
The following is an example of a show running interface command with the 4-Port Serial Interface SPA:
 
Router# show running interface ser4/0/1
Building configuration...
 
Current configuration : 54 bytes
!
interface Serial4/0/1
no ip address
shutdown
end
 

The following is an example of a show startup-config command with the 4-Port Serial Interface SPA:

Router# show startup-config | b Serial4/0/0
interface Serial4/0/0
no ip address
shutdown
!
interface Serial4/0/1
no ip address
shutdown
!
interface Serial4/0/2
no ip address
shutdown
!
interface Serial4/0/3
no ip address
shutdown
!

Using the ping Command to Verify Network Connectivity

Using the ping command, you can verify that an interface port is functioning properly. This section provides a brief description of this command. Refer to the publications listed in the “$paratext>” section for detailed command descriptions and examples.

The ping command sends echo request packets out to a remote device at an IP address that you specify. After sending an echo request, the system waits a specified time for the remote device to reply. Each echo reply is displayed as an exclamation point (!) on the console terminal; each request that is not returned before the specified timeout is displayed as a period (.). A series of exclamation points (!!!!!) indicates a good connection; a series of periods (.....) or the messages [timed out] or [failed] indicate a bad connection.

Following is an example of a successful ping command to a remote server with the address 10.0.0.10:

Router# ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 10.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/64 ms
Router#
 

If the connection fails, verify that you have the correct IP address for the destination and that the device is active (powered on), and repeat the ping command.

Proceed to the next section, “Using loopback Commands,” to finish checking network connectivity.

Using loopback Commands

With the loopback test, you can detect and isolate equipment malfunctions by testing the connection between the 4-Port Serial Interface SPA and a remote device such as a modem or a channel service unit (CSU) or a data service unit (DSU). The loopback command places an interface in loopback mode, which enables test packets that are generated from the ping command to loop through a remote device or compact serial cable. If the packets complete the loop, the connection is good. If not, you can isolate a fault to the remote device or compact serial cable in the path of the loopback test.


NoteYou must configure a clock rate on the portbefore performing a loopback test. However, if no cable is attached to the port, the port is administratively up, and the port is in loopback mode; you do not have to configure a clock rate on the port before performing a loopback test.


Depending on the mode of the port, issuing the loopback command checks the following path:

  • When no compact serial cable is attached to the 4-Port Serial Interface SPA port, or if a data circuit-terminating equipment (DCE) cable is attached to a port that is configured as line protocol up, the loopback command tests the path between the network processing engine and the interface port only (without leaving the network processing engine and port adapter).
  • When a data terminal equipment (DTE) cable is attached to the port, the loopback command tests the path between the network processing engine and the near (network processing engine) side of the DSU or modem to test the 4-Port Serial Interface SPA and compact serial cable. (The X.21 DTE interface cable does not support this loopback test; see the following Note.)

NoteThe X.21 interface definition does not include a loopback definition. On the 4-Port Serial Interface SPA port adapter, the X.21 DTE interface does not support the loopback function. Because of the internal clock signal present on the 4-Port Serial Interface SPAs, loopback will function on an X.21 DCE interface.


This completes the configuration procedure for the new 4-Port Serial Interface SPA port adapter serial interfaces.

Configuring Timing Signals

All interfaces support both DTE and DCE mode, depending on the mode of the compact serial cable attached to the port. To use a port as a DTE interface, you need only connect a DTE compact serial cable to the port. When the system detects the DTE mode cable, it automatically uses the external timing signal. To use a port in DCE mode, you must connect a DCE compact serial cable and set the clock speed with the clock rate configuration command. You must also set the clock rate to perform a loopback test. This section describes how to set the clock rate on a DCE port and, if necessary, how to invert the clock to correct a phase shift between the data and clock signals.

Use the following commands when configuring timing signals:

 

Command
Purpose
Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial slot/subslot/port

Selects the controller to configure and enters interface configuration mode.

Router(config-if)# invert txclock

Invert the transmit clock signal. When the EIA/TIA-232 interface is a DTE, the invert txclock command inverts the TxC signal the DTE receives from the remote DCE. When the EIA/TIA-232 interface is a DCE, the invert txclock command inverts the clock signal to the remote DTE port.

The no form of this command changes the clock signal back to its original phase.

Router(config-if)#clock rate bps

Set standard clock rate, in bits per second: 1200, 2400, 4800,9600, 14400, 19200, 28800, 32000, 38400, 48000, 56000, 57600, 64000, 72000, 115200, 128000, 230400, 252000, 504000, 1008000, 2016000, 4032000, 8064000.

Any nonstandard clock rates that are entered are rounded off to the nearest hardware supported clock rate. The actual clock rate is then displayed on console.

The no form of this command removes a clock rate that has been set.

Router(config-if)# invert data

Invert the data signal.

The no form of this command disables the inversion of the data signal.


NoteClock rates supported for EIA/TIA-232: 1.2K, 2.4K, 4.8K, 9.6K, 14.4K, 19.2K, 28.8K, 32K, 38.4K, 56K, 64K, 128K.



NoteClock rates supported for EIA-530, EIA-530A, EIA-449, V.35(bps): 1.2K, 2.4K, 4.8K, 9.6K, 14.4K, 19.2K, 28.8K, 32K, 38.4K, 56K, 64K, 72K, 115.2K, 128k, 230.4k, 252K, 504k, 1.008M, 2.016M, 4.032M, 8.064M. The other ones are unconfigurable.



NoteClock rates supported for X.21: 1.2K, 2.4K, 4.8K, 9.6K, 14.4K, 19.2K, 28.8K, 32K, 38.4K, 56K, 64K, 72K, 115.2K, 128k, 230.4k, 252K, 504k, 2.016M, 4.032M, 8.064M.


Inverting the Clock Signal

Systems that use long cables or cables that are not transmitting the TxC (clock) signal might experience high error rates when operating at higher transmission speeds. If a SPA-4XT DCE port is reporting a high number of error packets, a phase shift might be the problem: inverting the clock might correct this phase shift.

When the EIA/TIA-232 interface is a DTE, the invert-transmit-clock command inverts the TxC signal the DTE receives from the remote DCE. When the EIA/TIA-232 interface is a DCE, the invert-txclock command inverts the clock signal to the remote DTE port. Use the no invert-txclock command to change the clock signal back to its original phase.

Use the following commands when inverting the clock signal:

 

Command
Purpose
Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial slot/subslot/port

Selects the controller to configure and enters interface configuration mode.

Router(config-if)# invert txclock

Invert the transmit clock signal. When the EIA/TIA-232 interface is a DTE, the invert txclock command inverts the TxC signal the DTE receives from the remote DCE. When the EIA/TIA-232 interface is a DCE, the invert txclock command inverts the clock signal to the remote DTE port.

The no version changes the clock signal back to its original phase.

Router(config-if)# invert data

Invert the data signal.

The no version of this command disables inverting the data stream.

Configuring NRZI Format

All EIA/TIA-232 interfaces on the SPA-4XT support non-return-to-zero (NRZ) and non-return-to-zero inverted (NRZI) formats. Both formats use two different voltage levels for transmission. NRZ signals maintain constant voltage levels with no signal transitions—no return to a zero voltage level—during a bit interval and are decoded using absolute values: 0 and 1. NRZI uses the same constant signal levels but interprets the absence of data—a space—at the beginning of a bit interval as a signal transition and the presence of data—a mark—as no signal transition. NRZI uses relational encoding to interpret signals rather than determining absolute values.

 

Command
Purpose
Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial slot/subslot/port

Selects the controller to configure and enters interface configuration mode.

nrzi-encoding

Enable NRZI encoding.

no nrzi-encoding

Disable NRZI encoding.

Configuring Cyclic Redundancy Checks

Cyclic redundancy checking (CRC) is an error-checking technique that uses a calculated numeric value to detect errors in transmitted data. All interfaces use a 16-bit CRC (CRC-CITT) by default but also support a 32-bit CRC. The sender of a data frame calculates the frame check sequence (FCS). Before it sends a frame, the sender appends the FCS value to the message. The receiver recalculates the FCS and compares its calculation to the FCS from the sender. If there is a difference between the two calculations, the receiver assumes that a transmission error occurred and sends a request to the sender to resend the frame.

 

Command
Purpose
Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial slot/subslot/port

Selects the controller to configure and enters interface configuration mode.

Router(config-if)# crc [16 | 32]

Specifies the length of the CRC, where:

  • 16—Specifies a 16-bit length CRC. This is the default.
  • 32—Specifies a 32-bit length CRC.

To set the CRC length to the default value, use the no form of this command.

In the example that follows, the first serial port on a 4-Port Serial Interface SPA, installed on a versatile interface processor (VIP) in interface processor slot 3, is configured for 32-bit CRC:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface serial 3/1/0
Router(config-int)# crc 32
Ctrl-Z
Router#
 

The preceding command example applies to all systems in which the 4-Port Serial Interface SPA is supported.
Use the no crc 32 command to disable CRC-32 and return the interface to the default CRC-16 (CRC-CITT) setting.

Configuring Encapsulation

When traffic crosses a WAN link, the connection needs a Layer 2 protocol to encapsulate traffic. To set the encapsulation method, use the following commands:

 

Command
Purpose
Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial slot/subslot/port

Selects the interface to configure and enters interface configuration mode.

slot/subslot/port—Specifies the location of the interface. Seethe “Specifying the Interface Address on a SPA” section.

Router(config-if)# encapsulation {hdlc | ppp | frame-relay}

Set the encapsulation method on the interface.

  • hdlc—High-Level Data Link Control (HDLC) protocol for serial interface. This is the default.
  • ppp—Point-to-Point Protocol (PPP) (for serial interface).
  • frame-relay—Frame Relay (for serial interface).

Verifying Encapsulation

Use the show interface serial command to display the encapsulation method:

Router# show interface serial3/1/1
 
Serial3/1/1 is up, line protocol is down
Hardware is SPA-4XT-SERIAL
MTU 1500 bytes, BW 2016 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, crc 16, loopback not set
Keepalive set (10 sec)
LMI enq sent 13698, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 1023 LMI type is CISCO frame relay DTE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input never, output 00:00:05, output hang never
Last clearing of "show interface" counters 1d14h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
19344 packets output, 254168 bytes, 0 underruns
0 output errors, 0 collisions, 2283 interface resets
0 output buffer failures, 0 output buffers swapped out
4566 carrier transitions
RTS up, CTS up, DTR up, DCD up, DSR up

Configuring Distributed Multilink PPP

The Distributed Multilink Point-to-Point Protocol (dMLPPP) feature allows you to combine serial lines into a bundle that has the combined bandwidth of the multiple lines. This is done by using a dMLPPP link. You choose the number of bundles and the number of serial lines in each bundle. This allows you to increase the bandwidth of your network links beyond that of a single serial line without having to purchase a bigger line.

This section includes the following topics:

dMLPPP Configuration Guidelines

dMLPPP is supported under the following conditions:

  • All links are on the same Cisco 7600 SIP-200.
  • Member links in a bundle are recommended to have the same bandwidth and clock rate.
  • Quality of Service (QoS) is implemented on the Cisco 7600 SIP-200 for dMLPPP.
  • Bundle links are configurable across the multilinkSPA.

Note Because the bundles are done in software, performance is dependent on the line card CPU.


  • To enable fragmentation for software-based dMLPPP, you must configure the ppp multilink interleave command.
  • You must use the ppp chap hostname command when you have more than one bundle between two routers.

When configuring dMLPPP on the Cisco 7600 SIP-200, consider the following restrictions:

  • Data compression is supported for RTP traffic only (dCRTP) .
  • Encryption is not supported.
  • The maximum differential delay is 100 ms when supported in software.

dMLPPP Configuration Tasks

The following sections describe how to configure dMLPPP:

 

Creating a dMLPPP Bundle

To configure a dMLPPP bundle, use the following commands beginning in global configuration mode:

 

Command
Purpose

Step 1

Router(config)# interface multilink group-number

Creates a multilink interface and enters interface configuration mode, where:

  • group-number—Specifies the group number for the multilink bundle.

Step 2

Router(config-if)# ip address ip-address mask

Sets the IP address for the multilink group, where:

  • ip-address —Specifies the IP address for the interface.
  • mask —Specifies the mask for the associated IP subnet.

Step 3

Router(config-if)# ppp multilink interleave

(Optional—Software-basedng link fragmentation and interleaving [LFI]) Enables fragmentation for the interfaces assigned to the multilink bundle. Fragmentation is disabled by default in software-based LFI.

Step 4

Router(config-if)# ppp multilink fragment-delay delay

(Optional) Sets the fragmentation size satisfying the configured delay on the multilink bundle, where:

  • delay —Specifies the delay in milliseconds.

Assigning an Interface to a dMLPPP Bundle

To configure an interface PPP link and associate it as a member of a multilink bundle, use the following commands beginning in global configuration mode. Repeat these steps to assign multiple links to the dMLPPP bundle.

 

Command
Purpose

Step 1

Router(config)# interface serial slot / subslot / port

Specifies a serial interface and enters interface configuration mode, where:

  • slot —Specifies the chassis slot number where the SIP is installed.
  • subslot —Specifies the secondary slot number on a SIP where a SPA is installed.
  • port —Specifies the number of the interface port on the SPA.

Note If you configure a fractional interface on the SPA using a channel group and specify that fractional channel group as part of this task, then software-based dMLPPP is implemented automatically by the Cisco 7600 SIP-200 when you assign the interface to the dMLPPP bundle.

Step 2

Router(config-if)# encapsulation ppp

Enables PPP encapsulation.

Step 3

Router(config-if)# ppp multilink-group group-number

Restricts a physical link to joining only a designated multilink group interface.

  • Enter the multilink group number.

Step 4

Router(config-if)# ppp authentication chap

(Optional) Enables Challenge Handshake Authentication Protocol (CHAP) authentication.

The following example uses the ppp chap hostname command.

Router(config)# interface Serial4/1/0
Router(config-if)# no ip address
Router(config-if)# encapsulation ppp
Router(config-if)# ppp chap hostname X1
Router(config-if)# ppp multilink group 1
end
 
Router(config-if)# ppp chap host
Router(config-if)# ppp chap hostname ?
WORD Alternate CHAP hostname
 
Router(config-if)# ppp chap hostname

Configuring LFI over dMLPPP

LFI over dMLPPP is supported in software on the Cisco 7600 SIP-200. This support is determined by your link configuration.

Guidelines

When configuring LFI over dMLPPP, consider the following guidelines for software-based LFI:

  • LFI over dMLPPP will be configured in software if there is more than one link assigned to the dMLPPP bundle.
  • LFI is disabled by default in software-based LFI. To enable LFI on the multilink interface, use the ppp multilink interleave command.
  • Fragmentation size is calculated from the delay configured and the member link bandwidth.
  • You must configure a policy map with a priority class under the multilink interface.
  • Compressed Real-Time Protocol (CRTP) should not be configured on a multilink interface when LFI is enabled on the multilink interface when the multilink bundle has more than one member link, or a QoS policy with a priority feature is enabled on the multilink interface.
  • Using the using the shut and no shut commands in interface configuration mode is required when configuring interleave on the multilink interface.

Verifying dMLPPP

To verify dMLPPP configuration, use the show ppp multilink command, as shown in the following example:

Router# show ppp multilink
 
Multilink1
Bundle name: X1
Remote Endpoint Discriminator: [1] X1
Local Endpoint Discriminator: [1] X1
Bundle up for 00:00:08, total bandwidth 4032, load 1/255
Receive buffer limit 24000 bytes, frag timeout 1000 ms
Bundle is Distributed
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x2 received sequence, 0x2 sent sequence
Member links: 2 active, 0 inactive (max not set, min not set)
Se4/1/0, since 00:00:10
Se4/1/1, since 00:00:07

Configuring MLFR

Multilink Frame Relay (MLFR) allows you to combine lines into a bundle that has the combined bandwidth of the multiple lines. You choose the number of bundles and the number of lines in each bundle. This allows you to increase the bandwidth of your network links beyond that of a single line.


NoteMLFR is not supported with 4-port serial SPA on Cisco 7600 SIP-400.


MLFR Configuration Guidelines

MLFR will function in hardware if all of the following conditions are met:

  • All links in the bundle are member links.
  • All links are on the same SPA.

Creating a Multilink Bundle

To create a multilink bundle, use the following commands:

 

Command
Purpose
Router# configure terminal

Enters global configuration mode.

Router(config)# interface mfr number

Configures a MLFR bundle interface.

  • number—The number for the MLFR bundle.
Router(config-if)# frame-relay multilink bid name

(Optional) Assigns a bundle identification name to a multilink Frame Relay bundle.

  • name—The name for the MLFR bundle.

Note The bundle identification (BID) will not go into effect until the interface has gone from the down state to the up state. One way to bring the interface down and back up again is by using the shut and no shut commands in interface configuration mode.

Assigning an Interface to a Multilink Bundle

To assign an interface to a multilink bundle, use the following commands:

 

Command
Purpose
Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial slot/ subslot/port:channel-group

Selects the interface to assign.

Router(config-if)# encapsulation frame-relay mfr number [name]

Creates a MLFR bundle link and associates the link with a bundle.

  • number—The number for the MLFR bundle.
  • name—(Optional) The name for the MLFR bundle.
Router(config-if)# frame-relay multilink lid name

(Optional) Assigns a bundle link identification name with a multilink Frame Relay bundle link.

  • name—The name for the Frame Relay bundle.

Note The bundle link identification (LID) will not go into effect until the interface has gone from the down state to the up state. One way to bring the interface down and back up again is by using the shut and no shut commands in interface configuration mode.

Router(config-if)# frame-relay multilink hello seconds

(Optional) Configures the interval at which a bundle link will send out hello messages. The default value is 10 seconds.

  • seconds—Number of seconds between hello messages sent out over the multilink bundle.
Router(config-if)# frame-relay multilink ack seconds

(Optional) Configures the number of seconds that a bundle link will wait for a hello message acknowledgment before resending the hello message. The default value is 4 seconds.

  • seconds—Number of seconds a bundle link will wait for a hello message acknowledgment before resending the hello message.
Router(config-if)# frame-relay multilink retry number

(Optional) Configures the maximum number of times a bundle link will resend a hello message while waiting for an acknowledgment. The default value is 2 tries.

  • number—Maximum number of times a bundle link will resend a hello message while waiting for an acknowledgment.

Verifying Multilink Frame Relay

Use the show frame-relay multilink detailed command to verify the Frame Relay multilinks:

Router# show frame-relay multilink detailed
Bundle: MFR49, State = down, class = A, fragmentation disabled
BID = MFR49
No. of bundle links = 1, Peer's bundle-id =
Bundle links:
 
Serial6/0/0, HW state = up, link state = Add_sent, LID = test
Cause code = none, Ack timer = 4, Hello timer = 10,
Max retry count = 2, Current count = 0,
Peer LID = , RTT = 0 ms
Statistics:
Add_link sent = 21, Add_link rcv'd = 0,
Add_link ack sent = 0, Add_link ack rcv'd = 0,
Add_link rej sent = 0, Add_link rej rcv'd = 0,
Remove_link sent = 0, Remove_link rcv'd = 0,
Remove_link_ack sent = 0, Remove_link_ack rcv'd = 0,
Hello sent = 0, Hello rcv'd = 0,
Hello_ack sent = 0, Hello_ack rcv'd = 0,
outgoing pak dropped = 0, incoming pak dropped = 0

Configuring Multipoint Bridging

Multipoint bridging (MPB) enables the connection of multiple ATM permanent virtual circuist( PVCs), Frame Relay PVCs, Bridge Control Protocol (BCP) ports, and WAN Gigabit Ethernet subinterfaces into a single broadcast domain (virtual LAN), together with the LAN ports on that VLAN. This enables service providers to add support for Ethernet-based Layer 2 services to the proven technology of their existing ATM and Frame Relay legacy networks. Customers can then use their current VLAN-based networks over the ATM or Frame Relay cloud. This also allows service providers to gradually update their core networks to the latest Gigabit Ethernet optical technologies, while still supporting their existing customer base.

For MPB configuration guidelines and restrictions and feature compatibility tables, see the “Configuring Multipoint Bridging” section of Chapter5, “Configuring the SIPs and SSC”

Configuring Bridging Control Protocol Support

The Bridging Control Protocol (BCP) enables forwarding of Ethernet frames over SONET networks and provides a high-speed extension of enterprise LAN backbone traffic through a metropolitan area. The implementation of BCP on the SPAs includes support for IEEE 802.1D, IEEE 802.1Q Virtual LAN (VLAN), and high-speed switched LANs.

For BCP configuration guidelines and restrictions and feature compatibility tables, see the “BCP Feature Compatibility” section of Chapter5, “Configuring the SIPs and SSC”

Configuring BCP on MLPPP

BCP on MLPPP Configuration Guidelines

  • Only Distributed MLPPP is supported.
  • Only channelized interfaces are allowed, and member links must be from the same controller card.
  • Only trunk port BCP is supported on MLPPP.
  • Bridging can be configured only on the bundle interface.

NoteBCP on MLPPP operates only in trunk mode.



NoteBCP on MLPPP is not supported with 4-port serial SPA on Cisco 7600 SIP-400.


Configuring BCP on MLPPP Trunk Mode

To configure BCP on MLPPP trunk mode, perform these steps:

 

Command
Purpose

Step 1

Router(config)# interface multilink

Selects the multilink interface.

Step 2

Router(config-if)# switchport

Puts an interface that is in Layer 3 mode into Layer 2 mode for Layer 2 configuration.

Step 3

Router(config-if)# switchport trunk allowed vlan 100

By default, no VLANs are allowed. Use this command to explicitly allow VLANs; valid values for vlan-list are from 1 to 4094.

Step 4

Router(config-if)# switchport mode trunk

Configures the router port connected to the switch as a VLAN trunk port.

Step 5

Router(config-if)# switchport nonegotiate

Puts the LAN port into permanent trunking mode but prevents the port from generating DTP frames.

Step 6

Router(config-if)# no ip address

Unassigns the IP address.

Step 7

Router(config-if)# switchport trunk allowed vlan vlan-list

By default, no VLANs are allowed. Use this command to explicitly allow VLANs; valid values for vlan-list are from 1 to 4094.

Step 8

Router(config-if)# ppp multilink

Enables this interface to support MLP.

Step 9

Router(config-if)# multilink-group group-number

Assigns this interface to the multilink group.

Step 10

Router(config-if)# shutdown

Shuts down an interface.

Step 11

Router(config-if)# no shutdown

Reopens an interface.

Step 12

Router(config-if)# interface serial slot/subslot/port

Designates a serial interface as a multilink bundle.

Step 13

Router(config-if)# no ip address

Unassigns the IP address.

Step 14

Router(config-if)# encapsulation ppp

Enables PPP encapsulation.

Step 15

Router(config-if)# ppp multilink

Enables this interface to support MLP.

Step 16

Router(config-if)# multilink-group 1

Assigns this interface to the multilink group 1.

Step 17

Router(config-if)# interface Serial slot/subslot/port

Designates a serial interface as a multilink bundle.

Step 18

Router(config-if)# no ip address

Unassigns the IP address.

Step 19

Router(config-if)# encapsulation ppp

Enables PPP encapsulation.

Step 20

Router(config-if)# ppp multilink

Enables this interface to support MLP.

Step 21

Router(config-if)# multilink-group group-number

Assigns this interface to a multilink group.

Verifying BCP on MLPPP Trunk Mode

To display information about Multilink PPP, use the show ppp multilink command in EXEC mode.

 

Command
Purpose

Router(config-if)# show ppp multilink

Displays information on a multilink group.

The following shows an example of show ppp multilink command :

 
Router# show ppp multilink
 
Multilink1, bundle name is group 1
Bundle is Distributed
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 4 active, 0 inactive (max no set, min not set)
Serial1/0/1
Serial1/0/2
Serial1/0/3
Serial1/0/4

FRF.12 Guidelines

For FRF.12, note the following:

  • The fragmentation is configured at the main interface.
  • Any fragmentation size is available.

For information on configuring FRF.12 on the Cisco SIP-200, see:


NoteFRF.12 is not supported with 4-Port Serial Interface SPA on Cisco 7600 SIP-400.


LFI Guidelines

LFI can function intwo ways—using FRF.12 or MLPPP.

FRF.12 LFI Guidelines

For LFI using FRF.12, note the following:

  • The fragmentation is configured at the main interface.
  • Any fragmentation size is available.

NoteFRF.12 LFI is not supported with 4-Port Serial Interface SPA on Cisco 7600 SIP-400.


Saving the Configuration

To save your running configuration to nonvolatile random-access memory (NVRAM), use the following command in privileged EXEC configuration mode:

 

Command
Purpose
Router# copy running-config startup-config

Writes the new configuration to NVRAM.

For more information about managing configuration files, refer to the Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.2 and Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 publications.

Verifying the Interface Configuration

Besides using the show running-configuration command to display your Cisco 7600 series router configuration settings, you can use the show interfaces serial and the show controllers serial commands to get detailed information on a per-port basis for your 2-Port and 4-Port Channelized T3 SPA.

Verifying Per-Port Interface Status

To find detailed interface information on a per-port basis for the 2-Port and 4-Port Channelized T3 SPA, use the show interfaces serial command to display port-specific information.

The following example provides sample output for the serial interface:

Router# show interface serial4/0/0
Serial4/0/0 is down, line protocol is down
Hardware is SPA-4T
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
Reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
RTS down, CTS down, DTR down, DCD down, DSR down
 

To find detailed status and statistical information on a per-port basis for the 4-Port Serial Interface SPA, use the show controller serial command.

The following example provides sample controller statistics:

Router# show controller serial 2/0/0
 
Serial2/0/0 - (SPA-4XT-SERIAL) is down
Encapsulation : HDLC
Cable type: RS-232 DTE
mtu 1500, max_buffer_size 1524, max_pak_size 1656 enc 132
loopback: Off, crc: 16, invert_data: Off
nrzi: Off, idle char: Flag
tx_invert_clk: Off, ignore_dcd: Off
rx_clockrate: 0, rx_clock_threshold: 0
serial_restartdelay:60000, serial_restartdelay_def:60000
 
RTS up, CTS down, DTR up, DCD down, DSR down
Router#

Configuration Examples

This section includes the following configuration examples:

Inverting the Clock Signal Configuration Example

Router(config-if)# interface serial3/0/0
Router(config-if)# invert txclock ?
<cr>
Router(config-if)# invert txclock
Router(config-if)# invert ?
data Invert data stream
txclock Invert transmit clock
 
Router(config-if)# invert data
 

NRZI Format Configuration Example

Router(config-if)# nrzi-encoding ?
<cr>

Cyclic Redundancy Checks Configuration Example

Router(config-if)# crc ?
16 crc word-size
32 crc word-size
 
Router(config-if)# crc 32
 

Encapsulation Configuration Example

Router(config-if)# interface 1
Router(config-if)# encapsulation ppp
 

Distributed Multilink PPP Configuration Example

Router(config)# interface multilink1
Router(config-if)# ip addr 10.0.0.1 255.255.255.0
Router(config)# interface serial3/2/0
Router(config-if)# encapsulation ppp
Router(config-if)# ppp chap hostname X1
Router(config-if)# ppp multilink gr 1
Router(config-if)#

MLFR Configuration Example

Router(config)# interface MFR1
Router(config-if)# frame-relay intf dce
Router(config-if)# frame-relay bid B1
Router(config-if)# interface MFR1.1 point-to-point
Router(config-if)# frame-relay interface-dlci 16
Router(config-if)# ip addr 10.0.0.1 255.255.255.0
Router(config-if)# interface serial3/2/0
Router(config-if)# encapsulation frame-relay MFR1
Router(config-if)# frame-relay multilnk lid X1
Router(config-if)#
 

Bridging Control Protocol Support Configuration Example

Router(config-if)# Interface Serial3/2/0
Router(config-if)# switchport
%Serial3/2/0 - Bridge Domain configuration precludes IP routing on this interface.
%Bridging is enabled. The MTU should be at least 1524.
%Please shut/no shut Serial3/2/0 to bring up BCP
Router(config-if)# show
Router(config-if)# no show
Router(config-if)# switchport mode trunk ?
<cr>
 
Router(config-if)# switchport mode trunk
Router(config-if)# sw
Router(config-if)# switchport trunk allowed vlan 100
 

BCP on MLPPP Configuration Example

 
Router(config)# interface multilink1
Router(config-if)# switchport
%Multilink1 - Bridge Domain configuration precludes IP routing on this interface.
%Bridging is enabled. The MTU should be at least 1524.
%Please shut/no shut Multilink1 to bring up BCP
Router(config-if)# show
Router(config-if)# no show
Router(config-if)# switchport mode trunk ?
<cr>
 
Router(config-if)# switchport mode trunk
Router(config-if)# switchport trunk allowed vlan 100