Installation and Configuration Guide for Cisco Services Ready Engine Virtualization 1.1
Configuring the Cisco SRE Service Module Interfaces—Cisco IOS Version 15.1(2)T
Downloads: This chapterpdf (PDF - 184.0KB) The complete bookPDF (PDF - 5.46MB) | Feedback

Configuring the Cisco SRE Service Module Interfaces—Cisco IOS Version 15.1(2)T

Table Of Contents

Configuring the Cisco SRE Service Module Interfaces—Cisco IOS Version 15.1(2)T

Basic Workflow for Configuring the Cisco SRE Service Module Interfaces

Cisco SRE Service Module Interfaces Overview

Service-Module Interface

MGF Interface

External Service Module Interface

Configuring the Cisco SRE Service Module Interfaces

Perquisites for Configuring the Cisco SRE Service Module Interfaces

Configuring the Service-Module Interface on the Router

Configuring the MGF Interface on the Module


Configuring the Cisco SRE Service Module Interfaces—Cisco IOS Version 15.1(2)T



Note If the Generation 2 of the Cisco Integrated Services Router (ISR G2) in which the Cisco SRE Service Module is installed is running Cisco IOS version 15.1(2)T, and you do not want to upgrade to the supported Cisco IOS version (see the "Verifying the Router, Cisco SRE Service Module, and Cisco IOS Software Version Compatibility" section), follow the procedure documented in this appendix to configure the Cisco SRE Service Module interfaces.

Caution You cannot configure VLANs for Cisco SRE Service Modules if the ISR G2 is running Cisco IOS version 15.1(2)T.

This chapter provides information about how to configure the Cisco SRE Service Module interfaces to run the Cisco SRE-V System software.

This chapter contains the following sections:

Basic Workflow for Configuring the Cisco SRE Service Module Interfaces

Cisco SRE Service Module Interfaces Overview

Configuring the Cisco SRE Service Module Interfaces

Basic Workflow for Configuring the Cisco SRE Service Module Interfaces

1. Configure the service-module interface on the router. See the "Configuring the Service-Module Interface on the Router" section.

2. Configure the MGF interface on the module. See the "Configuring the MGF Interface on the Module" section.

Cisco SRE Service Module Interfaces Overview

The host router and the Cisco SRE Service Module use several interfaces for internal and external communication. Use the Cisco IOS CLI commands to configure each of the interfaces on the router.

Before configuring the interfaces, make sure that you have the following information for entering the Cisco SRE Service Module command environment:

IP address of the Cisco router that contains the Cisco SRE Service Module.

Username and password for logging into the router.

Slot and unit number of the Cisco SRE Service Module.

The service module communicates with the host router through two internal Gigabit Ethernet (GE) interfaces:

One GE interface connects to the router Peripheral Component Interconnect Express (PCIe). Use the Cisco IOS CLI to configure and manage this interface. This interface is sm slot/0.

The other GE interface connects to the multi-gigabit fabric (MGF). Use the Cisco IOS CLI to configure the IP address of the MGF interface for the VMware vSphere HypervisorTM. This configuration allows the VSphere Client to communicate with the VMware vSphere HypervisorTM. This interface is sm slot/1.

There is a third Gigabit Ethernet interface, which is located on the external face plate of the Cisco SRE Service Module. This Gigabit Ethernet interface is configured and managed by the VMware vSphere HypervisorTM.

See Figure A-1.

Figure A-1 Host Router and Cisco SRE Service Module Interfaces

Callout
Location
Cisco SRE Service Module Interface
Slot and Port
Configure IP Address
Configure From
1

PCIe Link

Service-Module interface

slot/0

IP address of the router side of the interface

Example:

Router(config-if)# ip address 10.0.0.1 255.255.255.0

Cisco IOS CLI

2

IP address of the module side of the interface

Example:

Router(config-if)# service-module ip address 10.0.0.2 255.255.255.0

3

MGF Link

MGF interface
(Module interface to manage virtual machines)

slot/1

IP address of the router side of the interface

Example:

Router(config-if)# ip address 10.10.10.1 255.255.255.0

Cisco IOS CLI

4

IP address of the module side of the interface

Example:

Router(config-if)# service-module ip address 10.10.10.2 255.255.255.0

5

Module Faceplate

External interface
(Module interface to external link)

VMware vSphere HypervisorTM


See the following sections for more information:

Service-Module Interface

MGF Interface

External Service Module Interface

Service-Module Interface

The service-module interface is used to access the service module console for configuration. Visible only to the Cisco IOS software on the host router, the service-module interface is an internal GE interface between the router and the Cisco SRE Service Module. The service-module interface connects to the router PCIe and all configuration and management of the service-module interface is performed using the Cisco IOS CLI.

MGF Interface

The MGF interface enables the Cisco SRE Service Module to communicate with one or more service modules installed in the host router. Configuration of the MGF interface is performed from the Cisco IOS CLI. The Cisco-authorized application running that is on the Cisco SRE Service Module manages the connections. For more information about configuring MGF, see the "Multi-Gigabit Fabric on the Router" chapter in the Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software Configuration Guide on Cisco.com.

External Service Module Interface

The external service-module interface can be used as a backup interface to connect the VMware vSphere Hypervisor directly to the LAN. Unlike the internal interfaces, the external interface is primarily controlled and managed by the VMware vSphere Hypervisor. The traffic does not go into the router unless the VMware vSphere Hypervisor is configured to forward the traffic into the router through the MGF interface.

Configuring the Cisco SRE Service Module Interfaces

This section describes how to configure basic network parameters for the Cisco SRE Service Module using the Cisco IOS CLI. It contains the following sections:

Perquisites for Configuring the Cisco SRE Service Module Interfaces

Configuring the Service-Module Interface on the Router

Configuring the MGF Interface on the Module

Perquisites for Configuring the Cisco SRE Service Module Interfaces

Cisco Router Prerequisites

Make sure that your Cisco router is running the appropriate Cisco IOS software version and recognizes the Cisco SRE Service Module.

Cisco SRE Service Module Prerequisites


Note In most cases, the routers are shipped with the Cisco SRE Service Module already installed in them.

Make a note of the Cisco SRE Service Module slot location in the host router:

slot—ID of the host router chassis slot in which the Cisco SRE Service Module resides. After you install the module, you can obtain this information by using the Cisco IOS software CLI
show running-config command.

port—ID of the Network Interface Card (NIC) on the Cisco SRE Service Module. The value is 0 for the PCIe interface and 1 for the MGF interface.

FTP/SFTP/HTTP Server Prerequisites

If you need to download a new image, access a FTP, Secure FTP (SFTP), or HTTP server.

Verify that the FTP/SFTP/HTTP server is accessible.

Configuring the Service-Module Interface on the Router

Configure the internal interface between the Cisco SRE Service Module and the host router. This initial configuration allows you to access the service module to install and configure the Cisco SRE-V application.

PREREQUISITES

See the "Perquisites for Configuring the Cisco SRE Service Module Interfaces" section.

SUMMARY STEPS

From the Host-Router CLI

1. enable

2. configure terminal

3. interface sm slot/0

4. ip address router-side-ip-address subnet-mask
or
ip unnumbered type number

5. service-module ip address module-side-ip-address subnet-mask

6. service-module ip default-gateway gateway-ip-address

7. no shut

8. end

9. copy running-config startup-config

10. show running-config

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

enable

<password>

Example:

Router> enable

Router> <password>

Router#

Enters privileged EXEC mode on the host router. Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode on the host router.

Step 3 

interface sm slot/0

Example:

Router(config)# interface sm 1/0

Enters interface configuration mode for the slot and port where the Cisco SRE Service Module resides.

Step 4 

ip address router-side-ip-address subnet-mask

or

ip unnumbered type number

exit

ip route service-module-ip-address subnet-mask sm slot/0

Example:

Router(config-if)# ip address 10.0.0.1 255.255.255.0

 or

Router(config-if)# ip unnumbered gigabitethernet 1/0

Router(config-if)# exit

Router(config)# ip route 192.168.100.60 255.255.255.255 SM1/0

Specifies the IP address for the router side of the interface.

router-side-ip-address subnet-mask—IP address and subnet mask for the router.

or

Enables IP processing on an interface without assigning an explicit IP address to the interface.

type—Type of interface on which the router has an assigned IP address.

number—Number of the interface on which the router has an assigned IP address.

Note The unnumbered interface cannot be another unnumbered interface.

Exit interface mode, and then enter the ip route command.

service-module-ip-address subnet-mask—IP address and subnet mask of the service module.

slot/0—slot and port where the Cisco SRE Service Module resides.

Step 5 

service-module ip address module-side-ip-address subnet-mask

Example:

Router(config-if)# service-module ip address 10.0.0.2 255.255.255.0

Specifies the IP address for the module side of the interface.

module-side-ip-address—IP address for the module.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

Step 6 

service-module ip default-gateway gateway-ip-address

Example:

Router(config-if)# service-module ip default-gateway 10.0.0.1

Specifies the IP address of the default gateway for the module.

gateway-ip-address—IP address for the default router.

Step 7 

no shut

Example:

Router# no shut

Causes the interface to be administratively down.

Step 8 

end

Example:

Router(config-if)# end

Returns to global configuration mode on the host router.

Step 9 

copy running-config startup-config

Example:

Router# copy running-config startup-config

Saves the new running configuration of the router as the startup configuration.

Step 10 

show running-config

Example:

Router# show running-config

Displays the running configuration of the router so that you can verify the address configurations.

Example

The following example shows the configuration of the internal interface between the Cisco SRE Service Module and the router:

interface SM1/0
 ip address 10.0.0.1 255.255.255.0
 service-module ip address 10.0.0.2 255.255.255.0
 service-module ip default-gateway 10.0.0.1

Configuring the MGF Interface on the Module

Cisco 3900 series and 2900 series ISR G2s use the MGF interface to inter-communicate with the router. Next generation module drivers integrate with the MGF to perform port configurations, configure packet flow, and control traffic buffering.

PREREQUISITES

See the "Perquisites for Configuring the Cisco SRE Service Module Interfaces" section.

SUMMARY STEPS

From the Host-Router CLI

1. enable

2. configure terminal

3. interface sm slot/1

4. ip address router-side-ip-address subnet-mask

5. service-module ip address module-side-ip-address subnet-mask

6. end

7. copy running-config startup-config

8. service module sm slot/0 session

From the Console Manager Interface

9. hypervisor set ip default-gateway module-side-ip-address

10. Press Control-Alt-6 x.

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

enable

<password>

Example:

Router> enable

Router> <password>

Router#

Enters privileged EXEC mode on the host router. Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode on the host router.

Step 3 

interface sm slot/1

Example:

Router(config)# interface sm 1/1

Enters interface configuration mode for the slot and port where the Cisco SRE Service Module resides.

Step 4 

ip address router-side-ip-address subnet-mask

Example:

Router(config-if)# ip address 10.10.10.1 255.255.255.0

Specifies the IP address for the router side of the interface.

router-side-ip-address—IP address for the router.

subnet-mask—Subnet mask to append to the IP address.

Step 5 

service-module ip address module-side-ip-address subnet-mask

Example:

Router(config-if)# service-module ip address 10.10.10.2 255.255.255.0

Specifies the IP address for the module side of the interface.

module-side-ip-address—IP address for the module.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

Step 6 

end

Example:

Router(config-if)# end

Returns to global configuration mode on the host router.

Step 7 

copy running-config startup-config

Example:

Router# copy running-config startup-config

Saves the new running configuration of the router as the startup configuration.

Step 8 

service module sm slot/0 session

Example:

Router# service module sm 1/0 session

 

Trying 10.0.0.1, 2065 .. Open

Begins a session on the Cisco SRE Service Module. To start a configuration session, press Enter.

 
From the Console Manager Interface Enter commands in EXEC mode.

Step 9 

hypervisor set ip default-gateway router-side-ip-address

Example:

SRE-Module# hypervisor set ip default-gateway 10.10.10.1

Specifies the default gateway IP address that the VMware vSphere Hypervisor will use to communicate to the VSphere client.

router-side-ip-address—IP address that you configured for the router side of the interface. See Step 4.

Step 10 

Press Control-Alt-6 x.

Closes the service module session and returns to the host router CLI.

Note The service module session stays up until you clear it in the next step. While it remains up, you can return to it from the router CLI by pressing Enter.

Example

The following example shows the configuration of the interface between the Cisco SRE Service Module and the MGF.

interface SM1/1

 ip address 10.10.10.1 255.255.255.0

 service-module ip address 10.10.10.2 255.255.255.0