Multichannel STM-1 Port Adapter Installation and Configuration
Configuring the Multichannel PA-STM-1 Port Adapter
Downloads: This chapterpdf (PDF - 312.0KB) The complete bookPDF (PDF - 4.53MB) | Feedback

Configuring the PA-MC-STM-1

Table Of Contents

Configuring the PA-MC-STM-1

Using the EXEC Command Interpreter

Configuring the Interface

Shutting Down an Interface

Performing a Basic Interface Configuration

Configuring the AU-3s and TUG-3s of a PA-MC-STM-1

Configuring a Logical Channel Group on an E1 Line

Configuring a Logical Channel Group Interface

Configuring an E1 Unframed Channel

Basic Multi-Router MSP Configuration

Basic Single Router APS Configuration

Checking the Configuration

Using show Commands to Verify the New Interface Status

Using the show controllers Commands

Using the show protocols Command

Using the show running-config Command

Using the show startup-config Command

Using the show version or show hardware Commands

Using the show diag Command

Using the show interfaces Command

Using the ping Command to Verify Network Connectivity

Using loopback Commands


Configuring the PA-MC-STM-1


To continue your PA-MC-STM-1 port adapter installation, you must configure the STM-1 interface. The instructions that follow apply to all supported platforms. Minor differences among the platforms—with Cisco IOS software commands—are noted.

This chapter contains the following sections:

Using the EXEC Command Interpreter

Configuring the Interface

Checking the Configuration


Note The Cisco 7200 VXR Port Adapter Jacket Card requires no configuration. Configure a port adapter in it as you would any other port adapter.


Using the EXEC Command Interpreter

You modify the configuration of your router or switch through the software command interpreter called the EXEC (also called enable mode). You must enter the privileged level of the EXEC command interpreter with the enable command before you can use the configure command to configure a new interface or change the existing configuration of an interface. The system prompts you for a password if one has been set.

The system prompt for the privileged level ends with a pound sign (#) instead of an angle bracket (>). At the console terminal, use the following procedure to enter the privileged level:


Step 1 At the user-level EXEC prompt, enter the enable command. The EXEC prompts you for a privileged-level password as follows:

Router> enable 

Password: 

Step 2 Enter the password (the password is case sensitive). For security purposes, the password is not displayed.

When you enter the correct password, the system displays the privileged-level system prompt (#):

Router#


Configuring the Interface

After you verify that the new PA-MC-STM-1 is installed correctly (the ENABLED LED goes on), use the privileged-level configure command to configure the new interface. Have the following information available:

Protocols you plan to route on each new interface

IP addresses, if you plan to configure the interfaces for IP routing

Bridging protocols you plan to use

If you installed a new PA-MC-STM-1 or if you want to change the configuration of an existing interface, you must enter configuration mode to configure the new interfaces. If you replaced a PA-MC-STM-1 that was previously configured, the system recognizes the new interfaces and brings each of them up in their existing configurations.

For a summary of the configuration options available and instructions for configuring interfaces on a PA-MC-STM-1, refer to the appropriate configuration publications listed in the "Related Documentation" section on page ix.

You execute configuration commands from the privileged level of the EXEC command interpreter, which usually requires password access. Contact your system administrator, if necessary, to obtain password access. (See the "Using the EXEC Command Interpreter" section for an explanation of the privileged level of the EXEC.)

This section contains the following subsections:

Shutting Down an Interface

Performing a Basic Interface Configuration

Configuring the AU-3s and TUG-3s of a PA-MC-STM-1

Configuring a Logical Channel Group on an E1 Line

Configuring a Logical Channel Group Interface

Configuring an E1 Unframed Channel

Basic Multi-Router MSP Configuration

Basic Single Router APS Configuration

Shutting Down an Interface

Before you remove an interface that you will not replace, or replace port adapters, use the shutdown command to shut down (disable) the interfaces to prevent anomalies when you reinstall the new or reconfigured port adapter. When you shut down an interface, it is designated administratively down in the show command displays.

Follow these steps to shut down an interface:


Step 1 Enter the privileged level of the EXEC command interpreter (also called enable mode). (See the "Using the EXEC Command Interpreter" section for instructions.)

Step 2 At the privileged-level prompt, enter configuration mode and specify that the console terminal is the source of the configuration subcommands, as follows:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

Step 3 Shut down interfaces by entering the interface serial subcommand (followed by the interface address of the interface), and then enter the shutdown command. Table 4-1 shows the command syntax.

When you have finished, press Ctrl-Z—hold down the Control key while you press Z—or enter end or exit to exit configuration mode and return to the EXEC command interpreter.

Table 4-1 shows the shutdown command syntax for the supported platforms.

Table 4-1 Syntax of the shutdown Command for the Supported Platforms 

Platform
Command
Example

FlexWAN module in Catalyst 6000 family switches and Cisco 7600 series Internet Routers

interface, followed by the type (serial) module/bay/port (module-slot-number/port-adapter-bay-number/interface-port-number)

shutdown

The example is for interface 0 on a port adapter in module slot 5 in port adapter bay 0.

Console# interface serial 5/0/0
Console# shutdown
Ctrl-Z
Console#

Cisco 7200 VXR routers

interface, followed by the type (serial) and slot/port (port-adapter-slot-number/
interface-port-number)

shutdown

The example is for interface 0 on a port adapter in port adapter slot 6.

Router(config-if)# interface serial 6/0
Router(config-if)# shutdown
Ctrl-Z
Router#

Cisco 7201 router

interface, followed by the type (serial) and slot/port (port-adapter-slot-number/
interface-port-number)

shutdown

The example is for interface 0 and interface 1 on a port adapter in slot 1.

Router(config)# interface serial 1/0
Router(config-if)# shutdown
Router(config-if)# interface serial 1/1
Router(config-if)# shutdown
Ctrl-Z
Router#

Cisco 7301 router

interface, followed by the type (serial) and slot/port (port-adapter-slot-number/
interface-port-number)

shutdown

The example is for interface 0 and interface 1 on a port adapter in slot 1.

Router(config)# interface serial 1/0
Router(config-if)# shutdown
Router(config-if)# interface serial 1/1
Router(config-if)# shutdown
Ctrl-Z
Router#

Cisco 7304 PCI Port Adapter Carrier Card in a Cisco 7304 router

interface, followed by the type (serial) and slot/port (module-slot-number/
interface-port-number)

shutdown

The example is for interface 0 on a port adapter in a Cisco 7304 PCI Port Adapter Carrier Card in module slot 3 of a Cisco 7304 router.

Router(config-if)# interface serial 3/0 
Router(config-if)# shutdown 
Ctrl-Z 
Router# 

Cisco 7401ASR router

interface, followed by the type (serial) and slot/port (port-adapter-slot-number/
interface-port-number)

shutdown

The example is for interface 0 and interface 1 on a port adapter in slot 1.

Router(config)# interface serial 1/0
Router(config-if)# shutdown
Router(config-if)# interface serial 1/1
Router(config-if)# shutdown
Ctrl-Z
Router#

VIP4-80 or VIP6-80 in Cisco 7500 series routers

interface, followed by the type (serial) and slot/port adapter/port (interface-processor-slot-number/
port-adapter-slot-number/
interface-port-number)

shutdown

The example is for interface 0 on a port adapter in port adapter slot 1 of a VIP installed
in interface processor slot 1.

Router(config-if)# interface serial 1/1/0
Router(config-if)# shutdown
Ctrl-Z
Router#


Note If you need to shut down additional interfaces, enter the interface serial command (followed by the interface address of the interface) for each of the interfaces on your port adapter. Use the no shutdown command to enable the interface.


Step 4 Write the new configuration to NVRAM as follows:

Router# copy running-config startup-config
[OK]
Router#

The system displays an OK message when the configuration has been stored in NVRAM.

Step 5 Verify that new interfaces are now in the correct state (shut down) using the show interfaces command (followed by the interface type and interface address of the interface) to display the specific interface.

Table 4-2 provides examples of the show interfaces serial command for the supported platforms.

Table 4-2 Examples of the show interfaces serial Command for the Supported Platforms 

Platform
Command
Example

FlexWAN module in Catalyst 6000 family switches and Cisco 7600 series Internet Routers

show interfaces serial, followed by module/bay/port (module-slot-number/port-adapter-bay-number/interface-port-number)

The example is for interface 0 on a port adapter in module slot 5 in port adapter bay 0.

Console# show interfaces serial 5/0/0

Serial 5/0/0 is administratively down, line 
protocol is down

[Additional display text omitted from this 
example]

Cisco 7200 VXR routers

show interfaces serial, followed by slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 on a port adapter in port adapter slot 6.

Router# show interfaces serial 6/0

Serial 6/0 is administratively down, line 
protocol is down

[Additional display text omitted from this 
example]

Cisco 7201 router

show interfaces serial, followed by slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 on a port adapter in port adapter slot 1.

Router# show interfaces serial 1/0

Serial 1/0 is administratively down, line 
protocol is down

[Additional display text omitted from this 
example]

Cisco 7301 router

interface, followed by the type (serial) and slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 and interface 1 on a port adapter in slot 1.

Router(config)# interface serial 1/0
Router(config-if)# shutdown
Router(config-if)# interface serial 1/1
Router(config-if)# shutdown
Ctrl-Z
Router#

Cisco 7304 PCI Port Adapter Carrier Card in a Cisco 7304 router

show interfaces serial, followed by slot/port (module-slot-number/
interface-port-number)

The example is for interface 0 on a port adapter in a Cisco 7304 PCI Port Adapter Carrier Card in module slot 3 of a Cisco 7304 router.

Router# show interfaces serial 3/0
 
Serial 3/0 is administratively down, line 
protocol is down 
 
[Additional display text omitted from this 
example]

Cisco 7401ASR router

interface, followed by the type (serial) and slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 and interface 1 on a port adapter in slot 1.

Router(config)# interface serial 1/0
Router(config-if)# shutdown
Router(config-if)# interface serial 1/1
Router(config-if)# shutdown
Ctrl-Z
Router#

VIP4-80 or VIP6-80 in Cisco 7500 series routers

show interfaces serial, followed by slot/port adapter/port (interface-processor-slot-number/
port-adapter-slot-number/
interface-port-number)

The example is for interface 0 on a port adapter in port adapter slot 1 of a VIP in interface processor slot 1.

Router# show interfaces serial 1/1/0

Serial 1/1/0 is administratively down, line 
protocol is down

[Additional display text omitted from this 
example]

Step 6 Re-enable interfaces by doing the following:

a. Repeat Step 3 to re-enable an interface. Substitute the no shutdown command for the shutdown command.

b. Repeat Step 4 to write the new configuration to memory. Use the copy running-config startup-config command.

c. Repeat Step 5 to verify that the interfaces are in the correct state. Use the show interfaces command followed by the interface type and interface address of the interface.


For complete descriptions of software configuration commands, refer to the publications listed in the "Related Documentation" section on page ix.

Performing a Basic Interface Configuration

Following are instructions for a basic configuration, which include enabling an interface and configuring the SONET controller. You might also need to enter other configuration subcommands, depending on the requirements for your system configuration and the protocols you plan to route on the interface. For complete descriptions of configuration subcommands and the configuration options available for SONET interfaces, refer to the appropriate software documentation.

In the following procedure, press the Return key after each step unless otherwise noted. At any time you can exit the privileged level and return to the user level by entering disable at the prompt as follows:

Router# disable

Router> 


Step 1 Enter configuration mode and specify that the console terminal is the source of the configuration subcommands, as follows:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

Step 2 Configure the SONET controller by entering the controller sonet subcommand, followed by the interface address of the controller you plan to configure.

Table 4-3 provides examples of the controller sonet subcommand for the supported platforms.

Table 4-3 Examples of the controller sonet Subcommand for the Supported Platforms 

Platform
Command
Example

FlexWAN module in Catalyst 6000 family switches and Cisco 7600 series Internet Routers

controller sonet, followed by module/bay/port (module-slot-number/port-adapter-bay-number/interface-port-number)

The example is for interface 0 on a port adapter in module slot 5 in port adapter bay 0.

Console# controller sonet 5/0/0
Console#

Cisco 7200 VXR routers

controller sonet, followed by slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 of a
port adapter in port adapter slot 6.

Router(config)# controller sonet 6/0
Router(config-if)#

Cisco 7201 router

controller sonet, followed by slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 of a
port adapter in port adapter slot 1.

Router(config)# controller sonet 1/0
Router(config-if)#

Cisco 7301 router

controller sonet, followed by slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 of a
port adapter in port adapter slot 1.

Router(config)# controller sonet 1/0
Router(config-if)#

Cisco 7304 PCI Port Adapter Carrier Card in a Cisco 7304 router

controller sonet, followed by slot/port (module-slot-number/
interface-port-number)

The example is for interface 0 on a port adapter in a Cisco 7304 PCI Port Adapter Carrier Card in module slot 3 of a Cisco 7304 router.

Router(config)# controller sonet 3/0
Router(config-if)#

Cisco 7401ASR router

controller sonet, followed by slot/port (port-adapter-slot-number/
interface-port-number)

The example is for interface 0 of a
port adapter in port adapter slot 1.

Router(config)# controller sonet 1/0
Router(config-if)#

VIP4-80 or VIP6-80 in Cisco 7500 series routers

controller sonet, followed by slot/port adapter/port (interface-processor-slot-number/
port-adapter-slot-number/
interface-port-number)

The example is for interface 0 in port adapter slot 1 of a VIP in interface processor slot 1.

Router(config)# controller sonet 1/1/0
Router(config-controller)#

Step 3 Use the framing {sonet | sdh} command to set the port to SONET mode or SDH mode, as shown below:

Router(config)# controller sonet 1/1/0
Router(config-controller)# framing sdh

The default is SONET mode.

Step 4 Use the clock source {internal | line} command to determine if clocking will be obtained locally from the PA-MC-STM-1 or from the network or line, as shown below:

Router(config)# controller sonet 1/1/0
Router(config-controller)# clock source internal

The default is line.

Step 5 Use the aug mapping {au-3 | au-4} command to determine how the administrative unit groups (AUGs) will be mapped. (See Figure 4-1.) The example shown below configures the AUG as AU-3:

Router(config)# controller sonet 1/1/0
Router(config-controller)# aug mapping au-3

When the AUG is configured to be AU-3, the following muxing, alignment, and mapping will be configured:

C-12 <--> VC-12 <--> TU-12 <--> TUG-2 <--> VC-3 <--> AU-3 <--> AUG

When the AUG is configured to be AU-4, the following muxing, alignment, mapping will be configured:

C-12 <--> VC-12 <--> TU-12 <--> TUG-2 <--> TUG-3 <--> VC-4 <--> AU-4 <--> AUG


Note This command is available only when SDH framing is configured


Step 6 After including all of the configuration subcommands to complete your configuration, press Ctrl-Z—hold down the Control key while you press Z—or enter end or exit to exit configuration mode and return to the EXEC command interpreter prompt.

Step 7 Write the new configuration to NVRAM as follows:

Router# copy running-config startup-config
[OK]
Router#


This completes the procedure for creating a basic configuration.

Configuring the AU-3s and TUG-3s of a PA-MC-STM-1

You can configure each of the administrative unit groups (AUGs) and tributary unit groups (TUGs) of a PA-MC-STM-1 to carry a set of E1 links that are mapped into TU-12s (see Figure 4-1).

Figure 4-1

PA-MC-STM-1 Multiplexing Structure

In the following example, SDH framing, internal clock source, AUG mapping au-4, and idle pattern are configured:

Router(config)# controller sonet 1/1/0
Router(config-controller)# framing sdh
Router(config-controller)# clock source internal
Router(config-controller)# aug mapping au-4
Router(config-controller)# au-4 1 tug-3 2
Router(config-controller-tug3)# mode c-12
Router(config-controller-tug3)# tug-2 4 e1 channel-group 15 timeslots 1-5, 20-23
Router(config-controller-tug3)# idle pattern 0X0
Router(config-controller-tug3)# exit
Router(config-controller)# exit

Configuring a Logical Channel Group on an E1 Line

To configure a logical channel group on an E1 line, use the tug-2 tug-2# e1 e1# channel-group channel-group# timeslots list-of-timeslots command where:

tug-2# is a value from 1 to 7

e1# is a value from 1 to 3

channel-group# is a value from 0 to 30

list-of-timeslots can be a value from 1 to 31 or a combination of subranges within the range 1 to 31 (each subrange is a list of time slots that makes up the E1 line).

In the following example, logical channel group 15 on E1 line 1 is configured and channelized time slots 1 to 5 and 20 to 23 are assigned to the newly created logical channel group:

Router(config)# controller sonet 1/1/0
Router(config-controller)# framing sdh
Router(config-controller)# aug mapping au-4
Router(config-controller)# au-4 1 tug-3 2
Router(config-controller-tug3)# mode c-12
Router(config-controller-tug3)# tug-2 4 e1 1 channel-group 15 timeslots 1-5, 20-23
Router(config-controller-tug3)# exit
Router(config-controller)# exit

Configuring a Logical Channel Group Interface

Once a channel group has been created (see the "Configuring a Logical Channel Group on an E1 Line" section), interface serial configuration commands may be used as in the example below:

Router(config)# controller sonet 1/1/0
Router(config-controller)# framing sdh
Router(config-controller)# aug mapping au-4
Router(config-controller)# au-4 1 tug-3 2
Router(config-controller-tug3)# mode c-12
Router(config-controller-tug3)# tug-2 4 e1 1 channel-group 15 timeslots 1-5, 20-23
Router(config-controller-tug3)# exit
Router(config-controller)# exit
Router(config)# interface serial 1/1/0.1/2/4/1:15
Router(config-if)# ip address 1.1.1.10 255.255.255.252
Router(config-if)# encapsulation ppp

Configuring an E1 Unframed Channel

To create an unframed or clear channel logical channel group on an E1 line, use the tug-2 tug-2# e1 e1# unframed command, as shown in the example below:

Router(config)# controller sonet 1/1/0
Router(config-controller)# au-4 1 tug-3 2
Router(config-controller-tug3)# tug-2 4 e1 1 unframed


Note The channel group is always 0 for unframed E1 lines.


Basic Multi-Router MSP Configuration

The following example shows the configuration of Multiplex Section Protection (MSP) on router A and router B (see Figure 4-2). In this example, router A is configured with the working controller, and router B is configured with the protect controller. If the working controller on router A becomes unavailable, the connection will automatically switchover to the protect controller on router B. This configuration is typically used to protect against both line card and router failures.

Figure 4-2 Basic Multi-Router MSP Configuration

To configure Router A as the working controller, use the following configuration:

RouterA# configure terminal
RouterA(config)# interface ethernet 0/0
RouterA(config-if)# ip address 7.7.7.7 255.255.255.0
RouterA(config-if)# exit
RouterA(config)# controller SONET 1/0/0
RouterA(config-controller)# aps group 1
RouterA(config-controller)# aps working 1
RouterA(config-controller)# end
RouterA#

To configure Router B as the protect controller, use the following configuration:

RouterB# configure terminal
RouterB(config)# interface ethernet 0/0
RouterB(config-if)# ip address 7.7.7.6 255.255.255.0
RouterB(config-if)# exit
RouterB(config)# controller SONET 3/0/0
RouterB(config-controller)# aps group 1
RouterB(config-controller)# aps protect 1 7.7.7.7
RouterB(config-controller)# end
RouterB#

To configure serial interfaces on Router A, use the following configuration:

RouterA# configure terminal
RouterA(config)# controller SONET 1/0/0
RouterA(config-controller)# au-4 1 tug-3 1
RouterA(config-ctrlr-tug3)# tug-2 1 e1 1 unframed
RouterA(config-controller)# exit
RouterA(config)#interface serial 1/0/0.1/1/1/1:0
RouterA(config-if)# ip address 192.0.1.2 255.255.255.0
RouterA(config-if)# end
RouterA#

To configure serial interfaces on Router B, use the following configuration:

RouterB# configure terminal
RouterB(config)# controller SONET 3/0/0
RouterB(config-controller)# au-4 1 tug-3 1
RouterB(config-ctrlr-tug3)# tug-2 1 e1 1 unframed
RouterB(config-controller)# exit
RouterB(config)#interface serial 3/0/0.1/1/1/1:0
RouterB(config-if)# ip address 192.0.1.2 255.255.255.0
RouterB(config-if)# end
RouterB#

Basic Single Router APS Configuration

The following example shows the configuration of Automatic Protection Switching (APS) on router A (see Figure 4-3). In this example, Router A has both working and protect controllers. If the working controller SONET 1/0/0 becomes unavailable, the connection will automatically switchover to the protect controller SONET 3/0/0. Single router APS configuration is typically used to protect line card failures.

Figure 4-3 Basic Single Router APS Configuration

To configure a loopback interface on Router A, use the following configuration:

RouterA# configure terminal
RouterA(config)# interface Loopback 0/0
RouterA(config-if)# ip address 7.7.7.7 255.255.255.255
RouterA(config-if)# end
RouterA#

Next, to configure working and protect controllers, use the following configuration:

RouterA# configure terminal
RouterA(config)# controller SONET 1/0/0
RouterA(config-controller)# aps group 1
RouterA(config-controller)# aps working 1
RouterA(config-controller)# exit
RouterA(config)# controller SONET 3/0/0
RouterA(config-controller)# aps group 1
RouterA(config-controller)# aps protect 1 7.7.7.7
RouterA(config-controller)# end
RouterA#

Finally, to configure serial interfaces on both working and protect controllers, use the following configuration:

RouterA(config)# controller SONET 1/0/0
RouterA(config-controller)# au-4 1 tug-3 1
RouterA(config-ctrlr-tug3)# tug-2 1 e1 1 unframed
RouterA(config-controller)# exit
RouterA(config)#interface serial 1/0/0.1/1/1/1:0
RouterA(config-if)# ip address 192.0.1.2 255.255.255.0
RouterA(config-if)# exit
RouterA(config)# controller SONET 3/0/0
RouterA(config-controller)# au-4 1 tug-3 1
RouterA(config-ctrlr-tug3)# tug-2 1 e1 1 unframed
RouterA(config-controller)# exit
RouterA(config)#interface serial 3/0/0.1/1/1/1:0
RouterA(config-if)# ip address 192.0.1.2 255.255.255.0
RouterA(config-if)# end


Note MSP is only supported at the SONET controller level. Individual E1 level protection is not supported with PA-MC-STM1.


Checking the Configuration

After configuring the new interface, use the show commands to display the status of the new interface or all interfaces, and use the ping and loopback commands to check connectivity. This section includes the following subsections:

Using show Commands to Verify the New Interface Status

Using the ping Command to Verify Network Connectivity

Using loopback Commands

Using show Commands to Verify the New Interface Status

This section demonstrates how you can use the show commands to verify that new interfaces are configured and operating correctly and that the module appears in them correctly. Sample displays of the output of selected show commands appear in the sections that follow. For complete command descriptions and examples, refer to the publications listed in the "Related Documentation" section on page ix.

If an interface is shut down and you configured it as up, or if the displays indicate that the hardware is not functioning properly, ensure that the interface is properly connected and terminated. If you still have problems bringing up the interface, contact a service representative for assistance.

This section includes the following subsections:

Using the show controllers Commands

Using the show protocols Command

Using the show running-config Command

Using the show startup-config Command

Using the show version or show hardware Commands

Using the show diag Command

Using the show interfaces Command

Using the show controllers Commands

Display all the current interface processors and their interfaces using the show controllers command.


Note The outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


The following is an example of the show controllers command:

Router# show controllers 

MEMD at 40000000, 2097152 bytes (unused 3360, recarves 1, lost 0) 
  RawQ 48000100, ReturnQ 48000108, EventQ 48000110 
  BufhdrQ 48000128 (2900 items), LovltrQ 48000140 (5 items, 2016 bytes) 
  IpcbufQ 48000150 (16 items, 4096 bytes) 
  IpcbufQ_classic 48000148 (8 items, 4096 bytes) 
  3570 buffer headers (48002000 - 4800FF10) 
  pool0: 9 buffers, 256 bytes, queue 48000130 
  pool1: 344 buffers, 1536 bytes, queue 48000138 
  pool2: 284 buffers, 4544 bytes, queue 48000158 
  pool3: 4 buffers, 4576 bytes, queue 48000160 
  slot2: VIP2, hw 2.4, sw 22.20, ccb 5800FF40, cmdq 48000090 
    software loaded from flash slot0:vip2_22-20.atmdx.191897 
    IOS (tm) VIP Software (SVIP-DW-M), Experimental Version 11.3 
  ROM Monitor version 17.0 
    ATM2/0/0, applique is DS3 (45Mbps) 
      gfreeq 48000158, lfreeq 48000168 (4544 bytes), throttled 0 
      rxlo 4, rxhi 284, rxcurr 1, maxrxcurr 5 
      txq 48001A00, txacc 48001A02 (value 284), txlimit 284 

Using the show protocols Command

Display protocols configured for the entire system and for specific interfaces using the show protocols command.


Note The outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


The following is an example of the show protocols command:

Router# show protocols
line protocol is up

Using the show running-config Command

Display the running configuration file using the show running-config command.


Note The outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


The following is an example of the show running-config command:

Router# show running-config

Building configuration...
Current configuration:
!
!
!
user add admin uid 0  capability admin-access
!
!
!
hostname CR4430
!
interface ethernet 0
 ip address 10.2.2.8 255.255.255.0
 ip broadcast-address 10.2.2.255
 exit
!
interface ethernet 1
 exit
!
ip default-gateway 10.2.2.1
ip name-server 10.2.2.6
ip route 0.0.0.0 0.0.0.0 10.2.2.1

Using the show startup-config Command

Display the configuration stored in the NVRAM using the show startup-config command.


Note The outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


The following is an example of the show startup-config command:

Router# show startup-config
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname rp-3640-2b
!
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
!
crypto isakmp policy 1
hash md5 
authentication pre-share
crypto isakmp key cisco123 address 95.95.95.2 
!
crypto ipsec transform-set rtpset esp-des esp-md5-hmac 
!
crypto map rtp 1 ipsec-isakmp 
set peer 95.95.95.2
set transform-set rtpset 
match address 115
!
interface Ethernet0/0
ip address 98.98.98.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/1
ip address 99.99.99.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
crypto map rtp
!
interface Ethernet0/2
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0/3
no ip address
no ip directed-broadcast
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 99.99.99.1
no ip http server
!
access-list 115 permit ip 98.98.98.0 0.0.0.255 10.103.1.0 0.0.0.255
access-list 115 deny ip 98.98.98.0 0.0.0.255 any
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

Using the show version or show hardware Commands

Display the configuration of the system hardware, the number of each interface type installed, the Cisco IOS software version, the names and sources of configuration files, and the boot images, using the show version (or show hardware) command.


Note The outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


The following sections provide platform-specific output examples of the show version command:

Catalyst 6000 Family Switches and Cisco 7600 Series Internet Routers with FlexWAN Module—Example Output of the show version Command

Cisco 7200 VXR Routers—Example Output of the show version Command

Cisco 7201 Router—Example Output of the show version Command

Cisco 7500 Series Routers with VIP—Example Output of the show version Command

Catalyst 6000 Family Switches and Cisco 7600 Series Internet Routers with FlexWAN Module—Example Output of the show version Command

Following is an example of the show version command from a Catalyst 6000 family switch with a PA-MC-STM-1 installed:

Console# show version

Cisco Internetwork Operating System Software 
IOS (tm) MSFC Software (C6MSFC-JSV-M), Version 12.1(20010119:22010]
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Fri 19-Jan-01 14:46 by biff
Image text-base: 0x60008950, data-base: 0x617AC000

ROM: System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE 
BOOTFLASH: MSFC Software (C6MSFC-BOOT-M), Version 12.0(7)XE1, EARLY DEPLOYMENT )

Switch uptime is 4 hours, 21 minutes
System returned to ROM by reload
System image file is "bootflash:c6msfc-jsv-mz.Feb9"

cisco Cat6k-MSFC (R5000) processor with 114688K/16384K bytes of memory.
Processor board ID SAD03432638
R5000 CPU at 200Mhz, Implementation 35, Rev 2.1, 512KB L2 Cache
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
1 FlexWAN controller (1 Channelized OC3/STM-1).
1 Virtual Ethernet/IEEE 802.3  interface(s)
1 Channelized OC3/STM-1 port(s)
123K bytes of non-volatile configuration memory.
4096K bytes of packet SRAM memory.
          
16384K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x100Cisco 7200 VXR Routers

Cisco 7200 VXR Routers—Example Output of the show version Command

Following is an example of the show version command from a Cisco 7200 VXR router with a PA-MC-STM-1 installed:

Router1-VXR> show version

Cisco Internetwork Operating System Software 
IOS (tm) 7200 Software (C7200-P-M), Version 12.1(20010104:023621) ]
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Tue 23-Jan-01 15:34 by biff
Image text-base: 0x60008968, data-base: 0x60C56000

ROM: System Bootstrap, Version 12.0(20000211:194150)
BOOTFLASH: 7200 Software (C7200-BOOT-M), Version 12.0(10)S, EARLY DEPLOYMENT RE)

Router1-VXR uptime is 5 days, 20 hours, 48 minutes
System returned to ROM by reload
System image file is "c7200-p-mz"

cisco 7206VXR (NSE-1) processor (revision A) with 114688K/16384K bytes of memor.
Processor board ID 21288237
R7000 CPU at 262Mhz, Implementation 39, Rev 2.1, 256KB L2, 2000KB L3 Cache
6 slot VXR midplane, Version 2.0

Last reset from power-on
X.25 software, Version 3.0.0.
PXF processor tmc is running.
8 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
63 Serial network interface(s)
1 Channelized T3 port(s)
1 Channelized OC3/STM-1 port(s)
125K bytes of non-volatile configuration memory.
          
20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x0

Cisco 7201 Router—Example Output of the show version Command

Following is an example of the show version command from a Cisco 7201 router:

Router# show version 

Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 
12.4(biffDEV.061001), INTERIM SOFTWARE Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Sun 01-Oct-06 23:42 by biff
ROM: System Bootstrap, Version 12.4(4r)XD5, RELEASE SOFTWARE (fc1)
BOOTLDR: Cisco IOS Software, 7200 Software (C7200P-KBOOT-M), Version 12.4(TAZ3DEV.060927), 
INTERIM SOFTWARE
c7201alpha1 uptime is 5 days, 18 hours, 32 minutes System returned to ROM by power-on 
System image file is "disk0:c7200p-adventerprisek9-mz.2006-10-01.biffdev"
This product contains cryptographic features and is subject to United States and local 
country laws governing import, export, transfer and use. Delivery of Cisco cryptographic 
products does not imply third-party authority to import, export, distribute or use 
encryption.
Importers, exporters, distributors and users are responsible for compliance with U.S. and 
local country laws. By using this product you agree to comply with applicable laws and 
regulations. If you are unable to comply with U.S. and local laws, return this product 
immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to export@cisco.com.
Cisco 7201 (c7201) processor (revision A) with 917504K/65536K bytes of memory.
Processor board ID 2222222222222
MPC7448 CPU at 1666Mhz, Implementation 0, Rev 2.2
1 slot midplane, Version 2.255
Last reset from power-on
1 FastEthernet interface
4 Gigabit Ethernet interfaces
2045K bytes of NVRAM.
62443K bytes of USB Flash usbflash0 (Read/Write)
250880K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2

Cisco 7500 Series Routers with VIP—Example Output of the show version Command

Following is an example of the show version command from a VIP4-80 in a Cisco 7500 series router with a PA-MC-STM-1 installed:

Router# show version

Cisco Internetwork Operating System Software 
IOS (tm) RSP Software (RSP-PV-M), Version 12.0(20000912:174226) ]
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Wed 13-Sep-00 04:08 by biff
Image text-base: 0x60010950, data-base: 0x60DA6000

ROM: System Bootstrap, Version 11.1(8)CA1, RELEASE SOFTWARE (fc1)
BOOTFLASH: GS Software (RSP-BOOT-M), Version 11.1(8)CA1, RELEASE SOFTWARE (fc1) 
7500_right uptime is 2 minutes
System returned to ROM by reload at 17:20:30 UTC Fri Apr 30 1999
System image file is 
"tftp://223.255.254.254//tftpboot-users/halrev312sdevtst/rel091300/bin/rsp-pv-mz091300"

cisco RSP4 (R5000) processor with 131072K/2072K bytes of memory.
R5000 CPU at 200Mhz, Implementation 35, Rev 2.1, 512KB L2 Cache
Last reset from power-on
G.703/E1 software, Version 1.0.
G.703/JT2 software, Version 1.0.
X.25 software, Version 3.0.0.
1 EIP controller (6 Ethernet).
1 VIP4-80 RM7000 controller (1 Channelized OC3/STM-1).
6 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
1 Channelized OC3/STM-1 port(s)
123K bytes of non-volatile configuration memory.

20480K bytes of Flash PCMCIA card at slot 1 (Sector size 128K).
8192K bytes of Flash internal SIMM (Sector size 256K).
No slave installed in slot 7.
Configuration register is 0x0

Using the show diag Command

Display the types of port adapters installed in your system (and specific information about each) using the show diag slot command, where slot is the port adapter slot in a Cisco 7200 VXR router, Cisco 7201 router, Cisco 7301 router, or Cisco 7401ASR router, the module slot in a Cisco 7304 PCI Port Adapter Carrier Card in a Cisco 7304 router, and the interface processor slot in a Cisco 7500 series router with a VIP. In the FlexWAN module, the show diag command is used without the slot designation.


Note The outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


The following sections provide platform-specific output examples of the show diag command:

Catalyst 6000 Family Switches and Cisco 7600 Series Internet Routers with FlexWAN Module—Example Output of the show diag Command

Cisco 7200 VXR Routers—Example Output of the show diag Command

Cisco 7201 Router—Example Output of the show diag Command

Cisco 7500 Series Routers with VIP—Example Output of the show diag Command

Catalyst 6000 Family Switches and Cisco 7600 Series Internet Routers with FlexWAN Module—Example Output of the show diag Command

Following is an example of the show diag command that shows a PA-MC-STM-1 installed in a FlexWAN module:

Console# show diag
Slot 4: Logical_index 8
        Board is analyzed ipc ready FlexWAN controller
        HW rev 1.3, board revision B0
        Serial Number: SAD04340JY3 Part number: 73-3869-07

        Slot database information:
        Flags: 0x2004   Insertion time: 0x61BFC (04:16:29 ago)

        CWAN Controller Memory Size: Unknown

Slot 4: Logical_index 9
        Board is analyzed ipc ready FlexWAN controller
        HW rev 1.3, board revision B0
        Serial Number: SAD04340JY3 Part number: 73-3869-07

        Slot database information:
        Flags: 0x2004   Insertion time: 0x622A0 (04:16:27 ago)

        Controller Memory Size: 56 MBytes DRAM, 8192 KBytes Packet Memory
        IOS (tm) cwlc Software (cwpa-DW-M), Experimental Version 12.1(20010119:v

PA Bay 1 Information:
                Channelized OC3/STM-1 SMI PA, 1 port
                EEPROM format version 4
                HW rev 1.00, Board revision UNKNOWN
                Serial number: 00000000  Part number: 76-33356-130 

Cisco 7200 VXR Routers—Example Output of the show diag Command

Following is an example of the show diag command that shows a PA-MC-STM-1 installed in port adapter slot 1 of a Cisco 7200 VXR router:

Router1-VXR> show diag 1
Slot 1:
        Ethernet Port adapter, 8 ports
        Port adapter is analyzed 
        Port adapter insertion time 5d20h ago
        EEPROM contents at hardware discovery:
        Hardware revision 1.14          Board revision A0
        Serial number     16733712      Part number 255-65535-255
        Test history      0x0           RMA number 255-255-255
        EEPROM format version 1
        EEPROM contents (hex):
          0x20: 01 01 01 0E 00 FF 56 10 49 05 6F 08 00 00 00 00
          0x30: 50 00 00 00 00 04 29 00 FF FF FF FF FF FF FF FF


Note Port adapters used with Cisco 7200 VXR routers require the correct base hardware revision in order to function. An error message occurs on bootup if the incorrect hardware revision is used. Use the show diag command to display the hardware revision.


Cisco 7201 Router—Example Output of the show diag Command

Following is an example of the show diag command from a Cisco 7201 router:

Router# show diag 1
Slot 1:
Dual OC3 POS Port adapter, 2 ports
Port adapter is analyzed 
Port adapter insertion time 00:02:19 ago
EEPROM contents at hardware discovery:
Hardware Revision : 1.0
PCB Serial Number : JAE07520DYL
Part Number : 73-8220-02
Board Revision : A0
RMA Test History : 00
RMA Number : 0-0-0-0
RMA History : 00
Deviation Number : 0
Product (FRU) Number : PA-POS-2OC3
Top Assy. Part Number : 800-21857-02
EEPROM format version 4
EEPROM contents (hex):
0x00: 04 FF 40 03 E3 41 01 00 C1 8B 4A 41 45 30 37 35
0x10: 32 30 44 59 4C 82 49 20 1C 02 42 41 30 03 00 81
0x20: 00 00 00 00 04 00 88 00 00 00 00 CB 94 50 41 2D
0x30: 50 4F 53 2D 32 4F 43 33 20 20 20 20 20 20 20 20
0x40: 20 C0 46 03 20 00 55 61 02 FF FF FF FF FF FF FF
0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Cisco 7500 Series Routers with VIP—Example Output of the show diag Command

Following is an example of the show diag command that shows a PA-MC-STM-1 installed in port adapter slot 2 on a VIP4-80 in interface processor slot 0:

Router# show diag 2
Slot 2:
	Physical slot 2, ~physical slot 0xD, logical slot 2, CBus 0
	Microcode Status 0x4
	Master Enable, LED, WCS Loaded
	Board is analyzed 
	Pending I/O Status: None
	EEPROM format version 1
	VIP4-80 RM7000 controller, HW rev 2.02, board revision B0
	Serial number: 18314858  Part number: 73-3143-02
	Test history: 0x00        RMA number: 00-00-00
	Flags: cisco 7000 board; 7500 compatible
	EEPROM contents (hex):
	  0x20: 01 22 02 02 01 17 76 6A 49 0C 47 02 00 00 00 00
	  0x30: 58 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

	Slot database information:
	Flags: 0x4	Insertion time: 0x1DB8 (00:02:13 ago)

	Controller Memory Size: 64 MBytes DRAM, 65536 KBytes SRAM

	PA Bay 0 Information:
Channelized OC3/STM-1 MM PA, 1 port
EEPROM format version 4
		HW rev 1.00, Board revision 04
		Serial number: MIC043626TF  Part number: 73-4762-03 

Using the show interfaces Command

Display status information (including the physical slot and interface address) for the interfaces you specify using the show interfaces command.

For complete descriptions of interface subcommands and the configuration options available for the supported interfaces, refer to the publications listed in the "Related Documentation" section on page ix.


Note The outputs that appear in this document may not match the output you receive when running these commands. The outputs in this document are examples only.


The following sections provide platform-specific output examples of the show interfaces command:

Catalyst 6000 Family Switches and Cisco 7600 Series Internet Routers with FlexWAN Module—Example Output of the show interfaces Command

Cisco 7200 VXR Routers—Example Output of the show interfaces Command

Cisco 7201 Router—Example Output of the show interfaces Command

Cisco 7500 Series Routers with VIP—Example Output of the show interfaces Command

Catalyst 6000 Family Switches and Cisco 7600 Series Internet Routers with FlexWAN Module—Example Output of the show interfaces Command

Following is an example of the show interfaces command that shows a PA-MC-STM-1installed in a FlexWAN module:

Console# show interfaces
Vlan1 is up, line protocol is up 
  Hardware is Cat6k RP Virtual Ethernet
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 2 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     30459 packets input, 2875285 bytes, 0 no buffer
     Received 30419 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     343 packets output, 110047 bytes, 0 underruns
     0 output errors, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out

Cisco 7200 VXR Routers—Example Output of the show interfaces Command

Following is an example of the show interfaces serial command that shows all of the information specific to interface port 0 on a PA-MC-STM-1 installed in port adapter slot 1 of a Cisco 7200 VXR router:

Router1-VXR> show interfaces serial 1/0.1/1/1/1:0
Serial1/0.1/1/1/1:0 is up, line protocol is up 
  Hardware is Channelized STM-1 controller
  MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:01, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     50594 packets input, 1216008 bytes, 3 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     223 input errors, 24 CRC, 75 frame, 0 overrun, 0 ignored, 124 abort
     59092 packets output, 6639740 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions no alarm present

Cisco 7201 Router—Example Output of the show interfaces Command

Following is an example of the show interfaces command for the Cisco 7201 router:

Router# show interfaces

GigabitEthernet0/0 is up, line protocol is up
  Hardware is MV64460 Internal MAC, address is 0019.56c5.2adb (bia
0019.56c5.2adb)
  Internet address is 209.165.200.225 
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 45/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is RJ45
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:07:03, output 00:00:07, output hang never
  Last clearing of "show interface" counters 00:00:04
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 180240000 bits/sec, 430965 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     2222975 packets input, 133378500 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out 

Cisco 7500 Series Routers with VIP—Example Output of the show interfaces Command

Following is an example of the show interfaces serial command used with a VIP. In this example, the PA-MC-STM-1 is installed in port adapter slot 0 of a VIP in interface processor slot 2.

Router# show interfaces serial 2/0/0.1/1/1/1:1

Serial2/0/0.1/1/1/1:1 is up, line protocol is up 
Hardware is cyBus Channelized OC3/STM-1 PA
Internet address is 105.105.105.1/24
MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, rely 255/255, load 36/255
Encapsulation HDLC, loopback not set
Keepalive not set
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 1/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
Conversations  0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 286000 bits/sec, 36 packets/sec
5 minute output rate 284000 bits/sec, 36 packets/sec
8019 packets input, 11695347 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
7991 packets output, 11650799 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
2 carrier transitions no alarm present
Timeslot(s) Used:1-31, Transmitter delay is 0 flags, transmit queue length 6
[Additional display text for remaining interfaces omitted]

Proceed to the next section, "Using the ping Command to Verify Network Connectivity," to check network connectivity of the PA-MC-STM-1 and switch or router.

Using the ping Command to Verify Network Connectivity

Using the ping command, you can verify that an interface port is functioning properly. This section provides a brief description of this command. Refer to the publications listed in the "Related Documentation" section on page ix for detailed command descriptions and examples.

The ping command sends echo request packets out to a remote device at an IP address that you specify. After sending an echo request, the system waits a specified time for the remote device to reply. Each echo reply is displayed as an exclamation point (!) on the console terminal; each request that is not returned before the specified timeout is displayed as a period (.). A series of exclamation points (!!!!!) indicates a good connection; a series of periods (.....) or the messages [timed out] or [failed] indicate a bad connection.

Following is an example of a successful ping command to a remote server with the address 10.0.0.10:

Router# ping 10.0.0.10 <Return>
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 10.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/64 ms
Router#

If the connection fails, verify that you have the correct IP address for the destination and that the device is active (powered on), and repeat the ping command.

Proceed to the next section, "Using loopback Commands," to finish checking network connectivity.

Using loopback Commands

With the loopback test, you can detect and isolate equipment malfunctions by testing the connection between the PA-MC-STM-1 interface and a remote device such as a multiplexer interface. The loopback subcommand places an interface in loopback mode, which enables test packets that are generated from the ping command to loop through a remote device. If the packets complete the loop, the connection is good. If not, you can isolate a fault to the remote device in the path of the loopback test.

The PA-MC-STM-1 supports two loopback modes at the sonet controller level: local and network.

Use the loopback {local | network} command to set the loopback mode, as shown below:

Router(config)# controller sonet 1/1/0
Router(config-controller)# loopback network

When the loopback local command is used, all data transmitted to the network is internally looped back to the receiver. In this loopback mode, the serial interfaces should go into up/up looped state.

When the loopback network command is used, all data received from the connected device is transmitted back unchanged. In this loopback mode, T1 serial interfaces are not working.

The PA-MC-STM-1 also supports loopback on E1 lines mapped to a TUG-3 or AU-3.

To specify a loopback on an E1 line that has been mapped to a TUG-3, use the tug-2 e1 loopback command in configuration controller tug3 mode.

To specify a loopback on an E1 line that has been mapped to an AU-3, use the tug-2 e1 loopback command in configuration controller au3 mode.

The complete tug-2 e1 loopback command syntax is:

tug-2 tug-2 number e1 e1-number loopback {local | network {line | payload}}

To disable the loopback, use the no form of this command:

[no] tug-2 tug-2 number e1 e1-number loopback {local | network {line | payload}}