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Access the User Workspace Management Interface
After you have started the Cisco Modeling Labs server, you can access the User Workspace Management
interface to manage user accounts, projects, licenses, and virtual machine images on the CiscoModeling Labs
server.

To access the User Workspace Management interface, complete the following steps:

Step 1 In a web browser, enter the IP address or hostname in the format, http://<IP address | hostname>.
The CML Server main menu page is displayed.
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Figure 1: CML Server Main Menu

Step 2 Click User Workspace Management to access the User Workspace Management interface.
Step 3 Log in to the User Workspace Management interface using the username uwmadmin and the password password.

You can log in to the User Workspace Management as either an administrator or as a non-administrative
user. Uwmadmin is an administrative user.

Note

The application opens on the Overview page.
Figure 2: User Workspace Management Overview
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User Management Workspace User Types
Within the UserManagementWorkspace interface there are two types of users available. These are administrator
and non-administrator user. The following tables describe the different functions available for each user type.

Table 1: Available Functions for Administrator Users

DescriptionFunction

Allows you to view current system version information, physical resource
usage, and a list of all deployed simulations. You can stop all or selected
simulations.

Overview

Allows you to import and export projects. You can also add new projects,
enable, disable, modify, and delete current projects.

Projects

Allows you add new users, enable, disable, modify, and delete current users.Users

Under System Configuration, you can set configuration parameters. Under
System Status, you can collect, view and download system status information.

CML Server

Allows you to add and delete L2 Flat IP, L3 Snat IP, and Management IP
allocations for projects.

Connectivity

Allows you to delete nodes, networks, ports and IP allocations, as well as
disable some host services when problems are encountered.

VM Control

Allows you to manage product licenses on the system.Licenses

Allows you add new images, modify, and delete current images. You can
also modify and delete image snapshots. You can add and delete flavors and
import and export subtypes. You can also create a new subtype based on one
of the available built in subtypes. You can manage and add new LXC images
and templates.

Node Resources

Allows you to add, delete, and refresh files from Git repositories.Repositories

Allows you to access STD and UWM API documentation.Documentation

Table 2: Available Functions for Non-Administrator Users

DescriptionFunction

Review and operate a user's own simulations.My Simulations

Review simulations in a user's own project.Project Simulations

Review a user's own IP address allocations.Connectivity

Review details for flavors and subtypes. Review and add new images, LXC
images and templates for use by the user's own project.

Node Resources

Allows you to add, delete, and refresh files from Git repositories.Repositories
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DescriptionFunction

Allows you to access STD and UWM API documentation.Documentation

Projects (Admin User)
Within the User Workspace Management interface, a project represents a set of resources that are available
to all users of that project. It has the following characteristics:

• By default, each project is created with one user account that has the same name as the project.
• Each user belongs to exactly one project. Users should typically each have a project of their own, hence
creating a new project is the preferred and efficient process for adding new users.

• Additional users can be assigned to a project as required.
• If a user is added to a project, the username of the user is prefixed with the project name.
• Deleting a user account does not delete a project that the user is assigned to.
• Deleting a project deletes all users of the project.

In the Projects page, you can perform a number of operations for projects. These operations are:

DescriptionOperation

Imports a project and its users from a JavaScript Object Notation (JSON) or
tab-Separated values (TSV) file.

Import

Exports a project and its users as a JSON or TSV file.Export

Creates a new project and its default user.Add

Enables a selected project.Enable

Disables a selected project.Disable

Modifies details for a selected project.Modify

Deletes a selected project and its users.Delete

Create a Project
To create a new project, and a user for the project complete the following steps:

Step 1 In the User Workspace Management interface, click Projects.
The Projects page, which lists all of the current projects, appears.

Step 2 Click Add to create a new project.
The Create Project page appears.
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Figure 3: Create a New Project

Step 3 UnderGeneral Settings, add a name and a description for the project. In theExpires field, you can either add an expiry
date for the project or accept the default, which is Never, meaning the project will never expire. Leave the Enabled
check box checked to enable the project for use.

Step 4 Under Project Quotas, you can either accept the default values for the system quotas or increase or decrease them
based on your project requirements:

• Instances quota is the maximum number of virtual machines of any type that can be operational at any given time
within the project per user or for all users associated with that project.

• RAM (MB) is the maximum RAM that can be consumed by virtual machines running in the project per user or
for all users associated with that project.

• VCPUS is the maximum number of virtual cores consumed by the virtual machines running in the project.

Step 5 Click Create.

The Edit User page appears.
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Figure 4: Edit the Project User

Using this window, you can add details for the new user created when the project is created.

Step 6 In the Password and Password Again fields, enter a new password for the user.

The default password can be used or a more meaningful password can be entered. This password can also be
changed at a later time.

Note

Step 7 In the Email field, add a valid email address for the user.
By default, the user is assigned a member role, which means the user is a non-admin account. Set Role to admin if the
user needs to perform the same administrative functions as the uwmadmin user.

Step 8 In the Expires field, you can add an expiry date for the user or accept the defaultNever. Leave the Enabled check box
checked to enable the project for immediate use. Alternatively, you can set up a project and users, but you cannot enable
them to be configured and available at a later time.

Step 9 Click Save to save the changes for the user.
Step 10 (Optional) To confirm that the project has been added, click Projects to view the newly added project, and click Users

to view the newly added user.

Export a Project
Export allows you to export selected projects and all their users to a JSON or TSV file.

To export a project and all its users, complete the following steps:

Step 1 Check the check box beside the project or projects for export.
Step 2 Click Export to export the selected projects and all their users.

Step 3 From the drop-down list, choose the type of file to export to, JSON or TSV.
The Open dialog box appears.

Step 4 Click the Save File radio button and click OK to save the file.
The exported file is saved to the specified location.
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Import a Project
Files for import must be in the JSON or TSV format and must have previously been exported from the User
Workspace Management interface.

The uwmadmin project and user are not modified by this function when imported data contains it.Note

To import a project and its users, complete the following steps:

Step 1 Click Import to import a new project and its associated users.
The Import Projects and Users page appears.

Step 2 Click Browse to locate the applicable JSON or TSV file for import.

If you import projects and users that already exist, they will be updated.Note

Step 3 Click Import.
The newly imported project is listed on the Projects page.

Users (Admin User)
Within the User Workspace Management interface, you can manage user accounts from the Users page.
User accounts permit access to the Cisco Modeling Cisco Modeling Labs server from the Cisco Modeling
Labs client.

In the Users page, you can perform a number of operations for users. These operations are:

DescriptionOperation

Creates a new user account.Add

Enables a selected user account.Enable

Disables a selected user account.Disable

Modifies details for a selected user account.Modify

Deletes a selected user account.Delete

Create a User
To create an additional user under an existing project, complete the following steps:

A Project should be created for each intended user of the CML server. It is not recommended to add users
to an already existing Project. Keep in mind that the uwmadmin user cannot start simualtions.

Note
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Step 1 In the User Workspace Management interface, log in as admin and click Users.
The Users page, which lists all the users, appears.

Step 2 Click Add to create a new user.
The Create User page appears.
Figure 5: Create a New User

Step 3 In the Username field, enter a username for the new user.

To create multiple users, click the Add (+) icon to the right of the Username field.Note

Step 4 In the Password and Password Again fields, enter a password for the new user.
Step 5 In the Email field, enter a valid email address for the user.
Step 6 From the Project drop-down list, choose the applicable project for the user.
Step 7 From the Role drop-down list, choose the applicable role for the user.

A user with administrative rights has administrative rights across the entire system.Note

Step 8 In the Expires field, you can either add an expiry date for the user or accept the default, which is Never.
Step 9 Leave the Enabled check box checked.
Step 10 Click Create.

The User <Project Name>-<Username> page appears.

This page presents details and project quotas for the user.
Step 11 (Optional) ClickModify User to amend the details for a user, or click Delete User to delete the user.
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Step 12 Click Users to view the newly created user.

CML Server (Admin User)
Within the User Workspace Management interface, under CML Server, you are able to make changes to
your Cisco Modeling Labs server configuration under the System Configuration option.

System Configuration
Within the UserWorkspaceManagement interface, navigate toCMLServer > SystemConfigurationUnder
System Configuration, you will find settings that pertain to the Cisco Modeling Labs server, and network
settings for simulation connectivity.

The hostname, management IP, and system (INT) network of the CML server cannot be modified after
deployment.

Note

Table 3: System Configuration Controls

DescriptionTab Name

Settings for NTP, HTTP(S) proxy, docker registry, and
nameservers.

Remote Connections

Enable / Disable (Disable is the default) RAMmanagement
features.

Hardware

Connect and configure simulation flat networks to access
external virtual or physical environments.

Shared Networks

NAT connection for nodes running inside a simulation to
external resources.

L3 SNAT

Default TCP port number allocation for system resources and
simulation node access.

Service Ports

Enable / Disable (Enable is the default) the primary user
guest (default) or modify user information, including
uwmadmin user password system-wide user restrictions.

Users

Enable / Disable (Disable is the default) Serial port timeout
setting.

Simulation Details

Cluster tab is visible only when the CML server has been
deployed as a Cluster Controller during First Boot
configuration. TheCluster option can only be enabled during
initial deployment.

Activate / De-Activate compute nodes or modify its
management IP address when static IP address has been
enabled on the CML management interface.

Cluster (optional)
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System Tools
Within the User Workspace Management interface, under CML Server > System Tools you can view
various statistics concerning the usage and operation of your system and check on server status and system
services. You also have the ability to download system log files.
Figure 6: System Tools Options

To download the system log files, click Download System Logs. A dialog box is displayed where you can
opt to open or save the system log file.

System Statistics
You can view various statistics concerning the usage and operation of your Cisco Modeling Labs system.
System statistics are available from the User Workspace Management interface under CML Server >
System Tools > Display Statistics.

The following areas are covered:
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Table 4: System Statistics

DescriptionArea

Lists the memory usage history per day, week and month and their average and
maximum usage stats.

Statistics

Lists the number of current projects and users.Projects and Users

Lists details for the number of active simulations and nodes for the last week,
the last month, the previous 24 hours, and those currently running.

There are two further categories:

Simulations
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DescriptionArea

Lists the subtypes and their average and maximum usage stats.Subtype Usage in
Simulations

Lists the number of simulation/node failures for the last week, the last month,
and the previous 24 hours.

Simulation/node
Operation Failures
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DescriptionArea

Lists details for the number of configurations generated in the last week, the last
month, and the previous 24 hours, including the number of invalid topologies
encountered. The category Subtype Usage in Configured Topologies lists the
subtypes used in configuration requests along with their average and maximum
usage stats.

AutoNetkit

System Health Status
You can check on server status and system services that are running using the Check Health Status option.
It performs a system check and generates a report. It is available from the User Workspace Management
interface under CML Server > System Tools > Check Health Status.

Available options on the Health Status page are:

• Check Again: Allows you to run the health status check again.

• Download: Allows you to open or download the health status log file.

• Display RAW Report: Displays the health status log file to screen.

System Operation Check
The System Operation Check performs a series of tests to ensure that your system is in a fully functional state.
These tests include checking all of the core services as well as starting up a small simulation. The results will
confirm if your system is performing as expected or if there are problems, and if so, in which area(s) the
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problems lie. The tests will take ~5 minutes to complete. the system operation check is available from the
User Workspace Management interface under CML Server > System Tools > System Operation Check.
Figure 7: System Operation Check

The following areas are tested:

Table 5: System Operation Check Tests

DescriptionArea

Click each entry to view further details of the tests run.Service
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DescriptionArea

Click each entry to view further details of the tests run.VIRL API Service

Click each entry to view further details of the tests run.Simulation

The Summary table provides details of tests passed, failed, skipped or not applicable.

Available options on the System Operation Check page are:

• Download Results: Allows you to open or download the system operation check log file.

• Rerun Tests: Allows you to run the tests again.

Download
Within the User Workspace Management interface, under CML Server > Download, you are able to
download various Cisco Modeling Labs client versions and Python libraries as shown.
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Figure 8: Files Available for Download

Double-click the applicable file to download it.

Cluster (Optional)
Figure 9: Cluster Management Controls
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Table 6: CML Server Troubleshooting Tools

DescriptionTab Name

Displays newly and previously discovered compute nodes. A
Power icon is displayed next to any compute node that is
unreachable or has been shutdown or forcefully removed.

Controls

Displays status of all connected or previously connected
compute nodes. <br />Minions lists all down, up, and
registered compute nodes in json format. <br />DHCPLeases
lists raw DHCP information, including the IP address that are
assigned to a compute node and its lease time.

Status

Cluster Status: The figure below shows the compute1 node connected and ready. This node must be set to
Active under CML Server > System Management > Cluster.
Figure 10: Compute Node 1 Status

User Workspace Management
17

User Workspace Management
Download



Connectivity
Within theUserWorkspaceManagement interface, theConnectivity page provides details on all OpenStack
ports available on the external (FLAT and SNAT) and project management networks.

• L2 FLAT IP address allocations—Create an externally reachable fixed IP address for a project.
• L3 SNAT IP address allocations—Create a floating IP address for a project. Floating IPs are externally
reachable and are mapped to an internal fixed IP address.

• Project Management IP address allocations—Create a fixed IP address on the management network of
the selected project. This IP address can be statically assigned to the nodes.

Create a Port Connection
To create a new port connection, complete the following steps:

Step 1 In the User Workspace Management interface, click Connectivity.
The Outside Connections page, which lists all current port connections appears.

Step 2 Connections are grouped into three areas: L2 FLAT, L3 SNAT, and Project Management. Click Add in the applicable
group to create the required port connection for that type.
The corresponding Add IP Allocation page appears.

Step 3 Complete the fields as required for the applicable port connection.

DescriptionFieldConnection Type

Choose a project from the drop-down
list.

Owning ProjectLayer 2 FLAT IP Address Allocations

Choose a FLAT network from the
drop-down list.

FLAT Network

Enter a name for the new port
connection.

Name

Enter a custom IP address from the
range defined by the prefix displayed,
or to have an address automatically
assigned, leave this field blank.

Fixed IP address
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DescriptionFieldConnection Type

Choose a project from the drop-down
list.

Owning ProjectLayer 3 SNAT IP Address Allocations

Enter a name for the new port
connection.

Name

Enter a custom IP address from the
range defined by the prefix displayed,
or to have an address automatically
assigned, leave this field blank.

Fixed IP Address

Enter a custom IP address from the
range defined by the prefix displayed,
or to have an address automatically
assigned, leave this field blank.

Floating IP Address

Enter a name for the new port
connection.

NameProject Management

Enter a custom IP address from the
range defined by the prefix displayed,
or to have an address automatically
assigned, leave this field blank.

Fixed IP Address

Step 4 Click Create.

The new connection is created and its details are displayed in the Connectivity page.

Using the VM Control Tool (Admin User)
The VM Control tool is available to aid system administrators with troubleshooting issues encountered in
the User Workspace Management interface. The tool enables system administrators to stop specific

User Workspace Management
19

User Workspace Management
Using the VM Control Tool (Admin User)



components of an active session. In circumstances where components of a session fail to be deleted through
the normal shutdown methods, this tool enables system administrators to remove blocked components.

VM Control Nodes
TheNodes page lists all the nodes for all the currently running projects for all users. You can delete a specific
node or all the nodes for a specific project or projects.
Figure 11: Nodes Page

Step 1 To delete a specific node:
a) In the node list for the applicable project, check the corresponding check box.
b) Click Delete in the Options column.

The node is deleted.

Step 2 To delete all the nodes for a specific project:
a) In the node list for the applicable project, check the corresponding Name check box.

When you check the Name check box for a particular project, the check boxes for all the nodes in the
project are automatically checked. You cannot uncheck individual nodes within a project; either all the
nodes or no nodes are checked.

Note

b) Click Delete Selected.
All nodes for the particular project are deleted.

VM Control Networks
TheNetworks page lists all the networks for all the currently running projects for all the users. You can delete
a specific network or all the networks for a specific project or projects.
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Figure 12: Networks Page

Step 1 To delete a specific network:
a) In the network list for the applicable project, check the corresponding Name check box.
b) Click Delete in the Options column.

The network is deleted.

Step 2 To delete all the networks for a specific project:
a) In the network list for the applicable project, check the corresponding Name check box.

When you check theName check box, the check boxes for all the networks in the project are automatically
checked. In the Networks page, for each user project, two networks are listed in blue with an information
icon. These two networks are specifically created for use by all users of the project when the project is
created. These networks cannot be recreated automatically; the project would need to be deleted and recreated
as a whole. We recommend that you do not delete these networks. Uncheck the check boxes for these two
networks before clicking Delete Selected.

Caution

b) Click Delete Selected.
All the networks for the particular project are deleted.

VM Control Ports and Floating IPs
The Ports and Floating IPs page lists all the ports and floating IPs for all the currently running projects for
all the users. You can delete a specific port or floating IP or all the ports and floating IPs for a specific project
or projects.
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Figure 13: Ports and Floating IPs Page

Step 1 To delete a specific port or floating IP:
a) In the port or floating IP list for the applicable project, check the corresponding check box.
b) Click Delete in the Options column.

The port or floating IP is deleted.

Step 2 To delete all the ports or floating IPs for a specific project:
a) In the port or floating IP list for the applicable project, check the Name check box.

When you check the Name check box for a particular project, the check boxes for all the ports or floating
IPs in the project are automatically checked. You can uncheck individual ports or floating IPs within the
project as required.

Note

b) Click Delete Selected.
All ports or all floating IPs for the particular project are deleted.

VM Control Hosts
The Hosts page lists all the compute services and network agents. Maintenance mode on a host disables the
compute service on that node. It prevents new virtual machines from being deployed on that host.
Figure 14: Hosts Page
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VM Control Allocated Ports
The Allocated ports page lists details for all of the currently allocated ports on the system.
Figure 15: Allocated Ports Page

Cisco Modeling Labs Licenses (Admin User)
Within the User Workspace Management interface, you can manage Cisco Modeling Labs licenses. A
license specifies the options that are enabled for Cisco Modeling Labs.

The Licenses page provides details on all the licenses that are currently installed on the CML server. These
include the license ID, type of license, number of nodes per license, and the expiry date.
Figure 16: Licenses Page

Register a Cisco Modeling Labs License
To register a license, complete the following steps:
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Step 1 Open the email containing your Cisco Modeling Labs license key.
Step 2 Using a text editor, open the attached .lic file.
Step 3 In the User Workspace Management interface, click Licenses.

The Licenses page, which lists all valid licenses, appears.
Step 4 Click Register License to register a valid license.

The Register licenses page appears.
Figure 17: Register Licenses

Step 5 Copy and paste the license key from the .lic file into the Licenses text area.
Step 6 Click Register.

The license is applied.
Step 7 Return to the Licenses page to view the newly registered license.

Node Resources
Within theUserWorkspaceManagement interface, underNodeResources, you canmanage virtual machine
run-time parameters and virtual machine images. You can also manage LXC container images and templates.
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Figure 18: Available Node Resources

Virtual Machine Flavors
Within the User Workspace Management interface, as part of the creation process for virtual machine
images, a virtual machine flavor is created. Flavors are used in each virtual machine to define the CPU, memory
(RAM) allocation, disk space, the number of cores, and so on.

In the Flavors page, you can perform two operations for flavors. These operations are:

DescriptionOperation

Creates a new flavor.Add

Deletes a selected flavor.Delete

Create a Virtual Machine Flavor
To create a new virtual machine flavor, complete the following steps:

Step 1 In the User Workspace Management interface, in admin mode, click Flavors.
The Flavors page, which lists all of the available flavors, appears.

Step 2 Click Add to create a new flavor.

The Create Flavor page appears.
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Figure 19: Create a Flavor

Step 3 In the Name field, enter a name for the flavor.
Step 4 From the RAM drop-down list, choose the amount of memory allocation for the flavor.
Step 5 From the Virtual CPUs drop-down list, choose the number of virtual CPUs for the flavor.
Step 6 Click Create to create your virtual machine flavor.

The Flavors page appears with the newly created flavor listed.
Step 7 Under the Options column, use the Delete option to delete a virtual machine flavor.

Images
Within the User Workspace Management interface, you can add new images, update details for existing
images, or delete images from the system. Additionally, you can take a snapshot of the disk content of a virtual
machine image. This newly created user-specific disk image can be used in other simulated sessions.

Cisco Modeling Labs 1.5 includes the following images built into the Cisco Modeling Labs client:

• Cisco IOSv Software Release 15.6(3)T

• Cisco IOSv Layer 2 Switch Software Release 15.2 (03.2017)

• Cisco IOS XRv Software Release 6.1.3 CCO

• Linux server (Ubuntu 16.04.3 Cloud-init)

• Unmanaged switch
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• Cisco ASAv Software Release 9.8.2

For the most up-to-date list of virtual images, see Release Notes for Cisco Modeling Labs 1.5.

The following demo images are available from the FileExchange:

• Cisco IOS XRv 9000 Software Release 6.2.2 demo image

• Cisco CSR1000v Software Release 16.5.1b XE-based demo image

• Cisco NX-OSv 9000 Software Release 7.0.3.17.1 demo image

In the Images page, you can perform a number of operations for images. These operations are:

DescriptionOperation

Creates a new virtual machine image.Add

Modifies details for a selected virtual machine image.Modify

Deletes a selected virtual machine image.Delete

Create a Virtual Machine Image
To create a new virtual machine image, complete the following steps:

Step 1 In the User Workspace Management interface, log in as admin and click Images.
The Images page, which lists all of the available registered images, appears.

Step 2 Click Add to create a new image.
The Create VM Image page appears.
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Figure 20: Create VM Image

Step 3 From the Owning Project drop-down list, choose the appropriate project for the new image.
Step 4 Click the Project Specific check box if you want the new image to be private and only available to the owning project.
Step 5 From the Subtype drop-down list, choose the appropriate subtype for the new image.
Step 6 In the Name/Version field, enter a name or version number for the image.
Step 7 In the Release field, enter the release number for the image.
Step 8 Click the appropriate Image Source: File on Server, URL, or Local Image File.
Step 9 In the Image Path field, enter a path on the server/virtual machine (an HTTP, FTP or TFTP URL) or choose a file to

upload.
Step 10 To upload an image from your own device, click Browse to navigate to the image file.
Step 11 Click Create to create your virtual machine image.

The creation process can take a while depending on where the image file is located relative to the Cisco
Modeling Labs server. Both virtual machine disk (VMDK) and QEMU copy-on-write 2 (QCOW2) image
formats are supported. As part of the creation process for images, a default flavor is also created if missing,
which contains information on the CPU and memory allocation for the virtual machine image.

Note

The Image <Image Name> page, which contains the details and properties of the virtual machine image, appears.

Step 12 Click Images to view the newly added image.
Step 13 Under the Options column, use theModify or Delete options to amend the details for the virtual machine or to delete

a virtual machine image. After the image is installed, it is available for users to select for their topology simulation.
Step 14 In the Cisco Modeling Labs client, click File > Preferences > Node Subtypes.

The Node Subtypes dialog box is displayed.
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Figure 21: Available Node Subtypes

Step 15 In the Node Subtypes dialog box, click Fetch from Server.
The Confirm dialog box is displayed.

Step 16 Click OK to update the list of node subtypes based on the currently configured Cisco Modeling Labs server.

Create an Image Snapshot
When a Linux server is present in a running simulation, you can take a snapshot of the disk content of the
server. This newly created user-specific disk image can be used in other simulated sessions.

To take a snapshot of the server's disk content, complete the following steps.

Step 1 Log in to the User Workspace Management interface.

You must log in as a user other than the uwmadmin user, for example, guest.Note

Step 2 On the Overview page, under Sessions, choose the applicable running session.
A list of active virtual machines is displayed.

Step 3 Choose the applicable virtual machine image, and under the Options column, click the Create Snapshot icon.
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Figure 22: Create Snapshot Icon

Project details for the newly created snapshot are displayed.
Figure 23: Newly Created Image Snapshot

The new image snapshot is listed under the Image Snapshot section on the Images page.
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Figure 24: Available Image Snapshots

The image snapshot can be reused in the Cisco Modeling Labs client under Properties > Node > VM Image.

Containers
In the User Workspace Management interface, the Containers page provides a list of LXC images and
templates. Here you can manage LXC container images and templates.

In the Containers page, you can perform a number of operations for LXC images and templates. These
operations are:

DescriptionOperation

Create a new LXC image and/or LXC template.Add

Modify details for LXC imagesModify

Delete LXC images and templates as required.Delete

Create an LXC Image
To create a new LXC image, complete the following steps:

Step 1 Click Node Resources > Containers in the User Workspace Management interface.
The Containers page, which lists all of the available LXC images and templates, appears.

Step 2 Click Add to create a new LXC image.

The Create LXC Image page appears.
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Figure 25: Create an LXC Image

Step 3 Click the Project Specific check box if you want the new image to be private and only available to the owning project.
Step 4 Choose the appropriate subtype for the new LXC image from the Subtype drop-down list.
Step 5 Enter a name or version number for the image in the Name/Version field.
Step 6 Enter the release number for the image in the Release field.
Step 7 Click the appropriate Image Source: File on Server, URL, or Local Image File.
Step 8 Enter a path on the server/virtual machine (an HTTP, FTP or TFTP URL) or choose a file to upload in the Image Path

field.
Step 9 Click Browse to navigate to the LXC image file to upload an image from your own device.
Step 10 Click Create to create your LXC image.
Step 11 Click Images to view the newly added image.
Step 12 Under the Options column, use theModify or Delete options to amend the details for the LXC image or to delete an

LXC image. After the LXC image is installed, it is available for users to select for their topology simulation.

Create an LXC Template
To create a new LXC template, complete the following steps:

Step 1 Click Node Resources > Containers in the User Workspace Management interface.
The Containers page, which lists all of the available LXC images and templates, appears.

Step 2 Click Add to create a new LXC template.
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The Create LXC Template page appears.
Figure 26: Create a LXC Template

Step 3 Click the Project Specific check box if you want the new image to be private and only available to the owning project.
Step 4 Choose the appropriate subtype for the new LXC image from the Subtype drop-down list.
Step 5 Enter a name or version number for the image in the Name/Version field.
Step 6 Enter the release number for the image in the Release field.
Step 7 Click the appropriate Template Source: File on Server, URL, or Local Image File.
Step 8 Enter a path on the server/virtual machine (an HTTP, FTP or TFTP URL) or choose a file to upload in the Template

Path field.
Step 9 Click Browse to navigate to the LXC image file to upload from your own device.
Step 10 Click Create to create your LXC template.
Step 11 Click Images to view the newly added LXC template.

Subtypes
In the User Workspace Management interface, the Subtypes page provides a list of integrated subtypes,
which users can use as templates to create their own custom subtypes. Using the Specialize option for a
subtype, a user can duplicate the subtype template and make the necessary updates to create a new custom
subtype. Subtypes can be imported and exported, which allows users to apply their custom subtypes to other
Cisco Modeling Labs server installations.

In the Subtypes page, you can perform a number of operations for subtypes. These operations are:
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DescriptionOperation

Imports a subtype from a JSON file.Import

Exports a subtype to a JSON file.Export

Duplicates an available subtype to create a custom subtype.Specialize

Import a Subtype
Subtypes for import must be available in a JSON file.

To import a subtype, complete the following steps:

Step 1 Click Import to import a new subtype.
The Import Subtypes page appears.

Step 2 Paste the subtype details from the JSON file into the text area.
Step 3 Click Import.

The newly imported subtype is listed on the Subtypes page.
Step 4 (Optional) Click Specialize to create a custom subtype based on the newly imported subtype, clickModify to amend the

details for the subtype, or click Delete to delete the subtype.

Create a Custom Subtype
To create a custom subtype, complete the following steps:

Step 1 For the applicable subtype, under the Options column and click the Specialize icon.
The Specialize Subtype page appears.

Step 2 Update the subtype fields as required.

You can use the default values on the Subtypes page; however, you must provide a new name for the new
subtype.

Note

Table 7: New Subtype Fields

DescriptionField

Enter a name for the new subtype.Name of new subtype

Provide a description of the plug-in to be created.Description of plugin

Enter a name for the management interface.Name of management interface

Enter names for dummy interfaces, inserted between management interface
and first data interface.

Names of dummy interfaces

Provide the interface name format, for example, GigabitEthernet0/{0}.Pattern for data interface names

Enter a valid integer for the first interface.First data interface number
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DescriptionField

Enter the maximum allowed number of interfaces.Max count of data interfaces

Enter the permitted number of interfaces per line card (LC) allowed.Number of interfaces per LC

Choose the number of interfaces allowed. Options are 0, 1, 2, 3, and 4.Number of serial interfaces

Choose the type of console connection. Options are Telnet or SSH.Protocol for network CLI

Allow VNC access. Enabled when the check box is checked.Make VNC access available

Enter a name for the subtype icon that is displayed in the Cisco Modeling Labs
client.

Name of icon for GUI

Allow the subtype icon to be displayed in the Cisco Modeling Labs client.
Enabled when the check box is checked.

Show subtype on GUI palette

Choose the type of configuration disk. Options are cdrom, disk, cloud-init,
iso9660, and vfat. For LXC subtypes, set to lxc.

Configuration disk type

Choose the ISO 9660 level in cdrom disk. Options are 2, 3, and 4.ISO 9660 Level in cdrom Disk

Enter a name for the configuration drive file.Name of file for config drive

Choose a virtual interface model. Options are e1000, virtio, and rtl8139.Virtual interface model

Choose a main disk bus model. Options are ide, virtio, and scsi.Main disk bus model

Specify the amount of RAM (MB) to use for each node.RAM (MB) allocated per node

Choose the number of CPUs to allocate per node. Value range is 1 to 16.Number of CPUs allocated per node

Enter any additional image properties, set on all images added for that subtype
through the Create New Image page.

Extra comma-separated image
properties

Enter a name for the default image.Name of default image

Enter a name for the default flavor for VM-based subtypes and a default
template name for LXC subtypes.

Name of default flavor

You can choose to go with the default values on the Subtypes page; though you must provide a name for the
new subtype.

Note

Step 3 When completed, click Create to create the new custom subtype.
The new subtype is created and its details are displayed in the Subtypes page for the new subtype.

For a newly created subtype, the value in the Dynamic column is Yes, which indicates that the subtype is not
built into the server, and therefore may be modified or deleted.

Note

Step 4 (Optional) On this page, you can click Specialize to create a custom subtype based on the newly created subtype, click
Modify to amend the details for the subtype, or click Delete to delete the subtype.

Step 5 Click the Subtypes tab to see the custom subtype listed on the page.
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Cluster Configuration and Defaults
The following configuration elements defined in the /etc/settings.ini file or via the UserWorkspaceManagement
interface are used to define Cisco Modeling Labs OpenStack Cluster configurations.

Table 8: Cluster Configuration Elements

DescriptionDefaultParameter

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 1 in the cluster.

Falsecompute1_active

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 2 in the cluster.

Falsecompute2_active

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 3 in the cluster.

Falsecompute3_active

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 4 in the cluster.

Falsecompute4_active

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 5 in the cluster.

Falsecompute5_active

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 6 in the cluster.

Falsecompute6_active

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 7 in the cluster.

Falsecompute7_active

Set to True for each
available compute node (1
through 8).

Specifies the absence or
presence of the compute
node 8 in the cluster.

Falsecompute8_active

Documentation
Within the User Workspace Management interface, you can access STD API and User Workspace
Management API documentation. It is available from User Workspace Management > Documentation.

To access the STD API, click STD API. The STD API page is displayed.

To access the User Workspace Management API, click UWM API. The UWM API page is displayed.
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