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Preface

• Document Conventions, page ix

• Related Documentation, page xi

• Obtaining Documentation and Submitting a Service Request, page xi

Document Conventions
This document uses the following conventions:

DescriptionConvention

Both the ^ symbol and Ctrl represent the Control (Ctrl) key on a keyboard. For
example, the key combination^D orCtrl-Dmeans that you hold down the Control
key while you press the D key. (Keys are indicated in capital letters but are not
case sensitive.)

^ or Ctrl

Commands and keywords and user-entered text appear in bold font.bold font

Document titles, new or emphasized terms, and arguments for which you supply
values are in italic font.

Italic font

Terminal sessions and information the system displays appear in courier font.Courier font

Bold Courier font indicates text that the user must enter.Bold Courier font

Elements in square brackets are optional.[x]

An ellipsis (three consecutive nonbolded periods without spaces) after a syntax
element indicates that the element can be repeated.

...

A vertical line, called a pipe, indicates a choice within a set of keywords or
arguments.

|

Optional alternative keywords are grouped in brackets and separated by vertical
bars.

[x | y]
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DescriptionConvention

Required alternative keywords are grouped in braces and separated by vertical
bars.

{x | y}

Nested set of square brackets or braces indicate optional or required choices
within optional or required elements. Braces and a vertical bar within square
brackets indicate a required choice within an optional element.

[x {y | z}]

A nonquoted set of characters. Do not use quotation marks around the string or
the string will include the quotation marks.

string

Nonprinting characters such as passwords are in angle brackets.< >

Default responses to system prompts are in square brackets.[ ]

An exclamation point (!) or a pound sign (#) at the beginning of a line of code
indicates a comment line.

!, #

Reader Alert Conventions

This document may use the following conventions for reader alerts:

Means reader take note. Notes contain helpful suggestions or references to material not covered in the
manual.

Note

Means the following information will help you solve a problem.Tip

Means reader be careful. In this situation, you might do something that could result in equipment damage
or loss of data.

Caution

Means the described action saves time. You can save time by performing the action described in the
paragraph.

Timesaver

IMPORTANT SAFETY INSTRUCTIONS

This warning symbol means danger. You are in a situation that could cause bodily injury. Before you
work on any equipment, be aware of the hazards involved with electrical circuitry and be familiar with
standard practices for preventing accidents. Use the statement number provided at the end of each warning
to locate its translation in the translated safety warnings that accompanied this device. Statement 1071

SAVE THESE INSTRUCTIONS

Warning
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Related Documentation

Before installing Cisco Modeling Labs, refer to the Cisco Modeling Labs release notes.Note

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional information,
see the monthlyWhat's New in Cisco Product Documentation, which also lists all new and revised Cisco
technical documentation, at:

http://www.cisco.com/c/en/us/td/docs/general/whatsnew/whatsnew.html

Subscribe to theWhat's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS version 2.0.

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
xi

Preface
Related Documentation

http://www.cisco.com/c/en/us/td/docs/general/whatsnew/whatsnew.html


   Cisco Modeling Labs Corporate Edition User Guide, Release 1.2
xii

Preface
Obtaining Documentation and Submitting a Service Request



C H A P T E R  1
Overview of Cisco Modeling Labs

• Cisco Modeling Labs, page 1

• Cisco Modeling Labs Server Components, page 1

• Cisco Modeling Labs Client, page 2

• Virtual Images, page 2

• Cisco Modeling Labs Server Requirements, page 3

• Cisco Modeling Labs Framework, page 5

Cisco Modeling Labs
CiscoModeling Labs is a scalable and extensible software platform that enables operators, engineers, network
designers, and architects to design Cisco-based networks and run simulations using virtual versions of selected
Cisco operating systems. Cisco Modeling Labs comprises the Cisco Modeling Labs server and the Cisco
Modeling Labs client. Together, they provide a sandbox environment that facilitates the design, configuration,
visualization, and simulation of network topologies quickly and efficiently.

• Cisco Modeling Labs server: A shared resource containing the capability to initiate topologies using
installed virtual images.

• CiscoModeling Labs client: A point-and-click GUI that simplifies topology creation and initial device
configurations along with continuous updates. It also permits access to the Cisco Modeling Labs server
functionality.

Cisco Modeling Labs Server Components
The Cisco Modeling Labs server is available as:

• ALinux distribution that is bundled within the VMware Open Virtual Appliance (OVA) file for VMware
ESXi. The bundle includes all the supporting files.

Cisco Modeling Labs comprises a framework of components. The main components are:
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• OpenStack: An open-source platform for creating and managing large groups of virtual servers in a
cloud-computing configuration. It is used for node control, management, and networking.

• AutoNetkit: An automated configuration engine that uses templates to provide working router
configurations based on user-supplied and default parameters for each virtual machine (VM).

• Services Topology Director: Generates OpenStack calls for the creation of VMs and links based on
the XML topology definition created by the Cisco Modeling Labs client. Additionally, it provides the
bootstrap configuration, which can be autogenerated, generated manually, or imported.

Cisco Modeling Labs Client
The Cisco Modeling Labs client is a cross-platform user interface for creating and editing network designs
and simulating those network topologies on the Cisco Modeling Labs server. The Cisco Modeling Labs client
offers the following benefits:

• The ability to use a graphical point-and-click editor to quickly create and edit complex network topologies
in a sandbox.

• Access to the build, visualization, and launch functions available in the Cisco Modeling Labs server.

The Cisco Modeling Labs client enables you to interact directly with your running simulations from the user
interface. The Cisco Modeling Labs client also provides the functionality to generate default router
configurations before launching the topology simulation.

For further information on the Cisco Modeling Labs client, see Using the Cisco Modeling Labs Client
Overview, on page 7.

Virtual Images
Cisco Modeling Labs 1.2 includes the following images built into the Cisco Modeling Labs client:

• Cisco Virtual IOS (IOSv) Software Release 15.6(2)T

• Cisco IOSv Layer 2 Switch Software Release 15.2 (4.0.55) DSGS

• Cisco IOS XRv Software Release 6.0.1 CCO

• Linux server (Ubuntu 14.04.2 Cloud-init)

• Cisco ASAv Software Release 9.5.1

Additionally, the following demonstration images are available from the Cisco FileExchange:

• Cisco IOS XRv 9000 Software Release 6.0.1

• Cisco CSR1000v Software Release 3.1.7 XE-based

See Release Notes for Cisco Modeling Labs 1.2 for more information on Cisco virtual software supported
features.
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Cisco Modeling Labs Server Requirements
This section details the hardware and software requirements for installing the Cisco Modeling Labs server.

The following table lists hardware requirements that are based on the number of virtual nodes used.

Table 1: Hardware Requirements for Cisco Modeling Labs Server

DescriptionRequirement

250 GB minimumDisk Space

Intel®with Intel virtualization technology VT-x and extended page
tables (EPT)

Chip Set

VMware ESXi 5.1 U2, ESXi 5.5 U1, ESXi 6.0 (Build 2494585)Hypervisor

Any server with Intel virtualization technology VT-x and extended
page tables (EPT)

Server type for OVA package

Supported only on Cisco UCS servers with local storageServer type for ISO package

Cisco UCS C220 M4 and Cisco UCS C420 M4Server Recommendation

The recommended servers for CiscoModeling Labs are the Cisco UCS C220M4 and Cisco C420M4 servers.

For more information on UCS servers, see the applicable data sheets at http://www.cisco.com/c/en/us/products/
servers-unified-computing/ucs-c-series-rack-servers/index.html.

For bare metal installations, Cisco Modeling Labs ISO package is certified only with the Cisco UCS C220
M4 and Cisco C420 M4 servers.

Sizing the Server: Number of Cores and Memory Requirements

The calculation for the number of cores and memory requirement is dependent on a number of factors:

• Type and number of virtual machines concurrently active

• Number of routing protocols

• Timer sets within the configurations

• Amount of traffic generated

The general rule of thumb is three virtual nodes to one physical core CPU for simulation of 49 nodes and
below, and two virtual nodes to one physical core CPU for 50 nodes and above.

In order to size the CiscoModeling Lab Server resources, you must use the CiscoModeling Labs resource
calculator available at http://www.cisco.com/go/cml

Note
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Table 2: Software Requirements

DescriptionRequirement

VMware

Any of the following:

• Release 5.1 U2 (Build 1483097) with VMware ESXi

• Release 5.5 U1 (Build 1623387) with VMware ESXi

• Release 6.0 (Build 2494585) with VMware ESXi

You must verify that you are using vSphere Client v5.5 Update 2
(Build 1993072) or later before deploying Cisco Modeling Labs.
Failure to use the minimum version will result in a failed deployment
that will return an error stating that nested virtualization is not
supported.

Note

VMware vSphere

Any of the following:

• Google Chrome 33.0 or later

• Internet Explorer 10.0 or later

• Mozilla Firefox 28.0 or later

• Safari 7.0 or later

Internet Explorer is not supported for use with the AutoNetkit
Visualization feature, the Live Visualization feature or with the User
Workspace Management interface. See Cisco Modeling Labs
Corporate Edition User Guide, Release 1.2 for more information.

Note

Browser

Table 3: Required BIOS Virtualization Parameters

DescriptionName

This parameter must be
Enabled.

Note

The processor uses Intel Hyper-Threading Technology, which allows
multithreaded software applications to execute threads in parallel
within each processor. The processor can be either of the following:

• Enabled—The processor allows for the parallel execution of
multiple threads.

• Disabled—The processor does not permit Hyper-Threading.

Intel Hyper-Threading Technology
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DescriptionName

This parameter must be
Enabled.

Note

If you change this option, you must power-cycle the server
before the change takes effect.

Note

The processor uses Intel Virtualization Technology (VT), which
allows a platform to run multiple operating systems and applications
in independent partitions. The processor can be either of the
following:

• Enabled—The processor allows multiple operating systems
in independent partitions.

• Disabled—The processor does not permit virtualization.

Intel VT

This parameter must be
Enabled.

Note

The processor uses Intel Virtualization Technology for Directed I/O
(VT-d). The processor can be either of the following:

• Enabled—The processor uses virtualization technology.

• Disabled—The processor does not use virtualization
technology.

Intel VT-d

Cisco Modeling Labs Framework
Figure 1: Cisco Modeling Labs Framework

Cisco Modeling Labs includes numerous features that enable you to create and simulate small and large
network designs. This user guide is organized in a task-based format where the main features are grouped
into four sections that are referred to as phases.
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The following items describe each phase which should help you determine, which section to refer to when
using this guide:

1 Design: This phase includes the tasks for creating a network topology. You use a blank canvas to create
topologies from scratch or import existing network topologies. You can also adjust where and how interfaces
are used on each device.

2 Build: This phase includes the tasks associated with configuring routers, external connections, and servers,
creating the required configurations, setting up interfaces, IP addressing, and routing protocols for the
virtual routers. There are several ways to create these configurations. You can use the AutoNetkit
functionality to set up the initial configuration, or you can input your own configuration details. Whatever
configurations you create in this phase will be the configurations that the Cisco Modeling Labs server will
use when it initiates the node simulations.

3 Visualization: This phase is optional and operates only if you use AutoNetkit to create your configurations
during the build phase. It includes the tasks related to running visualization scenarios of your network
design and configuration. It provides visual views of your topology whereby you can see how the nodes
will interact with each other in specific circumstances, including physical set up, as well as with specific
routing protocols, such as IS-IS and OSPF. It also supports MPLS and BGP.

4 Simulation: This phase includes the tasks for initiating the nodes and making them active. Once the nodes
are operational, you can use Telnet or SSH to connect to the consoles as you would connect to a router
console. You can run connectivity tests and modify configurations. This is where the power of the product
is realized: you can modify and test configurations as if you were on actual physical devices. In this phase,
you can also save your configurations and extract them for sharing with others or save them and use them
as reference when configuring the production network.
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C H A P T E R  2
Using the Cisco Modeling Labs Client

• Using the Cisco Modeling Labs Client Overview, page 7

• Navigating Within the Cisco Modeling Labs Client, page 7

• Cisco Modeling Labs Client Components, page 18

• Setting Preferences for the Cisco Modeling Labs Client, page 60

Using the Cisco Modeling Labs Client Overview
The Cisco Modeling Labs client is a cross-platform, point-and-click GUI that simplifies topology creation
and initial device configurations and permits access to the Cisco Modeling Labs server. You can interact
directly with your running simulations from this GUI. Additionally, the Cisco Modeling Labs client provides
the functionality to generate default router configurations before simulating your topology.

This chapter introduces the main areas and capabilities of the Cisco Modeling Labs client.

Navigating Within the Cisco Modeling Labs Client
This section describes the functionality of the Cisco Modeling Labs client, which comprises a workbench
containing a menu bar, a toolbar, multiple editors, multiple perspectives, and multiple views.
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• Workbench: Refers to the Cisco Modeling Labs client desktop environment. Each time the workbench
is exited, it is automatically saved, including all the open perspectives, views, and editors. When the
workbench is reopened, it appears exactly as it was when last closed.

Figure 2: Cisco Modeling Labs Workbench

• MenuBar: References all the actions that can be performed when using the CiscoModeling Labs client.

Figure 3: Menu Bar

• Toolbar: Contains a set of icons representing commands. The toolbar provides shortcuts to actions that
are used most often from the menu bar.

Figure 4: Toolbar

• Cisco Modeling Labs Client Perspectives: Identifies the Design and Simulation perspectives, each
of which is associated with an initial set of views and editors in your workbench.

Figure 5: Perspectives

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.2
8

Using the Cisco Modeling Labs Client
Navigating Within the Cisco Modeling Labs Client



◦From theDesign perspective, you can design your network topology, build the node configurations,
and check routing protocols. TheDesign perspective is the default perspective if you are launching
the Cisco Modeling Labs client for the first time.

◦From the Simulation perspective, you can enable devices and modify configurations to run the
simulations. When the nodes in your topology are fully initialized, you can connect to the consoles
as you would connect to a router console.

• Cisco Modeling Labs Client Editors: Provides alternative components within the Cisco Modeling
Labs client from which you can create and edit topologies. Two editors are provided: Node Editor and
Topology Editor.

◦The Node Editor shows the interface details for selected elements in the Topology Editor.

Figure 6: Node Editor
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• The Topology Editor comprises the Topology Palette view

Figure 7: Topology Palette View
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and the canvas.

Figure 8: Canvas

• Cisco Modeling Labs Client Views: Provides alternative presentations of your topology and methods
for navigating the information in your workbench.

Figure 9: Views

• Cisco Modeling Labs Client Layout: Enables you to personalize your workbench, allowing you to
rearrange, resize, reset, and move between views.
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Menu Bar
The menu bar provides access to the complete list of actions that are possible in the Cisco Modeling Labs
client.

Table 4: Menu Bar Items

Action(s)Menu

Enables you to perform actions on a topology .virl file, set preferences for resources,
and exit the Cisco Modeling Labs client.

• New: Creates a new topology project folder, topology project, or topology
.virl file. See Design a Topology Overview, on page 83 for more information.

• Save: Saves the current Topology Editor contents.

• Save As: Saves the current Topology Editor contents to a new file.

• Save All: Saves all Topology Editor contents to a new file.

• Print: Prints the current Topology Editor design.

• Import: Imports a resource type (for example, a topology .virl file) into the
Cisco Modeling Labs client. See Importing a Topology File, on page 15 for
more information.

• Export: Exports a resource type (for example, a topology .virl file) from the
Cisco Modeling Labs client. See Exporting a Topology File, on page 16 for
more information.

• Close: Closes the current editor.

• Close All: Closes all open editors.

• Preferences: Opens the Preferences dialog box, where you can update the
settings for the Cisco Modeling Labs client. See Setting Preferences for the
Cisco Modeling Labs Client, on page 60 for more information.

• SwitchWorkspace: Allows you to select a workspace folder to use for your
session.

• Exit: Exits the Cisco Modeling Labs client.

File
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Action(s)Menu

Enables you to manipulate resources on the canvas.

• Undo: Cancels the most recent change.

• Redo: Applies the most recent change that was removed.

• Copy: Places a copy of the topology on the clipboard.

• Paste: Pastes the topology from the clipboard to the canvas at the current
cursor location.

• Delete: Deletes the current topology.

• Search: Enables you to perform topology searches and text searches within
work spaces, topology projects, files, and working sets.

• Select All: Selects all objects in the current topology canvas.

• Grid: Provides three options for displaying nodes on the canvas: Display
Grid, Snap to Grid, and Distribute Nodes.

• Reset Node Subtype: Enables you to redefine a virtual node on the canvas.
When Reset All Interface Names is selected, the interface IDs are reset
sequentially, starting from the minimum range.

• Distribute Nodes: Aligns the nodes on the canvas evenly, either vertically
or horizontally. (This feature is disabled when Show Map Background is
chosen.)

• Layout Nodes: Places nodes on the canvas in a tree layout or an F-R layout.
(This feature is disabled when Show Map Background is selected.)

• Alignment: Aligns the nodes on the canvas. Options are: left, center, right,
top, middle, or bottom. (This feature is disabled when Show Map
Background is selected.)

• Group to Site: Groups two or more nodes within a site.

• Ungroup Site: Ungroups nodes from within a site, removing one layer of
nesting.

Edit

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
13

Using the Cisco Modeling Labs Client
Menu Bar



Action(s)Menu

Enables you to manipulate the Cisco Modeling Labs client.

• Zoom In: Allows you to zoom in on the canvas, increasing the topology
view. This is also available on the toolbar.

• Zoom Out: Allows you to zoom out on the canvas, reducing the topology
view. This is also available on the toolbar.

• Highlight Connection: Highlights all connections to and from the selected
node.

• Show/HideMap Background: Displays a map background for the topology.
Choose Hide to disable the feature.(You must have Internet access to use this
feature.)

• Topology Labels: Displays the following information:

• Show Topology Labels: Displays the topology labels on the canvas.

• Interface Names: Displays all the interface names in the topology on
the canvas.

• Node Loopback IPv4: Displays the IPv4 loopback addresses on the
canvas.

• Node Loopback IPv6: Displays the IPv6 loopback addresses on the
canvas.

• Serial Ports: Displays the serial port number assignments on the canvas.

• Excluded from Launch: Displays those nodes excluded from the
simulation launch on the canvas.

• Simulation State (text): Displays the simulation state of each node on
the canvas in text format, e.g. [ACTIVE], [ABSENT], and so on.

• Simulation State (color): Displays the simulation state of each node
on the canvas in color, e.g. the [ACTIVE] state displays in green, the
[ABSENT] state displays in grey, and so on.

• Packet Captures: Displays all packet captures present for all interfaces
in the topology.

• Link Parameters: Displays all parameters present for all links in the
topology.

You can toggle between the different options to see the different available
features.

View

Enables you to generate node configurations.

• Build Initial Configurations: Creates initial node configurations.

Configuration
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Action(s)Menu

Enables you to start and stop simulations.

• Launch Simulation: Starts a simulation.

• Launch Simulation (with time limit) : Starts a simulation for a specified
time period.

• Stop Simulation: Stops a running simulation.

• Stop Simulations: Stops multiple running simulations.

Simulation

Enables you to manage perspectives in the Cisco Modeling Labs client.

• Open Perspective: Opens the selected perspective.

• Show View : Displays the selected view.

• Reset Perspective: Resets the perspective to the initial login perspective.

• Save Perspective As: Saves the current perspective to a specified name.

• Close Perspective: Closes the open perspective.

Window

Displays the help topics for using the Cisco Modeling Labs client in a separate
browser window.

• HelpContents: Opens the CiscoModeling Labs client support documentation.

• Cheat Sheets: Helps you in completing a task.

• Generate Problem Report: Generates a detailed report of a problem, which
can be submitted to Cisco Technical Assistance Center (Cisco TAC) for
further investigation. See Generate Problem Reports, on page 16 for more
information.

• About Cisco Modeling Labs: Identifies version information and displays
details pertaining to software installations.

Help

Importing a Topology File

Step 1 From the menu bar, choose File > Import.
The Import dialog box appears.

Step 2 From the drop-down list, choose Topology > Import Topology file from File System, and click Next.
Step 3 Click Browse to locate the applicable .virl file.
Step 4 In the right pane, check the check box for the applicable .virl file.
Step 5 Click Finish to import the topology file.
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Exporting a Topology File

Step 1 From the menu bar, choose File > Export.

To export a topology file, it must be open on the canvas of theTopology Editor.Note

The Export dialog box appears.
Step 2 From the drop-down list, choose Topology > Export Topology file to File System, and click Next.
Step 3 Click Browse to select the directory to export the topology file to.
Step 4 Click Finish to export the topology file.

Generate Problem Reports
The Cisco Modeling Labs client provides functionality that allows you to generate problem reports for any
problems encountered in your topology. It is accessible from the menu bar under Help > Generate Problem
Report.

While all options are preselected, you can individually select the information you want to include in the report.

When generating a problem report for your topology, you must have the topology containing the problem
open on the canvas.

Note

DescriptionOption

User interface .log file from the user's workspace.Log File

Current content from the Console view messages. These are messages
from the server in response to AutoNetkit and simulation launch actions.

Consoles' Content

Contents of the currently open topology file in theTopology Editor canvas.Topology Editor Contents

Screenshot showing the state of the user interface when the problem
occurred.

Screenshot of the User Interface

Report of the web services details and errors.Web Services Setting

Any additional information that users can provide to describe the problem.Additional Information

The generated problem report is saved to a .zip file, where you can check the contents before sending it to
Cisco TAC for investigation.
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Toolbar
The toolbar is a compilation of icons representing commonly used actions. The toolbar is arranged below the
menu bar and offers the same actions as the menu bar in a single click. The following table outlines the actions
that can be performed using the Cisco Modeling Labs client toolbar.

Table 5: Toolbar Options

DescriptionFunctionIcon

Creates a new topology file. A topology file is a .virl
file where the network arrangement is designed.

New Topology File

Saves the current topology.Save

Prints the current topology.Print

Deletes the currently selected element within the
topology.

Delete

Undoes the most recent action.Undo

Redoes the most recent undone action.Redo

Enlarges the topology view on the canvas.Zoom In

Decreases the topology view on the canvas.Zoom Out

Displays either IPv4 or IPv6 loopback addresses
configured manually or by AutoNetkit for the topology
on the canvas.

Show Topology
Labels
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DescriptionFunctionIcon

Generates initial node configurations for the topology.Build Initial
Configurations

Launches a simulation indefinitely or for a
user-specified time period.

Launch Simulation

Stops all running simulation(s).Stop Simulations

Cisco Modeling Labs Client Components
The three main components of the Cisco Modeling Labs client are described in the following sections:

• Cisco Modeling Labs Client Editors, on page 18

• Cisco Modeling Labs Client Perspectives, on page 20

• Cisco Modeling Labs Client Views, on page 24

Cisco Modeling Labs Client Editors
Editors are visual components within the Cisco Modeling Labs client. Currently, two editors are available:

• Topology Editor: Shows the entire topology (or sites). The Topology Editor comprises the Palette
view and the canvas.

• Node Editor: Shows the interface details for the currently selected elements in the Topology Editor.

Selecting a connection in theTopology Editor shows the details of both the endpoints in theNode Editor.Note

Topology Editor
The Topology Editor allows you to:

• Add, move, group, rename, delete nodes, and sites on the canvas, or change the properties.

• Create or remove connections between nodes.
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• Use GPS coordinates to map your topology to precise geographic locations.

Figure 10: Topology Editor

Node Editor
The Node Editor allows you to:

• Add interfaces to a node.

• Add connections to the interfaces on a node.

• View nodes, their connections, and all the interfaces on the nodes.

• Specify which interface the connection connects to on each node.
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• Update properties for interfaces.

Figure 11: Node Editor

Cisco Modeling Labs Client Perspectives
A perspective defines the initial set and layout of views and editors in the workbench. The Cisco Modeling
Labs client provides two perspectives. However, you can customize your own user-defined perspectives for
use, which can be saved or deleted as needed.

The two perspectives provided in the Cisco Modeling Labs client are Design and Simulation.

• Design: Allows you to create and design your topologies, for example, adding devices and defining
interfaces and adding connections to devices within your network. If you are using the Cisco Modeling
Labs client for the first time, the Design perspective opens by default.

• Simulation: Allows you to simulate running configurations that are generated fromCisco IOSv versions.

The Design and Simulation perspectives that are built into the Cisco Modeling Labs client cannot be
deleted.

Note

One or more perspectives can exist in a single workspace. If multiple perspectives are opened at the same
time, you can choose whether to layer them or open them in a separate workspace.
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Working with Perspectives
You can manage the various perspectives defined in the workbench by choosing File > Preferences >General
> Perspectives.

Figure 12: Perspectives Preferences

The following table describes the Perspectives options:

Table 6: Perspectives Options

DescriptionOption

Defines whether a new perspective opens in the current workbench or opens in
a new window. By default, a new perspective opens in the current workbench.

Open a new perspective
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DescriptionOption

Defines whether a new view opens within the current perspective or opens
docked beside the current perspective (fast view). By default, a new view opens
within the current perspective.

Open a new view

Defines perspective behavior when a new project is created. By default, a new
project opens the perspective in the same workbench.

New project options

The following table describes the Available perspectives options:

Table 7: Available Perspectives Options

DescriptionOption

Sets the selected perspective as the default perspective.Make Default

Resets the definition of the selected perspective to the default configuration. This
option is only applicable to system-defined perspectives.

Revert

Deletes the selected perspective. This option is only applicable to user-defined
perspectives. (System-defined perspectives cannot be deleted.)

Delete

Customize Perspectives
Cisco Modeling Labs provides two perspectives for use in the workspace: the Design perspective and the
Simulation perspective. These perspectives display various views and settings that cannot be changed, nor
can they be deleted from the Cisco Modeling Labs client. You can, however, customize additional Design
and Simulation perspectives for your specific needs.

From the View menu, you can open additional views and arrange them in your perspective. The views can
be arranged by dragging them around the workspace. When finished, you can save the perspective.

Right-click the applicable perspective tab to open the context menu, and then click ShowText. TheDesign
perspective and the Simulation perspective buttons will be displayed as text labels instead of icons only.

Note

Step 1 Open the Design perspective or Simulation perspective in your workspace.
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Use this as an initial template from which to create a customized perspective.

Step 2 To add new views, chooseWindow > Show View >Other and the Show View dialog box is displayed listing all views
for use.
Views already in use are shown as dimmed in the list.

Step 3 To add node information, double-click a node to add a Node Editor in the perspective.
Step 4 Click and drag the views and Node Editors to different positions within the workspace. For example, you can move

each node's Console view so they are either side by side or stacked in tabs.
Step 5 When you are finished arranging the workspace, right-click the applicable perspective button, and then click Save As.

You are prompted to name the new perspective.
Step 6 Enter a name for the perspective and click OK.

Design Perspective
The Design perspective allows you to create and design your topologies. By default, the Design perspective
incorporates the components listed here because they are the most widely used. However, you can customize
a Design perspective to include a different set of components.

• Palette view: Provides the node types, connection types, and sites used to design a topology.

• Projects view: Lists topology projects, subfolders, and files defined from the workbench.

• History view: Lists changes made to a file based on date and time stamp.

• Properties view: Identifies node and interface properties.

• Node Editor: Identifies nodes, node connections, and node interfaces.

• Topology Editor: Develops a network topology.

• Graph Overview: Provides methods for viewing a network topology.

To customize a new Design perspective, choose the desired components from the View menu (for example,
View > Other > Cisco Terminal), and then drag that component view to the desired location within the
workbench. When you are done adding components to the workbench and the component views are laid out
as desired, right-click the Design perspective button, select Save As, and enter a name for the new Design
perspective.

From the Design perspective, right-click the Design icon. This displays the following menu options:

Table 8: Design Perspective Context Menu Options

DescriptionOperation

Saves the customized workbench layout, views, and editors as a new Design
perspective.

Save As

Resets the current perspective to display the workbench design that was used when
the workbench was first opened.

Any open editors, for example, Node Editor, are not closed when a
perspective is reset. You must close them manually.

Note

Reset
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DescriptionOperation

Closes the current perspective. You can reopen it using the Open Perspective tool,
which is located at the upper right corner of the window.

Close

When selected, shows perspective names in the toolbar instead of icons.
When deselected, shows perspective icons in the toolbar instead of names.

Show Text

Simulation Perspective
The Simulation perspective opens after you launch a simulation; you are prompted to switch to the Simulation
perspective. Switching to the Simulation perspective means that you can now connect to your running nodes
in the Simulations view. By default, it incorporates the Topology Editor, Projects view, Simulations view,
Console view, and Terminal view.

From the Simulation perspective, right-click the Simulation icon. This displays the following menu options:

Table 9: Simulation Perspective Context Menu Options

DescriptionOperation

Saves the current perspective.Save As

Resets the current perspective to its original configuration (when the workbench
opened initially).

Any open editors, for example, Topology Editor, are not closed when a
perspective gets reset to its original configuration. They are stacked as tabs
in the default editor area for that perspective.

Note

Reset

Closes the current perspective. (Reopen it using the Open Perspective tool.)Close

When selected, shows perspective names in the toolbar instead of icons.
When deselected, shows perspective icons in the toolbar instead of names.

Show Text

Cisco Modeling Labs Client Views
Views provide alternativemethods for presenting topology information and navigating within your workbench.
You can drag the view windows and position them anywhere within the workbench. Some views have their
own toolbars, and some of the tools on these toolbars are specific to the views being presented.

The most commonly used views within the Cisco Modeling Labs client are listed in the following table:
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Table 10: Commonly Used Views in the Cisco Modeling Labs Client

DescriptionPerspective Where
Used

View Name

Design—Displays messages from AutoNetkit when it
is used to generate router configurations.
Simulation—Displaysmessage streams from the Cisco
Modeling Labs server after a simulation is launched.

For more information, see Console View, on page 26.

Design and
Simulation

Console view

Provides you with the ability to view a scaled-down
version of your entire topology.
For more information, see Graph Overview, on page
27.

DesignGraph Overview

Provides a history of changes made to a file and enables
you to select a previous file version from the list. For
more information, see History View, on page 27.

DesignHistory view

Allows you to add devices and interface connections
to your topology.
For more information, see Topology Palette View, on
page 29.

DesignTopology Palette view

Displays errors, warnings, and other information that
was detected within the Topology Editor.
For more information, see Problems View, on page
31.

DesignProblems view

Provides a hierarchical view of topology projects,
folders, and topologies in the workbench.
For more information, see Projects View, on page 36.

Design and
Simulation

Projects view

Displays names and properties of nodes and interfaces.
For more information, see Properties View, on page
38.

DesignProperties view

Displays the results of a search, which can be based on
text strings, regular expressions, patterns, whole words,
and case-sensitive characters.

For more information, see Search View, on page 51.

DesignSearch view

Displays information on all running simulations.
For more information, see Simulations View, on page
54.

SimulationSimulations view

Displays console information when you use Telnet or
SSH to connect to a node.
For more information, see Terminal View, on page 59.

SimulationTerminal view
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Console View
The Console view displays message streams from the Cisco Modeling Labs server after a simulation is
launched. It also displays messages from AutoNetkit when it is used to generate router configurations.

Figure 13: Console View

The Console view toolbar contains the following tools:

Figure 14: Console View Toolbar

Table 11: Available Tools

DescriptionFunctionIcon

Removes all the information from the Console view.Clear Console

Switches scrolling on and off.Scroll Lock

Pins the Console view to the workbench so that
subsequent message streams are shown in another
Console view. The pinned view remains unchanged.

Pin Console

Displays theConsole view for the selected simulation.Display Selected Console

Opens a new Console view.Open Console
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DescriptionFunctionIcon

Reduces the size of the Console view.Minimize

Increases the size of the Console view.Maximize

When several simulations are running, use the toolbar buttonDisplay Selected Console to toggle between
the Console views for the different simulations.

Note

Graph Overview
Graph Overview enables you to view a scaled-down version of your entire topology. A blue rectangle
(representing an overlay) is used to indicate a portion of the topology that is currently being displayed in the
Topology Editor. Using this overlay, you can easily see where the displayed portion sits in relation to the
entire topology.

The Graph Overview also allows you to navigate around a large topology when it is either too large to fit
into the canvas or is zoomed in and not fully displayed on the canvas.

Figure 15: Graph Overview

From theGraph Overview, click and drag the overlay to pan around your topology. As you drag the overlay,
the corresponding content is reflected in the Topology Editor.

History View
When you create or modify a file, a history of record is maintained and a copy of the modified file is stored
locally. This allows you to replace the current file with a previous version or restore a file that has been deleted.
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You can also use theHistory view to compare the changes that were made to the local files. Each file's history,
which is stored locally, is uniquely represented by the date and time at which the file was saved.

Only changes made to topology files (.virl) are retained locally; changes made to projects and folders are
not.

Note

Figure 16: History View

To view the changed history of a file, in the Projects view, right-click the applicable file and choose Team
> Show Local History.

The History view displays a list of revision times; the most recent revision time is highlighted at the top of
the list.

If you have a .virl file opened in the workbench, click theHistory tab to view the list of changes made to
the file.

Note

The History view toolbar contains the following tools:

Figure 17: History View Toolbar

Table 12: Available Tools

DescriptionFunctionIcon

Refreshes the contents of the view, retrieving the latest history
information for a file from the system.

Refresh

Toggles when the History view selection is linked to the
active editor.When this option is selected, changing the active
editor automatically updates the History view selection to
the project, folder, and file being edited.

Link with Editor
and Selection
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DescriptionFunctionIcon

Pins the view to the workbench and captures a snapshot of
the file history information. New requests for file history are
opened in a new instance of the History view.

Pin this History
View

Sorts all history items by date. Options are:

• Today

• Yesterday

• This Month

• Previous

GroupRevisions by
Date

Collapses all the history items listed in the hierarchical view.Collapse All

Opens the compare editor for file comparison.Compare Mode

Topology Palette View
The Topology Palette view allows you to add devices and interface connections to your topology. Using the
Topology Palette view, you can:

• Add nodes, Layer 3 external Secure Network Address Translation (SNAT) connections, and Layer 2
external (FLAT) connections to your topologies.

• Select nodes and connections for repositioning on the canvas.

• Create connections between node interfaces.
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• Group nodes into sites.

Figure 18: Topology Palette View

The Topology Palette view is divided into the following categories:

• Tools: Contains the Select and Connect tools. The Select tool allows you to select nodes, Layer 3
external (SNAT) connections, and Layer 2 external (FLAT) connections on theTopology Editor canvas.
The Connect tool creates connections between node interfaces.

TheFile >Preferences >Topology Editor setting affects how the nodes and connections
are placed on the canvas. If you check the Revert back to the palette's default tool
check box, you must click a node, connection, or other object each time you place an
object on the canvas. If the Revert back to the palette's default tool check box is not
checked, each time you click the canvas, an object is placed until you click the Select
tool (the default palette tool).

Note

• Nodes: Contains the node types available for use in topologies. Currently, CiscoModeling Labs, Release
1.2 includes the following:

• Cisco Virtual IOS (IOSv) Software Release 15.6(2)T

• Cisco IOSv Layer 2 Switch Software Release 15.2.(4.0.55) DSGS
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• Cisco IOS XRv Software Release 6.0.0 CCO

• Linux server Ubuntu 14.04.2 LTS Cloud-init

• Cisco ASAv Software Release 9.5.1

Additional node subtypes can be installed separately. See Release Notes for Cisco
Modeling Labs Release 1.2 for the most up-to-date list of supported virtual images.

Note

• General: Contains the different types of connection functions that are supported for nodes. Options are:

◦Layer 3 external connections

◦Layer 2 external connections

You can also create sites.

The Topology Palette view toolbar contains the following tools:

Figure 19: Topology Palette View Toolbar

Table 13: Available Tools

DescriptionToolIcon

Reduces size of Palette view.Minimize

Increases size of Palette view.Maximize

Problems View
TheTopology Editor automatically detects errors, warnings, and other information displayed on the topology
elements in the Topology Editor and Node Editor. These markers can be viewed in the Problems view.

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
31

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views

http://www.cisco.com/c/dam/en/us/td/docs/cloud_services/cisco_modeling_labs/v120/release/notes/CML-1-2-Release-Notes.pdf
http://www.cisco.com/c/dam/en/us/td/docs/cloud_services/cisco_modeling_labs/v120/release/notes/CML-1-2-Release-Notes.pdf


By default, the Problems view displays all the errors and warnings for all the topologies in the Projects
view, not just the currently open topology. From the Problems view toolbar, choose ViewMenu > Show
> Errors/Warnings on Project to filter only those errors and warnings that are applicable to the current
project. Alternatively, you can also use the Configure Contents dialog box, which is accessible from the
ViewMenu option, to filter warnings and errors associated with a particular topology or topology project.

Note

Figure 20: Problems View

The Problems view groups errors and warnings by severity, with the most critical issues listed first.

Double-click the problem marker in the Problems view, which opens the appropriate editor in the Cisco
Modeling Labs client. If the problem relates to an XML file, the XML file opens in a text editor. The problem
is highlighted, allowing you to quickly identify the issue and correct it.

Figure 21: Problem Example

The Problems view toolbar contains the following tools:

Figure 22: Problems View Toolbar
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Table 14: Available Tools

DescriptionFunctionIcon

The View menu has the following options:

• Show: Displays errors and warnings.

• Group By: Groups problems under the headings Type,
Severity, and None. The default is Severity.

• Sort By: Sorts problems under the following headings:

◦Description: Details the problem encountered.

◦Resource: Displays the name of the .virl file where
the problem has occurred.

◦Path: Displays the applicable project folder.

◦Location: Displays the location in the .virl file where
the problem has occurred.

◦Type: Displays the type of problem, for example, XML
problem.

• New Problems View: Opens a new Problems view on the
workbench.

• ConfigureContents: Opens theConfigureContents dialog
box, where you can add multiple filters to the Problems
view and enable or disable them. Filters can either be
additive or exclusive. The All Errors/Warnings on
Selection filter is provided by default.

• ConfigureColumns: Opens theConfigureColumns dialog
box, where you can choose to hide or show specific
information about the problem encountered, as shown in the
Sort By option. Options are:

◦Creation Time: Displays the time when the problem
occurred.

◦Description, ID: Displays the system-generated ID
for the problem, location, path, resource, and type.

View Menu

Reduces the size of the Problems view.Minimize

Increases the size of the Problems view.Maximize
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The Quick Fix Option

Problems displayed in the Problems view are provided with a Quick Fix option if available. A quick fix is
indicated by a light bulb icon that is visible on the marker. When this option is selected, you are presented
with one or more possible fixes.

We recommend that you useQuick Fix to resolve the errors discovered unless the errors have been deliberately
created for testing purposes.

Figure 23: Quick Fix

To fix a problem:

1 Right-click the line containing the problem, and select Quick Fix.
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The Quick Fix dialog box displays a list of possible solutions.

Figure 24: Quick Fix Dialog Box

2 Select a fix from the list, and then check the check box of any of the resources listed in the Problems area.
You can click Select All to apply the quick fix to all the resources listed. Alternatively, you can click
Deselect All to clear all selections.

3 Click Finish.

Once a problem has been fixed using the Quick Fix option, the action cannot be undone.Note
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Projects View
The Projects view provides a hierarchical view of topology projects, folders, and topologies in the workbench.
From here, you can open topologies for editing or select resources for operations, such as exporting.

Figure 25: Projects View

Right-click any topology in the Projects view to open a context menu. In this context menu, you can copy,
move, and create new topology files, view comparison files, and so on.

The Projects view toolbar contains the following tools:

Figure 26: Projects View Toolbar

Table 15: Available Tools

DescriptionFunctionIcon

Collapses the hierarchy of all the resources in the Projects view.Collapse All

Links the Projects view with an active editor. A change to an
active editor automatically updates the Projects view and allows
you to toggle between the two views.

Link with
Editor

Provides options for customizing the content displayed in the
Projects view. Options are:

• Sort by filters

• Sort by content

View Menu

Reduces the size of the Projects view.Minimize
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DescriptionFunctionIcon

Increases the size of the Projects view.Maximize

The Projects view displays several icons on the toolbar:

Table 16: Projects View Icons

DescriptionNameIcon

Indicates an open topology project.Topology Project

Indicates an open folder. Folders are created within a
topology project so that topology files can be organized
into separate areas for greater accessibility.

Folder

Indicates a topology file.Topology
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Properties View
The Properties view displays the names and properties of nodes and interfaces. If no specific node or interface
is selected, the Properties settings apply globally to all the nodes and interfaces within a topology. If a specific
node or interface is selected, the Properties settings apply to only that node or interface.

Figure 27: Properties View

The Properties view toolbar contains the following tools:

Figure 28: Properties View Toolbar

Table 17: Available Tools

DescriptionFunctionIcon

Shows the available properties categories.Show Categories

Shows all advanced properties.ShowAdvancedProperties

Restores the default value for the property.Restore Default Value
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DescriptionFunctionIcon

Pins this properties view to the current selection.Pin to Selection

Displays menu items that allow you to:

• Open a new properties view.

• Pin the properties view to the current selection.

View Menu

Reduces the size of the Properties view.Minimize

Increases the size of the Properties view.Maximize

The properties in the Properties view are discussed in the following sections:

• Node Properties, on page 39

• Topology Properties, on page 45

Node Properties

When you select a node on the canvas, the properties for that node are displayed in the Properties view.

Figure 29: Node Properties
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Under the Node tab, you can perform the following tasks:

Table 18: Node Properties

DescriptionProperty

Specify a name for the node.
Use only alphanumeric and special characters for node names. Node names must
be unique across the entire topology. Duplicate node names cause the build to
fail when the configuration is autogenerated. If a duplicate node name is defined,
a marker is shown in the Problems view. Unicode is not supported for node
names. The use of a period in a node name may cause the node name to wrap
when viewing the hierarchy from the Cisco Modeling Labs server. When you
update a node name in the Properties >Node view, the node name is not updated
in the Node Editor.

Note
Name

Specify a subtype from the list. Cisco Modeling Labs 1.2 includes the following images
built into the Cisco Modeling Labs client:

• Cisco Virtual IOS (IOSv) Software Release 15.6(2)T

• Cisco IOSv Layer 2 Switch Software Release 15.2.(4.0.55) DSGS

• Cisco IOS XRv Software Release 6.0.0 CCO

• Linux server (Ubuntu 14.04.2 LTS Cloud-init)

• Cisco ASAv Software Release 9.5.1

Additional Cisco virtual images are available for use. However, they must be installed
separately. For a list of supported subtypes, see Release Notes for Cisco Modeling Labs
1.2.

When changing a node subtype after it is initially configured using AutoNetkit,
for example, changing a Cisco IOSv subtype to a Cisco IOS XRv subtype, you
need to revalidate the AutoNetkit properties for the new node subtype.

Note

Subtype

Specify an IPv4 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv4

Specify an IPv6 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv6

Specify a VM image other than the default. Click Browse to choose a valid VM image
from the Select VM Image dialog box.

VM Image

Specify a VM flavor other than the default. Click Browse to choose a valid VM flavor
from the Select VM Flavor dialog box.

VM Flavor

The property Exclude Node from Simulation Launch is set on a per-node basis. When it is enabled for a
node, the node is not launched when the simulation is launched. However, the node can later be booted and
configured and automatically join a running simulation.
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Under theAutoNetkit tab, when you check theAuto-generate the configuration based on these attributes
check box, the AutoNetkit generates the configuration for your topology when you click the Build Initial
Configurations icon on the toolbar.

Any preexisting configuration for a node is overwritten when you choose Build Initial Configurations
from the toolbar. Uncheck this Auto-generate the configuration based on these attributes check box
if you do not want the router configuration for a node updated by AutoNetkit.

Note

Using the properties listed, you can perform the following tasks:

Table 19: AutoNetkit Properties

DescriptionFieldsProperty

Specify the autonomous system number, which is used to infer IGP and
BGP. This can be any valid integer.

ASNGeneral

Configure an internal routing protocol. Options are:

• Not specified

• OSPF

• ISIS

• EIGRP

• RIP-V2

The default value is Not specified.

IGPIGP

Configure an OSPF area. The default value is 0.OSPF Area

Configure an iBGP role from the list and use it to create an iBGP topology.
Options are:

• Not specified

• Disabled

• Peer

• RR (route reflector)

• HRR(hierarchical route reflector)

• RRC(route reflector client)

The default value is Peer.

iBGP RoleiBGP

Specify the RRC as a name or number. Should be an alphanumeric string.RR Cluster

Specify the HRR cluster. Should be an alphanumeric string.HRR Cluster
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DescriptionFieldsProperty

In this section, users can specify their own configuration text for inclusion
in the appropriate section of the node configuration.

The following fields do not apply to external routers. Note too that
text entered is not syntactically checked, so ensure that the text is
valid.

Note

GlobalCustom
Configuration

Specify a custom configuration for the physical interfaces.Physical
Interfaces

Specify a custom configuration for loopback zero.LoopbackZero

Specify a custom configuration for OSPF.OSPF

Specify a custom configuration for IS-IS.IS-IS

Specify a custom configuration for EIGRP.EIGRP

Specify a custom configuration for RIPv2.RIP-V2

Specify a custom configuration for BGP.BGP

Specify an MPLS VPN name for VRF MPLS VPNs.VRF NameMPLS

Enable Cisco MPLS Label Distribution Protocol. Options are:

• Not specified

• True

• False

The default value is False.

LDP

Enable Cisco MPLS Traffic Engineering. Options are:

• Not specified

• True

• False

The default value is False.

Enable MPLS
TE

This property only applies to external
routers.

Note

Specify the IPv4 address of the remote router. Enter a valid IP address in
the correct format.

IPv4 AddressExternal
BGP

Specify an IPv6 address of the remote router. Enter a valid IP address in the
correct format.

IPv6 Address
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DescriptionFieldsProperty

Specify the AS number of the remote router. This is used when trying to
establish a BGP connection to a remote device. The value range is 1 to 65535.

Remote ASN

Specify the MD5 password to use to secure the BGP session to the remote
router.

MD5Password

Enable BGP multihop. When the remote router is directly adjacent (Layer
3 adjacent), this field is set to False; otherwise it is set to True.

Options are:

• Not specified

• True

• False

The default value is True.

Multihop

Specify a remote loopback IPv4 address.Remote
Loopback IPv4
Address

External
L2TPv3

Specify a local endpoint IPv4 address.LocalEndpoint
IPv4 Address

Specify a local endpoint IPv4 netmask.LocalEndpoint
IPv4 Netmask

Specify a pseudowire ID.PseudoWire ID

Enable IPv4 GRE tunneling. Options are:

• Not specified

• True

• False

The default value is False.

IPv4 Tunnel
Enabled

GRE
Tunnel

Specify a tunnel IPv4 address to use, which is the IP address of the far-end
node terminating the GRE tunnel itself.

Tunnel IPv4
Address

Specify a tunnel IPv4 netmask to use.Tunnel IPv4
Netmask
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DescriptionFieldsProperty

Enable IPv6 GRE tunneling. Options are:

• Not specified

• True

• False

The default value is False.

IPv6 Tunnel
Enabled

Specify a tunnel IPv6 address to use, which is the IP address of the far-end
node terminating the GRE tunnel itself.

Tunnel IPv6
Address

Specify a tunnel IPv6 netmask to use.Tunnel IPv6
Netmask

Cisco IOS XRv devices set with the ODL Management Group attribute
must be paired with an External Router entity which is configured with the
matching ODL Management Group attribute along with an ODL External
Server IP address. The ODL server may be running on your CiscoModeling
Labs server or another location and does not need to part of the Cisco
Modeling Labs simulation itself. Connectivity between the simulation and
server must be provided.

ODL
Management
Group

ODL

For this release, RIP-V2 has been added as an IGP in addition to IS-IS, OSPF, and EIGRP. You can specify
the IGP on a per-node basis, which takes precedence over the global IGP setting. Additionally, you can specify
LDP enabled/disabled per node, which allows LDP to be enabled directly, rather than only when VRFs are
specified.

Per interface you can specify a VLAN. This is specified on the destination interface and determines the VLAN
a node belongs to. This is used in the Cisco IOSvL2 configuration. See Assign VLANs, on page 126 for more
information

Information displayed under theConfiguration tab depends on whether theAuto-generate the configuration
based on these attributes check box under the AutoNetkit tab is checked.

•When checked, AutoNetkit generates the configuration and displays it under the node's Configuration
tab.

•When unchecked, no configuration information is created for the node. You must configure the node
manually or cut and paste the existing configuration information into this area.

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.
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Topology Properties

When you select an area on the canvas other than a node, the properties for that topology are displayed in the
Properties view.

Figure 30: Topology Properties

Under the Topology tab, you can perform the following tasks:

Table 20: Topology Properties

DescriptionProperty

Specify the type of out-of-band (OOB) external network access. Options are:

• Not specified

• Private simulation network: Creates a per-simulation Linux container (LXC). The
LXC is automatically connected into the OOB management network to which all
VMs in your simulation are connected, enabling you to connect into each VM via
its management Ethernet port. This removes the need to use the console port
connection method. See the section Linux Container (LXC), on page 179 for more
information.

• Shared flat network: Enables OOB external network access to all devices in the
topology.

• Private project network: Enables OOB private access to all simulations running
within the user space.

Management
Network

Enter the IPv4 address to be assigned to the Management LXC node. This address must
be in the IPv4 subnet assigned to the Flat network.

LXC Node's
Static IP
Address

An optional offset value to be applied to each node's static serial port number. (New port
number = node's static port number + offset value.) The new port number must be within
the range 4000 - 32767.

Static Serial
Port Offset
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The Nodes and Simple Connections properties are for information purposes only and are useful when
comparing the size of the topology to your current user quotas, licensing limits, or both.

In this instance, Nodes include node subtypes and FLAT and SNAT port groups.Note

TheUse an LXCmanagement node check box is used to enable the management node as a Linux container.
See the section Linux Container (LXC), on page 179 for more information.

Under the AutoNetkit tab, you can perform the following tasks:

Table 21: AutoNetkit Properties

DescriptionFieldsProperty

Enable the Cisco Discovery Protocol (CDP). Options are:

• Not specified

• True

• False

The default value is False.

Enable CDPGeneral

Enable the Cisco One Platform Kit (OnePK). Options are:

• Not specified

• True

• False

The default value is False.

Enable OnePK

Configure a routing session to use IPv4 address prefixes, IPv6
address prefixes, dual stack (includes both native IPv4 and IPv6),
or none. Options are:

• Not specified

• None

• v4

• v6

• Dual_stack

IP Address FamilyAddressing

Specify the address to use for IPv4 infrastructure address allocations.
This is the address assigned to the interface created on the router.
The default value is 10.0.0.0. Enter a valid IP address in the correct
format.

IPv4 Infrastructure
Subnet

Specify the prefix to use for IPv4 infrastructure address allocations.
The default value is 8.

IPv4 Infrastructure
Prefix
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DescriptionFieldsProperty

Specify the address to use for IPv4 loopback address allocations.
The default value is 192.168.0.0. Enter a valid IP address in the
correct format.

IPv4Loopback Subnet

Specify the prefix size to use for IPv4 loopback address allocations.
The default value is 22.

IPv4 Loopback Pool
Prefix

Specify the address to use for IPv4 VRF address allocations when
specifying the address range for MPLS VRF. The default value is
172.16.0.0. Enter a valid IP address in the correct format.

IPv4 VRF Subnet

Specify the prefix to use for IPv4 VRF address allocations. The
default value is 24.

IPv4 VRF Prefix

Specify the address to use for IPv6 infrastructure address allocations.
This is the address assigned to the interface created on the router.
The default value is 0:0:0:a::. Enter a valid IP address in the correct
format.

IPv6 Infrastructure
Subnet

Specify the prefix to use for IPv6 infrastructure address allocations.
The default value is 64.

IPv6 Infrastructure
Prefix

Specify the address to use for IPv6 loopback address allocations.
The default value is 0:0:0:b::. Enter a valid IP address in the correct
format.

IPv6Loopback Subnet

Specify the prefix size to use for IPv6 loopback address allocations.
The default value is 64.

IPv6 Loopback Pool
Prefix

Specify the address to use for IPv6 VRF address allocations when
specifying the address range for MPLS VRF. The default value is
0:0:0:c::. Enter a valid IP address in the correct format.

IPv6 VRF Subnet

Specify the prefix to use for IPv6 VRF address allocations. The
default value is 64.

IPv6 VRF Prefix

Configure routing protocols (BGP and IGP). Options are:

• Not specified

• True

• False

The default value is True.
If you specify False, there will be no router configuration for any
of the routing protocols.

Enable Routing
Protocols

Routing
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DescriptionFieldsProperty

Configure the Cisco IGP. Options are:

• Not specified

• OSPF

• ISIS

• EIGRP

• RIP-V2

The default value is OSPF.

IGP

Enable Cisco MPLS OAM for all routes on the topology. Options
are:

• Not specified

• True

• False

The default value is False.

Enable MPLS OAMMPLS

The following table shows the default IP address values used by Cisco Modeling Labs. You can update these
values as required.

Table 22: IP Address Default Values

Optional Value(s)Default ValueOptionViewed from

Not specified, None, v6,
dual_stack

v4IP Address FamilyTopology > AutoNetkit
> Addressing

Address to use.10.0.0.0IPv4 Infrastructure Subnet

Prefix to use.8IPv4 Infrastructure Prefix

Address to use.192.168.0.0IPv4 Loopback Subnet

Prefix to use.22IPv4 Loopback Pool Prefix

Address to use.172.16.0.0IPv4 VRF Subnet

Prefix to use.24IPv4 VRF Prefix

Address to use.0:0:0:a::IPv6 Infrastructure Subnet

Prefix to use.64IPv6 Infrastructure Prefix

Address to use.0:0:0:b::IPv6 Loopback Subnet
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Optional Value(s)Default ValueOptionViewed from

Prefix to use.64IPv6 Loopback Pool Prefix

Address to use.0:0:0:c::IPv6 VRF Subnet

Prefix to use.64IPv6 VRF Prefix

The following table shows the default routing protocols used by Cisco Modeling Labs. You can update these
values as required.

Table 23: Routing Protocols Default Values

Optional Value(s)Default ValueOptionViewed from

true, Not specifiedfalseEnable CDPTopology >AutoNetkit
> General

true, Not specifiedfalseEnable OnePK

false, Not specifiedtrueEnable Routing ProtocolsTopology >AutoNetkit
> Routing

ISIS, EIGRP, RIPv2, Not
specified

OSPFIGP

true, Not specifiedfalseEnable MPLS OAMTopology >AutoNetkit
> MPLS

None or any valid integer1ASNNode > AutoNetkit >
General

ISIS, EIGRP, RIPv2, Not
specified

OSPFIGPNode > AutoNetkit >
IGP

None or valid OSPF area
number

0OSPF Area

Disabled, RRC, HRR, RR,
Not specified

PeeriBGP RoleNode > AutoNetkit >
iBGP

None or alphanumeric stringNo default valueRR Cluster

None or alphanumeric stringNo default valueHRR Cluster

Specify a custom
configuration for the global
stanza.

No default valueGlobalNode > AutoNetkit >
CustomConfiguration
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Optional Value(s)Default ValueOptionViewed from

Specify a custom
configuration for the
physical interfaces.

No default valuePhysical Interfaces

Specify a custom configuration
for loopback zero.

No default valueLoopback Zero

Specify a custom
configuration for OSPF.

No default valueOSPF

Specify a custom
configuration for IS-IS.

No default valueIS-IS

Specify a custom
configuration for EIGRP.

No default valueEIGRP

Specify a custom
configuration for RIP-V2.

No default valueRIP-V2

Specify a custom
configuration for BGP.

No default valueBGP

None or alphanumeric stringNo default valueVRF NameNode > AutoNetkit >
MPLS

true, Not specifiedfalseEnable MPLS TE

false, Not specifiedtrueMultihopNode > AutoNetkit >
External BGP

true, Not specifiedfalseIPv4 Tunnel EnabledNode > AutoNetkit >
GRE Tunnel

true, Not specifiedfalseIPv6 Tunnel Enabled

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Interface Properties

In theNode Editor, selecting an interface on the canvas displays properties for the interface in the Properties
view.

Under the Interface tab, you can perform the following tasks:
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Table 24: Interface Properties

DescriptionProperty

Specify a name for the interface.Name

Specify an IPv4 interface address and an IPv4 subnet prefix length.IPv4

Specify an IPv6 interface address and an IPv6 subnet prefix length.IPv6

To delete an interface from the Node Editor canvas, select the interface, right-click, and choose Delete
from the context menu.

Note

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Connection Properties

When you select a connection on the canvas, the properties of that connection are displayed in the Properties
view.

From the Connection tab, you can associate a line style design with a connection between nodes. Line styles
are visual aids that help you identify the connections used in your topology design.

Search View
To search for text string and files, from the toolbar chooseEdit > Search. The Search dialog box is displayed.
Enter criteria for your search and click Search. The Search view displays the results of the search. A file
search can be based on text strings, regular expressions, and patterns, in addition to whole words and
case-sensitive characters. The scope of a file search can encompass a workspace, selected resources, or projects.

Text searches are only performed on expressions contained in files with the extension .virl.Note

The Search view also displays the results of a Git search, which can be based on the same criteria as noted
in a file search. However, the scope of a Git search, can encompass a particular message, resource, or
identification number in the code.
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Search criteria can be based on either a file or Git. The scope of a search can be general to all the topologies
that are defined on Cisco Modeling Labs client or specific to a particular project or file.

Figure 31: Search View

To use the search functionality, perform the following tasks:

1 From the Cisco Modeling Labs client toolbar, click Search > File.
The Search dialog box appears.

2 In the Containing text field, enter the text string to search for. The Containing text field displays a list
of recently performed searches to select from. Leave this field empty if you want to search for files only.
Check or uncheck the Case sensitive check box depending on whether a case-sensitive search is to be
performed. You can also check the Regular expression check box to enable more powerful searching
capabilities. Check theWhole word check box if you want to search for whole words that are identical
to the text string. Specify the types of files to include in the search in the File name patterns field.

3 Click Choose to open the Select Types dialog box. This dialog box provides a quick way to select from
a list of valid extensions.

4 In the Scope area, specify the files and folders to include in the search. Valid options are:

• The entire workspace.

• The currently selected resources in the workspace.

• A named working set.

• A customized group of files and folders. Use the Customize option to define the type of available
searches from the Search Page Selection dialog box.

5 Click Search to begin your search.
The Search view appears with the results of the search listed. You can click theCancel tool in the Search
view to cancel your search while it is still in progress.

The Search view toolbar contains the following tools:

Figure 32: Search View Toolbar
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Table 25: Available Tools

DescriptionFunctionIcon

Deletes all the highlighted matches from the search results.Remove Selected
Matches

Deletes all the matches from the search results.Remove All
Matches

Expands each item in the Search view.Expand All

Collapses each item in the Search view.Collapse All

Reruns the current search to retrieve previous search results or
to reflect recent changes.

Run the Current
Search Again

Cancels the search currently running.Cancel Current
Search

Browses previously conducted searches and selects a previous
search from the drop-down menu to repeat a previous search.
You can also clear the search history.

Show Previous
Searches

Pins the Search view so that subsequent search results are
displayed in a separate Search view while the pinned view
remains unchanged. This allows for a comparison of results.

Pin the Search
View

Displays the search results as a tree or a list, filters the results
using the Filters option, and sets the overall preferences for
searches using the Preferences option.

View Menu

Reduces the size of the Search view.Minimize

Increases the size of the Search view.Maximize
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Simulations View
The Simulations view displays information about all the running simulations, including:

• Name of the user running the simulation

• Name of the topology

• Number of nodes in the running simulation

• Current state of each node

Figure 33: Simulations View

Possible simulation states are:
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Table 26: Simulation States

DescriptionState

Indicates that the launchworker process has successfullymade all requests
to OpenStack to deploy all simulation nodes.

ACTIVE

Indicates that a stop simulation request has been received.STOP

Possible node states are:

Table 27: Node States

DescriptionState

Indicates that the VM process is successful. It may take a few minutes
for the node to boot up and configure.

ACTIVE

Indicates that the VM is not currently deployed.ABSENT

Indicates that the VM is starting but the router image has not yet loaded.BUILDING

Indicates that the VM process failed.ERROR

Indicates that a request to stop the VM process has been received, without
regard to the current state of the VM.

TERMINATING

The Simulations view toolbar contains the following tools:

Figure 34: Simulations View Toolbar

Table 28: Available Tools

DescriptionFunctionIcon

Refreshes the list of simulations displayed in the Simulations
view.

Refresh the List

Reduces the size of the Simulations view.Minimize

Increases the size of the Simulations view.Maximize
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Topology Options

The following operations are available when you right-click the topology name in the Simulations view:

Figure 35: Topology Options

Table 29: Topology Options

DescriptionOperation

Reopens the Simulation view on the canvas if it is closed.View Simulation

Opens the Console view, showing the message stream from Cisco Modeling
Labs server for the selected topology. Message streams contain information
on the topology launch, such as the name of the launched topology, the date
and time of the launch, and the current status of each node in the topology.

Open Messages Console
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DescriptionOperation

Extracts all the routers' configurations to a locally saved file.
All active console connections are automatically disconnected by
Cisco Modeling Labs. All external Telnet connections to the console
ports must be closedmanually. The Stop simulation operation cannot
be selected prior to the Extract configurations operation.

Note
Extract Configurations

Launches the Live Visualization phase which provides a live, real-time visual
representation of the running simulation in the Cisco Modeling Labs client.

Launch Live Visualization

Stops the running simulation. See Simulate the Topology Overview, on page
171 for more information on stopping and starting simulations.

Stop Simulation

Allows you to use Telnet to connect to ports on a node.Telnet

Allows you to use Telnet to connect over WebSockets to ports on a node.
WebSockets provide full-duplex communications channels over a single
connection.

Telnet over WebSocket

Closes all port connections.Close

Resets all link parameters to their original setting.Reset All Link Parameters
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Node Options

The following operations are available when you right-click the node name in the Simulations view:

Figure 36: Node Options

Table 30: Node Options

DescriptionOperation

Allows you to use SSH to connect to ports on a node; this is available when the
Management Network option Private Simulation Network is selected for the
topology.

SSH

Allows you to use Telnet to connect to ports on a node.Telnet

Allows you to use Telnet to connect over WebSocket to ports on a node. WebSocket
provides full-duplex communications channels over a single connection.

Telnet over Web
Socket
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DescriptionOperation

Allows you to extract the configurations for all routers to a file saved locally.
This operation only applies when the server subtype is
used.

Note
Extract
Configurations

Stops the selected node.Stop this Node

Starts the selected node.Start this Node

Terminal View
The Terminal view is displayed when you connect via Telnet to a node. Using the Terminal view, you can
communicate with and control the operating system running on the node.

Figure 37: Terminal View

The Terminal view toolbar contains the following tools:

Figure 38: Terminal View Toolbar

Table 31: Available Tools

DescriptionFunctionIcon

Disconnects the terminal connection to the node.Disconnect

Sets scrolling on and off.Scroll Lock
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DescriptionFunctionIcon

Allows you to select a connection from the list of
active terminal connections.

Display SelectedConnections

Closes the Terminal view.Remove Terminal

Allows you to set the font to be used in the
terminal, from the Colors and Fonts dialog box.

You can also access theColors and Fonts
dialog box by choosing File >
Preferences >General > Appearance >
Colors and Fonts.

Note

Set Terminal Font

Setting Preferences for the Cisco Modeling Labs Client
For the Cisco Modeling Labs client to operate, you must first identify certain setting preferences. These
preferences are available from the menu bar under File > Preferences:

• Node Subtypes Setting, on page 65

• Terminal Setting, on page 70

• Topology Editor Setting, on page 75

•Web Services Setting, on page 76

• AutoNetkit Visualization Setting, on page 78

•Web Browser Setting, on page 61

• Secure Storage Setting, on page 63

These are discussed in the following sections.
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Web Browser Setting
This setting allows you to add, remove, or edit installed browsers. The selected browser is used by default
when web pages are opened in the Cisco Modeling Labs client for AutoNetkit visualization.

Figure 39: Web Browser Setting

The available operations for this setting are:
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Table 32: Web Browser Setting Operations

DescriptionOperation

Allows you to use an internal web browser built into the Cisco Modeling
Labs client to view AutoNetkit visualization.

The use of an internal Web browser for AutoNetkit visualization is
not supported.

Note

Use Internal Web Browser

Allows you to use an external web browser. You can add new browsers,
delete or edit existing browsers, or search for new browsers to use.

You are required to use an external Web browser for AutoNetkit
visualization. Also, you are required to use Mozilla Firefox, Google
Chrome, or Apple Safari as your default web browser. Internet
Explorer is not supported for AutoNetkit visualization.

Note

Use External Web Browser

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply
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Secure Storage Setting
This setting configures security preferences and encryption requirements for storing system passwords.

Figure 40: Secure Storage Setting

The Password tab pools functionality related to the master password life cycle and password providers.

The available options are:

Table 33: Password Tab Options

DescriptionOption

Clears cached master passwords from memory.Clear Passwords
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DescriptionOption

Lists the currently available password providers. By default, the enabled
provider with the highest priority is used to encrypt the data added to secure
storage. The priority range is from 0 to 10, with 10 being the highest priority.

Data can only be decrypted by the same provider that encrypted the
data. By default, all password providers are enabled. Each password
provider that has been used at least once will have a master password
associated with it. The Details text box provides information on the
master password providers.

Note

Master Password Providers

Changes the master password of the selected password provider.Change Password

Opens the Password Recovery dialog box. Use this option if you have
forgotten the master password and have configured password recovery
questions. The button is disabled if the password recovery setup was cancelled
when the master password was created.

The answers for the password recovery questions must be entered
exactly as they were during the password recovery setup. Answers
are case sensitive, and white space inside answers are relevant.

Note

Recover Password

Restores to the initial default state.Restore Defaults

Applies changes.Apply

The Contents tab displays contents of the default secure storage. Secure storage is organized as a tree, where
nodes represent the context of information and values associated with each node. Selecting a node in the tree
displays a table of values associated with that node. Values stored in a nonencrypted form will be displayed;
the encrypted values will be shown as *********. At the bottom of this tab, you will find the actual file
location used to persist secure storage data. To force the changes to the contents of secure storage to be saved,
click Save.

To delete stored data in order to recover from an error or to reflect a change in the setup, click Delete. This
deletes the contents of secure storage. In some cases, other parts of the applicationmay depend on the contents
of secure storage that you deleted.

To avoid unexpected errors, we recommend that you restart the application after secure storage has been
deleted.

Caution

TheAdvanced tab provides a list of algorithms to further configure secure storage. Changes in the encryption
algorithm are applied only to the data stored after a change. If you have already created a secure storage, you
must first delete it and then recreate it to use the newly selected encryption algorithm.

Resetting the Secure Storage Password
When the Secure Storage feature is used for the first time, it generates a master password that is used to encrypt
the data. In the future, this same master password will be required to retrieve the data from secure storage. If
the master password becomes unavailable, the Secure Storage feature provides optional support for password
recovery.

Two methods are used to reset the password for the secure storage feature.

Method 1
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1 From within Cisco Modeling Labs client, choose File > Preferences > General > Security > Secure
Storage.

2 Click Change Password. The Secure Storage dialog box appears.
3 Click Yes. The Password Recovery dialog box appears.
4 Enter details in both Question fields and provide answers for both questions. Take note of the answers

you provide, as these are treated as secondary passwords.
5 Click OK.

Method 2

If you are unable to access the Cisco Modeling Labs client due to a lost or forgotten password for the secure
storage feature, complete the following steps:

1 Move to the <user-home>/.eclipse/org.eclipse.equinox.security folder.
2 Delete the file secure_storage.
3 Open Cisco Modeling Labs client to provide details for the password for the secure storage feature when

prompted.

Node Subtypes Setting

Figure 41: Node Subtypes Setting

The available operations for this setting are:
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Table 34: Node Subtypes Setting Operations

DescriptionOperation

Updates the local subtypes based on the currently configured CiscoModeling
Labs server. All the subtypes supported on Cisco Modeling Labs server are
available with this operation. See Fetch Node Subtypes from the Cisco
Modeling Labs Server, on page 66.

Fetch from Server

Reverts to the original list of subtypes.Restore Defaults

Applies changes.Apply

Fetch Node Subtypes from the Cisco Modeling Labs Server
To fetch new node subtypes from the Cisco Modeling Labs server, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Fetch from Server button.

The Confirm dialog box is displayed.
Step 3 Click OK to update the list of node subtypes.

Figure 42: Fetch Node Subtypes from Server

Step 4 Click OK to finish.
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The updated list of node subtypes is available for use in the Topology Palette view.
Contact your system administrator if a specific node subtype is missing from the list, as the system administrator
is responsible for adding new node subtypes to the Cisco Modeling Labs server.

Packet Capture Setting
This setting allows you to check for suitable applications that can open .pcap files when you have downloaded
packet captures. The .pcap files can be set to either open automatically or after receiving a prompt.

Figure 43: Packet Capture Setting

The available operations for this setting are:

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
67

Using the Cisco Modeling Labs Client
Packet Capture Setting



Table 35: Packet Capture Setting Operations

DescriptionOperation

Check the checkbox box to have the system automatically check for a suitable
application to open the .pcap files.

Check forApplications
Capable of Opening
*.pcap Files

Select the applicable option: Always, Never or Prompt for opening downloaded
.pcap files.

Open Downloaded
*.pcap Files

Restore the settings to their initial default state.Restore Defaults

Apply any changes made.Apply
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Simulation Launch Setting
This setting allows you to include the file's path in the system-generated Simulation IDs. You can set the
system to either open the Simulation perspective automatically or after receiving a prompt.

Figure 44: Simulation Launch Setting

The available operations for this setting are:

Table 36: Simulation Launch Setting Operations

DescriptionOperation

Check this box if you want to include the file's path in the system-generated
Simulation IDs.

Include the File's Path
in Sytem generated
Simulation IDs.
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DescriptionOperation

Select the applicable option: Always, Never or Prompt for switching to the
Simulation perspective after a simulation is launched.

Switch to the
Simulation Perspective
after a Simulation is
Launched.

Restore the settings to their initial default state.Restore Defaults

Apply any changes made.Apply

Terminal Setting
This setting allows you to launch an external terminal application, such as SecureCRT or PuTTY, or use the
internal Cisco Modeling Labs client Terminal view in a separate window.
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Note • If you are using the internal Cisco Modeling Labs Terminal view, the views are visible from both
the Design and Simulation perspectives. However, a detached view is only visible from the
perspective in which it was detached.

• If you are using an external terminal application, you must specify both Telnet and SSH run
commands. Youmust also ensure that the title format includes the percentage (%) character. Omission
of either of these requirements will impede your ability to save your setting preferences.

•When you specify to use an external terminal via File > Preferences > Terminal > Cisco Terminal
and then Telnet over WebSocket to a VM, the terminal opens internally, not externally as specified.

Figure 45: Terminal Setting
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The available operations for this setting are:

Table 37: Terminal Setting Operations

DescriptionOperation

Allows you to add a Terminal view title using the required formatting
characters.

Title Format

Uses the Cisco Modeling Labs internal Terminal view.Use Internal Terminal View

Opens multiple tabs in a terminal view for a running simulation.Multiple Tabs forOne Simulation

Uses an external terminal application, such as SSH or PuTTY.Use External Terminal
Application (specified below)

Specify the Telnet command to run if you are using an external terminal
application.

Telnet Command

Specify the arguments for the Telnet command.Telnet Arguments

Specify the SSH command to run if you are using an external terminal
application.

SSH Command

Specify the arguments for the SSH command.SSH Arguments

Removes settings specified for an external terminal application and
restores terminal settings to the CiscoModeling Labs internalTerminal
view.

Restore Defaults

Applies changes.Apply

Setting Up an External Terminal

This section outlines the steps involved in setting up an external terminal on Windows and OS X.

Windows

Under File > Preferences > Terminal > Cisco Terminal, update the terminal settings for connection to an
external program. For example, for a PuTTY installation, configure the putty.exe binary file as the terminal
program.

The complete PATH must be specified.Note

Table 38: PuTTY Command-Line Options

DescriptionCommand-Line Option

Opens an SSH connectionssh

Opens a Telnet connectiontelnet
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DescriptionCommand-Line Option

Specifies the host to connect to (the Cisco Modeling Labs client will not allow an
external program to be set without having%h in the command line)

%h

Specifies the host to connect to (the Cisco Modeling Labs client will not allow an
external program to be set without having%p in the command line)

%p

For an external terminal on Windows, the commands to enter are:

• Telnet command: "C:\Program Files (x86)\PuTTY\putty.exe" -telnet %h %p

• SSH command: "C:\Program Files (x86)\PuTTY\putty.exe" -ssh %h %p

The double quotes (" ") must enclose the PATH to allow the use of spaces within the PATH. Select the
Use external terminal application (specified below) radio button to use an external terminal.

Note

The following table lists other terminal programs that can be used.

Table 39: Additional Terminal Programs

Command to UseConnection TypeTerminal
Program

"C:\Program Files (x86)\NetSarang\Xshell 4\xshell.exe"

-url telnet://%h:%p -newtab %t

TelnetXshell

"C:\Program Files\VanDyke Software\SecureCRT\SecureCRT.exe"

/T /TELNET %h %p

The /T option ensures SecureCRT creates a tab for new
sessions instead of opening a newwindow. Ensure to validate
the path of the binary.

Note

TelnetSecureCRT

OS X

The procedure is more complex on OSX since command-line parameters are not as easy to use on this platform.
Two additional components are required. These are:

• AppleScript: A program used to start applications and interact with them; some examples are open
windows, start new sessions, paste keyboard input into a session, and so on.

• /usr/bin/osascript: A built-in OS X command-line utility used to execute AppleScript and other OSA
language scripts. This is configured in the Cisco Modeling Labs client; it is essentially the glue between
the Cisco Modeling Labs client and the terminal application.

The following table lists iTerm and the built-in Terminal.app programs that can be used on OS X.
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Table 40: Additional Terminal Programs for OS X

Command to UseConnection TypeTerminal
Program

/usr/bin/osascript /Users/your-user-id/iterm.scpt telnet

%h %p %t

TelnetiTerm

/usr/bin/osascript /Users/your-user-id/iterm.scpt telnet

%h %p %t

SSH

/usr/bin/osascript /Users/your-user-id/iterm.scpt ssh %h

%p %t

TelnetTerminal.app

/usr/bin/osascript /Users/your-user-id/terminal.scpt ssh

%h %p %t

SSH

The following are AppleScript scripts that are used to set up an external terminal.

iTerm
on run argv

tell application "iTerm"
activate
if current terminal exists then

set t to current terminal
else

set t to (make new terminal)
end if

tell t
launch session "Default Session"
tell the current session

write text "/usr/bin/" & item 1 of argv & " " & item 2 of argv & " " & item
3 of argv

set name to item 4 of argv
end tell

end tell
end tell

end run

Terminal.app
on run argv

tell application "Terminal"
activate
-- open a new Tab - there is no method
tell application "System Events"

keystroke "t" using {command down}
end tell
repeat with win in windows

try
if get frontmost of win is true then

set cmd to "/usr/bin/" & item 1 of argv & " " & item 2 of argv & " " &
item 3 of argv

do script cmd in (selected tab of win)
set custom title of (selected tab of win) to item 4 of argv

end if
end try

end repeat
end tell

end run
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Topology Editor Setting
This setting allows you to customize the Topology Editor in the Cisco Modeling Labs client.

Figure 46: Topology Editor Setting

The available operations for this setting are:

Table 41: Topology Editor Setting Operations

DescriptionOperation

Resets the definition of the Palette view tools Select andConnect
to their default configuration. This option is disabled by default.

Revert Back to the Palette's Default
Tool
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DescriptionOperation

Enables the following:

•When selected, interfaces are automatically assigned to
connections between nodes.

•When deselected, you are presented with a list of available
interfaces.

Associate New Connection with
Interfaces Silently

Enables the following:

•When the number of connections in the topology exceeds
the value set in this field, the internal algorithm used to
connect nodes will not be the shortest path algorithm.

Disable Shortest Path Algorithm if
Connection Amount > (Greater than)

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

Web Services Setting
This setting allows you to configure the CiscoModeling Labs client to communicate with the CiscoModeling
Labs server. When you first launch the Cisco Modeling Labs client, the Active profile is not specified and
the web services that are listed displayUnauthorized in red. This message relates to theMaster Credentials
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field, which must be set before the Cisco Modeling Labs client can communicate with the Cisco Modeling
Labs server.

Figure 47: Web Services Setting

The available operations for this setting are:

Table 42: Web Services Setting Operations

DescriptionOperation

Identifies an active profile that has been defined on the Cisco Modeling Labs
client. You can define a new active profile and edit or delete an existing active
profile.

Active Profile
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DescriptionOperation

Specifies a username and password for accessing the CiscoModeling Labs server.
These credentials are provided by the system administrator.

Master Credentials

Lists the web services needed for the Cisco Modeling Labs server and the Cisco
Modeling Labs client to communicate with each other. The web services listed
are:

• Roster

• Simulation Engine

• OpenStack

• AutoNetkit

After you have set up your profile with the correct base URI, each of the
web services will displayCompatible in green, indicating that the Cisco
Modeling Labs client can communicate with the Cisco Modeling Labs
server.

Note

Web Services

Encrypts passwords and stores them locally on the Cisco Modeling Labs client.
To change the settings for managing the encrypted passwords, choose File >
Preferences >General > Security > Secure Storage. See Secure Storage Setting,
on page 63 for more information.

Store Encrypted
Passwords in System's
Secure Storage

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

AutoNetkit Visualization Setting
The AutoNetkit visualization feature is available only when node configurations are built using the parameters
defined in AutoNetkit. If AutoNetkit visualization is turned off, you cannot get a true representation of your
topology.

AutoNetkit visualization is used to determine how AutoNetkit presents graphical representations of
topology-specific attributes, such as nodes, links, and interfaces, during the build phase. The graphical
representations can be presented as a physical perspective of a network topology or based on a protocol
perspective.

For AutoNetkit visualization to operate, the Cisco Modeling Labs client must be connected to the Cisco
Modeling Labs server. The nodes in the network topology must be set to open AutoNetkit visualization either
automatically or after receiving a prompt.
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To access this setting, choose File > Preferences >Web Services > AutoNetkit Visualization.

Figure 48: AutoNetkit Visualization Setting

The available operations for this setting are:

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
79

Using the Cisco Modeling Labs Client
AutoNetkit Visualization Setting



Table 43: AutoNetkit Visualization Setting Operations

DescriptionOperation

Specifies the external web browser to use when displaying AutoNetkit
visualization results. Options are:

• Default: The default system browser

• WebKit: Based on the Safari web browser

• Mozilla

You are required to useMozilla Firefox, Google Chrome, or Apple
Safari as your default web browser. Internet Explorer is not
supported for AutoNetkit visualization or for theUserWorkspace
Management interface.

Note

Preferred Web Browser
Engine

Specifies whether to view configuration changes after a new build is
generated. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

View Configuration Changes

Specifies when to open a browser window to display AutoNetkit
visualization. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

Open AutoNetkit
Visualization

Assigns a port value to the web service supporting AutoNetkit visualization.
The default port is 19401. However, the port might need to be changed
depending on your network, for example, if a firewall is blocking that port.
The port value should be provided by the system administrator.

If an incorrect port value is entered, you will be prompted with an
error during the build stage.

Note

Configuration Visualization
Port

Assigns a port value to the web service supporting Live Visualization. The
default port is 19402. However, the port might need to be changed
depending on your network, for example, if a firewall is blocking that port.
The port value should be provided by the system administrator.

If an incorrect port value is entered, you will be prompted with an
error during the build stage.

Note

Live SimulationVisualization
Port

Restores the default state for the preferred web browser engine and restores
the default port values assigned to AutoNetkit visualization and Live
Visualization.

Restore Defaults

Applies any changes made.Apply
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C H A P T E R  3
Design a Topology

• Design a Topology Overview, page 83

• Topology Nodes and Connections, page 83

• Create a Topology, page 86

• Place the Nodes on the Canvas, page 87

• Create Connections and Interfaces, page 88

• Use Unmanaged Switches, page 88

• The Cisco IOSvL2 Switch Image, page 90

• Create a Site, page 94

Design a Topology Overview
The design phase is the initial step in creating a network topology. During the design phase, you will perform
the tasks described in the following sections.

Topology Nodes and Connections
The topology you design consists of nodes and connection functions. See NavigatingWithin the CiscoModeling
Labs Client, on page 7 for additional information about how to select and edit nodes and connection functions.

Topology Nodes

Table 44: Node Subtypes

Node TypeNode Name

Router node. Runs a Cisco IOS operating system.Cisco IOSv

Router node. Runs a Cisco IOS Layer 2 operating system.Cisco IOSvL2
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Node TypeNode Name

Server node. Runs a Linux operating system.Server

Router node. Runs a Cisco IOS XR operating system.Cisco IOS XRv

Router node. Runs a Cisco IOSXR 9000 operating system.
(Available separately.)

Cisco IOS XRv 9000

Router node. Runs a Cisco CSR 1000 operating system.
(Available separately.)

Cisco CSR1000v

Router node. Runs a Cisco ASAv operating system.Cisco ASAv

A node subtype is a virtual machine that runs on top of OpenStack, which itself is running in a Linux virtual
machine that is running on top of VMware software. Because the node is virtual, specific hardware is not
emulated. For example, there are no power supplies, no fans, no ASICs, and no physical interfaces. For all
router nodes, the interface type is a Gigabit Ethernet network interface. A server node has an Ethernet network
interface.

You can choose an image and image flavor for each node type. See theUserWorkspaceManagement chapter
in the Cisco Modeling Labs Corporate Edition System Administrator Installation Guide, Release 1.2 for
information on how to access the VM Image and the VM Flavor choices. In most cases, you need not select
an image and flavor. By default, the node subtype is associated with an image and flavor that runs with the
topology.

Table 45: Node VM Images

Used ForVM Image Name

Server nodeserver

Cisco CSR1000 nodeCSR1000v

Cisco IOS nodeIOSv

Cisco IOS Layer 2 nodeIOSvL2

Cisco IOS XR nodeIOS XRv

Cisco IOS XR 9000 nodeIOS XRv 9000

Cisco AVAv nodeAVAv

Table 46: Node VM Flavors

Used ForVM Flavor Name

Linux serverm1_tiny
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Used ForVM Flavor Name

Linux serverm1_small

Linux serverm1_medium

Linux serverm1_large

Linux serverm1_xlarge

Linux serverserver

Cisco CSR 1000 nodeCSR1000v

Cisco IOS XR nodeIOS XRv

Cisco IOS XR 9000 nodeIOS XRv 9000

Cisco IOS nodeIOSv

Cisco IOS Layer 2 nodeIOSvL2

Cisco AVA nodeAVAv

Each Linux flavor provides a different amount of memory and CPU allocated to the server.

Connection Functions

Cisco Modeling Labs provides the connection functions shown in the following table.

Table 47: Connection Functions

DescriptionConnection Type

Creates a connection between two interfaces.
Interfaces are created in the node to support a
connection. Any unused interfaces present are
automatically assigned. All the interfaces in router
nodes are represented as Gigabit Ethernet interfaces.
Multiple parallel connections are supported.

Connection

Creates an external router connection point.
When the external router is used in conjunction with
a Layer 2 External (Flat) network and IOSv instances,
AutoNetkit is able to configure an L2TPv3 tunnel to
connect simulations to remote devices in a transparent
manner.

External Router

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
85

Design a Topology
Topology Nodes and Connections



DescriptionConnection Type

Creates a Layer 3 external connection point using
static network address translation (SNAT). This
external connection point allows connections outside
of Cisco Modeling Labs to connect to the topology.

Layer 3 External (SNAT)

Creates a Layer 2 external connection point using
FLAT. This external connection point allows
connections outside of Cisco Modeling Labs to
connect to the topology.

Layer 2 External (Flat)

Creates a Layer 2 external connection point using
FLAT1. This second external connection point allows
connections outside of Cisco Modeling Labs to
connect to the topology.

Layer 2 External (Flat1)

Table 48: Site Groups

DescriptionType

Creates a site that uses levels of hierarchy in a Cisco
Modeling Labs topology. Sites can be added to a
topology, objects can be created within a site, and
objects can be linked between sites and parent sites.

Site

Create a Topology
Before You Begin

A topology project folder must exist.

There are several methods for creating a topology. These are discussed in the following sections.

Method 1: Create a Topology from the Menu Bar

Step 1 Select a topology project folder.
Step 2 Enter a filename, ensuring that it ends with the extension .virl.
Step 3 Click Finish.

A filename .virl topology file is created in the selected project folder.
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Method 2: Create a Topology from the Projects View

Step 1 Right-click Projects view.
Step 2 Choose New > Topology.
Step 3 Select a topology project folder.
Step 4 Enter a filename, ensuring that it ends with the extension .virl.
Step 5 Click Finish.

A filename .virl topology file is created in the selected project folder.

Method 3: Create a Topology from the Toolbar

Step 1 Click the New Topology File icon in the toolbar.
Step 2 Select a topology project folder.
Step 3 Enter a filename, ensuring that it ends with the extension .virl.
Step 4 Click Finish.

A filename .virl file is created in the selected project folder.

What to Do Next

Place the nodes.

Place the Nodes on the Canvas
Before You Begin

• A topology file must exist.

• The topology file must be open and the canvas visible in the Topology Editor.

Step 1 Click a node type, which is under the Nodes heading in the Palette view.
Step 2 Click the canvas at each point where you want to place a node. You can also drag the nodes on the canvas to position

them. You can then arrange the nodes using several methods:
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What to Do Next

Create connections and interfaces.

Create Connections and Interfaces
Before You Begin

Nodes must be in place on the canvas of the Topology Editor.

Step 1 Click Connection in the Tools view.
Step 2 Click the first node.
Step 3 Click the next node to create the connection.

When you connect two nodes, the interfaces are created and named automatically when you choose File >
Preferences > Topology Editor > Associate new connection with interfaces silently check box. You can
view the node interfaces when you click the connection and the two end points of the connection appear in the
Node Editor.

Note

Step 4 Repeat Step 2 and Step 3 until all the connections are in place.
You can create multiple parallel connections between two nodes. When a connection is selected, the Topology
Editor shows the connection end points and the Node Editor shows the two nodes involved in the connection,
all of the interfaces on those nodes, and all the connections between those two nodes.

Tip

Choose File > Export > Export Topology Diagram to Image to capture an image of the current topology on
the canvas.

Note

Use Unmanaged Switches
Users have the choice to use either an unmanaged switch or Cisco IOSv layer 2 to provide a switching service.
Unmanaged switches are used in place of the multipoint connection which was available in previous versions
of Cisco Modeling Labs. For example, in the following figure there are 3 IOSv instances connected to an
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unmanaged switch. Each of the interfaces on iosv-1, iosv-2, and iosv-3 appear to be on the same subnet for
point to point communication through the unmanaged switch.

Figure 49: Using an Unmanaged Switch in a Simple Topology

Unmanaged switch instances use the underlying Linux bridge process running under OpenStack control to
provide this connectivity between the various virtual machines. It is a transparent switch.

Before You Begin

A topology file with the extension .virl must exist. Router nodes or server nodes are placed on the canvas.
Optionally, connections may exist between nodes.

Step 1 In the Nodes view, click Unmanaged Switch.
Step 2 Click the area on the canvas where you want the unmanaged switch to appear.
Step 3 In the Tool view, click Connect.
Step 4 On the canvas, click the unmanaged switch node then click an end node. A connection appears.
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Continue clicking unmanaged switch-node combinations until all connections are made.

Figure 50: Using an Unmanaged Switch

The Cisco IOSvL2 Switch Image
The Cisco IOSvL2 switch image is a virtual machine like Cisco IOSv, Cisco IOS XRv, and so on. It runs and
is configured in the same way as all other virtual machines. It runs an Cisco IOSv 15.2 switch image.

All Cisco IOSvL2 switch images in a topology are counted against the node limit.Note

A Cisco IOSvL2 switch image provides sixteen Gigabit Ethernet interfaces, reserving Gi0/0 for OOB
management. It can be configured manually or using AutoNetkit.

Cisco IOSvL2 switch instances can operate in:

• Layer 2 mode

• Layer 3 mode

By default the instances operate in layer 3 mode. However, the primary use of the Cisco IOSvL2 switch image
is for switching purposes.

Any routers set up to connect to the Cisco IOSvL2 switch will be in switchport access mode. By default, all
routers are placed in VLAN 2. You can specify which VLAN to place a port in by setting a VLAN attribute
on the router interface. See Assign VLANs, on page 126 for details on how to do this.
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When using a switch to switch connection, it defaults to a 802.1q trunk port between the switches when
configured using AutoNetkit.

Use the Cisco IOSvL2 Switch Image

Step 1 In the Nodes view, click IOSvL2.
Step 2 Click the canvas at each point where you want to place an IOSvL2 node. You can also drag the nodes on the canvas to

position them.
Step 3 Add additional node types as required.
Step 4 Use the Connect tool to create connections between the nodes.
Step 5 To specify which VLAN to place a port in, select the interface for the host or router in the Node Editor.
Step 6 Under Properties > AutoNetkit, enter a value for the VLAN field, as shown.

Figure 51: Setting the VLAN Attribute

Step 7 From the toolbar, click Build Initial Configurations to generate a configuration for the topology using AutoNetkit.
When prompted to open AutoNetkit visualization, click Yes.
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AutoNetkit visualization for the topology opens in a browser window.

Figure 52: AutoNetkit Visualization

Step 8 To view all broadcast domains that are enabled, select layer2_conn from the phy drop-down list. For example, hovering
over server-2 in this example shows the routers and servers that are in the same VLAN. All other devices are greyed out.

Figure 53: Layer 2 Connectivity
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Selecting layer2 from the phy drop-down list shows the switches representing the VLANs in place.

Figure 54: Layer 2 Switches
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Step 9 In the Cisco Modeling Labs client, click Launch Simulation to start the simulation.
The simulation starts and is visible in the Simulations view.

Figure 55: Simulation with Cisco IOSvL2 Switch Image

Create a Site
A site is a container that can hold one or more nodes. It is used to group multiple nodes within the same site,
which provides a degree of hierarchy and simplifies the topology view.

A node interface within a site can connect to another node interface in the same site or to a node interface
located in a different site. A connection cannot start on a node and terminate on a site. Sites can be nested,
forming a hierarchical structure.
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Before You Begin

One or more nodes should be on the canvas.

Step 1 In the General view, click Site.

Step 2 Click an area on the canvas to place the site.

Step 3 Shift-Click the nodes that you want in the site, or click and drag a selection window around the nodes.

• From the Edit menu, choose Group to Site.

• Alternatively, you can drag the selected nodes to the site icon that you placed on the canvas.

Step 4 To view the site, select the site name from the drop-down list under the Topology tab.
A topology site tab opens and displays the site view.

The drop-down list under the Topology tab displays the site hierarchy as a navigation trail.

To open a site view, double-click on the site. The following figure shows the navigation trail selections for Site 1 and
Site 2.

Figure 56: Site Selection

Step 5 To ungroup the site, click the site icon and choose Edit > Ungroup Site.
Step 6 To connect node interfaces between Site 1 and Site 2:

a) Select Site 1.
b) Click Connect.
c) Click the node that is the starting point of the connection, Site 1.
d) Move the cursor to the breadcrumbs and click Site 2.

Site 2 is displayed.
e) Click the node that is the endpoint of the connection.

A connection now exists between the interfaces in the two sites.

Step 7 To delete a node from a site:
a) Select the applicable node.
b) Right-click the node and select Delete from the list.
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The node is deleted.

Step 8 To delete a site from a topology:
a) Select the applicable site.
b) Right-click the site and select Delete from the list.

The site is deleted including all associated interfaces and connections.
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C H A P T E R  4
Build a Configuration

• Build a Configuration Overview, page 97

• Create and Modify a Node Configuration, page 97

• Create a Node Configuration Manually, page 98

• Use an Existing Node Configuration, page 99

• Import the Configuration from Other Types of Files, page 99

• Import the Nodes Configuration Files, page 117

• Create Node and Interface Configurations Using AutoNetkit, page 122

• Assign VLANs, page 126

• Use a Managed Switch, page 127

• Set Firewall Capabilities, page 133

• Set Security Levels, page 135

• Configure GRE Tunnels, page 137

• Automatic Configuration for OpenDayLight Controllers, page 143

Build a Configuration Overview
In the build phase, you build the configurations for each node. After selecting the options for the overall
topology and each node, you create the configuration files. Alternatively, you can use AutoNetkit to create
the configuration files.

You can modify and save configuration files for the topology and for each node in your topology.

Create and Modify a Node Configuration
While AutoNetkit is useful for generating configuration files for all the nodes in the topology, you can bypass
AutoNetkit and enter node configuration information directly.

You can enter configuration information in either of the following ways:
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• During the design phase, copy and paste configuration commands for each node.

• During the simulation phase, connect to a node console and change its configuration when the topology
is running. See the chapter Simulate the Topology Overview for more information on how to modify,
extract, and save a running configuration.

When you create your configuration files:Note

• Changes that are manually entered are not visible in the topology design. If you create a new interface
by entering configuration commands, the interface is not created in OpenStack nor does the interface
show up in any of the node views.

• Depending on how the AutoNetkit Auto-generate the configuration based on these attributes
feature is set, you may overwrite the changes you enter.

While in the Design perspective, any changes you manually make to a node configuration are saved in the
current filename .virl file. Before you launch a simulation from theDesign perspective, a notification window
advises you to save the changes or cancel the simulation launch.

Figure 57: Save Changes Before Launch

Create a Node Configuration Manually
Before You Begin

The topology design should be complete.

Step 1 In the Topology Editor, click a node.
Step 2 In the Properties view, clickAutoNetkit and uncheck theAuto-generate the configuration based on these attributes

check box.
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Figure 58: Uncheck Auto-generate Check Box

Step 3 Click the Configuration tab.
Step 4 Enter the configuration commands in the Configuration view.

All changes are automatically saved to the filename .virl file. However, the changes made do not appear in the
topology on the canvas.

Note

Use an Existing Node Configuration
You can use an existing configuration file to create a node configuration in Cisco Modeling Labs.

Before You Begin

The topology design should be complete.

Step 1 In the Topology Editor, click a node.
Step 2 In the Properties view, clickAutoNetkit and uncheck theAuto-generate the configuration based on these attributes

check box.
Step 3 Click the Configuration tab.

a) Open the configuration file you want to use and copy the configuration commands.
b) In the Configuration view, paste the configuration commands.

All changes are automatically saved to the filename.virl file. However, the changes made do not appear in
the topology on the canvas.

Note

What to Do Next

Launch a simulation to observe the changes.

Import the Configuration from Other Types of Files
For this version of Cisco Modeling Labs, you are able to import configurations from a number of other file
types, such as, Cariden MATE, Visio, GNS3 to name a few. These are discussed in the following sections.
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Import the Configuration from a Cariden MATE File
You can import a topology from an existing Cariden MATE file, version 5.2.0 or later or version 6.1.0. Cisco
Modeling Labs client will accept site imports up to two layers deep. Any Cariden MATE file that has a
topology with more than two layers of sites will not import correctly.

Before You Begin

• A valid Cariden MATE file is available on your file system.

• Cisco Modeling Labs client is running.

• Your license allows Cariden MATE file import.

Step 1 Choose File > Import.
A window appears, prompting you to Import Cariden MATE file.

Step 2 Choose Import Cariden MATE File then click Next.

Figure 59: Import Cariden MATE File
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Step 3 Choose the From data file Cariden MATE file to import. Use Browse to select the directory and file to import.
Step 4 Choose the location Into target folder for the Cariden MATE file. Use Browse to select the target Project folder.

Figure 60: Choose the From and To Locations

Step 5 Enter a filename for the imported Cariden MATE file.
The filename you enter must have the extension .virl. For example, Lab_import.virl is a valid filename.
Otherwise, you cannot open the file in the topology editor.

Important

The Cariden MATE file converts to a Cisco Modeling Labs .virl file.
Step 6 In the Projects view, expand the project folder where you saved the imported file.
Step 7 Right click on the imported file, for example, Lab_import.virl and choose Open With > Topology Editor.
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The canvas opens and displays the topology.

Figure 61: Imported Cariden MATE File

Export the Configuration to Cariden MATE File

Before You Begin

• Cisco Modeling Labs client is running.

• A topology is open in the Topology Editor.

• Your license allows Cariden MATE file export.

Step 1 Choose File > Export.
A window appears, prompting you to Export to Cariden MATE file.

Step 2 Choose Export Cariden MATE File then click Next.
Step 3 Choose the location To file for the Cariden MATE file export. Use Browse to select the target Project folder.
Step 4 Enter a filename for the exported Cariden MATE file, or use the default filename. For example, sample_topology.virl

is converted to sample_topology.pln and saved in the target directory.
Step 5 Click Finish.

The Cisco Modeling Labs .virl file silently converts to a Cariden MATE .pln file.
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Import the Configuration from a Visio vsdx File
You can import a topology from an existing Visio .vsdx file, version 2013 and later.

Before You Begin

• A valid Visio file is available on your file system.

• Cisco Modeling Labs client is running.

• Your license allows Visio file import.

Step 1 Choose File > Import.
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The Import dialog box appears.
Step 2 Expand the Topology folder, choose Import Visio vsdx File and click Next.

Figure 62: Import Visio vsdx File
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Step 3 Choose the From data file Visio .vsdx file to import. Use Browse to select the directory and file to import.
Step 4 Choose the location Into target folder for the Visio .vsdx file. Use Browse to select the target Project folder.

Figure 63: Choose the From and To Locations

Step 5 Click Finish.

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
105

Build a Configuration
Import the Configuration from a Visio vsdx File



The Visio .vsdx file converts to a Cisco Modeling Labs .virl file, using the original filename of the file and it is
automatically opened on the canvas.

Figure 64: Imported Visio .vsdx File

In this example, the file pod-topology.vsdx has been renamed by Cisco Modeling Labs to
pod-topology.vsdx-Final Topo.virl. We recommend that for your .vsdx file imports, you rename the file(s)
replacing the dot in .vsdx with '_'. In this example, pod-topology.vsdx-Final Topo.virl becomes
pod-topology_vsdx-Final Topo.virl. You must do this as in Cisco Modeling Labs, the roster will parse the
extra dot as a hierarchy delimiter and the simulation will fail.

Note
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Export the Configuration to SVG Files
For this release of Cisco Modeling Labs, export to Visio .vsdx files is not supported. However, export to .svg
files is supported, as Visio supports the use of .svg files. The Export option can be used to export .virl files
as .svg files.

Before You Begin

• Cisco Modeling Labs client is running.

• A topology is open in the Topology Editor.

• Your license allows SVG file export.

Step 1 Choose File > Export.
A window appears, prompting you to Export to SVG file.

Step 2 Choose Export to SVG file then click Next.
Step 3 Choose the location To file for the SVG file export. Use Browse to select the target Project folder.
Step 4 Enter a filename for the exported SVG file, or use the default filename. For example, sample_topology.virl is converted

to sample_topology.svg and saved in the target directory.
Step 5 Click Finish.

The Cisco Modeling Labs .virl file silently converts to a SVG .svg file.

Import the Configuration from a GNS3 File
You can import a topology from an existing GNS3 .gns3 file.

Before You Begin

• A valid GNS3 JSON-based (.gns3) file is available on your file system.

• Cisco Modeling Labs client is running.

Step 1 Choose File > Import.
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The Import dialog box appears.
Step 2 Expand the Topology folder, choose Import GNS3 File and click Next.

Figure 65: Import a GNS3 .gns3 File
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The Import GNS3 File dialog box is displayed.
Step 3 In the From source file field, use Browse to select the directory and GNS3 .gns3 file to import.
Step 4 In the Into destination file field, use Browse to select the target folder.

Figure 66: Choose the From and To Locations

Step 5 Click Finish.

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
109

Build a Configuration
Import the Configuration from a GNS3 File



The GNS3 .gns3 file converts to a Cisco Modeling Labs .virl file, using the original filename of the file and it is
automatically opened on the canvas.

Figure 67: Imported GNS3 .gns3 File

Export the Configuration to GNS3 Files

Before You Begin

• Cisco Modeling Labs client is running.

• A topology is open in the Topology Editor.

Step 1 Choose File > Export.

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.2
110

Build a Configuration
Import the Configuration from a GNS3 File



The Export dialog box appears.
Step 2 Expand the Topology folder, choose Export to GNS3 File and click Next.

Figure 68: Export a GNS3 .gns3 File
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Step 3 In the To file field, use Browse to select the target folder.

Figure 69: Export a GNS3 .gs3 File

Step 4 Enter a filename for the exported GNS3 file, or use the default filename. For example, sample_topology.virl is converted
to sample_topology.gns3 and saved in the target directory.

Step 5 Click Finish.
The Cisco Modeling Labs .virl file silently converts to a GNS3 .gns3 file.

Import the Configuration from a GraphML File
You can import a topology from an existing GraphML .graphml file.

Before You Begin

• A valid GraphML file is available on your file system.
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• Cisco Modeling Labs client is running.

Step 1 Choose File > Import.
The Import dialog box appears.

Step 2 Expand the Topology folder, choose Import GraphML and click Next.

Figure 70: Import a GraphML .graphml File
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The Import GraphML File dialog box is displayed.
Step 3 In the From source file field, use Browse to select the directory and GraphML .graphml file to import.
Step 4 In the Into destination file field, use Browse to select the target folder.

Figure 71: Choose the From and To Locations

Step 5 Click Finish.
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The GraphML .graphml file converts to a Cisco Modeling Labs .virl file, using the original filename of the file and it is
automatically opened on the canvas.

Figure 72: Imported GraphML .graphml File

Export the Configuration to GraphML Files

Before You Begin

• Cisco Modeling Labs client is running.

• A topology is open in the Topology Editor.

Step 1 Choose File > Export.
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The Export dialog box appears.
Step 2 Expand the Topology folder, choose Export to GraphML File and click Next.

Figure 73: Export a GraphML .graphml File
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Step 3 In the To file field, use Browse to select the target folder.

Figure 74: Choose the To Location

Step 4 Enter a filename for the exported GraphML file, or use the default filename. For example, sample_topology.virl is
converted to sample_topology.graphml and saved in the target directory.

Step 5 Click Finish.
The Cisco Modeling Labs .virl file silently converts to a GraphML .graphml file.

Import the Nodes Configuration Files
You can import the per-node configurations previously exported as individual text files (.cfg suffix) into your
.virl file. You can import the configuration files having made any necessary changes to them.

Before You Begin

• Cisco Modeling Labs client is running.
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• A topology file is open in the Topology Editor.

Step 1 Choose File > Import.
The Import dialog box is displayed.

Figure 75: Import Dialog Box

Step 2 Choose Import Configurations into Existing Topology and click Next.
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The Import Configurations into Existing Topology dialog box is displayed.

Figure 76: Import Configurations into Existing Topology

Step 3 Select the applicable location from the From Directory drop-down list or choose Browse.
Step 4 Click Finish to import the node configuration files.

The node configuration files are imported into the existing topology and a message is displayed to confirm this

Figure 77: Config Import Finished Dialog Box

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
119

Build a Configuration
Import the Nodes Configuration Files



.

Export the Nodes Configuration Files
You can export the per-node configurations from within your .virl file and export them to a directory location
of your choice as individual text files (.cfg suffix). There you canmake necessary changes to the configuration
files before importing the configuration files back into the .virl file.

Before You Begin

• Cisco Modeling Labs client is running.

• A topology file is open in the Topology Editor.

Step 1 Choose File > Export.
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The Export dialog box is displayed.

Figure 78: Export Dialog Box

Step 2 Choose Export Nodes' Configurations to Files and click Next.
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The Export Nodes' Configurations to Files dialog box is displayed.

Figure 79: Export Nodes' Configurations to Files

Step 3 Select a location from the To Directory drop-down list or choose Browse to select the applicable location.
Step 4 Click Finish to export the node configuration files.

The node configuration files are exported to the chosen location.

Create Node and Interface Configurations Using AutoNetkit
Before You Begin

The topology design should be complete.

Step 1 Verify the configuration for each node in the topology.
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a) In the Topology Editor, click a node.
b) In the Properties view, click AutoNetkit. Verify Auto-generate the configuration based on these attributes is

checked or unchecked, depending on whether AutoNetkit will generate a configuration for that node.
Any pre-existing configuration for this node is overwritten when you choose Build Initial Configurations
from the toolbar. Uncheck the Auto-generate the configuration based on these attributes check box if
you do not want the router configuration for this node updated by AutoNetkit.

Note

Step 2 Generate a configuration for the topology. Click Build Initial Configurations from the toolbar. Alternatively, from the
menu bar, choose Configuration > Build Initial Configurations. You are prompted to save any changes made since
the previous configuration update.
If the Auto-generate the configuration based on these attributes check box is checked for a node, the configuration
updates are generated by AutoNetkit.

When using the Build Initial Configurations option, the out-of-band management interface is, by default,
placed into a “Mgmt-intf” VRF. By placing the interface into a VRF, it ensures that there is no route-leaking by
the routing protocols and that CDP will not report the OOB interface.

Note

Step 3 AutoNetkit displays a notification after it generates the configuration. Click No to skip a comparison of configuration
changes. Click Yes to open a comparison view of the configuration changes.

Figure 80: View Configuration Changes? Notification

The .virl file opens and displays previous and current configurations side-by-side, with the changes highlighted. You
can scroll through the contents and see the differences. However, you cannot edit the configurations.

Figure 81: Show Configuration Comparison Side-by-Side

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
123

Build a Configuration
Create Node and Interface Configurations Using AutoNetkit



Click OK to close the comparison view.
Step 4 When you close the comparison view, a notification is displayed, and you can choose whether or not to open AutoNetkit

Visualization.

• Click No to skip the visualization. You return to the Design perspective.

• Click Yes to display the visualization. The AutoNetkit Visualization opens in a browser window. For more
information about this feature, see AutoNetkit Visualization, on page 145.

Figure 82: Open AutoNetkit Visualization? Notification

Selecting the Remember my decision check box will always open AutoNetkit visualization for subsequent
invocations. You can later change this behavior by choosing File > Preferences >Web Services >AutoNetkit.

Note

Generate a Infrastructure-only Configuration Using AutoNetkit
AutoNetkit allows you to generate a stripped-back configuration that provides the basic infrastructure
configuration required to support configuration extraction and Live Visualization.

With this feature enabled, no IP addressing or routing protocol configuration is created. This leaves the node
in a state where it is ready for manual configuration. This is ideal when using a simulation for study practice
or when wanting to go through the process of building an environment by hand.
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The feature is enabled in the CiscoModeling Labs client, by selecting the Infrastructure Only option available
under General at the topology level under the AutoNetkit tab, as shown.

Figure 83: Infrastructure Only Option in AutoNetkit

Static TCP Port Allocation Control
You can specify the TCP port number that you want to use when connecting to the console, auxiliary, or
monitor ports of a particular node running in a simulation. These port numbers are optional and can be set
via the CiscoModeling Labs client. The port number allocation is retained in the settings.ini file and is applied
each time the simulation is started. Functionality is provided so that the TCP port numbers in use are easily
adjusted.
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To set these port numbers, in the Design perspective, select a node and choose the Node configuration tab.
Update the Static Serial Ports' fields as required.

Figure 84: Specify TCP Port Numbers

Assign VLANs
VLANs can be assigned to the interfaces of the end nodes, using the Properties > Interface view.

VLANs are set using theVLAN property under theGeneral tab in theAutoNetkit field on the interface. The
interface is selected in the Node Editor. The properties are set on the interfaces of the nodes connected to the
IOSvL2 image, such as on the IOSv nodes, server node interfaces.
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The following example shows how to set a VLAN property.

Figure 85: Set a VLAN Property

These VLAN values are displayed in the VLAN attribute of the interfaces in AutoNetkit visualization:

Figure 86: VLAN Property Assigned

Use a Managed Switch
The Cisco IOSv Layer 2 switch introduces a managed switch to the Cisco Modeling Labs environment.

By default, all VLANs are placed in vlan2.
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For example, consider the following topology which includes four nodes and one IOSvL2 image:

Figure 87: Using a Managed Switch

After running AutoNetkit, you can see the default VLAN assigned using the vtp view:

Figure 88: VLAN Assignment
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The layer2 view shows the vtp domain originating from the virtual switch for vlan2:

Figure 89: Vtp Domain - layer2.tiff

The relevant configuration for the IOSvL2 image is:
interface GigabitEthernet0/1
description to iosv-1
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet0/2
description to iosv-3
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet0/3
description to iosv-2
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet1/0
description to iosv-4
switchport access vlan 2
switchport mode access
no shutdown
!

Use Multiple Managed Switches
It is permissible to connect multiple managed switches together. Multiple managed switches connected together
form a trunk link between the switches and their appropriate vtp domains.
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In the following example, two managed switches are connected together:

Figure 90: Using Multiple Managed Switches

The vtp view shows the trunk link created between the two managed switches:

Figure 91: Trunk Link Created
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The layer2 view shows the resulting layer2 connectivity, where both of the managed switches have been
aggregated into a single vtp domain for the default vlan2:

Figure 92: Layer2 Connectivity

The relevant configurations for iosvl2-1 and iosvl2-2 on the trunk port are shown below.

iosvl2-1
interface GigabitEthernet0/1
description to iosv-1
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet0/2
description to iosv-3
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet0/3
description to iosv-2
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet1/0
description to iosv-4
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet1/1
description to iosvl2-2
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
!

iosvl2-2
interface GigabitEthernet0/1
description to iosvl2-1
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
!
interface GigabitEthernet0/2
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description to server-1
switchport access vlan 2
switchport mode access
no shutdown
!
interface GigabitEthernet0/3
description to iosv-5
switchport access vlan 2
switchport mode access
no shutdown
!

Use Multiple Unconnected Managed Switches
In cases where there are multiple managed switches, only those that are directly connected, either through a
point-to-point link or via an unmanaged switch are connected.

For example, in this topology, there are two sets of managed switches:

Figure 93: Using Multiple Managed Switches
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After running AutoNetkit, the resulting layer2 view shows two separate layer 2 domains:

Figure 94: Separate Layer2 Domains

Set Firewall Capabilities
For this release of CiscoModeling Labs, the Cisco ASAv image is available to purchase separately. The Cisco
ASAv image adds firewall capabilities to Cisco Modeling Labs.

The default AutoNetkit configuration puts each interface into security-level 0, adds a nameif, and allows http,
SSH, and Telnet access to this nameif.

For example, consider the following topology which includes three IOSv nodes, one server node and one
ASAv node:

Figure 95: Example Topology Showing a Cisco ASAv Node

Cisco Modeling Labs Corporate Edition User Guide, Release 1.2    
133

Build a Configuration
Set Firewall Capabilities



After running AutoNetkit, the firewall view shows the allocated properties on the interfaces:

Figure 96: Allocated Firewall Properties

The configuration for the interface is:
interface GigabitEthernet0/0
description to server-1
nameif outside
security-level 0
no shutdown
ip address 10.0.0.5 255.255.255.252
interface GigabitEthernet0/1
description to iosv-1
nameif outside-1
security-level 0
no shutdown
ip address 10.0.0.9 255.255.255.252
interface GigabitEthernet0/2
description to iosv-2
nameif outside-2
security-level 0
no shutdown
ip address 10.0.0.13 255.255.255.252
interface GigabitEthernet0/3
description to iosv-3
nameif outside-3
security-level 0
no shutdown
ip address 10.0.0.17 255.255.255.252

The access details are:
http 0.0.0.0 0.0.0.0 mgmt
ssh 0.0.0.0 0.0.0.0 mgmt
telnet 0.0.0.0 0.0.0.0 mgmt
http 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 outside
telnet 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 outside-1
ssh 0.0.0.0 0.0.0.0 outside-1
telnet 0.0.0.0 0.0.0.0 outside-1
http 0.0.0.0 0.0.0.0 outside-2
ssh 0.0.0.0 0.0.0.0 outside-2
telnet 0.0.0.0 0.0.0.0 outside-2
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http 0.0.0.0 0.0.0.0 outside-3
ssh 0.0.0.0 0.0.0.0 outside-3
telnet 0.0.0.0 0.0.0.0 outside-3

Set Security Levels
Security levels are set using the Security Level property under the Firewall tab in the AutoNetkit field on
the interface. The interface is selected in the Node Editor. The properties are set on the Cisco ASAv node's
interfaces, as shown.

Figure 97: Set the Security Level
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The security level is displayed in the security_level attribute of the interfaces in AutoNetkit visualization:

Figure 98: Security Level Attribute Set

The configuration for nameif is updated.
interface GigabitEthernet0/0
description to server-1
nameif level-50
security-level 50
no shutdown
ip address 10.0.0.5 255.255.255.252
interface GigabitEthernet0/1
description to iosv-1
nameif outside
security-level 0
no shutdown
ip address 10.0.0.9 255.255.255.252
interface GigabitEthernet0/2
description to iosv-2
nameif outside-1
security-level 0
no shutdown
ip address 10.0.0.13 255.255.255.252
interface GigabitEthernet0/3
description to iosv-3
nameif outside-2
security-level 0
no shutdown
ip address 10.0.0.17 255.255.255.252

The access details are also updated.
http 0.0.0.0 0.0.0.0 level-50
ssh 0.0.0.0 0.0.0.0 level-50
telnet 0.0.0.0 0.0.0.0 level-50
http 0.0.0.0 0.0.0.0 mgmt
ssh 0.0.0.0 0.0.0.0 mgmt
telnet 0.0.0.0 0.0.0.0 mgmt
http 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 outside
telnet 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 outside-1
ssh 0.0.0.0 0.0.0.0 outside-1
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telnet 0.0.0.0 0.0.0.0 outside-1
http 0.0.0.0 0.0.0.0 outside-2
ssh 0.0.0.0 0.0.0.0 outside-2
telnet 0.0.0.0 0.0.0.0 outside-2

AutoNetkit automatically renames the nameif if there are multiple interfaces with the same security level.Note

Configure GRE Tunnels
Generic routing encapsulation (GRE) is a simple IP packet encapsulation protocol that is used to transport
packets over a network. Information is sent from one network to the other through a GRE tunnel.

The GRE tunnel functionality uses the IOSv subtype as the GRE tunnel head and connects from an IOSv
instance out over the FLAT/FLAT1/SNAT connector to some other device which is the far-end of the GRE
Tunnel.

Figure 99: Using GRE Tunnels

In this example, you set the values on node iosv-1 and node iosv-2 to tell AutoNetkit to create the configuration
for a GRE tunnel terminating on the external router node, ext_router_1.
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So on iosv-1, set the tunnel IP address and subnet mask of the far-end device ext-router-1. Similarly, on the
ext-router-1, set the tunnel IP address and subnet mask of the far-end device iosv-1.

Figure 100: Tunnel IP Address and Subnet Mask for ext_router_1

Figure 101: Tunnel IP Address and Subnet Mask for iosv-1
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On iosv-2, set the tunnel IP address and subnet mask of the far-end device ext-router-2. Similarly, on the
ext-router-2, set the tunnel IP address and subnet mask of the far-end device iosv-2.

Figure 102: Tunnel IP Address and Subnet Mask for ext_router_2

Figure 103: Tunnel IP Address and Subnet Mask for iosv-2

When the configurations are built, AutoNetkit selects the appropriate corresponding IP address and applies
it to the interface as follows:
!
interface Tunnel1
ip address 172.16.100.2 255.255.255.252
tunnel source GigabitEthernet0/3
tunnel destination 0.0.0.0

!
The tunnel destination is blank since it needs to be set to the IP address of the far-end device, which you may
or may not know in advance. However, you can edit the configuration in the Cisco Modeling Labs client GUI
before you start up the simulation. So if you do know the target address, you can add the target IP address in
there (tunnel destination x.x.x.x.) Remember that it is not the IP address of the tunnel that goes in here but
the IP address of the router/device terminating the GRE tunnel itself. If this is a devices that is on the FLAT
network directly, then a 172.16.1.x address would go in here.
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To make things simple and repeatable, you can use a static IP address on the interface of the IOSv GRE tunnel
device that connects to the FLAT/FLAT1/SNAT connector.

Figure 104: Static IP Address for flat-1

Figure 105: Static IP Address for flat-2

This provides a target address that the other device can then try to connect to and it is the same IP address
each time the simulation is started.

You cannot do this using the standard guest account. The simulation will fail as you are using a system-level
resource (the Static IP address), so an account with administrative permissions is required.

Note

You must create this account in the User Workspace Management interface.
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In the User Workspace Management interface, under the Projects tab, click Add to create a new project,
as follows:

Figure 106: Create a New Project
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In the corresponding user created for the project, set Role to admin.

Figure 107: Update the Role Field
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In the Cisco Modeling Labs client GUI, choose File > Preferences >Web Services.. In theWeb Services
dialog box, click Change under Master Credentials to login with the newly created user.

Figure 108: Log In as New Role

You can now start your simulation.

Automatic Configuration for OpenDayLight Controllers
Cisco IOSXRv virtual machines, version 5.3.0 and upwards can be automatically configured for communication
and operation with an OpenDayLight (ODL) controller for path manipulation and control using MPLS TE
tunnels. An option in available under the AutoNetkit properties tab in the Cisco Modeling Labs client called
ODL Management Group. Cisco IOS XRv devices set with the ODL management group attribute must be
paired with an external router entity, which is configured with the matching ODL Management Group
attribute and an ODL external server IP address. The ODL server may be running on your Cisco Modeling
Labs server or another location. It does not need to be part of the Cisco Modeling Labs simulation itself.
However, connectivity between the simulation and the server must be provided.
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C H A P T E R  5
Visualizing the Topology

• AutoNetkit Visualization, page 145

• Live Visualization, page 154

AutoNetkit Visualization
The AutoNetkit visualization phase allows you to see how the nodes interact in terms of routing protocol
connectivity, autonomous system (AS) numbers, Open Shortest Path First (OSPF) area, and so on. Before
entering the AutoNetkit visualization phase, you must have designed the topology and generated the node
configurations using parameters defined in AutoNetkit.

AutoNetkit visualization is available before a simulation is launched. A valid CiscoModeling Labs license
is not required to run AutoNetkit visualization. AutoNetkit visualization is only viewable on an external
Web browser; internal Web browsers are not supported.

Note
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The following figure shows an overview of the AutoNetkit Visualization phase as it appears in a browser
window.

Figure 109: Visualization Overview

The following figure shows how the visualization compares to the topology design.

Figure 110: Topology Design
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Access AutoNetkit Visualization
To access AutoNetkit visualization, complete the following steps:

Step 1 Generate a configuration for the topology.
Click Build Initial Configurations from the toolbar. Alternatively, from the menu bar, choose Configuration > Build
Initial Configurations.

Step 2 View the configuration changes.
AutoNetkit displays a notification after it generates the configuration.

Figure 111: View Configuration Change Notification

• Click No to skip this step.

• Click Yes to open a comparison view of the configuration changes.

Step 3 Display the AutoNetkit visualization view of the topology.
When you close the comparison view, a notification prompts you whether to open AutoNetkit visualization.

Figure 112: Open AutoNetkit Visualization

• Click No to skip this step.

• Click Yes to display the visualization.
AutoNetkit visualization opens in a browser window.

Choose File > Preferences >Web Services >AutoNetkit Visualization to control the prompts for visualization.Note
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Figure 113: AutoNetkit Visualization Window
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AutoNetkit View Options
The initial AutoNetkit visualization view that is displayed in the browser window is the physical model of
the topology. The physical model shows the nodes and interface connections between the nodes. It is similar
to the Cisco Modeling Labs topology view.

Figure 114: Initial View
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To select another view, place the cursor over the Physical selection in the browser window.

Figure 115: List of Available Views
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When you place the cursor over the Overlay view, several choices appear. For example, selecting iBGP v4
will show the IPv4 iBGP topology.

Figure 116: iBGP v4 View
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For example, selecting eBGP v4 will show the IPv4 eBGP topology.

Figure 117: eBGP v4 View
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For example, selecting Layer 2 will show the IPv4 Layer 2 topology.

Figure 118: Layer 2 View

Placing the cursor over one of the nodes displays a pop-up view of information about that node. The type of
information displayed depends on the selected option and node configuration.
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You can also hover over the connections to see connection details.Note

Figure 119: Node Information

You can continue to select different protocol views to see how the protocol-centric view changes. In a complex
topology, you can use the Physical views to verify that the protocols, nodes, and connections meet the design
requirements.

Live Visualization
The Live Visualization phase provides a live, real-time visual representation of the running simulation in the
Cisco Modeling Labs client.

In order to use the Live Visualization feature, the topology must use an LXC management node when
launched. Under Properties > Topology, check the Use an LXC Management Node check box when
designing your topology. Then generate the node configurations using parameters defined in AutoNetkit.

Note

For the running simulation, you can see the LXC management node in the Simulations view.
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Live Visualization runs in an separate, external Web browser window. Ensure that you use a compatible
browser, as described in Cisco Modeling Labs Server Requirements, on page 3 for the version of Cisco
Modeling Labs that you are using.

Live Visualization is independent of AutoNetkit. It does not require AutoNetkit to run. However, a valid
CiscoModeling Labs license is required in order to use this feature. Also, ensure that each node has started
up successfully and has applied its configuration before attempting to run a Live Visualization. A running
node is displayed in green on the canvas and is displayed in green with [ACTIVE] in the Simulations
view.

Note

The following figure shows an overview of the Live Visualization phase as it appears in a browser window.

Figure 120: Live Visualization Overview
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The following figure shows how the Live Visualization compares to the topology design.

Figure 121: Topology Design

View the Live Visualization
To access the Live Visualization for a running simulation, complete the following steps:

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.2
156

Visualizing the Topology
View the Live Visualization



The simulation must be configured to use an LXC management node when launched. This is enabled
under Properties > Topology view by checking the Use an LXC Management Node check box. Then
generate the node configurations using AutoNetkit.

Note

Step 1 In the Simulations view, right-click the simulation name.
Step 2 From the drop-down list displayed, click Launch Live Visualization.

Figure 122: Launch Live Visualization Option

A web browser opens.
Step 3 Enter your username and password and click Log In.
Step 4 From the Simulation ID drop-down list displayed, choose the applicable simulation to launch.
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The Live Visualization opens in a web browser as shown.

Figure 123: Live Visualization View

You are only prompted for your user credentials the first time you launch a Live Visualization.Note

Step 5 You can also access the Live Visualization for a running simulation from the User Workspace Management interface.
In the UserWorkspaceManagement interface, login and underMySimulations, choose the applicable running simulation.
The details page for the running simulation is displayed.

Figure 124: Accessing Live Simulations from the User Workspace Management Interface

Step 6 Choose Live Visualization to launch the Live Visualization for the running simulation in a new web browser.
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Live Visualization Overlay Options
The initial Live Visualization overlay that is displayed in the browser window is the physical model of the
topology. The physical model shows the nodes and interface connections between the nodes based on the .virl
file. It is similar to the Cisco Modeling Labs topology view.

Figure 125: Initial Overlay

The Physical drop-down list provides a series of overlays such as the physical live overlay, the OSPF live
overlay, the iBGP live overlay and so on. When you select one of these options, CiscoModeling Labs collects
the live data from the nodes in the topology and draws the protocol map.

Figure 126: List of Physical Overlays

The Actions drop-down list provides a list of actions that are applied for each specific protocol. When an
action is selected from the Actions drop-down list, this results in commands being executed on each active
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virtual machine. The Actions drop-down list also provides other functions such as Shutdown Simulation,
Show Interface Table, Clear Traceroute Paths.

Figure 127: List of Actions Options

Placing the cursor over a node displays a pop-up view of information about that node. The type of information
displayed depends on the selected option and node configuration. You can also hover over the connections
to see connection details.

Figure 128: Node Information
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Selecting a node displays a pop-up menu of available options for the node.

Figure 129: Node Options

Available options are:

• Shutdown Node: Allows you to shutdown a running node, with the results reported in the Log view.

• Telnet to Serial0/Serial1: Allows you to Telnet to a node's serial ports 0 and 1. Opens a console port
to serial or aux ports from within the web browser.

• Collect Node Route Table: Allows you to collect the route table from every node in the simulation,
with the results reported in the Log view.

• Plot Routes to Prefix (alpha): Allows you to select a node and the system will show the next hops
taken by traffic to this node's loopback address. This only work for nodes that are Cisco IOSv instances.

• Ping From/To:Allows you to ping from one node to another node. A five packet ping is triggered from
source to destination, with the results reported in the Log view.

• Trace From/To:Allows you to execute a traceroute between nodes, with the results reported in the Log
view.
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Selecting an interface displays a pop-up menu of available options for the interface.

Figure 130: Interface Options

Available options are:

• Disable/Enable Interface:Allows you to disable an interface, with the results reported in theLog view.

• Setup Packet Capture: Allows you to start a packet capture. Opens the User Workspace Management
interface in a new web browser, where you can set the required capture limits.

• Plot Routes to Prefix (alpha):Allows you to select an interface and the system will show the next hops
taken by traffic to this interface's loopback address.

• Trace From/To:Allows you to execute a traceroute between interfaces, with the results reported in the
Log view.

• Ping From/To: Allows you to ping from one interface to another interface, with the results reported in
the Log view.

Physical Connections

To view the live physical data, place the cursor over the Physical list and select Physical Live from the
drop-down list.
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The collect interfaces action is run automatically when a Live Visualization session is first loaded.Note

Figure 131: Physical Live Overlay

Hovering over an interface displays the information collected about the interface. The command Actions >
Collect Interfaces is used to collect IP addressing information from the interfaces in order to perform reverse
mappings, such as, IGP, BGP, and traceroute data processing. If the IPs are changed, you need to re-run this
command. You can view the command applied in the Log view.

Figure 132: Physical Live Log Output

OSPF

To view the live OSPF data, do either of the following:

• Choose Physical > OSPF Live from the drop-down list; or
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• Choose Actions > Collect OSPF. For both options, the Collect OSPF action runs the relevant show
OSPF command on the nodes and then triggers the processor to parse and build the connectivity. The
results are shown as adjacencies on the topology.

Figure 133: OSPF Live Overlay

You can view the show command applied in the Log view.

Figure 134: OSPF Live Log Output

iBGP

To view the live iBGP data, do either of the following:

• Choose Physical > iBGP Live from the drop-down list; or
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• Choose Actions > Collect BGP. For both options, the Collect BGP action runs the relevant show BGP
command on the nodes and then triggers the processor to parse and build the connectivity. The results
are shown as adjacencies on the topology.

Figure 135: iBGP Live Overlay

You can view the show command applied in the Log view.

Figure 136: iBGP Live Log Output

SYSLOG

You can configure all nodes to send syslog messages to a syslog process. From the Actions drop-down list,
click Setup Syslog. This sets up the virtual machines to send syslog messages to the LXC management node.
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Figure 137: Setup Syslog Option

These messages are forwarded through a web socket to the front-end and can be seen under the Syslog option.

Figure 138: Syslog Process

Live Visualization Traceroute
The traceroute functionality allows you to view the different routes used between the nodes in your topology.
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In the Live Visualization, for the source node or source interface, left-click on the applicable node to access
the drop-down menu and choose Trace From.

Figure 139: Node Menu

Figure 140: Interface Menu

Next choose a destination node (for the loopback), or destination interface and from the drop-down menu,
choose Trace To.
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This is then matched to the appropriate IP address, using the interfaces IP addresses collected using the
interfaces command. This, together with the node identifier, is then sent to the Live Visualization back-end
for formatting and running of the command.

Figure 141: Traceroute Path Displayed

When a traceroute is executed, hovering the mouse over the path displays information on the path taken.

Figure 142: Information on the Path Taken
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Details on the command executed for the traceroute are available in the Log view.

Figure 143: Traceroute Log

When an interface is disabled in the Live Visualization, the disabled interface name is shown in red. For a
disabled node, all its interface names are shown in red. An interface that has link parameters set is displayed
as a dashed line.

In the following example, the interface ge0/3 has been disabled so the path is rerouted. The interfaces ge0/1
and ge0/2 for node iosv-1 indicate that the node is disabled.

The interfaces ge0/4 and ge0/3 connecting nodes iosv-2 and iosxrv-2 indicate that link parameters have been
set for this link.

Re-running the previous traceroute now shows a different path.

Figure 144: Updated Image Showing Rerouted Path
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Additionally, the disabled interface is displayed in the Cisco Modeling Labs client with red text and a red dot
on a broken line. The link parameters link is shown with a Tools icon. The disabled node is shown in grey
with it interfaces displayed as dashed lines, as shown in the following image.

Figure 145: Updated Details in the Cisco Modeling Labs Client
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C H A P T E R  6
Simulate the Topology

• Simulate the Topology Overview, page 171

• Cisco Modeling Labs Active Canvas, page 172

• Launch a Simulation, page 175

• Connect to a Simulation Node Console, page 192

• Start a Single Node, page 198

• Stop a Simulation, page 203

• Stop a Single Node, page 208

• Modify a Node Configuration in the Simulation, page 210

• Extract and Save Modified Configurations, page 216

• Linux Server Snapshot Support, page 219

• Latency, Jitter and Packet Loss Control Options, page 222

Simulate the Topology Overview
The simulation phase is when you run the simulation of your topology design. The Simulation perspective
provides a set of views that support the simulation phase. By comparison, the design and build activities occur
in the Design perspective, which provides a set of views that support the design activity. Some views in the
Simulation perspective can also be viewed in the Design perspective.

Simulation Perspectives and Views

The main areas of focus within the Simulation perspective are the Simulations view and the Console view.
The following figure highlights the Simulations and Console views for a running simulation.

From theViewmenu, you can open additional views in the perspective and arrange the open views by dragging
them within the perspective workspace. See the online help and the section Customize Perspectives, on page
22 for more information.
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To reset your current perspective to its original configuration when the workbench was first opened,
right-click the perspective button and select Reset.

Note

Node Limits

In Cisco Modeling Labs, the number of nodes you can run is limited by the resources available on the server
and the number of licenses available. Currently, the design limit is 1,000 nodes.

Cisco Modeling Labs Active Canvas
The Cisco Modeling Labs client provides users with an active canvas. When a simulation is started and the
user switches to the Simulation perspective, a new window opens displaying the network diagram. As the
virtual machines start up, the network diagram updates showing the current state of the simulation. Nodes
change color depending on their current operational state.

For example, the following figure shows nodes in green which indicates the Active state. Nodes in blue
indicate the Build state. Grey nodes indicate the Absent state where a node is yet to be started or has been
stopped.

Figure 146: Node States in a Simulation
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Once a node is in the active state, you can right-click on the node to perform operations such as opening an
SSH or Telnet connection, extract the configuration of the specific node and stop/start the node.

Figure 147: Node Operations

Right-clicking on the background, without selecting a node, enables you to perform simulation-wide operations
such as configuration extraction, launch the live visualization view, stop the simulation as well as resetting
all link latency, jitter and packet-loss parameters that may be in operation.

Figure 148: Simulations Operations
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If the Simulations view is closed, it can be reopened by selecting the simulation from the simulations panel,
right-clicking and selecting the View Simulation option.

Figure 149: View Simulation Option

Link latency, jitter and packet-loss parameters can be set by selecting a link, right-clicking and using the
Modify Link Parameters option.

Figure 150: Link Parameters
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Packet capture operations can be performed by selecting a link, selecting the interface (at one end of the link)
and right-clicking to reveal the packet-capture control menu, as shown.

Figure 151: Packet Capture Operations

Once a packet capture has been configured, an icon will indicate that a packet-capture is present on the
interface, with the Packet capture view listing the .pcap file that is available for analysis.

Additional diagram labels are now available including interface name, serial port number assignment and so
on. These can be accessed from the Show Topology Labels icon on the Cisco Modeling Labs toolbar.

Figure 152: Show Topology Label Options

Launch a Simulation
To launch a simulation, complete the following steps.

Before You Begin

• Complete the topology design.
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• Complete the task of building the nodes and interfaces.

• (Optional) Generate the configuration using AutoNetkit.

When you manually make changes to a node configuration and bypass AutoNetkit
autogeneration, those changes do not appear in the topology view of the Design
perspective or Simulation perspective. For example, if you use the hostname command
to change the host name from iosv-1 to Router-1 in the configuration, the node name
in the topology view and in other related views remains as iosv-1.

Caution

• Open the desired topology.

The topology should be open and visible in the Topology Editor. If you have multiple
topologies open in the Topology Editor, simulation will launch for the currently active
view.

Note

Step 1 From the toolbar, click the Launch Simulation button.
The simulation launches and provides a unique identifier, which means that multiple instances of the topology can be
launched and each will have a unique name.

Step 2 In the Launching Simulation dialog box, select any of the following actions:

a) Check the Always run in the background check box. All future node start requests, stop requests, and simulation
launch requests run in the background and do not display dialog boxes.

To control the background setting, chooseFile >Preferences >General.Note

b) Click Run in Background. The dialog box closes when the node simulation starts.
c) Click Cancel to return to the Design view.
d) Take no action, and the node simulation launches momentarily.

When you click Run in Background, the status bar displays a progress icon. Click the icon to display a
compact view of the activity progress. If the background activity encounters an error, the icon shows a red
X. Click the error icon to display the error dialog.

Tip

Step 3 In the Simulation launched dialog box, click OK.
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Step 4 When prompted to switch to the Simulation perspective, click Yes.

We recommend that you switch to the Simulation perspective to view the running simulation and to connect
to node consoles.

Note

The Cisco Modeling Labs client tracks the state of the simulations. All launched simulations appear in the Simulations
view. Status messages are displayed in theConsole view. After the CiscoModeling Labs server has started the simulation
launch, a confirmation dialog box appears with an identifier assigned to the simulation by the Cisco Modeling Labs
server.
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When the nodes are running on the Cisco Modeling Labs server, they are displayed in the Simulations view with the
status [ACTIVE], as shown in the following figure.

Figure 153: Simulation Launched in Simulations View

Jumphost Virtual Machine (VM)
The jumphost VM is the default method for accessing the management network of a running simulation. The
jumphost node runs in a separate simulation named ~jumphost and has two interfaces, eth0 in the project/user
management network and eth1 in the FLAT network.

The purpose of the jumphost is to provide an access point into a simulated network that remains fixed, in that
there is a single external IP address or port that the user can access. A user can access the jumphost and then
access all the nodes inside the simulation.
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Cisco Modeling Labs provides two implementations of jumphost:

• A VM: Based on the server VM image type.

• A Linux container: A lighter weight form of a jumphost. See Linux Container (LXC), on page 179 for
more information.

The VM implementation is costly in terms of the memory and CPU used when a jumphost is instantiated.
However, since it is a full-blown server VM, there is value to it, in that you can install and run any application
on it.

To select a jumphost VM, in the Cisco Modeling Labs client, choose Properties > Topology >Management
Network > Private project network or Shared flat network.

Figure 154: Setting the Jumphost Option

The jumphost VM is per user; a user can create multiple simulations, but only one corresponding jumphost
is created. Therefore, depending on the type of simulation you are running, you can choose between the two
implementations.

Linux Container (LXC)
An LXC provides a means of accessing a topology rather than having to create a full Linux server VM. All
nodes in the network are connected to a hidden OOB management network that uses the first interface on
each of the nodes.

In the CiscoModeling Labs client, it is enabled by selecting the management network type Private simulation
network for your topology. The LXC is automatically connected into this hidden OOBmanagement network
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to which all VMs in your simulation are connected. This enables you to connect into each VM via its
management Ethernet port, removing the need to use the console port connection method.

Figure 155: Setting the LXC Option

The LXC is operational when your simulation is active and terminates when your simulation stops. LXC uses
a significantly smaller memory footprint than the Linux server VM. The LXC automatically gets an IP address
on the FLAT network.

Figure 156: LXC on the FLAT Network
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LXC facilitates SSH access to the VMs; it provides direct SSH access to each VM running inside the simulation.
Telnet is not supported. As shown below, LXC is accessed by right-clicking the ~mgmt_lxc [ACTIVE] node
and selecting SSH from the list.

Figure 157: Accessing LXC

The LXC is automatically spun up and provides a jumphost point for access into the network. Connecting to
the LXCmeans you can see the interfaces to the outside world and to the OOB network inside your simulation.

A connection is opened from the Cisco Modeling Labs client to a port on the Cisco Modeling Labs server
and is forwarded to the LXC. The LXC, in turn, opens a connection to the Management Interface (Gi0/0) of
the VM inside the simulation to the node instance.

Static Port Assignment to the LXC
When the management network property Private simulation network is set, Cisco Modeling Labs assigns
a random port for SSH port access to the LXC. However, you can statically define this by setting an extension
on your topology.

To set an extension for your topology, complete the following steps.

Step 1 Click on the canvas to open the Topology tab in the Properties view.
Step 2 Click the Extensions tab.
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Step 3 Click the Add new extension icon.
The Edit Extension dialog box appears.

Step 4 Enter the following values:

• Key: lxc.host.tcp_port

• Value: 30799

• Type: String (from the drop-down list)

Figure 158: Add a New Extension

Step 5 Click OK to add the new extension.
When the LXC starts, it will be bound to the TCP port specified in the new extension.

LXC iPerf Container
The LXC iPerf container provides a stripped down lightweight Linux container which has been loaded with
the iPerf application available from Downloads - iPerf.
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iPerf is a tool for the active measurement of the maximum achievable bandwidth on IP networks. It supports
tuning of various parameters related to timing, buffers and protocols (TCP, UDP, SCTP with IPv4 and IPv6).
For each test it reports the bandwidth, loss, and other parameters.

Figure 159: LXC iPerf Container

LXC Ostinato Container
An LXC container is available that contains the Ostinato packet traffic generator application. This application
provides data-plane traffic generation capabilities. The Ostinato drone (generator) is used in combination
with the Ostinato GUI. The GUI can be obtained from Downloads – Ostinato.
When deployed, the LXC Ostinato container can be accessed using the SSH connection method.

Telnet does not work.Note

The Ostinato drone application executes automatically when the LXC becomes active.
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The Ostinato drone application should not be installed on the host system as the version in the repositories
cannot be executed in the LXC.

Note

Figure 160: LXC Ostinato Container

Launch a Phased Simulation
On occasions, you may need to start your simulation in phases rather than having all nodes launched at the
same time. This functionality is facilitated by the Exclude node from simulation launch check box, which
allows you to pick and choose which nodes to start.

To launch a phased simulation, complete the following steps.

Step 1 With the applicable topology open, click on the canvas and move the selection area over the nodes to be excluded from
the running simulation. (Alternatively, you can double-click a specific node, hold down the Shift key, and select the
remaining nodes.)
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The Properties > Node view opens.
Step 2 In the Properties > Node view, check the Exclude node from simulation launch check box.

Figure 161: Nodes Excluded from Simulation Start

Step 3 Save your topology using Ctrl-S.
You can set this property for each individual node, if you prefer. Select the node on the canvas, and select the
Exclude node from simulation launch check box in the Properties > Node view.

Note

Step 4 From the toolbar, click the Build Initial Configurations button to build the node configurations.
Step 5 From the toolbar, click the Launch Simulation button.

The simulation launches.
When the nodes are running on the Cisco Modeling Labs server, they are displayed in the Simulations view with the
status as [ACTIVE].
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In the Console view, you can see the message Node '<node name>' is excluded from automatic start for the
excluded nodes, and in the Simulations view, you can see that the excluded nodes have the state [ABSENT].

Note

Figure 162: Phased Simulation Launched
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Launch Simulation Options
In circumstances where you need to run a simulation for a specified time frame or you want to specify your
own name for a simulation, complete the following steps:

Step 1 From the menu bar, choose the Simulation button.
Step 2 From the list, click Launch Simulation with Options.

Figure 163: Launch Simulation with Options

The Launch Simulation dialog box is displayed.

Figure 164: Launch Simulation

Step 3 If you want to specify your own name or label for the simulation, check the User Specified radio button. Otherwise,
leave the default System generated ( based on a file) radio button checked.

Alternatively, you can specify a simulation name via the User Workspace Management interface; selectMy
Simulations > Launch New Simulation and enter the name in the Simulation Name field.

Note

Step 4 Set a time duration for the simulation by entering details forDays,Hours, andMinutes by using either the up and down
arrows or entering the values directly. Click OK to apply your time limit to the simulation.
The simulation launches.
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An expiration warning is displayed ten minutes (or less) before your simulation is due to expire.

Figure 165: Simulation Expiration Warning

We recommend that you extract configurations for your simulation before it expires.

Note

You can reset the time limit for a running simulation in theUserWorkspaceManagement interface. See Reset
the Time Limit on a Running Simulation, on page 188 for more information.

Note

Reset the Time Limit on a Running Simulation
You can extend or reduce the time limit set for a running simulation in the User Workspace Management
interface. To do this, complete the following steps.

Step 1 Log in to the User Workspace Management interface.
On the Overview page, information on running simulations is displayed. Move to the applicable simulation under the
Session heading. If your simulation is due to expire in ten minutes or less, the simulation name is displayed in red.

Step 2 Under the Options column, click the down arrow and click Set expiration.

Figure 166: Soon to Expire Simulation
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Step 3 The Set expiration for session page is displayed. In the date and time field, enter either a new expiration date and time,
a date only, or a time only for the simulation.

Figure 167: Set Expiration for Session Page

Step 4 Click Set expiration to save the changes.
The time limit for the simulation is updated.

Control Interface States
In a running simulation, you are able to change the state of the network interface by bringing it up or down.

This changes the state of the underlying communication infrastructure, not the interface state of the virtual
machine.

Note

To control the state of an interface, complete the following steps.

Step 1 Log in to the User Workspace Management interface.
You must log in as a user other than the uwmadmin user, for example,
guest.

Note

Step 2 On the Overview page, under Sessions, choose the applicable running session.
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A list of active virtual machines and interfaces is displayed.
Step 3 Scroll down to the Interfaces section and choose the applicable virtual machine.
Step 4 From the applicable Options drop-down list, click Update admin state.

Figure 168: Interface State Control Option

Depending on the current state of the interface, either a Bring Down or Bring Up page is displayed. In this case, the
Bring Down page is displayed.

Figure 169: Bring Down the Applicable Interface

Step 5 Click Bring down to bring down the network interface.
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A message is displayed indicating that the interface has been brought down.

Figure 170: Interface Successfully Brought Down

Step 6 To bring up the interface at a later stage, click Update admin state again.
The Bring up page displayed.

Figure 171: Bring Up the Applicable Interface

Step 7 Click Bring up to bring up the network interface.
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A message is displayed indicating that the interface has been brought up.

Figure 172: Interface Successfully Brought Up

Connect to a Simulation Node Console
Cisco Modeling Labs provides the capability for you to connect to your nodes via SSH and Telnet. You can
start an SSH session, which connects into the node via the LXC, as described in Linux Container (LXC), on
page 179.

This access method makes use of SSH to the LXC and then Telnet from the LXC to the nodes running inside
the simulation. This does not use the console port of the nodes and is more reliable and faster to use.

Connect to a Simulation Node Console via SSH
To connect to a simulation node console, complete the following steps.

Before You Begin

• Launch a simulation.

• Ensure that the Simulation perspective is active.

• Ensure that the Simulations view and Console view are displayed.

Step 1 To connect to a console for a specific node, right-click the node in the Simulations view and choose SSH > to its
Management (via LXC) port.
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Figure 173: Connecting to a Node Console via SSH
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A new Terminal view opens.

Figure 174: Terminal View

Step 2 To disconnect a terminal from the simulation, click Disconnect in the Terminal view toolbar or click the Close icon in
the Terminal view.

When you disconnect or close aTerminal view, all text in the view is discarded.Note

When you disconnect a terminal but do not close the Terminal window, you can press Enter to reconnect the
terminal.

Tip

Connect to Multiple Simulation Node Consoles
To connect to all consoles for all nodes in a running simulation, complete the following steps.

Step 1 Right-click the simulation in the Simulations view and choose Telnet > to all <number> available Console ports.

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.2
194

Simulate the Topology
Connect to a Simulation Node Console via SSH



Figure 175: Connect to Multiple Node Consoles
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A new Terminal view opens for all console ports.

Figure 176: Terminal View

Step 2 To disconnect a terminal from the simulation, click Disconnect in the Terminal view toolbar or click the Close icon in
the Terminal view.

When you disconnect or close aTerminal view, all text in the view is discarded.Note

When you disconnect a terminal but do not close the Terminal window, you can press Enter to reconnect the
terminal.

Tip

Terminal Multiplexer Functionality
A terminal multiplexer is available for use with the Cisco Modeling Labs client. It permits a number of
terminals to be accessed and controlled from a single terminal. Terminals can be detached to run in the
background and then reattached later.

The terminal multiplexer is available fromWindow > Show View > Other > General > Terminal
Multiplexer.

When the terminal multiplexer starts up, a status line at the bottom of the terminal displays information on
the current session and is used to enter interactive commands. It lists all of the active console sessions. You
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can select console sessions individually or all together from the View Menu drop-down list. Keyboard
commands entered in the command-line text box are broadcast to the selected sessions.

Figure 177: Terminal Multiplexer
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The terminal multiplexer also provides a command-line history, which you can access using Ctrl-Space.

Figure 178: Accessing the Command-Line History

Start a Single Node
To start a single node, complete the following steps.

Step 1 Right-click a stopped node.
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When a node is stopped, its status is shown as [ABSENT].
Step 2 Click Start this node.

Figure 179: Start a Single Node

The Requesting start dialog box appears.

Figure 180: Requesting Start Dialog Box

Step 3 Choose one or more of the following actions:
a) Check the Always run in the background check box. All future node start requests, stop requests, and simulation

launch requests run in the background and do not display dialog boxes.
To control the background setting, chooseFile >Preferences >General.Note

b) Click Run in Background.
The dialog box closes while the node simulation stops.
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c) Click Cancel to return to the Simulations view.
d) Take no action and the node simulation restarts momentarily.

When you clickRun in Background, the status bar displays a progress icon. Click the icon to display a compact
view of the progress. If an error is encountered, the icon displays a red X. Click the error icon to display the error
dialog box.

Tip

Start a Node in a Running Simulation
In cases where a phased simulation is running, you can later start those nodes not started with the initial
simulation. To start a node in a running simulation, complete the following steps.

Step 1 In the Simulations view, right-click the node.
A node not yet started has the status
[ABSENT].

Note

Step 2 Click Start this node.

Figure 181: Start This Node Option

The Requesting start dialog box appears.
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Figure 182: Requesting Start Dialog Box

The status of the selected node is changed from [ABSENT] to [ACTIVE], indicating that the node is up and
running.

Note
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Start Multiple Nodes in a Running Simulation
In cases where a phased simulation is running, you can later start those nodes not started with the initial
simulation. To start multiple nodes, complete the following steps.

Step 1 In the Simulations view, click the first node in the list to be started.
Step 2 Hold down the Shift key and select the remaining nodes.
Step 3 Right-click the selected nodes.
Step 4 Click Start nodes.

Figure 183: Start Nodes Option

The Requesting start dialog box appears.

Figure 184: Requesting Start Dialog Box
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The status of the selected nodes changes from [ABSENT] to [ACTIVE], indicating that the nodes are up and
running.

Note

Figure 185: Multiple Nodes Started

Stop a Simulation
There are several ways to stop a simulation. In addition, you can stop multiple simulations at the same time.
These are discussed in the following sections.

Stop a Simulation from the Toolbar
To stop a simulation from the toolbar, complete the following steps.

Step 1 In the toolbar, click the Stop Simulations button.
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A Stop Simulation(s) dialog box appears.

Figure 186: Stop Simulation(s) Dialog Box

Step 2 In the Simulation column, click once to highlight the simulation to stop.
Step 3 (Optional) To save the configurations, click the adjacent setting in theExtract Configurations? column until the prompt

changes to Yes.
Configurations for server nodes are not
extracted.

Note

Step 4 (Optional) To close the internal terminals associated with the simulation, click the adjacent setting in theClose Terminals?
column until the prompt changes to Yes.

External terminal connections are not stopped as part of this operation and must be closed manually.Note

Step 5 To stop the simulation, click the adjacent setting in the Stop Simulation? column until the prompt changes to Yes.
Step 6 Click OK to stop the simulation, or click Cancel to leave the simulation running.

On OSX, you update the values forExtract Configurations?, Stop Simulation?, andClose Terminals? in the columns
directly. You do not need to select the name of the simulation.
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Stop a Simulation from the Simulations View
To stop a simulation, complete the following steps.

Step 1 In the Simulations view, right-click the simulation name and select Stop Simulation.

Figure 187: Stop a Simulation
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The Stop Simulation Confirmation dialog box appears.

Figure 188: Stop Simulation Confirmation Dialog Box

• (Optional) Check the Extract Configurations before Stopping the Simulation check box to save the current
configurations.

• (Optional) Check theClose Associated Terminal Views check box to close all the open internal terminals associated
with the specific simulation. External terminals are not closed.

Step 2 Click OK to stop the simulation.
Once selected, all nodes in the simulation start shutting down. It may take a few minutes for the simulation to shut down
completely and to disappear from the Simulations view.

For instances where a user account expires, all running simulations for that user continue to run. Since the user
account can no longer log in to stop them, they will remain active until the next system reboot or until the system
administrator explicitly stops them.

Note
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Stop Multiple Simulations from the Simulations View
To stop multiple simulations, complete the following steps.

Step 1 In the Simulations view, click the first simulation in the list to stop.
Step 2 Hold down the Shift key and select the remaining simulations.
Step 3 Right-click the selected simulations and select Stop Simulations.

Figure 189: Stop Multiple Simulations

The Stop Simulations Confirmation dialog box appears.

Figure 190: Stop Simulations Confirmation Dialog Box

• (Optional) Check the Extract Configurations before Stopping the Simulation check box to save the current
configurations.

• (Optional) Check theClose Associated Terminal Views check box to close all the open internal terminals associated
with the specific simulation. External terminals are not closed.
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Step 4 Click OK to stop the simulations.
Once selected, all nodes in the simulations start shutting down. It may take a few minutes for the simulations to shut
down completely and to disappear from the Simulations view.

For instances where a user account expires, all running simulations for that user continue to run. Since the user
account can no longer log in to stop them, they will remain active until the next system reboot or until the system
administrator explicitly stops them.

Note

Stop a Single Node
To stop a single node in a simulation, complete the following steps.

Step 1 In the Simulations view, right-click the node to stop and select Stop this Node.

Figure 191: Stop a Single Node

The Are you sure? dialog box appears.

Step 2 Click OK to stop the node. Alternatively, click Cancel to abandon the operation and return to the simulation.
When you clickOK, the node stops without saving any changes to the configuration.Note

When a node is stopped, its status changes to [ABSENT].
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Stop Multiple Nodes
To stop multiple nodes in a running simulation, complete the following steps.

Step 1 In the Simulations view, click the first node in the list to stop.
Step 2 Hold down the Shift key and select the remaining nodes.
Step 3 Right-click the selected nodes.
Step 4 Click Stop Nodes.

Figure 192: Stop Multiple Nodes

The Are you sure? dialog box appears.

Step 5 Click OK to stop the nodes. Alternatively, click Cancel to abandon the operation and return to the simulation.
When you clickOK, the nodes stop without saving any changes to the configuration.Note
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When the nodes are stopped, their status changes to [ABSENT].

Figure 193: Multiple Nodes Stopped

Modify a Node Configuration in the Simulation
You can modify node configurations in a running simulation. To do this, the type of connection available,
either SSH or Telnet depends on the option set for the topology propertyManagement Network.

•WhenManagement Network is set to Private simulation network, SSH and Telnet are available.

•WhenManagement Network is set to Shared flat network, Private project network, or not specified,
only Telnet is available.

Modify a Node Configuration in the Simulation via SSH
To modify a node configuration in a running simulation via SSH, complete the following steps.

Step 1 Right-click the node in the Simulations view and choose SSH > to its Management (via LXC) port.
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Figure 194: Connecting to a Node Console
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A new Terminal view opens.

Figure 195: Terminal View

Step 2 If no banner or router prompt is visible, press Enter.
You are now working with the operating system running on the node, for example, Cisco IOSv virtual software.

Step 3 Use the operating system commands to view or modify the node configuration.
Changes you make to the configuration do not appear in the canvas of theTopology Editor.Note

Modify a Node Configuration in the Simulation via Telnet
To modify a node configuration in a running simulation via Telnet, complete the following steps.

Step 1 Right-click the node in the Simulations view and choose Telnet > to its Console port.
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Figure 196: Connecting to a Node Console
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A new Terminal view opens.

Figure 197: Terminal View

Step 2 If no banner or router prompt is visible, press Enter.
You are now working with the operating system running on the node, for example, Cisco IOSv virtual software.

Step 3 Use the operating system commands to view or modify the node configuration.
Changes you make to the configuration do not appear in the canvas of theTopology Editor.Note

Modify Multiple Node Configurations in the Simulation
To modify multiple node configurations in a running simulation, complete the following steps.

Step 1 Right-click the topology in the Simulations view and choose Telnet > to all <number> available Console ports.
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Figure 198: Connect to Multiple Node Consoles
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A new Terminal view opens for each of the consoles.

Figure 199: Terminal Views

Step 2 If no banner or router prompt is visible, press Enter.
You are now working with the operating system running on the node, for example, Cisco IOSv virtual software.

Step 3 Use the operating system commands to view or modify the node configuration.
Changes you make to the configuration do not appear in the canvas of theTopology Editor.Note

Extract and Save Modified Configurations
To extract and save modified configurations, complete the following steps.

Before You Begin

• You have modified a configuration within one or more nodes running within the simulation and want
to save the changes.
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• Ensure that all routers in the simulation are operational before attempting to extract their configurations.

Step 1 In the Simulations view, right-click the topology name, making sure not to click the node name, and select Extract
Configurations.

Figure 200: Simulations View Context Menu

A confirmation dialog box appears.
Step 2 Ensure that all external Telnet connections to the simulation are closed before proceeding.
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Youmust close all external Telnet connections to the simulation before you can proceed.Note

Figure 201: Extract Configurations Dialog Box

Step 3 Click OK.
The Extracting Configurations dialog box appears indication that the extraction is in process.

When the extraction is complete, a message is displayed.

Figure 202: Extraction Complete Message

The configuration information is extracted and saved in the filename.virl file that corresponds to the topology.
For example, the file New_Topology that is running as a New_Topology-dkIFaW simulation has its configuration
extracted to the file New_Topology.virl.

Note

Step 4 Click OK.

Partial Configuration Extraction
During a configuration extraction, if the process encounters issues or fails for a particular node, the problem
node is identified and reported.

The extraction process then continues for all other nodes in the simulation and returns collected configurations
to you.
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Linux Server Snapshot Support
When a Linux server is present in a running simulation, you can use the User Workspace Management
interface to take a snapshot of the disk content of the server. This newly created user-specific disk image can
be used in other simulated sessions.

To take a snapshot of the server's disk contents, complete the following steps.

Step 1 Log in to the User Workspace Management interface.
You must log in as a user other than the uwmadmin user, for example,
guest.

Note

Step 2 On the Overview page, under Sessions, select the applicable running simulation.

Figure 203: Running Simulation Listed

A list of active VMs is displayed.

Figure 204: Active VMs
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Step 3 Select the applicable Linux server, and from the Options drop-down menu, click Create snapshot.

Figure 205: Create Snapshot Option

Project details for the newly created snapshot are displayed.

Figure 206: Newly Created Disk Image
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Reuse the Image Snapshot
To reuse the image snapshot, complete the following steps.

Step 1 Create a new topology or open an existing topology.
Step 2 On the canvas, add a node to the topology.
Step 3 Select the node on the canvas.

The sample topology opens in the Topology Editor canvas.
Step 4 In the Properties > Node view, click Browse beside the VM Image field.

The Select VM Image dialog box appears.
Step 5 Select the applicable image snapshot and click OK.

Figure 207: Select the Image Snapshot to Use
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Details for the image snapshot are visible in the VM Image field under Properties > Node view.

Figure 208: Image Snapshot Selected

Latency, Jitter and Packet Loss Control Options
The availability of link-level parameters allows users to investigate and understand the impact on services of
transmission characteristics encountered in the physical world. With a running simulation, you are able to
select links between the nodes in the simulation and set latency, jitter and packet-loss values on those links.
This enables you to create links that have properties seen in the physical world such as transatlantic or
transcontinental latencies or packet-loss.

The link parameters can be applied on any link, except for those connected to a FLAT or SNAT external
connector. The values set by the user are applied bi-directionally, meaning that setting a latency value of
100ms results in 100ms from node A to node B and 100ms from node B to node A for the return path. That
is 200ms in total. The same is true for packet-loss. Ten packets sent from node A on a link with 10% packet-loss
results in 9 packets being received on node B. The packet loss will also be applied on the return path meaning
that another packet may be lost between node B and node A.

You can set these link-level parameters in one of three ways:
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• In the Cisco Modeling Labs Client.

Figure 209: Setting Link Parameters in the Cisco Modeling Labs Client
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• In the User Workspace Management interface.

Figure 210: Setting Link Parameters in the User Workspace Management Interface
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• In the Live Visualization view of the running simulation.

Figure 211: Setting Link Parameters in the Live Visualization View
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C H A P T E R  7
External Connectivity in Cisco Modeling Labs

• Basic Node Access, page 227

• External Connectivity to a Node, page 230

• Node Access via an External Terminal Client, page 231

• Out-of-Band Management Sessions via the Flat Interface, page 231

• In-Band Management Sessions via a Flat Interface, page 241

• Interconnect Topologies in Physical Labs via a Flat Interface, page 244

• Interconnect External Devices via a SNAT Interface, page 250

• Use Case Scenarios, page 257

Basic Node Access
For simple network topology simulations, access to simulated nodes can be conducted through the Cisco
Modeling Labs server’s management interface , Ethernet0. This is useful for simulation scenarios that do not
require connection to external devices, and leverages the CiscoModeling Labs server's management interface
for communications with the virtual devices. No Flat or SNAT interfaces are configured or referenced, and
no option is specified within the project’s Properties > Topology >Management Network setting. In this
minimal configuration, connections to the virtual nodes instances are facilitated through the Cisco Modeling
Labs’s client Server management option.
Telnet via Cisco Modeling Labs Client Console

The Cisco Modeling Labs client provides an integral access method to running node simulations. In the
Simulation perspective, highlight an ACTIVE node within the Simulations view and performing a right-click
operation expands a session start menu. Positioning the cursor over Telnet triggers a popup menu from which
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the Console, Monitor, or Management ports may be selected. Alternatively, highlighting a node on the canvas
and performing a right-click will present the same set of options, as shown.

Figure 212: Start a Telnet Session

Within the Cisco Modeling Labs client’s console, a Telnet session through this node’s console port is started.
SSH via Cisco Modeling Labs Client Console

Using the same scenario as for Telnet, an SSH session may be used. In the pop-up menu, a SSH session may
be selected. Positioning the cursor over SSH triggers a popup menu from which the Management port may
be selected. Alternatively, highlighting a node on the canvas and performing a right-click will present the
same set of options, as shown.

Figure 213: Start a SSH Session

A secure shell session is then launched to an internal jumphost (a lightweight Linux-based virtual machine
running within the simulation) from which a Telnet session is started to the highlighted node’s Management
interface. The IP_Addr:Port_ID combination is the same for each of the nodes within the running simulation,
and represents the JumpHost as an intermediate session proxy. The Cisco Modeling Labs client will initiate
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the connection via the Cisco Modeling Labs management interface (Eth0) to the intermediate jumphost, and
then facilitate the subsequent Telnet connection to the targeted node in a single operation.

Figure 214: SSH Session via JumpHost

Access via User Workspace Management Interface

Another option is to access the nodes in a running simulation through the User Workspace Management
interface via a web browser. After entering log in credentials, click theMy Simulations option to view a list
of running simulations. Select the applicable simulation to view a list of nodes comprising the running
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simulation. To access a node, click one of the ports icons, representing Serial-0, Serial-1, or the Management
port, associated with the desired node. As shown, a corresponding session is started for the selected node.

Figure 215: Using the User Workspace Management Interface for Node Access

External Connectivity to a Node
Depending on how the Cisco Modeling Labs environment has been set up by the system administrator, you
may have several ways to externally connect to the nodes in a running simulation.

1 Bypass the Cisco Modeling Labs client and connect directly to nodes via Out of Band Management IP
access using FLAT

If enabled by the system administrator, when designing your virtual network, you can specify that you
want all nodes to be configured on a reserved management network. All management interfaces are
connected to a shared management network segment known as FLAT. This set up will allow you to bypass
the Cisco Modeling Labs client and connect directly via Telnet to the nodes.

2 Connecting to external devices using FLAT Inband access

When enabled, you can configure your virtual topologies to connect and pass data-plane and control-plane
packets to one or more external devices such as routers or traffic generators during a simulation. Since
FLAT is a Layer-2 solution, the IP addresses in your topology are reachable externally. The L2 External
FLAT tool in the Cisco Modeling Labs client GUI is used to enable this option.

Your simulation continues to be driven through the Cisco Modeling Labs client GUI by communicating
with the Cisco Modeling Labs server at its IP address that is bound to the relevant management port.

Note
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3 Connecting to external devices using SNAT Inband access

As an alternative to Inband access using FLAT, you can set up the Static NAT (SNAT) approach. SNAT
is a Layer-3 solution that leverages the use of an internal SNAT router to hide the IP addresses in your
topology. This router, internal to the Cisco Modeling Labs server, translates IP addresses inbound and
outbound which means that the addressing schemes used on the virtual topology are not propagated outside
the virtual network.

When configured, an internal and an external address are assigned to the SNAT-assigned interface on the
nodes. For example, configuring 10.11.12.1 as the internal address, andmapping it to 172.16.2.51 externally.
Traffic sent to 172.16.2.51 will be translated to the correct internal address and presented to the appropriate
node.

The L3 External SNAT tool in the Cisco Modeling Labs client GUI is used to enable this option.

Your simulation continues to be driven through the Cisco Modeling Labs client by communicating with
the Cisco Modeling Labs server at its IP address that is bound to the relevant management port.

Note

Node Access via an External Terminal Client
There are situations when an external terminal client may be preferred over the Cisco Modeling Labs client
for accessing the nodes’ console. Factors may just be familiarity, or to capture and save session commands
and respective responses to configuration changes.

Standard Telnet Sessions

By using the same socket combination used by the Cisco Modeling Labs client initiated sessions, a Telnet
session may be launched from a Telnet client residing on the Cisco Modeling Labs client workstation, or
another workstation. Using the Cisco Modeling Labs client, hovering the cursor over Telnet triggers a popup
menu from which either the Console or Monitor ports may be noted. A Telnet session is directed to the Cisco
Modeling Labs management IP address using the assigned port to the serial console port.

The TCP port is a transient value generated upon spinning up the virtual node. If the party accessing the
nodes does not have a Cisco Modeling Labs project login account, the project owner/administrator will
need to provide the node access socket details.

Note

SSH Sessions

If using an external terminal emulator, an SSH session directed to the JumpHost socket will open a terminal
session on the JumpHost. After entering user credentials (same as those for the Cisco Modeling Labs server),
the logged in user will then manually initiate a Telnet session to the desired node using its management
interface.

Out-of-Band Management Sessions via the Flat Interface
The Cisco Modeling Labs client is not required to access nodes within a running project simulation. When
configured, the out-of-band (OOB) management network interface for the running nodes may be accessible
by external (physical) devices. A variety of methods employ a Layer-2 connection through the Ethernet1
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interface, designated as Flat. This can be useful when you want to grant access to nodes within a running
project to users without Cisco Modeling Labs credentials.

The available options are:

• Use Telnet to bypass the Cisco Modeling Labs Client:You can configure a shared OOBmanagement
interface on each of the topology’s nodes. You can do this by selecting Shared Flat Network as the
Management Network option for the topology under Properties > Topology.

Figure 216: Shared Flat Network Option

Selecting the Shared Flat Network option enables OOB external network access to all devices within
the topology. This management network option assigns an IP address from the Flat network pool to each
of the node’s designated OOB Management interface (GigabitEthernet0/0), and presents that network
to the Cisco Modeling Labs' Flat interface (Eth1).

All running projects configured with Shared Flat Network as theManagement Network
will have their constituent nodes exposed to the Flat network interface with an IP address
assigned from the provisioned Flat subnet range. As such, project users are able to access
operating nodes beyond those associated with their specific project.

Note

For management stations directly attached to this network, a node is accessed by initiating a standard
Telnet session to the OOB management interface assigned during the topology start-up process. The
Cisco Modeling Labs client, via the Simulations perspective or the User Workspace Management
interface may be used to find out the IP addresses assigned to the OOB management interface for each
of the running nodes.
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• Use SSH via Jumphost: You can use SSH to access a node's OOB management interface via the Flat
Ethernet1 interface, where the session is directed to the project-level Jumphost.

Figure 217: Using an SSH JumpHost in a Simulation

Accessing the simulated nodes via SSH using an external terminal emulator will require a two-step
process. The jumphost represents a minimal Linux-container that terminates the SSH sessions. After
entering user credentials, the logged in user may then manually initiate a Telnet session to the desired
node using its management interface, provided that remote access has been enabled in the devices’
configurations. A jumphost implemented at the Project level will have accessibility to any simulation
running within the user’s project space. Implementing an LXC management node creates a jumphost
within the simulation. The following figure shows where enabling a node with the Use an LXC
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Management Node option when defining the topology’s properties results in an ~lxc-flat object being
launched within the simulation.

Figure 218: Using an LXC Flat JumpHost in a Simulation

• Use Private Management Networks:When the simulation’s Management Network is set as Shared
Flat Network, all nodes within the topology are assigned an IP address from the pool provisioned for
the Flat network interface (Eth1) and are accessible to any user attached to the Eth1 interface. To provide
additional isolation from other users, the topology may be optioned with an internal OOB management
network. When set for private management, the simulation-nodes’ OOB interfaces are assigned, by
default, addresses from the 10.255.0.0/24 range.

A private OOB management network may be established at the project-level with multiple simulations
within a common project or per simulation. When a private OOBmanagement network is implemented,
access to the simulation’s virtual nodes is limited to the Cisco Modeling Labs client, or via SSH to the
jumphost when external terminals are used.

Set Up a FLAT Network for Out of Band (OOB) Management Access
By using an out-of-band (OOB) network connection to the Cisco Modeling Labs simulation, you can connect
an external application to the Management port of any router node in the simulated network. All management
ports will have an IP address on the OOB network, which is a separate network from the other interface IP
addresses.

The IP address range assigned to FLAT must be a routable IP address. In addition, these IP addresses
must be defined in the settings.ini file. When done, the administrator must run the Upgrade or Rehost
option so that the changes take affect. Note too that running the Rehost option will affect other users on
the server.

Important

Before You Begin

• Ensure that you have installed a third-party application for Telnet connections, such as PuTTY.
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• Ensure that FLAT connectivity has been enabled by the system administrator.

Step 1 Log in to the Cisco Modeling Labs client.
Step 2 Verify you have connectivity to the Cisco Modeling Labs server.
Step 3 Open the Design perspective, if it is not already open.
Step 4 Open an existing topology or create your network topology. See Create a Topology for information on how to do this.
Step 5 Configure the OOB management network.

a) Click on the Topology Editor canvas.
b) Choose Properties > Topology.
c) LocateManagement Network and select Shared flat network from the drop-down list.

The Shared flat network option is what enables the OOB connectivity.
Step 6 From the toolbar, click the Build Initial Configurations tool.

For the purpose of this task, you may retain the default
settings.

Note

Step 7 After the build phase is completed, initiate the simulation by clicking the Launch Simulation tool in the toolbar, and
then change to the Simulation perspective.

Step 8 (Optional) Enter the ping command on the PC to confirm that the management port on a running node can be reached.
a) In the Cisco Modeling Labs client simulation, select a node and display the IP address for its management port. In

this example, the IP address for the node management port is 172.16.1.51.

b) In the PC command window, enter the ping command to target the node management port identified in Step 8a.
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Step 9 (Optional) In the CiscoModeling Labs client simulation, connect to a console port on a node and confirm the management
network IP address exists. Enter the show ip interface brief command to display the IP addresses. For this example,
use the IP address 172.16.1.51.

Step 10 Launch and configure a terminal emulator for a Telnet connection to the node management port. In this example, the
PuTTY application is used.
a) Launch the PuTTY application.
b) In the PuTTY Configuration window, enter the IP address for a Telnet connection to the management port. In this

example, the IP address for the node management port is 172.16.1.51.
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c) When successful, a Telnet window opens and the router console information is displayed.
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Add an Additional FLAT Network to a Simulation
The following procedure describes how to configure a second FLAT network to your simulation. A FLAT
network uses Layer 2 connectivity, in which the IP address information about your virtual network can be
viewed externally.

Step 1 With your topology open on the canvas, click the L2 External (FLAT) icon to add another FLAT network to your
topology, as shown.

Figure 219: Add an Additional FLAT Network

Step 2 Click the FLAT network just added, and in the Extensions tab in the Properties view, click the Add new extension
icon.
The Edit extension dialog box is displayed.

Step 3 Add the following details for the new extension and click OK.

• Key: host_network

• Value: flat1
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• Type: String

Figure 220: Edit Extension Dialog Box

You must add this new extension for the second FLAT network, as a second interface is not permitted in the
same subnet. This FLAT network is in the flat1 subnet.

Note

Step 4 From the toolbar, click the Build Initial Configurations tool.
For the purpose of this task, you may retain the default
settings.

Note

During the simulation phase, the system automatically assigns an IP address to the node interface that is connected to
the FLAT cloud.

Step 5 After the build phase is completed, start the simulation by clicking the Launch Simulation tool in the toolbar, and then
change to the Simulation perspective.
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The IP addresses assigned to each of the interfaces in the FLAT network and connected to each node, are displayed in
the Simulations view. These IP addresses are automatically applied to the nodes when they become active.

Figure 221: Flat1 Subnet

Step 6 Regarding the node that has two FLAT network connections, when its state has changed to [ACTIVE], log in to said
node.

Step 7 Enter the command show ip interface bri to view all interfaces available to the node.

Figure 222: Viewing the FLAT Networks
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You can see that the node has a connection into each of the external FLAT connectivity networks, 172.16.1.196 and
172.16.2.53.

In-Band Management Sessions via a Flat Interface
Managing nodes via the CiscoModeling Labs client or using terminal emulator sessions via OOBmanagement
interfaces work well when the access is exclusively used for management plane interactions. When external
connectivity will be used for both management-plane and data-plane traffic exchanges with external devices,
an In-Bandmanagement solution may be warranted. As shown in the following figure, the Flat (Eth1) interface
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is associated with an interface on the new-york node, to which an IP address from the Flat-interface address
pool is assigned.

Figure 223: In-Band Management Connections

Within the Cisco Modeling Labs client’s Design perspective, an L2 External (FLAT) object is placed on the
canvas and a link connection is drawn between the resultant flat-1 icon and a node, as shown.

Figure 224: Enabling Bridged Connections to External Devices

Using the L2 External (FLAT) object precludes the simultaneous use of the Out-of-Band management option.
The Management Network option within Properties > Topology is not defined (<not specified>) as shown
above.

During the topology’s launch phase, an IP address from the range provisioned for the Flat (Eth1) interface
(by default, 172.16.1.0/24) is assigned to the associated interface on new-york. The externally attached terminal
or management device is then manually configured with an unused IP address within this scope. An alternative
option is to enable DHCP services on the node as to offer an IP address to the attached workstation.
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In multiuser deployments, consideration must be given to DHCP scope and exclusion ranges applied to
nodes within simulation environments and to coordinate the assignment ranges being facilitated by the
Cisco Modeling Labs server during topology build/launch phases. Otherwise, multiple agents assigning
addresses from overlapping pools might result in duplicate address assignments.

Note

Set Up a FLAT Network for Inband Access
Managing nodes via the CiscoModeling Labs client or using terminal emulator sessions via OOBmanagement
interfaces work well when the access is exclusively used for management plane interactions. When external
connectivity is used for both management-plane and data-plane traffic exchanges with external devices, an
In-Band management solution may be required.

The following procedure describes how to connect your virtual network topology to physical devices that are
external to the Cisco Modeling Labs server environment. In this procedure, you will be configuring a FLAT
network. A FLAT network uses Layer-2 connectivity in which the IP address information about your virtual
network can be viewed externally.

The IP address range assigned to FLAT must be a routable IP address. In addition, these IP addresses
must be defined in the settings.ini. When done, the administrator must run the Upgrade or Rehost option
so that the changes take affect. Note too that running the Rehost option will affect other users on the server.

Important

Before You Begin

• Ensure that the system administrator has configured the Cisco Modeling Labs server to allow FLAT
connections.

• Ensure that you obtain the IP address of the default gateway from the system administrator.

• Ensure that you have the IP address of the external device to which the nodes will connect.

We recommend that you first draw your intended design, and then label the devices with the appropriate
IP addresses.

Note

Step 1 Log in to the Cisco Modeling Labs client.
Step 2 Verify you have connectivity to the Cisco Modeling Labs server.
Step 3 Open the Design perspective, if it is not already open.
Step 4 Open an existing topology or create your network topology. See Create a Topology for information on how to do this.
Step 5 Click on the canvas to open the Topology tab in the Properties view and ensure thatManagement Network displays

<not specified>.
Step 6 From the Palette view, under General, click the L2 External FLAT tool, and then click the canvas to add one FLAT

cloud network icon to each corresponding node icon on the canvas.
Step 7 From the Palette view, under Tools, click the Connect tool and connect the L2 External FLAT to the desired nodes.
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L2 External FLAT connections can only be assigned to one interface on one
node.

Note

Step 8 From the toolbar, click the Build Initial Configurations tool.

For the purpose of this task, you may retain the default
settings.

Note

The system automatically assigns an IP address to the node interface that is connected to the FLAT cloud during the
Simulation phase, not the Build phase.

Step 9 After the build phase is completed, start the simulation by clicking the Launch Simulation tool in the toolbar, and then
change to the Simulation perspective.

Step 10 Log in to the node that is connected to the FLAT network when its state has changed to ACTIVE.
Step 11 View the IP address assigned to the FLAT network and determine if it is on the same subnet as the gateway IP address

provided by your system administrator. The L2 external address for each node can be viewed from the Simulations view
or from each individual node.

• If yes, continue to Step 12.

• If no, advise your system administrator and request the correct gateway IP address.

Step 12 If the external device is on a different subnet, define a default gateway or a broadcast domain that points to the IP address
of the gateway that the system administrator supplies.

Prior to completing this step, if you do a show route, you will see that no default gateway is defined in the node. This
is the default set up. This step allows you to inform the node what path to take in order to reach the external environment
via the gateway. An alternative to defining a gateway or static route, with IOSv devices, is to enable DHCP on the
interface used for external connectivity.

Not all virtual images support DHCP. Check the supported features for the virtual images to determine which
ones do support DHCP.

Note

Step 13 Test the connection by pinging from the node to the external (physical) device. If required, turn on debug ip icmp or
use the tracert command to see the progress through the network.

Youmust repeat steps 10-13 for each node that is connected to the FLAT network.Note

If the ping does not work, confirm with your system administrator that the Cisco Modeling Labs server is configured to
support FLAT connectivity and that the gateway IP address you have been provided is correct.

If these items are correct, ping to each of the key devices in the path to determine where the failure occurs and notify
your system administrator of the failure source if it is outside your Cisco Modeling Labs environment.

Interconnect Topologies in Physical Labs via a Flat Interface
A Flat interface may also be used to interconnect a group of physical lab devices to nodes running within a
simulation.

By default, the node’s interface associated with the Flat object is assigned an IP address from the range
provisioned to the Cisco Modeling Labs’ Ethernet1 interface during server installation. This is allotted when
the node is spun up by OpenStack when the simulation is launched. Once fully active, the assigned interface
address may be adjusted to meet the addressing requirements of the external environment (or the external
device’s interface is configured with an appropriate address to interact with the node.) After confirming Layer-2
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connectivity between the physical/virtual nodes, implement the necessary (static or dynamic) routing in both
physical and virtual lab environments to complete the integration.

Access Multiple Nodes via a Flat Interface

TheL2External (FLAT) object may be assigned to only one interface on one node.When topology scenarios
demand Layer-2 connections to multiple nodes, additional L2 External (FLAT) objects may be used on the
canvas with the associated link relationship to the associated node.

Figure 225: Multiple Flat Network Associations

When a simulation is launched, an IP address from the Flat (Ethernet1) external address pool is assigned to
the respective node interfaces connected to the external icon. While the example functionally matches that of
the OOB_Management configuration, it differs in that the interfaces reserved for OOB (GigabitEthernet0/0)
are not used. Instead, the next available infrastructure interface is selected for use (or manually allocated).

Connect Multiple Networks across a Single Flat Interface

Multiple Layer-3 networks may be interconnected between physical and virtual nodes using a single flat
interface. This is facilitated by the use of the Cisco IOSvL2 node within the simulation, with the external
facing interface configured as an 802.1Q trunk. The corresponding trunk configurations are applied to the
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attached physical device’s interface, as shown. Each Layer-3 network is represented as a VLAN traversing
this Layer-2 trunk.

Figure 226: Extending VLANs across Cisco Modeling Labs' Flat (Eth1) Interface

Note that the AutoNetkit process may not completely provision this application, and manual configurations
may be necessary to enable the external connection as a trunked interface. Special consideration may be
required for Cisco Modeling Labs deployments on top of ESXi when extending VLANs between an IOSvL2
node and an external device. Whether deployed with distinct ESXi vSwitches and dedicated pNICs or a
common vSwitch with a shared/trunked pNIC, the ESXi Port Groups associated with the Flat interface must
be set to carry 802.1Q tagged frames. Using the vSphere client (or vCenter management station) to access the
ESXi server, the host’s Networking > Configuration page is accessed. Edit the Port Group properties of the
Flat interface to pass All (4095) VLAN IDs, as shown. If the Flat1 interface is to be used in a similar manner,
it should also be enabled to carry all VLAN IDs.

Figure 227: Setting the ESXi Port Group to Support VLANs
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The upstream (physical) switch interface should not have the BPDU_Guard feature enabled on the associated
interface(s) as to prevent any BPDUs originating from virtual nodes from triggering an interface-shutdown.

Note

Employ Multiple Flat Interfaces

There are simulation scenarios that may necessitate multiple Layer-2 connections to external devices, as
shown.

Figure 228: Employing Multiple Flat Interfaces to External Devices

Applications that necessitate multiple flat network interfaces may include:

• Traffic generated by an external source that crosses the virtualized network to another external destination
device.

• Integrating multiple, physical lab topologies (representing access-networks) to a simulated core topology.

• Interconnecting multiple virtual lab scenarios or external virtual machines to a simulated core topology.

• Scaling CiscoModeling Labs topology sizes by interconnecting multiple CiscoModeling Labs instances
across separate servers.

The Cisco Modeling Labs server offers a second bridged interface to enable such test designs. Adding L2
External (FLAT) objects will, by default, be associated to the Flat (Eth1) interface. This default allocation
may be manually overridden by editing the object’s properties as to use the server’s Flat1 (Eth2) interface.
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This change is done by selecting the L2 External (FLAT) icon on the canvas. Within the Properties view,
choose the Extensions tab and click Add [+], as shown.

Figure 229: Editing L2_External(FLAT) Object Properties

Within the Edit Extension dialog box, add the following details for the new extension, and click OK.

• Key: host_network

• Value: flat1

• Type: String
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When the simulation is launched, an IP address from the Flat1 external address pool is assigned to the respective
node interface connected to the L2 External (FLAT) icon. The Simulations view shows the flat-1 and flat-2
objects and their attributes.

Figure 230: Displaying Properties of Running Flat Interfaces

Examination of the flat-2 object shows its association to the flat1 Host Network, and the respective iosv-1
interface (GigabitEthernet0/3) assigned an IP address from the Flat1 address pool (172.16.2.0/24 in the
example). As additional L2 External (FLAT) objects are added to the canvas, they may remain associated
with the default flat interface or edited as described to be associated with the flat1 interface.

Employ OOB Management with External Devices

When the Shared flat network is selected as the Management Network for OOB_Management, the Flat (Eth1)
interface is associated with the GigabitEthernet0/0 interfaces for each of the nodes in the topology simulation.
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If external devices are also to be integrated using a flat interconnection, the Flat1 (Eth2) and associated IP
address range must be used, as shown.

Figure 231: Using OOB Management with Flat-interconnect External Devices

When the L2 External (FLAT) object is inserted into the topology, its properties must be edited as described
in the previous section.

In these scenarios, if the L2 External (FLAT) object is not edited to use the Flat1 interface, the Cisco
Modeling Labs client’s Build process will fail, reporting overlapping use of the Flat interface.

Important

Interconnect External Devices via a SNAT Interface
The Static Network Address Translation (SNAT) interface enables communications between running nodes
and external devices using Layer-3 services via an internal (OpenStack) virtual router. Using the L3_External
(SNAT) object, the simulated virtual networks and details are hidden behind a Static NAT address block. The
CiscoModeling Labs server does a static IP address translation, translating the private address range allocated
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to the SNAT ‘inside’ network into the IP network configured for the SNAT ‘outside' network. By default,
Cisco Modeling Labs uses an internal gateway function that acts as a SNAT router, as shown.

Figure 232: Using the SNAT Interface

The IP address range assigned to SNAT must be a routable IP address. In addition, these IP addresses
must be defined in the settings.ini file. When done, you must run the Upgrade or Rehost option so that
the changes take affect.

Important

When a simulation starts up, IP addresses from the internal infrastructure pool are assigned to their respective
node interfaces by OpenStack’s Neutron services. Those interfaces are then mapped to their corresponding
external address, also assigned by Neutron services. These internal to external IP mappings are maintained
within the Neutron SNAT-Gateway.
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In the following example, the new-york GE 0/4 interface has two IP addresses. The addresses on the 172.16.3.0
subnet are reachable from the external devices and will be translated to the internal addresses which are on
the 10.254.0.1 network.

Figure 233: SNAT Functionality

Looking at the snat-1 object shows the internal and external addresses assigned to the SNAT gateway function
associated with the GigabitEthernet0/1 interface within the new-york node during the spin-up of the project
simulation. Manual configuration of the associated nodes is now required to enable traffic to traverse the
SNAT gateway, where static routing statements must be added to the simulated device “attached” to the snat-1
object.

By accessing the User Workplace Management interface, you can determine the additional details required
to set up the static routing. After logging in, access the external connections list by selecting theConnectivity
option. Within the L3 Snat IP Address Allocations section, the appropriate SNAT gateway addresses are
listed, as shown.

Figure 234: Determine the SNAT Gateway Addresses

The IP addresses shown above are default values that may be adjusted during the Cisco Modeling Labs
server installation process. Viewing the Connectivity information in the User Workplace Management
interface ensures that the correct details are employed. If the User Workplace Management interface is
not available, the necessary details must be provided by the system administrator.

Note
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The appropriate static routes must be configured to route externally destined traffic to the inside gateway’s
IP address. This may be done manually by logging into the running node associated with the SNAT object,
and adding the appropriate static or default routing statement(s).

Alternatively, you can use AutoNetkit to insert the static route statements. This is done in the Cisco Modeling
Labs client in the Design perspective, before the simulation is launched. With the node directly connected to
the SNAT node selected, enter the static route statements under Properties > AutoNetkit > Custom
Configuration > Global, as shown.

Figure 235: Use AutoNetkit to Set the SNAT Gateway Route
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Access Multiple Devices via a SNAT Interface
Multiple L3_External (SNAT) objects may be placed on the canvas in the Cisco Modeling Labs client with
links drawn to their respective virtual nodes as shown.

Figure 236: Using the SNAT Interface

When a simulation starts up, OpenStack-Neutron services within Cisco Modeling Labs provisions internal
and external IP assignments and maintains these mappings on a 1:1 basis within the SNAT gateway, as shown.

Figure 237: Multiple SNAT Connections

The SNAT-attached nodes will require appropriated static routing commands applied to their running
configurations. As with the single SNAT connection, these may be inserted via console sessions with each
of the nodes after launching. This will also require configuration extraction prior to shutting down the simulation
if the topology is expected to be run again.

The node to snat-n links shown above do not represent Layer-3 links to distinct external devices.Note
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The more efficient method is to use AutoNetkit to apply the statements to the startup configuration file via
the build process. By selecting each of the affected nodes on the canvas, the Custom Configuration may be
simultaneously added to all of the nodes with SNAT connectors, as shown.

Figure 238: Applying Static Routes to Multiple SNAT-attached Nodes

Set Up a SNAT Network for Inband Access
To set up a SNAT Network for inband access, complete the following steps:

Before You Begin

• Ensure that the system administrator has configured the Cisco Modeling Labs server to allow SNAT
connections.

• Ensure that the system administrator provides you with the internal and external IP addresses of the
SNAT router.

• Ensure that you have the IP address to the default gateway.
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• Ensure that you have the IP address of the external device to which the nodes will connect.

Step 1 Log in to the Cisco Modeling Labs client.
Step 2 Verify you have connectivity to the Cisco Modeling Labs server.
Step 3 Open the Design perspective, if it is not already open.
Step 4 Open an existing topology or create your network topology. See Create a Topology for information on how to do this.
Step 5 Click on the canvas to open the Topology tab in the Properties view and ensure thatManagement Network displays

<not specified>.

Step 6 From the Palette view, under General, click the L3 External SNAT tool, and then click the canvas to add one SNAT
cloud network icon to each corresponding node icon on the canvas.

Step 7 From the Palette view, under Tools, click the Connect tool and connect the L3 External SNAT to the desired nodes.

L3 External SNAT connections can only be assigned to one interface on one
node.

Note

Step 8 From the toolbar, click the Build Initial Configurations tool.

For the purpose of this task, you may retain the default
settings.

Note

The system automatically assigns the internal and external IP addresses to the node interface that is connected to the
SNAT cloud during the Simulation phase, not theBuild phase. Therefore, no assigned addresses are visible at this point.

Step 9 After the build phase is completed, start the simulation by clicking the Launch Simulation tool in the toolbar, and then
change to the Simulation perspective.

Step 10 Log in to the node that is connected to the SNAT network when the status of the device has changed to ACTIVE.
Step 11 Create a static route or define a default gateway for the external connection IP addresses that point to the SNAT router’s

internal IP address. For example, if the external connections are part of the subnet 172.16.2.0/24, and the SNAT router’s
internal IP address is 10.11.11.1, then the route statement would be:
ip route 172.16.2.0 255.255.255.0 10.11.11.1

An alternative to defining a gateway or static route, with IOSv devices, is to enable DHCP on the interface used for
external connectivity.

Not all virtual images support DHCP. Check the supported features for the virtual images to determine which
ones do support DHCP.

Note

Step 12 Test the connection by pinging from the node to the external (physical) device. If required, turn on debug ip icmp or
use the tracert command to see the connectivity between the end points.

If the ping does not work, confirm with your system administrator that the Cisco Modeling Labs server is configured to
support SNAT connectivity and that the gateway IP address you have been provided is correct.

If these items are correct, ping to each of the key devices in the path to determine where the failure occurs and notify
your system administrator of the failure source if it is outside your Cisco Modeling Labs environment.
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Use Case Scenarios
Within many different sectors, for example, education and technical training, Cisco Modeling Labs may be
used to facilitate virtual labs to support hands-on practice in conjunction with lesson plans. Cisco Modeling
Lab's multi-user features can be configured to support multiple projects, containing several similarly defined
simulations representing a lab exercise. There are a variety of methods to enable student access to virtualized
lab environments, for example:

• Using Flat for OOB_Management of Simulations

• Using SNAT for OOB_Management of Simulations

•

These methods are discussed in the next sections.

Using Flat for OOB_Management of Simulations

In this use case, each course is represented as a Cisco Modeling Labs project containing a sequential series
of pre-defined topology designs representing the lab exercises associated with the lesson plan. Each of these
topologies is spun up as a group of lab instances with one for each student. To assure isolated access to each
virtual lab-pod, the simulations are launched with the Private_Simulation OOB_Management Network, which
uses a simulation-level jump-host employed as a lab-network gateway.

For each lab-pod, the virtualized devices within the simulations must be enabled for Telnet logins before
students can access them via the Jumphosts. The appropriate users, passwords, and line vty commands
may be implemented as part of the AutoNetKit custom configurations, by manually modifying the
configurations prior to launching the simulations, or implemented after spinning up the virtual nodes
(preferably using an automated script.)

Note

This basic layout is summarized in the following figure, which illustrates two subsets of students accessing
virtualized lab resources associated with two different courses. Two distinct Projects are shown Course-A
and Course-B, each independently managed by their respective course instructor. Within each project, a set
of similarly designed and configured simulations are spun-up as student lab resources. Because each simulation
is completely isolated from the other simulations within the project, they may be exact copies of each other
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(the exception being the external IP address assigned to the jumphost, which is assigned when the simulation
starts.)

Figure 239: Using Flat Connections for Student Lab Access

Students access their respective lab-pods using SSH sessions to the jumphost address assigned by the instructor.
Upon successful login, they may access the virtual nodes within their topology and perform the hands-on
exercise associated with the lesson. Using the Cisco Modeling Labs client, the instructor is able to access any
of the labs within the project to provide assistance and perform course-specific administration of the lab
exercises.

This scenario only depicts the student/instructor access to the lab environment. There are additional
considerations with respect to simulation startup/teardown, remote access (e.g. front-end VPN gateway
or router), access scheduling, activity retention/restoral, and lab resets.

Note

Using SNAT for OOB_Management of Simulations

A Layer-3 based method may be used to access the same course lab scenario. In this use case, the SNAT
interface provides access to a single node within each simulation. A significant advantage of this approach is
that it preserves the other Flat interfaces for other external communications considerations (for example,
connections to physical devices and interconnecting student simulations as part of a progression lab design.)
Each simulation is set for Private_Simulation management network as to ensure the desired isolation between
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the simulated topologies. Users gain access to the simulation via the public IP address associated with their
assigned topology environment, which is translated to the internal IP address of the head-end node. Once
logged in, Telnet sessions may be launched to the other simulation's nodes, as shown in the following figure.

Figure 240: Using SNAT Connections for Student Lab Access

Since the SNAT based approach only establishes an in-band management connection to the head-end node,
the base topology design must have sufficient configurations applied as to enable in-band Telnet sessions to
the other virtual nodes within the simulation. This includes the initial interface configurations, as well as the
appropriate users, passwords, and line vty commands.

As in the previous example, this scenario only depicts the student/instructor access to the lab environment.
There are additional considerations with respect to simulation startup/teardown, remote access (e.g. front-end
VPN gateway or router), access scheduling, activity retention/restoral, and lab resets.

Similar to the Flat-interface based method, the Cisco Modeling Labs client is used by the instructor to access
any of the labs within the project to provide assistance, as well as to perform course-specific administration
of the lab exercises.

Using the Cisco Modeling Labs Client

Leveraging external communications interfaces for student access of virtual labs is useful for the novice learner
or when there is a desire to use more tightly scripted learning labs. It allows the hands-on lab elements to be
limited to the curricula requirements without introducing the features of the Cisco Modeling Labs' client
interface. For more intermediate and advanced networking learners, the Cisco Modeling Labs client may be
the appropriate means to access CiscoModeling Labs services. Student use of the CiscoModeling Labs client
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enables self-administration of lab scenarios, and enables a self-directed discovery and learning style. When
allowing student use of the Cisco Modeling Labs client, considerations include (but not limited to):

• Remote access options and associated firewall settings

• Setting appropriate resource quotas

• Configuring an expiration account access

• Corresponding access rights to any NAS/shared storage for reusable .virl files

• Access to any external communications interfaces and attached devices
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