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Using the Cisco Modeling Labs Client Overview
The Cisco Modeling Labs client is a cross-platform, point-and-click GUI that simplifies topology creation
and initial device configurations and permits access to the Cisco Modeling Labs server. You can interact
directly with your running simulations from this GUI. Additionally, the Cisco Modeling Labs client provides
the functionality to generate default router configurations before simulating your topology.

This chapter introduces the main areas and capabilities of the Cisco Modeling Labs client.

Navigating Within the Cisco Modeling Labs Client
This section describes the functionality of the Cisco Modeling Labs client, which comprises a workbench
containing a menu bar, a toolbar, multiple editors, multiple perspectives, and multiple views.
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•Workbench: Refers to the Cisco Modeling Labs client desktop environment. Each time the workbench
is exited, it is automatically saved, including all the open perspectives, views, and editors. When the
workbench is reopened, it appears exactly as it was when last closed.

Figure 1: Cisco Modeling Labs Workbench

•MenuBar: References all the actions that can be performed when using the CiscoModeling Labs client.

Figure 2: Menu Bar

• Toolbar: Contains a set of icons representing commands. The toolbar provides shortcuts to actions that
are used most often from the menu bar.

Figure 3: Toolbar

• Cisco Modeling Labs Client Perspectives: Identifies the Design and Simulation perspectives, each
of which is associated with an initial set of views and editors in your workbench.

Figure 4: Perspectives
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◦From theDesign perspective, you can design your network topology, build the node configurations,
and check routing protocols. TheDesign perspective is the default perspective if you are launching
the Cisco Modeling Labs client for the first time.

◦From the Simulation perspective, you can enable devices and modify configurations to run the
simulations. When the nodes in your topology are fully initialized, you can connect to the consoles
as you would connect to a router console.

• Cisco Modeling Labs Client Editors: Provides alternative components within the Cisco Modeling
Labs client from which you can create and edit topologies. Two editors are provided: Node Editor and
Topology Editor.

◦The Node Editor shows the interface details for selected elements in the Topology Editor.

Figure 5: Node Editor
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◦The Topology Editor comprises the Palette view

Figure 6: Palette
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and the canvas.

Figure 7: Canvas
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• Cisco Modeling Labs Client Views: Provides alternative presentations of your topology and methods
for navigating the information in your workbench.

Figure 8: Views

• Cisco Modeling Labs Client Layout: Enables you to personalize your workbench, allowing you to
rearrange, resize, reset, and move between views.

Menu Bar
The menu bar provides access to the complete list of actions that are possible in the Cisco Modeling Labs
client.

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.1
6

Using the Cisco Modeling Labs Client
Menu Bar



Table 1: Menu Bar Items

Action(s)Menu

Enables you to perform actions on a topology .virl file, set preferences for resources,
and exit the Cisco Modeling Labs client.

• New: Creates a new topology project folder, topology project, or topology
.virl file. See Design a Topology Overview for more information.

• Save: Saves the current Topology Editor contents.

• Save As: Saves the current Topology Editor contents to a new file.

• Save All: Saves all Topology Editor contents to a new file.

• Print: Prints the current Topology Editor design.

• Import: Imports a resource type (for example, a topology .virl file) into the
Cisco Modeling Labs client. See Importing a Topology File, on page 10 for
more information.

• Export: Exports a resource type (for example, a topology .virl file) from the
Cisco Modeling Labs client. See Exporting a Topology File, on page 10 for
more information.

• Close: Closes the current editor.

• Close All: Closes all open editors.

• Preferences: Opens the Preferences dialog box, where you can update the
settings for the Cisco Modeling Labs client. See Setting Preferences for the
Cisco Modeling Labs Client, on page 56 for more information.

• SwitchWorkspace: Allows you to select a workspace folder to use for your
session.

• Exit: Exits the Cisco Modeling Labs client.

File
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Action(s)Menu

Enables you to manipulate resources on the canvas.

• Undo: Cancels the most recent change.

• Redo: Applies the most recent change that was removed.

• Copy: Places a copy of the topology on the clipboard.

• Paste: Pastes the topology from the clipboard to the canvas at the current
cursor location.

• Delete: Deletes the current topology.

• Search: Enables you to perform topology searches and text searches within
work spaces, topology projects, files, and working sets.

• Select All: Selects all objects in the current topology canvas.

• Grid: Provides three options for displaying nodes on the canvas: Display
Grid, Snap to Grid, and Distribute Nodes.

• Reset Node Subtype: Enables you to redefine a virtual node on the canvas.
When Reset All Interface Names is selected, the interface IDs are reset
sequentially, starting from the minimum range.

• Distribute Nodes: Aligns the nodes on the canvas evenly, either vertically
or horizontally. (This feature is disabled when Show Map Background is
chosen.)

• Layout Nodes: Places nodes on the canvas in a tree layout or an F-R layout.
(This feature is disabled when Show Map Background is selected.)

• Alignment: Aligns the nodes on the canvas. Options are: left, center, right,
top, middle, or bottom. (This feature is disabled when Show Map
Background is selected.)

• Group to Site: Groups two or more nodes within a site.

• Ungroup Site: Ungroups nodes from within a site, removing one layer of
nesting.

Edit
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Action(s)Menu

Enables you to manipulate the Cisco Modeling Labs client.

• Zoom In: Allows you to zoom in on the canvas, increasing the topology
view. This is also available on the toolbar.

• Zoom Out: Allows you to zoom out on the canvas, reducing the topology
view. This is also available on the toolbar.

• Highlight Connection: Highlights all connections to and from the selected
node.

• Show/HideMap Background: Displays a map background for the topology.
Choose Hide to disable the feature.(You must have Internet access to use this
feature.)

• Topology Labels: Displays the IPv4 and IPv6 loopback addresses on the
canvas. Click Show Topology Labels to turn on this functionality. Toggle
betweenNode loopback IPv4 andNode loopback IPv6 to see the applicable
addresses on the node(s) on the canvas.

View

Enables you to generate node configurations.

• Build Initial Configurations: Creates initial node configurations.

Configuration

Enables you to start and stop simulations.

• Launch Simulation: Starts a simulation.

• Launch Simulation (with time limit) : Starts a simulation for a specified
time period.

• Stop Simulations: Stops a running simulation.

Simulation

Enables you to manage perspectives in the Cisco Modeling Labs client.

• Open Perspective: Opens the selected perspective.

• Show View : Displays the selected view.

• Reset Perspective: Resets the perspective to the initial login perspective.

• Save Perspective As: Saves the current perspective to a specified name.

• Close Perspective: Closes the open perspective.

Window
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Action(s)Menu

Displays the help topics for using the Cisco Modeling Labs client in a separate
browser window.

• HelpContents: Opens the CiscoModeling Labs client support documentation.

• Cheat Sheets: Helps you in completing a task.

• Generate Problem Report: Generates a detailed report of a problem, which
can be submitted to Cisco Technical Assistance Center (Cisco TAC) for
further investigation. See Generate Problem Reports, on page 11 for more
information.

• About Cisco Modeling Labs: Identifies version information and displays
details pertaining to software installations.

Help

Importing a Topology File

Step 1 From the menu bar, choose File > Import.
The Import dialog box appears.

Step 2 From the drop-down list, choose Topology > Import Topology file from File System, and click Next.
Step 3 Click Browse to locate the applicable .virl file.
Step 4 In the right pane, check the check box for the applicable .virl file.
Step 5 Click Finish to import the topology file.

Exporting a Topology File

Step 1 From the menu bar, choose File > Export.

To export a topology file, it must be open on the canvas of theTopology Editor.Note

The Export dialog box appears.
Step 2 From the drop-down list, choose Topology > Export Topology file to File System, and click Next.
Step 3 Click Browse to select the directory to export the topology file to.
Step 4 Click Finish to export the topology file.
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Generate Problem Reports
The Cisco Modeling Labs client provides functionality that allows you to generate problem reports for any
problems encountered in your topology. It is accessible from the menu bar under Help > Generate Problem
Report.

While all options are preselected, you can individually select the information you want to include in the report.

When generating a problem report for your topology, you must have the topology containing the problem
open on the canvas.

Note

DescriptionOption

User interface .log file from the user's workspace.Log File

Current content from the Console view messages. These are messages
from the server in response to AutoNetkit and simulation launch actions.

Consoles' Content

Contents of the currently open topology file in theTopology Editor canvas.Topology Editor Contents

Screenshot showing the state of the user interface when the problem
occurred.

Screenshot of the User Interface

Report of the web services details and errors.Web Services Setting

Any additional information that users can provide to describe the problem.Additional Information

The generated problem report is saved to a .zip file, where you can check the contents before sending it to
Cisco TAC for investigation.

Toolbar
The toolbar is a compilation of icons representing commonly used actions. The toolbar is arranged below the
menu bar and offers the same actions as the menu bar in a single click. The following table outlines the actions
that can be performed using the Cisco Modeling Labs client toolbar.

Table 2: Toolbar Options

DescriptionFunctionIcon

Creates a new topology file. A topology file is a .virl
file where the network arrangement is designed.

New Topology File

Saves the current topology.Save
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DescriptionFunctionIcon

Prints the current topology.Print

Deletes the currently selected element within the
topology.

Delete

Undoes the most recent action.Undo

Redoes the most recent undone action.Redo

Enlarges the topology view on the canvas.Zoom In

Decreases the topology view on the canvas.Zoom Out

Displays either IPv4 or IPv6 loopback addresses
configured manually or by AutoNetkit for the topology
on the canvas.

Show Topology
Labels

Generates initial node configurations for the topology.Build Initial
Configurations

Launches a simulation indefinitely or for a
user-specified time period.

Launch Simulation

Stops all running simulation(s).Stop Simulations

Cisco Modeling Labs Client Components
The three main components of the Cisco Modeling Labs client are described in the following sections:
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• Cisco Modeling Labs Client Editors, on page 13

• Cisco Modeling Labs Client Perspectives, on page 14

• Cisco Modeling Labs Client Views, on page 18

Cisco Modeling Labs Client Editors
Editors are visual components within the Cisco Modeling Labs client. Currently, two editors are available:

• Topology Editor: Shows the entire topology (or sites). The Topology Editor comprises the Palette
view and the canvas.

• Node Editor: Shows the interface details for the currently selected elements in the Topology Editor.

Selecting a connection in theTopology Editor shows the details of both the endpoints in theNode Editor.Note

Topology Editor
The Topology Editor allows you to:

• Add, move, group, rename, delete nodes, and sites on the canvas, or change the properties.

• Create or remove connections between nodes.

• Use GPS coordinates to map your topology to precise geographic locations.

Figure 9: Topology Editor

Node Editor
The Node Editor allows you to:

• Add interfaces to a node.

• Add connections to the interfaces on a node.
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• View nodes, their connections, and all the interfaces on the nodes.

• Specify which interface the connection connects to on each node.

• Update properties for interfaces.

Figure 10: Node Editor

Cisco Modeling Labs Client Perspectives
A perspective defines the initial set and layout of views and editors in the workbench. The Cisco Modeling
Labs client provides two perspectives. However, you can customize your own user-defined perspectives for
use, which can be saved or deleted as needed.

The two perspectives provided in the Cisco Modeling Labs client are Design and Simulation.

• Design: Allows you to create and design your topologies, for example, adding devices and defining
interfaces and adding connections to devices within your network. If you are using the Cisco Modeling
Labs client for the first time, the Design perspective opens by default.

• Simulation: Allows you to simulate running configurations that are generated fromCisco IOSv versions.

The Design and Simulation perspectives that are built into the Cisco Modeling Labs client cannot be
deleted.

Note

One or more perspectives can exist in a single workspace. If multiple perspectives are opened at the same
time, you can choose whether to layer them or open them in a separate workspace.
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Working with Perspectives
You can manage the various perspectives defined in the workbench by choosing File > Preferences >General
> Perspectives.

Figure 11: Perspectives Preferences

The following table describes the Perspectives options:

Table 3: Perspectives Options

DescriptionOption

Defines whether a new perspective opens in the current workbench or opens in
a new window. By default, a new perspective opens in the current workbench.

Open a new perspective
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DescriptionOption

Defines whether a new view opens within the current perspective or opens
docked beside the current perspective (fast view). By default, a new view opens
within the current perspective.

Open a new view

Defines perspective behavior when a new project is created. By default, a new
project opens the perspective in the same workbench.

New project options

The following table describes the Available perspectives options:

Table 4: Available Perspectives Options

DescriptionOption

Sets the selected perspective as the default perspective.Make Default

Resets the definition of the selected perspective to the default configuration. This
option is only applicable to system-defined perspectives.

Revert

Deletes the selected perspective. This option is only applicable to user-defined
perspectives. (System-defined perspectives cannot be deleted.)

Delete

Customize Perspectives
Cisco Modeling Labs provides two perspectives for use in the workspace: the Design perspective and the
Simulation perspective. These perspectives display various views and settings that cannot be changed, nor
can they be deleted from the Cisco Modeling Labs client. You can, however, customize additional Design
and Simulation perspectives for your specific needs.

From the View menu, you can open additional views and arrange them in your perspective. The views can
be arranged by dragging them around the workspace. When finished, you can save the perspective.

Right-click the applicable perspective tab to open the context menu, and then click ShowText. TheDesign
perspective and the Simulation perspective buttons will be displayed as text labels instead of icons only.

Note

Step 1 Open the Design perspective or Simulation perspective in your workspace.
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Use this as an initial template from which to create a customized perspective.

Step 2 To add new views, chooseWindow > Show View >Other and the Show View dialog box is displayed listing all views
for use.
Views already in use are shown as dimmed in the list.

Step 3 To add node information, double-click a node to add a Node Editor in the perspective.
Step 4 Click and drag the views and Node Editors to different positions within the workspace. For example, you can move

each node's Console view so they are either side by side or stacked in tabs.
Step 5 When you are finished arranging the workspace, right-click the applicable perspective button, and then click Save As.

You are prompted to name the new perspective.
Step 6 Enter a name for the perspective and click OK.

Design Perspective
The Design perspective allows you to create and design your topologies. By default, the Design perspective
incorporates the components listed here because they are the most widely used. However, you can customize
a Design perspective to include a different set of components.

• Palette view: Provides the node types, connection types, and sites used to design a topology.

• Projects view: Lists topology projects, subfolders, and files defined from the workbench.

• History view: Lists changes made to a file based on date and time stamp.

• Properties view: Identifies node and interface properties.

• Node Editor: Identifies nodes, node connections, and node interfaces.

• Topology Editor: Develops a network topology.

• Graph Overview: Provides methods for viewing a network topology.

To customize a new Design perspective, choose the desired components from the View menu (for example,
View > Other > Cisco Terminal), and then drag that component view to the desired location within the
workbench. When you are done adding components to the workbench and the component views are laid out
as desired, right-click the Design perspective button, select Save As, and enter a name for the new Design
perspective.

From the Design perspective, right-click the Design icon. This displays the following menu options:

Table 5: Design Perspective Context Menu Options

DescriptionOperation

Saves the customized workbench layout, views, and editors as a new Design
perspective.

Save As

Resets the current perspective to display the workbench design that was used when
the workbench was first opened.

Any open editors, for example, Node Editor, are not closed when a
perspective is reset. You must close them manually.

Note

Reset

Cisco Modeling Labs Corporate Edition User Guide, Release 1.1    
17

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Perspectives



DescriptionOperation

Closes the current perspective. You can reopen it using the Open Perspective tool,
which is located at the upper right corner of the window.

Close

When selected, shows perspective names in the toolbar instead of icons.
When deselected, shows perspective icons in the toolbar instead of names.

Show Text

Simulation Perspective
The Simulation perspective opens after you launch a simulation; you are prompted to switch to the Simulation
perspective. Switching to the Simulation perspective means that you can now connect to your running nodes
in the Simulations view. By default, it incorporates the Topology Editor, Projects view, Simulations view,
Console view, and Terminal view.

From the Simulation perspective, right-click the Simulation icon. This displays the following menu options:

Table 6: Simulation Perspective Context Menu Options

DescriptionOperation

Saves the current perspective.Save As

Resets the current perspective to its original configuration (when the workbench
opened initially).

Any open editors, for example, Topology Editor, are not closed when a
perspective gets reset to its original configuration. They are stacked as tabs
in the default editor area for that perspective.

Note

Reset

Closes the current perspective. (Reopen it using the Open Perspective tool.)Close

When selected, shows perspective names in the toolbar instead of icons.
When deselected, shows perspective icons in the toolbar instead of names.

Show Text

Cisco Modeling Labs Client Views
Views provide alternativemethods for presenting topology information and navigating within your workbench.
You can drag the view windows and position them anywhere within the workbench. Some views have their
own toolbars, and some of the tools on these toolbars are specific to the views being presented.

The most commonly used views within the Cisco Modeling Labs client are listed in the following table:
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Table 7: Commonly Used Views in the Cisco Modeling Labs Client

DescriptionPerspective Where
Used

View Name

Design—Displays messages from AutoNetkit when it
is used to generate router configurations.
Simulation—Displaysmessage streams from the Cisco
Modeling Labs server after a simulation is launched.

For more information, see Console View, on page 20.

Design and
Simulation

Console view

Provides you with the ability to view a scaled-down
version of your entire topology.
For more information, see Graph Overview, on page
21.

DesignGraph Overview

Provides a history of changes made to a file and enables
you to select a previous file version from the list. For
more information, see History View, on page 22.

DesignHistory view

Shows a list of the nodes in the topology and their
interface connections.
For more information, see Outline View, on page 24.

DesignOutline view

Allows you to add devices and interface connections
to your topology.
For more information, see Palette View, on page 25.

DesignPalette view

Displays errors, warnings, and other information that
was detected within the Topology Editor.
For more information, see Problems View, on page
27.

DesignProblems view

Provides a hierarchical view of topology projects,
folders, and topologies in the workbench.
For more information, see Projects View, on page 32.

Design and
Simulation

Projects view

Displays names and properties of nodes and interfaces.
For more information, see Properties View, on page
33.

DesignProperties view

Displays the results of a search, which can be based on
text strings, regular expressions, patterns, whole words,
and case-sensitive characters.

For more information, see Search View, on page 46.

DesignSearch view

Displays information on all running simulations.
For more information, see Simulations View, on page
49.

SimulationSimulations view
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DescriptionPerspective Where
Used

View Name

Displays console information when you use Telnet or
SSH to connect to a node.
For more information, see Terminal View, on page 55.

SimulationTerminal view

Console View
The Console view displays message streams from the Cisco Modeling Labs server after a simulation is
launched. It also displays messages from AutoNetkit when it is used to generate router configurations.

Figure 12: Console View

The Console view toolbar contains the following tools:

Figure 13: Console View Toolbar

Table 8: Available Tools

DescriptionFunctionIcon

Removes all the information from the Console view.Clear Console

Switches scrolling on and off.Scroll Lock

Pins the Console view to the workbench so that
subsequent message streams are shown in another
Console view. The pinned view remains unchanged.

Pin Console
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DescriptionFunctionIcon

Displays theConsole view for the selected simulation.Display Selected Console

Opens a new Console view.Open Console

Reduces the size of the Console view.Minimize

Increases the size of the Console view.Maximize

When several simulations are running, use the toolbar buttonDisplay Selected Console to toggle between
the Console views for the different simulations.

Note

Graph Overview
Graph Overview enables you to view a scaled-down version of your entire topology. A blue rectangle
(representing an overlay) is used to indicate a portion of the topology that is currently being displayed in the
Topology Editor. Using this overlay, you can easily see where the displayed portion sits in relation to the
entire topology.

The Graph Overview also allows you to navigate around a large topology when it is either too large to fit
into the canvas or is zoomed in and not fully displayed on the canvas.

Figure 14: Graph Overview
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From theGraph Overview, click and drag the overlay to pan around your topology. As you drag the overlay,
the corresponding content is reflected in the Topology Editor.

History View
When you create or modify a file, a history of record is maintained and a copy of the modified file is stored
locally. This allows you to replace the current file with a previous version or restore a file that has been deleted.
You can also use theHistory view to compare the changes that were made to the local files. Each file's history,
which is stored locally, is uniquely represented by the date and time at which the file was saved.

Only changes made to topology files (.virl) are retained locally; changes made to projects and folders are
not.

Note

Figure 15: History View

To view the changed history of a file, in the Projects view, right-click the applicable file and choose Team
> Show Local History.

The History view displays a list of revision times; the most recent revision time is highlighted at the top of
the list.

If you have a .virl file opened in the workbench, click theHistory tab to view the list of changes made to
the file.

Note

The History view toolbar contains the following tools:

Figure 16: History View Toolbar
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Table 9: Available Tools

DescriptionFunctionIcon

Refreshes the contents of the view, retrieving the latest history
information for a file from the system.

Refresh

Toggles when the History view selection is linked to the
active editor.When this option is selected, changing the active
editor automatically updates the History view selection to
the project, folder, and file being edited.

Link with Editor
and Selection

Pins the view to the workbench and captures a snapshot of
the file history information. New requests for file history are
opened in a new instance of the History view.

Pin this History
View

Sorts all history items by date. Options are:

• Today

• Yesterday

• This Month

• Previous

GroupRevisions by
Date

Collapses all the history items listed in the hierarchical view.Collapse All

Opens the compare editor for file comparison.Compare Mode
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Outline View
TheOutline view shows a list of the nodes in the topology and their interface connections. Node connectivity
is shown through their interface connections.

Figure 17: Outline View

The Outline view toolbar contains the following tools:

Figure 18: Outline View Toolbar

Table 10: Available Tools

DescriptionFunctionIcon

Allows you to choose various options when displaying
connections:

• Hide Connections—No connections are shown.

Show Selected Connections—Displays only the
connections that are selected in theTopology Editor.

• Show Intra-Topology Connections—Displays only
the connections between the sites in the topology.

• Show Inter-Topology Connections—Displays only
the connections that are within a site.

• ShowAll Connections—Displays all the connections
for all the nodes in the topology.

ChangeDisplayMode
of Connection

Sorts and lists the node names in alphabetical order.Sort Alphabetically

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.1
24

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views



DescriptionFunctionIcon

Sorts and lists the node types in alphabetical order.Sort By Node Type

Expands nodes, interfaces, and connections in the
hierarchical view.

Expand All

Collapses all of the items in the hierarchical view.Collapse All

Palette View
The Palette view allows you to add devices and interface connections to your topology. Using the Palette
view, you can:

• Add nodes, Layer 3 external Secure Network Address Translation (SNAT) connections, and Layer 2
external (FLAT) connections to your topologies.

• Select nodes and connections for repositioning on the canvas.

• Create connections between node interfaces.
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• Group nodes into sites.

Figure 19: Palette View

The Palette view is divided into the following categories:

• Tools: Contains the Select and Connect tools. The Select tool allows you to select nodes, Layer 3
external (SNAT) connections, and Layer 2 external (FLAT) connections on theTopology Editor canvas.
The Connect tool creates connections between node interfaces.

TheFile >Preferences >Topology Editor setting affects how the nodes and connections
are placed on the canvas. If you check the Revert back to the palette's default tool
check box, you must click a node, connection, or other object each time you place an
object on the canvas. If the Revert back to the palette's default tool check box is not
checked, each time you click the canvas, an object is placed until you click the Select
tool (the default palette tool).

Note

• Nodes: Contains the node types available for use in topologies. Currently, CiscoModeling Labs, Release
1.1 includes the following:

• Cisco IOSv Software Release15.4(3)M

• Cisco IOSv Layer 2

• Ubuntu 14.04 Cloud
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Additional node subtypes can be installed separately. See Release Notes for Cisco
Modeling Labs Release 1.1 for the most up-to-date list of supported virtual images.

Note

• General: Contains the different types of connection functions that are supported for nodes. Options are:

◦Layer 3 external connections

◦Layer 2 external connections

You can also create sites.

The Palette view toolbar contains the following tools:

Figure 20: Palette View Toolbar

Table 11: Available Tools

DescriptionToolIcon

Reduces size of Palette view.Minimize

Increases size of Palette view.Maximize

Problems View
TheTopology Editor automatically detects errors, warnings, and other information displayed on the topology
elements in the Topology Editor and Node Editor. These markers can be viewed in the Problems view.
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By default, the Problems view displays all the errors and warnings for all the topologies in the Projects
view, not just the currently open topology. From the Problems view toolbar, choose ViewMenu > Show
> Errors/Warnings on Project to filter only those errors and warnings that are applicable to the current
project. Alternatively, you can also use the Configure Contents dialog box, which is accessible from the
ViewMenu option, to filter warnings and errors associated with a particular topology or topology project.

Note

Figure 21: Problems View

The Problems view groups errors and warnings by severity, with the most critical issues listed first.

Double-click the problem marker in the Problems view, which opens the appropriate editor in the Cisco
Modeling Labs client. If the problem relates to an XML file, the XML file opens in a text editor. The problem
is highlighted, allowing you to quickly identify the issue and correct it.

Figure 22: Problem Example

The Problems view toolbar contains the following tools:

Figure 23: Problems View Toolbar
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Table 12: Available Tools

DescriptionFunctionIcon

The View menu has the following options:

• Show: Displays errors and warnings.

• Group By: Groups problems under the headings Type,
Severity, and None. The default is Severity.

• Sort By: Sorts problems under the following headings:

◦Description: Details the problem encountered.

◦Resource: Displays the name of the .virl file where
the problem has occurred.

◦Path: Displays the applicable project folder.

◦Location: Displays the location in the .virl file where
the problem has occurred.

◦Type: Displays the type of problem, for example, XML
problem.

• New Problems View: Opens a new Problems view on the
workbench.

• ConfigureContents: Opens theConfigureContents dialog
box, where you can add multiple filters to the Problems
view and enable or disable them. Filters can either be
additive or exclusive. The All Errors/Warnings on
Selection filter is provided by default.

• ConfigureColumns: Opens theConfigureColumns dialog
box, where you can choose to hide or show specific
information about the problem encountered, as shown in the
Sort By option. Options are:

◦Creation Time: Displays the time when the problem
occurred.

◦Description, ID: Displays the system-generated ID
for the problem, location, path, resource, and type.

View Menu

Reduces the size of the Problems view.Minimize

Increases the size of the Problems view.Maximize
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The Quick Fix Option

Problems displayed in the Problems view are provided with a Quick Fix option if available. A quick fix is
indicated by a light bulb icon that is visible on the marker. When this option is selected, you are presented
with one or more possible fixes.

We recommend that you useQuick Fix to resolve the errors discovered unless the errors have been deliberately
created for testing purposes.

Figure 24: Quick Fix

To fix a problem:

1 Right-click the line containing the problem, and select Quick Fix.
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The Quick Fix dialog box displays a list of possible solutions.

Figure 25: Quick Fix Dialog Box

2 Select a fix from the list, and then check the check box of any of the resources listed in the Problems area.
You can click Select All to apply the quick fix to all the resources listed. Alternatively, you can click
Deselect All to clear all selections.

3 Click Finish.

Once a problem has been fixed using the Quick Fix option, the action cannot be undone.Note
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Projects View
The Projects view provides a hierarchical view of topology projects, folders, and topologies in the workbench.
From here, you can open topologies for editing or select resources for operations, such as exporting.

Figure 26: Projects View

Right-click any topology in the Projects view to open a context menu. In this context menu, you can copy,
move, and create new topology files, view comparison files, and so on.

The Projects view toolbar contains the following tools:

Figure 27: Projects View Toolbar

Table 13: Available Tools

DescriptionFunctionIcon

Collapses the hierarchy of all the resources in the Projects view.Collapse All

Links the Projects view with an active editor. A change to an
active editor automatically updates the Projects view and allows
you to toggle between the two views.

Link with
Editor

Provides options for customizing the content displayed in the
Projects view. Options are:

• Sort by filters

• Sort by content

View Menu

Reduces the size of the Projects view.Minimize
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DescriptionFunctionIcon

Increases the size of the Projects view.Maximize

The Projects view displays several icons on the toolbar:

Table 14: Projects View Icons

DescriptionNameIcon

Indicates an open topology project.Topology Project

Indicates an open folder. Folders are created within a
topology project so that topology files can be organized
into separate areas for greater accessibility.

Folder

Indicates a topology file.Topology

Properties View
The Properties view displays the names and properties of nodes and interfaces. If no specific node or interface
is selected, the Properties settings apply globally to all the nodes and interfaces within a topology. If a specific
node or interface is selected, the Properties settings apply to only that node or interface.

Figure 28: Properties View
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The Properties view toolbar contains the following tools:

Figure 29: Properties View Toolbar

Table 15: Available Tools

DescriptionFunctionIcon

Shows the available properties categories.Show Categories

Shows all advanced properties.ShowAdvancedProperties

Restores the default value for the property.Restore Default Value

Pins this properties view to the current selection.Pin to Selection

Displays menu items that allow you to:

• Open a new properties view.

• Pin the properties view to the current selection.

View Menu

Reduces the size of the Properties view.Minimize

Increases the size of the Properties view.Maximize

The properties in the Properties view are discussed in the following sections:

• Node Properties, on page 35

• Topology Properties, on page 40
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Node Properties

When you select a node on the canvas, the properties for that node are displayed in the Properties view.

Figure 30: Node Properties

Under the Node tab, you can perform the following tasks:

Table 16: Node Properties

DescriptionProperty

Specify a name for the node.
Use only alphanumeric and special characters for node names. Node names must
be unique across the entire topology. Duplicate node names cause the build to
fail when the configuration is autogenerated. If a duplicate node name is defined,
a marker is shown in the Problems view. Unicode is not supported for node
names. The use of a period in a node name may cause the node name to wrap
when viewing the hierarchy from the Cisco Modeling Labs server. When you
update a node name in the Properties >Node view, the node name is not updated
in the Node Editor.

Note
Name

Specify a subtype from the list. Cisco Modeling Labs 1.1 includes the following images
built into the Cisco Modeling Labs client:

• Cisco IOSv Software Release 15.4(3)M

• Cisco IOSv Layer 2 switch

• Ubuntu 14.04 Cloud

Additional Cisco virtual images are available for use. However, they must be installed
separately. For a list of supported subtypes, see Release Notes for Cisco Modeling Labs
1.1.

When changing a node subtype after it is initially configured using AutoNetkit,
for example, changing a Cisco IOSv subtype to a Cisco IOS XRv subtype, you
need to revalidate the AutoNetkit properties for the new node subtype.

Note

Subtype
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DescriptionProperty

Specify an IPv4 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv4

Specify an IPv6 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv6

Specify a VM image other than the default. Click Browse to choose a valid VM image
from the Select VM Image dialog box.

VM Image

Specify a VM flavor other than the default. Click Browse to choose a valid VM flavor
from the Select VM Flavor dialog box.

VM Flavor

The property Exclude Node from Simulation Launch is set on a per-node basis. When it is enabled for a
node, the node is not launched when the simulation is launched. However, the node can later be booted and
configured and automatically join a running simulation.

Under theAutoNetkit tab, when you check theAuto-generate the configuration based on these attributes
check box, the AutoNetkit generates the configuration for your topology when you click the Build Initial
Configurations icon on the toolbar.

Any preexisting configuration for a node is overwritten when you choose Build Initial Configurations
from the toolbar. Uncheck this Auto-generate the configuration based on these attributes check box
if you do not want the router configuration for a node updated by AutoNetkit.

Note

Using the properties listed, you can perform the following tasks:

Table 17: AutoNetkit Properties

DescriptionFieldsProperty

Specify the autonomous system number, which is used to infer IGP and
BGP. This can be any valid integer.

ASNGeneral

Configure an internal routing protocol. Options are:

• Not specified

• OSPF

• ISIS

• EIGRP

• RIP-V2

The default value is Not specified.

IGPIGP

Configure an OSPF area. The default value is 0.OSPF Area
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DescriptionFieldsProperty

Configure an iBGP role from the list and use it to create an iBGP topology.
Options are:

• Not specified

• Disabled

• Peer

• RR (route reflector)

• HRR(hierarchical route reflector)

• RRC(route reflector client)

The default value is Peer.

iBGP RoleiBGP

Specify the RRC as a name or number. Should be an alphanumeric string.RR Cluster

Specify the HRR cluster. Should be an alphanumeric string.HRR Cluster

In this section, users can specify their own configuration text for inclusion
in the appropriate section of the node configuration.

The following fields do not apply to external routers. Note too that
text entered is not syntactically checked, so ensure that the text is
valid.

Note

GlobalCustom
Configuration

Specify a custom configuration for the physical interfaces.Physical
Interfaces

Specify a custom configuration for loopback zero.LoopbackZero

Specify a custom configuration for OSPF.OSPF

Specify a custom configuration for IS-IS.IS-IS

Specify a custom configuration for EIGRP.EIGRP

Specify a custom configuration for RIPv2.RIP-V2

Specify a custom configuration for BGP.BGP

Specify an MPLS VPN name for VRF MPLS VPNs.VRF NameMPLS

Enable Cisco MPLS Label Distribution Protocol. Options are:

• Not specified

• True

• False

The default value is False.

LDP
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DescriptionFieldsProperty

Enable Cisco MPLS Traffic Engineering. Options are:

• Not specified

• True

• False

The default value is False.

Enable MPLS
TE

This property only applies to external
routers.

Note

Specify the IPv4 address of the remote router. Enter a valid IP address in
the correct format.

IPv4 AddressExternal
BGP

Specify an IPv6 address of the remote router. Enter a valid IP address in the
correct format.

IPv6 Address

Specify the AS number of the remote router. This is used when trying to
establish a BGP connection to a remote device. The value range is 1 to 65535.

Remote ASN

Specify the MD5 password to use to secure the BGP session to the remote
router.

MD5Password

Enable BGP multihop. When the remote router is directly adjacent (Layer
3 adjacent), this field is set to False; otherwise it is set to True.

Options are:

• Not specified

• True

• False

The default value is True.

Multihop

Specify a remote loopback IPv4 address.Remote
Loopback IPv4
Address

External
L2TPv3

Specify a local endpoint IPv4 address.LocalEndpoint
IPv4 Address

Specify a local endpoint IPv4 netmask.LocalEndpoint
IPv4 Netmask

Specify a pseudowire ID.PseudoWire ID
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DescriptionFieldsProperty

Enable IPv4 GRE tunneling. Options are:

• Not specified

• True

• False

The default value is False.

IPv4 Tunnel
Enabled

GRE
Tunnel

Specify a tunnel IPv4 address to use, which is the IP address of the far-end
node terminating the GRE tunnel itself.

Tunnel IPv4
Address

Specify a tunnel IPv4 netmask to use.Tunnel IPv4
Netmask

Enable IPv6 GRE tunneling. Options are:

• Not specified

• True

• False

The default value is False.

IPv6 Tunnel
Enabled

Specify a tunnel IPv6 address to use, which is the IP address of the far-end
node terminating the GRE tunnel itself.

Tunnel IPv6
Address

Specify a tunnel IPv6 netmask to use.Tunnel IPv6
Netmask

For this release, RIP-V2 has been added as an IGP in addition to IS-IS, OSPF, and EIGRP. You can specify
the IGP on a per-node basis, which takes precedence over the global IGP setting. Additionally, you can specify
LDP enabled/disabled per node, which allows LDP to be enabled directly, rather than only when VRFs are
specified.

Per interface you can specify a VLAN. This is specified on the destination interface and determines the VLAN
a node belongs to. This is used in the Cisco IOSvL2 configuration. See Assign VLANs for more information

Information displayed under theConfiguration tab depends on whether theAuto-generate the configuration
based on these attributes check box under the AutoNetkit tab is checked.

•When checked, AutoNetkit generates the configuration and displays it under the node's Configuration
tab.

•When unchecked, no configuration information is created for the node. You must configure the node
manually or cut and paste the existing configuration information into this area.

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Cisco Modeling Labs Corporate Edition User Guide, Release 1.1    
39

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views

Build_a___Configuration.pdf#unique_49


Topology Properties

When you select an area on the canvas other than a node, the properties for that topology are displayed in the
Properties view.

Figure 31: Topology Properties

Under the Topology tab, you can perform the following tasks:

Table 18: Topology Properties

DescriptionProperty

Specify the type of out-of-band (OOB) external network access. Options are:

• Not specified

• Private simulation network: Creates a per-simulation Linux container (LXC). The
LXC is automatically connected into the OOB management network to which all
VMs in your simulation are connected, enabling you to connect into each VM via
its management Ethernet port. This removes the need to use the console port
connection method. See the section Linux Container (LXC) for more information.

• Shared flat network: Enables OOB external network access to all devices in the
topology.

• Private project network: Enables OOB private access to all simulations running
within the user space.

Management
Network

The Nodes and Simple Connections properties are for information purposes only and are useful when
comparing the size of the topology to your current user quotas, licensing limits, or both.

In this instance, Nodes include node subtypes and FLAT and SNAT port groups.Note
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TheUse an LXCmanagement node check box is used to enable the management node as a Linux container.
See the section Linux Container (LXC) for more information.

Under the AutoNetkit tab, you can perform the following tasks:

Table 19: AutoNetkit Properties

DescriptionFieldsProperty

Enable the Cisco Discovery Protocol (CDP). Options are:

• Not specified

• True

• False

The default value is False.

Enable CDPGeneral

Enable the Cisco One Platform Kit (OnePK). Options are:

• Not specified

• True

• False

The default value is False.

Enable OnePK

Configure a routing session to use IPv4 address prefixes, IPv6
address prefixes, dual stack (includes both native IPv4 and IPv6),
or none. Options are:

• Not specified

• None

• v4

• v6

• Dual_stack

IP Address FamilyAddressing

Specify the address to use for IPv4 infrastructure address allocations.
This is the address assigned to the interface created on the router.
The default value is 10.0.0.0. Enter a valid IP address in the correct
format.

IPv4 Infrastructure
Subnet

Specify the prefix to use for IPv4 infrastructure address allocations.
The default value is 8.

IPv4 Infrastructure
Prefix

Specify the address to use for IPv4 loopback address allocations.
The default value is 192.168.0.0. Enter a valid IP address in the
correct format.

IPv4Loopback Subnet

Specify the prefix size to use for IPv4 loopback address allocations.
The default value is 22.

IPv4 Loopback Pool
Prefix
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DescriptionFieldsProperty

Specify the address to use for IPv4 VRF address allocations when
specifying the address range for MPLS VRF. The default value is
172.16.0.0. Enter a valid IP address in the correct format.

IPv4 VRF Subnet

Specify the prefix to use for IPv4 VRF address allocations. The
default value is 24.

IPv4 VRF Prefix

Specify the address to use for IPv6 infrastructure address allocations.
This is the address assigned to the interface created on the router.
The default value is 0:0:0:a::. Enter a valid IP address in the correct
format.

IPv6 Infrastructure
Subnet

Specify the prefix to use for IPv6 infrastructure address allocations.
The default value is 64.

IPv6 Infrastructure
Prefix

Specify the address to use for IPv6 loopback address allocations.
The default value is 0:0:0:b::. Enter a valid IP address in the correct
format.

IPv6Loopback Subnet

Specify the prefix size to use for IPv6 loopback address allocations.
The default value is 64.

IPv6 Loopback Pool
Prefix

Specify the address to use for IPv6 VRF address allocations when
specifying the address range for MPLS VRF. The default value is
0:0:0:c::. Enter a valid IP address in the correct format.

IPv6 VRF Subnet

Specify the prefix to use for IPv6 VRF address allocations. The
default value is 64.

IPv6 VRF Prefix

Configure routing protocols (BGP and IGP). Options are:

• Not specified

• True

• False

The default value is True.
If you specify False, there will be no router configuration for any
of the routing protocols.

Enable Routing
Protocols

Routing

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.1
42

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views



DescriptionFieldsProperty

Configure the Cisco IGP. Options are:

• Not specified

• OSPF

• ISIS

• EIGRP

• RIP-V2

The default value is OSPF.

IGP

Enable Cisco MPLS OAM for all routes on the topology. Options
are:

• Not specified

• True

• False

The default value is False.

Enable MPLS OAMMPLS

The following table shows the default IP address values used by Cisco Modeling Labs. You can update these
values as required.

Table 20: IP Address Default Values

Optional Value(s)Default ValueOptionViewed from

Not specified, None, v6,
dual_stack

v4IP Address FamilyTopology > AutoNetkit
> Addressing

Address to use.10.0.0.0IPv4 Infrastructure Subnet

Prefix to use.8IPv4 Infrastructure Prefix

Address to use.192.168.0.0IPv4 Loopback Subnet

Prefix to use.22IPv4 Loopback Pool Prefix

Address to use.172.16.0.0IPv4 VRF Subnet

Prefix to use.24IPv4 VRF Prefix

Address to use.0:0:0:a::IPv6 Infrastructure Subnet

Prefix to use.64IPv6 Infrastructure Prefix

Address to use.0:0:0:b::IPv6 Loopback Subnet
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Optional Value(s)Default ValueOptionViewed from

Prefix to use.64IPv6 Loopback Pool Prefix

Address to use.0:0:0:c::IPv6 VRF Subnet

Prefix to use.64IPv6 VRF Prefix

The following table shows the default routing protocols used by Cisco Modeling Labs. You can update these
values as required.

Table 21: Routing Protocols Default Values

Optional Value(s)Default ValueOptionViewed from

true, Not specifiedfalseEnable CDPTopology >AutoNetkit
> General

true, Not specifiedfalseEnable OnePK

false, Not specifiedtrueEnable Routing ProtocolsTopology >AutoNetkit
> Routing

ISIS, EIGRP, RIPv2, Not
specified

OSPFIGP

true, Not specifiedfalseEnable MPLS OAMTopology >AutoNetkit
> MPLS

None or any valid integer1ASNNode > AutoNetkit >
General

ISIS, EIGRP, RIPv2, Not
specified

OSPFIGPNode > AutoNetkit >
IGP

None or valid OSPF area
number

0OSPF Area

Disabled, RRC, HRR, RR,
Not specified

PeeriBGP RoleNode > AutoNetkit >
iBGP

None or alphanumeric stringNo default valueRR Cluster

None or alphanumeric stringNo default valueHRR Cluster

Specify a custom
configuration for the global
stanza.

No default valueGlobalNode > AutoNetkit >
CustomConfiguration
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Optional Value(s)Default ValueOptionViewed from

Specify a custom
configuration for the
physical interfaces.

No default valuePhysical Interfaces

Specify a custom configuration
for loopback zero.

No default valueLoopback Zero

Specify a custom
configuration for OSPF.

No default valueOSPF

Specify a custom
configuration for IS-IS.

No default valueIS-IS

Specify a custom
configuration for EIGRP.

No default valueEIGRP

Specify a custom
configuration for RIP-V2.

No default valueRIP-V2

Specify a custom
configuration for BGP.

No default valueBGP

None or alphanumeric stringNo default valueVRF NameNode > AutoNetkit >
MPLS

true, Not specifiedfalseEnable MPLS TE

false, Not specifiedtrueMultihopNode > AutoNetkit >
External BGP

true, Not specifiedfalseIPv4 Tunnel EnabledNode > AutoNetkit >
GRE Tunnel

true, Not specifiedfalseIPv6 Tunnel Enabled

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Interface Properties

In theNode Editor, selecting an interface on the canvas displays properties for the interface in the Properties
view.

Under the Interface tab, you can perform the following tasks:
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Table 22: Interface Properties

DescriptionProperty

Specify a name for the interface.Name

Specify an IPv4 interface address and an IPv4 subnet prefix length.IPv4

Specify an IPv6 interface address and an IPv6 subnet prefix length.IPv6

To delete an interface from the Node Editor canvas, select the interface, right-click, and choose Delete
from the context menu.

Note

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Connection Properties

When you select a connection on the canvas, the properties of that connection are displayed in the Properties
view.

From the Connection tab, you can associate a line style design with a connection between nodes. Line styles
are visual aids that help you identify the connections used in your topology design.

Search View
To search for text string and files, from the toolbar chooseEdit > Search. The Search dialog box is displayed.
Enter criteria for your search and click Search. The Search view displays the results of the search. A file
search can be based on text strings, regular expressions, and patterns, in addition to whole words and
case-sensitive characters. The scope of a file search can encompass a workspace, selected resources, or projects.

Text searches are only performed on expressions contained in files with the extension .virl.Note

The Search view also displays the results of a Git search, which can be based on the same criteria as noted
in a file search. However, the scope of a Git search, can encompass a particular message, resource, or
identification number in the code.
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Search criteria can be based on either a file or Git. The scope of a search can be general to all the topologies
that are defined on Cisco Modeling Labs client or specific to a particular project or file.

Figure 32: Search View

To use the search functionality, perform the following tasks:

1 From the Cisco Modeling Labs client toolbar, click Search > File.
The Search dialog box appears.

2 In the Containing text field, enter the text string to search for. The Containing text field displays a list
of recently performed searches to select from. Leave this field empty if you want to search for files only.
Check or uncheck the Case sensitive check box depending on whether a case-sensitive search is to be
performed. You can also check the Regular expression check box to enable more powerful searching
capabilities. Check theWhole word check box if you want to search for whole words that are identical
to the text string. Specify the types of files to include in the search in the File name patterns field.

3 Click Choose to open the Select Types dialog box. This dialog box provides a quick way to select from
a list of valid extensions.

4 In the Scope area, specify the files and folders to include in the search. Valid options are:

• The entire workspace.

• The currently selected resources in the workspace.

• A named working set.

• A customized group of files and folders. Use the Customize option to define the type of available
searches from the Search Page Selection dialog box.

5 Click Search to begin your search.
The Search view appears with the results of the search listed. You can click theCancel tool in the Search
view to cancel your search while it is still in progress.

The Search view toolbar contains the following tools:

Figure 33: Search View Toolbar
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Table 23: Available Tools

DescriptionFunctionIcon

Deletes all the highlighted matches from the search results.Remove Selected
Matches

Deletes all the matches from the search results.Remove All
Matches

Expands each item in the Search view.Expand All

Collapses each item in the Search view.Collapse All

Reruns the current search to retrieve previous search results or
to reflect recent changes.

Run the Current
Search Again

Cancels the search currently running.Cancel Current
Search

Browses previously conducted searches and selects a previous
search from the drop-down menu to repeat a previous search.
You can also clear the search history.

Show Previous
Searches

Pins the Search view so that subsequent search results are
displayed in a separate Search view while the pinned view
remains unchanged. This allows for a comparison of results.

Pin the Search
View

Displays the search results as a tree or a list, filters the results
using the Filters option, and sets the overall preferences for
searches using the Preferences option.

View Menu

Reduces the size of the Search view.Minimize

Increases the size of the Search view.Maximize
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Simulations View
The Simulations view displays information about all the running simulations, including:

• Name of the user running the simulation

• Name of the topology

• Number of nodes in the running simulation

• Current state of each node

Figure 34: Simulations View

Possible simulation states are:

Table 24: Simulation States

DescriptionState

Indicates that the launchworker process has successfullymade all requests
to OpenStack to deploy all simulation nodes.

ACTIVE

Indicates that a simulation has been successfully stopped and no longer
exists in the STD database.

DONE

Indicates that the simulation has just been created and is being launched.INIT

Indicates that a stop simulation request has been received.STOP

Possible node states are:

Table 25: Node States

DescriptionState

Indicates that the VM process is successful. It may take a few minutes
for the node to boot up and configure.

ACTIVE

Indicates that the VM is not currently deployed.ABSENT

Indicates that the VM is starting but the router image has not yet loaded.BUILDING
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DescriptionState

Indicates that the VM process failed.ERROR

These two states can occur when:

• The host environment is rebooted.

• The node itself shuts down.

• The operating system of the node crashes.

• The virtualization process running the node crashes.

In such instances, the appropriate action is to stop the nodes and then
start the nodes again.

All configuration changes to the nodes are
lost.

Note

PAUSED and SUSPENDED

Indicates that a request to stop the VM process has been received, without
regard to the current state of the VM.

TERMINATING

Indicates that the VM is deployed but not actually running. This state can
occur when:

• The host environment is rebooted.

• The node itself shuts down.

• The operating system of the node crashes.

• The virtualization process running the node crashes.

In such instances, the appropriate action is to stop the nodes and then
start the nodes again.

All configuration changes to the nodes are
lost.

Note

SHUTOFF

Indicates that OpenStack is unresponsive and retrieval of node states'
fails.

UNKNOWN

The Simulations view toolbar contains the following tools:

Figure 35: Simulations View Toolbar

Table 26: Available Tools

DescriptionFunctionIcon

Refreshes the list of simulations displayed in the Simulations
view.

Refresh the List
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DescriptionFunctionIcon

Reduces the size of the Simulations view.Minimize

Increases the size of the Simulations view.Maximize
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Topology Options

The following operations are available when you right-click the topology name in the Simulations view:

Figure 36: Topology Options
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Table 27: Topology Options

DescriptionOperation

Opens the Console view, showing the message stream from Cisco Modeling
Labs server for the selected topology. Message streams contain information
on the topology launch, such as the name of the launched topology, the date
and time of the launch, and the current status of each node in the topology.

Open Messages Console

Extracts all the routers' configurations to a locally saved file.
All active console connections are automatically disconnected by
Cisco Modeling Labs. All external Telnet connections to the console
ports must be closedmanually. The Stop simulation operation cannot
be selected prior to the Extract configurations operation.

Note
Extract Configurations

Stops the running simulation. See Simulate the Topology Overview for more
information on stopping and starting simulations.

Stop Simulation

Allows you to use Telnet to connect to ports on a node.Telnet

Allows you to use Telnet to connect over WebSockets to ports on a node.
WebSockets provide full-duplex communications channels over a single
connection.

Telnet over WebSocket

Closes all port connections.Close

Node Options

The following operations are available when you right-click the node name in the Simulations view:

Figure 37: Node Options
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Table 28: Node Options

DescriptionOperation

Allows you to use SSH to connect to ports on a node; this is available when the
Management Network option Private Simulation Network is selected for the
topology.

SSH

Allows you to use Telnet to connect to ports on a node.Telnet

Allows you to use Telnet to connect over WebSocket to ports on a node. WebSocket
provides full-duplex communications channels over a single connection.

Telnet over Web
Socket

Stops the selected node.Stop this Node

Starts the selected node.Start this Node

Terminal View
The Terminal view is displayed when you connect via Telnet to a node. Using the Terminal view, you can
communicate with and control the operating system running on the node.

Figure 38: Terminal View

The Terminal view toolbar contains the following tools:

Figure 39: Terminal View Toolbar

Table 29: Available Tools

DescriptionFunctionIcon

Disconnects the terminal connection to the node.Disconnect
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DescriptionFunctionIcon

Sets scrolling on and off.Scroll Lock

Allows you to select a connection from the list of
active terminal connections.

Display SelectedConnections

Closes the Terminal view.Remove Terminal

Allows you to set the font to be used in the
terminal, from the Colors and Fonts dialog box.

You can also access theColors and Fonts
dialog box by choosing File >
Preferences >General > Appearance >
Colors and Fonts.

Note

Set Terminal Font

Setting Preferences for the Cisco Modeling Labs Client
For the Cisco Modeling Labs client to operate, you must first identify certain setting preferences. These
preferences are available from the menu bar under File > Preferences:

• Node Subtypes Setting, on page 56

• Terminal Setting, on page 58

• Topology Editor Setting, on page 63

•Web Services Setting, on page 64

• AutoNetkit Visualization Setting, on page 66

•Web Browser Setting, on page 69

• Secure Storage Setting, on page 70

These are discussed in the following sections.

Node Subtypes Setting
A node subtype defines a VM running a particular operating system. For example, Cisco IOSv, Cisco IOSv
Layer 2 switch software releases, and an Ubuntu 14.4.2 LTSCloud-init image are installed with CiscoModeling
Labs 1.1. Additionally, Cisco IOS XRv Software Release 5.1.3 and Cisco CSR1000v Software Release 3.1.6
demonstration images are included in the build. Cisco ASAv Software Release 9.3.2 production image is
available to purchase separately.
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This setting allows you to add and remove node subtypes for use with the Cisco Modeling Labs 1.1 client.

See the User Workspace Management chapter in the Cisco Modeling Labs Corporate Edition System
Administrator Installation Guide, Release 1.1 for information on installing VM images on the CiscoModeling
Labs server.

Figure 40: Node Subtypes Setting

The available operations for this setting are:

Table 30: Node Subtypes Setting Operations

DescriptionOperation

Updates the local subtypes based on the currently configured CiscoModeling
Labs server. All the subtypes supported on Cisco Modeling Labs server are
available with this operation. See Fetch Node Subtypes from the Cisco
Modeling Labs Server, on page 58.

Fetch from Server

Reverts to the original list of subtypes.Restore Defaults

Applies changes.Apply
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Fetch Node Subtypes from the Cisco Modeling Labs Server
To fetch new node subtypes from the Cisco Modeling Labs server, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Fetch from Server button.

The Confirm dialog box is displayed.
Step 3 Click OK to update the list of node subtypes.

Figure 41: Fetch Node Subtypes from Server

Step 4 Click OK to finish.

The updated list of node subtypes is available for use in the Palette view.
Contact your system administrator if a specific node subtype is missing from the list, as the system administrator
is responsible for adding new node subtypes to the Cisco Modeling Labs server.

Terminal Setting
This setting allows you to launch an external terminal application, such as SecureCRT or PuTTY, or use the
internal Cisco Modeling Labs client Terminal view in a separate window.
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Note • If you are using the internal Cisco Modeling Labs Terminal view, the views are visible from both
the Design and Simulation perspectives. However, a detached view is only visible from the
perspective in which it was detached.

• If you are using an external terminal application, you must specify both Telnet and SSH run
commands. Youmust also ensure that the title format includes the percentage (%) character. Omission
of either of these requirements will impede your ability to save your setting preferences.

•When you specify to use an external terminal via File > Preferences > Terminal > Cisco Terminal
and then Telnet over WebSocket to a VM, the terminal opens internally, not externally as specified.

Figure 42: Terminal Setting

The available operations for this setting are:

Table 31: Terminal Setting Operations

DescriptionOperation

Launches the Terminal view in a separate window.Detached Internal Terminal View
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DescriptionOperation

Allows you to add a Terminal view title using the required formatting
characters.

Title Format

Uses the Cisco Modeling Labs internal Terminal view.Use Internal Terminal View

Uses an external terminal application, such as SSH or PuTTY.Use External Terminal
Application (specified below)

Specifies the Telnet command to run if you are using an external
terminal application.

Telnet Command

Specifies the SSH command to run if you are using an external terminal
application.

SSH Command

Removes settings specified for an external terminal application and
restores terminal settings to the CiscoModeling Labs internalTerminal
view.

Restore Defaults

Applies changes.Apply

Setting Up an External Terminal

This section outlines the steps involved in setting up an external terminal on Windows and OS X.

Windows

Under File > Preferences > Terminal > Cisco Terminal, update the terminal settings for connection to an
external program. For example, for a PuTTY installation, configure the putty.exe binary file as the terminal
program.

The complete PATH must be specified.Note

Table 32: PuTTY Command-Line Options

DescriptionCommand-Line Option

Opens an SSH connectionssh

Opens a Telnet connectiontelnet

Specifies the host to connect to (the Cisco Modeling Labs client will not allow an
external program to be set without having%h in the command line)

%h

Specifies the host to connect to (the Cisco Modeling Labs client will not allow an
external program to be set without having%p in the command line)

%p

For an external terminal on Windows, the commands to enter are:

• Telnet command: "C:\Program Files (x86)\PuTTY\putty.exe" -telnet %h %p

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.1
60

Using the Cisco Modeling Labs Client
Terminal Setting



• SSH command: "C:\Program Files (x86)\PuTTY\putty.exe" -ssh %h %p

The double quotes (" ") must enclose the PATH to allow the use of spaces within the PATH. Select the
Use external terminal application (specified below) radio button to use an external terminal.

Note

Figure 43: Specify an External Terminal Application for Use

The following table lists other terminal programs that can be used.

Table 33: Additional Terminal Programs

Command to UseConnection TypeTerminal
Program

"C:\Program Files (x86)\NetSarang\Xshell 4\xshell.exe"

-url telnet://%h:%p -newtab %t

TelnetXshell
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Command to UseConnection TypeTerminal
Program

"C:\Program Files\VanDyke Software\SecureCRT\SecureCRT.exe"

/T /TELNET %h %p

The /T option ensures SecureCRT creates a tab for new
sessions instead of opening a newwindow. Ensure to validate
the path of the binary.

Note

TelnetSecureCRT

OS X

The procedure is more complex on OSX since command-line parameters are not as easy to use on this platform.
Two additional components are required. These are:

• AppleScript: A program used to start applications and interact with them; some examples are open
windows, start new sessions, paste keyboard input into a session, and so on.

• /usr/bin/osascript: A built-in OS X command-line utility used to execute AppleScript and other OSA
language scripts. This is configured in the Cisco Modeling Labs client; it is essentially the glue between
the Cisco Modeling Labs client and the terminal application.

The following table lists iTerm and the built-in Terminal.app programs that can be used on OS X.

Table 34: Additional Terminal Programs for OS X

Command to UseConnection TypeTerminal
Program

/usr/bin/osascript /Users/your-user-id/iterm.scpt telnet

%h %p %t

TelnetiTerm

/usr/bin/osascript /Users/your-user-id/iterm.scpt telnet

%h %p %t

SSH

/usr/bin/osascript /Users/your-user-id/iterm.scpt ssh %h

%p %t

TelnetTerminal.app

/usr/bin/osascript /Users/your-user-id/terminal.scpt ssh

%h %p %t

SSH

The following are AppleScript scripts that are used to set up an external terminal.

iTerm
on run argv

tell application "iTerm"
activate
if current terminal exists then

set t to current terminal
else

set t to (make new terminal)
end if

tell t
launch session "Default Session"

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.1
62

Using the Cisco Modeling Labs Client
Terminal Setting



tell the current session
write text "/usr/bin/" & item 1 of argv & " " & item 2 of argv & " " & item

3 of argv
set name to item 4 of argv

end tell
end tell

end tell
end run

Terminal.app
on run argv

tell application "Terminal"
activate
-- open a new Tab - there is no method
tell application "System Events"

keystroke "t" using {command down}
end tell
repeat with win in windows

try
if get frontmost of win is true then

set cmd to "/usr/bin/" & item 1 of argv & " " & item 2 of argv & " " &
item 3 of argv

do script cmd in (selected tab of win)
set custom title of (selected tab of win) to item 4 of argv

end if
end try

end repeat
end tell

end run

Topology Editor Setting
This setting allows you to customize the Topology Editor in the Cisco Modeling Labs client.

Figure 44: Topology Editor Setting

The available operations for this setting are:
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Table 35: Topology Editor Setting Operations

DescriptionOperation

Resets the definition of the Palette view tools Select andConnect
to their default configuration. This option is disabled by default.

Revert Back to the Palette's Default
Tool

Enables the following:

•When selected, interfaces are automatically assigned to
connections between nodes.

•When deselected, you are presented with a list of available
interfaces.

Associate New Connection with
Interfaces Silently

Enables the following:

•When the number of connections in the topology exceeds
the value set in this field, the internal algorithm used to
connect nodes will not be the shortest path algorithm.

Disable Shortest Path Algorithm if
Connection Amount > (Greater than)

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

Web Services Setting
This setting allows you to configure the CiscoModeling Labs client to communicate with the CiscoModeling
Labs server. When you first launch the Cisco Modeling Labs client, the Active profile is not specified and
the web services that are listed displayUnauthorized in red. This message relates to theMaster Credentials

   Cisco Modeling Labs Corporate Edition User Guide, Release 1.1
64

Using the Cisco Modeling Labs Client
Web Services Setting



field, which must be set before the Cisco Modeling Labs client can communicate with the Cisco Modeling
Labs server.

Figure 45: Web Services Setting

The available operations for this setting are:

Table 36: Web Services Setting Operations

DescriptionOperation

Identifies an active profile that has been defined on the Cisco Modeling Labs
client. You can define a new active profile and edit or delete an existing active
profile.

Active Profile

Specifies a username and password for accessing the CiscoModeling Labs server.
These credentials are provided by the system administrator.

Master Credentials
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DescriptionOperation

Lists the web services needed for the Cisco Modeling Labs server and the Cisco
Modeling Labs client to communicate with each other. The web services listed
are:

• Roster

• Simulation Engine

• OpenStack

• AutoNetkit

After you have set up your profile with the correct base URI, each of the
web services will displayCompatible in green, indicating that the Cisco
Modeling Labs client can communicate with the Cisco Modeling Labs
server.

Note

Web Services

Encrypts passwords and stores them locally on the Cisco Modeling Labs client.
To change the settings for managing the encrypted passwords, choose File >
Preferences >General > Security > Secure Storage. See Secure Storage Setting,
on page 70 for more information.

Store Encrypted
Passwords in System's
Secure Storage

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

AutoNetkit Visualization Setting
The AutoNetkit visualization feature is available only when node configurations are built using the parameters
defined in AutoNetkit. If AutoNetkit visualization is turned off, you cannot get a true representation of your
topology.

AutoNetkit visualization is used to determine how AutoNetkit presents graphical representations of
topology-specific attributes, such as nodes, links, and interfaces, during the build phase. The graphical
representations can be presented as a physical perspective of a network topology or based on a protocol
perspective.

For AutoNetkit visualization to operate, the Cisco Modeling Labs client must be connected to the Cisco
Modeling Labs server. The nodes in the network topology must be set to open AutoNetkit visualization either
automatically or after receiving a prompt.
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To access this setting, choose File > Preferences >Web Services > AutoNetkit Visualization.

Figure 46: AutoNetkit Visualization Setting

The available operations for this setting are:

Table 37: AutoNetkit Visualization Setting Operations

DescriptionOperation

Specifies the external web browser to use when displaying AutoNetkit
visualization results. Options are:

• Default: The default system browser

•WebKit: Based on the Safari web browser

•Mozilla

You are required to useMozilla Firefox, Google Chrome, or Apple
Safari as your default web browser. Internet Explorer is not
supported for AutoNetkit visualization or for theUserWorkspace
Management interface.

Note

Preferred Web Browser
Engine
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DescriptionOperation

Specifies whether to view configuration changes after a new build is
generated. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

View Configuration Changes

Specifies when to open a browser window to display AutoNetkit
visualization. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

Open AutoNetkit
Visualization

Assigns a port value to the web service supporting AutoNetkit visualization.
The default port is 19401. However, the port might need to be changed
depending on your network, for example, if a firewall is blocking that port.
The port value should be provided by the system administrator.

If an incorrect port value is entered, you will be prompted with an
error during the build stage.

Note

Visualization Port

Restores the default state for the preferred web browser engine and restores
the default port value assigned to AutoNetkit visualization.

Restore Defaults

Applies changes.Apply
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Web Browser Setting
This setting allows you to add, remove, or edit installed browsers. The selected browser is used by default
when web pages are opened in the Cisco Modeling Labs client for AutoNetkit visualization.

Figure 47: Web Browser Setting

The available operations for this setting are:

Table 38: Web Browser Setting Operations

DescriptionOperation

Allows you to use an internal web browser built into the Cisco Modeling
Labs client to view AutoNetkit visualization.

Use Internal Web Browser

Allows you to use an external web browser. You can add new browsers,
delete or edit existing browsers, or search for new browsers to use.

You are required to use Mozilla Firefox, Google Chrome, or Apple
Safari as your default web browser. Internet Explorer is not supported
for AutoNetkit visualization or for the User Workspace
Management interface.

Note

Use External Web Browser

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply
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Secure Storage Setting
This setting configures security preferences and encryption requirements for storing system passwords.

Figure 48: Secure Storage Setting

The Password tab pools functionality related to the master password life cycle and password providers.

The available options are:

Table 39: Password Tab Options

DescriptionOption

Clears cached master passwords from memory.Clear Passwords
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DescriptionOption

Lists the currently available password providers. By default, the enabled
provider with the highest priority is used to encrypt the data added to secure
storage. The priority range is from 0 to 10, with 10 being the highest priority.

Data can only be decrypted by the same provider that encrypted the
data. By default, all password providers are enabled. Each password
provider that has been used at least once will have a master password
associated with it. The Details text box provides information on the
master password providers.

Note

Master Password Providers

Changes the master password of the selected password provider.Change Password

Opens the Password Recovery dialog box. Use this option if you have
forgotten the master password and have configured password recovery
questions. The button is disabled if the password recovery setup was cancelled
when the master password was created.

The answers for the password recovery questions must be entered
exactly as they were during the password recovery setup. Answers
are case sensitive, and white space inside answers are relevant.

Note

Recover Password

Restores to the initial default state.Restore Defaults

Applies changes.Apply

The Contents tab displays contents of the default secure storage. Secure storage is organized as a tree, where
nodes represent the context of information and values associated with each node. Selecting a node in the tree
displays a table of values associated with that node. Values stored in a nonencrypted form will be displayed;
the encrypted values will be shown as *********. At the bottom of this tab, you will find the actual file
location used to persist secure storage data. To force the changes to the contents of secure storage to be saved,
click Save.

To delete stored data in order to recover from an error or to reflect a change in the setup, click Delete. This
deletes the contents of secure storage. In some cases, other parts of the applicationmay depend on the contents
of secure storage that you deleted.

To avoid unexpected errors, we recommend that you restart the application after secure storage has been
deleted.

Caution

TheAdvanced tab provides a list of algorithms to further configure secure storage. Changes in the encryption
algorithm are applied only to the data stored after a change. If you have already created a secure storage, you
must first delete it and then recreate it to use the newly selected encryption algorithm.

Resetting the Secure Storage Password
When the Secure Storage feature is used for the first time, it generates a master password that is used to encrypt
the data. In the future, this same master password will be required to retrieve the data from secure storage. If
the master password becomes unavailable, the Secure Storage feature provides optional support for password
recovery.

Two methods are used to reset the password for the secure storage feature.

Method 1
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1 From within Cisco Modeling Labs client, choose File > Preferences > General > Security > Secure
Storage.

2 Click Change Password. The Secure Storage dialog box appears.
3 Click Yes. The Password Recovery dialog box appears.
4 Enter details in both Question fields and provide answers for both questions. Take note of the answers

you provide, as these are treated as secondary passwords.
5 Click OK.

Method 2

If you are unable to access the Cisco Modeling Labs client due to a lost or forgotten password for the secure
storage feature, complete the following steps:

1 Move to the <user-home>/.eclipse/org.eclipse.equinox.security folder.
2 Delete the file secure_storage.
3 Open Cisco Modeling Labs client to provide details for the password for the secure storage feature when

prompted.
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