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1  About This Guide
This Cisco Service Control Usage Analysis and Reporting Solution Guide provides:

• An overview of the Cisco Service Control solution and the advantages that it can provide when monitoring and analyzing 
network use.

• An overview of the Cisco Service Control Application (SCA) Reporter.

• An introduction to using the SCA Reporter to create reports based on network bandwidth use that allow you to understand 
how subscribers are using your network.

2  Solution Overview
The goal of Usage Analysis is to identify the manner in which network resources are used to save operational costs and generate 
new revenue streams that reflect the established business model. The Cisco Service Control solution gives Service Providers an 
effective means of gaining true visibility into subscriber activity and usage patterns of complex network environments.

The Cisco Service Control solution provides the following advantages:

• Deep packet inspection reconstructs traffic semantics up to layer-7 protocol information, classifies traffic to end-application 
(file sharing the over the top (OTT) video, browsing, VoIP, gaming) even for port-hopping or multi-flow applications

• Subscriber aware traffic processing monitors traffic at a per-subscriber, group, or global level

• Actionable and meaningful usage statistics

• Traffic inspection and usage export without any impact on existing network performance

• Transparent deployment in either Cisco or third-party networks. The Cisco Service Control solution can be installed inline 
or receive-only.

The Cisco Service Control solution:

• Allows you to identify network activity, control subscriber and application traffic, and to perform traffic management 
service creation. 

• Provides a granular classification and control engine that provides key, actionable data on network activities.

• Consists of the Service Control Engine (SCE), Service Control Application for Broadband (SCA BB), Collection Manager, 
and Service Control Application (SCA) Reporter components.

When the solution is installed:

1. The SCE creates raw data records (RDRs) that contain the raw information about network use

2. The Collection Manager collects the RDRs into a database

3. The SCA Reporter (as part of the SCA BB console or as a standalone application) queries the Collection Manager database 
to produce reports

For more information, see the Cisco Service Control Product Overview.

3  Using the SCA Reporter
This chapter describes how to use the SCA Reporter to produce meaningful reports that highlight network use by services and 
subscribers.

Service Control Application Reporter
The Cisco SCA Reporter is the Cisco Service Control Application tool that allows you to produce reports based on the traffic 
analysis performed by the SCE platform. The information is sent from the SCE platform and is stored in a database. The SCA 
Reporter can query and retrieve information from the database and present the results in a comprehensive range of reports, 
including global monitoring, subscriber monitoring, file sharing and OTT video, and traffic discovery statistics reports.
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Prerequisites
Before proceeding, ensure that the following prerequisites are met:

• The SCE platform, SCA BB Console, SCA Reporter, and Collection Manager are all installed. For details, see the Cisco 
Service Control Product Installation Guide.

• The SCE is processing traffic.

• The Collection Manager is set up and collecting RDRs.

• The SCA Reporter is connected to the Collection Manager database.

Initial Reports
Several categories of reports are available. However, this chapter focuses on the following reports which provide a 
comprehensive view into all of the bandwidth used by applications, subscribers, and services:

• Global Monitoring reports—The report used is the Global Bandwidth per Service report. This report provides information 
about how much bandwidth is consumed by applications and can be used to view bandwidth use by particular groups of 
applications.

• Demographic Data and Service Popularity reports—The reports used are:

– Global Active Subscriber per Service which shows the distribution of subscribers among the different services defined 
in the system for all traffic, regardless of subscriber or package.

– Relative Consumption of Top Subscribers which shows the relative consumption of a specific number of subscribers 
compared to other subscribers.

• Subscriber Monitoring reports—The reports used are

– Top Subscriber report which shows a list of the top subscriber volume consumption in a specific hour or day.

– Subscriber Bandwidth per Service which shows the relative consumption of services by a specific subscriber.

• Web and Streaming reports and Traffic Discovery - Statistics reports—The report used are:

– Top Web Hosts report. This report provides information about which sites are most popular among the subscriber base.

– Top Service Ports report which shows the most popular server ports of a certain service or services.

• VoIP reports—The reports used are:

– Top Talkers report which shows the consumption of volume, sessions, or minutes by the top talkers in a specific hour 
or day for a specific VoIP service.

– Global VoIP MOS report which shows the global VoIP quality estimation; that is, the Mean-Opinion-Score (MOS).

– Global VoIP MOS Distribution report which shows the distribution of the global VoIP quality estimation.

– Global VoIP Codec Distribution report which shows the distribution of the VoIP codecs in use.

• Malicious Traffic Reports—The report used is the Top Scanned or Attacked ports which shows the top scanned or attacked 
ports.

Starting the Reporter and Generating Reports

Step 1 Start the SCA BB Console by choosing Start > All Programs > Cisco SCA > SCA BB Console 3.5.5 > SCA BB Console 
3.5.5.

The Cisco Service Control SCA BB Console splash screen appears. After the Console has loaded, the main window of 
the Console appears.

Step 2 From the Console main menu, choose Tools > Reporter.

The Reporter opens and the Templates tab appears.
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Global Monitoring
The Global Monitoring group of reports are the most commonly used and provide a starting point for monitoring bandwidth 
use on the network. To monitor bandwidth per service you use the Global Bandwidth per Service report template. A Global 
Bandwidth per Service report shows which applications are going through network and how much bandwidth they are using.

Creating a Global Bandwidth per Service Report

Step 1 Open the SCA Reporter. See Starting the Reporter and Generating Reports, page 3.

Step 2 In the Templates view, expand the Global Monitoring group.

Step 3 Double-click Global Bandwidth per Service.

The New Report Wizard window appears (Figure 1), allowing you to configure the new report.

Figure 1 New Report Wizard

Step 4 Click Finish. The report appears along with all of the services listed in the Hierarchy tab as shown in Figure 2.
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Figure 2 Global Bandwidth per Service Report

Viewing Reports by Popularity of Service

By default, reports are generated and displayed based on the configured services tree. However, it is often useful to view the 
report based on the popularity (that is, the amount of bandwidth consumed) of the services.

Step 1 Create a Global Bandwidth per Service report. See the “Creating a Global Bandwidth per Service Report” section on 
page 4.

Step 2 To view the services by popularity, on the Hierarchy tab, click  (Based on service popularity).

The report is redrawn to show the services based on their popularity as shown in Figure 3.
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Figure 3 Global Bandwidth per Service by Popularity

To expand a service, click expand next to the service name in the Hierarchy tab. The report is redrawn to show all 
services that were used over the report time period, based on their popularity as shown in Figure 4.
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Figure 4 Global Bandwidth per Service by Popularity Over Time Period

Viewing File Sharing Bandwidth Use

You can use the reporter to drill down and view a particular group of services and see the quantity of bandwidth consumed.

Note You can use this procedure to view the bandwidth used by any group of service (for example, Internet Video or 
Gaming).

Step 1 Create a Global Bandwidth per Service report. See the “Creating a Global Bandwidth per Service Report” section on 
page 4.

Step 2 On the Hierarchy tab, click  (Based on service popularity).

Step 3 Uncheck all of the group check boxes, but leave the File Sharing check box checked. The report appears showing only 
the File Sharing bandwidth use as shown in Figure 5.
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Figure 5 Global Bandwidth per Service—File Sharing Only

Step 4 To view the report showing each of the File Sharing services, click the File Sharing expand button.

The report shows each of the File Sharing services that consumed bandwidth during the report time period as shown in 
Figure 6.
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Figure 6 Global Bandwidth per Service—File Sharing Services

Monitoring Demographic Data
Use the Demographic Data and Service Popularity reports to view statistics of the demographic data. The Global Active 
Subscriber per Service report shows the distribution of subscribers among the different services defined in the system for all 
traffic, regardless of subscriber or package. The Relative Consumption of Top Subscribers report shows the relative 
consumption of a specific number of subscribers compared to other subscribers.

Creating a Global Active Subscriber per Service Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the Demographic Data and Service Popularity group.

Step 3 Double-click Global Active Subscriber per Service. The New Report Wizard dialog box appears allowing you to 
configure the new report.

Step 4 Click Finish.

The report appears showing the number of active subscribers and the number of total subscribers for the time period 
specified as shown in Figure 7.
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Figure 7 Global Active Subscribers per Service

Creating a Relative Consumption of Top Subscribers Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the Demographic Data and Service Popularity group.

Step 3 Double-click Relative Consumption of Top Subscribers. The New Report Wizard dialog box appears, allowing you to 
configure the new report.

Step 4 In the Specific Time row, click the right column and click the Browse button that appears. A calendar appears.

Step 5 Choose a date and time that contains the traffic for which you want to produce a report.

Step 6 Click OK.

Step 7 Click Finish.

The report appears showing the consumption of the top subscribers compared to the consumption of the other 
subscribers as shown in Figure 8.
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Figure 8 Relative Consumption of Top Subscribers

Monitoring Subscribers
Use the Subscriber Monitoring group of reports to view statistics about the bandwidth or volume of traffic used by subscribers. 
The reports are provided per service usage counter for the total volume consumed by subscribers. The Top Subscribers report 
identifies the subscribers that consume the largest traffic volume. The Subscriber Bandwidth per Service report shows the 
bandwidth used for each service by a specific subscriber.

Creating a Top Subscribers Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the Subscriber Monitoring group.

Step 3 Double-click Top Subscribers. The New Report Wizard dialog box appears, allowing you to configure the new report.

Step 4 In the Specific Time row, click the right column and click the Browse button that appears. A calendar appears.

Step 5 Choose a date and time that contains the traffic for which you want to produce a report.

Step 6 Click OK.

Step 7 Click Finish.

The report appears showing the top subscribers for the time specified as shown in Figure 9.
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Figure 9 Top Subscribers for Specified Time Period

Enabling Subscribers for Real-Time Monitoring

It is possible to enable the generation of real-time subscriber usage RDRs to allow you to produce reports for a specific 
subscriber using the SCE command line interface.

The following example shows how to enable the generation of the real-time subscriber usage RDRs for subscriber jane_smith.

SCE> enable 10
Password:<cisco>
SCE# config
SCE(config)# interface linecard 0
SCE(config if)# subscriber name jane_smith property name monitor value 1
SCE(config if)#

Creating a Subscriber Bandwidth per Service Report

After enabling a subscriber for real-time monitoring, you can product reports specific to that subscriber.

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In Templates view, expand the Subscriber Monitoring group.

Step 3 Double-click Subscriber Bandwidth per Service. The New Report Wizard dialog box appears, allowing you to configure 
the new report.

Step 4 In the Name of subscriber to focus on row, click the right column and enter the subscriber ID of the subscriber you wish 
to view.

Step 5 Click Finish.

The report appears showing the bandwidth consumed by the services used by the specified subscriber as shown in 
Figure 10.
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Figure 10 Subscriber Bandwidth per Service

Monitoring Top Sites and Service Ports
Use the Web and Streaming group of report templates to compile statistics presenting the most popular servers or hosts for the 
various predefined system services (such as browsing, streaming, and downloading) and for user-defined services. The Top Web 
Hosts report shows which are the most popular web hosts among the subscriber base.

The Traffic Discovery - Statistics group of report templates allows you to view statistics compiled from the source and 
destination IP addresses and ports of the system traffic. The Top Service Ports report shows the most popular server ports of a 
certain service or services.

Creating a Top Web Hosts Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the Web and Streaming group.

Step 3 Double-click Top Web Hosts. The New Report Wizard dialog box appears allowing you to configure the new report.

Step 4 Click Finish.

The report appears along with all of the web hosts listed in the Hierarchy tab as shown in Figure 11.
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Figure 11 Top Web Hosts

Creating a Top Service Ports Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the Traffic Discovery - Statistics group.

Step 3 Double-click Top Service Ports. The New Report Wizard dialog box appears, allowing you to configure the new report.

Step 4 Click Finish.

The report appears in table format listing the top services, the ports used by the top services, and the volume of traffic 
used by the services as shown in Figure 12.
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Figure 12 Top Service Ports

Monitoring VoIP Use
The VoIP group of reports allow you to view statistics of the VoIP traffic.

• Top Talkers report—Shows the consumption of volume, sessions, or minutes by the top talkers in a specific hour or day for 
a specific VoIP service.

• Global VoIP MOS report—Shows the global VoIP quality estimation.

• Global VoIP MOS distribution report—Shows the distribution of the VoIP quality estimation.

• Global VoIP Codec distribution report—Shows the distribution of the VoIP codecs being used.

Creating a Top Talkers Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the VoIP group.

Step 3 Double-click Top Talkers. The New Report Wizard dialog box appears, allowing you to configure the new report.

Step 4 In the Items to Focus on property group, choose the service on which the report focuses.

Step 5 In the Specific Time row, click the right column and click the Browse button that appears. A calendar appears.

Step 6 Choose a date and time that contains the traffic for which you want to produce a report.

Step 7 Click OK.

Step 8 Click Finish. The report appears showing the top talkers for the time period and service chosen (Figure 13).
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Figure 13 Top Talkers

Creating Global VoIP MOS Reports

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the VoIP group.

Step 3 To create a Global VoIP MOS report, double-click Global VoIP MOS. The New Report Wizard dialog box appears, 
allowing you to configure the new report.

Step 4 Click Finish.

The report appears showing the global VoIP quality estimation (Figure 14).
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Figure 14 Global VoIP MOS

Step 5 To create a Global VoIP MOS distribution report, double-click Global VoIP MOS Distribution. The New Report 
Wizard dialog box appears, allowing you to configure the new report.

Step 6 Click Finish.

The report appears showing the global VoIP quality estimation distribution (Figure 15).
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Figure 15 Global VoIP MOS Distribution

Creating a Global VoIP Codec Distribution Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the VoIP group.

Step 3 Double-click Global VoIP Codec Distribution. The New Report Wizard dialog box appears, allowing you to configure 
the new report.

Step 4 Click Finish.

The report appears showing the distribution of VoIP codecs being used (Figure 16).
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Figure 16 Global VoIP Codec Distribution

Monitoring Malicious Traffic
The Malicious Traffic group of report templates allows you to view statistics of the malicious events accrued in the system. The 
Top Scanned or Attacked Ports report shows the top scanned or attacked ports.

Creating a Top Scanned or Attacked Ports Report

Step 1 Open the SCA Reporter. See the “Starting the Reporter and Generating Reports” section on page 3.

Step 2 In the Templates view, expand the Malicious Traffic group.

Step 3 Double-click Top Scanned or Attacked Ports. The New Report Wizard dialog box appears, allowing you to configure 
the new report.

Step 4 Click Finish.

The report appears showing the top scanned or attacked ports (Figure 17).
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Figure 17 Top Scanned or Attacked Ports

4  Useful SCA Reporter Tools
The SCA Reporter contains features that allow you to:

• Zoom in and zoom out of the report

• View chart tool tips

• Edit chart colors

• Export the reports to various formats

Zooming In and Out of Charts

Zooming in on a 2-Dimensional Chart

Step 1 Generate a report. A report view opens displaying the report, and the Properties view displays the chart display 
properties.

Step 2 To display the chart in two dimensions, click the 3D property. The value of the 3D property toggles from True to False 
and the Look/3D category is removed from the Properties view.

Step 3 Mark off a rectangle by dragging the mouse over the chart. The cursor changes to a plus icon.

Step 4 Release the mouse button. The view zooms in.
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Zooming Out of a Zoomed-In Chart

Step 1 Mark off a rectangle by dragging the mouse over the chart while pressing the Shift key. The cursor changes to a minus 
icon.

Step 2 Release the mouse button. The view zooms out.

Managing Report Output
You can manage report output in several ways:

• You can print, send by email, or export reports to PDF format.

• You can save charts to a number of graphic formats.

• You can save tables to CSV or Quoted CSV formats, which you can open as spreadsheets.

• You can print, send, or export multiple reports in one send operation.

Printing Reports

Step 1 After you execute one or more report instances, choose File > Print Reports. The Print Reports wizard opens as shown 
in Figure 18.

Figure 18 Print Reports Wizard

Step 2 Select one or more format for each report you are printing.

Step 3 Click Finish. The selected reports print in the format or formats you chose.
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Note For PDF and CSV formats, the print feature uses the desktop interface and only prints if the associated application 
can print from the desktop. If you can print from the desktop without opening the application, the print feature 
works.

Note If you selected several reports to print, the application may freeze for several moments while sending the reports to 
the printer.

Sending Reports by Email

Step 1 After executing one or more report instances, choose File > Send Reports. The Send Reports wizard opens as shown in 
Figure 19.

Figure 19 Send Reports Wizard

Step 2 Select one or more format for each report you want to send.

Step 3 Click Finish. An email message opens from the default email application installed on the desktop, with the selected 
reports attached.
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Exporting Reports

Step 1 After you execute one or more report instances, choose File > Export.

The Export wizard appears as shown in Figure 20.

Figure 20 Export Wizard

Step 2 Select one of the following:

• Export chart to an image file

• Export report to a PDF file

• Export table to a CSV file

Step 3 Click Next.

The Tables and Destination page of the Export wizard opens as shown in Figure 21.
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Figure 21 Charts and Destination Window

Step 4 Check the checkbox for one or more of the Available reports.

Step 5 (Optional) To change the Output folder, click Browse.

Step 6 Do one of the following:

• If you chose Report in Step 2, go to Step 8.

• If you chose Chart or Table in Step 2, click Next.

The Format page of the Export wizard opens. (The display depends on whether you chose Chart or Table in Step 2.)

Step 7 Enter the required information. Do one of the following:

• For Chart

– From the File type drop-down list, choose a file type.

– In the Image width and Image height fields, enter values in pixels.

• For Table

– From the File type drop-down list, choose a file type.

– (Optional) Uncheck Open the exported CSV file in the system's default CSV editor.

Step 8 Click Finish. Each report selected is saved in a separate file.
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Setting the Colors Used in Charts
Predefined colors are packaged within the SCA BB Templates package. Instead of using the default color set for charts that is 
installed as part of the Reporter installation, you can define your own color sets.

This allows you to ensure color persistence between different sessions of the Reporter, including:

• Different sessions of the same Reporter installation

• Different Reporter installations using data from the same SCE platform, by exporting and importing color files

• Different Reporters using data from different SCE platforms

• Different versions of the Reporter

Changing the Color of Legend Items

Step 1 From the main menu, choose Preferences > Reporter. The Preferences dialog box appears.

Step 2 In the Preferences tree, choose Reporter > Charts Colors. The Charts Colors preference page opens.

Step 3 Select a legend item from the color tree.

Note Possible categories of legend items are Direction, Hostname, Host IP, Protocol, MOS, Range, Codec, Port Number, 
Newsgroup, Protocol, Service, Measure, and Subscriber.
Categories and legend items are only displayed in the Charts Colors pane after colors are allocated to legend items. 
Colors are allocated to any legend items in the chart the first time a report instance is executed.

The current color of the legend item appears in the upper right of the Charts Colors pane.

Step 4 Click the displayed color. A color palette dialog box appears.

Step 5 Select a new color for the legend item and click OK. The Color dialog box closes.

The selected color is applied to the legend item.

Step 6 Click OK.
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Viewing Chart Tool Tips

Step 1 From an open chart, hover your mouse over the chart. A tool tip appears with information about the chart; specifically, 
information about the location over which the mouse is placed as shown in Figure 22.

Figure 22 Global Bandwidth per Service—Tool Tip

5  Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional information, see the 
monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be 
delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS 
Version 2.0. 
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