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Getting Started  

The Cisco Service Control Application Reporter (SCA Reporter) is the Cisco Service Control 
Application tool that allows you to produce reports based on the traffic analysis performed by the Service 
Control Engine (SCE) platform. The information is sent from the SCE platform and is stored in a 
database. The SCA Reporter can query and retrieve information from the database and present the results 
in a comprehensive range of reports, including global monitoring, subscriber monitoring, P2P, and traffic 
discovery statistics reports.

• System Components, page 2-1

• System Requirements, page 2-2

• Installing the SCA Reporter under Windows, page 2-2

• Installing the SCA Reporter under Linux, page 2-6

• How to Launch the SCA Reporter, page 2-7

• Configuring the SCA Reporter, page 2-8

• Online Help, page 2-21

• Quick Start, page 2-22

System Components 
The SCA Reporter is a valuable tool for understanding the habits and resource consumption of the 
applications and subscribers that use your network. It can also be used to judge the efficacy of various 
rules and the possible impact of their implementation on the network.

The SCA Reporter is available only in a deployment with a database. You can generate reports using any 
of the following methods:

• Standalone application

• Command-line interface (CLI)—See The SCA Reporter Command-Line Interface, page 6-1

• Tool of the SCA BB Console—See SCA Reporter as a Tool in the SCA BB Console, page C-1

The available reports can be displayed in a variety of chart renderings (for example, stacked-bar or area) 
or in tabular form. You can adjust the chart display for various presentation options (for example, 3D). 
You can export both tabular and chart reports to files. You can also modify the reports by changing the 
values assigned to the properties (for example, time boundaries). You can duplicate, export, and save 
reports.

You can also generate reports using the SCA Reporter Command-Line Interface (CLI) without using the 
GUI.
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SCA Reporter consists of visual components (known as views). The following are the views and the tasks 
that you can perform in each view:

• Templates view—Select a report template, create a new report instance, and generate a report.

• Properties view—View properties of the object in focus and their values. The object in focus can be 
a template group, a report template, a report instance, or the chart display of a report. You can 
configure report instance and chart display properties.

• Report view—View a graphical representation or tabular display of the data of the report. Each 
report is displayed in its own report view.

• Progress view—Monitor reports executed or exported. You can view progress details in this view, 
and also choose to generate reports in the background so that you can continue working on other 
reports.

Generating a report can be divided into five broad steps:

1. Create a report instance from the Templates view.

2. Configure the properties of the report instance in the Properties view.

3. Execute the report instance.

4. View the report in tabular or graphic form in its report view.

5. Adjust the chart display of the report in the Properties view.

You can generate multiple reports simultaneously and later export them. While the reports are executing, 
you can monitor them and put them in the background by using the Progress view.

System Requirements 
You can install and run the SCA Reporter GUI front end and command-line application on any computer 
running Windows 2000 or Windows XP.

You can install the SCA Reporter command-line application for Linux on any computer running Red Hat 
Enterprise Linux 4.

The computer should have a minimum of 512 MB of memory; 1024 MB of memory is highly 
recommended.

Minimum screen resolution is 1024 by 768 pixels.

Installing the SCA Reporter under Windows 
• How to Install the SCA Reporter under Windows, page 2-3

• How to Uninstall the SCA Reporter under Windows, page 2-5
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How to Install the SCA Reporter under Windows 

Step 1 Navigate to the SCA Reporter installation file, SCA Reporter 3.1.7 Setup.exe, and double-click it.

The Welcome page of the SCA Reporter 3.1.7 Setup wizard appears.

Step 2 Click Next.

The Install Location page of the Setup wizard opens.
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Step 3 (Optional) Click Browse to choose a different destination folder.

Step 4 Click Next.

The Start Menu Folder page of the Setup wizard opens.

Step 5 (Optional) Enter a different Start Menu folder in the Start Menu Folder field.

Step 6 Click Install.

The Installing page of the Setup wizard opens.
2-4
Cisco Service Control Application Reporter User Guide

OL-8411-07



Chapter 2      Getting Started
  Installing the SCA Reporter under Windows
Step 7 Wait until installation is complete.

The Installation Complete page of the Setup wizard opens.

Step 8 Click Finish.

The SCA Reporter 3.1.7 Setup wizard closes.

The SCA Reporter is now installed on the machine.

How to Uninstall the SCA Reporter under Windows 

Step 1 Choose Start > All Programs > Cisco SCA > SCA Reporter 3.1.7 > Uninstall.

Step 2 Click Yes.
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Step 3 Click OK.

The SCA Reporter is uninstalled from the machine.

Installing the SCA Reporter under Linux 
You can install the SCA Reporter under Linux, and then run it from the command line. (See The SCA 
Reporter Command-Line Interface, page 6-1.)

• How to Install the SCA Reporter under Linux, page 2-6

• How to Uninstall the SCA Reporter under Linux, page 2-6

How to Install the SCA Reporter under Linux 

Step 1 Download the SCA BB installation package (reporter-cmd-linux.tgz) from the CCO.

Step 2 Open the installation package in a selected directory, using the command tar xpzf 
reporter-cmd-linux.tgz.

Step 3 From the installation directory, run the command reportercmd.sh –setup.

How to Uninstall the SCA Reporter under Linux  

Step 1 Delete the installation directory.
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How to Launch the SCA Reporter 
You can access the SCA Reporter from the Start menu.

Step 1 Choose Start > All Programs > Cisco SCA > SCA Reporter 3.1.7 > SCA Reporter 3.1.7.

The Cisco Service Control SCA Reporter splash screen appears.

After the SCA Reporter has loaded, the main window of the SCA Reporter appears, displaying the 
Welcome view.

Step 2 Close the Welcome view.

The Templates view is displayed.
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Configuring the SCA Reporter 
You must create a basic configuration for the SCA Reporter, which includes selecting a database type, 
connecting to a database, activating the database, and setting the IP address of the Service Control 
Engine (SCE) platform whose service configuration data is to be used.

In bundled mode, the Cisco Service Control Management Suite (SCMS) Collection Manager (CM) is 
used with the Sybase Adaptive Server Enterprise (Sybase ASE). The Sybase data management platform 
supports transaction-intensive enterprise applications. It enables you to store and retrieve information 
online and can warehouse information as needed. (For more information, see the Cisco Service Control 
Management Suite Collection Manager User Guide.) The CM can also be configured to work with 
Oracle and MySQL databases.

After a database is activated, you must select the IP address of one of the SCE platforms in the database. 
The choice is made for each repository, represented by a tab in the Preferences dialog box. All options 
offered in the Templates view of the SCA Reporter (available packages, services, etc.) are determined 
by the service configuration currently applied to the configured SCE platform. Each report is generated 
according to the SCE device to which it is configured. In the example configuration, there is one SCE 
device connected to the database and one repository preference.

• Managing Database Connections, page 2-9

• How to Set the IP Address of an SCE Platform, page 2-12

• How to Set the Colors Used in Charts, page 2-14
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• How to Configure the Legend Displayed in Charts, page 2-19

• How to Configure Advanced Options for the SCA Reporter, page 2-20

Managing Database Connections  
To use the SCA Reporter, you must create and activate a connection to a database containing data 
generated from an SCE platform.

You can add connections to a number of databases, and then change the active database as required.

• How to Add a Database Connection, page 2-9

• How to Activate a Database Connection, page 2-12

How to Add a Database Connection  

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 From the Preferences tree, select Reporter > Databases.

Step 3 In the Databases pane, click Add.

The Add Database wizard appears.
2-9
Cisco Service Control Application Reporter User Guide

OL-8411-07



Chapter 2      Getting Started
  Configuring the SCA Reporter
Step 4 Select one of the Choose definition mode radio buttons.

• Simple 

• Advanced 

Step 5 Click Next.

The Define new database connection page of the Add Database wizard opens. The actual display depends 
on the definition mode you selected in Step 4:

• If you selected Simple definition mode:
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• If you selected Advanced definition mode:

Step 6 Fill in all the fields.

Step 7 (Optional) Check the activate this database check box.

Step 8 Click Finish.

The Add Database wizard closes.

The definition of the database is added to the list in the Preferences dialog box.

Step 9 Click OK.

The Preferences dialog box closes.
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How to Activate a Database Connection 

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 From the Preferences tree, select Reporter > Databases.

All defined database connections are listed in the table.

The currently active database (if any) is shown by a check mark ( ).

Step 3 Select the database connection you wish to activate.

Step 4 Click Activate.

Step 5 Click OK.

The Preferences dialog box closes.

How to Set the IP Address of an SCE Platform  

Note The Preferences dialog box contains one tab for each repository (set of templates) that is available in the 
Reporter. In each, you choose one SCE platform. If there is more than one repository, there will be more 
than one set of template groups in the Templates view.

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Templates.
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Step 3 In the Templates pane, from the IP of SCE for policy data drop-down list, select the IP address of the 
SCE platform whose service configuration data is to be used in reports. This IP address is added to the 
SCA Reporter templates repository.

Step 4 Click Apply.

The IP address of the SCE platform is set for service configuration data.

Note You must click Apply before you close the dialog box by clicking OK.

Step 5 Click OK.

The Preferences dialog box closes.
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How to Set the Colors Used in Charts  
Instead of using the default color set for charts that is installed as part of the Reporter installation (the 
predefined colors are packaged within the SCA BB Templates package), you can define your own color 
set(s).

This allows you to ensure color persistence between different sessions of the Reporter, including:

• different sessions of the same Reporter installation

• different Reporter installations using data from the same SCE platform, by exporting and importing 
color files

• different Reporters using data from different SCE platforms

• different versions of the Reporter

• How to Work with Color Sets, page 2-14

• How to Change the Color of Single Legend Items, page 2-16

How to Work with Color Sets  

The Color Set File  

Each line of the a color set file defines the color of one legend item.

It is recommended that you do not edit the color set file manually.

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Charts Colors.

The Charts Colors preference page opens.
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Step 3 Select an action to perform.

• To import a color set from a file, click Import.

An Open dialog box appears. Browse to the required file and click Open. The file is imported and 
overwrites the existing color set.

• To export the current color set to a file, click Export.

A Save As dialog box appears. Browse to the required directory, enter a file name in the File name 
field, and click Save. The color set is exported.

• To Restore the default color set (the predefined colors delivered with the SCA BB Templates 
package), click Restore Defaults.

• To enable the color allocation method used prior to release 3.1.5, check the Enable legacy coloring 
mode check box.
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Note Before applying Import, Restore Defaults, or Enable legacy color mode, a warning is displayed.

Step 4 Click OK.

The Preferences dialog box closes.

How to Change the Color of Single Legend Items  

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Charts Colors.

The Charts Colors preference page opens.

Step 3 Select a legend item (in the following screen capture, a service) from the color tree.
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Note Possible categories of legend items are Direction, Hostname, Host IP, Protocol, MOS, Range, Codec, 
Port Number, Newsgroup, Protocol, Service, Measure, and Subscriber.

Categories and legend items are only displayed in the Charts Colors pane after colors are allocated to 
legend items. Colors are allocated to any legend items in the chart the first time a report instance is 
executed.

The current color of the legend item is displayed in the top right of the Charts Colors pane.

Step 4 Click on the displayed color.

A color palette dialog box appears.
2-17
Cisco Service Control Application Reporter User Guide

OL-8411-07



Chapter 2      Getting Started
  Configuring the SCA Reporter
Step 5 Select a new color for the legend item and click OK.

The Color dialog box closes.

The selected color is applied to the legend item.

The Reset button is enabled.
2-18
Cisco Service Control Application Reporter User Guide

OL-8411-07



Chapter 2      Getting Started
  Configuring the SCA Reporter
Note The Reset button restores the default color of a single selected legend item.

How to Configure the Legend Displayed in Charts  
You can configure globally the appearance of the legend in charts.

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Configuration.

Step 3 (Optional) Uncheck the Show item check box in legend check box.

Step 4 (Optional) Uncheck the Allow multi column in legend check box.
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Step 5 (Optional) In the Max legend percentage field, enter a new value.

Step 6 Click OK.

The new settings are saved.

The Preferences dialog box closes.

How to Configure Advanced Options for the SCA Reporter  
You can configure the following advanced options of the SCA Reporter:

• Whether to log debug messages

• The time to wait for a database connection

• The maximum number of report instances that can be executed simultaneously

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Configuration.

Step 3 To log debug messages, check the Send debug messages to log check box.

Logging debug messages can cause the log file to grow rapidly.

Step 4 In the Seconds to wait for a database connection field, enter a new value.

Step 5 In the Maximum number of reports that can be executed simultaneously field, enter a new value.

Step 6 Click OK.

The new settings are saved.

The Preferences dialog box closes.
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Online Help 
• How to Access Online Help, page 2-21

• How to Search Online Help, page 2-21

How to Access Online Help  
You can access relevant parts of this user guide from the SCA Reporter.

Step 1 From the Help menu, choose Help Contents.

Online help opens in a separate window.

How to Search Online Help  
You can also search online help from inside the SCA Reporter.

Step 1 From the Help menu, choose Search.

The Help view opens in the Reporter window.
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Step 2 Enter a word, phrase, or more complex search expression in the Search expression field.

The Go button is enabled.

Note Click >> (Expand) for an explanation of how to construct search expressions.

Step 3 Click Go.

Help topics containing your search expression are listed under Local Help.

Step 4 Click a help topic to view its contents.

Note You can bookmark topics for later reference.

Step 5 By clicking the appropriate link at the bottom of the Help view, you can switch to:

• All topics

• Related topics

• Bookmarks

Quick Start 
This Quick Start section will help you get started with the SCA Reporter. You will configure the 
Reporter, create a report instance and generate a report, and then work with the report.

• How to Create a First Report, page 2-23

• How to Work with a First Report, page 2-26
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How to Create a First Report  

Step 1 Launch the SCA Reporter (choose Start > All Programs > Cisco SCA > SCA Reporter 3.1.7 > SCA 
Reporter 3.1.7).

Step 2 Add, configure, and activate a database connection (see Managing Database Connections, page 2-9).

Step 3 Set the IP address of the SCE platform (see How to Set the IP Address of an SCE Platform, page 2-12).

Step 4 Confirm that there is an active database and that the system is configured correctly. (From the main 
menu, choose Help > Check Conditions.)

Step 5 In the Templates view, expand the node of one of the template groups.
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Step 6 Right-click a report template.

A popup menu appears.

Step 7 From the menu, select New.

A report instance is added below the report template.
2-24
Cisco Service Control Application Reporter User Guide

OL-8411-07



Chapter 2      Getting Started
  Quick Start
The report instance has the same name as the report template with the addition of “#1”. You can rename 
the report instance.

The Properties view opens in the bottom right of the SCA Reporter window, displaying the basic report 
instance properties.

Step 8 If any property has the value  (not set) , assign it a value.

Step 9 Click  (Execute) to generate the report.

A report view, with the name of the report instance, opens in the top right of the SCA Reporter window, 
displaying a chart of the report.
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Step 10 View your report.

The chart display properties are shown in the Properties view.

How to Work with a First Report  

Step 1 Create a report, as described in the previous procedure.

Step 2 Adjust the chart display by modifying the chart display properties in the Properties view. (See Adjusting 
the Chart Display, page 5-7.)

Step 3 In the report view, from the drop-down menu above the view, select Go To Report.

The Properties view displays the report instance properties.

Step 4 Display all the report instance properties by clicking  (Show Advanced Properties).
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Step 5 Modify one or more properties. (See How to Modify an Existing Report Instance, page 4-3.)

Step 6 Click  (Execute) to regenerate the report.

The modified report is displayed in the report view.

(In the illustrated example, the Select services to view property was modified, and Browsing, Generic, 
and P2P were checked.)
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