Cisco uBR10012 Universal Broadband Router Software Configuration Guide
Chapter 3: Configuring Cable Interface Features for the Cisco uBR10012 Router
Downloads: This chapterpdf (PDF - 667.0KB) The complete bookPDF (PDF - 6.42MB) | Feedback

Configuring Cable Interface Features for the Cisco uBR10012 Router

Table Of Contents

Configuring Cable Interface Features for the Cisco uBR10012 Router

Configuring the Downstream Cable Interface

Activating Downstream Cable Address Resolution Protocol Requests

Verifying ARP Requests

Activating Downstream Ports

Verifying the Downstream Ports

Assigning the Downstream Channel ID

Verifying the Downstream Channel ID

Setting the Downstream Helper Address

Verifying the Downstream Helper Address

Setting the Downstream Interleave Depth

Verifying the Downstream Interleave Depth

Setting the Downstream Modulation

Verifying the Downstream Modulation

Setting the Downstream MPEG Framing Format

Verifying the Downstream MPEG Framing Format

Setting Downstream Rate Limiting and Traffic Shaping

Verifying Downstream Traffic shaping

Configuring the Upstream Cable Interface

Activating Upstream Admission Control

Verifying Upstream Admission Control

Activating Upstream Differential Encoding

Verifying Upstream Differential Encoding

Activating Upstream Forward Error Correction

Verifying Upstream FEC

Activating the Upstream Ports

Verifying the Upstream Ports

Activating Upstream Power Adjustment

Verifying Upstream Power Adjustment

Activating the Upstream Scrambler

Verifying the Upstream Scrambler

Activating Upstream Timing Adjustment

Verifying Upstream Timing Adjustment

Setting Upstream Backoff Values

Verifying Upstream Data Backoff

Setting the Upstream Channel Width

Verifying Upstream Channel Width

Setting the Upstream Frequency

Verifying the Upstream Frequency

Setting the Upstream Input Power Level

Verifying the Upstream Input Power Level

Specifying Upstream Minislot Size

Verifying Upstream Minislot Size

Setting Upstream Rate Limiting and Traffic Shaping

Verifying Upstream Traffic Shaping

Troubleshooting Tips

Configuring Optional Cable Interface Features

Activating Host-to-Host Communication (Proxy ARP)

Activating Cable Proxy ARP Requests

Activating Packet Intercept Capabilities

Configuring Payload Header Suppression and Restoration

Setting Optional Broadcast and Cable IP Multicast Echo

Setting IP Multicast Echo

Verifying IP Multicast Echo

Access Lists and the cable ip-multicast echo Command

Setting IP Broadcast Echo

Verifying IP Broadcast Echo

Cable Interface Configuration Examples


Configuring Cable Interface Features for the Cisco uBR10012 Router



Note The content in this document applies to the Cisco uBR10-MC5X20, Cisco uBR-MC28U/MC28X, Cisco uBR-MC16U/MC16X, and earlier cable interface line cards.
For information on Cisco UBR-MC20X20V, Cisco uBR-MC88V, and Cisco uBR-MC3GX60V cable interface line cards, see the respective line card configuration guide.


The cable interface in the Cisco uBR10012 router serves as the cable TV radio frequency (RF) interface, supporting downstream and upstream signals. The downstream is output as an intermediate-frequency (IF) signal suitable for use with an external upconverter. Your cable plant, combined with your planned and installed subscriber base, service offering, and external network connections, determines what combination of Cisco uBR10000 series cable interfaces, network uplink line cards, and other components that you should use.

Up to eight Cisco line cards (cable interface line card and Line Card Processor (LCP) combined) can be housed in a chassis.

Cable interface line cards support varied downstream and upstreams ports. Refer to the "Hardware Supported on the Cisco uBR10012 Router" section for a summary.

The Cisco IOS software command-line interface (CLI) can be used to configure the Cisco cable interface line card for correct operation on the hybrid fiber-coaxial (HFC) cable network. This chapter describes the following tasks to configure the Cisco cable interfaces:

Section
Purpose

"Configuring the Downstream Cable Interface" section

Provides instructions for performing required upstream configuration tasks.

"Configuring the Upstream Cable Interface" section

Provides instructions for performing several optional cable interface configurations.

"Configuring Optional Cable Interface Features" section

Provides instructions for performing several optional cable interface configurations.

"Cable Interface Configuration Examples" section

Provides examples of some cable interface configurations corresponding to earlier procedures in this chapter.


The Cisco Cable Modem Termination System Feature Guide at http://www.cisco.com/en/US/docs/cable/cmts/feature/guide/cmtsfg.html contains several additional interface and router configurations applicable to the Cisco uBR10000 series CMTS.

Configuring the Downstream Cable Interface

These configurations are required. The first step in configuring the Cisco cable interface is to configure the downstream cable interface. Configuring the downstream cable interface consists of the following procedures:

Task
Description

"Activating Downstream Cable Address Resolution Protocol Requests" section

Provides instructions to activate ARP requests on the cable interface so that the Cisco uBR10000 series CMTS can perform IP address resolution on the downstream path.

"Activating Downstream Ports" section

Provides instructions to activate and verify a downstream port on a cable interface card for digital data transmissions over the HFC network.

"Assigning the Downstream Channel ID" section

Provides instructions to assign and verify a numeric channel ID to the downstream port on the Cisco cable interface line card.

"Setting the Downstream Helper Address" section

Provides instructions to specify an IP address of a Dynamic Host Configuration Protocol (DHCP) server where User Datagram Protocol (UDP) broadcast packets will be sent.

"Setting the Downstream Interleave Depth" section

Provides instructions to set the downstream interleave depth in milliseconds for the downstream port on the Cisco cable interface line card.

"Setting the Downstream Modulation" section

Provides instructions to define the speed in symbols per second at which data travels downstream to the subscriber's CM.

"Setting the Downstream MPEG Framing Format" section

Provides instructions to set and verify the downstream MPEG framing format, which must be compatible with DOCSIS specifications and your local cable plant operations.

"Setting Downstream Rate Limiting and Traffic Shaping" section

Provides instructions to use the token bucket policing algorithm with traffic shaping options or the weighted discard algorithm to buffer, shape, or discard packets that exceed a set bandwidth.



Note In most applications, default values for the commands used in these configuration steps are adequate to configure the Cisco uBR10012 router. You do not need to specify individual parameters unless you want to deviate from system defaults.


For information on other configuration options, refer to the Cisco Broadband Cable Command Reference Guide at http://www.cisco.com/en/US/docs/ios/cable/command/reference/cbl_book.html and the Documentation CD-ROM.

Activating Downstream Cable Address Resolution Protocol Requests

This configuration is required. Address Resolution Protocol (ARP) is an Internet protocol used to map IP addresses to MAC addresses on computers and other equipment installed in a network. You must activate ARP requests on the cable interface so that the Cisco uBR10000 series CMTS can perform IP address resolution on the downstream path.


Note The default values for the commands used in this configuration step are adequate in most cases to configure the Cisco uBR10000 series CMTS.


To activate ARP requests, use the following command in cable interface configuration mode.

Command
Purpose
Router(config-if)# cable arp

Enable ARP. This is the default.


Verifying ARP Requests

To verify that cable ARP is activated, enter the more system:running-config command and look for the cable interface configuration information. If ARP is activated, it does not appear in this output. If ARP is deactivated, it appears in the output as no cable arp.

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0
ip address 1.1.1.1 255.255.255.0
 no keepalive
 no cable arp 
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream symbol-rate 5056941
 cable upstream 0 frequency 15008000
 no cable upstream 0 shutdown

Tip If you are having difficulty with verification, verify that you entered the correct port and cable interface line card slot number when you activated ARP and when you entered the
show interface cable command.


Activating Downstream Ports

To activate a downstream port on a Cisco uBR10000 series cable interface card for digital data transmissions over the HFC network, complete the steps in the following table.

Command
Purpose

Step 1 

Router> enable

Password: password

Router#

Enters enable (privileged EXEC) mode.

Enter the password.

You have entered privileged EXEC mode when the prompt displays the pound symbol (#).

Step 2 

Router# configure terminal

Enter configuration commands, one per line. End with 
CNTL/Z. 
Router(config)#

Enters global configuration mode. You have entered global configuration mode when the (config)# prompt appears.

This command can be abbreviated to config t or conf t.

Step 3 

Router(config)# interface cable5/0/0  
Router(config-if)#

Enters cable interface configuration mode.

In this example, the interface is downstream port 0 on the cable interface card installed in slot 1 of the Cisco uBR10000 series CMTS.

Step 4 

Router(config-if)# cable downstream if-output


Router(config-if)# no cable downstream if-output

Default. Activates downstream digital data from the Cisco uBR10012 router.

Deactivates downstream digital data. This command mutes the IF output of the cable interface card and shuts down the interfaces.

Step 5 

Router(config-if)# no shutdown

Places the downstream port in the "admin up" state.

Step 6 

Router(config-if)# end
Router#

%SYS-5-CONFIG_I: Configured from console by console

Returns to privileged EXEC mode.


This message is normal and does not indicate an error.

Verifying the Downstream Ports

To determine if the downstream carrier is active (up), enter the show controllers cable command for the downstream port that you just configured. For National Television Standards Committee (NTSC) 6 MHz operations, see the following example:

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
 FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
 
   

Assigning the Downstream Channel ID

To assign a numeric channel ID to the downstream port on the Cisco cable interface line card, use the following command in cable interface configuration mode. The acceptable range is 0 to 255.

Router(config-if)# cable downstream channel-id id
 
   

Note The cable downstream channel-id command must be used with the following command:
cable downstream frequency 54000000-1000000000 broadcast frequency - h


These commands are used in instances where you want to send multiple downstream frequencies to a single region that contains CMs that can connect only to upstream ports on the same cable interface line card. You must configure unique channel IDs for each downstream that any CM is capable of receiving. The downstream frequency setting must match the setting on the upconverter.


Caution After defining unique downstream IDs, test the CMs for correct operation. Cisco recommends that when using this feature, you re-test each subsequent software release of CM code to verify correct operation and to ensure reasonable acquisition time for new installations. Failure to use these commands in conjunction or to test the involved CMs can result in customer service outages of indefinite duration.

Verifying the Downstream Channel ID

To verify the downstream channel ID, enter the show controllers cable command for the downstream port you have just configured. See the following example:

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
Downstream channel ID: 1
 
   

Setting the Downstream Helper Address

Specify an IP address of a Dynamic Host Configuration Protocol (DHCP) server where User Datagram Protocol (UDP) broadcast packets will be sent. You can specify a DHCP server for UDP broadcast packets from cable interfaces, and a DHCP server for UDP broadcast packets from hosts. To set a downstream helper address, use the following commands in cable interface configuration mode.

 
Command
Purpose

Step 1 

Router(config-if)# cable 
helper-address 10.x.x.x 
cable-modem

Set the downstream helper address to the DHCP server at IP address 10.x.x.x for UDP broadcast packets from cable modems.

Note Use the IP address of the DHCP server. Both 10.x.x.x and 172.56.x.x are private ranges.

Step 2 

Router(config-if)# cable 
helper-address 172.56.x.x host

Set the downstream helper address to the DHCP server at IP address 172.56.x.x for UDP broadcast packets from hosts.

Verifying the Downstream Helper Address

To verify the downstream helper address setting, enter the show running-config command and look for cable helper-address in the cable interface configuration information:

Router# show running-config
Building configuration...
 
   
Current configuration:
!
interface cable5/0/0
ip address 10.254.254.254 255.0.0.0
 no ip directed-broadcast
 cable helper-address 192.168.1.1
 no keepalive
 
   

Perform these steps if you are having difficulty with verification:


Step 1 Check the cables, upconverters, RF levels, and frequencies if the cable interfaces do not find a downstream signal.

Step 2 Check the cables, RF levels, and upstream frequencies, and enter a no shut command if the cable interfaces find a downstream signal, but not an upstream signal.

Step 3 Check the provisioning servers.

Ping the DHCP server using the source IP address option—the primary IP address of a cable interface.

Check IP routing if the cable interfaces acquire an RF upstream and downstream lock, but do not stay up.

Step 4 Check DHCP options and the IP address of the Time-of-Day (ToD) server:

Ping the ToD server using the source IP address option.

Check IP routing.

Verify that the TFTP filename is correct.

Verify that the TFTP file is in the correct directory on the TFTP server.

Ensure that the TFTP file has read privileges.

Ping the TFTP server using the source IP address option, and check IP routing if the cable interfaces acquire an RF and a DHCP, but fail on ToD or TFTP.


Setting the Downstream Interleave Depth

Set the interleave depth for the downstream port on the Cisco cable interface line card. A higher interleave depth provides more protection from bursts of noise on the HFC network; however, it increases downstream latency.


Note The valid values are 8, 16, 32 (default), 64, and 128.


To set the downstream interleave depth in milliseconds, use the following command in cable interface configuration mode:

Router(config-if)# cable downstream interleave-depth {8|16|32 |64|128}
 
   

Verifying the Downstream Interleave Depth

To verify the downstream interleave depth setting, enter the show controllers cable command for the downstream port you have just configured:

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
 Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
 FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=
 
   

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that the downstream carrier is active, using the cable downstream if-output command.


Setting the Downstream Modulation

To set the downstream modulation, define the speed in symbols per second at which data travels downstream to the subscriber's CM. A symbol is the basic unit of modulation. Quadrature Phase Shift Key (QPSK) encodes 2 bits per symbol, Quadrature Amplitude Modulation (QAM) -16 encodes 4 bits per symbol, QAM-64 encodes 6 bits per symbol, and QAM-256 encodes 8 bits per symbol.


Note Setting a downstream modulation rate of QAM-256 requires approximately a 6 dB higher signal-to-noise ratio (SNR) than QAM-64 at the subscriber's cable interface. If your network is marginal or unreliable at QAM-256, use the QAM-64 format instead. Also, consider the significance of your data.


To set the downstream modulation, use the following command in cable interface configuration mode. The standard DOCSIS modulation rate (and the Cisco default) is QAM-64.

Router(config-if)# cable downstream modulation 64qam
 
   

Verifying the Downstream Modulation

To verify the downstream modulation setting, enter the show controllers cable command for the downstream port you have just configured. See the following example:

Router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
 Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
 FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
 
   

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers

Step 5 Verify that the downstream carrier is active, using the cable downstream if-output command

Step 6 Verify that you have selected the default if you are not certain about the modulation rate needed.


Setting the Downstream MPEG Framing Format

The MPEG framing format must be compatible with DOCSIS specifications (viewable at http://www.cisco.com/en/US/tech/tk86/tk168/tsd_technology_support_protocol_home.html) and your local cable plant operations.


Tip Annex B is the DOCSIS MPEG framing format standard for North America.



Note Annex B framing format is automatically set when configuring Cisco cable interface line cards. The cable interface line card's downstream ports and the connected CMs on the network must be set to the same MPEG framing format and must support DOCSIS operations as appropriate.


The following command appears in the Cisco uBR10012 router configuration file to designate Annex B operation. This command sets the downstream MPEG framing format.

Router(config-if)# cable downstream annex {B}
 
   

Verifying the Downstream MPEG Framing Format

To verify the downstream MPEG framing format setting, enter the show controllers cable command for the downstream port you have just configured. See the following example:

router# show controllers cable5/0/0 downstream
Cable5/0/0 Downstream is up
Frequency=96000000, Channel Width 6 MHz, 64-QAM, Symbol Rate 5.056941 Msps
FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4
Downstream channel ID: 0
 
   

Setting Downstream Rate Limiting and Traffic Shaping

Downstream traffic shaping enables you to use the token bucket policing algorithm with traffic shaping options or the weighted discard algorithm to buffer, shape, or discard packets that exceed a set bandwidth. Downstream traffic shaping is disabled by default.

To enable downstream traffic shaping for a downstream port on a Cisco cable interface line card, use one of the following commands in cable interface configuration mode.

 
Command
Purpose

Step 1 

Router(config-if)# cable downstream rate-limit token-bucket



Router(config-if)# cable downstream rate-limit token-bucket shaping

Router(config-if)# cable downstream rate-limit token-bucket shaping granularity 8


Router(config-if)# cable downstream rate-limit token-bucket shaping max-delay 256

Enables traffic shaping on the downstream port using the token bucket policing algorithm. With this command, the Cisco uBR10012 router automatically drops packets that are in violation of the allowable bandwidth.

Enables traffic shaping on the downstream port using the token bucket policing algorithm with traffic shaping.

Enables traffic shaping on the downstream port using the token bucket policing algorithm with specific traffic shaping time granularity. Acceptable values are 1, 2, 4, 8, or 16 milliseconds.

Enables traffic shaping on the downstream port using the token bucket policing algorithm with specific maximum traffic shaping buffering delay. Acceptable values are 128, 256, 512, or 1028 milliseconds.

Step 2 

Router(config-if)# cable downstream 
rate-limit weighted-discard 3

Enables traffic shaping on the downstream port using the weighted discard algorithm and assigns a weight for the exponential moving average of the loss rate. Acceptable values are 1 to 4.

Step 3 

Router(config-if)#  ^Z 
Router

Exits back to EXEC mode so that you can verify the steps.

Verifying Downstream Traffic shaping

To determine if downstream traffic shaping is configured and activated, enter the show running-config command and look for the cable interface configuration information. If downstream traffic shaping is configured and enabled, a traffic shaping entry appears in the output. If downstream traffic shaping is disabled, no traffic shaping entry appears.

Router# show running-config
Building configuration...
Current configuration:
!
interface cable5/0/0
ip address 10.254.254.254 255.0.0.0
no ip directed-broadcast
cable helper-address 192.168.1.1
no keepalive
cable downstream annex B
cable downstream modulation 64qam
 
   

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you selected the default if you are not certain about the modulation rate needed.

Step 6 Verify that the downstream carrier is active using the cable downstream if-output command.


Configuring the Upstream Cable Interface

These configurations are required. Upstream cable interface commands configure the frequency and input power level of the upstream signal, in addition to error detection and correction of the upstream signal. The configuration of the upstream cable interface depends on the characteristics of your cable plant.

Perform the following tasks in this section to configure the upstream cable interface.


Note For some of these tasks, default values are adequate to configure the device.

Task
Description

"Activating Upstream Admission Control" section

Provides information about the upstream admission control feature, and provides instructions to set the upstream admission control as a percentage of the upstream channel capacity.

"Activating Upstream Differential Encoding" section

Provides brief explanation and instructions to activate differential encoding on the upstream, which is a digital encoding technique whereby a binary value is denoted by a signal change rather than a particular signal level.

"Activating Upstream Forward Error Correction" section

Provides instructions to activate forward error correction (FEC). The Cisco uBR10000 series CMTS uses FEC to attempt to correct any upstream data that might have been corrupted.

"Activating the Upstream Ports" section

Provides instructions to activate upstream ports. Each upstream port must be activated to enable upstream data transmission from the CMs on the HFC network to the Cisco uBR10000 series CMTS.

"Activating Upstream Power Adjustment" section

Provides instructions to enable upstream power adjustment. This feature sets the minimum power adjustment in dB that will allow continued ranging status.

"Activating the Upstream Scrambler" section

Provides instructions to activate the upstream scrambler on the upstream RF carrier, which enables CMs on the HFC network to use built-in scrambler circuitry for upstream data transmissions.

"Activating Upstream Timing Adjustment" section

Provides instructions to activate upstream timing adjustment on the specified interface. This feature sets the minimum timing adjustment that allows continued ranging status.

"Setting Upstream Backoff Values" section

Provides DOCSIS-compliant instructions that define contention resolution for CMs wanting to transmit data or requests on the upstream channel. Contention resolution is achieved with a truncated binary exponential backoff value.

"Setting the Upstream Channel Width" section

Provides instructions to enter the upstream channel width in hertz (Hz). Also describes NTSC spectrum parameters and spectrum management processes.

"Setting the Upstream Frequency" section

Provides instructions to set upstream channel frequency for the RF output that complies with the expected input frequency of the Cisco cable interface line card.

"Setting the Upstream Input Power Level" section

Provides instructions to set the upstream input power level in decibels per millivolt (dBmV), and provides additional information about the Cisco uBR10000 series CMTS controls the output power levels of CMs

"Setting Upstream Rate Limiting and Traffic Shaping" section

Provides instructions to activate traffic shaping on the upstream. Upstream traffic shaping, available on the DOCSIS upstream channel, delays the scheduling of the upstream packet, which in turn causes the packet to be buffered on the cable customer premises equipment (CPE) device, instead of being dropped.

"Specifying Upstream Minislot Size" section

Provides instructions to specify the minislot size (in ticks) for specific upstream cable interfaces. The minislot size and the channel width are related to certain degree but not tightly coupled.



Activating Upstream Admission Control

Upstream admission control tallies up the total amount of guaranteed minimum upstream throughput reserved by CMs on an upstream interface. Once the total exceeds an allowable level, no more CMs requiring a guaranteed minimum upstream rate are allowed online on that upstream port.

Cisco CMTS upstream admission control is turned off by default and must be activated. To set the upstream admission control as a percentage of the upstream channel capacity, use the following command in cable interface configuration mode. The admission control is set as a percentage of the specified upstream channel capacity. The acceptable range is from 10 to 1000 percent.

Router(config-if)# cable upstream usport admission-control percentage
 
   

For example:

7246VXR(config-if)# cable upstream 0 admission-control ?
    Max Reservation Limit As Percentage of Raw Channel Capacity
 
   

Syntax Description

usport

The upstream port that has admission control enabled.

percentage

The optional percentage parameter specifies the overbooking rate that will be used when deciding the amount of bandwidth that is available to be guaranteed.



Note If percentage is left blank or set to 100%, the CMTS will only allow a total up to the real available upstream bandwidth to be guaranteed. If percentage is set to its maximum of 1000, then up to 10 times the real interface bandwidth may be "guaranteed".


Verifying Upstream Admission Control

To determine if upstream admission control is configured and activated, enter the show running-config command in privileged EXEC mode and look for the cable interface configuration information. If upstream admission control is configured and enabled, an admission control entry appears in the show running-config command output, indicating the user-defined percentage of upstream channel capacity allowable. If upstream admission control is disabled, no admission control entry appears in the output.

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you selected a valid frequency for your router.


Activating Upstream Differential Encoding

Differential encoding on the upstream is a digital encoding technique whereby a binary value is denoted by a signal change rather than a particular signal level. To enable differential encoding on upstream traffic to a specified cable interface, use the following command in cable interface configuration mode. Upstream differential encoding is enabled by default.

Router(config-if)# cable upstream usport differential-encoding
 
   

Verifying Upstream Differential Encoding

To determine if upstream differential encoding is activated, enter the show running-config command and look for the cable interface configuration information. If upstream differential encoding is enabled, a differential encoding entry appears in the show running-config output. If upstream differential encoding is disabled, no differential encoding entry appears in the output.

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you selected a valid frequency for your router.


Activating Upstream Forward Error Correction

The Cisco uBR10000 series CMTS uses forward error correction (FEC) to attempt to correct any upstream data that might have been corrupted. When FEC is activated, all CMs on the network also activate FEC.


Note Although upstream FEC is an option, Cisco recommends that you use upstream FEC. FEC is activated by default and should not be disabled.


To activate the upstream forward error correction and to enable FEC, use the following command in cable interface configuration mode.

Router(config-if)# cable upstream usport fec
 
   

Verifying Upstream FEC

To verify whether FEC is activated or deactivated, enter the more system:running-config command and look for the cable interface configuration information. If FEC is enabled, an FEC entry appears in the show running-config command output. If FEC is disabled, no FEC entry appears in the output.

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you selected a valid frequency for your router.


Activating the Upstream Ports

Each upstream port must be activated to enable upstream data transmission from the CMs on the HFC network to the Cisco uBR10000 series CMTS.


Note The upstream cable interface does not operate until you either set a fixed upstream frequency or create and configure a spectrum group. Refer to the "Setting the Upstream Frequency" section for details.


To activate the upstream ports, use the following commands in global configuration mode.

 
Command
Purpose

Step 1 

Router(config)# interface cable slot/port

Specifies a cable interface and enters cable interface configuration mode.

Step 2 

Router(config-if)# no cable upstream usport shutdown

Enables upstream data traffic.

Verifying the Upstream Ports

To determine if the upstream ports are activated or deactivated, enter the show interface cable command for the upstream port just configured:

Router# show interface cable5/0/0
Cable5/0/0 is up, line protocol is up
 Hardware is BCM3210 FPGA, address is 00e0.1e5f.7a60 (bia 00e0.1e5f.7a60)
 Internet address is 1.1.1.3/24
 MTU 1500 bytes, BW 27000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
 Encapsulation, loopback not set, keepalive not set
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:25, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Queuing strategy: fifo
 Output queue 0/40, 0 drops; input queue 0/75, 0 drops
 5 minute input rate 0 bits/sea, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
     10878 packets input, 853740 bytes, 0 no buffer
     Received 3679 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     5401 packets output, 645885 bytes, 0 underruns
     0 output errors, 0 collisions, 9 interface resets
     0 output buffer failures, 0 output buffers swapped out
 
   

Activating Upstream Power Adjustment

To enable upstream power adjustment for a specified cable interface, use one of the following commands in cable interface configuration mode.

Command
Purpose
Router(config-if)# cable upstream 
usport power-adjust continue db  

Sets the minimum power adjustment in dB that allows continued ranging status. Valid values are 2 to 15 dB. Default = 2 dB.

Router(config-if)# cable upstream 
usport power-adjust noise percentage 

Sets the minimum number (percentage) of power-adjustment packets required to justify changing the upstream power rating. Valid values are 10 to 100 percent. Default = 30 percent.

Router(config-if)# cable upstream 0 
power-adjust threshold db

Sets the power-adjustment threshold in dB. Valid values are 0 to 2 dB. Default = 1 dB.

Router(config-if)# end  
Router#

Returns to enable (privileged EXEC) mode.


To return the automatic upstream power-adjustment ranging value to the default of 2 dB, enter the following command in cable interface configuration mode:

Router(config-if)# no cable upstream usport power-adjust continue 

To return the automatic upstream power-adjustment noise value to the default of 30 percent, enter the following command in cable interface configuration mode:

Router(config-if)# no cable upstream usport power-adjust noise
 
   

To return the upstream power-adjustment threshold value to the default of 1 dB, enter the following command in cable interface configuration mode:

Router(config-if)# no cable upstream usport power-adjust threshold

Verifying Upstream Power Adjustment

To determine if upstream power adjustment is configured and activated, enter the show running-config command and look for the cable interface configuration information. If upstream power adjustment is enabled, any or all three of the continue, noise, and threshold power-adjustment entries appear in the show running-config command output. If all three upstream power adjustments are disabled, no power-adjustment entry appears in the show running-config command output.

Activating the Upstream Scrambler

The scrambler on the upstream RF carrier enables CMs on the HFC network to use built-in scrambler circuitry for upstream data transmissions. The scrambler circuitry improves reliability of the upstream receiver on the cable interface line card.


Caution The upstream scrambler is activated by default and should not be disabled under normal circumstances. Disabling it can result in corrupted packets. Disable it only for prototype modems that do not support the upstream scrambler.

To activate the upstream scrambler, use the following command in cable interface configuration mode. The upstream scrambler is enabled by default.

Router(config-if)# cable upstream usport scrambler

Verifying the Upstream Scrambler

To determine if the upstream scrambler is activated, enter the more system:running-config command and look for the cable interface configuration information. Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you selected a valid frequency for your router.


Activating Upstream Timing Adjustment

To enable upstream timing adjustment for a specified cable interface, use one of the following commands in cable interface configuration mode.

Command
Purpose
Router(config-if)# cable upstream usport 
time-adjust continue seconds 

Sets the minimum timing adjustment that allows continued ranging status. Valid values are 2 to 64 seconds. Default = 2 seconds.

Router(config-if)# cable upstream usport 
time-adjust threshold seconds 

Sets the timing adjustment threshold value in seconds. Valid values are 1 to 32 seconds. Default = 1 second.

Router(config-if)# end  
Router#

Returns to enable (privileged EXEC) mode.


\

To return the upstream time-adjustment ranging value to the default of 2 seconds, enter the following command in cable interface configuration mode:

Router(config-if)# no cable upstream usport time-adjust continue
 
   

To return the upstream time adjustment threshold value to the default of 1 second, enter the following command in cable interface configuration mode:

Router(config-if)# no cable upstream usport time-adjust threshold

Verifying Upstream Timing Adjustment

To determine if upstream timing adjustment is configured and activated, enter the show running-config command and look for the cable interface configuration information. If upstream timing adjustment is enabled, either or both of the continue and threshold timing-adjustment entries appear in the show running-config command output. If both the continue and threshold upstream timing adjustments are disabled, no timing adjustment entry appears in the show running-config command output.


Tip Perform the following steps if you are having difficulty with verification:



Step 1 Verify that the cable connections are not loose or disconnected.

Step 2 Verify that the cable interface line card is firmly seated in its chassis slot

Step 3 Verify that the captive installation screws are tight.

Step 4 Confirm that you have entered the correct slot and port numbers.


Setting Upstream Backoff Values

The DOCSIS-specified method of contention resolution for CMs wanting to transmit data or requests on the upstream channel is a truncated binary exponential backoff value, with the initial backoff window and the maximum backoff window controlled by the CMTS. The Cisco uBR10000 series CMTS specifies backoff window values for both data and initial ranging, and sends these values downstream as part of the Bandwidth Allocation Map (MAP) MAC message.

The values are configurable on the Cisco uBR10000 series software and are power-of-two values. For example, a value of 4 indicates a window between 0 and 15; a value of 10 indicates a window between 0 and 1023. You can set fixed start and end values for data backoff on the upstream ports, or you can set the upstream ports for automatic data backoff. You have the same options for ranging backoff. For both backoff windows, the default start value is 0; the default end value is 4. Valid values are from 0 to 15.


Note Cisco does not recommend that you adjust default values, but that you enable the automatic dynamic backoff algorithm. Refer to the "Configuring Dynamic Contention Algorithms (Cable Insertion Interval, Range, and Data Backoff)" section.


To set data or ranging backoff values for an upstream port, use one or more of the following commands, in cable interface configuration mode.

 
Command
Purpose

Step 1 

Router(config-if)# cable upstream 
usport data-backoff start end  
 
or 
 
Router(config-if)# cable upstream 
usport data-backoff automatic
 
        

Optimizes the automatic setting for as many as 250 cable interfaces per upstream port. Sets manual values for data backoff windows only when operating with more than 250 cable interfaces per upstream port.

Configures the default backoff window values of 0 and 4.

Step 2 

Router(config-if)# cable upstream 
usport range start end  
 
or 
 
Router(config-if)# cable upstream 
usport range automatic
 
        

Optimizes the automatic setting for as many as 250 cable interfaces per upstream port. Sets manual values for data backoff windows only when operating with more than 250 cable interfaces per upstream port.

Configures the default backoff window values of 0 and 4.

When considering whether to adjust backoff values, keep the following considerations in mind:

The cable interface reconnection time after a power outage is related to the following factors:

DHCP, ToD, and TFTP servers often operate well below 1 percent load under normal situations, but can jump to over 100 percent after an outage.

Adjusting the backoffs to larger numbers slows cable interface reconnection and reduces server load.

Backoffs that are too small result in cable interfaces failing to range the upstream RF levels correctly and cycling to maximum power, thus increasing connection time and reducing network performance.

Backoffs that are too large result in increased recovery time after a large service outage.

There is significant variation in cable interface performance (brand to brand) in cable interface restart time.

All cable interfaces should recover in 0 to 10 minutes after all services are restored (Cisco uBR10012 router, RF transport, DHCP, TFTP, and ToD servers). A CM that takes longer than 10 minutes could be experiencing a problem with the modem itself, a problem with CMTS settings, or a problem in the DOCSIS provisioning servers.


Note Upstream segments serving a relatively large number of cable interfaces (for example, more than 1600) might suffer recovery times greater than 10 minutes.


Verifying Upstream Data Backoff

To verify backoff window settings, enter the show controllers cable command for the upstream port you have just configured:

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 1.600 MHz, QPSK Symbol Rate 1.280 Msps
  Spectrum Group is overridden
  SNR 33.2560 dB
  Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
  Ranging Backoff automatic (Start 0, End 3)
  Ranging Insertion Interval automatic (60 ms)
  Tx Backoff Start 0, Tx Backoff End 4
  Modulation Profile Group 1
  part_id=0x3137, rev_id=0x03, rev2_id=0xFF
  nb_agc_thr=0x0000, nb_agc_nom=0x0000
  Range Load Reg Size=0x58
  Request Load Reg Size=0x0E
  Minislot Size in number of Timebase Ticks is = 8
  Minislot Size in Symbols = 64
  Bandwidth Requests = 0xFE
  Piggyback Requests = 0xD
  Invalid BW Requests= 0x2
  Minislots Requested= 0x2963
  Minislots Granted  = 0x2963
  Minislot Size in Bytes = 16
  Map Advance = 4000 usecs
  UCD Count = 32964
  DES Ctrl Reg#0 = C000C043, Reg#1 = 0
 
   

Setting the Upstream Channel Width

Use the commands below to enter the upstream channel width in hertz (Hz). For NTSC operations, valid values are 200000 Hz (160 kilo symbols per second [ksps]), 400,000 Hz (320 ksps), 800,000 Hz (640 ksps), 1,600,000 Hz (1280 ksps), and 3,200,000 Hz (2560 ksps). The default is 1,600,000 Hz.

If no acceptable channels of the specified width are found, the spectrum management card automatically begins to scan the upstream spectrum for the next largest available channel width; for example, if the spectrum management card is unable to find a usable 1.6 MHz upstream channel, it automatically begins searching for usable 800 kHz channels.


Caution Higher symbol rates are more susceptible to RF noise and interference. If you use a symbol rate or modulation format beyond the capabilities of your HFC network, you might experience packet loss or loss of cable interface connectivity.


Note For QAM-16 channel widths of 400 kHz (320 ksps) or greater, Cisco recommends that you use QAM-16 modulation for long and short data, and that you use QPSK for request, initial, and station communications. For QAM-16 channel widths of 200 kHz (160 ksps), all communication must be able to use QAM-16. That is, 160 ksps with QAM-16 requires an exceptional signal-to-noise ratio (SNR) in your upstream channels. When you use QAM-16 for request, initial, and station maintenance messages with channel widths greater than 400 kHz, the QAM-16 preamble and message data take longer to transmit than the QPSK format.



Note To set the upstream channel width, use the following commands in cable interface configuration mode.


 
Command
Purpose

Step 1 

Router(config-if)# cable upstream usport 
channel-width width

Enters the channel width for your upstream RF carrier in Hz.

Step 2 

Router(config-if)# no cable upstream usport 
channel-width

Returns the channel width to its default setting of 1,600,000 Hz.

For additional information about channel width and minislot size, refer to the Cable Radio Frequency (RF) FAQs at http://www.cisco.com/en/US/customer/tech/tk86/tk319/technologies_q_and_a_item09186a0080134faa.shtml.

Verifying Upstream Channel Width

To verify the current value of the upstream channel width, enter the show controllers cable command for the upstream port you just configured. A sample follows below:

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
  Frequency 24.016 MHz, Channel Width 0.800 MHz, QPSK Symbol Rate 0.640 Msps
  Spectrum Group is overridden
  SNR 33.2560 dB
  Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
  Ranging Backoff automatic (Start 0, End 3)
  Ranging Insertion Interval automatic (60 ms)
  Tx Backoff Start 0, Tx Backoff End 4
  Modulation Profile Group 1
 
   

Perform these steps if you are having difficulty with verification:


Step 1 Use a valid combination of modulation format (QPSK and QAM-16), minislot size, frequency, and the no shutdown command.

Step 2 Use a recommended or previously tested modulation profile. It is not uncommon to create a modulation profile that does not allow cable interface-to-headend communication. Because each message type is individually specified, some messages might not work.

Step 3 Verify using IP ping packets of varying lengths (64 to 1500 bytes). Ping from the headend to the cable interface.

Step 4 Verify with your cable interface vendor that your CM software is fully certified or compatible with DOCSIS 1.0 and extensions, as appropriate.


Setting the Upstream Frequency

The upstream channel frequency of your RF output must be set to comply with the expected input frequency of your Cisco cable interface line card. To configure upstream channel frequencies, perform one of the following tasks:

Configure a fixed frequency from 5 to 42 MHz for NTSC operations, then enable the upstream port.

Create a global spectrum group, assign the interface to it, and enable the upstream port.


Note You can also select a default that does not set a specific fixed value.



Note The upstream port is frequency agile. If you define spectrum groups, the frequency can change while the interface is up and carrying traffic.


A modulation profile consists of a table of physical layer characteristics for the different types of upstream bursts; for example, initial maintenance, long grant, request/data, request, short grant, and station maintenance.


Note The upstream cable interface does not operate until you either set a fixed upstream frequency or create and configure a spectrum group.

If you are setting a fixed upstream frequency, make sure that the frequency selected does not interfere with the frequencies used for any other upstream applications running on the cable plant.


To set a fixed upstream frequency, use the following commands in cable interface configuration mode.

 
Command
Purpose

Step 1 

Router(config-if)# cable upstream usport frequency 
up-freq-hz

Enters the fixed center frequency for your upstream RF carrier in Hz.

Step 2 

Router(config-if)# no cable upstream usport shutdown

Places the upstream port in the "admin up" state.


Tip For National Television Standards Committee (NTSC) operations, valid ranges are 5000000 to 42000000 Hz.



Caution Some cable systems cannot reliably transport frequencies near these band edges. The wider the upstream channel (in MHz), the more difficulty you might have. Enter a center frequency between 20 and 38 MHz if you have difficulty.


Note You can also select a default that does not set a specific fixed value. The Cisco uBR10000 series software instructs the cable interfaces to use this frequency as the center frequency.


Verifying the Upstream Frequency

To verify the current value of the upstream frequency, enter the show controllers cable command for the upstream port you have just configured:

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 1.600 MHz, QPSK Symbol Rate 1.280 Msps
  Spectrum Group is overridden
  SNR 33.2560 dB
  Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
  Ranging Backoff automatic (Start 0, End 3)
  Ranging Insertion Interval automatic (60 ms)
  Tx Backoff Start 0, Tx Backoff End 4
  Modulation Profile Group 1
  

Note The upstream frequency displayed in the show controllers cable command output might not match the frequency that you entered when you set the upstream frequency. The Cisco uBR10000 series CMTS might select an upstream frequency close to the frequency you entered that offers better performance. The Cisco uBR10000 series CMTS selects the closest frequency available.


Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you have selected a valid frequency for your router.


Setting the Upstream Input Power Level

The Cisco uBR10012 router controls the output power levels of CMs to meet the desired upstream input power level. The nominal input power level for the upstream RF carrier is specified in decibels per millivolt (dBmV). The default setting of 0 dBmV is the optimal setting for the upstream power level.

The valid range for the input power level depends on the data rate. At 1.6 MHz, the valid range is -10 to 25 dBmV. If your power levels operate at greater than the maximum valid level, use an inline attenuator to bring the power level to within the valid range.


Caution If you increase the input power level, CMs on your HFC network increase their transmit power level. This increases the carrier-to-noise ratio (C/N) on the network, but also increases distortion products. Composite Second Order Beat (CSO) and Composite Triple Beat (CTB) values worsen by 2 dB for every 1 dB-increased C/N. The return path laser immediately enters a nonlinear mode called clipping, and all communication becomes unreliable. Many return lasers send short bursts above the clipping thresholds and fail on longer or successive bursts.

You should not adjust your input power level by more than 5 dB in a 30-second interval. If you increase the power level by more than 5 dB within 30 seconds, cable interface service on your network is disrupted. If you decrease the power level by more than 5 dB within 30 seconds, cable interfaces on your network are forced offline.


Note When you run the cable upstream 0 power-level command, Cisco recommends that the adjacent channel not have a large variation. The recommended maximum input power variance is 5 to 6 dBmV.


To set the upstream input power level in dBmV, use the following command in cable interface configuration mode. The default is 0 dBmV.

Router(config-if)# cable upstream usport power-level dbmv
 
   

Verifying the Upstream Input Power Level

To verify the current value of the upstream input power level, enter the show controllers cable command for the upstream port you have just configured:

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
  Frequency 24.016 MHz, Channel Width 0.800 MHz, QPSK Symbol Rate 0.640 Msps
  Spectrum Group is overridden
  SNR 33.2560 dB
  Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
  Ranging Backoff automatic (Start 0, End 3)
  Ranging Insertion Interval automatic (60 ms)
  Tx Backoff Start 0, Tx Backoff End 4
  Modulation Profile Group 1
  

Perform these steps if you are having difficulty with verification:

1. Verify that the upstream amplitude of an optimal RF carrier (injected at the fiber node reference input point) reaches the cable interface line card input point at a consistent level (node-to-node and port-to-port).

2. Verify that this absolute level, as installed, matches both the design and software settings on the Cisco uBR10000 series CMTS.


Note Software adjustments of 1 to 3 dB can be used to adjust for minor variations in measurement or setup and port-to-port calibration differences. These adjustments can significantly improve cable interface performance, particularly in marginal situations. Larger adjustments should be made in conjunction with spectrum analyzer support at the headend or distribution hub.


Specifying Upstream Minislot Size

To specify the minislot size (in ticks) for specific upstream cable interfaces, use the following command in cable interface configuration mode. Acceptable values are 2, 4, 8, 16, 32, 64, and 128. The default is 8.

Router(config-if)# cable upstream usport minislot-size size
 
   

For additional information about channel width and minislot size, refer to the Cable Radio Frequency (RF) FAQs at http://www.cisco.com/en/US/customer/tech/tk86/tk319/technologies_q_and_a_item09186a0080134faa.shtml

Verifying Upstream Minislot Size

To verify upstream minislot size, enter the show controllers cable command for the upstream port you have just configured:

Router# show controllers cable5/0/0 u0
Cable5/0/0 Upstream 0 is up
Frequency 24.016 MHz, Channel Width 1.600 MHz, QPSK Symbol Rate 1.280 Msps
  Spectrum Group is overridden
  SNR 33.2560 dB
  Nominal Input Power Level 0 dBmV, Tx Timing Offset 2288
  Ranging Backoff automatic (Start 0, End 3)
  Ranging Insertion Interval automatic (60 ms)
  Tx Backoff Start 0, Tx Backoff End 4
  Modulation Profile Group 1
  part_id=0xFFFF, rev_id=0xFF, rev2_id=0xFF
  nb_agc_thr=0x0000, nb_agc_nom=0x0000
  Range Load Reg Size=0x58
  Request Load Reg Size=0x0E
  Minislot Size in number of Timebase Ticks is = 8
  Minislot Size in Symbols = 64
  Bandwidth Requests = 0xFE
  Piggyback Requests = 0xD
  Invalid BW Requests= 0x2
  Minislots Requested= 0x2963
  Minislots Granted  = 0x2963
  Minislot Size in Bytes = 16
  Map Advance = 4000 usecs
  UCD Count = 32964
  DES Ctrl Reg#0 = C000C043, Reg#1 = 0
 
   

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you selected a valid frequency for your router.


Setting Upstream Rate Limiting and Traffic Shaping

Upstream traffic shaping, available on the DOCSIS upstream channel, delays the scheduling of the upstream packet, which in turn causes the packet to be buffered on the cable customer premises equipment (CPE) device, instead of being dropped. This allows the user's TCP/IP stack to pace the application traffic appropriately and approach throughput commensurate with the subscriber's defined quality of service (QoS) levels.

The CMs are buffered without incurring TCP-related timeouts and retransmits. This enables the CMTS to enforce the peak upstream rate for each CM, without degrading overall TCP performance for the subscriber CPEs. Upstream grant shaping is per cable interface (per service ID (SID)).

Token-bucket policing with shaping is the per-upstream default rate-limiting setting at the CMTS. Shaping can be enabled or disabled for the token-bucket algorithm.

To enable upstream traffic shaping for an upstream port on a Cisco cable interface line card, use one of the following commands in cable interface configuration mode.

 
Command
Purpose

Step 1 

Router(config-if)# cable upstream usport 
rate-limit 
Router(config-if)# cable upstream usport 
rate-limit token-bucket 
 
 
 
 
Router(config-if)# cable upstream usport 
rate-limit token-bucket shaping 

Enables traffic shaping for the specified upstream cable interface.

Enables traffic shaping for the upstream cable interface employing the token-bucket policing algorithm. With this command the Cisco uBR10000 series CMTS automatically drops packets in violation of allowable upstream bandwidth.

Default. Enables traffic shaping for the upstream cable interface employing the token-bucket policing algorithm with traffic shaping.

Step 2 

Router(config-if)# ^Z 
Router

Exits back to the EXEC mode so that you can verify upstream traffic shaping.

To disable upstream traffic shaping for an upstream port, enter the following command in cable interface configuration mode:

Router(config-if)# no cable upstream usport rate-limit
 
   

The software supports:

Generic calendar queuing routines

New token-bucket policing function

Grant shaping application of the calendar queues

Upstream rate-shaping option to the token-bucket keyword

A default state change from 1-second burst policing to token bucket with shaping


Tip Upstream grant shaping is per CM (per service ID (SID)). Shaping can be enabled or disabled for the token-bucket algorithm.



Note Before the introduction of this feature, the CMTS would drop bandwidth requests from a CM it detected as exceeding its configured peak upstream rate. Such request dropping affects the throughput performance of IP-based protocols such as FTP, TCP, and Simple Network Management Protocol (SNMP). With this feature, the CMTS can shape (buffer) the grants for a CM that is exceeding its upstream rate, rather than dropping the bandwidth requests.


Router# show interface c5/0/0 sid 1 counters
00:02:23: %ENVM-3-LASTENV: Cannot save environmental data 
Sid  Req-polls  BW-reqs    Grants     Packets    Frag       Concatpkts
     issued     received   issued     received   complete   received
1    0          22         22         22         0          0          
2    0          3          3          2          0          0          
3    0          0          0          0          0          0 
 
   

Verifying Upstream Traffic Shaping

To determine if upstream traffic shaping is configured and activated, enter the show running-config command and look for the cable interface configuration information. If upstream traffic shaping is configured and enabled, a traffic shaping entry appears in the show running-config output. If upstream traffic shaping is disabled, no cable upstream rate-limit appears in the output.

You can also perform the following tasks to verify that traffic shaping is enabled on the upstream channel:


Step 1 Configure a low-peak upstream rate limit for the CM in its QoS profile. Either use the command-line interface (CLI) to modify the modem's QoS profile, or edit the modem's TFTP configuration file. refer to the DOCSIS 1.1 for the Cisco uBR7200 Series Universal Broadband Routers feature module at http://www.cisco.com/en/US/docs/cable/cmts/feature/DOCSIS11.html.

Step 2 Use a regular rate-limiting algorithm on the upstream without rate shaping, and note the drops of the excess bandwidth requests from this CM when it exceeds its peak upstream rate.

Use the show interface cx/y sid counters verbose command to see the bandwidth request drops. Verify that the upstream rate received by that modem is less than its configured peak rate, due to the timeouts and backoffs produced by the drop in bandwidth requests. Enter the show interface cx/y service flow qos command to see the input rate at CMTS in bps.

Step 3 Enable grant shaping on the upstream channel by using the new shaping keyword extension to the token-bucket algorithm CLI command.

Step 4 Make the CM exceed its peak upstream rate by generating upstream traffic, and note the effect of grant buffering (shaping) at the CMTS. If you use CM-to-CMTS pings, there is a perceivable decrease in the frequency of the pings.

Let the pings run long enough to allow the averages at the CMTS to settle; then view the upstream rate received by this single modem. Use the show interface cx/y command and see the input rate in bps. This value should be close to the modem's peak upstream rate. Also note the drop counts for the modem's SID by using the show interface sid counters command, and verify that the CMTS no longer drops the bandwidth requests from the CM.

The bandwidth request drop count (from the previous nonshaping test) remains unchanged when upstream rate shaping is used, indicating that the CMTS is actually shaping (buffering) the grants for the modem. Verify that the input rate at the CMTS (from the single rate-exceeded CM) stabilizes close to the configured peak rate of 128 Kbps.


Troubleshooting Tips

Perform these steps if you are having difficulty with verification:


Step 1 Ensure that the cable connections are not loose or disconnected.

Step 2 Ensure that the cable interface line card is firmly seated in its chassis slot.

Step 3 Ensure that the captive installation screws are tight.

Step 4 Verify that you have entered the correct slot and port numbers.

Step 5 Verify that you selected a valid frequency for your router.


Configuring Optional Cable Interface Features

This section builds on the required cable interface features documented earlier in this chapter. This section provides instructions for several optional cable interface configurations. These interface features pertain to heightened performance and security measures.


Note Default settings are typically adequate to configure optional features on the system. Change default settings only with careful prior analysis.


Section
Purpose

"Activating Host-to-Host Communication (Proxy ARP)" section

Allows the Cisco uBR10012 router to issue cable Address Resolution Protocol (ARP) requests on behalf of CMs on the same cable network subnet.

"Activating Packet Intercept Capabilities" section

Specifies a MAC address on the cable network for which interception capabilities are to be activated.

"Configuring Payload Header Suppression and Restoration" section

Provides command information to set up the Payload Header Suppression (PHS) feature, which is used to suppress repetitive or redundant portions in packet headers before transmission on the DOCSIS link.

"Setting Optional Broadcast and Cable IP Multicast Echo" section

Sets additional IP parameters to enable downstream echoing of upstream data.


Activating Host-to-Host Communication (Proxy ARP)

Cable proxy ARP allows the Cisco uBR10012 router to issue cable ARP requests on behalf of CMs on the same cable network subnet.


Note Because the downstream and upstreams are separate interfaces, modems cannot directly perform ARP with other modems on the cable plant.



Note The default values for the commands used in this configuration task are adequate in most cases to configure the Cisco uBR10012 router.


Activating Cable Proxy ARP Requests

To activate cable proxy ARP for host-to-host communications, use the following command in cable interface configuration mode.

Command
Purpose
Router(config-if)# cable proxy-arp

Enables proxy ARP on the cable interface. This is the default.


Verifying Cable Proxy ARP Requests

To verify if cable proxy ARP has been activated or deactivated, enter the more system:running-config command and look for the cable interface configuration information. If cable proxy ARP has been activated, it does not appear in the output. If cable proxy ARP has been deactivated, it appears in the output as no cable proxy-arp.

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0
 
   
 ip address 1.1.1.1 255.255.255.0
 no keepalive
 no cable proxy-arp
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream symbol-rate 5056941
 cable upstream 0 frequency 15008000
 no cable upstream 0 shutdown

Tip If you are having difficulty with verification, make sure that you entered the correct port and cable interface line card slot number when you activated cable proxy ARP.


Activating Packet Intercept Capabilities

To activate packet intercept functionality, use the following commands in cable interface configuration mode.

Command
Purpose
Router(config-if)# cable intercept 
xxxx.xxxx.xxxx

Specifies a MAC address on the cable network for which interception capabilities are to be activated. There is a limit of 10 MAC addresses.

Router(config-if)# no cable intercept 
xxxx.xxxx.xxxx

Disables interception after it is enabled.


Configuring Payload Header Suppression and Restoration

Payload Header Suppression (PHS) is a new feature in the DOCSIS1.1 MAC driver. The PHS feature is used to suppress repetitive or redundant portions in packet headers before transmission on the DOCSIS link. The upstream receive driver is now capable of restoring headers suppressed by CMs, and the downstream driver is capable of suppressing specific fields in the packet header before forwarding the frame to the CM.

Command
Purpose
show interface cable x/0/0 
service-flow [sfid] phs

Displays cable interface information.

debug cable error 

Displays errors that occur in the cable MAC protocols. To disable debugging output, use the no form of the command.

debug cable phs 

Displays the activities of the PHS and restoration driver. The no form of this command disables debugging output.


Setting Optional Broadcast and Cable IP Multicast Echo

You can set additional IP parameters to enable downstream echoing of upstream data. This section contains two procedures to configure these optional IP parameters:

"Setting IP Multicast Echo" section

"Setting IP Broadcast Echo" section


Note The default values for the commands used in these configuration steps are adequate in most cases to configure the Cisco uBR10012 router.


Setting IP Multicast Echo

The Cisco uBR10012 router does not echo IP multicast packets by default. To activate IP multicast echo, use the following command in cable interface configuration mode:

Command
Purpose
Router(config-if)# cable ip-multicast-echo

Enables IP multicast echo.


To disable IP multicast echo, enter the no cable ip-multicast-echo command in cable interface configuration mode.

There are two types of multicast echo packets:

Control packet (Internet Group Management Protocol [IGMP] packets that are destined for the router)

Data packet (layer 3 packet used for switching)


NoteThe cable ip-multicast-echo command controls only control packets.

Data multicast echoing is always enabled and cannot be disabled.


Verifying IP Multicast Echo

To determine whether IP multicast echo is activated or deactivated, enter the more system:running-config command, and look for the cable interface configuration information. If IP multicast echo is activated, there is no notation in the output, because this is the default setting. If IP multicast echo is deactivated, a notation appears in the output:

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0
 
   
 ip address 1.1.1.1 255.255.255.0
 no keepalive
 no cable ip-multicast-echo 
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 15008000
 no cable upstream 0 shutdown

Tip If you are having difficulty with verification, make sure that you entered the correct slot and port numbers when you entered cable interface configuration mode.


Access Lists and the cable ip-multicast echo Command

The cable ip-multicast-echo command is enabled by default on the Cisco uBR10012 router, so that multicast IP packets that arrive on the upstream at the Cisco CMTS are forwarded on the appropriate downstream ports so that they are delivered to the other CMs and CPE devices on that segment of the network. This allows the cable network to behave like a standard Ethernet network in terms of its handling of multicast IP traffic.

However, on the Cisco uBR10012 router, input access lists are not applied to the multicast traffic that is echoed on each downstream. To control the echoed multicast traffic, you therefore need to configure an output access list and apply it to each downstream interface.

Refer to the Cisco Broadband Cable Command Reference Guide on Cisco.com for additional information on access lists and multicast echo:

http://www.cisco.com/en/US/docs/ios/cable/command/reference/cbl_book.html

Setting IP Broadcast Echo

By default, the Cisco uBR10012 router does not echo IP broadcast packets. To activate IP broadcast echo, use the following command in cable interface configuration mode.

Command
Purpose
Router(config-if)# cable ip-broadcast-echo

Enables IP broadcast echo.


To disable IP broadcast echo when it is enabled, enter the no cable ip-broadcast-echo command in cable interface configuration mode.

Verifying IP Broadcast Echo

To determine whether IP broadcast echo is activated or deactivated, enter the more system:running-config command and look for a notation in the cable interface configuration information:

Router# more system:running-config
Building configuration...
 
Current configuration:
!
interface cable5/0/0

 ip address 1.1.1.1 255.255.255.0
 no keepalive
 cable ip-broadcast-echo 
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 15008000
 no cable upstream 0 shutdown
 
   

Cable Interface Configuration Examples

This section provides the following configuration examples:

"Subinterface Configuration Example" section

"Cable Interface Bundling Example" section

"Cable Interface Bundle Master Configuration Example" section

"PE Router Configuration Example" section

"P Router Configuration Example" section

"BGP Routing Sessions Configuration Example" section

"PE-to-PE Routing Sessions Configuration Example" section

"BGP PE-to-CE Routing Sessions Configuration Example" section

"RIP PE-to-CE Routing Sessions Configuration Example" section

"Static Route PE-to-CE Routing Sessions Configuration Example" section

Subinterface Configuration Example

The following example shows how to define a subinterface on the cable5/0/0:

interface cable5/0/0
! No IP address
! MAC level configuration only
! first subinterface
interface cable5/0/0.1
description Management Subinterface
ip address 10.255.1.1 255.255.255.0
cable helper-address 10.151.129.2
 
   
! second subinterface
interface cable5/0/0.2
ip address 10.279.4.2 255.255.255.0
cable helper-address 10.151.129.2
 
   
! third subinterface
interface cable5/0/0.3
ip address 10.254.5.2 255.255.255.0
cable helper-address 10.151.129.2

Cable Interface Bundling Example

The following example shows how to bundle a group of physical interfaces. In this example, the interfaces int c5/0/0 and int c4/0 are bundled.

int c5/0/0
ip address 209.165.200.225 255.255.255.0
ip address 209.165.201.1 255.255.255.0 secondary
cable helper-address 10.5.1.5
! MAC level configuration
cable bundle 1 master
int c4/0/0
! No IP address
! MAC layer configuration only
cable bundle 1

Subinterface Definition on Bundle Master Example

The following example shows how to define subinterfaces on a bundle master and define Layer 3 configurations for each subinterface. In this example, the interfaces int c5/0/0 and int c4/0/0 are bundled.

int c5/0/0
! No IP address
! MAC level configuration only
cable bundle 1 master
 
   
int c4/0/0
! No IP address
! MAC layer configuration
cable bundle 1
 
   
! first subinterface
int c5/0/0.1
ip address 10.22.64.0 255.255.255.0
cable helper-address 10.4.1.2
 
   
! second subinterface
int c5/0/0.2
ip address 10.12.39.0 255.255.255.0
cable helper-address 10.4.1.2
 
   
! third subinterface
int c5/0/0.3
ip address 10.96.3.0 255.255.255.0
cable helper-address 10.4.1.2

Cable Interface Bundle Master Configuration Example

The following example shows how to configure cable interface bundles:

Displaying the contents of the bundle
Router(config-if)# cable bundle ?
  <1-255>  Bundle number
Router(config-if)# cable bundle 25 ?
  master  Bundle master
  <cr>
Router(config-if)# cable bundle 25 master ?
  <cr>
Router(config-if)# cable bundle 25 master
Router(config-if)# 
07:28:17: %uBR10000-5-UPDOWN: Interface Cable5/0/0 Port U0, changed state to down
07:28:18: %uBR10000-5-UPDOWN: Interface Cable5/0/0 Port U0, changed state to up

PE Router Configuration Example

This example (system information display) identifies the version of Cisco IOS software installed and displays PE configurations:

! Defines the hostname of the Cisco uBR10012
hostname region-1-ubr
!
! Describes where the system is getting the software image it is running. In
! this configuration example, the system is loading a Cisco uBR10012 image named
! AdamSpecial from slot 0.
boot system flash slot0:uBR10000-p-mz.AdamSpecial
!
! Creates the enable secret password.
enable secret xxxx
enable password xxxx
!
! Sets QoS per modem for the cable plant.
no cable qos permission create
no cable qos permission update
cable qos permission modems
!
! Allows the system to use a full range of IP addresses, including subnet zero, for
! interface addresses and routing updates.
ip subnet-zero
!
! Enables Cisco Express Forwarding.
ip cef
!
! Configures a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server to insert the
! DHCP relay agent information option in forwarded BOOTREQUEST messages.
ip dhcp relay information option
!
! Enters the virtual routing forwarding (VRF) configuration mode and maps a VRF table to
! the virtual private network (VPN) called MGMT-VPN. The VRF table contains the set of
! routes that points to or gives routes to the CNR device, which provisions the cable
! modem devices. Each VRF table defines a path through the MPLS cloud.
ip vrf MGMT-VPN
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
 rd 100:1
!
! Creates a list of import and/or export route target communities for the VPN.
 route-target export 100:2
 route-target export 100:3
!
! Maps a VRF table to the VPN called ISP1-VPN.
ip vrf ISP1-VPN
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
 rd 100:2
!
! Creates a list of import and/or export route target communities for the VPN.
 route-target import 100:1
!
! Maps a VRF table to the VPN called ISP2-VPN.
ip vrf ISP2-VPN
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
 rd 100:3
!
! Creates a list of import and/or export route target communities for the VPN.
 route-target import 100:1
!
! Maps a VRF table to the VPN called MSO-isp. Note: MSO-isp could be considered ISP-3; in
! this case, the MSO is competing with other ISPs for other ISP services.
ip vrf MSO-isp
!
! Creates the route distinguisher and creates the routing and forwarding table of the
! router itself.
 rd 100:4
!
! Creates a list of import and/or export route target communities for the VPN.
  route-target import 100:1
!
! Builds a loopback interface to be used with MPLS and BGP; creating a loopback interface 
! eliminates unnecessary updates (caused by physical interfaces going up and down) from
! flooding the network.
interface Loopback0
 ip address 10.0.0.0 255.255.255.0
 no ip directed-broadcast
!
! Assigns an IP address to this Fast Ethernet interface. MPLS tag-switching must be
! enabled on this interface.
interface FastEthernet0/0/0
 description Connection to MSO core.
 ip address 10.0.0.0 255.255.255.0
 no ip directed-broadcast
 full-duplex
 tag-switching ip
!
! Enters cable interface configuration mode and configures the physical aspects of the
! 5/0/0 cable interface. Please note that no IP addresses are assigned to this interface;
! they will be assigned instead to the logical subinterfaces. All other commands for
! this cable interface should be configured to meet the specific needs of your cable RF
! plant and cable network.
interface Cable5/0/0
 no ip address
 ip directed-broadcast
 no ip mroute-cache
 load-interval 30
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 855000000
 cable upstream 0 frequency 30000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
! Configures the physical aspects of the 5/0/0.1 cable subinterface. If cable modems have
! not been assigned IP addresses, they will automatically come on-line using the settings
! for subinterface X.1. 
interface Cable5/0/0.1
 description Cable Administration Network
!
! Associates this interface with the VRF and MPLS VPNs that connect to the MSO cable
! network registrar (CNR). The CNR provides cable modems with IP addresses and other
! initialization parameters. 
 ip vrf forwarding MSO
!
! Defines a range of IP addresses and masks to be assigned to cable modems not yet 
associated with an ISP.
 ip address 10.0.0.0 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
 no ip directed-broadcast
!
! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
 cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PCs that are not yet associated with an ISP.
 cable helper-address 10.4.1.2 host
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
 no cable proxy-arp
 no cable ip-multicast-echo
!
! Configures the physical aspects of the 5/0/0.2 cable subinterface.
interface Cable5/0/0.2
 description MSO as ISP Network
!
! Assigns this subinterface to the MPLS VPN used by the MSO to supply service to
! customers—in this case, MSO-isp. 
 ip vrf forwarding MSO-isp
!
! Defines a range of IP addresses and masks to be assigned to cable modems associated
! with the MSO as ISP network.
 ip address 10.1.0.0 255.255.255.0 secondary
! 
! Defines a range of IP addresses and masks to be assigned to host devices associated
! with the MSO as ISP network.
 ip address 10.1.0.0 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
 no ip directed-broadcast
!
! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
 cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PC host devices.
 cable helper-address 10.4.1.2 host
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
 no cable proxy-arp
 no cable ip-multicast-echo
!
! Configures the physical aspects of the 5/0.3 cable subinterface
interface Cable5/0/0.3
 description ISP1's Network
! 
! Makes this subinterface a member of the MPLS VPN.
 ip vrf forwarding isp1
!
! Defines a range of IP addresses and masks to be assigned to cable modems associated
! with the MSO as ISP network.
 ip address 10.1.1.1 255.255.255.0 secondary
!
! Defines a range of IP addresses and masks to be assigned to host devices associated
! with the MSO as ISP network.
 ip address 10.0.1.1 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
 no ip directed-broadcast
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
 no cable proxy-arp
 no cable ip-multicast-echo
!
! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
 cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PC host devices.
 cable helper-address 10.4.1.2 host
!
! Configures the physical aspects of the 5/0/0.4 cable subinterface
interface Cable5/0/0.4
 description ISP2's Network
!
! Makes this subinterface a member of the MPLS VPN.
 ip vrf forwarding isp2
!
! Defines a range of IP addresses and masks to be assigned to cable modems associated
! with the MSO as ISP network.
 ip address 10.1.2.1 255.255.255.0 secondary
!
! Defines a range of IP addresses and masks to be assigned to host devices associated
! with the MSO as ISP network.
 ip address 10.0.1.1 255.255.255.0
!
! Disables the translation of directed broadcasts to physical broadcasts.
 no ip directed-broadcast
!
! Disables cable proxy Address Resolution Protocol (ARP) and IP multicast echo on this
! cable interface.
 no cable proxy-arp
 no cable ip-multicast-echo
!
!
 cable dhcp-giaddr policy
!
!! Defines the DHCP server for cable modems whether they are associated with an ISP or
! with the MSO acting as ISP.
 cable helper-address 10.4.1.2 cable-modem
!
! Defines the DHCP server for PC host devices.
 cable helper-address 10.4.1.2 host
!
!
end

P Router Configuration Example

This example (system information display) identifies the version of Cisco IOS software installed and displays PE configurations:

Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R7460-7206-02
!
enable password xxxx
!
ip subnet-zero
ip cef
ip host brios 223.255.254.253
!
interface Loopback0
 ip address 10.2.1.3 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
!
interface FastEthernet0/0/0
 ip address 1.7.108.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 full-duplex
 no cdp enable
!
router ospf 222
 network 10.0.1.0 255.255.255.0 area 0
 network 10.0.2.0 255.255.255.0 area 0
 network 10.0.3.0 255.255.255.0 area 0
 network 10.0.4.0 255.255.255.0 area 0
 network 20.2.1.3 255.255.255.0 area 0
!
ip classless
no ip http server
!
!
map-list test-b
no cdp run
!
tftp-server slot0:master/120/ubr10k-p6-mz.122-2.XF
!
line con 0
 exec-timeout 0 0
 password xxxx
 login
 transport input none
line aux 0
line vty 0 4
 password xxxx
 login
!
no scheduler max-task-time
end

BGP Routing Sessions Configuration Example

To configure BGP routing sessions in a provider network, use the following commands in router configuration mode on the PE router:


Step 1 Configure the BGP routing process with the autonomous system number:

Router(config)# router bgp 42
 
   

Step 2 Specify a neighbor's IP address or BGP peer group, identifying it to the local autonomous system:

Router(config-router)# neighbor 200.28.28.40
Activate the advertisement of the IPv4address family.
Router(config-router)# neighbor 200.28.28.40 activate
 
   

PE-to-PE Routing Sessions Configuration Example

To configure PE-to-PE routing sessions in a provider network, use the following commands in router configuration mode on the PE router:


Step 1 Define internal Border Gateway Protocol (iBGP) parameters for VPNv4 network-layer reachability information (NLRI) exchange:

Router(config-router)# address-family vpnv4 unicast
 
   

Step 2 Define an IBGP session to exchange VPNv4 NLRIs:

Router(config-router-af)# neighbor 200.28.28.45 remote-as 48
Router(config-router-af)# exit
 
   

Step 3 Activate the advertisement of the IPv4address family:

Router(config-router)# neighbor 200.28.28.45 activate
 
   

BGP PE-to-CE Routing Sessions Configuration Example

To configure BGP PE-to-CE routing sessions, use the following commands in router configuration mode on the PE router:


Step 1 Define external Border Gateway Protocol (eBGP) parameters for PE-to-CE routing sessions:

Router(config-router)# address-family ipv4 unicast vrf 
go_fast_internet_company
 
   

Step 2 Define an eBGP session between PE and CE routers and activate the advertisement of the IPv4 address family:

Router(config-router-af)# neighbor 200.28.28.46 remote-as 49
Router(config-router-af)# neighbor 200.28.28.46 activate 
 
   

RIP PE-to-CE Routing Sessions Configuration Example

To configure RIP PE-to-CE routing sessions, use the following commands in router configuration mode on the PE router:


Step 1 Enable RIP, define RIP parameters for PE-to-CE routing sessions, and enable RIP on the PE-to-CE link:

Router(config)# router rip
Router(config-router)# address-family ipv4 unicast vrf 
go_fast_internet_company
Router(config-router-af)# network 200.28.28.47
 
   

Static Route PE-to-CE Routing Sessions Configuration Example

To configure static route PE-to-CE routing sessions, use the following commands in router configuration mode on the PE router:


Step 1 Define static route parameters for each PE-to-CE session and for each BGP PE-to-CE routing session.

Router(config)# ip route vrf go_fast_internet_company 200.28.28.46 
255.255.255.0 200.28.28.50 
Router(config-router)# address-family ipv4 unicast vrf 
go_fast_internet_company
 
   

Step 2 Redistribute VRF static routes and directly connected networks into the VRF BGP table.

Router(config-router-af)# redistribute static
Router(config-router-af)# redistribute static connected