Cisco uBR10012 Universal Broadband Router Software Configuration Guide
Chapter 5: Configuring Basic Broadband Internet Access
Downloads: This chapterpdf (PDF - 119.0KB) The complete bookPDF (PDF - 6.42MB) | Feedback

Configuring Basic Broadband Internet Access

Table Of Contents

Configuring Basic Broadband Internet Access

Overview of Basic Broadband Internet Access

Recommended Basic Configuration for High-Speed Internet Access

Basic Internet Access Sample Configuration File


Configuring Basic Broadband Internet Access


This chapter describes the parameters of configuring and maintaining basic broadband Internet access. The chapter contains these sections:

"Overview of Basic Broadband Internet Access" section

"Recommended Basic Configuration for High-Speed Internet Access" section

"Basic Internet Access Sample Configuration File" section

Overview of Basic Broadband Internet Access

A Cisco uBR10012 router and an intermediate frequency (IF)-to-radio frequency (RF) upconverter are installed at the headend or distribution hub to transmit digital data. The Cisco uBR10012 router downstream ports transmit IF signals to the upconverter, which translates the downstream signals to RF for broadcast.

Receivers, scramblers, and descramblers then process the TV signals to encode or decode signals as needed for broadcast. Modulators format the analog TV and digital signals.

The analog and digital signals then pass through the RF combiner. The signals are broadcast from the headend through optical transmitters to fiber nodes.

Amplifiers, coaxial cable, and taps carry the signals to the subscriber premises. Signals are processed as follows:

Tuners that handle MPEG video, audio, and broadcast services in set-top boxes (STBs), TVs, and VCRs receive one-way analog signals.

CMs receive digital data signals:

Two-way CMs transmit RF signals back through amplifiers to optical fiber receivers at the headend. These receivers pass the upstream signal to upstream ports on the Cisco uBR10012 router, where they are processed.

Figure 1-1 illustrates this general signal flow and associated processes in the CMTS.

Figure 1-1 Two-Way Internet Access Network Example


Note The external upconverter shown in Figure 1-1 is needed only if you are not using the router's integrated upconverter.


Recommended Basic Configuration for High-Speed Internet Access

The Cisco uBR10012 router is fully capable of self-provisioning all CMs and hosts to which it is attached. The router supports multiple IP subnets, including different subnets for hosts and CMs. Configuration options are limited only by available configuration file length.

The Cisco uBR10012 router automatically connects DOCSIS-compliant CMs and hosts right out of the box. Therefore, the factory-supplied configuration activates the downstream RF to 861 MHz center frequency, and the upstream to 24 MHz.


Step 1 Connect one upstream port and the downstream port to a duplex filter.


Note Do not combine multiple ports, because they are all set on the same frequency.


Step 2 Use at least 40 dB attenuation before the first modem, and modems will connect in under 5 minutes.


Basic Internet Access Sample Configuration File

The following sample configuration file for the Cisco uBR10012 router includes the following features:

Basic DOCSIS Internet Access

DHCP Address Pools—The Cisco uBR10012 router acts as a DHCP server, providing different address spaces on the basis of the CM's service level, including those customers whose network access should be denied access because they have cancelled their service. Different default pools can be used for CMs and for the IP hosts behind them. Static IP addresses can also be assigned to specific clients on the basis of the client's MAC address.

DOCSIS CM Configuration Files—These configuration files provide several different service level options:

platinum.cm—Users are given a maximum upstream bandwidth of 128 kbps, with a guaranteed minimum bandwidth of 10 kbps. The downstream has a maximum bandwidth of 10 Mbps. Up to 8 PCs are allowed on this connection.

gold.cm—Users are given a maximum upstream bandwidth of 64 kbps and a maximum downstream bandwidth of 5 Mbps. Up to 3 PCs are allowed on this connection.

silver.cm—Users are given a maximum upstream bandwidth of 64 kbps and a maximum downstream bandwidth of 1 Mbps. Only 1 PC is allowed on this connection.

disable.cm—Users are denied access to the cable network. This configuration file can be used for users who have cancelled service or have not paid their bills.

!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
service udp-small-servers max-servers 500
!
hostname uBR10000
!
boot system slot0:
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file platinum.cm
   service-class 1 max-upstream 128
   service-class 1 guaranteed-upstream 10
   service-class 1 max-downstream 10000
   service-class 1 max-burst 1600
   cpe max 8
   timestamp
!
cable config-file gold.cm
   service-class 1 max-upstream 64
   service-class 1 max-downstream 5000
   service-class 1 max-burst 1600
   cpe max 3
   timestamp
!
cable config-file silver.cm
   service-class 1 max-upstream 64
   service-class 1 max-downstream 1000
   service-class 1 max-burst 1600
   cpe max 1
   timestamp
!
cable config-file disable.cm
   access-denied
   service-class 1 max-upstream 1
   service-class 1 max-downstream 1
   service-class 1 max-burst 1600
   cpe max 1
   timestamp
!
ip subnet-zero
ip cef
no ip domain-lookup
ip dhcp excluded-address 10.128.1.1 10.128.1.15
ip dhcp excluded-address 10.254.1.1 10.254.1.15
ip dhcp ping packets 1
!
ip dhcp pool CableModems
     network 10.128.1.0 255.255.255.0
     bootfile platinum.cm
     next-server 10.128.1.1
     default-router 10.128.1.1
     option 128 ip 10.128.1.1
     option 4 ip 10.128.1.1
     option 2 hex ffff.8f80
     option 11 ip 10.128.1.1
     option 10 ip 10.128.1.1
     lease 1 0 10
!
ip dhcp pool hosts
     network 10.254.1.0 255.255.255.0
     next-server 10.254.1.1
     default-router 10.254.1.1
     dns-server 10.254.1.1 10.128.1.1
     domain-name ExamplesDomainName.com
     lease 1 0 10
!
ip dhcp pool staticPC(012)
     host 10.254.1.12 255.255.255.0
     client-identifier 0108.0009.af34.e2
     client-name staticPC(012)
     lease infinite
!
ip dhcp pool goldmodem
     host 10.128.1.129 255.255.255.0
     client-identifier 0100.1095.817f.66
     bootfile gold.cm
!
ip dhcp pool DisabledModem(0010.aaaa.0001)
     host 10.128.1.9 255.255.255.0
     client-identifier 0100.1095.817f.66
     bootfile disable.cm
!
ip dhcp pool DisabledModem(0000.bbbb.0000)
     client-identifier 0100.00bb.bb00.00
     host 10.128.1.10 255.255.255.0
     bootfile disable.cm
!
interface bundle 1
ip address 5.102.0.1 255.255.0.0 secondary  
ip address 5.100.0.1 255.255.0.0  
cable arp filter request-send 3 2  
cable arp filter reply-accept 3 2  
no cable ip-multicast-echo  
cable dhcp-giaddr primary  
cable helper-address 172.18.73.210
!
interface Cable5/0/0
no ip address
no cable packet-cache
cable bundle 1
cable downstream channel-id 120
cable downstream annex B
cable downstream modulation 256qam
cable downstream interleave-depth 32
cable downstream frequency 561000000
no cable downstream rf-shutdown
cable upstream max-ports 4
cable upstream 0 connector 0
cable upstream 0 frequency 24000000
cable upstream 0 channel-width 3200000 3200000  
cable upstream 0 minislot-size 2  
cable upstream 0 power-level 0  
cable upstream 0 range-backoff 3 6  
cable upstream 0 modulation-profile 22  
no cable upstream 0 shutdown
!
ip classless
no ip forward-protocol udp netbios-ns
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip http server
!
!
alias exec scm show cable modem
alias exec scf show cable flap
alias exec scp show cable qos profile
!
line con 0
   transport input none
line aux 0
line vty 0 4
   login
!
end
 
   

The command lines in the sample configuration file beginning with the cable modulation-profile command contain the critical elements necessary to set up a modulation profile in your overall configuration:

cable modulation-profile 22 request 0 16 0 22 qpsk scrambler 152 no-diff 32 fixed
cable modulation-profile 22 initial 5 34 0 48 16qam scrambler 152 no-diff 392 fixed 
cable modulation-profile 22 station 5 34 0 48 16qam scrambler 152 no-diff 392 fixed 
cable modulation-profile 22 short 4 76 7 22 16qam scrambler 152 no-diff 128 shortened
cable modulation-profile 22 long 9 232 0 22 16qam scrambler 152 no-diff 128 shortened
 
   

In this case, the user has configured modulation profile number "22" to be available to upstream channels wherever they are configured to apply it. Note that this modulation profile has been configured to operate with a QAM-16 modulation scheme. The default modulation scheme for any upstream profile (if it is not set to QAM-16) is QPSK.

Later in the configuration file example, upstream port 0 on the cable interface card installed in slot 5 uses the modulation profile configured in the sample:

cable upstream 0 modulation-profile 22