Getting Started Guide vA5(1.0), Cisco ACE 4700 Series Application Control Engine Appliance
Configuring Health Monitoring Using Health Probes
Downloads: This chapterpdf (PDF - 118.0KB) The complete bookPDF (PDF - 2.98MB) | Feedback

Configuring Health Monitoring Using Health Probes

Table Of Contents

Configuring Health Monitoring Using Health Probes

Information About Configuring Health Monitoring

Prerequisites for Configuring Health Monitoring

Configuring an HTTP Health Probe

Configuring an HTTP Health Probe Using the Device Manager GUI

Configuring an HTTP Health Probe Using the CLI

Configuration Example for an HTTP Health Probe

Where to Go Next


Configuring Health Monitoring Using Health Probes


This chapter describes how to configure a health probe on the Cisco 4700 Series Application Control Engine (ACE) appliance. It outlines how to configure an HTTP probe.

This chapter contains the following sections:

Information About Configuring Health Monitoring

Prerequisites for Configuring Health Monitoring

Configuring an HTTP Health Probe

Configuration Example for an HTTP Health Probe

Where to Go Next

Information About Configuring Health Monitoring

After reading this chapter, you should have a basic understanding of how the ACE supports server health monitoring using health probes (sometimes referred to as "keepalives"), and how to configure an HTTP health probe.

To detect failures and make reliable load-balancing decisions, you can configure the ACE to track the health of servers and server farms by periodically sending out health probes. By default, the ACE implicitly checks for server failures.

You can configure probes on the ACE to make active connections and explicitly send traffic to servers. The ACE evaluates the server's response to determine the health of that server.

When the ACE determines the health of a server, the result is one of the following:

Passed—The server returned a valid response.

Failed—The server failed to provide a valid response to the ACE within a specified number of retries.

When a server fails in response to the probe, the ACE can check for network problems that prevent a client from accessing that server. The ACE can place the server out of service.

A probe can be any of several types, including HTTP, HTTPS, ICMP, TCP, Telnet, and UDP. You can also configure scripted probes using the TCL scripting language.

For information on how to configure other types of probes, see the Server Load-Balancing Guide, Cisco ACE Application Control Engine.

Prerequisites for Configuring Health Monitoring

Before you can configure health monitoring, you must configure one or more servers or a server farm. For details, see Chapter 6, Configuring Server Load Balancing.

Configuring an HTTP Health Probe

To configure health monitoring, you can use either the ACE Device Manager user interface (GUI) or the CLI.

Configuring an HTTP Health Probe Using the Device Manager GUI

Configuring an HTTP Health Probe Using the CLI

Configuring an HTTP Health Probe Using the Device Manager GUI

You can configure an HTTP health probe using the ACE Device Manager GUI by following these steps:


Step 1 Choose Load Balancing > Health Monitoring. The Health Monitoring pane appears.

Step 2 Click Add (+) to add a new health probe. The Health Monitoring window appears.

Step 3 Enter the following health probe attributes. Leave the remaining attributes blank or with their default values.

Name: HTTP_probe1

Type: HTTP

Probe Interval (Seconds): 5

Pass Detect Interval (Seconds): 10

Port: 80

Step 4 Click Deploy Now to deploy this configuration on the ACE appliance.

Step 5 Click the Expect Status tab at the bottom of the Health Monitoring window, then click Add to add a new health probe. The Expect Status configuration screen appears.

Step 6 Configure a single status code or a range of status code responses that the ACE expects from the probe destination. This parameter is required; without it, all HTTP or HTTPS probes will fail.

Enter a value of 200 for the Min. Expect Status Code and the Max. Expect Status Code.

Step 7 Click Deploy Now to deploy this configuration on the ACE appliance.

Step 8 Associate the health probe with a server farm by choosing Load Balancing > Server Farms. The Server Farms pane appears.

Step 9 Choose the server farm SF_web and click Edit. The Server Farms window appears.

Step 10 For Probes, choose HTTP_probe1 from the Available list, and click the right-arrow button to move the probe to the Selected list.

Step 11 Click Deploy Now to associate the health probe HTTP_probe1 with the server farm SF_web.


Configuring an HTTP Health Probe Using the CLI

You can configure an HTTP health probe using the CLI by following these steps:


Step 1 Verify that you are operating in the desired context by checking the CLI prompt. If necessary, change to the correct context.

host1/Admin# changeto VC_web
host1/VC_web#
 
   

Step 2 Enter configuration mode.

host1/VC_web# config
host1/VC_web(config)#
 
   

Step 3 Define an HTTP probe named HTPP_probe1 to access its configuration mode.

host1/VC_web(config)# probe http HTTP_probe1
host1/VC_web(config-probe-http)#
 
   

Step 4 Configures a single status code or a range of status code responses that the ACE expects from the probe destination. This parameter is required; without it, all HTTP or HTTPS probes will fail.

host1/VC_web(config-probe-http)# expect status 200 200 
 
   

Step 5 Configure port number 80 for the HTTP probe.

host1/VC_web(config-probe-http)# port 80
 
   

Step 6 Configure a time interval of 5 seconds between probes.

host1/VC_web(config-probe-http)# interval 5
 
   

Step 7 Configure a pass detect interval of 10 seconds, after which the ACE will send another probe to a failed server.

host1/VC_web(config-probe-http)# passdetect interval 10
 
   

Step 8 Exit probe configuration mode.

host1/VC_web(config-probe-http)# exit
host1/VC_web(config)#
 
   

Step 9 Associate the probe HTTP_probe1 with the server farm SF_web, and exit configuration mode.

host1/VC_web(config)# serverfarm SF_web
host1/VC_web(config-sfarm-host)# probe HTTP_probe1
host1/VC_web(config-sfarm-host)# exit
host1/VC_web(config)# exit
host1/VC_web#
 
   

Step 10 Display the HTTP probe configuration.

host1/VC_web# show running-config probe
 
   

Configuration Example for an HTTP Health Probe

The following example shows how to configure an HTTP health probe. The commands that you have configured in this chapter appear in bold text.

switch/VC_web(config)# do show running config
Generating configuration....
 
   
access-list INBOUND line 8 extended permit ip any any
 
   
probe http HTTP_PROBE1
  expect status 200 200
 
   
rserver host RS_WEB1
  description content server web-one
  ip address 10.10.50.10
  inservice
rserver host RS_WEB2
  description content server web-two
  ip address 10.10.50.11
  inservice
rserver host RS_WEB3
  description content server web-three
  ip address 10.10.50.12
  inservice
rserver host RS_WEB4
  description content server web-four
  ip address 10.10.50.13
  inservice
 
   
serverfarm host SF_WEB
  predictor hash header Accept
  probe HTTP_PROBE1
  rserver RS_WEB1 80
    inservice
  rserver RS_WEB2 80
    inservice
  rserver RS_WEB3 80
    inservice
  rserver RS_WEB4 80
    inservice
 
   
sticky http-cookie Cookie1 StickyGroup1
  timeout 3600
  serverfarm SF_WEB
 
   
ssl-proxy service SSL_PSERVICE_SERVER
  key cisco-sample-key
  cert cisco-sample-cert
 
   
class-map match-all CM_SSL
  2 match virtual-address 10.10.40.11 tcp eq https
class-map type management match-any REMOTE_ACCESS
  description Remote access traffic match
  2 match protocol ssh any
  3 match protocol telnet any
  4 match protocol icmp any
class-map match-all VS_WEB
  2 match virtual-address 10.10.40.10 tcp eq www
 
   
policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
  class REMOTE_ACCESS
    permit
 
   
policy-map type loadbalance first-match PM_LB
  class class-default
    serverfarm SF_WEB
 
   
policy-map multi-match PM_MULTI_MATCH
  class VS_WEB
    loadbalance vip inservice
    loadbalance policy PM_LB
policy-map multi-match PM_SSL
  class CM_SSL
    ssl-proxy server SSL_PSERVICE_SERVER
 
   
service-policy input REMOTE_MGMT_ALLOW_POLICY
 
   
interface vlan 400
  description Client connectivity on VLAN 400
  ip address 10.10.40.1 255.255.255.0
  access-group input INBOUND
  service-policy input PM_MULTI_MATCH
  service-policy input PM_SSL
  no shutdown
interface vlan 500
  description Server connectivity on VLAN 500
  ip address 10.10.50.1 255.255.255.0
  no shutdown
 
   
domain DOMAIN1
add-object all
 
   
ip route 0.0.0.0 0.0.0.0 172.25.91.1
username USER1 password 5 $1$vAN9gQDI$MmbmjQgJPj45lxbtzXPpB1  role SLB-Admin domain 
DOMAIN1

Where to Go Next

In this chapter, you have configured an HTTP health probe. In the next chapter, you will configure the the ACE for redundancy.