Guest

Cisco 2500 Series Wireless Controllers

Cisco 2500 Series Wireless Controller Deployment Guide

Document ID: 113034

Updated: Mar 03, 2015

Contributed by Nicolas Darchis, Cisco TAC Engineer.

   Print

Introduction

This document serves as a deployment guide for the Cisco 2500 Series Wireless Controller. The Cisco 2500 Series Wireless Controller is a cost-effective systems-wide wireless solution for retail, enterprise branches, and small and medium-sized businesses. The controller can scale in a network as the network grows.

The Cisco 2500 Series Wireless Controller blends into the Cisco Unified Wireless Network (CUWN) and works with both Cisco lightweight access points (APs) and the Cisco Wireless Control System (WCS) or Cisco Network Control System (NCS) or Prime Infrastructure (PI) in order to provide system-wide wireless LAN functions. The Cisco 2500 Series Wireless Controller provides real-time communication between wireless APs and other devices in order to deliver centralized security policies, guest access, wireless intrusion prevention system (wIPS), context-aware (location), Radio Frequency (RF) management, and quality of services (QoS) for mobility services such as voice and video, and OfficeExtend Access Point (OEAP) support for the teleworker solution.

The Cisco 2500 Series Wireless Controller supports a maximum of 50 lightweight APs in increments of 5 AP licenses with a minimum of a 5 AP license, which makes it a cost-effective solution for retail and small and medium-sized businesses. The Cisco 2500 Series Wireless Controller offers robust coverage with 802.11 a/b/g or delivers unprecedented reliability with the use of 802.11n, 802.11ac and Cisco Next-Generation Wireless Solutions and Cisco Enterprise Wireless Mesh.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the Cisco 2500 Series Wireless Controller.

Hardware Specifications

  • Data Ports - 4 x 1 Gigabit Ethernet Ports

  • Console Port - 1 x RJ45

  • External 48V Power Supply

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Additional Features

  • Support for Control and Provisioning of Wireless Access Points (CAPWAP) protocol.

  • Encryption on CAPWAP Data Tunnel (DTLS) (optional).

  • License-based AP count. AP Counts - 50 (in steps of 5, 25, 50). This was increased to 75 as of Release 7.4 software code.

  • Supported Client Count - 500 (In all STATE). This was increased to 1000 as of Release 7.4 software code.

  • Supported Tag Count - 500.

  • Triple Play Ready - Supports Data, Voice, and Video.

  • 500 Mbps of overall traffic throughput (no matter how many ports are connected). This was increased to 1Gbps as of Release 7.4 software code.

  • Link Aggregation Group (LAG) is available only as of Release 7.4 software code and later.

  • In Release 7.4 software code and later, the 2504 can act as a mobility anchor for up to 15 mobility tunnels towards other controllers.

  • The 2504 supports new mobility (that is, mobility with converged access controllers such as the 3850/5760) in Release 8.0 and later.

Note: The 2504 supports neither the wired guest feature before Release 8.0, nor the multicast-unicast feature (only multicast-multicast). It also does not support the Lync SDN and Flexconnect AVC features that are introduced in Release 8.1.

Note: For an accurate list of supported features, check the release notes for your specific software release, which contain a Features not supported on WLC 2504 paragraph.

Hardware Architecture of the Cisco 2500 Series Wireless Controller

These sections provide a greater insight into the architecture of the Cisco 2500 Series Wireless Controller.

The Cisco 2500 Series Wireless Controller physically has the same form factor as the Cisco 2106 controller. The CPU on a Cisco 2500 Series Wireless Controller is a multi-core CPU and can handle both data plane and wireless data traffic. The CPU can handle control plane application, which handles all the management traffic needed to "control" a wireless network.

The Cisco 2500 Series Wireless Controller has 1 GB system memory. Two types of memory devices are supported in order to store software images. The boot flash contains the boot code, and the compact flash contains the application code that can store multiple images. The front panel houses four Gigabit Ethernet ports. Two of the ports are 802.3af capable. All ports will transfer the traffic to/from the wireless network. The Power over Ethernet (PoE) ports on the Cisco 2500 Series Wireless Controller will not support directly attached APs although those APs might power up and join, it is not a supported scenario.

The Cisco 2500 Series Wireless Controller is powered by an external 48VDC power brick. The power brick can handle power input from 110VAC to 240VAC.

Basic Configuration of the Cisco 2500 Series Wireless Controller

These tools and information are needed before you can install the controller:

  • Wireless Controller hardware:

    • Controller with factory-supplied power cord and mounting hardware

    • Network, operating system service network, and AP cables as required for the CLI console

    • VT-100 terminal emulator on the CLI console (PC, laptop, or palmtop)

    • Null modem serial cable to connect the CLI console and controller

  • Local TFTP server (required in order to download the operating system software updates). Cisco uses an integral TFTP server. This means that third-party TFTP servers cannot run on the same workstation as the Cisco WCS because Cisco WCS and third-party TFTP servers use the same communication port.

If the controller is brought up for the first time with no prior configuration, it automatically enters into a wizard which asks you a series of configuration information. The wizard first will first prompt for user ID and password. This wizard cannot be bypassed and you must enter all the information it asks.

Caution: Do not connect a PoE cable to the console port. This action damages the controller.

Controller Configuration through the CLI

Before you can configure the controller for basic operations, you need to connect it to a PC that uses a VT-100 terminal emulator (such as HyperTerminal, ProComm, Minicom, or Tip). Complete these steps in order to connect the PC to the controller's console port:

  1. Plug the RJ-45 connector on a null-modem serial cable into the controller's console port and the other end of the cable into the PC's serial port.

  2. Start the PC's terminal emulation program.

  3. Configure the terminal emulation program for these parameters:

    • 9600 baud

    • 8 data bits

    • No flow control

    • 1 stop bit

    • No parity

The Cisco 2500 Series Wireless Controller has 4 Gigabit Ethernet ports. Each port is, by default, an 802.1Q VLAN trunk port. The VLAN trunking characteristics of the port are not configurable.

An interface is a logical entity on the controller. An interface has multiple parameters associated with it; which iinclude the IP address, default-gateway (for the IP subnet), primary physical port, secondary physical port, VLAN tag, and DHCP server. Since LAG is not used, each interface is mapped to at least one primary physical port and an optional secondary port. Multiple interfaces can be mapped to a single Wireless Controller port.

There are multiple types of interfaces on the Wireless Controller, four of which are static types that must be present and are configured at setup time:

  • Management interface (static and configured at setup time; mandatory)

  • AP-manager interface - Not required for the Cisco 2500 Series Wireless Controller

  • Virtual interface (static and configured at setup time; mandatory)

  • Dynamic interface (user-defined)

The management interface is the default interface for in-band management of the controller and connectivity to enterprise services such as Authentication, Authorization, and Accounting (AAA) servers. The management interface is also used for communications between the controller and APs. The management interface is the only consistently "pingable" in-band interface IP address on the controller. The management interface acts like an AP manager interface by default.

The dynamic interface with the "Dynamic AP Management" option enabled on it is used as the tunnel source for packets from the controller to the AP, and as the destination for CAPWAP packets from the AP to the controller. The dynamic interfaces for AP manager must have a unique IP address. Typically, this is configured on the same subnet as the management interface, but this is not necessarily a requirement. In the case of the Cisco 2500 Series Wireless Controller, a single dynamic AP manager can support any number of APs. However, as a best practice, it is suggested to have 4 separate dynamic AP manager interfaces and associate them to the 4 Gigabit interfaces. By default, the management interface acts like an AP-manager interface as well and it is associated to one Gigabit interface. As a result, if you use the management interface, you need to create only 3 more dynamic AP manager interfaces and associate them to the remaining 3 Gigabit interfaces.

The virtual interface is used to support mobility management, DHCP relay, and embedded Layer 3 security like guest web authentication and VPN termination. The virtual interface must be configured with an unassigned and unused gateway IP address. A typical virtual interface is 1.1.1.1. The virtual interface address is not pingable and should not exist in any routing table in your network.

Dynamic interfaces are created by users and are designed to be analogous to VLANs for wireless LAN client device. The Cisco 2500 Series Wireless Controller will support up to 16 dynamic interfaces. Dynamic interfaces must be configured on a unique IP network and VLAN. Each dynamic interface acts as a DHCP relay for wireless clients associated to wireless LANs (WLANs) mapped to the interface. A WLAN associates a Service Set Identifier (SSID) to an interface and is configured with security, QoS, radio policies, and other wireless network parameters. There can be up to 16 WLANs configured per controller. Management servers, such as a radius server and NTP server, should not be in a dynamic interface subnet but should be either in the management interface subnet or any other subnet not added to the WLC.

Note: LAG is supported on the Cisco 2500 Series Wireless Controller only on Release 7.4 software code and later.

Configure the Neighbor Switch

By default, all four ports on the Cisco 2500 Series Wireless Controller are 802.1Q trunk ports. The controller is always connected to a Gigabit Ethernet port on the neighboring switch. The neighbor switch port is configured as an 802.1Q trunk and only the appropriate VLANs are allowed on the trunk. All other VLANs are pruned. This is not necessary, but is a deployment best practice because when irrelevant VLANs are pruned, the controller only processes relevant frames which optimizes performance.

This is the 802.1Q switchport configuration:

switchport 
switchport trunk encapsulation dot1q
switchport trunk native vlan X
switchport trunk allowed vlan X
switchport mode trunk
end

Configure the Cisco 2500 Series Wireless Controller

Configure the Controller With the Startup Wizard

This wizard output is taken from Release 7.4 software, so it might be slightly different in other software releases.

(Cisco Controller)(Cisco Controller)


Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup


Would you like to terminate autoinstall? [yes]:
AUTO-INSTALL: starting now...
rc = 0
AUTO-INSTALL:no interfaces registered.
AUTO-INSTALL: process terminated - no configuration loaded


System Name [Cisco_b2:19:c4] (31 characters max):WLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (3 to 24 characters): *******
Re-enter Administrative Password                 : *******

Enable Link Aggregation (LAG) [yes][NO]: no

Management Interface IP Address: 10.48.39.212
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 10.48.39.5
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1 to 4]: 1
Management Interface DHCP Server IP Address: 10.48.39.5

Virtual Gateway IP Address: 1.1.1.1

Multicast IP Address: 239.1.1.1

Mobility/RF Group Name: Nico

Network Name (SSID): none

Configure DHCP Bridging Mode [yes][NO]: no

Allow Static IP Addresses [YES][no]: yes

Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.

Enter Country Code list (enter 'help' for a list of countries) [US]: BE

Enable 802.11b Network [YES][no]: yes
Enable 802.11a Network [YES][no]: yes
Enable 802.11g Network [YES][no]: yes
Enable Auto-RF [YES][no]: yes

Configure a NTP server now? [YES][no]: yes
Enter the NTP server's IP address: 10.48.39.33
Enter a polling interval between 3600 and 604800 secs: 3600

Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

Configuration saved!
Resetting system with new configuration...


Configuration saved!
Resetting system

Note: The previous configuration is an example. It might differ from one install to another.

(Cisco Controller) >show sysinfo

Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 7.4.121.0
Bootloader Version............................... 1.0.20
Field Recovery Image Version..................... 7.6.101.1
Firmware Version................................. PIC 16.0


Build Type....................................... DATA + WPS

System Name...................................... WLC
System Location..................................
System Contact...................................
System ObjectID.................................. 1.3.6.1.4.1.9.1.1279
IP Address....................................... 10.48.39.212
Last Reset....................................... Software reset
System Up Time................................... 0 days 0 hrs 14 mins 58 secs
System Timezone Location.........................
System Stats Realtime Interval................... 5
System Stats Normal Interval..................... 180


--More-- or (q)uit
Configured Country............................... BE  - Belgium
Operating Environment............................ Commercial (0 to 40 C)
Internal Temp Alarm Limits....................... 0 to 65 C
Internal Temperature............................. +31 C
External Temperature............................. +35 C
Fan Status....................................... 4300 rpm

State of 802.11b Network......................... Enabled
State of 802.11a Network......................... Enabled
Number of WLANs.................................. 1
Number of Active Clients......................... 0

Memory Current Usage............................. Unknown
Memory Average Usage............................. Unknown
CPU Current Usage................................ Unknown
CPU Average Usage................................ Unknown

Burned-in MAC Address............................ 84:78:AC:B2:19:C0
Maximum number of APs supported.................. 75

License Installation

The Cisco 2500 Series Wireless Controller does not have any licenses installed. Without any installed licenses, the APs will not be able to join the controller. It is recommended to install appropriate licenses on the Cisco 2500 Series Wireless Controller in order to work with the controller as you go forward. The Cisco 2500 Series Wireless Controller is shipped with an evaluation license for a period of 60 days (that is, 8 weeks 4 days). The evaluation license is a base license only.

The ordered license can be installed on the controller with either the CLI or the GUI. The license installed can be checked through both the CLI and the GUI. In both cases, there should be a TFTP server that hosts the license files.

(Cisco Controller) >license install ?
<url> tftp://<server ip>/<path>/<filename>
(Cisco Controller)

The show license all command displays the installed licenses.

Note: This license includes a data DTLS functionality.

(Cisco Controller) >show license all

License Store: Primary License Storage
StoreIndex: 2 Feature: base-ap-count Version: 1.0
License Type: Permanent
License State: Active, In Use

License Count: 50/50/0
License Priority: Medium
StoreIndex: 3 Feature: data encryption Version: 1.0
License Type: Permanent
License State: Active, In Use

License Count: Non-Counted
License Priority: Medium
License Store: Evaluation License Storage
StoreIndex: 0 Feature: base Version: 1.0
License Type: Evaluation
License State: Active, Not in Use, EULA accepted
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
License Count: Non-Counted
License Priority: Low
StoreIndex: 1 Feature: base-ap-count Version: 1.0
License Type: Evaluation
License State: Inactive
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
License Count: 50/0/0
License Priority: None
(Cisco Controller) >

Enable DTLS in the Cisco 2500 Series Controller

In order to enable DTLS on an AP or particularly on a group of APs, make sure that you have Data Encryption License installed in the controller. DTLS (Data Encryption) can be enabled on a per AP basis from the Advanced tab once you select the AP details.

Select an AP, go to the Advanced tab, and check the Data Encryption check box.

(Cisco Controller) >config ap link-encryption enable ? 
<Cisco AP> Enter the name of the Cisco AP. all Apply the configuration for
all capable Cisco AP
(Cisco Controller) >config ap link-encryption enable J-3502E
(Cisco Controller) >show ap link-encryption all
Encryption Dnstream Upstream Last
AP Name State Count Count Update
-------------- --- -------- -------- ------
J-3502E En 102 747 22:12
J-1262 Dis 0 0 22:12
J-1040 Dis 0 0 22:13
J-1140 Dis 0 0 22:10

(Cisco Controller) >show dtls connections

AP Name Local Port Peer IP Peer Port Ciphersuite
------------ ------------- ------------- ---------- ------------------
J-3502E Capwap_Ctrl 10.10.10.116 41066 TLS_RSA_WITH_AES_128_CBC_SHA
J-3502E Capwap_Data 10.10.10.116 41066 TLS_RSA_WITH_AES_128_CBC_SHA
J-1262 Capwap_Ctrl 10.10.10.120 45543 TLS_RSA_WITH_AES_128_CBC_SHA
J-1040 Capwap_Ctrl 10.10.10.122 65274 TLS_RSA_WITH_AES_128_CBC_SHA
J-1140 Capwap_Ctrl 10.10.10.123 4825 TLS_RSA_WITH_AES_128_CBC_SHA

(Cisco Controller) >

Configure the PI and Add the Cisco 2500 Series Wireless Controller

PI is the current management software used to manage the Cisco 2500 Series Wireless Controller. Earlier versions were called WCS or NCS. It provides advanced management tools like wireless coverage display and location-based services. There is a close relation between the software version of the management system (Prime Infrastructure/NCS/WCS) and the WLC software version. See the wireless software compatibility matrix as well as the Prime Infrastructure and WLC release notes for supported compatible releases. Prime Infrastructure uses SNMP in order to manage wireless controllers, access points, and client devices. The Cisco 2500 Series Wireless Controller devices need to have SNMP configured correctly.

Complete these steps:

  1. Log in to the PI web interface with the URL:

    https://<prime-ip-address>

  2. SNMPv2 is configured on the Cisco 2500 Series Wireless Controller. In order to configure SNMPv2 through the Controller web interface, select Management > SNMP > Communities. The Cisco 2500 Series Wireless Controller defaults are Read-Only community public and Read-Write community private. Add new communities or modify as necessary. For simplicity, the defaults are used.

  3. In the PI interface, select Operate > Device work center. Select Add device from the menu bar. Note that this might differ dependent upon if you use the classic theme from PI or if you ucs NCS or WCS.

  4. Enter the IP Address of the Cisco 2500 Series Wireless Controller management interface and configure the appropriate SNMP parameters. Click OK.

    The controller is added successfully and the Cisco 2500 Series Wireless Controller is ready to be provisioned by PI.

In order to verify the Cisco 2500 Series Wireless Controller after it is added in PI, go check back in the device work center if it is successfully synced and managed. Wrong SNMP credentials might leave it "unmanaged".

Cisco 2500 Series Wireless Controller Deployment Scenarios

The Cisco 2500 Series Wireless Controller provides a cost effective Unified wireless solution. Although the controller has multiple 10/100/1000 ports, it does not behave like switches or routers. It is not recommended to use different ports as a hub/switch implementation. This fundamental point is a key aspect to get the best performance out of the controller.

The Cisco 2500 Series Wireless Controller supports multiple uplink ports. In Release 7.4 and later you can use LAG in order to build an etherchannel and treat several ports as just one connection. Or, you can disable LAG and configure a system where management and dynamic interfaces can be configured on different physical ports, and data traffic can switch back and forth infra network from respective physical ports.

The Cisco 2500 Series Wireless Controller also supports multiple AP-managers (for AP Load Balancing) where multiple AP-managers can be configured in addition to an AP-manager which is bounded with a management interface. In this case, it is recommended to have all AP-managers in the same subnet as a management interface.

<CISCO2504> >show interface summary

Interface Name Port Vlan Id IP Address Type Ap Mgr Guest
--------------------- ---- -------- -------------- ------- ------ -----
apmgr2 2 10 10.10.10.12 Dynamic Yes No
apmgr3 3 10 10.10.10.13 Dynamic Yes No
apmgr4 4 10 10.10.10.14 Dynamic Yes No
management 1 10 10.10.10.10 Static Yes No
virtual N/A N/A 1.1.1.1 Static No No

<CISCO2504> >

In the above output, the management interface and AP-manager are bounded together to port 1. Three more AP-managers are created on other physical ports (2, 3, and 4) in the same subnet as management interfaces.

APs that join the controller are load balanced such that each port on the controller shares the load of the 50 APs. Each port in the previous configuration allows 13 APs to join the controller.

It is also possible to have multiple AP-managers in a different subnet than the management interface. However, in this case, it is recommended that you disable the AP-manager from the management interface and create another AP-manager interface on different physical ports in a different subnet than the management interface. All multiple AP-managers in this scenario should be in the same subnet.

<CISCO2504> >show interface summary

Interface Name Port Vlan Id IP Address Type Ap Mgr Guest
--------------------- ---- -------- -------------- ------- ------ -----
apmgr2 2 11 10.10.11.12 Dynamic Yes No
apmgr3 3 11 10.10.11.13 Dynamic Yes No
apmgr4 4 11 10.10.11.14 Dynamic Yes No
management 1 10 10.10.10.10 Static No No
virtual N/A N/A 1.1.1.1 Static No No

<CISCO2504> >

In the previous output, management and AP-manager are not bounded. In this scenario, multiple AP-managers can be created in a different subnet from the management interface and mapped to different physical ports.

Note: The internal DHCP server only works (for wireless clients) with DHCP proxy enabled.

Some of the scenarios supported by the Cisco 2500 Series Wireless Controller are described here with sample configurations.

Scenario 1

The management interface with an embedded AP-Manager is configured on Port 1. Two WLANs are configured on the controller. WLAN 1 and WLAN 2 are mapped to the management interface.

A simple topology has the Cisco 2500 Series Wireless Controller connected to a Catalyst 3560 switch. Gigabit Ethernet port 1 on the controller is connected to Gigabit Ethernet port 1/0/1 on the switch.

Switch#sh run int gig 1/0/1
Building configuration...

Current configuration : 123 bytes
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
end

Switch#

The management interface configuration on the Cisco 2500 Series Wireless Controller is straightforward and has dynamic AP management enabled.

Two WLANs are configured. WLAN1 and WLAN2 are mapped to the management interface and service clients.

<CISCO2504> >show wlan summ

Number of WLANs.................................. 2

WLAN ID WLAN Profile Name / SSID Status Interface Name
------- ------------------------------------- -------- --------------------
1 WLAN1 / WLAN1 Enabled management
2 WLAN2 / WLAN2 Enabled management

<CISCO2504> >

Internal DHCP Server with DHCP Proxy Enabled

The DHCP server TestVlan10 is configured on the controller and this scope services APs and clients. The DHCP server configuration on the controller is simple.

<CISCO2504> >show dhcp summary

Scope Name Enabled Address Range
TestVlan10 Yes 10.10.10.100 -> 10.10.10.200


<CISCO2504> >show dhcp detailed TestVlan10
Scope: TestVlan10

Enabled................................... Yes
Lease Time................................ 36400 <10 hours 6 minutes 40 seconds>
Pool Start................................ 10.10.10.100
Pool End.................................. 10.10.10.200
Network................................... 10.10.10.0
Netmask................................... 255.255.255.0
Default Routers........................... 10.10.10.10 0.0.0.0 0.0.0.0
DNS Domain................................
DNS....................................... 0.0.0.0 0.0.0.0 0.0.0.0
Netbios Name Servers...................... 0.0.0.0 0.0.0.0 0.0.0.0

<CISCO2504> >

This is the DHCP configuration capture from the GUI of the Cisco 2500 Series Wireless Controller:

The DHCP Proxy is enabled on all Cisco controllers by default.

In the all of the previous configurations, VLAN10 is not tagged on the switch. All traffic from the switch is sourced to Port 1 on the controller. APs and client traffic are forwarded to the controller untagged.

APs are connected to the Catalyst switch with these switchport configurations. The switchport can either be trunked or configured to be an access port.

Switch#sh run int gig 1/0/9
Building configuration...

Current configuration : 132 bytes
!
interface GigabitEthernet1/0/9
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
end

Switch#sh run int gig 1/0/10
Building configuration...

Current configuration : 66 bytes
!
interface GigabitEthernet1/0/10
switchport access vlan 10
end

Switch#

The AP can join the controller and the status of the AP can be verified on the controller. There are two APs that have joined the controller and can be confirmed by the status in this capture:

<CISCO2504> >show ap join stats summary all

Number of APs.............................................. 2

Base Mac AP EthernetMac AP Name IP Address Status
00:22:90:96:69:00 00:22:90:90:ab:d3 AP0022.9090.abd3 10.10.10.103 Joined
ec:44:76:b9:7d:c0 c4:7d:4f:3a:e3:78 APc47d.4f3a.e378 10.10.10.105 Joined


<CISCO2504> >show ap summary

Number of APs.................................... 2

Global AP User Name.............................. Not Configured
Global AP Dot1x User Name........................ Not Configured

AP Name Slots AP Model Ethernet MAC Location
---------------- ----- ----------------- ----------------- ----------------
AP0022.9090.abd3 2 AIR-LAP1142N-A-K9 00:22:90:90:ab:d3 default location
APc47d.4f3a.e378 2 AIR-CAP3502E-A-K9 c4:7d:4f:3a:e3:78 default location

Port Country Priority
---- ------- ------
1 US 1
1 US 1

The APs that have joined the controller can also be verified by the AP's summary on the controller. Configure both the AP name and the location of the AP install.

Configure the controller name and IP address under High Availability in order to prime the AP.

With this configuration, the AP joins the configured controller as the first preference.

External DHCP Server with DHCP Proxy Disabled

This is a general setup that has been in practice for all Cisco controllers for some deployments. The configurations are almost the same as noted previously, but have the DHCP Proxy disabled.

The AP-manager interfaces in this scenario point to an external DHCP server.

Note: It is recommended to enable either an internal DHCP server or an external DHCP server.

ip dhcp excluded-address 10.10.11.1 10.10.11.150
!
ip dhcp pool VLAN11
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1
!

External DHCP Server with DHCP Proxy Enabled

This is a general setup that is one of the best practices for all Cisco controllers. The configurations are almost the same as noted in the previous with DHCP Proxy enabled.

The management interface in this scenario is always directed to an external DHCP server.

ip dhcp excluded-address 10.10.11.1 10.10.11.150
!
ip dhcp pool VLAN11
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1
!

Scenario 2

The management interface with AP-manager enabled is mapped to port 1. Dynamic interface dynamic11 is mapped to another physical interface (port 2) for data traffic. WLAN 1 is mapped to the management interface and WLAN 2 is mapped to the dynamic interface.

One more DHCP scope is configured on the controller. This configured DHCP Scope TestVlan11 is mapped to the dynamic-interface configured on the controller.

<CISCO2504> >show dhcp summary

Scope Name Enabled Address Range
TestVlan10 Yes 10.10.10.100 -> 10.10.10.200
TestVlan11 Yes 10.10.11.100 -> 10.10.11.200


<CISCO2504> >show dhcp detailed TestVlan11
Scope: TestVlan10

Enabled................................... Yes
Lease Time................................ 36400 <10 hours 6 minutes 40 seconds>
Pool Start................................ 10.10.11.100
Pool End.................................. 10.10.11.200
Network................................... 10.10.11.0
Netmask................................... 255.255.255.0
Default Routers........................... 10.10.11.10 0.0.0.0 0.0.0.0
DNS Domain................................
DNS....................................... 0.0.0.0 0.0.0.0 0.0.0.0
Netbios Name Servers...................... 0.0.0.0 0.0.0.0 0.0.0.0

<CISCO2504> >

Internal DHCP Server with DHCP Proxy Enabled

By default, the DHCP Proxy is enabled on the controller as seen in one of the previous captures. Dynamic interface dynamic11 is configured and is mapped to VLAN11. The interface is also mapped to the configured internal DHCP server. The dynamic interface is not enabled for dynamic AP management.

One of the configured WLANs is mapped to the management interface and the second WLAN is mapped to the configured dynamic interface dynamic11. The primary DHCP server is a necessity for configuration in this scenario, but should be pointed to the management interface.

External DHCP Server with DHCP Proxy Disabled

Clients successfully get IP addresses from the configured external DHCP server. Verify the status of the internal DHCP server and make sure that the internal DHCP server is disabled.

External DHCP Server with DHCP Proxy Enabled

Clients successfully get IP addresses from the configured external DHCP server.

Scenario 3

The management interface with AP-manager enabled is mapped to port 1. Port 2 is configured to be a backport. WLAN 1 is mapped to the management interface.

In this scenario the management and dynamic interfaces are configured on Port 1 with either the internal DHCP server or the external DHCP server. Ports 1 and 2 are connected to 2 different switches. This provides redundancy to the Layer 2 and Layer 3 switch network as shown in this topology and interface captures.

Scenario 4 : LAG

In Release 7.4 and later software on the WLC, it is possible to configure LAG. Note that the overall 2504 WLC throughput stays 1 Gbps no matter how many ports you connect.

In this scenario, port 1 and 2 of the WLC 2504 were connected to the same switch on port 8 and 10 bundled into port-channel 1. It is required to plug all WLC ports to the same switch (unless in the case of 2 catalyst 6000 in VSS or Nexus in VPC).

(Cisco Controller) >show port summary

STP Admin Physical Physical Link Link
Pr Type Stat Mode Mode Status Status Trap POE
-- ------- ---- ------- ---------- ---------- ------ ------- -------
1 Normal Forw Enable Auto 1000 Full Up Enable N/A
2 Normal Forw Enable Auto 1000 Full Up Enable N/A
3 Normal Disa Enable Auto Auto Down Enable N/A
4 Normal Disa Enable Auto Auto Down Enable N/A


(Cisco Controller) >show lag summary

LAG Enabled

(Cisco Controller) >show interface summary


Number of Interfaces.......................... 2

Interface Name Port Vlan Id IP Address Type Ap Mgr Guest
-------------------------------- ---- -------- --------------- ------- ------ -----
management LAG untagged 10.48.39.212 Static Yes No
virtual N/A N/A 1.1.1.1 Static No No

(Cisco Controller) >show interface detailed management

Interface Name................................... management
MAC Address...................................... 84:78:ac:b2:19:cf
IP Address....................................... 10.48.39.212
IP Netmask....................................... 255.255.255.0
IP Gateway....................................... 10.48.39.5
External NAT IP State............................ Disabled
External NAT IP Address.......................... 0.0.0.0
VLAN............................................. untagged
Quarantine-vlan.................................. 0
Active Physical Port............................. LAG (13)
Primary Physical Port............................ LAG (13)
Backup Physical Port............................. Unconfigured
DHCP Proxy Mode.................................. Global
Primary DHCP Server.............................. 10.48.39.5
Secondary DHCP Server............................ Unconfigured
DHCP Option 82................................... Disabled
ACL.............................................. Unconfigured
mDNS Profile Name................................ Unconfigured
AP Manager....................................... Yes
Guest Interface.................................. No
L2 Multicast..................................... Enabled

You can see that it is now impossible to select ports for interfaces on the WLC as they are all attached to the LAG port bundle (which will always show as number 13).

On the switch, all ports that participate in the bundle must have the exact same configuration (especially trunk native VLAN and allowed VLANs). In this example, allowed VLANs were limited to what will be used on the WLC which is a best practice.

Once the interfaces are bundled together with the command channel-group X mode on, a port channel interface of number X is created. Any further change of the configuration should be completed on the port channel interface and not on the individual ports anymore.

Nico3560C#show run int g0/8
Building configuration...

Current configuration : 208 bytes
!
interface GigabitEthernet0/8
switchport access vlan 33
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,30-39
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on
end

Nico3560C#show run int g0/10
Building configuration...

Current configuration : 182 bytes
!
interface GigabitEthernet0/10
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,30-39
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on
end


Nico3560C#show etherchannel 1 summ
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) - Gi0/8(P) Gi0/10(P)

Nico3560C#

Nico3560C#show run int po1
Building configuration...

Current configuration : 131 bytes
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,30-39
switchport mode trunk
end

 The command eterchannel load-balance src-dst-ip is also required on the switch globally for this to work.

These are just a few designs implemented by users in order to leverage the wireless service to their client devices with CUWN.

Guidelines to Deploy the Cisco 2500 Wireless Controller

Ethernet ports on the Cisco 2500 Series Wireless Controllers do not work as Switch ports (that is, two machines directly connected to these ports cannot communicate with each other). You should not connect servers, such as DHCP, TFTP, and so on, on these ports and expect Wireless Clients and APs to receive an IP address from this DHCP server.

Ethernet ports on the Cisco 2500 Series Wireless Controller should only be used to connect/uplink to an infrastructure network configured as a data interface (management interface and dynamic interfaces) or an AP-managers interface.

If multiple Ethernet ports on a Cisco 2500 Series Wireless Controller are uplinked to an infrastructure switch, you should make sure data interfaces (management or dynamic interfaces) or AP-managers interfaces are configured for these uplinked physical ports. Physical Ethernet ports which are used as an uplink to an infra switch should not be left unconfigured. This might result in unexpected behaviors.

Multicast unicast is not a supported configuration on the Cisco 2500 Series Wireless Controller. As a result, HREAP/Flexconnect APs are not able to receive multicast traffic because HREAP/Flexconnect APs only work with multicast unicast.

Web Express Setup

In Version 7.6.130 and later, the WLC offers an Express version of the GUI. It is a way to configure it via the GUI, but is also a simplified monitoring dashboard that shows the first time you connect.

On the first GUI connection you will see this:

This page shows all monitoring data in an easy and accessible manner. In order to reach the "old" and complete GUI, you can click Advanced in the upper right corner. Once you are in Advanced mode, you cannot go back to the express GUI unless you configured the WLC. As a benefit of the Express Setup GUI, you will have a home button on the upper right corner of the WLC page to return to the Express monitoring page.

In order to configure the 2504 via the Express Setup GUI, you need to connect a PC to port 2, wait for the SYS led to turn green, and then browse to 192.168.1.1 in your browser. This only works on port 2, which allows you to connect port 1 of the WLC for network connectivity.

Configuration of the controller via the Express Setup GUI also changes various default settings to better match small businesses deployments.

A special wizard will then appear for configuration:

High Availability

In Release 7.5 software code and later, the 2500 can be purchased as HA-SKU. This means that the 2504 can then act as N+1 WLC. It still does not support AP SSO.

The HA SKU WLC does not require a license and stands there in case any other WLC of its mobility group fails. It can then support a maximum AP count license for 90 days, which starts when the original WLC failed and when APS started to join the HA-SKU. There is no configuration replication in N+1 redudancy. Check the High Availability deployment guide for more information on HA.

It is also possible to turn a non-HA SKU WLC into an HA SKU when you enable the HA SKU secondary unit :

Updated: Mar 03, 2015
Document ID: 113034