Guest

Wireless, LAN (WLAN)

VLANs on Wireless LAN Controllers Configuration Example

Document ID: 68100

Updated: Aug 26, 2011

   Print

Introduction

This document describes how to configure VLANs on Wireless LAN controllers (WLCs).

Prerequisites

Requirements

There are no specific requirements for this document. However, this document assumes that there is a working DHCP server to provide IP addresses to the access points (APs) that are registered to the controller.

Components Used

The information in this document is based on these software and hardware versions:

  • Configuration A:

    • Catalyst switch that runs Cisco IOS® Software and a WLAN controller

    • Cisco 4404 WLAN Controller that runs software version 7.0

  • Configuration B:

    • Catalyst switch that runs Catalyst OS (CatOS) software and a WLAN controller

    • Cisco 4404 WLAN Controller that runs software version 7.0

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Dynamic Interfaces on WLCs

Dynamic interfaces, also known as VLAN interfaces, are created by users and designed to be analogous to VLANs for Wireless LAN clients. A controller can support up to 512 dynamic interfaces (VLANs). Each dynamic interface is individually configured and allows separate communication streams to exist on any or all of the distribution system ports of the controller. Each dynamic interface controls VLAN and other communications between controllers and all other network devices, and each acts as a DHCP relay for wireless clients associated to WLANs mapped to the interface. You can assign dynamic interfaces to distribution system ports, WLANs, the Layer 2 management interface, and the Layer 3 AP-manager interface. You can also map the dynamic interface to a backup port.

You can configure zero, one, or multiple dynamic interfaces on a distribution system port. However, all dynamic interfaces must be on a different VLAN or IP subnet from all other interfaces configured on the port. If the port is untagged, all dynamic interfaces must be on a different IP subnet from any other interface configured on the port.

Configuring a dynamic interface with a secondary subnet is not supported.

Cisco recommends using tagged VLANs for dynamic interfaces.

VLANs with WLAN controllers use this model:

wlan_controllers_vlans1.gif

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Catalyst Switch Configurations

This section uses these configurations:

Catalyst Switch That Runs Cisco IOS Software
lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

Catalyst Switch That Runs CatOS Software
controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- This command should be on one line.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

WLAN Controller VLAN Configuration

GUI Configuration

Complete these steps on the WLAN controller.

  1. From the WLC GUI, choose Controller > Interfaces. The Interfaces page lists all the interfaces that are configured on the WLC. In order to create a new dynamic interface, click New.

    wlan_controllers_vlans2.gif

  2. Enter the Interface Name and VLAN Identifier and click Apply.

    wlan_controllers_vlans3.gif

  3. Enter the parameters specific to this VLAN. Some of the parameters include the IP Address, Netmask, Gateway, and the DHCP server IP address, and click Apply.

    Here is an example.

    wlan_controllers_vlans4.gif

    Note: The IP address assigned to this interface acts as the DHCP relay for a client to obtain an IP address from the DHCP server. For example, when a client attempts to associate to a WLAN/SSID (see step 5 in this configuration) mapped to this dynamic interface, it performs a local subnet broadcast to identify the DHCP server. The controller sends a request to the DHCP server (or to itself if it is the DHCP server for the segment) with the IP address of this dynamic interface as relay IP to the DHCP server configured for this interface. The DHCP server assigns an IP address to the client from the configured DHCP scope.

  4. Verify the interface configuration.

    Click the Controller tab in the menu at the top of the window, and choose Interfaces from the menu on the left.

    wlan_controllers_vlans5.gif

  5. Click the WLANs tab in the menu at the top of the window, and click Create New.

    wlan_controllers_vlans6.gif

  6. Enter the Service set identifier (SSID) and Profile Name and click Apply.

    This example uses vlan 15 for ease of understanding.

    wlan_controllers_vlans7.gif

  7. Select vlan 15 from the Interface Name drop-down menu at the bottom of the window, and click Apply.

    In this case, SSID vlan 15 is tied to Interface Name vlan 15.

    wlan_controllers_vlans8.gif

CLI Configuration

Use this section in order to configure your VLAN via command-line interface (CLI).

  1. Create the interface and the associated VLAN tag.

    The command is config interface create interface_name vlan_id .

    (lab5wlc4404ip15) >config interface create "vlan 15" 15
    

    Note: If there is a space in the VLAN/WLAN name as is the case in this example, make sure the name is in quotes.

  2. Define the IP address and default gateway.

    The command is config interface interface_name IP_address netmask gateway .

    (lab5wlc4404ip15) >config interface address "vlan 15" 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- This command should be on one line.
    
    
  3. Define the DHCP server.

    The command is config interface dhcp dynamic-interface <interface-name> primary <primary-server> [secondary] <secondary-server> .

    (lab5wlc4404ip15) >config interface dhcp dynamic-interface "vlan 15" primary 1
    2.168.15.15
    
  4. Issue this command in order to map the interface to a physical port:

    config interface port operator_defined_interface_name physical_ds_port_number. . Here is an example:

    (Cisco Controller) >config interface port "vlan 15" 2
    
  5. Verify the interface configuration.

    The command is show interface summary.

    (Cisco Controller) >show interface summary
    
    Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Guest
    -------------------------------- ---- -------- --------------- ------- ------ ----
    ap-manager                       2    untagged 10.77.244.207   Static  Yes    N
    
    management                       2    untagged 10.77.244.206   Static  No     N
    
    service-port                     N/A  N/A      50.0.0.1        Static  No     N
    
    virtual                          N/A  N/A      1.1.1.1         Static  No     N
    
    vlan 15                          2    15       192.168.15.10   Dynamic No     N
  6. Define the WLAN.

    The command is config wlan create wlan_id name .

    (lab5wlc4404ip15) >config wlan create 2 "vlan 15"
    
  7. Define the interface for the WLAN.

    The command is config wlan interface wlan_id interface_name .

    (lab5wlc4404ip15) >config wlan interface 2 "vlan 15"
    
  8. Verify the WLAN and the associated interface.

    The command is show wlan summary.

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN ID�  WLAN Name�������������� Status���� �� Interface Name����������������� 
    -------� �--------------------�   ---------� ���--------------------------------
    1������� �lab5wlc4404ip15������   Enabled����   management��������������������� 
    2������� �vlan 15����������������� Disabled���   vlan 15������������������������� 
    
    (lab5wlc4404ip15) >

Click this link in order to view a Cisco Support Community video that describes how to configure VLANs on Wireless LAN controllers:

VLANs on Wireless LAN Controllers leavingcisco.com

wlan_controllers_vlans9.gif

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Catalyst Switches Verification

  • Catalyst switch that runs Cisco IOS Software— show running-config interface interface_type interface_number

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • Catalyst switch that runs CatOS software—show config mod

    controller-catos> (enable) show config 2
    
    !--- This command shows non-default configurations only.
    !--- Issue the show config mod all command in order to  
    !--- show both default and non-default configurations.
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

WLAN Controller VLAN Verification

See the WLAN Controller VLAN Configuration section of this document, which includes verification steps.

Troubleshoot

Use this section to troubleshoot your configuration.

Troubleshooting Procedure

Complete these instructions in order to troubleshoot your configuration.

  1. Ping from the WLAN controller to the default gateway that is configured on the VLAN routed interface, and then ping in the opposite direction.

    • WLAN controller:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • VLAN routed interface:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = ½/4 ms
      lab1sup720ip1#
  2. If the pings are unsuccessful, deploy a packet capture/sniffer at the switch and check in order to verify proper VLAN tagging.

    Note: When you initiate the ping from your controller to a Layer 3 gateway, which is on the same subnet as your dynamic interface, the controller appears to source the ping from the dynamic interface.

Related Information

Updated: Aug 26, 2011
Document ID: 68100