Guest

Wireless, LAN (WLAN)

Wireless LAN Controller Module (WLCM) Configuration Examples

Document ID: 70530

Updated: Feb 19, 2007

   Print

Introduction

The Cisco WLAN Controller (WLC) module (WLCM) enables Cisco ISRs and Cisco 3700 Series Routers to manage up to six wireless LAN (WLAN) access points (APs) and simplifies the deployment and management WLANs. It is equivalent to a Cisco WLC 2006 put into an NM form factor. The only difference is that the NM-WLC (WLCM module) has only one Fast Ethernet port internally connected to the host router and the external Fast Ethernet port on the NM faceplate is disabled and unusable. This document explains how to configure the WLCM for different scenarios.

Prerequisites

Requirements

Ensure that you meet these requirements before you attempt this configuration:

  • Basic knowledge of Lightweight Access Point Protocol (LWAPP)

  • Basic knowledge of the WLC and Lightweight APs (LAPs)

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Basic Configuration

Think of the NM-WLC as an external WLC (2006) with only one Fast Ethernet (FE) interface (known as port 1) connected internally to the Fast Ethernet interface of a router named the WLAN Controller interface. This diagram shows an example.

Note: The external FastEthernet port on the faceplate of the Cisco WLC module is not supported.

nm-wlc-config-guide-1.gif

The usual way to connect to the module is internally within the router with the service-module session command.

  1. Insert the NM-WLC module onto the router and boot up the router with a valid image.

    Any image (from ipbase to adventerprisek9) can support the NM-WLC module. This feature was introduced with Cisco IOS Software Release 12.4(2)XA1 (router software). The minimum controller firmware version should be 3.2.78.0 (controller software).

  2. Configure an IP address on the interface wlan-controller 1/0; assuming the module is plugged into slot 1 of the router. Perform a no shut if it is in the shutdown state.

    c2811#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    c2811(config)#
    c2811(config)#interface wlan-controller 1/0
    c2811(config-if)#ip address 192.168.99.254 255.255.255.0
    c2811(config-if)#no shut
    c2811(config-if)#end
    c2811#
  3. From the privileged exec prompt, open a session to the controller using the service-module session command.

    c2811#service-module wlan-controller 1/0 session 
    Trying 192.168.99.254, 2066 ... Open

    Note: Cisco IOS commands for theWLCM module varies on the Router that runs Cisco IOS Software Release 12.4(15) T or later. Refer to Configuring the Cisco WLCM in the Router for more information.

If the controller is brought up for the first time with no prior configuration, it automatically enters into a CLI wizard that asks you a series of configuration information. This wizard cannot be bypassed and you must enter all the information it asks. Understanding beforehand how you want your configurations to look when completed helps answer the questions. Some of the information it asks is not relevant and used right away but you still need to supply them because it does not accept invalid input and you also cannot bypass. The output appears similar to the output in this table:

Cisco Controller
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
 
Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24
 
AP Manager Interface IP Address: 192.168.99.25
 
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24
 
Virtual Gateway IP Address: 1.1.1.1
 
Mobility/RF Group Name: mg1
 
Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no
 
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
 
Enter Country Code (enter 'help' for a list of countries) [US]: US
 
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

Once the configuration is complete, it automatically reboots with the new configuration and stops at the User: prompt where you supply a username and password. The (Cisco Controller) > prompt then appears.

User:admin
Password:*****
(Cisco Controller) >

Once you are in the controller prompt, you can do further configurations or modifications of what you did through the CLI wizard. Use ? for help.

In order to switch back to the router, press ctrl+shift+6, release, and then press x. This takes you to the router prompt. The session remains intact, so if you press Enter, it takes you back to the controller. If you want to completely clear the session, enter disconnect at the router prompt.

Even though the controller has only one physical port (referred to as port 1), you can create any number of logical interfaces on it, static or dynamic, and those interfaces can be VLAN-tagged or untagged. By default, the controller has two static and untagged interfaces:

  • Management interface

  • AP-manager interface

The Management interface is used for management purposes. If you choose to use a web-based GUI interface in order to manage the WLCM, you need to configure the IP address on the Management interface and make that reachable from the workstation you plan to manage it from.

Note: By default, the HTTP server on the controller is disabled but secure HTTP is enabled. Therefore, the URL to the controller management IP address must be https://mgt-ip-address.

The AP-manager interface is used by the controller to talk to the LAPs. Since both management and AP-manager interfaces are untagged, they must be in the same IP subnet as the interface WLC on the router.

(Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254
(Cisco Controller) config>interface address ap-manager 
                           192.168.99.25 255.255.255.0 192.168.99.254

You can configure the CLI in two ways. One is from the regular prompt by preceding the CLI with config. The other method is to go to the config prompt with the config command and then issue CLIs without the word config. For example:

 (Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254

or

(Cisco Controller)>config interface address management 
                        192.168.99.24 255.255.255.0 192.168.99.254

This example configures the management interface with IP address 192.168.99.24/24 and defines the default gateway as 192.168.99.254.

Note: The default gateway on Management and AP Management should point to the IP address of the WLCM Ethernet port.

Note: Once you configure these IP addresses via the wizard then you do not need these commands. This is just to show you that both these IP addresses belong to the same subnet and this can also be configured via the command line.

In both cases, the last IP address (192.168.99.254) is the default gateway IP address. Since the only way out of the controller is via the host router, the default gateway should be the IP address of the interface wlan-controller1/0 on the router. With this much configuration, you can ping from the router to the management interface IP address of the controller.

c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811# 

Example 1 - Basic Configuration with an AP Connected to a Router Onboard the Fast Ethernet/Gigabit Ethernet

When an LAP connected to the onboard Gigabit Ethernet interface (g0/0) of a router is powered on, it sends a DHCP request for an IP address. In this example, the router is configured as a DHCP server with the IP address pool of 192.168.100.0/24 network. So, the LAP gets an IP address of 192.168.100.101. The DHCP offer also tells the LAP (via option 43) that the controller IP address is 192.168.99.24 (the management IP address of controller). The LAP now sends a controller discovery message unicast to 192.168.99.24. The controller offers the registration and as a result, LAP registers with the controller.

Use the show ap summary command in order to see the LAP that registers with the WLCM.

(Cisco Controller) >show ap summary

AP Name             Slots  AP Type    MAC Addr           Location          Port
------------------  -----  ---------  -----------------  ---------------- 	----
AP11                 2     Cisco      00:0b:85:01:03:30                   	1

In this example, the controller is configured with two WLANs (wl15 and wl16) as described later in the document.

Client C1 sends an association request with SSID wl15. It associates and gets an IP address of 192.168.15.101 and a default gateway of 192.168.15.1 from the DHCP server configured on the router.

Client C2 also sends an association request with SSID wl16. It associates and gets an IP address of 192.168.16.101 and a default gateway of 192.168.16.1. Now there are two clients in two different subnets. Communication between them is possible by means of a router that performs the routing between its two sub-interfaces (wlc1/0.15 and wlc1/0.16) as this diagram shows:

The configuration required on the devices for this setup is discussed in the Controller Configuration section of this document.

nm-wlc-config-guide-2.gif

Controller Configuration

This section discusses the configuration required on the controller module.

  1. Create two dynamic interfaces named vl15 in VLAN 15 and vl16 in VLAN 16.

    (Cisco Controller) >config interface create vl15 15
    (Cisco Controller) >config interface create vl16 16
    
  2. Assign the IP address, netmask, and default gateway for these VLAN interfaces.

    (Cisco Controller) >config interface address vl15 
                                  192.168.15.254 255.255.255.0 192.168.15.1
    
    (Cisco Controller) >config interface address vl16 
                                  192.168.16.254 255.255.255.0 192.168.16.1
    

    Note: The default gateway for the dynamic interfaces must be the sub-interface IP address on the router for the corresponding VLAN.

  3. Create two WLANs 15 and 16 with corresponding SSIDs wl15 and wl16.

    (Cisco Controller) >wlan create 15 wl15
    (Cisco Controller) >wlan create 16 wl16
    
  4. Bind these WLANs with the corresponding VLAN interfaces you created (on the wired side).

    (Cisco Controller) >wlan interface 15 vl15
    (Cisco Controller) >wlan interface 16 vl16
    
  5. Configure the dynamic interfaces you created with a DHCP server IP address to forward the client DHCP requests to.

    Since the DHCP server is configured on the router, it should point to the corresponding sub-interface IP addresses of the router. If you have an external DHCP server, then it should point to that IP address.

    (Cisco Controller) >interface dhcp vl15 192.168.15.1
    (Cisco Controller) >interface dhcp vl16 192.168.16.1
    
  6. By default, the authentication method is dot1X and it is enabled. In order to work with open authentication, disable it with this command for both WLANs:

    (Cisco Controller) >wlan security 802.1X disable 15
    (Cisco Controller) >wlan security 802.1X disable 16
    

This configuration can be expanded based on your needs such as more VLANs/WLANs, authentication (Lightweight Extensible Authentication Protocol [LEAP], EAP), QoS, and so forth.

Note: With WLCM, it is difficult for a LAP to discover the WLCM through IP subnet broadcast. This is because of the way the WLCM integrates on the backplane and the LAP and the Gigabit interface of the 2800 router which is directly connected with LAP needs to be the same subnet. If you want to perform IP subnet broadcast discovery with success, use the ip helper-address/ip forward-protocol udp 12223 commands. In general, the purpose of these commands is to forward/relay potentially any IP broadcast frame. Simply relaying and directing it to the WLC management interface should be adequate to get the WLC to respond back to the LAP.

Note: All of the controller configurations in this section can easily be done through GUI access via a web browser once the management interface is configured with an IP address, netmask, and gateway information. Also, any routing required on the network for your browser stations to be able to reach the controller is done. The URL to open the GUI page is https://192.168.99.24.

Router Configuration

Complete these steps in order to configure the router for the setup this section describes.

  1. Configure interface G0/0 on the router that it is connected to the LAP.

  2. Configure interface wlan-controller 1/0 with an IP address from the 192.168.99.0/24 network and sub-interfaces w1/0.15 in VLAN 15 and w1/0.16 in VLAN 16 with IP addresses from networks 192.168.15.0/24 and 192.168.16.0/24.

  3. Configure a DHCP server on the router with several pools defined.

    • Pool lwapp-ap assigns an IP address to the AP from the 192.168.100.0/24 network which also includes DHCP option 43 that informs the AP of the controller IP address to contact.

    • Pool client-15 assigns an IP address to the clients (wired/wireless) in VLAN 15 from the 192.168.15.0/24 network.

    • Pool client-16 assigns an IP address to the clients (wired/wireless) in VLAN 16 from the 192.168.16.0/24 network.

This output shows the configuration on the router:

Router
!		
interface GigabitEthernet0/0								
Description: Connected to AP							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 duplex auto									
 speed auto
									
!										
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap

!--- Creates a DHCP pool for the LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15

!--- Creates a DHCP pool for users that connect to WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16

!--- Creates a DHCP pool for users that connect to WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!										
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15

!--- Creates a sub-interface for VLAN 15.
						
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16

!--- Creates a sub-interface for VLAN 16.
					
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0							
!

Example 2 - VLAN Configurations with APs Connected to an External Switch

The WLCM plugged into the router can be logically considered equivalent to an external WLC connected to the router via an Ethernet interface as this diagram shows. With the assumption that the network module is plugged into slot 1 of the router, typical connectivity consists of:

  • A WLCM connected to the router through interface wlan-controller 1/0.

  • A Layer 2 switch connected to routers onboard Gigabit Ethernet interface G0/0.

  • A Lightweight AP Protocol (LWAPP) AP connected to the switch.

  • Wireless clients C1 and C2 associated with the AP, one in WLAN 15 and the other in WLAN 16.

This example shows how two wireless VLANs or WLANs (wl15 and wl16) are created on the controller, mapped to corresponding wired side VLAN 15 and VLAN 16, and how routing between the VLAN 15 and VLAN 16 is done by the router through dot1Q sub-interfaces.

On the router, create one sub-interface under the WLC interface (in interface configuration mode) for every VLAN, assign it to the corresponding VLAN, and configure the IP address from the respective subnets.

See the Controller Configuration section of this document for the configurations required on the devices for this setup.

nm-wlc-config-guide-3.gif

Controller Configuration

Complete these steps on the controller module for this setup.

  1. On the controller, for every VLAN, create one dynamic interface in the corresponding VLAN and assign an IP address, netmask, and default gateways from the respective subnets.

    (Cisco Controller)#configure interface create vl15 15
    (Cisco Controller)#configure interface create vl16 16
    
    (Cisco Controller)#configure interface address 
                      Vl15 192.168.15.254 255.255.255.0 192.168.15.1
    (Cisco Controller)#configure interface address 
                      Vl16 192.168.16.254 255.255.255.0 192.168.16.1
    
  2. Create two WLANs 15 and 16 with corresponding SSIDs wl15 and wl16.

    (Cisco Controller)#configure wlan create 15 wl15
    (Cisco Controller)#configure wlan create 16 wl16
    
  3. Bind these WLANs with the corresponding VLAN interfaces you created (on the wired side).

    (Cisco Controller)#configure wlan interface 15 Vl15
    (Cisco Controller)#configure wlan interface 16 Vl16
    
  4. Configure the DHCP server information on the interfaces of the controllers (for wireless clients) that point to the respective sub-interface IP addresses on the router.

    (Cisco Controller)#configure interface dhcp vl15 192.168.15.1
    (Cisco Controller)#configure interface dhcp Vl16 192.168.16.1
    

With these configurations, the two wireless clients in two WLANs should be up and running, with the assumption that the appropriate security configuration is also done. The traffic from the client in WLAN 15 destined to the client in WLAN 16 is routed between the sub-interfaces w1/0.15 and w1/0.16 on the router. The same configurations can be extended for any number of VLANs up to the maximum number of supported VLANs for the controller (16).

Switch Configuration

With the assumption that all wired clients are connected to the switch (for example, cat3750) which is trunked to the router through interface Gig 1/0/1 for inter-LAN routing, connect the LWAPP AP into interface F1/0/1 on the switch and configure it for VLAN 100.

Interface Fastethernet 1/0/1
Description: Connected to LWAPP AP
Switchport access vlan 100
Switchport mode access
!
Interface Gigabitethernet 1/0/1
Description: Connected to Router
Switchport trunk encapsulation dot1Q
Switchport mode trunk

Router Configuration

Complete these steps on the router.

  1. Configure interface G0/0 that it is connected to the switch and also the required sub-interfaces for inter-VLAN routing for the wired LAN.

  2. Configure interface wlan-controller 1/0 with an IP address from the 192.168.99.0/24 network and sub-interfaces w1/0.15 in VLAN 15 and w1/0.16 in VLAN 16 with IP addresses from networks 192.168.15.0/24 and 192.168.16.0/24.

  3. Configure a DHCP server on the router with several pools defined.

    • Pool lwapp-ap assigns an IP address to the AP from the 192.168.100.0/24 network which also includes DHCP option 43 that informs the AP of the controller IP address to contact.

    • Pool client-15 assigns an IP address to the clients (wired/wireless) in VLAN 15 from the 192.168.15.0/24 network.

    • Pool client-16 assigns an IP address to the clients (wired/wireless) in VLAN 16 from the 192.168.16.0/24 network.

    Note: Separate pools are needed for APs and clients.

Router
ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
								
ip dhcp pool client-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 

ip dhcp pool client-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet0/0
Description: Connected to AP
No ip address							
 load-interval 30									
 duplex auto									
 speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0	
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0

Note: You can also run DHCP services for the clients on the controller. But it is recommended to run on the router as the controller is not a full-fledged DHCP server and cannot pass on options like the TFTP server required for applications like Cisco CallManager Express.

With this configuration, the AP is able to get the IP address, find, and register with the controller. Two wireless clients C1 and C2 should be able to associate with the AP and get the IP address from the respective subnets.

Example 3 - Configurations with APs Connected to an EtherSwitch on the Router and Merging Corresponding VLANs from Wired and Wireless LANs

In this scenario, there is an EtherSwitch HWIC plugged into ISR HWIC slot 0 and an NM-WLC plugged into NM slot 1. Wired client C3 is connected to interface F0/0/1 in VLAN 15 with an IP address of 192.168.15.102 and wired client C4 is connected to F0/0/2 in VLAN 16 with an IP address of 192.168.16.102.

The LWAPP AP is connected to interface F0/0/0 in VLAN 100 with an IP address of 192.168.100.1. The router is configured as a DHCP server to serve an IP address to the AP. For example, an AP receives an IP address of 192.168.100.101, a default gateway of 192.168.100.1 and a controller IP address of 192.168.99.24 via Option 43.

Note: The configuration required on the controller is similar to the configuration explained in the previous example and is not discussed here. The remaining sections provide the configuration required on the router.

nm-wlc-config-guide-4.gif

Wireless clients C1 and C2 associate with the LAP in wl15 and wl16 respectively. Wireless clients C1 and C2 also get an IP address of 192.168.15.101 and 192.168.16.101 assigned by the DHCP server configured on the router or an external DHCP server with IP pools for those subnets. If the DHCP server is external, the IP helper address must be configured on the corresponding VLAN and sub-interfaces. From the perspective of the router, it has two wired VLANs represented by interface VLAN 15 and interface VLAN 16 and two wireless VLANs represented by dot1Q sub-interfaces w1/0.15 and w1/0.16 under the WLC interface on the router.

In order to collapse wired VLAN 15 and wireless WLAN 15 together, configure interface VLAN 15 and interface w1/0.15 under a common bridge group, for example, bridge-group 15. Similarly, in order to collapse wired VLAN 16 and wireless WLAN 16, configure interface VLAN 16 and interface w1/0.16 under a common bridge group, for example, bridge-group 16. With this configuration, corresponding wired and wireless VLANs belong to the same IP subnets 192.168.15.0/24 and 192.168.16.0/24 and can talk to each other within the bridge group. But in order for the clients in two different bridge groups to communicate to each other, enable Integrated Routing and Bridging (IRB) on the router so that they communicate via the BVI interfaces in the respective bridge groups.

Note: This configuration is based on the assumption that you have EtherSwitch HWIC or NM-ESW on the router for wired LAN. If you have the EtherSwitch service module (NME-ESW) instead of the NM/HWIC, the VLAN interfaces are replaced by corresponding dot1Q sub-interfaces under the Gigabit Ethernet interface on the router and the rest of the configuration remains same.

Router Configuration
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 


interface FastEthernet0/0/0								
Description: Connected to AP
Switchport mode access
Switchport access vlan 100
!
interface FastEthernet0/0/1								
Description: Connected to C3
Switchport mode access
Switchport access vlan 15
!
interface FastEthernet0/0/2								
Description: Connected to C4
Switchport mode access
Switchport access vlan 16
!
Interface vlan 15
Bridge-group 15
!
Interface vlan 16
Bridge-group 16

Interface vlan 100							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Example 4 - Configurations with Wired VLANs under NME-ESW merged with Wireless VLANs under NM-WLC

Consider this scenario where you have an EtherSwitch Service Module (NME-ESW) plugged into ISR NM slot 2 and an NM-WLC plugged into NM slot 1. The NME-ESW can be considered equivalent to an external switch connected to the router through a Gigabit Ethernet link. Wired client C3 is connected to interface F0/0/1 in VLAN 15 with IP address 192.168.15.102 and wired client C4 connected to F0/0/2 in VLAN 16 with IP address 192.168.16.102

The LWAPP AP is connected to interface F0/0/3 in VLAN 100. The EtherSwitch internal interface (G1/0/2) is internally connected to the host router with interface Gigabit Ethernet 2/0. Since there is more than one VLAN in the switch, the internal link between the switch and router should be configured as a trunk. The router is configured as a DHCP server with several pools in order to serve the IP address to the AP and clients (wired and wireless).

The AP gets an IP address of 192.168.100.101, a default gateway of 192.168.100.1 and a controller IP address of 192.168.99.24 via Option 43, and discovers and registers with the controller. Wireless clients C1 and C2 associate with the LAP in WLAN 15 and 16 and get IP address 192.168.15.101 and 192.168.16.101 respectively. The wired clients C3 and C4 in VLAN 15 and 16 also get an IP address of 192.168.15.102 and 192.168.16.102 from the DHCP server.

In order to merge wired VLAN 15 with wireless WLAN 15, configure interfaces G2/0.15 and interface w1/0.15 under a common bridge group 15. Similarly, bridge group 16 under interfaces G2/0.16 and W1/0.16. The two bridge groups communicate to each other through their BVI interfaces BVI15 and BVI16.

The controller configuration remains same as in the earlier scenarios.

nm-wlc-config-guide-5.gif

Router Configuration

Router Configuration
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet2/0								
Description: Internally connected to Etherswitch
IP address 20.0.0.1 255.255.255.0
load-interval 30
!
Interface GigabitEthernet2/0.100
Encapsulation dot1Q 100							
 ip address 192.168.100.1 255.255.255.0						

Interface GigabitEthernet2/0.15
Encapsulation dot1Q 15							
 Bridge-group 15
!
Interface GigabitEthernet2/0.16
Encapsulation dot1Q 16							
Bridge-group 16									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Switch Configuration

Open a session from the router to the EtherSwitch Service Module with the service-module session command. Once on the switch, configure the switch as this output shows:

!
Interface GigabitEthernet 1/0/2
Description: Internally connected to router G2/0 interface.
Switchport trunk encapsulation dot1Q
Switchport mode trunk

!
Interface Fastethernet 0/0/1
Description: Connected to Client C3 in vlan 15
Switchport access vlan 15
Switchport mode access
!
Interface Fastethernet 0/0/2
Description: Connected to Client C4 in vlan 16
Switchport access vlan 16
Switchport mode access
!
Interface Fastethernet 0/0/3
Description: Connected to Client LWAPP AP in vlan 100
Switchport access vlan 100
Switchport mode access

Related Information

Updated: Feb 19, 2007
Document ID: 70530