Guest

Frame Relay

Configuring ISDN Backup for WAN Links Using Floating Static Routes

Document ID: 10214

Updated: Aug 17, 2004

   Print

Introduction

This sample configuration shows you how to back up a frame relay link with Integrated Services Digital Network (ISDN) by using floating static routes and dial-on-demand (DDR) routing.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This configuration was developed and tested using the software and hardware versions below.

  • Cisco 2503 Routers

  • Cisco IOS® Software Release 12.2(7b) was running on both routers

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Background Theory

One implementation goal of WAN links is to provide a way to back up the link, should it fail. ISDN frequently provides this backup. Cisco provides backup strategies that can achieve the same functionality but in different ways. If routing information is passed across the frame relay link, a floating static route can bring up the backup link if the frame relay link stops passing information.

Note: This example shows a backup for Frame Relay using floating static routes. However, you can also use this method to backup any WAN link.

Other solutions can employ a backup interface (See Configuring a Backup Interface for a Subinterface) or Dialer watch. If you use the backup interface command approach, point-to-point subinterfaces are advantageous because the main or multipoint interfaces can remain in an up/up state even if permanent virtual connections (PVCs) go down with frame relay.

For more information on configuring DDR backup, refer to the document Configuring and Troubleshooting DDR Backup. You can also refer to the document Evaluating Backup Interfaces, Floating Static Routes, and Dialer Watch for DDR Backup for more information on the various DDR backup methods.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup tool for IOS.

Network Diagram

This document uses the network setup shown in the diagram below.

fr_isdn_backup.gif

Configurations

This document uses the configurations shown below.

This configuration was tested using Cisco IOS Software Release 12.2(7b) on 2500 series routers. The same configuration concepts would apply to a similar router topology or other Cisco IOS releases.

Router1 (Cisco 2503 Router)
Current configuration:

version 12.2
!
hostname Router1
!

!--- This username password pair is used for 
!--- PPP CHAP authentication

username Router2 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0

!--- Primary Link.
!--- The bandwidth is adjusted to allow for rapid backup of the link.


!--- This adjusts the EIGRP Hello interval and 
!--- Hold time for rapid convergence.
!--- The bandwidth command does not actually change the bandwidth of the link,
!--- it only adjusts the routing protocol bandwidth parameter.

 bandwidth 2048
 ip address 172.16.2.1 255.255.255.128
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0

! -- Backup link.

 ip address 172.16.3.1 255.255.255.0

! -- The backup link is in a different subnet.
! -- The BRI interface on the peer should also be in this subnet.

 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer map ip 172.16.3.2 name Router2 broadcast 5552000

! -- Dialer map for the peer. Note the IP address and name.
! -- The name must match the authenticated username of the peer.

 dialer load-threshold 5 either
 dialer-group 1

! -- Apply interesting traffic definition.
! -- Interesting traffic definition is defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink
!
router eigrp 100

!--- This example uses eigrp. 
!--- You can use any routing protocol instead.

 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.4.0 255.255.255.0 172.16.3.2 200

!--- The floating static route is defined.
!--- Note the administrative distance of the route is 200.
!--- Hence it is only used when all other routes for 172.16.4.0/24 
!--- are lost. Note that the next hop for the floating static route 
!--- matches the dialer map ip. If the nexthop is not the same as 
!--- in the dialer map then the router will no dial.

!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any

!--- EIGRP routing packets are denied in the dialer-list.


!--- This prevents eigrp packets from keeping the link up.
!--- Adjust the interesting traffic depending on your traffic definitions.

!
dialer-list 1 protocol ip list 100

!---  Interesting traffic defintion. Use access-list 100.
!---  The interesting traffic is applied to BRI interface 
!--- using dialer-group 1. 

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

A floating static has been configured for Router1. The floating static route has an assigned administrative distance of 200. A route for the same subnet will also be learned over the frame relay link via the Enhanced Interior Gateway Routing Protocol (EIGRP), which emphasizes the additional or redundant nature of the floating route. EIGRP learnt route will be installed in the routing table because of its lower administrative distance 90, compared to that of the static route's 200. In the event of Frame Relay link failure, EIGRP route will disappear from the routing table, the floating static route is installed. Any interesting traffic to be sent across the ISDN connection brings up the line. When connectivity is restored over the frame relay, the route is learned again through EIGRP. This route replaces the static route and direct traffic once again over the frame relay circuit.

Routing protocol traffic is marked as uninteresting in the dialer list so that it does not cause the ISDN line to connect or remain connected. However, once the link is up, EIGRP packets can cross the link and the two routers can exchange routing information. The broadcast keyword has been included in the dialer map statement to allow the passage of routing protocol traffic over the ISDN link. If you do not want EIGRP to exchange routing information even if the ISDN link is up, do not include the broadcast keyword in the dialer map statement.

The dialer load-threshold command sets a load that will trigger a concurrent call to be placed on the second B channel. Multilink Point-to-Point Protocol (PPP) has been configured (ppp multilink)so that both ISDN B channels can be bundled together as one Virtual-Access interface for aggregate bandwidth.

In the current configuration, only Router1 is configured to place a call. Router2 receives calls from Router1. If you want both sides to bring up the link, add dialer map and dialer load-threshold commands to the configuration of Router2.

Router2 (Cisco 2503 Router)
Current configuration:

version 12.2
!
!
hostname Router2
!
username Router1 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 bandwidth 2048
 ip address 172.16.2.2 255.255.255.128
 encapsulation frame-relay
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
 clockrate 64000
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0

! -- IP address of backup interface.
! -- This router accepts the call. Note the IP address matches both the 
! -- dialer map floating static router nexthop on the peer.

 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink

!--- The missing dialer map command disables 
!--- this router from making the call.

!
router eigrp 100
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 200
!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
line con 0
line aux 0
line vty 0 4
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Routing Table Changes

Note: Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output;

Observe the routing tables below from Router1. Notice that the floating static route replaced the EIGRP learned route, after Router2 became unreachable over the Frame Relay link.

Shown below is the routing table of Router1, when the Frame Relay link is up.

Router1#show ip route      
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
            inter area      
            * - candidate default, U - per-user static route, o - ODR 
            P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
      [D 172.16.4.0/2490/1787392] via 172.16.2.2, 00:06:56, Serial0
     
!---  EIGRP learned route over Frame Relay link 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

When connectivity over the frame relay link is lost, Router1 installs the floating static route in its routing table as shown below.

Router1#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
     S 172.16.4.0/24 [200/0] via 172.16.3.2 
     
!--- Floating static route. Administrative distance is 200 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

Any interesting traffic to the network 172.16.4.0/24 now brings up the ISDN connection. For example, from Router1, a ping to 172.16.4.1 brings up the ISDN link as shown below.

Note: If you make the routing protocol interesting, then the periodic traffic brings up the link automatically. The downside of this is that the link will remain up indefinitely, possibly resulting in high toll charges.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms 
Router1# 
3d22h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
3d22h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up 
3d22h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552000 Router2 
Router1# 

Since the ISDN line is up, EIGRP now starts exchaging routing information over the ISDN connection. This causes Router1 to install the EIGRP route into its routing table, pointing to the next-hop 172.16.3.2.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is not set 

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks 
D      172.16.4.0/24 [90/40537600] via 172.16.3.2, 00:00:17, BRI0

!--- EIGRP route learnt over the ISDN link 

C      172.16.3.2/32 is directly connected, BRI0 
C      172.16.1.0/24 is directly connected, Ethernet0 
C      172.16.2.0/25 is directly connected, Serial0 
C      172.16.3.0/24 is directly connected, BRI0 
Router1# 

Interesting traffic is the traffic that will initiate the ISDN call and is defined by the dialer-list command. In the above configuration, the dialer-list points to the access-list number 100 which permits all IP packets except EIGRP packets. This means, all IP packets, except EIGRP packets, can bring up the ISDN connection. Once the connection is made, any traffic, including EIGRP traffic, is allowed to go across the link. But if no interesting traffic crosses the ISDN link for the duration of the dialer idle timer, the link will be brought down and no EIGRP routes will be exchanged. At this point, floating static route will again be installed in Router1's routing table.

Troubleshoot

For information on troubleshooting the floating static route refer to the document Configuring and Troubleshooting DDR Backup. This document addresses common symptoms such as:

  • The Backup link is not dialed when the primary link goes down.

  • The Backup link dials but does not connect to the other side.

  • The backup link is not deactivated when the primary link recovers.

  • The backup link is not stable (for example, it flaps) when the primary interface is down.

For Frame Relay specific troubleshooting refer to Configuring Frame Relay Backup

The following commands can help to troubleshoot the backup link.:

Before attempting any of the above debug commands, please see Important Information on Debug Commands.

Debug Output

Routing protocol traffic (EIGRP) is marked as uninteresting by the dialer list command, so it will not bring up the link or keep it up. However, when the link is active, routing updates will be exchanged. The debug dialer packet command can verify if the correct traffic can bring up a link. Output is shown below.

Router1#debug dialer packets 
Dial on demand packets debugging is on 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: cdp, 273 bytes, outgoing uninteresting (no list matched) 

Interesting traffic (Internet Control Message Protocol (ICMP) echoes in this case) will reset the idle timer and keep the link up as below. Uninteresting traffic is passed but will not keep the link up if the idle timer expires.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/51/80 ms 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping) 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 

Though marked as uninteresting, EIGRP packets cross the ISDN link, because the connection is already made by the interesting ICMP traffic.

Related Information

Updated: Aug 17, 2004
Document ID: 10214