Guest

Gateway Protocols

MGCP Support on a VRF Enabled Router Configuration Example

Document ID: 113180

Updated: Aug 22, 2011

   Print

Introduction

This document describes how to configure Message Gateway Control Protocol (MGCP) on a Voice Routing and Forwarding (VRF) enabled router.

There are two main elements you should understand regarding MGCP:

  • Endpoints

  • Call Agents

Endpoints are any of the voice ports on the designated gateway. These voice ports provide connectivity to both analog ports, such as Foreign Exchange Office (FXO)/Foreign Exchange Station (FXS), and digital trunks, such as a T1 or E1, to the PSTN. Gateways can have multiple endpoints dependent on the number of ports it contains.

Call agents are external control devices in a voice system. Cisco CallManager is the call agent referenced in this document. In MGCP, the call agent is the device that has complete control of the gateway. This is a very efficient system as all the administration is performed by the call agent. There is very little setup required on the end of the gateway, as all route patterns and dial-plans are configured on the Cisco CallManager.

It is important to remember that this protocol is used for control purposes only. No voice data is transmitted through the MGCP protocol itself. All the voice data transfer occurs directly between the phone and the gateway. This graphic depicts the MGCP communications relationships:

mgcp-support-vrf-enabled-01.gif

The Cisco IP phones in this example use the Skinny Call Control Protocol (SCCP) to communicate with the Cisco CallManager. The actual voice data is transferred through Real-time Transport Protocol (RTP) directly between the two devices. MGCP is used by the Cisco CallManager only to control the gateway.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco IOS Software Version 12.4(24)T 4

  • Cisco 2800 Series Router

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

MGCP and VRF Lite

VRF Routing intelligence does not exist in the MGCP protocol.

Since MGCP is not a "VRF-aware” protocol, you cannot configure an IOS voice gateway to put MGCP traffic into the voice VRF. MGCP traffic will only use the default routing table of the router regardless of VRF configurations.

There are two solutions to support MGCP in a typical VRF deployment. Refer to this typical VRF Network scenario:

mgcp-support-vrf-enabled-02.gif

Using two routers you can establish one, that is, with the MGCP gateway acting as a basic router (no VRFs) providing Ethernet traffic to a second router that does MPLS VRF routing. You can then route MGCP traffic over a VRF router as it is just a routing technique and MGCP is unaware.

mgcp-support-vrf-enabled-03.gif

Another similar solution is to use a single VRF router and utilize a second available interface to direct MGCP traffic out to the voice network.

mgcp-support-vrf-enabled-04.gif

Connecting the interface to the voice VLAN on the switching network allows the MGCP protocols to be routed back into the router via the VRF interface and ultimately the CallManager.

The global route of the VRF router only needs to be given an IP and a static route pointing to the IP of the VRF interface or a DHCP address off the voice VLAN. See these configuration details:

hostname VRF_MGCP_rtr
!
ip DATA
rd 65232:1
route-target export 65232:1
route-target import 65232:1
!
ip VOICE
rd 65232:3
route-target export 65232:3
route-target import 65232:3
!
interface GigabitEthernet0/0
 description MGCP interface
 ip address dhcp 
!-- USE DHCP or Static IP address from VOICE VLAN

!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed auto
 no keepalive
!
interface GigabitEthernet0/1.100
description DATA VLAN
encapsulation dot1Q 1 native
ip forwarding DATA
ip address 10.1.232.1 255.255.255.0
ntp broadcast
!
Interface GigabitEthernet0/1.300
Description VOICE VLAN
encapsulation dot1Q 2
ip forwarding VOICE
ip address 10.2.20.129 255.255.255.128
!
Interface Serial0/0/0
no ip address
no encapsulation ppp
encapsulation frame-relay IETF
!
interface Serial0/0/0.100 point-to-point
description DATA PVC
ip forwarding DATA
ip address 10.1.52.198 255.255.255.252
frame-relay interface-dlci 100 IETF
!
interface Serial0/0/0.300 point-to-point
description VOICE PVC
ip forwarding VOICE
ip address 10.2.54.198 255.255.255.252
frame-relay interface-dlci 300 IETF
!
mgcp
mgcp call-agent 10.1.255.241 2427 service-type mgcp version 0.1
mgcp bind control source-interface GigabitEthernet0/0 
!-- Bind to MGCP Interface

mgcp bind media source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!

Verify

There is currently no verification procedure available for this configuration.

Related Information

Updated: Aug 22, 2011
Document ID: 113180