Guest

Telephony Signaling

VoIP with Common Channel Signaling (CCS)

Cisco - VoIP with Common Channel Signaling (CCS)

Document ID: 14079

Updated: Nov 20, 2006

   Print

Introduction

This document illustrates the configurations necessary for the two routers in this document to communicate via Voice over IP (VoIP) and Common Channel Signaling (CCS) over a digital PRI.

It is important to note that in this configuration, the two routers are connected back-to-back over an IP segment. In most topologies however, the voice-enabled routers can exist anywhere. Usually, the voice routers are connected via LAN connectivity to other routers that are connected to the WAN. This is important to note because if your voice routers are not connected over a leased-line, all WAN connectivity configuration commands are configured on those routers that are connected to the WAN, and not on the voice routers, as they are in the configurations in this document.

While a Cisco 3640 router and a Cisco AS5300 router are used in this configuration example, these configurations can also be used for Cisco 2600 series routers.

Prerequisites

Requirements

Before you can configure your Cisco router to use VoIP, it is best if you understand the concepts of Quality of Service (QoS) features in Cisco IOS® software. To learn more about QoS features, refer to Queuing, Traffic Shaping, and Filtering and QoS Signaling from the Cisco IOS QoS page on Cisco.com.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco 2600 and 3640 Series Routers

  • Cisco AS5300

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

T1 Signaling: CAS and CCS

Signaling in the Telephony world provides functions such as supervising and advertising line status, alerting devices when a call is trying to connect, and routing and addressing information.

There are two different types of signaling information within the T1 world:

  • CCS

  • Channel Associated Signaling (CAS)

CCS

CCS is the transmission of signaling information out of the information band. The most notable and widely used form of this signaling type is ISDN. One disadvantage to the use of an ISDN PRI is the removal of one DS0, or voice channel. In this case, for signaling use. Therefore, one T1 would have twenty-three DS0s, or B-channels for user data, and one DS0, or D-channel for signaling. It is possible to control multiple PRIs with a single D-channel with each using Non Facility Associated Signaling (NFAS). Therefore, you can configure the other PRIs in the NFAS group to use all twenty-four DS0s as B-channels. The use of PRI signaling ensures the maximum possible connection rates, especially with the advent of 56 K modems. This illustrates the clear channel capability of ISDN.

Another disadvantage of using CCS (as seen in the network diagram) is that the PBX needs a digital T1 PRI card, which is more expensive than an E&M signaling card. An E&M signaling card is used in the same network diagram if you run CAS between the AS5300 and the PBX.

CAS

CAS is the transmission of signaling information within the information band, or in-band signaling. This means that voice signals travel on the same circuits as line status, address, and alerting signals. As there are twenty-four channels on a full T1 line, CAS interleaves signaling packets within voice packets. Therefore, there are a full twenty-four channels to use for voice.

Various types of CAS signaling are available in the T1 world. The most common forms of CAS signaling are loopstart, groundstart, and E&M signaling. The biggest disadvantage of CAS signaling is that the network uses bits from information IP packets, such as voice packets, to perform signaling functions. CAS signaling is thus often referred to as robbed-bit signaling.

CAS is not the optimal choice when one attempts to achieve the highest possible connection rates with modems. Most modems can adjust to the signal quality and still give high-speed reliable connections. However, the use of 56 K modems on CAS lines drops the connection speeds by almost 2 K in the downstream direction of communication per trunk that uses CAS signaling.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

voip_pri_cookbook_topo.gif

Configurations

This document uses these configurations:

Cisco 3640 San Jose
sanjose3640A#show run
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3640
!
logging buffered 60000 debugging
enable password cisco
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 3/0/0
 operation 4-wire
!
voice-port 3/0/1
 operation 4-wire
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 1 pots     

!--- More on dial peers.

 destination-pattern 4552468
 port 1/0/1
!
dial-peer voice 2 voip
 destination-pattern 3006
 session target ipv4:10.2.1.2
!
dial-peer voice 3 pots
 destination-pattern 5551234
 port 1/0/0
!
dial-peer voice 4 voip
 destination-pattern 4005
 fax-rate 9600
 session target ipv4:10.2.1.2
!
interface Ethernet0/0
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial2/1
 no ip address
 no ip directed-broadcast
 shutdown
 clockrate 38000
!
interface Serial2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco AS5300 Raleigh
AS5300#show run
Building configuration...
 
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5300
!
boot system flash c5300-js-mz_113-6_na2.bin
enable password cisco
!
isdn switch-type primary-dms100
!
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 clock source internal
!
controller T1 2
 clock source internal
!
controller T1 3
 clock source internal
!
!
dial-peer voice 1 voip           

!--- More on dial peers.

 destination-pattern 4552468
 session target ipv4:10.2.1.1
!
dial-peer voice 2 pots
 destination-pattern 3...
 direct-inward-dial
 port 0:D
 prefix 3
!
dial-peer voice 4 pots
 destination-pattern 4...
 direct-inward-dial
 port 0:D
 prefix 4
!
dial-peer voice 3 voip
 destination-pattern 5551234
 fax-rate 9600
 session target ipv4:10.2.1.1
!
!
voice-port 0:D
!
interface Ethernet0
 ip address 10.2.1.2 255.255.255.0
!
interface Serial0:23
 no ip address
 isdn switch-type primary-dms100
 isdn tei-negotiation first-call
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
!
ip classless
!
logging buffered 60000 debugging
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, refer to Important Information on Debug Commands.

  • debug voip ccapi inout —Used to trace the execution path through the call control API, which serves as the interface between the call session application and the underlying network-specific software. You can use the output from this command to understand how calls are handled by the router.

  • debug vpm all —Used to enable all of the debug vpm commands: debug vpm spi, debug vpm signal, and debug vpm dsp.

    Note: This debug generates a lot of output.

  • show call active voice —Used to display the contents of the active call table, which shows all of the calls currently connected through the router.

  • show call history voice —Used to display the call history table. The call history table contains a listing of all calls connected through this router in descending time order since VoIP was enabled. You can display subsets of the call history table by using specific keywords.

  • show voice port —Used to display configuration information about a specific voice port.

Related Information

Updated: Nov 20, 2006
Document ID: 14079