Guest

Cisco Unified Border Element

Unified Border Element (CUBE) with Cisco Unified Communications Manager (CUCM) Configuration Example

Cisco - Unified Border Element (CUBE) with Cisco Unified Communications Manager (CUCM) Configuration Example

Document ID: 99863

Updated: Oct 31, 2007

   Print

Introduction

The Cisco Unified Border Element facilitates simple and cost-effective connectivity between enterprise unified communications Session Initiation Protocol (SIP) trunks to the public-switched telephone network (PSTN). Designed to meet enterprise and service-provider Session Border Controller (SBC) device needs, the Cisco Unified Border Element (CUBE) is an integrated Cisco IOS® Software application that runs on:

  • Cisco 2800 Series Integrated Services Routers

  • Cisco 3800 Series Integrated Services Routers

  • Cisco 2600XM Series Multiservice Platforms

  • Cisco 3700 Series Routers

  • Cisco 7200VXR Routers

  • Cisco 7301 Routers

  • Cisco AS5400XM and AS5350XM Access Gateways

Direct IP interconnections between unified communications networks offer greater flexibility to support emerging services when compared with traditional public-switched telephone network (PSTN) time-division multiplexing (TDM) interconnections.

The Cisco Unified Border Element provides a network-to-network interface point for:

  • Signaling interworking—H.323, SIP

  • Media interworking—dual-tone multifrequency [DTMF], fax, modem, and codec transcoding

  • Address and port translations—privacy and topology hiding

  • Billing and call detail record (CDR) normalization

  • Quality-of-service (QoS) and bandwidth management—QoS marking using differentiated services code point [DSCP] or type of service (ToS), bandwidth enforcement using Resource Reservation Protocol [RSVP] and codec filtering

A Cisco Unified Border Element interoperates with many different network elements including voice gateways, IP phones, and call-control servers in many different application environments, from advanced enterprise voice and/or video services with Cisco Unified Communications Manager or Cisco Unified Communications Manager Express, as well as simpler toll bypass and voice over IP (VoIP) transport applications.

The Cisco Unified Border Element provides organizations with all the border controller functions integrated into the network layer to interconnect unified communications voice and video enterprise-to-service-provider architectures. The Cisco Unified Border Element is used by enterprise and small and medium-sized organizations to interconnect SIP PSTN access with SIP and H.323 enterprise unified communications networks.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the Cisco Unified Border Element (CUBE).

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Configurations

This configuration enables the basic Cisco Unified Border Element functionality on a platform. This functionality terminates an incoming VoIP call and re-originates it with the use of an outbound VoIP dial-peer. The calls can be H.323 to SIP or SIP to SIP.

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

Configure the incoming and outgoing dial-peers with the relevant protocol, DTMF type, and codec information.

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

SIP User Agent Configuration

Configure the SIP User Agent (UA) for registration and authentication.

SIP User Agent (UA)
sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Interconnecting with Cisco Unified Communications Manager

Cisco Unified Communications Manager can be interconnected with the Cisco Unified Border Element with the use of an H.323 or SIP unified communications trunk.

H.323 Trunk to the Cisco Unified Border Element

There are two methods of defining an H.323 trunk to the Cisco Unified Border Element on the Cisco Unified Communications Manager:

  • With a gatekeeper—Configure an H.225 trunk (GK controlled) toward Cisco Unified Border Element

  • Without a gatekeeper—Configure the Cisco Unified Border Element as an H.323 gateway

Media Termination Point (MTP) requirements:

  • If the Cisco Unified Border Element does H.323 to H.323 calls, an MTP is not mandatory as long as the Cisco Unified Border Element release is 12.4(6)T or later and the Cisco Unified Communications Manager is Version 4.1 or later.

  • An hardware or software MTP can be co-resident on the same router as the Cisco Unified Border Element (on routers platforms that support CUCM MTPs, which include the Cisco 2800 and 3800 series ISRs).

H.323 Fast Start requirements:

  • If the Cisco Unified Border Element does H.323 to SIP interworking for Cisco Unified Communications Manager, most SIP proxy servers require the SIP call to be Early Offer. This implies the H.323 side must be H.323 Fast Start. Hence, Cisco Unified Communications Manager must be configured for inbound and outbound H.323 Fast Start, which also requires an MTP.

Figure 1 shows the configuration for a Cisco Unified Border Element defined as an H.323 gateway on Cisco Unified Communications Manager.

Figure 1. The Configuration of the Cisco Unified Border Element as an H.323 Gateway on Cisco Unified Communications Manager

cube-config01.gif

cube-config02.gif

Figure 2 shows the Cisco Unified Border Element configuration to match the preceding Cisco Unified Communications Manager configuration.

Figure 2. Configuration on the Cisco Unified Border Element for an H.323 Trunk

cube-config03.gif

SIP Trunk to the Cisco Unified Border Element

Cisco Unified Communications Manager Version 5.x or later is required to define a unified communications SIP trunk to the Cisco Unified Border Element.

MTP requirements:

  • SIP trunk without an MTP—Configure a unified communications SIP trunk without MTP if delayed media or invite with no SDP is acceptable.

  • SIP trunk with MTP—Configure a unified communication SIP trunk (with MTP) if early media or invite with SDP is a requirement (G.711 calls only).

Figures 3 shows the configuration for a Cisco Unified Border Element defined with a unified communications SIP trunk to Cisco Unified Communications Manager.

Figure 3. The Configuration of the Cisco Unified Border Element with a SIP Trunk to Cisco Unified Communications Manager

cube-config04.gif

Figure 4 shows configuration the Cisco Unified Border Element configuration to match the preceding Cisco Unified Communications Manager configuration.

Figure 4. Configuration on the Cisco Unified Border Element for a SIP Trunk

cube-config05.gif

MTP Co-resident with the Cisco Unified Border Element

If a software MTP is required by the Cisco Unified Communications Manager configuration, this can be configured on the same router used for the Cisco Unified Border Element.

This is the configuration on the Cisco Unified Border Element for an MTP:

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Transcoding on the Cisco Unified Border Element

The Cisco Unified Border Element can do transcoding between G.711 -law/a-law and various flavors of G.729. Transcoding can be invoked for any call whether it originates from Cisco Unified Communications Manager towards the PSTN, or from the PSTN towards Cisco Unified Communications Manager. The main criterion is if the two call legs on the Cisco Unified Border Element have different codecs - G.711 and G.729. The configuration of transcoding on the Cisco Unified Border Element requires DSPs to be available on the platform.

This is the configuration on the Cisco Unified Border Element for transcoding:

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Using Tcl IVR on the Cisco Unified Border Element

The Cisco Unified Border Element supports Tcl scripts, and you can configure them under the VoIP dial-peers. There is no need for a DSP in order to use the Tcl functionality. There are a number of Tcl applications already built into Cisco IOS Software that can be used for Cisco Unified Border Element deployments. The Cisco IOS authentication, authorization, and accounting (AAA) functionality can also be used in conjunction with Tcl scripting and the Cisco Unified Border Element to provide authentication and authorization of calls.

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

Full Sample Configuration

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip 

!--- key command

allow-connections sip to h323 

!--- key command

allow-connections sip to sip 

!--- key command

allow-connections h323 to h323 

!--- key command

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard 

!--- TCL Application

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric 

!--- DTMF config for h.245 alphanumeric

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte 

!--- DTMF config for RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Note: Refer to Important Information on Debug Commands before you use debug commands.

  • logging—It is important to ensure the Cisco Unified Border Element is set up for logging as in this example and also to perform debugging during non-peak hours as far as possible since the debug commands are verbose.

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • show—This is relevant output:

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debug—Make sure to clear the log before a call for debugging is made, and get the output of the show logging command after the call has executed.

    H.323 to H.323 Scenarios

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    H.323 to SIP Scenarios

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    SIP to SIP Scenarios

    debug ccsip all
    debug voip ccapi inout
  • debug—In addition to the debugging commands based on the scenario described earlier, these transcoder debugging commands should be enabled:

    debug dspfarm all
    debug sccp messages
  • debug voip rtp session named-events—If RFC2833 (dtmf-relay rtp-nte) is used, you should also turn on this debug command.

Related Information

Updated: Oct 31, 2007
Document ID: 99863