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Failure of Agents to Log into Cisco Collaboration Server

Cisco - Failure of Agents to Log into Cisco Collaboration Server

Document ID: 69686

Updated: Mar 30, 2006

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Introduction

This document describes one reason for the failure of agents to log into Cisco Collaboration Server. This document also provides a solution in a Cisco Intelligent Contact Manager (ICM) or IP Contact Center (IPCC) Enterprise environment.

Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

  • Cisco ICM or IPCC Enterprise

  • Cisco Web Collaboration Option

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco ICM or IPCC Enterprise Edition version 6.0 SR4

  • Cisco Web Collaboration Option version 5.0 SR3

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

Internet Server API (ISAPI) filters are Dynamic Link Library (DLL) files that help to modify and enhance the Internet Information Services (IIS) functionality. ISAPI filters always run on an IIS server, and filter every request until the filters find a valid request to process. The ability to examine and modify both incoming and outgoing streams of data makes ISAPI filters powerful and flexible.

URLScan is an ISAPI filter that allows web site administrators to restrict the type of HTTP requests that the server processes. The URLScan filter blocks specific HTTP requests, and ensures that potentially harmful requests do not reach the server.

The URLScan tool screens all requests that come into the server, and filters the requests based on rules that the administrator sets. URLScan ensures that only valid requests are processed, and helps protect the security of the server. URLScan effectively helps protect web servers because most attacks involve the use of a request that is unusual in some way. Here are some examples of unusual requests that can be potentially harmful:

  • Requests that are extremely long

  • Requests that involve an unusual action

  • Requests encoded with an alternate character set

  • Requests that include character sequences that are rarely seen in legitimate requests

URLScan filters out all unusual requests, and protects the server from damage.

Problem

Agents are unable to log into Cisco Collaboration Server. When an agent attempts to log in, an error message appears (see Figure 1):

Figure 1 – Agent Login Failure

CTIAgent_loginerror_01.gif

Cause

This problem occurs because URLScan ISAPI filter is installed and enabled on Cisco Collaboration Server.

Solution

Remove URLScan in order to solve the problem. Use the ISAPI Filters page of the Web Server Properties dialog box in Internet Services Manager to remove URLScan manually.

You must remove URLScan from the the Default Web Site and from the WWW Service Manager.

Remove URLScan from the Default Web Site

Complete these steps to remove URLScan from the Default Web Site:

  1. Select Start > Programs > Administrative Tools > Internet Services Manager. The Internet Information Services window appears (see Figure 2).

  2. Expand the tree in the left pane until you see Default Web Site (see arrow A in Figure 2).

    Figure 2 – Internet Information Services

    CTIAgent_loginerror_02.gif

  3. Right-click Default Web Site.

  4. Select Properties from the shortcut menu. The Default Web Site Properties dialog box appears (see Figure 3).

    Figure 3 – Default Web Site Properties

    CTIAgent_loginerror_03.gif

  5. Select the ISAPI Filters tab (see arrow A in Figure 3).

  6. Select URLScan from the list of filters (see arrow B in Figure 3).

  7. Click Remove (see arrow C in Figure 3).

  8. Click OK (see arrow D in Figure 3).

Remove URLScan from the WWW Service Master

Complete these steps to remove URLScan from the WWW Service Master:

  1. Select Start > Programs > Administrative Tools > Internet Services Manager.

  2. Expand the tree in the left pane.

  3. Right-click the server name (see arrow B in Figure 2).

  4. Select Properties from the shortcut menu.

  5. Select WWW Service in the Master Properties section, and click Edit. The WWW Service Master Properties dialog box appears (see Figure 4).

    Figure 4 – WWW Service Master

    CTIAgent_loginerror_04.gif

  6. Select the ISAPI Filters tab (see arrow A in Figure 4).

  7. Select URLScan from the list of filters (see arrow B in Figure 4).

  8. Click Remove (see arrow C in Figure 4).

  9. Click OK (see arrow D in Figure 4).

Related Information

Updated: Mar 30, 2006
Document ID: 69686