Guest

Cisco Nexus 1000V Switch for VMware vSphere

Nexus 1000V Series Switches Port Channel Configuration Examples

Document ID: 116739

Updated: Aug 08, 2014

Contributed by Carlos Lopez and Matthew Wronkowski, Cisco TAC Engineers.

   Print

Introduction

This document describes the best practices to use when you deploy port channels on the Cisco Nexus 1000V Series switch (N1KV). The N1KV requires port channels for port profiles that contain more than one interface per host.

Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

  • N1KV
  • Cisco Unified Computing System (UCS)
  • Cisco Nexus and Catalyst Series Switches

Components Used

The information in this document is based on these software and hardware versions:

  • N1KV
  • UCS

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Configure

This section contains these configurations:

N1KV on UCS B-Series Servers in End-Host Mode

Cisco UCS uses two diverse paths between the blade and the upstream network. Currently, the Fabric Interconnects do not support Link Aggregation Control Protocol (LACP)/Virtual Port Channel (vPC) southbound toward the blades. This means that a static port channel from the N1KV perspective must be used. MAC Pinning is required, since the upstream switches do not support multichassis EtherChannel.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV on UCS C-Series Servers or Rack Mount Servers Connected to Nexus 5000/7000 Switches with vPC

In this topology, each rack server is physically connected to two different Nexus switches - one cable to each switch. LACP is the preferred mode, because it allows the best traffic distribution and non-disruptive addition/subtraction of links. It is assumed that the upstream Nexus switches already have a vPC peer link configured.

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
switchport mode trunk
vpc 1000
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable

no lacp suspend-individual <- Nexus 7k only!!!
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV on UCS C-Series Servers or Rack Mount Servers Connected to Switches without vPC

In this topology, each rack server is physically connected to two different switches, but vPC is not available. The only supported configuration is MAC Pinning. This configuration is identical to that used on UCS B-Series servers. A static port channel (mode on) is not supported, since the upstream switches do not support a multichassis EtherChannel technology.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV on UCS C-Series Servers or Rack Mount Servers Connected to 6500 VSS or Stacking Switches

In this topology, the upstream switches act as a single chassis. This allows the N1KV to connect with LACP.

# VSM configuration
feature lacp
lacp offload
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# 6500 VSS configuration
interface Port-channel1000
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface GigabitEthernet1/1/1
description ESX-Host1 adapter 1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active
!
interface GigabitEthernet2/1/1
description ESX-Host1 adapter 2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV on UCS C-Series Servers or Rack Mount Servers Connected to a Single Upstream Switch with a Static Port Channel

In this topology, the servers are single-homed to an upstream switch. This topology provides no switch redundancy and is not a best practice.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream Nexus switch
interface port-channel 1000
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode on

Verify

Use this section in order to confirm that your configuration works properly.

show run interface po{X} membership
show port-channel summary

Troubleshoot

This section provides information you can use in order to troubleshoot your configuration.

show port-channel summary
show port-channel internal event-history [all|errors]debug lacp all
Updated: Aug 08, 2014
Document ID: 116739