Guest

Cisco Catalyst 6500 Series Switches

Configuring Catalyst Switches for Polycom Conference Phones

Document ID: 97229

Updated: Jul 31, 2007

   Print

Introduction

This document provides sample configurations on Catalyst switches in order to connect to Polycom IP Conference Station 7935/7936 and Polycom SoundPoint IP 430. This document does not include power inline and quality of service (QoS) configurations.

Prerequisites

Requirements

Ensure that you meet these requirements before you attempt this configuration:

Components Used

The information in this document is based on the Cisco Catalyst 6500 Series Switch with Supervisor Engine 720 and running Cisco IOS® Software Release 12.2(18)SXD6 and Cisco Catalyst 6500 Series Switch with Supervisor Engine 2 and running Cisco CatOS Software Release 8.4(4).

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Related Products

This configuration can also be used with Cisco Catalyst Switches that run Cisco IOS Software, except Cisco 2900XL and 3500XL series. The CatOS configurations can be used with any Cisco Catalyst Switches that run Catalyst OS Software.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Background Information

This document explains the configuration of the switches that connect the PCs and IP phone Polycom SoundPoint IP 430 on a switch port. This document also explains the configuration of the switches that connect to a Polycom IP Conference Station 7935/7936 switch port.

The Polycom IP Conference Station 7935/7936 has a single 10/100BaseTx Ethernet LAN connection to the network through an RJ-45 cable interface and unlike the other Cisco Unified IP phones 7900 Series, it does not have a 10/100BaseTx Ethernet LAN connection in order to connect to a PC.

Due to the absence of the provision to connect to a PC with the 10/100BaseTx Ethernet LAN connection on the Cisco 7935/7936 IP Conference Phone, the concept of a voice or auxiliary VLAN does not directly apply and can cause problems. The single 10/100BaseTx Ethernet LAN connection that the Cisco IP Conference Station 7935/7936 has is used in order to connect this device to a switch port. Since this connection carries traffic for only the voice, the switch port should belong to a single VLAN.

The Polycom SoundPoint IP 430 has dual 10/100 Mbps Ethernet ports. One port connects to the switch and the other port connects to a PC. In this connection, the port carries traffic for these two VLANs:

  • Data (PC) traffic

  • Voice (IP Phone) traffic

In this scenario, you need a trunk port in order to pass traffic for more than one VLAN.

Note: The Polycom IP Conference Station 7935/7936 does not have external power supply, so either the switch has to supply power through its PoE ports, or a separate power injector needs to be used.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) in order to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

config-cat-switches-polycom.gif

Cisco IOS Configurations

This document uses this configuration:

  • Catalyst 6500

Catalyst 6500 in Native Cisco IOS Mode
Cat6500#show running-config 
 Building configuration...
Current configuration : 5869 bytes
!
version 12.1 
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!

boot system sup-bootflash:s72033-psv-mz.122-18.SXD6.bin


main-cpu
 auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!
vlan 1
name DataVlan
!
vlan 2
name VoiceVlan
!
interface FastEthernet4/1
 no ip address 
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a
!--- Layer 2 access port. Otherwise, you create a network loop.
!--- Refer to Using Portfast and Other Commands to Fix Workstation Startup
!--- Connectivity Delays for more information on how to enable portfast.

!
interface FastEthernet4/2
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a 
Layer 2 access port. Otherwise, you create a network loop.

!
interface FastEthernet4/3
 no ip address
 shutdown
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4 
!
end

CatOS Configurations

This example explains the configuration of switches in Hybrid mode that connect the PC and IP phone Polycom SoundPoint IP 430 on a switch port. This document also explains the configuration of the switches that connect to a Polycom IP Conference Station 7935/7936 switch port. This configuration uses the same diagram as the previous example.

Catalyst 6500 in Hybrid Mode

!--- Set the VLAN Trunk Protocol (VTP) mode.
!--- In this example, the mode is set to transparent.
!--- Dependent upon your network, set the VTP mode accordingly.
!--- Refer to Understanding and Configuring VLAN Trunk Protocol (VTP) 
!--- for more information on VTP.

Catalyst6500> (enable) set vtp mode transparent
VTP domain modified


!--- Add VLAN 2. VLAN 1 already exists by default.
 
Catalyst6500> (enable) set vlan 2
VLAN 2 configuration successful


!--- Add port 4/2 to VLAN 2.

Catalyst6500> (enable) set vlan 2 4/2
VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     4/2


!--- Enable trunking on port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Vlan(s) 1,2 already allowed on the trunk
Please use the 'clear trunk' command to remove vlans from allowed list.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.
Catalyst6500> (enable) 


!--- Enable spanning tree portfast on the ports. Refer to 
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information on how to enable portfast.

Catalyst6500> (enable) set spantree portfast 4/1 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/1 fast start enabled.
Catalyst6500> (enable) set spantree portfast 4/2 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/2 fast start enabled.
Catalyst6500> (enable)


!--- If you want to ONLY allow VLAN 1 and VLAN 2 on trunk port 4/1, do this.
!--- A trunk port allows all VLANs by default.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1-4094

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       
Catalyst6500> (enable) clear trunk 4/1 1-4094
Removing Vlan(s) 1-4094 from allowed list.
Port  4/1 allowed vlans modified to none.


!--- Allow only VLAN 1 and VLAN 2 on trunk port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Adding vlans 1,2 to allowed list.
Port(s)  4/1 allowed vlans modified to 1,2.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1,2

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       

!--- Refer to Configuring Ethernet VLAN Trunks for more
!--- information on how to configure trunk ports. 


!--- Issue the show config <module_number> command 
!--- in order to check the configuration.

Catalyst6500> (enable) show config 4
This command shows non-default configurations only.
Use 'show config <mod> all' to show both default and non-default configurations.
.................................
begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu Jun 21 2007, 23:37:51 
!
# default port status is enable
!
!
#module 4 : 16-port 1000BaseX Ethernet
set vlan 2    4/2
clear trunk 4/1  1-9,11-39,41-4094
set trunk 4/1  on dot1q 1,2
set spantree portfast    4/1-2 enable
end
Catalyst6500> (enable) 

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use in order to troubleshoot your configuration.

Spanning Tree Loop due to Polycom IP Phones

When you connect an IP Phone to a switch, it can experience STP loops, which causes the CPU of the switch to go up to 100 percent of utilization. STP loops can occur even if portfast is enabled on the switch port where the IP Phone is connected.

  1. Check the switch port configuration. If the port where the IP Phone is connected goes into an err-disabled status and if there is no physical loop, you can try to recover the port from the err-disabled status. Refer to Errdisable Port State Recovery on the Cisco IOS Platforms for more information.

  2. In order to avoid the port to go into an err-disabled status when there is a risk that end users create a physical loop by mistake, you can enable err-disable recovery so there is not a need to manually reset a port which becomes disabled. Refer to Spanning-Tree Protocol Enhancements using Loop Guard and BPDU Skew Detection Features for more information on STP Loop Guard.

Related Information

Updated: Jul 31, 2007
Document ID: 97229