Guest

Cisco Catalyst 6500 Series Switches

Spanning Tree from PVST+ to Rapid-PVST Migration Configuration Example

Document ID: 72836

Updated: Jan 12, 2007

   Print

Introduction

This document provides a sample configuration to migrate the spanning tree mode from PVST+ to rapid-PVST+ in the campus network. It also explains the PVST+ configuration, Spanning Tree load balancing, and the UplinkFast and BackboneFast features.

Prerequisites

Requirements

It is recommended to read Understanding Rapid Spanning Tree Protocol (802.1w) before you configure rapid-PVST+.

This table shows the support of Rapid Spanning Tree Protocol (RSTP) in Catalyst switches, and the minimum software required for that support.

Catalyst Platform Rapid-PVST+
Catalyst 2900 XL / 3500 XL Not available.
Catalyst 2940 12.1(20)EA2
Catalyst 2950/2955/3550 12.1(13)EA1
Catalyst 2970/3750 12.1(14)EA1
Catalyst 3560 12.1(19)EA1
Catalyst 3750 Metro 12.1(14)AX
Catalyst 2948G-L3/4908G-L3 Not available.
Catalyst 4000/2948G/2980G (CatOS) 7.5
Catalyst 4000/4500 (IOS) 12.1(19)EW
Catalyst 5000/5500 Not available.
Catalyst 6000/6500 7.5
Catalyst 6000/6500 (IOS) 12.1(13)E
Catalyst 8500 Not available.

Components Used

The information in this document is based on Cisco IOS® Software Release12.2(25) and CatOS 8.5(8). However, the configuration is applicable on the minimum Cisco IOS version shown in the table.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

802.1D Spanning Tree Protocol (STP) has a drawback of slow convergence. Cisco Catalyst switches support three types of STPs, which are PVST+, rapid-PVST+ and MST. PVST+ is based on IEEE802.1D standard and includes Cisco proprietary extensions such as BackboneFast, UplinkFast, and PortFast. Rapid-PVST+ is based on IEEE 802.1w standard and has a faster convergence than 802.1D. RSTP (IEEE 802.1w) natively includes most of the Cisco proprietary enhancements to the 802.1D Spanning Tree, such as BackboneFast and UplinkFast. Rapid-PVST+ has these unique features:

  • Uses Bridge Protocol Data Unit (BPDU) version 2 which is backward compatible with the 802.1D STP, which uses BPDU version 0.

  • All the switches generate BPDUs and send out on all the ports every 2 seconds, whereas in 802.1D STP only the root bridge sends the configuration BPDUs.

  • Port Roles—Root port, designated port, alternate port and backup port.

  • Port States—Discarding, Learning, and Forwarding.

  • Port Types—Edge Port (PortFast), Point-to-Point and Shared port.

Rapid-PVST uses RSTP to provide faster convergence. When any RSTP port receives legacy 802.1D BPDU, it falls back to legacy STP and the inherent fast convergence benefits of 802.1w are lost when it interacts with legacy bridges.

Configure

This example contains two sections. The first section shows the current PVST+ configuration. The second section shows the configuration to migrate from PVST+ to rapid-PVST+.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

This diagram has these switches:

  • Distribution1 and Distribution2, which are in the distribution layer

  • Two access-layer switches called Access1 (IOS) and Access2 (CatOS)

  • Two server aggregation switches called Services1 and Services2

VLANs 10, 30, and 100 carry data traffic. VLANs 20, 40, and 200 carry voice traffic.

rapidpvst-mig-config1.gif

Configurations

This document uses these configurations:

PVST+ Configuration

The switches are configured in PVST+ to carry the data and voice traffic as per the network diagram. This is a short summary of the configuration:

  • The Distribution1 switch is configured to become a primary root bridge for the data VLANs 10, 30, 100 using the Distribution1(config)# spanning-tree vlan 10,30,100 root primary command, and the secondary root bridge for the voice VLANs 20, 40, 200 uses the Distribution1(config)# spanning-tree vlan 20,40,200 root secondary command.

    Note: The spanning-tree root primary command alters the switch's bridge priority to 8192 and the spanning-tree root secondary command alters the priority to 16384.

  • The Distribution2 switch is configured to become a primary root bridge for the voice VLANs 20, 40, 200 using the Distribution2(config)# spanning-tree vlan 20,40,200 root primary command, and the secondary root bridge for the data VLANs 10, 30, 100 uses the Distribution2(config)# spanning-tree vlan 10,30,100 root secondary command.

  • The spanning-tree backbonefast command is configured on all the switches to converge the STP faster in case of indirect link failure in the network.

  • The spanning-tree uplinkfast command is configured on the access-layer switches to converge the STP faster in case of direct uplink failure.

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 8192
spanning-tree vlan 20,40,200 priority 16384
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

You can see that the port Fa1/0/24 is configured with the spanning-tree vlan 20,40,200 port-priority 64 command. Distribution2 is configured root for VLANs 20,40,200. Distribution2 has two links to Distribution1: Fa1/0/23 and Fa1/0/24. Both ports are designated ports for VLANs 20, 40, 200 because Distribution2 is the root for those VLANs. Both ports have the same priority 128 (default). Also, these two links have the same cost from Distribution1: fa1/0/23 and fa1/0/24. Distribution1 chooses the lowest port number of the two ports in order to set the port into the Forwarding state. The lowest port number is Fa1/0/23. However, as per the network diagram, voice VLANs 20, 40, 200 should flow through Fa1/0/24. You can accomplish this with these methods:

  1. Decrease the port cost in Distribution1: Fa1/0/24

  2. Decrease the port priority in Distribution2: Fa1/0/24

In this example, port priority is decreased to forward VLANs 20, 40, 200 through fa1/0/24.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

You can see that port Fa0/5 in Services1, and both Fa0/6 and Fa0/48 in Services2 have Spanning Tree port cost and port priority configuration. Here the STP is tuned so that VLAN 100 and 200 of Services1 and Services2 can pass through the trunk links between them. If this configuration is not applied, Services1 and 2 will not pass traffic through the trunk links between them. Instead, it chooses the path through Distribution1 and Distribution2.

Services2 sees two equal cost paths to the VLAN 100 root (Distribution1). One via Services1, the second one via Distribution2. The STP chooses the best path (root port) in this order:

  1. Path cost

  2. The bridge ID of the forwarding switch

  3. Lowest port priority

  4. Lowest internal port number

In this example, both the paths have the same cost. However, the Distribution2 (24576) has lower priority than Services1 (32768) for the VLAN 100. Therefore, Services2 chooses Distribution2. In this example, port cost on Services1: fa0/5 is set lower to let Services2 choose the Services1. The path cost overrides the forwarding switch priority number.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

The same concept is applied for Services1 to choose Services2 to forward VLAN 200. After you reduce the cost for VLAN 200 in Services2 - fa0/6, Services1 chooses fa0/47 to forward VLAN 200. However, the requirement here is to forward VLAN 200 through fa0/48. You can accomplish with these two methods:

  1. Decrease the port cost in Services1: Fa0/48

  2. Decrease the port priority in Services2: Fa0/48

In this example, port priority in Services2 is decreased to forward VLAN 200 through fa0/48.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

UplinkFast and BackboneFast

It is good to know the UplinkFast and BackboneFast behavior before you start the migration process. In the network diagram, the Access1 switch runs Cisco IOS. This output is taken before migration to the rapid-PVST+ mode:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  Uplinkfast enabled

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p


Access1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled
BackboneFast                 is enabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

This output is taken after the mode is changed to rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  UplinkFast enabled but inactive in rapid-pvst mode

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled but inactive in rapid-pvst mode
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

You can see in the show spanning-tree summary command output that UplinkFast and BackboneFast are enabled, but are inactive in rapid-PVST mode. It is optional to remove both the commands. It does not affect any of the rapid-PVST operation if you do not remove the commands. If you disable the UplinkFast with the no spanning-tree uplinkfast configuration mode command, the bridge priority and port cost revert back to default. It is advisable to have the bridge priority of the non-root switch as a higher number. This output shows after the UplinkFast feature is disabled in the rapid-PVST mode:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        19
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 19        128.107  P2p
Fa3/0/2          Altn BLK 19        128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

CatOS does not allow you to change the mode to rapid-PVST if the BackboneFast feature is enabled. You have to disable BackboneFast before the migration. UplinkFast acts as same as it behaves in IOS.

Access2> (enable) set spantree mode rapid-pvst+
Cannot change the spantree mode to RAPID-PVST+ when backbonefast is enabled.

Rapid-PVST+ Migration

Rapid-PVST+ uses the same BPDU format as the 802.1D and it is backward compatible. It is difficult to convert all the switches in the enterprise network at the same time to rapid-PVST+. Because of the backward compatibility, you can convert phase by phase. It is recommended to implement the changes in the scheduled maintenance window because the spanning tree reconfiguration disrupts the traffic flow. Spanning Tree UplinkFast and BackboneFast features are PVST+ features. These are disabled when you enable rapid-PVST+ because those features are built within rapid-PVST+. Therefore, during the migration you can remove those commands. The configuration of the features such as PortFast, BPDUguard, BPDUfilter, root guard, and loopguard are applicable in rapid-PVST+ mode also. The usage of these features are the same as in PVST+ mode. If you have already enabled these features in the PVST+ mode, the features remain active after the migration to rapid-PVST+ mode. In this example, migration occurs in this order:

  1. Access1

  2. Access2

  3. Services1 and Services2

  4. Distribution1 and Distribution2

  1. Access1 migration:

    Access1(config)#spanning-tree mode rapid-pvst
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
    
    Access1#show spanning-tree vlan 10
    
    VLAN0010
      Spanning tree enabled protocol rstp
      Root ID    Priority    24586
                 Address     0015.63f6.b700
                 Cost        19
                 Port        107 (FastEthernet3/0/1)
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
    
      Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
                 Address     000f.f794.3d00
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time 300
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa3/0/1          Root FWD 19        128.107  P2p Peer(STP)
    Fa3/0/2          Altn BLK 19        128.108  P2p Peer(STP)
    
    
    !--- Type P2p Peer(STP) represents that the neighbor switch runs PVST.
    
    
  2. Access2 migration:

    Access2> (enable) set spantree backbonefast disable
    Backbonefast disabled for all VLANs.
    
    Access2> (enable) set spantree mode rapid-pvst+
    PVST+ database cleaned up.
    Spantree mode set to RAPID-PVST+.
    
    
    Access2> (enable) clear spantree uplinkfast
    This command will cause all portcosts, portvlancosts, and the
    bridge priority on all vlans to be set to default.
    Do you want to continue (y/n) [n]? y
    VLANs 1-4094 bridge priority set to 32768.
    The port cost of all bridge ports set to default value.
    The portvlancost of all bridge ports set to default value.
    uplinkfast all-protocols field set to off.
    uplinkfast disabled for bridge.
  3. Services1 and Services2 migration:

    Services1(config)#spanning-tree mode rapid-pvst
    Services1(config)#no spanning-tree backbonefast
    
    Services2(config)#spanning-tree mode rapid-pvst
    Services2(config)#no spanning-tree backbonefast
    
  4. Distribution1 and Distribution2 migration:

    Distribution1(config)#spanning-tree mode rapid-pvst
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution1 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution1(config)#no spanning-tree backbonefast
    
    
    Distribution2(config)#spanning-tree mode rapid-pvst
    
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    own
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    p
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution2 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution2(config)#no spanning-tree backbonefast
    

Debug Output - Mixed Mode

In a large enterprise network, the migration process can take a few days. During the migration process, you can run the LAN in mixed mode, such as a few switches in PVST+ and a few switches in rapid-PVST+ mode. In mixed mode, you do not receive the complete advantages of rapid-PVST+. The overall convergence time is the same as the convergence time of PVST+ mode. In order to take full advantage of rapid-PVST+, all the switches in the spanning tree topology must run the rapid-PVST+ . In order to show how the spanning tree behaves in the mixed mode, a sample debug command output is shown here. Distribution1 and Distribution2 are in PVST+, and Access1 is in rapid-PVST+ mode.

The debug spanning-tree command output shows the STP operation when the link between Access1 and Distribution1 fails.

Access1

00:55:13: RSTP(10): updt roles, root port Fa0/1 going down
00:55:13: RSTP(10): Fa0/2 is now root port
00:55:13: RSTP(10): Fa0/2 received a tc ack
00:55:15: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
00:55:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

00:55:20: STP: VLAN0010 Topology Change rcvd on Fa1/0/23
00:55:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:55:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
00:55:22: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

Distribution2

00:55:06: STP: VLAN0010 Topology Change rcvd on Fa1/0/2
00:55:06: STP: VLAN0010 sent Topology Change Notice on Fa1/0/23

The debug spanning-tree command output shows the STP operation when the link between Access1 and Distribution1 is up.

Access1

00:55:40: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:55:43:  STP: PVST vlan 10 port Fa0/1 created, ext id 2E42430, vp 3389640
00:55:43: RSTP(10): initializing port Fa0/1
00:55:43: RSTP(10): Fa3/0/1 is now designated
00:55:43:  STP: PVST vlan 20 port Fa0/1 created, ext id 2E42430, vp 300EC20
00:55:43: RSTP(20): initializing port Fa0/1
00:55:43: RSTP(20): Fa0/1 is now designated
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): updt roles, received superior bpdu on Fa0/1
00:55:43: RSTP(10): Fa0/1 is now root port
00:55:43: RSTP(10): Fa0/2 blocked by re-root
00:55:43: RSTP(10): Fa0/2 is now alternate
00:55:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to up
00:55:44: RSTP(20): updt roles, received superior bpdu on Fa0/1
00:55:44: RSTP(20): Fa0/1 is now alternate

Distribution1

00:55:49: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
00:55:50: set portid: VLAN0010 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDB708
00:55:50: STP: VLAN0010 Fa1/0/1 -> listening
00:55:50: set portid: VLAN0020 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 3C06F20
00:55:50: STP: VLAN0020 Fa1/0/1 -> listening
00:55:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to up
00:56:05: STP: VLAN0010 Fa1/0/1 -> learning
00:56:05: STP: VLAN0020 Fa1/0/1 -> learning
00:56:20: STP: VLAN0010 Fa1/0/1 -> forwarding
00:56:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:56:20: STP: VLAN0020 Fa1/0/1 -> forwarding


!--- This output is evident that the Access1 switch waits for the 
!--- standard 802.1D Spanning Tree process of listening, learning and forwarding
!--- to complete in Distribution1.




Distribution2

00:55:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
00:56:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24


!--- This output shows that Distribution2 is notified
!--- about the indirect link outage by TCN BPDUs.

Debug Output - Rapid-PVST+ Mode

The Distribution1, Distribution2 and Access1 switches are in rapid-PVST+ mode. The debug spanning-tree command output shows the STP operation when the link between Access1 and Distribution1 fails.

Access1

01:31:04: RSTP(10): updt roles, root port Fa0/1 going down
01:31:04: RSTP(10): Fa0/2 is now root port
01:31:06: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
01:31:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

01:31:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
01:31:14: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

The debug spanning-tree command output shows the STP operation when the link between Access1 and Distribution1 is up.

Access1

01:35:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:35:48:  STP: PVST vlan 10 port Fa3/0/1 created, ext id 2E42430, vp 3C8E360
01:35:48: RSTP(10): initializing port Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now designated
01:35:48:  STP: PVST vlan 20 port Fa3/0/1 created, ext id 2E42430, vp 3C8E3E0
01:35:48: RSTP(20): initializing port Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now designated
01:35:48: RSTP(10): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now root port
01:35:48: RSTP(10): Fa3/0/2 blocked by re-root
01:35:48: RSTP(10): synced Fa3/0/1
01:35:48: RSTP(10): Fa3/0/2 is now alternate
01:35:48: RSTP(20): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now alternate
01:35:48: RSTP(10): transmitting an agreement on Fa3/0/1 as a response to a prop
osal

Distribution1

01:35:55: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
01:35:56:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDCCD8
01:35:56: RSTP(10): initializing port Fa1/0/1
01:35:56: RSTP(10): Fa1/0/1 is now designated
01:35:56:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 2D21C60
01:35:56: RSTP(20): initializing port Fa1/0/1
01:35:56: RSTP(20): Fa1/0/1 is now designated
01:35:56: RSTP(10): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(10): received an agreement on Fa1/0/1
01:35:57: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:59: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:01: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:03: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:06: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:08: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:10: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:11: RSTP(20): Fa1/0/1 fdwhile Expired
01:36:12: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:14: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:16: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:18: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:20: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:22: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:24: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): Fa1/0/1 fdwhile Expired


!--- Distribution1 puts the port Fa1/0/1 as designated for VLANs 10 and 20.
!--- It also proposes that Fa1/0/1 is designated for VLANs 10, 20. Access1 agrees with the 
!--- proposal for VLAN10. However, it does not agree with the proposal for VLAN20 because it  
!--- has the superior BPDU for VLAN20 from Distribution2.

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

It is recommended to verify the spanning tree topology every time the configuration is changed.

Verify that the Distribution1 switch is the root bridge for data VLANs 10, 30, 100. Also, verify that the spanning tree forwarding path matches as per the path in the network diagram.

Distribution1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     0015.63f6.b700
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 19        128.1    P2p
Fa1/0/3          Desg FWD 19        128.3    P2p
Fa1/0/5          Desg FWD 19        128.5    P2p
Fa1/0/23         Desg FWD 19        128.23   P2p
Fa1/0/24         Desg FWD 19        128.24   P2p


Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Access2> (enable) show spantree 30
VLAN 30
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24606
Designated Root Cost        19
Designated Root Port        3/3
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-1d
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT        19   32 P2P
 3/4                     blocking      ALTR        19   32 P2P

Access2> (enable) show spantree 40
VLAN 40
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24616
Designated Root Cost        19
Designated Root Port        3/4
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-27
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR        19   32 P2P
 3/4                     forwarding    ROOT        19   32 P2P


Services1#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        18
             Port        7 (FastEthernet0/5)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Root FWD 18        128.7    P2p
Fa0/46           Desg FWD 19        128.50   P2p
Fa0/47           Desg FWD 19        128.51   P2p

Services1#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        37
             Port        51 (FastEthernet0/47)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Altn BLK 19        128.7    P2p
Fa0/46           Altn BLK 19        128.50   P2p
Fa0/47           Root FWD 19        128.51   P2p

Services2#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        37
             Port        42 (GigabitEthernet0/42)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Altn BLK 19        128.6    P2p
Fa0/42           Root FWD 19        128.42   P2p
Fa0/43           Altn BLK 19        128.43   P2p

Services2#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        18
             Port        6 (GigabitEthernet0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Root FWD 18        128.6    P2p
Fa0/42           Desg FWD 19        128.42   P2p
Fa0/43           Desg FWD 19         64.43   P2p

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jan 12, 2007
Document ID: 72836