Guest

Cisco Catalyst 3750 Series Switches

PIM Stub Routing on Catalyst 3750, and 3560 Series Switches

Cisco - PIM Stub Routing on Catalyst 3750, and 3560 Series Switches

Document ID: 98289

Updated: Aug 04, 2011

   Print

Introduction

Multicast control plane traffic is always seen by every router on a LAN environment. The Stub IP Multicast is used to reduce and minimize the unnecessary multicast traffic that is seen on LAN in the access layer and save the bandwidth on the media to forward multicast traffic to the upstream distribution/core layer.

In the Catalyst 3750 and 3560 Series Switches, the PIM Stub Multicast feature supports multicast routing between the distribution layer and access layer. It supports two types of PIM interfaces: uplink PIM interfaces and PIM passive interfaces. In particular, a routed interface configured with the PIM Passive mode does not pass/forward PIM control plane traffic; it only passes/forwards IGMP traffic.

Prerequisites

Requirements

Ensure that you meet these requirements before you attempt this configuration:

  • The PIM stub router does not route the transit traffic between distribution routers. This behavior is enforced by unicast (EIGRP) stub routing. The proper unicast stub routing configuration is required to assist this PIM stub router behavior. The PIM stub feature does not prevent router administrator configuring RIP, static routes, or PIM RP to bypass this restriction.

  • Only direct-connected multicast (IGMP) receivers and sources are allowed in the layer 2 access domains. The PIM protocol is not supported in access domains.

  • The redundant PIM stub router topology is not supported.

Components Used

The information in this document is based on output from the Catalyst 3750 Switch.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Related Products

This configuration can also be used with these switch types:

  • Catalyst 3750 and 3560 Series Switches

Cisco Catalyst 3750 and 3560 switches support PIM Stub Multicast Routing Code Version 12.2(37)SE and later.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

PIM SSM is used on the uplinks to communicate with the upstream router. Users can use any other PIM Mode (for example, Dense or Sparse).

For additional information about the configuration of Multicast Routing on the 3750 Series Switches, refer to Configuring IP Multicast Routing.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

pim_stub-1.gif

Configurations

This document uses these configurations:

Complete these steps to configure PIM Stub Routing:

  1. Issue this command to enable multicast routing globally on the switch or switch stack:

    mix_stack(config)#ip multicast-routing distributed
    
  2. Issue this command to define the SSM range of IP multicast address with default group range:

    mix_stack(config)#ip pim ssm default
    
  3. Issue this command to enable PIM SSM on the uplink:

    mix_stack(config)#interface GigabitEthernet3/0/25
    
    
    !--- By default switch configures the Layer 2 parameters.
    So in order to configure the Layer 3 parameter, use the next command.
    
    mix_stack(config-if)#no switchport
    
    mix_stack(config-if)#ip pim sparse-dense-mode
    
  4. Issue this command to enable PIM Stub Routing on the VLAN interface:

    mix_stack(config)#interface vlan100
    mix_stack(config-if)#ip pim passive
    

Switch (mix_stack) Configuration

mix_stack#show run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Output suppressed.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Output suppressed.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Output suppressed.
!
! 
ip pim ssm default
!
!
!--- Output suppressed.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Issue the show ip pim interface command in order to display the PIM Stub that is enable for each interface.

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

Issue the show ip igmp groups detail to display the interested client that has joined the specific Multicast source/group.

mix_stack#show ip igmp groups 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

Issue the show ip mroute to verify that the Multicast stream forwards from the source to the interested clients.

mix_stack#show ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

Related Information

Updated: Aug 04, 2011
Document ID: 98289