Guest

Cisco SN 5400 Series Storage Routers

Configuring Win2K iSCSI Host to SN5428

Cisco - Configuring Win2K iSCSI Host to SN5428

Document ID: 45100

Updated: Nov 11, 2004

   Print

Introduction

Cisco's iSCSI drivers, which reside on the server, are a key component of an iSCSI solution. These iSCSI drivers intercept SCSI commands, encapsulate them into IP packets, and redirect them to the Cisco SN 5420, Cisco SN 5428, Cisco SN5428-2, or Cisco MDS/IPS-8. This document provides sample configurations for Win2k host to SN5428.

Prerequisites

Requirements

Before attempting this configuration, ensure that you meet these requirements:

  • Before you build your iSCSI configuration on the SN5428, you need to install the iSCSI driver that is compatible with your Windows version. The most current version of the driver can be found at the Cisco iSCSI Driver (registered customers only) web page on Cisco.com. The README.txt file is included in the driver zip(tar) file. The README contains information about the license agreement, driver installation and configuration instructions, and a technical overview of the driver architecture.

  • The operating system requirements and patch requirements are described in the System Requirements section of Cisco iSCSI Driver for Microsoft Windows 2000.

Components Used

The information in this document is based on these software and hardware versions:

  • Host with Windows 2000 (Service Pack 3)

    sn5428_win2k-A.gif

  • Cisco iSCSI Driver 3.1.1 for Windows 2000. The iSCSI driver version can be seen at the bottom left of the Cisco iSCSI config for Win2000 dialog box.

    sn5428_win2k-B.gif

  • Cisco SN5428 with Software Version 3.3.2.

    *[Rita]$ sh vers
    Cisco SN 5428-K9 Storage Router 
             CLI Version: 2.1 
           iSCSI Version: 0/2 (Min/Max) 
        System Bootstrap: 3.3.2-K9 
        Operating System: 3.3.2-K9 
          Switch Version: V1.4.0.43-0 
             Application: 3.3.2-K9 
              Web Server: R6_1_0 
                 OpenSSH: 3.4p1 
                 OpenSSL: 0.9.6e 
                    Zlib: 1.1.4 
    
    Copyright (c) 1986-2002 by Cisco Systems, Inc

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Background Theory

SCSI routing provides IP hosts with access to Fibre Channel (FC) storage devices as if the storage devices were directly attached to the hosts, with access to devices managed primarily in the SN 5428 storage router. An iSCSI target is an arbitrary name for a group of physical storage devices. The iSCSI targets are created and mapped to physical storage devices attached to the SN 5428. The storage router presents the iSCSI targets to IP hosts as if the physical storage devices were directly attached to the hosts.

With SCSI routing, storage devices are not aware of each IP host; the storage devices are aware of the SN 5428, and respond to it as if it were one FC host. SCSI routing consists of routing SCSI requests and responses between hosts in an IP network and FC storage. Each host that requires IP access to storage with an SN 5428 Storage Router needs to have a compatible iSCSI driver installed. The iSCSI driver uses the iSCSI protocol to allow an IP host to transport SCSI requests and responses over an IP network. To the host operating system, the iSCSI driver appears to be a SCSI or FC driver for a peripheral channel in the host. SCSI routing allows you to:

  • Transport SCSI requests and responses over an IP network between the hosts and the SN 5428 storage router

  • Route SCSI requests and responses between hosts on an IP network and FC storage

  • Transport SCSI requests and responses between the SN 5428 storage router and FC storage.

SCSI routing occurs in the SN 5428 storage router when physical storage devices are mapped to iSCSI targets. An iSCSI target is an arbitrary name for a group of physical storage devices. You can map an iSCSI target to multiple physical devices. An iSCSI target always contains at least one Logical Unit Number (LUN). Each LUN on an iSCSI target is mapped to a single LUN on a physical storage target.

You can choose either of two types of storage mapping: target-and-LUN mapping or target-only mapping. Target-and-LUN mapping maps an iSCSI target and LUN combination to a physical storage target and LUN combination. Target-only mapping maps an iSCSI target to a physical storage target and its LUNs.

With target-and-LUN mapping, an iSCSI target name and iSCSI LUN number are specified and mapped to the physical storage address of one LUN; either a World Wide Port Name + LUN (WWPN + LUN) combination, a LUN ID (unique LUN identifier), or a LUN serial number.

If the LUN is available, it is made available as an iSCSI LUN, and numbered with the iSCSI LUN number specified. For example, if an iSCSI target and iSCSI LUN specified as Database, LUN 9 were mapped to the physical storage address, WWPN 3100112233445566, LUN 12, then LUN 12 would be available as one iSCSI LUN. An iSCSI driver would see the iSCSI target named Database, with one iSCSI LUN identified as LUN 9. The iSCSI LUN would appear as one storage device to a host.

With target-only mapping, an iSCSI target name is specified and mapped to the physical storage address of a storage controller only; a WWPN. Any LUNs that are available in the storage controller are made available as iSCSI LUNs and are numbered the same as the LUNs in the storage controller. For example, if an iSCSI target specified as Webserver2000 were mapped to the physical storage address WWPN 3100112233445577, and LUNs 0 through 2 were available in that controller, those LUNs would become available as three iSCSI LUNs. An iSCSI driver would see the iSCSI target named Webserver2000 as a controller with three iSCSI LUNs identified as LUN 0, LUN 1, and LUN 2. Each iSCSI LUN would appear as a separate storage device to a host.

Access for SCSI routing is controlled in the IP hosts and the storage router. In an IP host, the iSCSI driver is configured with the Gigabit Ethernet IP address of the SCSI routing instance in the storage router with which the host is to transport SCSI requests and responses. In a storage router, access is controlled through an access list and a VLAN Identifier (VID) number of the hosts. Additionally, access can be further controlled in the SN 5428 through authentication.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, refer to the Cisco SN5428 Family Software Configuration Guide.

Network Diagram

This document uses the network setup in the diagram shown here:

sn5428_win2k-C.gif

Configurations

This document uses these configurations:

  • Bonobo (Host Windows 2000 )

  • Rita (Cisco SN 5428)

Bonobo
These are the initial configuration tasks:
  • Set the iSCSI target IP addresses of SN 5400 Series systems that the driver will access.
  • Set the iSCSI target authentication user name and passwords.
  • Save the iSCSI target configuration, and set the driver's "Boot Type."
To configure the driver, perform these steps:
  1. Log on to the computer as a user with administrator privileges.
  2. Click Start, point to Settings, click Control Panel, and then double-click iSCSI Config. The iSCSI Config program causes the Cisco iSCSI config for Win 2000 dialog box to be displayed.

    sn5428_win2k-D.gif

  3. At the Cisco iSCSI config for Win 2000 dialog box, configure the IP address of a SCSI routing instance in an SN 5400 Series system as follows:
    1. At the Target Host Names/IP Addresses text box, type the IP address of a SCSI routing instance in an SN 5400 Series system. In the configuration example, the IP address will be 10.48.69.245.

      sn5428_win2k-J.gif

    2. Click Add. The IP address is displayed in the display area below the Target Host Names/IP Addresses text box.

      sn5428_win2k-E.gif

  4. Click Save and Exit.
  5. Restart the computer.

Rita (Cisco SN 5428)
!
! SCSIROUTER 
!
scsirouter win2k  

!--- A scsirouter instace win2k has been created for the test.

scsirouter win2k authentication "none"
scsirouter win2k username "none"
scsirouter win2k password "none"
scsirouter win2k primary "none"
scsirouter win2k reserveproxy disable
scsirouter win2k failover primary none
scsirouter win2k failover secondary none
scsirouter win2k lun reset no
scsirouter win2k serverIf ge1 10.48.69.245/255.255.255.192    
scsirouter win2k target emc-0123 lun 0 wwpn "500601608802a82b" lun "0"
scsirouter win2k target emc-0123 lun 1 wwpn "500601608802a82b" lun "1"
scsirouter win2k target emc-0123 lun 2 wwpn "500601608802a82b" lun "2"
scsirouter win2k target emc-0123 lun 3 wwpn "500601608802a82b" lun "3"
scsirouter win2k target emc-0123 enable
scsirouter win2k target emc-0123 accesslist "any" rw
scsirouter win2k target emc-0123 accesslist "none" ro
scsirouter win2k target emc-0123 maxcmdqueuedepth "0"
scsirouter win2k target emc-456 lun 4 wwpn "500601608802a82b" lun "4"
scsirouter win2k target emc-456 lun 5 wwpn "500601608802a82b" lun "5"
scsirouter win2k target emc-456 lun 6 wwpn "500601608802a82b" lun "6"
scsirouter win2k target emc-456 enable
scsirouter win2k target emc-456 accesslist "any" rw
scsirouter win2k target emc-456 accesslist "none" ro
scsirouter win2k target emc-456 maxcmdqueuedepth "0"
scsirouter win2k target jbod1 wwpn "210000203767f7a2"
scsirouter win2k target jbod1 enable
scsirouter win2k target jbod1 accesslist "any" rw
scsirouter win2k target jbod1 accesslist "none" ro
scsirouter win2k target jbod1 maxcmdqueuedepth "0"
!
! GE
!
interface ge1 no autonegotiation
interface ge1 mtusize 1500
interface ge1 vlan enable
interface ge1 ip-address 10.48.69.206/255.255.255.192
!
! ROUTES
!
ip default-gateway 10.48.69.129
ip route 144.254.7.0/255.255.255.0 10.48.69.200

!
! FC PORTS
!
interface fc4 enable
interface fc4 ms-enable enable
no interface fc4 al-fairness enable
interface fc4 fan-enable enable
interface fc4 ext-credit 0
interface fc4 mfs-bundle enable timeout 10
interface fc4 linkspeed auto
interface fc4 type gl-port
!
interface fc5 enable
interface fc5 ms-enable enable
no interface fc5 al-fairness enable
interface fc5 fan-enable enable
interface fc5 ext-credit 0
interface fc5 mfs-bundle enable timeout 10
interface fc5 linkspeed auto
interface fc5 type gl-port
!
!
interface fc7 enable
interface fc7 ms-enable enable
no interface fc7 al-fairness enable
interface fc7 fan-enable enable
interface fc7 ext-credit 0
interface fc7 mfs-bundle enable timeout 10
interface fc7 linkspeed auto
interface fc7 type gl-port
!
interface fc8 enable
interface fc8 ms-enable enable
no interface fc8 al-fairness enable
interface fc8 fan-enable enable
interface fc8 ext-credit 0
interface fc8 mfs-bundle enable timeout 10
interface fc8 linkspeed auto
interface fc8 type gl-port
!
! AAA
!
aaa new-model

Verify

This section provides information you can use to confirm your configuration is working properly.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Displays from Bonobo

In the Cisco iSCSI config for Win 2000 window, click on Status to check if the host has successfully logged into the iSCSI targets.

sn5428_win2k-F.gif

To see the new disks, right click on the My Computer icon on the desktop, and double-click on Computer Manager . In the console tree under System Tool, click Device Manager.

sn5428_win2k-G.gif

To manage the storage, right click on the My Computer icon on the desktop, and double-click on Computer Manager. In the console tree under Storage, click Disk Management.

sn5428_win2k-H.gif

Displays from Rita (Cisco SN 5428)

Configuration
*[Rita]# sh scsirouter win2k
SCSI Router Information
Status Codes: A=active, I=inactive, C=create failed, D=not enabled, S=slave
                          CDB   Reserve  Pass Lun  
Router               Stat Retry Proxy    Thru Reset Description
-------------------- ---- ----- -------- ---- ----- -----------
win2k                A    6     disabled no   no    (not set)

SCSI Router Authentication Information
Router               Authentication  Username        Password
-------------------- --------------- --------------- --------
win2k                none            none            none    

Router     ServerIf   Vlan Vid IP/Netmask                       Secondary  TCP Port SLP
---------- ---------- -------- -------------------------------- ---------- -------- ---
win2k      ge1                 10.48.69.245/26                  none       3260     ON

Target Attribute Information
                                     Accesslist Accesslist                               
Router     Target           Status   Read-Write Read-Only  Profile CRC        Description
---------- ---------------- -------- ---------- ---------- ------- ---------- -----------
win2k      emc-0123         enabled  any        none       High    prefer-off (not set)
win2k      emc-456          enabled  any        none       High    prefer-off (not set)
win2k      jbod1            enabled  any        none       High    prefer-off (not set)

Target Mapping Information
Router     Target           Mapping    iSCSI Name 
---------- ---------------- ---------- -----------
win2k      emc-0123         Lun-wwpn   iqn.1987-05.com.cisco:00.7656b615026b.emc-0123
win2k      emc-456          Lun-wwpn   iqn.1987-05.com.cisco:00.7a0606b3fed3.emc-456
win2k      jbod1            Tgt        iqn.1987-05.com.cisco:00.c66df6c6a175.jbod1

Targets - Target Mapped
Router     Target           WWPN Primary     WWPN Secondary  
---------- ---------------- ---------------- ----------------
win2k      jbod1            210000203767f7a2                 

Targets - Lun Mapped via WWPN
Router     Target           Lun   WWPN Primary     Lun   WWPN Secondary   Lun  
---------- ---------------- ----- ---------------- ----- ---------------- -----
win2k      emc-0123         0     500601608802a82b 0                           
win2k      emc-0123         1     500601608802a82b 1                           
win2k      emc-0123         2     500601608802a82b 2                           
win2k      emc-0123         3     500601608802a82b 3                           
win2k      emc-456          4     500601608802a82b 4                           
win2k      emc-456          5     500601608802a82b 5                           
win2k      emc-456          6     500601608802a82b 6 
*[Rita]# show devices 
Fabric Attached Devices detected
Interface WWPN             PortId   Device Type     Lun   Lunid Type        Lunid
--------- ---------------- -------- --------------- ----- ----------------- -----
fc7       500601608802a82b 0x680700 Disk            0     IEEE Reg Extended 600601608802a82bda05b6a9b69d7b00
fc7       500601608802a82b 0x680700 Disk            1     IEEE Reg Extended 600601608802a82b6a660d74cb33886c
fc7       500601608802a82b 0x680700 Disk            2     IEEE Reg Extended 600601608802a82bec815ba2c4430d8a
fc7       500601608802a82b 0x680700 Disk            3     IEEE Reg Extended 600601608802a82be047b3be3b00e0d5
fc7       500601608802a82b 0x680700 Disk            4     IEEE Reg Extended 600601608802a82b00515b7f3d9a7bce
fc7       500601608802a82b 0x680700 Disk            5     IEEE Reg Extended 600601608802a82babb1ae8059c0fcf0
fc7       500601608802a82b 0x680700 Disk            6     IEEE Reg Extended 600601608802a82bad9158afd2fdc747
fc7       500601608802a82b 0x680700 Disk            7     IEEE Reg Extended 600601608802a82bb1efe76c445c1697
fc7       500601608802a82b 0x680700 Disk            8     IEEE Reg Extended 600601608802a82b844f0960301efc50
fc7       500601608802a82b 0x680700 Disk            9     IEEE Reg Extended 600601608802a82baa6de20ece7acc21
fc7       500601608802a82b 0x680700 Disk            10    IEEE Reg Extended 600601608802a82b5b6667896cf2d156
fc7       500601608802a82b 0x680700 Disk            11    IEEE Reg Extended 600601608802a82ba932bd044abb3d9b
fc7       500601608802a82b 0x680700 Disk            12    IEEE Reg Extended 600601608802a82bcdd996f7573f070c
fc7       500601608802a82b 0x680700 Disk            13    IEEE Reg Extended 600601608802a82b0ce5ba3968cad6f0
fc7       500601608802a82b 0x680700 Disk            14    IEEE Reg Extended 600601608802a82b606eee7698fcab97
fc7       500601608802a82b 0x680700 Disk            15    IEEE Reg Extended 600601608802a82b8b58807b12fb6b12
fc7       500601608802a82b 0x680700 Disk            16    IEEE Reg Extended 600601608802a82ba12f6db0c3d6c246
fc7       500601608802a82b 0x680700 Disk            17    IEEE Reg Extended 600601608802a82b2c48c474254b26dd
fc7       500601608802a82b 0x680700 Disk            32    IEEE Reg Extended 600601608802a82bba186a4022409475
fc7       500601608802a82b 0x680700 Disk            33    IEEE Reg Extended 600601608802a82b74d2429e318dff86
fc8       500601688802a82b 0x680800 Disk            0     IEEE Reg Extended 600601608802a82bda05b6a9b69d7b00
fc8       500601688802a82b 0x680800 Disk            1     IEEE Reg Extended 600601608802a82b6a660d74cb33886c
fc8       500601688802a82b 0x680800 Disk            2     IEEE Reg Extended 600601608802a82bec815ba2c4430d8a
fc8       500601688802a82b 0x680800 Disk            3     IEEE Reg Extended 600601608802a82be047b3be3b00e0d5
fc8       500601688802a82b 0x680800 Disk            4     IEEE Reg Extended 600601608802a82b00515b7f3d9a7bce
fc8       500601688802a82b 0x680800 Disk            5     IEEE Reg Extended 600601608802a82babb1ae8059c0fcf0
fc8       500601688802a82b 0x680800 Disk            6     IEEE Reg Extended 600601608802a82bad9158afd2fdc747
fc8       500601688802a82b 0x680800 Disk            7     IEEE Reg Extended 600601608802a82bb1efe76c445c1697
fc8       500601688802a82b 0x680800 Disk            8     IEEE Reg Extended 600601608802a82b844f0960301efc50
fc8       500601688802a82b 0x680800 Disk            9     IEEE Reg Extended 600601608802a82baa6de20ece7acc21
fc8       500601688802a82b 0x680800 Disk            10    IEEE Reg Extended 600601608802a82b5b6667896cf2d156
fc8       500601688802a82b 0x680800 Disk            11    IEEE Reg Extended 600601608802a82ba932bd044abb3d9b
fc8       500601688802a82b 0x680800 Disk            12    IEEE Reg Extended 600601608802a82bcdd996f7573f070c
fc8       500601688802a82b 0x680800 Disk            13    IEEE Reg Extended 600601608802a82b0ce5ba3968cad6f0
fc8       500601688802a82b 0x680800 Disk            14    IEEE Reg Extended 600601608802a82b606eee7698fcab97
fc8       500601688802a82b 0x680800 Disk            15    IEEE Reg Extended 600601608802a82b8b58807b12fb6b12
fc8       500601688802a82b 0x680800 Disk            16    IEEE Reg Extended 600601608802a82ba12f6db0c3d6c246
fc8       500601688802a82b 0x680800 Disk            17    IEEE Reg Extended 600601608802a82b2c48c474254b26dd
fc8       500601688802a82b 0x680800 Disk            32    IEEE Reg Extended 600601608802a82bba186a4022409475
fc8       500601688802a82b 0x680800 Disk            33    IEEE Reg Extended 600601608802a82b74d2429e318dff86
fc4       210000203767f7a2 0x6804e8 Disk            0     IEEE Extended     200000203767f7a2

Lun Description Table
Interface WWPN             Lun   Capacity Vendor       Product      Serial
--------- ---------------- ----- -------- ------------ ------------ ------
fc7       500601608802a82b 0     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 1     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 2     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 3     1GB      DGC          RAID         f60004202091
fc7       500601608802a82b 4     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 5     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 6     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 7     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 8     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 9     1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 10    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 11    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 12    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 13    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 14    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 15    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 16    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 17    1023MB   DGC          RAID         f60004202091
fc7       500601608802a82b 32    4GB      DGC          RAID         f60004202091
fc7       500601608802a82b 33    2GB      DGC          RAID         f60004202091
fc8       500601688802a82b 0     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 1     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 2     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 3     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 4     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 5     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 6     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 7     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 8     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 9     0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 10    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 11    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 12    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 13    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 14    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 15    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 16    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 17    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 32    0KB      DGC          RAID         f60004202091
fc8       500601688802a82b 33    0KB      DGC          RAID         f60004202091
fc4       210000203767f7a2 0     16GB     SEAGATE      ST318203FC   LRE8091500007039HLT6
*[Rita]# show fcswitch nameserver all 
Port Id          680000
Port Type        N
Port Number      0
Port WWN         280000059ba695e0
Port IP Address  00000000
Sym Port Name    
Sym Node Name    
Node WWN         100000059ba695e0
Node IP Address  00000000
Fabric Port Name 200000059ba695e1
Class of Service 3
FC-4 Types       FCP
FC-4 Description (NULL)

Port Id          6804e8
Port Type        NL
Port Number      4
Port WWN         210000203767f7a2
Port IP Address  00000000
Sym Port Name    
Sym Node Name    
Node WWN         200000203767f7a2
Node IP Address  00000000
Fabric Port Name 200400059ba695e1
Class of Service 3
FC-4 Types       FCP
FC-4 Description SEAGATE  ST318203FC       (Rev. 0004)

Port Id          680500
Port Type        N
Port Number      5
Port WWN         10000000c923a775
Port IP Address  00000000
Sym Port Name    
Sym Node Name    
Node WWN         20000000c923a775
Node IP Address  00000000
Fabric Port Name 200500059ba695e1
Class of Service 2,3
FC-4 Types       FCIP,FCP
FC-4 Description (NULL)

Port Id          680700
Port Type        N
Port Number      7
Port WWN         500601608802a82b
Port IP Address  00000000
Sym Port Name    
Sym Node Name    
Node WWN         500601601102a82b
Node IP Address  00000000
Fabric Port Name 200700059ba695e1
Class of Service 3
FC-4 Types       FCP
FC-4 Description DGC      RAID 0           (Rev. 0632)

Port Id          680800
Port Type        N
Port Number      8
Port WWN         500601688802a82b
Port IP Address  00000000
Sym Port Name    
Sym Node Name    
Node WWN         500601601102a82b
Node IP Address  00000000
Fabric Port Name 200800059ba695e1
Class of Service 3
FC-4 Types       FCP
FC-4 Description DGC      RAID 0           (Rev. 0632)

Port Id          680f00
Port Type        N
Port Number      15
Port WWN         290000059ba695e0
Port IP Address  00000000
Sym Port Name    
Sym Node Name    
Node WWN         100000059ba695e0
Node IP Address  00000000
Fabric Port Name 200f00059ba695e1
Class of Service 3
FC-4 Types       FCP
FC-4 Description (NULL)

6 entries found

*[Rita]# 
*[Rita]# show scsirouter win2k connection 

CRC values (Header / Data)
  N = No CRC negotiated
  H = Hardware CRC
  S = Software CRC

router  sid cid      host:port          login        ver  crc  rtt  target  access
win2k   1   33   10.48.69.232:1026  Sep 05 14:03:09   0   N/N   on       
win2k   2   34   10.48.69.232:1914  Sep 05 14:03:15   0   N/N  off  emc-0123     RW
win2k   4   35   10.48.69.232:1915  Sep 05 14:03:15   0   N/N  off  emc-456     RW
win2k   3   36   10.48.69.232:1916  Sep 05 14:03:15   0   N/N  off  jbod1     RW

4 connections listed
*[Rita]# show scsirouter win2k stats 
                           Logins   Logins Target Access  Authentication
Router     Started         Accepted Active Failures       Failures      
---------- --------------- -------- ------ -------------- --------------
win2k      Sep 05 13:48:59 5        4      0              0             
1 scsirouter listed
*[Rita]# show scsirouter win2k host 

router      host       name   logins  active    last login     last disconnect
win2k   10.48.69.232  BONOBO      5       4   Sep 05 14:03:14  Sep 05 14:02:59
*[Rita]# show scsirouter "win2k" host stats 

win2k host 10.48.69.232 alias "BONOBO"
Login info:
  loginsActive = 4
  lastLoginTime: Fri Sep  5 14:03:14 GMT 2003
  loginsTerminated = 1
  lastLoginTerminatedTime: Fri Sep  5 14:02:59 GMT 2003
  loginsFailed = 0
  lastLoginFailedTime: 
  loginsDiscovery = 2
  loginsNormal = 3
 stats:

           RECEIVE               SEND
       OK         ERROR
  0000001127                0000001855  total msgs
  0000000235                0000000235  no-op msgs
  0000000117                0000000117  ping msgs/rsps
  0000000764  0000000000    0000000764  SCSI cmd msgs/rsps
  0000000000  0000000000    0000000725  SCSI data msgs
  0000000000  0000000000    0000000000  task mgt msgs/rsps
  0000000010  0000000000    0000000010  login msgs/rsps
  0000000001  0000000000    0000000001  text msgs/rsps
  0000000000                0000000000  invalid msgs/rsps
                            0000000000  RTT msgs
                            0000000003  async msgs

  bytes rcvd 0000000000000000
  discarded          00000000
  bytes sent 000000000002f330


1 host listed
*[Rita]# 
*[Rita]#  show scsirouter win2k target all stats 
win2k target emc-0123:

        RECEIVED           TRANSMITTED
    count      error      count      error

0000000372            0000000372             Messages
0000000372 0000000000 0000000372 0000000008  SCSI cmd/resp
0000000000 0000000000 0000000000             task mgt
0000000001 0000000000 0000000000             login cmd
0000000000                                   logout
                      0000000000             async event
0000000000            0000000352             data msg

0000000000000000 bytes received
        00000000 discarded
0000000000017218 bytes transmitted

 target emc-456:

        RECEIVED           TRANSMITTED
    count      error      count      error

0000000282            0000000282             Messages
0000000282 0000000000 0000000282 0000000006  SCSI cmd/resp
0000000000 0000000000 0000000000             task mgt
0000000001 0000000000 0000000000             login cmd
0000000000                                   logout
                      0000000000             async event
0000000000            0000000267             data msg

0000000000000000 bytes received
        00000000 discarded
00000000000119d4 bytes transmitted

 target jbod1:

        RECEIVED           TRANSMITTED
    count      error      count      error

0000000110            0000000110             Messages
0000000110 0000000000 0000000110 0000000001  SCSI cmd/resp
0000000000 0000000000 0000000000             task mgt
0000000001 0000000000 0000000000             login cmd
0000000000                                   logout
                      0000000000             async event
0000000000            0000000106             data msg

0000000000000000 bytes received
        00000000 discarded
0000000000006744 bytes transmitted


totals for all targets:

        RECEIVED           TRANSMITTED
    count      error      count      error

0000000764            0000000764             Messages
0000000764 0000000000 0000000764 0000000015  SCSI cmd/resp
0000000000 0000000000 0000000000             task mgt
0000000003 0000000000 0000000000             login cmd
0000000000                                   logout
                      0000000000             async event
0000000000            0000000725             data msg

0000000000000000 bytes received
        00000000 discarded
000000000002f330 bytes transmitted
[Rita]# show int ge1  
Operational Data
Interface Stat IP/Netmask               MAC          Options
--------- ---- ------------------------ ------------ -------
ge1       up   10.48.69.206/ffffffc0    00059ba695ff type Gigabit Ethernet
               10.48.69.245/ffffffc0    02023d3045f5 mtusize 1500
                                                     speed 1000000000
                                                     flags UP BRDCST RUNNING MLTCST
                                                     signal signal detect
                                                     duplex full
                                                     auto-negotiate complete
                                                     flow control rx pause
                                                     SFPVendor CISCO-AGILENT   
                                                     SFPVendorID A00258957       
                                                     SFPPartNumber QFBR-5790L      
                                                     SFPRev     -5790L      


Configuration Data
Interface MTU Size   AutoNegotiation  Vlan     IP/Netmask               Secondary
--------- ---------- ---------------- -------- ------------------------ ---------
ge1       1500       enabled          enabled  10.48.69.206/ffffffc0    
*[Rita]# show ip route 
Codes: C - connected, S - static, R - RIP

S    0.0.0.0/0 [1/0] via 10.48.69.129, mgmt
C    10.1.1.0/24 is directly connected, ha
C    10.48.69.128/26 is directly connected, mgmt
C    10.48.69.192/26 is directly connected, ge1
C    127.0.0.1/8 is directly connected, lo0
S    144.254.7.0/24 [0/0] via 10.48.69.200, ge1
*[Rita]#

Related Information

Updated: Nov 11, 2004
Document ID: 45100