Guest

Cisco UCS Manager

UCS Upstream Port Channel Configuration Example

Document ID: 116095

Updated: May 23, 2013

Contributed by Joe LeBlanc and Andrew Kelly, Cisco TAC Engineers.

   Print

Introduction

This document describes how to configure an upstream port channel on Cisco UCS Servers.

Prerequisites

Requirements

Cisco recommends that you have knowledge of port channels before you attempt this configuration.

Components Used

The information in this document is based on Cisco Unified Computing Systems (UCS).

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Configure

UCS port channel configuration is statically set to Link Aggregation Control Protocol (LACP) mode active. This configuration cannot be modified; therefore, all upstream port-channel configurations must adhere to LACP mode active as well. Alternatively, you can configure the upstream switchports for LACP mode passive.

CLI Configuration

Here is a sample of the UCS interface configuration that cannot be modified:

UCS1-B(nxos)# show run interface eth1/19

!Command: show running-config interface Ethernet1/19
!Time: Fri Oct 12 20:25:59 2012

version 5.0(3)N2(2.11)

interface Ethernet1/19
description U: Uplink
pinning border
switchport mode trunk
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
channel-group 100 mode active
no shutdown

Here is the port-channel interface configuration:

UCS1-B(nxos)# show run interface po100

!Command: show running-config interface port-channel100
!Time: Fri Oct 12 20:21:19 2012

version 5.0(3)N2(2.11)

interface port-channel100
description U: Uplink
switchport mode trunk
pinning border
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
speed 10000

You can run the show interface command on the port channel in order to show the port-channel members:

UCS1-B(nxos)# show interface po100
port-channel100 is up
Hardware: Port-Channel, address: 000d.eccd.665a (bia 000d.eccd.665a)
Description: U: Uplink
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth1/19, Eth1/20

The upstream port channel must be LACP to match the UCS configuration. Other configurations can be present, but (at a minimum) you should see this configuration:

5k# show run int eth1/3

!Command: show running-config interface Ethernet1/3
!Time: Sat Oct 13 00:30:51 2012

version 5.1(3)N2(1)

interface Ethernet1/3
switchport mode trunk
spanning-tree port type edge trunk
channel-group 100 mode active

Notice spanning-tree port type edge trunk on NXOS devices. This configuration ensures that, if a link flaps, the port immediately comes back up. In a failure situation, it is important that the upstream switch ports do not move through STP states, which prolong downtime. For more information on this command, refer to spanning-tree port type edge.

The Cisco IOS equivalent of this command is spanning-tree portfast trunk.

Refer to these documents for more information:

Note: Use the Command Lookup Tool (registered customers only) in order to obtain more information on the commands used in this section.

GUI Configuration

  1. Create the Port Channel interface.

    116095-configure-ucs-upstream-port-channel-01.jpg

  2. Select the ports and click the double arrow to add them to the Port Channel.

  3. After you click Finish, the port channel appears as down while LACP negotiates with the upstream switch.

    116095-configure-ucs-upstream-port-channel-02.jpg

If the upstream switch is configured properly, the overall status moves to an Up state.

Troubleshoot

  • A port channel will not come up if the speed is different on both sides. This is a common misconfiguration.
  • You might need to bring up all links individually first and verify neighboring ports. Use show cdp neighbor to verify neighboring ports.
Updated: May 23, 2013
Document ID: 116095