Guest

Cisco Secure Access Control Server for Unix

Cisco Secure ACS for UNIX Compatibility

Document ID: 16090

Updated: May 14, 2009

   Print

Introduction

This document presents the software and hardware with which Cisco Secure ACS for UNIX (CSU) is compatible.

Prerequisites

Requirements

There are no specific prerequisites for this document.

Components Used

This document presents compatibility information about the specific software and hardware versions discussed in the sections below.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Software

In this section, you can see the operating systems, web browsers, token servers and database programs that are compatible with CSU.

Operating Systems

Version Compatible With
CSU 2.1(x)
  • Solaris 2.51
CSU 2.2(2)
  • Solaris 2.6
  • Solaris 2.5.1 with these patches:
    • 103566-08
    • 103600-03
    • 103640-08
CSU 2.2(3)
  • Solaris 2.6
  • Solaris 2.5.1 with these patches:
    • 103566-36
    • 103640-21
    • 106255-01
CSU 2.3.1, 2.3.2
  • Solaris 2.6
  • Solaris 2.5.1 with these patches:
    • 103566-08 (or later version)
    • 103600-21 (or later version)
    • 106255-01 (or later version)
    • 101242-13 (or later version)
CSU 2.3.3
  • Solaris 2.6
  • Solaris 2.5.1 with thes patches:
    • 106529-03 (or later version)
    • 103566-08 (or later version)
    • 03600-03 (or later version)
    • 103640-08 (or later version)
CSU 2.3.5
  • Solaris 2.7 (also known as Solaris 7)
  • Solaris 2.6 with these patches:
    • 105181-10 (recommended)
    • 105284-05 (recommended)
    • 105490-04 (recommended)
    • 106040-10 (recommended for non-English locales)
    • 106409-01 (recommended for locales that use traditional Chinese characters)
  • Solaris 2.5.1 with these patches:
    • 103566-25 (required)
    • 103640-17 (required)
    • 106255-01 (required)
    • 106529-04 (required)
CSU 2.3.5.1
  • Solaris 2.7 (also known as Solaris 7)
  • Solaris 2.6 with these patches:
    • 105181-10 (or later version)
    • 105284-05 (or later version) and at least one of the following:
    • 105490-04 (or later version)
    • 107773-01 (or later version)
  • Solaris 2.5.1 with these patches:
    • 103566-25 (or later version)
    • 103640-27 (or minimum 103900-03)
    • 106529-04 (or minimum 101242-13)
    • 106255-01 (or later version)
CSU 2.3.5.2
  • Solaris 2.7 (also known as Solaris 7)
  • Solaris 2.6 with these patches:
    • 105181-10 (recommended)
    • 105284-05 (recommended)
    • 105490-04 (recommended)
    • 106040-10 (recommended for non-English locales)
    • 106409-01 (recommended for locales that use traditional Chinese characters)
CSU 2.3.6
  • Solaris 2.8 (also known as Solaris 8)
  • Solaris 2.7 (also known as Solaris 7)
  • Solaris 2.6 with these patches:
    • 105181-10 (recommended)
    • 105284-05 (recommended)
    • 105490-04 (recommended)
    • 106040-10 (recommended for non-English locales)
    • 106409-01 (recommended for locales that use traditional Chinese characters)
  • Solaris 2.5.1 with these patches:
    • 103566-25 (required)
    • 103640-17 (required)
    • 106255-01 (required)
    • 106529-04 (required)
CSU 2.3.6.1
  • Solaris 2.8 (also known as Solaris 8)
  • Solaris 2.7 (also known as Solaris 7)
  • Solaris 2.6 with these patches:
    • 105181-10 (recommended)
    • 105284-05 (recommended)
    • 105490-04 (recommended)
    • 106040-10 (recommended for non-English locales)
    • 106409-01 (recommended for locales that use traditional Chinese characters)
CSU 2.3.6.2
  • Solaris 2.9 (also known as Solaris 9)
  • Solaris 2.8 (also known as Solaris 8)
  • Solaris 2.7 (also known as Solaris 7)
  • Solaris 2.6 with these patches:
    • 105181-10 (recommended)
    • 105284-05 (recommended)
    • 105490-04 (recommended)
    • 106040-10 (recommended for non-English locales)
    • 106409-01 (recommended for locales that use traditional Chinese characters)

Note: This table lists the minimum revision of the patches. Later revisions are acceptable. Solaris patches or their latest versions can be downloaded from SunSolve leavingcisco.com.

Web Browsers

Version Compatible With
CSU 2.2(2)
  • Solaris:
    • Netscape Navigator 4.04
  • Windows 95/NT:
    • Netscape Navigator 3.04 through 4.03
    • Netscape Communicator 4.04
    • Microsoft Internet Explorer (IE) 3.01, 3.02, 4.0
CSU 2.2(3)
  • Solaris:
    • Netscape Navigator 4.04
  • Windows 95/98/NT:
    • Netscape Navigator 4.04, 4.05
    • Microsoft IE 3.x, 4.x
CSU 2.2(3) Patch 2
  • Solaris:
    • Netscape Navigator 4.08, 4.5
  • Windows 95/98/NT:
    • Netscape Navigator 4.08, 4.5
    • Microsoft IE 4.01
CSU 2.2(4)
  • Solaris:
    • Netscape Communicator 4.5, 4.51
  • Windows 95/98/NT:
    • Netscape Communicator 4.5, 4.51
    • Microsoft IE 4.01
CSU 2.3(1) and 2.3(2)
  • Solaris:
    • Netscape Communicator 4.04
  • Windows 95/98/NT:
    • Netscape Navigator 4.04, 4.05, 4.07
    • Microsoft IE 3.x or 4.x
CSU 2.3(3)
  • Solaris:
    • Netscape Communicator 4.5, 4.51, 4.6, 4.61
  • Windows 95/98/NT:
    • Netscape Communicator 4.5, 4.51, 4.6, 4.61
    • Microsoft IE 4.01
CSU 2.3.5
  • Solaris:
    • Netscape Communicator 4.5, 4.51, 4.6, 4.61, 4.7
  • Windows 95/98/NT:
    • Netscape Communicator 4.5, 4.51, 4.6, 4.61, 4.7
    • Microsoft IE 4.01, 5.0
CSU 2.3.5.1
  • Solaris:
    • Netscape Communicator 4.5, 4.51, 4.6, 4.61, 4.7, 4.72
  • Windows 95/98/NT:
    • Netscape Communicator 4.5, 4.51, 4.6, 4.61, 4.7, 4.72
    • Microsoft IE 4.01, 5.0
CSU 2.3.5.2
  • Solaris:
    • Netscape Communicator 4.51, 4.61, 4.7
  • Windows 95/98/NT:
    • Netscape Communicator 4.51, 4.61, 4.7, 4.72, 4.74
    • Microsoft IE 4.01 SP2, 5.0, 5.5
CSU 2.3.6
  • Solaris:
    • Netscape Communicator 4.51, 4.61, 4.7. 4.72
  • Windows 95/98/NT:
    • Netscape Communicator 4.51, 4.61, 4.7, 4.72, 4.74
    • Microsoft IE 4.01 SP2, 5.0, 5.5
CSU 2.3.6.1
  • Solaris:
    • Netscape Communicator 4.51, 4.61, 4.7, 4.72, 4.75, 4.77
  • Windows NT/2000:
    • Netscape Communicator 4.72, 4.74, 4.77, 4.79, 6.2
    • Microsoft IE 5.0, 5.5
CSU 2.3.6.2
  • Solaris:
    • Netscape Communicator 4.51, 4.61, 4.7, 4.72, 4.75, 4.77
  • Windows NT/2000:
    • Netscape Communicator 4.72, 4.74, 4.77, 4.79, 6.2
    • Microsoft IE 5.0, 5.5

Note these caveats as you work with CSU and a web browser:

  • The Security Socket Layer (SSL) feature of Netscape Navigator 4 for Solaris does not support the Java-based Cisco Secure Administrator advanced configuration program. To access the Cisco Secure Administrator using the SSL feature, use Netscape Navigator or Netscape Communicator for Windows 95 or Windows NT.

  • If using Microsoft IE 3.02 or later, you must have JIT compiling turned off in the Advanced Properties menu. If a later version of Microsoft IE was installed over an earlier version without removal of the earlier version, and you are encountering problems, completely remove Microsoft IE and then reinstall.

  • If using Netscape Navigator, confirm that your browser has Java and JavaScript enabled by choosing Network Preferences from the Options menu; select the Languages tab and confirm that an x is placed in the check boxes beside Java and JavaScript. Set memory cache to 8M and disk cache to 20M. There should be no proxy server selected.

  • If you are having problems with a version of Netscape you installed before installing CSU, completely remove Netscape and then reinstall.

  • You can find additional information about known browser problems in the CSU Installation Guide. Look at the section titled "Existing Issues with Cisco Secure ACS."

Database Software

Version Compatible With
CSU 2.1(x)
  • SQLAnywhere
  • Oracle version 7.3.2
  • Sybase SQL Server version 11
CSU 2.2(x) through 2.3.5.2
  • SQLAnywhere
  • Oracle Enterprise version 7.3.2, 7.3.3, 7.3.4 or 8.0.x
  • Sybase SQL Server version 11.0.2 and later
CSU 2.3.5.1 and 2.3.5.2
  • CSU has been tested with these database engines:
    • Oracle Enterprise version 8.0.5
    • Sybase Enterprise version 11.9.2
    • Sybase Enterprise version 11.0.2 (for replication)
  • Supported database engines include:
    • SQLAnywhere
    • Oracle Enterprise version 7.3.2, 7.3.3, 7.3.4, or 8.0.x
    • Sybase SQL Server version 11.0.2 or later
CSU 2.3.6 and 2.3.6.1
  • CSU 2.3.6 has been tested with these database engines:
    • SQLAnywhere
    • Oracle Enterprise version 8.0.5
    • Oracle Enterprise version 8i releases 8.1.5, 8.1.6, and 8.1.7
    • Sybase Enterprise version 11.9.2
  • Supported database engines include:
    • SQLAnywhere
    • Oracle Enterprise version 7.3.4, 8.0.x, or 8i
    • Sybase SQL Server version 11.0.2 or later
CSU 2.3.6.2
  • CSU 2.3.6 has been tested with these database engines:
    • SQLAnywhere
    • Oracle Enterprise version 8.0.5
    • Oracle Enterprise version 8i releases 8.1.5, 8.1.6, and 8.1.7
    • Sybase Enterprise version 11.9.2
  • Supported database engines include:
    • SQLAnywhere
    • Oracle Enterprise version 8.0.x, 8i, and 9i version 9.0.1
    • Sybase SQL Server version 11.0.2 or later

Note these caveats as you work with CSU and its supported databases:

  • The supplied SQLAnywhere database does not require preinstallation on the network.

  • The SQLAnywhere database engine does not support networks of more than 5,000 users and does not support database replication. If your network requires these user database capabilities, Cisco recommends preinstalling the Oracle Enterprise or Sybase Enterprise database engine.

  • Oracle Enterprise requires pre-installation and configuration. It must be running during CSU installation. For instructions on configuring this software to support CSU, refer to "Setting Up an Oracle Database for Cisco Secure" in the CSU installation guide for your software version in the Documentation for Cisco Secure ACS for UNIX.

  • Sybase Enterprise versions 11.0.2 and later require pre-installation and configuration. The software must be running during CSU installation. For instructions on configuring this software to support CSU, refer to "Setting Up a Sybase Enterprise SQL Server for Cisco Secure" in the CSU installation guide for your software version in the Documentation for Cisco Secure ACS for UNIX.

  • If you intend to set up CSU with Oracle database replication, read "Using Cisco Secure with Oracle's Distributed Database Feature" before you install the Oracle or Cisco Secure software. This document has the file name csbsdoc.pdf and can be found in the /CSCEacs/reloc/FastAdmin/docs directory of the CSU distribution CD-ROM. The document provides an easy-to-understand, start-to-finish, screen-by-screen configuration example of setting up Oracle database replication to work with CSU.

  • From CSU version 2.3, Oracle enterprise version 7.33 or later is required for database replication and DSM support.

  • Oracle SQL*Net and TCP/IP protocol adapter from Oracle 7.3.4 or later are required with CSU 2.3(1). These are the required components on the system where CSU is installed. It is highly recommended (although not required) to have Oracle 7.3.4 or later rdbms server.

Token Server

Version Compatible With
CSU 2.3.6.2
  • Cisco Secure Unix Server comes bundled with CRYPTOCard server and does not need an external CRYPTOCard server. CSU supports only the bundled software v3.2. It supports only RB-1 CRYPTOCard.
  • RSA ACE/Server version 5.2 and ACE/Client version 1.4
  • Secure Computing Safeword Server 5.2

Hardware

In this section, you can see the hardware that is compatible with CSU.

CSU Compatible With
CSU 2.1(x)
  • Sun SPARCstation or compatible workstation (SPARC 20 or faster recommended)
  • 128 MB minimum of swap space
  • 64 MB of RAM
  • At least 500 MB of free disk space for the first 10,000 users, and 256 KB for each additional 1,000 users
  • CD-ROM drive
CSU 2.2(x) and later
  • Sun SPARCstation or compatible workstation (SPARC 20, 167 Mhz or faster recommended)
  • Minimum 256 MB of swap space
  • 128 MB of RAM
  • Minimum 250 MB of free disk space for 5000 users (if you are using the supplied SQLAnywhere database)
  • CD-ROM drive
CSU 2.3(x) through 2.3.6
  • Sun UltraSPARC or compatible workstation
  • To support CSU with or without the licensed Distributed Session Manager option:
    • Ultra 1 with a processor speed of 167 MHz or faster
    • 256 MB of swap space
    • 128 MB of RAM
    • 256 MB of free disk space
  • If the Oracle or Sybase RDBMS is installed on the same system:
    • Ultra 10 with a processor speed of 200 MHz or faster
    • 512 MB of swap space
    • 256 MB of RAM
    • 2 GB of free disk space
  • CD-ROM drive
CSU 2.3.6.1 and 2.3.6.2
  • To support CSU with or without the licensed Distributed Session Manager option:
    • Ultra 1 with a processor speed of 167 MHz or faster
    • 512 MB of swap space
    • 512 MB of RAM
    • 512 MB of free disk space
  • If the Oracle or Sybase RDBMS is installed on the same system:
    • Ultra 10 with a processor speed of 200 MHz or faster
    • 1 GB of swap space
    • 512 MB of RAM
    • 4 GB of free disk space

Related Information

Updated: May 14, 2009
Document ID: 16090