Guest

IPSec Negotiation/IKE Protocols

Cisco Hardware and VPN Clients Supporting IPSec/PPTP/L2TP

Document ID: 4504

Updated: Feb 07, 2007

   Print

Introduction

This document shows which versions of Cisco VPN Clients, VPN Concentrators, Cisco IOS® Software, and the PIX Firewall support IPsec/Point-to-Point Tunneling Protocol (PPTP).

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions.

  • Cisco IOS Software Releases 12.2.8T and later

  • Cisco VPN 3000 Concentrator

  • Cisco VPN 5000 Concentrator (Cisco has announced the end of sales for the Cisco VPN 5000 Series Concentrators. Refer to the End-of-Sales Announcement for more information.)

  • Cisco Secure PIX Firewall and Cisco PIX Firewall Software 5.0.x through 6.3.x

  • Cisco Secure VPN Client (CSVPN) 1.0 and 1.1

    Refer to EOS and EOL Product Bulletin # 2224 for more information.

  • Cisco VPN Client (CVPN) 2.5 and later

  • Microsoft Windows 9.x, ME, SE, XP, NT 4.0, 2000, and XP

  • Solaris 2.6

  • Linux 2.2.12 and 2.2.14

  • Mac OS 9, 10.0 (Mac OS X), 10.1, and later

In order to obtain the latest VPN software, visit the Cisco resource center for VPN Software Download (registered customers only) . Refer also to all Security and VPN End-of-Sale and End-of-Life product literature.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

IPsec/PPTP Support

Supported versions are listed as client version/hardware operating system version. For example, the listing "CVPN 5000 Client 5.1.7 / 5.2.22" in the Cisco VPN 5000 Concentrator column and the Windows 9x row means that IPsec/PPTP is supported when:

  • the end user's PC with Windows 9x

  • runs Cisco VPN 5000 Client version 5.1.7

  • and connects to the Cisco VPN 5000 Concentrator

  • which runs VPN Concentrator software version 5.2.22

See Table Notes for information about the abbreviations used in this table.

  Client Version/ Hardware Operating System Version
Client OS Cisco IOS Software on an IOS device Cisco VPN 3000 Concentrator Cisco VPN 5000 Concentrator Cisco PIX Firewall
Windows 9x++ CSVPN 1.1 / 12.0.7T+ CVPN 3000 Client 2.5.x+ CVPN 5000 Client 5.1.7 / 5.2.22 CSVPN 1.1 / 5.1.x+
CVPN 3.x / 12.2.8T or 12.3 CVPN 3000 Client 2.5.x / 2.5.x+   CSVPN 1.0 / 5.0.x
  CVPN 3000 Client 3.x+ / 3.x+   CVPN 3000 Client 2.5.2 / 5.2.x+
      CVPN Client 3.x+ / 6.0.x+
Windows ME CVPN 3.x / 12.2.8T or 12.3 CVPN 3000 Client 3.x+ / 3.x+ CVPN 5000 Client 5.1.7 / 5.2.22 CVPN 3.x+ / 6.0.x+
Windows NT 4.0 CSVPN 1.1 / 12.0.7T+ CVPN 3000 Client 2.5.x+ CVPN 5000 Client 5.1.7 / 5.2.22 CSVPN 1.1 / 5.1.x+
CVPN 3.x / 12.2.8T or 12.3 CVPN 3000 Client 2.5.x / 2.5.x+   CSVPN 1.0 / 5.0.x
  CVPN Client 3.x + / 3.x+   CVPN 3000 Client 2.5.2 / 5.2.x+
      CVPN Client 3.x+ / 6.0.x+
Windows 2000 CVPN 3.x / 12.2.8T or 12.3 CVPN 3000 Client 3.x / 3.x CVPN 5000 Client 5.1.7 / 5.2.22, 5.1.10 (3DES available) CVPN Client 3.x+ / 6.0.x+
Windows XP CVPN 3.1.2+ / 12.2.8T or 12.3 CVPN 3000 Client 3.1.2+ / 3.x CVPN 5000 Client 5.1.10 (3DES available) /5.2.22 [XP Home Edition or Professional] CVPN Client 3.1+ / 6.0.x+
Palm PDA/Palm OS 3.5   MovianVPN***/3.x    
Handheld or Pocket PC/ Windows CE   MovianVPN***/3.x    
Solaris 2.6 CVPN Client 3.X/12.2.8T CVPN Client 3.5 for Solaris / 3.5 CVPN 5000 Client 5.0.8 / 5.2.22 CVPN Client 3.5 for Solaris / 6.x
Mac OS 8**** and 9****   ****Netlock leavingcisco.com CVPN 5000 Client 5.0.3 / 5.2.22  
Mac OS 10.0 or Mac OS X* CVPN Client 3.X/12.2.8T CVPN Client 3.5 for Mac OS X / 3.5 CVPN 5000 Client 5.1.2 CVPN Client 3.5 for Mac OS X / 6.x
Mac OS X.1 CVPN Client 3.X/12.2.8T CVPN Client 3.5 for Mac OS X / 3.5 CVPN 5000 Client 5.1.4 Release Notes  
Mac OS X and 10.1.0 or later CVPN Client 3.6/12.2.8T CVPN Client 3.6 for Mac OS X, Version 10.1.0 or later / 3.0 or later   Version 6.1(1) or later
Linux 2.2.12 (Red Hat 6.2 Linux (Intel) or compatible distribution, using kernel Version 2.2.12 or later) CVPN Client 3.X/12.2.8T CVPN 3000 Client 3.0.8+ / 3.x+    
Linux CVPN Client 3.X/12.2.8T CVPN Client 3.5 for Linux / 3.5   CVPN Client 3.5 for Linux / 3.5
Linux 2.2.14 CVPN Client 3.X/12.2.8T   CVPN 5000 Client 5.0.19 / 5.2.14  
Linux (Intel) Kernel 2.2.5 CVPN Client 3.X/12.2.8T   CVPN 5000 Client 5.2.X  
Microsoft PPTP Microsoft native PPTP/ 12.1.5T+ Microsoft native PPTP / 2.5+   Microsoft native PPTP / 5.2+
3002   CVPN Hardware Client 3.0+ / 3.0+   CVPN Hardware Client 3.0+ / 6.0+
L2TP/IPSec Microsoft native/ 12.0.7T+ Microsoft native / 2.5+   Microsoft native / 6.0+

Table Notes

  • CVPN is the Cisco VPN Client (versions 2.x and above), not the Cisco Secure VPN Client (version 1.x only).

  • CSVPN is the Cisco Secure VPN Client.

  • + Support continues to all later versions.

  • ++ Windows 98 Second Edition (SE) support added in VPN 3.0 Client. The VPN 3.1 Client requires Operating System Release 2 (OSR2) of Windows 95.

  • * There is no DES version available for Mac X release, only 3DES.

  • *** The MovianVPN client is now End-of-Life; refer to Product Status - End of Life leavingcisco.com for more information.

  • **** Cisco does not Original Equipment Manufacture (OEM) a Mac OS 8 or 9 VPN Client. A VPN Client for use with the VPN 3000 Concentrators is available from Netlock leavingcisco.com.

Related Information

Updated: Feb 07, 2007
Document ID: 4504