Guest

Cisco ASR 900 Series Aggregation Services Routers

ASR 903 Port-Channel Group Members Flap After EVC Configuration

Techzone Article content

Document ID: 116116

Updated: Jun 25, 2013

Contributed by Amer Ibrahimovic, Cisco TAC Engineer.

   Print

Introduction

This document describes the solution to an issue in which port-channel group members flap after Ethernet Virtual Connections (EVC) are configured on Cisco ASR 903 Series Aggregation Services Routers.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on Cisco ASR 903 Series Aggregation Services Routers configured as a Provider Edge device with port-channel towards the Customer Edge device.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Problem

The port-channel group members start to flap after you configure Ethernet Virtual Connections (EVC); when you remove the EVC configuration, the port-channel group members no longer flap.

The logs display output similar to this:

GigabitEthernet0/0/4 taken out of port-channel1
GigabitEthernet0/0/4 added as member-2 to port-channel1
GigabitEthernet0/0/5 taken out of port-channel1
GigabitEthernet0/0/5 added as member-2 to port-channel1

This issue is specific to the ASR 903 port channels with EVC and is seen in this sample configuration:

!
interface Port-channel1
mtu 1604
no ip address
no negotiation auto
service instance 999 ethernet
encapsulation dot1q 999
rewrite ingress tag pop 1 symmetric
bridge-domain 999
!
service instance 1700 ethernet
encapsulation dot1q 1700
rewrite ingress tag pop 1 symmetric
xconnect 172.26.225.1 1700 encapsulation mpls pw-class TE101
!
service instance 1820 ethernet
encapsulation dot1q 1820
rewrite ingress tag pop 1 symmetric
xconnect 172.26.225.15 1820 encapsulation mpls pw-class TE305
!
interface GigabitEthernet0/0/4
mtu 1604
no ip address
negotiation auto
service-policy input Core-In
service-policy output Core-Out
channel-group 1 mode active
!
interface GigabitEthernet0/0/5
mtu 1604
no ip address
negotiation auto
cdp enable
service-policy input Core-In
service-policy output Core-Out
channel-group 1 mode active

Solution

When you configure port channels with EVC on the ASR 903, you must configure 1 EVC with untagged encapsulation and L2 protocol. For example:

interface Port-channel1
!
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
l2protocol peer
!

For more information on ASR 903 service instances and port channels, refer to the EFPs and EtherChannels section of the Configuring Ethernet Virtual Connections on the Cisco ASR 903 Router.

Updated: Jun 25, 2013
Document ID: 116116