Guest

Cisco 800 Series Routers

Configuring a Cisco 827 Router With AAL5MUX IP Routing, Multiple PVCs, and Terminating on a Cisco 6400 UAC-NRP

Cisco - Configuring a Cisco 827 Router With AAL5MUX Encapsulation, Multiple PVCs, and Termininating on a Cisco 6400 UAC-NRP

Document ID: 12891

Updated: Nov 23, 2007

   Print

Introduction

This sample configuration shows a Cisco 827 Digital Subscriber Line (DSL) Router that has been configured with AAL5MUX encapsulation and supports multiple Permanent Virtual Circuits (PVCs). The Cisco 827 is connected to a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM) and terminates at a Cisco 6400 Universal Access Concentrator-Node Route Processor (UAC-NRP). Also included are configurations for the Cisco 6130 and Cisco 6400.

In this example, IP is used for both PVCs to show how it maps to the Cisco 6400 UAC-NRP.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco 827-4V Customer Premises Equipment (CPE) IOS® Software Release 12.1(1)XB

  • Cisco 6400 UAC-NRP IOS Software Release 12.0(7)DC

  • Cisco 6400 UAC-NSP IOS Software Release 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(1)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

827pvc_encap_6400.gif

Configurations

This document uses the configurations shown below.

Cisco 827
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 no ip address 
 no ip directed-broadcast 
 shutdown 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 bundle-enable 
 hold-queue 224 in 
! 
interface ATM0.3 point-to-point 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 pvc 3/100 
  protocol ip 172.18.0.2 
  encapsulation aal5mux ip 
 ! 
! 
interface ATM0.4 point-to-point 
 ip address 172.19.0.1 255.255.0.0 
 no ip directed-broadcast 
 PVC 4/100 
  protocol ip 172.19.0.2 
  encapsulation aal5mux ip 
 ! 
! 
ip classless 
ip route 172.18.0.2 255.255.255.255 ATM0.3 
ip route 172.19.0.2 255.255.255.255 ATM0.4 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
! 
end

Cisco 6130 DSLAM (NI2)
Current configuration:
!
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname ni2 
! 
interface ATM0/0 
 no ip address 
 ATM cac service-category abr deny 
 ATM maxvp-number 0 
 ATM maxvc-number 4096 
 ATM maxvci-bits 12 
! 
interface Ethernet0/0 
 no ip route-cache 
! 
interface ATM0/1 
 no ip address 
 ATM ilmi-keepalive 
 ATM cac service-category abr deny 
! 
interface ATM1/4 
 no ip address 
 no ATM ilmi-keepalive 
 ATM PVC 3 100  interface  ATM0/1 3 100 
 ATM PVC 4 100  interface  ATM0/1 4 100 
ip classless 
no ip http server 
! 
end

Cisco 6400-NSP1
Current configuration: 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NSP1 
! 

interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 ! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface ATM1/0/0 
 no ip address 
 no ip directed-broadcast 
 no ATM ilmi-keepalive 
!
interface ATM8/0/1 
 no ip address 
 no ip directed-broadcast 
 no ATM ilmi-keepalive 
 ATM PVC 3 100  interface  ATM1/0/0 3 100 
 ATM PVC 4 100  interface  ATM1/0/0 4 100 
! 
ip classless 
end 

Cisco 6400-NRP1
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.3 point-to-point 
 ip address 172.18.0.2 255.255.0.0 
 no ip directed-broadcast 
 no ip route-cache 
 PVC 3/100 
  encapsulation aal5mux ip 
 ! 
! 
interface ATM0/0/0.4 point-to-point 
 ip address 172.19.0.2 255.255.0.0 
 no ip directed-broadcast 
 no ip route-cache 
 PVC 4/100 
  encapsulation aal5mux ip 
! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Nov 23, 2007
Document ID: 12891