Guest

Cisco 800 Series Routers

Cisco 827 Router Configuration Frequently Asked Questions

Cisco - Cisco 827 Router Configuration Frequently Asked Questions

Document ID: 12879

Updated: Jun 01, 2005

   Print

Contents

Introduction

This document addresses the most frequently asked questions regarding the Cisco 827 router configuration.

Cisco 827-4V Front Panel

827_4v_front.gif

Cisco 827-4V Back Panel

827_4v_back.gif

Cisco 827 Front Panel

827_front.gif

Cisco 827 Back Panel

827_back.gif

Q. How do I configure the Cisco 827 for RFC1483 Bridging?

!
no ip routing           

!--- Disable IP routing.
 
!
interface Ethernet0 
 no ip address 
 no ip directed-broadcast 
 bridge-group 1       
 
!--- Specify the bridge-group number the interface belongs to.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 ! 
  encapsulation aal5snap
 ! 
 bridge-group 1         
 
!--- Specify the bridge-group number the interface belongs to.

! 
bridge 1 protocol ieee 
! 

Q. How do I configure the Cisco 827 for RFC1483 Bridging with Integrated Routing and Bridging (IRB)?

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify the bridge-group number the interface belongs to.

 !
interface BVI1          

!--- A routed interface from the WAN bridge-group to the
!--- nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. How do I configure the Cisco 827 for RFC1483 Bridging with IRB and Port Address Translation (PAT) when I am assigned one usable address from my provider?

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.

!
interface BVI1          

!--- A routed interface from the WAN bridge-group
!--- to the nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
!
ip nat inside source list 1 interface BVI1 overload     

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to the address specified in the BVI interface.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. How do I configure the Cisco 827 for RFC1483 Bridging with IRB and Network Address Translation (NAT) when I am assigned a block of usable addresses from my provider?

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.
 
!
interface BVI1          

!--- A routed interface from the WAN bridge-group to the
!--- nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

!
ip nat pool POOL-A 192.168.2.2 192.168.2.10 netmask 255.255.255.0

!--- Create a pool of global IP addresses for NAT.

!
ip nat inside source list 1 pool POOL-A overload

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to one of the addresses specified in the pool.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. How do I configure the Cisco 827 for RFC1483 Routing?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast 
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.
 
  !
  encapsulation aal5snap
 !
!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!

Q. How do I configure the Cisco 827 for RFC1483 Routing with PAT when I am assigned one usable address from my provider?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
ip nat inside source list 1 interface ATM0.1 overload   

!--- Enable the dynamic translation of addresses permitted by the
!--- access-list to the address specified in the ATM interface.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. How do I configure the Cisco 827 for RFC1483 Routing with NAT when I am assigned a block of usable addresses from my provider?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 ip nat outside         
 
!--- Establish the interface as the outside interface. 

 !
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
ip nat pool POOL-A 192.168.2.2 192.168.2.10 netmask 255.255.255.0

!--- Create a pool of global IP addresses for NAT.

!
ip nat inside source list 1 pool POOL-A overload

!--- Enable dynamic translation of addresses permitted by
!--- the access-list to one of the addresses specified in the pool.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. How do I configure the Cisco 827 for PPP over ATM (PPPoA) with Internet Protocol Control Protocol (IPCP)?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast 
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
  
!--- Specify a dialer pool-member.

 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. How do I configure the Cisco 827 for Easy IP (Phase I) with PAT and PPP/IPCP?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
  
!--- Specify a dialer pool-member.

 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

!
ip nat inside source list 1 interface Dialer1 overload  

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to the address specified in the Dialer interface.

!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!
!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. How do I configure the Cisco 827, acting as a DHCP server, for Easy IP (Phase 2)?

!
ip dhcp pool POOL-DHCP
 network 192.168.1.0 255.255.255.0    
 
!--- Specify a range of IP addresses that can be assigned to
!--- the DHCP clients.

!
 domain-name cisco.com        
 
!--- Configure the domain name.

!
 dns-server 192.168.3.1       
 
!--- Configure the DNS server.

!
 default-router 192.168.1.1
 
!--- Designate the router as the default router and specify
!--- an IP address.

!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
!--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  ### specify a dialer pool-member
 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          

 !--- Specify which dialer pool number you are using.

 !
!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. How do I configure the Cisco 827, acting as a DHCP Relay, for Easy IP (Phase 2)?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip helper-address 192.168.4.1  
 
!--- Forward default UDP broadcasts including 
 !--- IP configuration requests to the DHCP server.

 !
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
 
 !--- Specify a dialer pool-member.
 
 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

 !
!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. How do I configure the Cisco 827 to be a DHCP client with PAT?

!
bridge irb
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.

!
interface BVI1
 ip address dhcp client-id Ethernet0    
 
!--- Use the MAC address of the Ethernet interface as 
 !--- the client ID when the DHCP request is sent.

 !
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
!
ip nat inside source list 1 interface BVI1 overload     

!--- Enable the dynamic translation of addresses permitted by
!--- the access-list to the address specified in the BVI interface.

!
ip route 0.0.0.0 0.0.0.0 BVI1   

!--- Configure the default gateway.

!
!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting 
!--- addresses that need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. How do I configure the Cisco 827 for PPP over Ethernet (PPPoE)?

A. Please refer to the configuration of RFC1483 Bridging.

Q. Can I configure the Cisco 827 as a PPPoE client?

A. Yes, but Cisco IOS® Software Release 12.1(3)XG or later is required. Please see Configuring the Cisco 827 Router as a PPPoE Client With NAT.

Q. How do I configure the Cisco 827-4V for basic Voice over IP (VoIP)?

!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip
 destination-pattern 2...	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 codec g711ulaw			
 
!--- Specify a codec if you are not 
!--- using the default codec of g.729.

!

Q. How do I configure Quality of Service (QoS) for voice?

A. A single PVC Environment in which Cisco IOS provides both Priority Queuing (using CBWFQ) for voice and fragmentation and interleaving:

!
class-map VOICE			

!--- Configure a class for voice.

!
 match access-group 101	
 
!--- Associate the class with the access-list.

 !
!
policy-map POLICY		

!--- Configure a policy map.

!
 class VOICE			
 
!--- Specify the class for queuing.

!
  priority 480		
  
!--- Specify strict priority for voice traffic.

 !
!
interface ATM0
 mtu 300		
 
!--- Decrease MTU of ATM interface so that large 
!--- IP data packets get fragmented.

 !
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1/35 		
 
!--- VPI/VCI assigned to you by your provider.

 !
  service-policy out POLICY	
  
!--- Associate policy map to PVC.

  !
  vbr-rt 640 640 10		
  
!--- Specify the service class.

  !
  encapsulation aal5snap
 !
 bundle-enable
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip  
 destination-pattern 2... 	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 ip precedence 5		
 
!--- Configure IP precedence 5 for voice packets.

 !
! 
access-list 101 permit ip any any precedence critical

!--- Configure access-list to match voice packets.

! 

Multiple PVC environment in which voice and data are on different subnets:

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 pvc 1/35			
 
!--- Voice PVC.

 !
  protocol ip 192.168.2.2 broadcast	
  
!--- Set the protocol broadcast for the IP address.

  !
  vbr-rt 424 424 5		
  
!--- Specify the service class.

  !
  encapsulation aal5snap
 !
!
interface ATM0.2 point-to-point
 ip address 192.168.3.1 255.255.255.0
 no ip directed-broadcast
 pvc 1/36			
 
!--- Data PVC.

 !
  protocol ip 192.168.3.2 broadcast	
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip 
 destination-pattern 2...	

 !--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
!

Multiple PVC environment in which voice and data are on the same subnet with virtual circuit bundling:

!
interface ATM0
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
 bundle TEST 			
 
!--- Specify a bundle name.

 !
  protocol ip 192.168.2.2 broadcast
  encapsulation aal5snap
  pvc-bundle data 1/36 		
  
!--- Create a PVC for the data bundle.

  !
   precedence other		
   
!--- Set the IP precedence level other to the data bundle.

   !
  pvc-bundle voice 1/35 	
  
!--- Create a PVC for the voice bundle.

  !
   vbr-rt 424 424 5		
   
!--- Set the service class for the voice bundle.

   !
   precedence 5			
   
!--- Set the IP precedence level critical to the voice bundle.

   !
 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip
 destination-pattern 2...	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 ip precedence 5		
 
!--- Set IP precedence to critical for voice traffic.

 !
!

Q. How do I configure the Cisco 827-4V to register with an H.323 Gatekeeper?

!
interface ATM0
 h323-gateway voip interface	
 
!--- Identifies this interface as a VoIP gateway interface.

 !
 h323-gateway voip id GATEKEEPER ipaddr 192.168.1.2 1719
 
!--- Defines the name and location of the gatekeeper 
 !--- for this gateway.

 !
 h323-gateway voip h323-id GATEWAY 	
 
!--- Defines the H.323 name of the gateway, identifying 
 !--- this gateway to its associated gatekeeper.

 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

!
dial-peer voice 10 voip
 destination-pattern +.T	
 
!--- Define the destination number pattern.

 !
 session target ras		
 
!--- Specify a destination to be RAS.

!
gateway
!

Q. How do I configure line encoding on my Cisco 827 ADSL interface?

A. Log in to the Cisco 827 and from enable mode, issue the Cisco IOS command dsl operating-mode xxx where xxx is your line encoding type.

Note: The Cisco 827 ADSL interface is in auto detect mode by default and will auto detect the line encoding to use when it connects to your Internet Service Provider (ISP).

The following example shows setting the line encoding to G.LITE.

Router>enable 
Router# 
Router#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface atm 0 
Router(config-if)#dsl operating-mode ? 
ansi-dmt ANSI full rate mode 
auto auto detect mode 
itu-dmt ITU full rate mode 
splitterless G.lite mode 

Router(config-if)#dsl operating-mode splitterless 

Router(config-if)# exit 
Router(config)# exit 
Router#write mem 
Building configuration... 
[OK] 
Router#

The following sample configuration shows a Cisco 827 after its been configured for G.LITE.

Router#show running 
Building configuration... 

Current configuration : 1198 bytes 
! 
version 12.2 

interface ATM0 
 no ip address 
dsl operating-mode splitterless 

!--- This is G.LITE mode.
 
! 
end

Another way to verify that the Cisco 827 ADSL interface is in G.LITE mode is to issue the Cisco IOS command show controller atm 0. In the output you should see (G.Lite). For example:

Router#show controller atm 0
.Snip 
.Snip 
.Snip 
15 Real bd=0x80BFD628 Status=0x0 Buf=0x1F0222E Len=14 Own=0 
16 Real bd=0x80BFD634 Status=0x2000 Buf=0x1F0222E Len=14 Own=0 
          ATU-R (DS)              ATU-C (US) 
Modem Status: Showtime (DMTDSL_SHOWTIME) 
DSL Mode: ITU G.992.2 (G.Lite) 

!--- G.LITE mode is indicated here. 

ITU STD NUM: 0x01                0x1 
.Snip 
.Snip
end

Q. How do I configure NAT and PAT to support an internal Web server?

A. See Configuring Network Address Translation and Static Port Address Translation to Support an Internal Web Server.

Related Information

Updated: Jun 01, 2005
Document ID: 12879