Guest

Cisco 6400 Series Broadband Aggregators

Configuring a Cisco 6400 NRP Using Point-to-Point and Multipoint Interfaces with PPPoA (aal5mux ppp)

Cisco - Configuring a Cisco 6400 NRP Using Point-to-point and Multipoint Interfaces with PPPoA (aal5mux ppp)

Document ID: 12876

Updated: Jun 01, 2005

   Print

Introduction

This sample configuration shows a Cisco 6400 Universal Access Concentrator (UAC) with a node route processor (NRP) adapter. Examples of point-to-point and multipoint NRP configurations are provided. Two Cisco 827 digital subscriber line (DSL) Routers configured with Point-to-Point Protocol over Asynchronous transfer mode (PPPoA) (aal5mux ppp) terminate on the Cisco 6400.

Configurations for a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM) NI2 and Cisco 6400 node switch processor (NSP) also are provided.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco 827-4V Customer Premises Equipment (CPE) IOS® Software Release 12.1(1)XB

  • Cisco 6400 UAC-NRP IOS Software Release 12.0(7)DC

  • Cisco 6400 UAC-NSP IOS Software Release 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(1)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

827_6400_uac_nrp.gif

Configurations

This document uses the configurations shown below.

Cisco 827 Router (R1)
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec
service timestamps log datetime msec
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 no ip address 
 no ip directed-broadcast 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 pvc 3/100 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 bundle-enable 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1
 dialer-group 1 
 ppp authentication chap callin 
 ppp chap hostname <hostname1>
 ppp chap password <password1>
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
dialer-list 1 protocol ip permit 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end

Cisco 827 Router (R2)
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec
! 
hostname R2 
! 
ip subnet-zero 
! 
interface Ethernet0 
 no ip address 
 no ip directed-broadcast 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ATM ilmi-keepalive 
 PVC 4/100 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 bundle-enable 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.2 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap callin 
 ppp chap hostname <hostname2>
 ppp chap password <password2>
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
! 
dialer-list 1 protocol ip permit 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end

Cisco 6130-NI2 DSLAM
ni2#
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec
service timestamps log datetime msec
! 
hostname ni2 
! 
slot 1 ATUC-1-4DMT 
slot 2 ATUC-4FLEXIDMT 
slot 13 ATUC-4FLEXIDMT 
! 
dsl-profile default 
 dmt training-mode quick 
ip subnet-zero 
! 
ATM address 47.0091.8100.0000.0075.2b3f.4d01.0075.2b3f.4d01.00 
ATM router pnni 
 no aesa embedded-number left-justified 
 node 1 level 56 lowest 
  redistribute ATM-static 
! 
interface ATM0/0 
 no ip address 
 ATM cac service-category abr deny 
 ATM maxvp-number 0 
 ATM maxvc-number 4096 
 ATM maxvci-bits 12 
! 
interface Ethernet0/0 
 no ip route-cache 
! 
interface ATM0/1 
 no ip address 
 ATM ilmi-keepalive 
! 
interface ATM0/2
 no ip address 
 no ATM ilmi-keepalive 
! 
interface ATM1/1 
 no ip address 
 no ATM ilmi-keepalive 
! 
interface ATM1/2 
 no ip address 
 no ATM ilmi-keepalive 
! 
interface ATM1/3 
 no ip address 
 no ATM ilmi-keepalive 
 ATM PVC 3 100  interface  ATM0/1 3 100 
! 
interface ATM1/4 
 no ip address 
 no ATM ilmi-keepalive 
 ATM PVC 4 100  interface  ATM0/1 4 100 
! 
ip classless 
! 
end

Cisco 6400 NSP
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NSP 
! 
ip subnet-zero 
! 
atm address 47.0091.8100.0000.0030.8027.7501.0030.8027.7501.00 
atm router pnni 
 no aesa embedded-number left-justified 
 node 1 level 56 lowest 
  redistribute atm-static 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 atm maxvp-number 0 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface ATM1/0/0 
 no ip address 
 no ip directed-broadcast 
no atm ilmi-keepalive 
! 
interface ATM2/0/0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
! 
interface ATM8/0/0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
! 
interface ATM8/0/1 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 atm pvc 3 100  interface  ATM1/0/0 3 100 
 atm pvc 4 100  interface  ATM1/0/0 4 100 
! 
ip classless 
! 
end

Cisco 6400-NRP Using a Point-to-point Interface
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 
! 
username <username1> password <password1>
username <username2> password <password2>
! 
redundancy 
 main-cpu 
  no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback0 
 ip address 172.18.0.3 255.255.0.0 
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache 
 no atm ilmi-keepalive 
! 
interface ATM0/0/0.3 point-to-point
 no ip directed-broadcast 
 pvc 3/100 
  encapsulation aal5mux ppp Virtual-Template1 
 ! 
! 
interface ATM0/0/0.4 point-to-point 
 no ip directed-broadcast 
 pvc 4/100 
  encapsulation aal5mux ppp Virtual-Template1 
! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
interface Virtual-Template1 
 ip unnumbered Loopback0 
 no ip directed-broadcast 
 no peer default ip address 
 ppp authentication chap 
! 
ip classless 
end

Cisco 6400 NRP Using a Multipoint Interface
NRP#
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 
! 
username <username1> password <password1>
username <username2> password <password2>
! 
redundancy 
 main-cpu 
  no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback0 
 ip address 172.18.0.3 255.255.0.0 
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache 
 no atm ilmi-keepalive 
! 
interface ATM0/0/0.9 multipoint
 no ip directed-broadcast 
 pvc 3/100 
  encapsulation aal5mux ppp Virtual-Template1 
 !
 pvc 4/100 
  encapsulation aal5mux ppp Virtual-Template1 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
interface Virtual-Template1 
 ip unnumbered Loopback0 
 no ip directed-broadcast 
 no peer default ip address 
 ppp authentication chap 
! 
ip classless
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jun 01, 2005
Document ID: 12876