Guest

Cisco 6400 Series Broadband Aggregators

Configuring a Cisco 6400 to Support MUX-PPP, SNAP, and Use an atm ilmi-pvc-discovery Subinterface

Cisco - Configuring a Cisco 6400 to Support MUX-PPP, SNAP, and Use an atm ilmi-pvc-discovery Subinterface

Document ID: 12855

Updated: Nov 23, 2007

   Print

Introduction

This document describes a sample configuration for a Cisco 6400 Universal Access Concentrator (UAC) that supports MUX-PPP and Subnetwork Access Protocol (SNAP) and uses an atm ilmi-pvc-discovery subinterface.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Configuration

This document uses this configuration:

Cisco 6400 NRP1
!
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Access-6400-NRP1
!
enable password <password>
!
username <username> password 0 <password>
username <username1> password 0 <password1>
username <username2> password 0 <password2>
!
!
!
!
redundancy
 main-cpu
  auto-sync standard
 no secondary console enable
ip subnet-zero
ip domain-name cisco.com
ip name-server 171.68.10.70
!
!
!
bridge irb
!
!
process-max-time 200
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm ilmi-pvc-discovery subinterface
 pvc 0/16 ilmi
 !
!
interface ATM0/0/0.1 multipoint

!--- For VPI starting with number 1 (example: 1/34).

 no ip directed-broadcast
 class-int bridge1
 bridge-group 1
!
interface ATM0/0/0.4 multipoint

!--- For VPI starting with number 4 (example: 4/33).

 no ip directed-broadcast
 class-int router
!
interface Ethernet0/0/1
 no ip address
 no ip directed-broadcast
!
interface Ethernet0/0/0
 ip address 171.68.186.117 255.255.255.240
 no ip directed-broadcast
!
interface FastEthernet0/0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Virtual-Template1
 ip unnumbered Loopback1
 no ip directed-broadcast
 peer default ip address pool mypool
 ppp authentication chap
!
interface BVI1
 mac-address
 ip address 10.10.33.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool mypool 10.1.1.2 10.1.1.200
ip classless
ip route 0.0.0.0 0.0.0.0 171.68.186.113
no ip http server
!
!
vc-class atm bridge1
 encapsulation aal5snap
!
vc-class atm router
 encapsulation aal5mux ppp Virtual-Template1
tacacs-server host 171.68.201.249
tacacs-server last-resort succeed
tacacs-server optional-passwords
tacacs-server extended
!
bridge 1 protocol ieee
 bridge 1 route ip
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password xxxxxx
 login local
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

show atm pvc Command Output

Access-6400-NRP1# show atm pvc 
     VCD /               Peak Avg/Min Burst 
Interface  Name  VPI  VCI  Type  Encaps  SC  Kbps  Kbps  Cells  Sts
0/0/0         2    0   16  PVC     ILMI  UBR 155000              UP 
0/0/0.1       7    1   34  PVC-D   SNAP  UBR 155000              UP

!--- Snap (bridge).
!--- Subinterface 1 took VPI .

0/0/0.4       8    4   33  PVC-D    MUX  UBR 155000              UP 

!--- mux (ppp)
!--- Subinterface 4 took VPI 4.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, refer to Important Information on Debug Commands.

Debugging ATM Events

The following output shows the virtual path identifier/virtual channel identifier (VPI/VCI) that the node route processor (NRP) learns from the node switch processor (NSP).

Access-6400-NRP1# debug atm events
ATM events debugging is on

Shut/no Shut on main ATM0/0/0 interface
Access-6400-NRP1# 
*Dec 16 15:51:43.667: ATM0/0/0 nrp_sarmgr_shutdown: state=0 
*Dec 16 15:51:44.515: Resetting ATM0/0/0 
*Dec 16 15:51:45.015: Resetting ATM0/0/0
*Dec 16 15:51:45.015: nrp_sarmgr_config(ATM0/0/0)
*Dec 16 15:51:45.015: nrp_sarmgr_enable(ATM0/0/0
*Dec 16 15:51:45.215: nrp_sarmgr_enable(ATM0/0/0): restarting VCs: 0
*Dec 16 15:51:45.215: nrp_sarmgr_setup_vc(ATM0/0/0): vc:2 vpi:0 vci:16
*Dec 16 15:51:45.223: %SYS-5-CONFIG_I: Configured from console by console
*Dec 16 15:51:45.667: %LINK-3-UPDOWN: Interface ATM0/0/0, changed state to up
*Dec 16 15:51:46.667: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0/0, 
   changed state to up
*Dec 16 15:51:47.219: %LINK-3-UPDOWN: Interface BVI1, changed state to up
*Dec 16 15:51:47.471: Reserved bw for 1/34 Available bw = 155000
*Dec 16 15:51:47.471: nrp_sarmgr_setup_vc(ATM0/0/0): vc:13 vpi:1 vci:34
*Dec 16 15:51:47.475: Reserved bw for 4/33 Available bw = 155000 
*Dec 16 15:51:47.527: nrp_sarmgr_setup_vc(ATM0/0/0): vc:14 vpi:4 vci:33
*Dec 16 15:51:48.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, 
   changed state to up
*Dec 16 15:51:49.019: nrp_sarmgr_teardown_vc(ATM0/0/0): vc:13 vpi:1 vci:34
*Dec 16 15:51:49.179: nrp_sarmgr_teardown_vc(ATM0/0/0): vc:14 vpi:4 vci:33
*Dec 16 15:51:49.339: PPP-ATM(Virtual-Access1) deleting vaccess on VC 14
*Dec 16 15:51:49.351: %LANE-6-INFO: ATM0/0/0: ILMI prefix add event received
*Dec 16 15:51:49.659: Reserved bw for 1/34 Available bw = 155000 
*Dec 16 15:51:49.659: nrp_sarmgr_setup_vc(ATM0/0/0): vc:15 vpi:1 vci:34
*Dec 16 15:51:49.659: Reserved bw for 4/33 Available bw = 155000
*Dec 16 15:51:49.715: nrp_sarmgr_setup_vc(ATM0/0/0): vc:16 vpi:4 vci:33
*Dec 16 15:51:55.419: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
Access-6400-NRP1#

PPP Debug Output for a Cisco 675 in IP Routing Mode

Success rate is 0 percent (0/5) 
Access-6400-NRP1#
*Dec 16 15:38:03.439: Vi1 LCP: I CONFREQ [Open] id 42 len 14
*Dec 16 15:38:03.439: Vi1 LCP: MagicNumber 0xA60C0000 (0x0506A60C0000) 
*Dec 16 15:38:03.439: Vi1 LCP: MRU 2048 (0x01040800)
*Dec 16 15:38:03.439: Vi1 IPCP: State is Closed
*Dec 16 15:38:03.439: Vi1 PPP: Phase is ESTABLISHING 
*Dec 16 15:38:03.439: Vi1 LCP: O CONFREQ [Open] id 132 len 15
*Dec 16 15:38:03.439: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Dec 16 15:38:03.439: Vi1 LCP: MagicNumber 0x30995E50 (0x050630995E50)
*Dec 16 15:38:03.439: Vi1 LCP: O CONFACK [Open] id 42 len 14
*Dec 16 15:38:03.439: Vi1 LCP: MagicNumber 0xA60C0000 (0x0506A60C0000) 
*Dec 16 15:38:03.439: Vi1 LCP: MRU 2048 (0x01040800)
*Dec 16 15:38:03.443: Vi1 IPCP: Remove route to 10.1.1.2
*Dec 16 15:38:03.443: Vi1 LCP: I CONFACK [ACKsent] id 132 len 15
*Dec 16 15:38:03.443: Vi1 LCP: AuthProto CHAP (0x0305C22305) 
*Dec 16 15:38:03.443: Vi1 LCP: MagicNumber 0x30995E50 (0x050630995E50)
*Dec 16 15:38:03.447: Vi1 LCP: State is Open
*Dec 16 15:38:03.447: Vi1 PPP: Phase is AUTHENTICATING, by this end
*Dec 16 15:38:03.447: Vi1 CHAP: O CHALLENGE id 4 len 37 from "Access-6400-NRP1"
*Dec 16 15:38:03.451: Vi1 CHAP: I RESPONSE id 4 len 26 from "cisco"
*Dec 16 15:38:03.451: Vi1 CHAP: O SUCCESS id 4 len 4
*Dec 16 15:38:03.451: Vi1 PPP: Phase is UP
*Dec 16 15:38:03.451: Vi1 IPCP: O CONFREQ [Closed] id 5 len 16
*Dec 16 15:38:03.451: Vi1 IPCP: Address 10.1.1.1 (0x03060A010101)
*Dec 16 15:38:03.451: Vi1 IPCP: Type20 (0x900600000000)
*Dec 16 15:38:03.455: Vi1 IPCP: I CONFREQ [REQsent] id 43 len 10
*Dec 16 15:38:03.455: Vi1 IPCP: Address 10.1.1.2 (0x03060A010102)
*Dec 16 15:38:03.455: Vi1 IPCP: O CONFACK [REQsent] id 43 len 10
*Dec 16 15:38:03.455: Vi1 IPCP: Address 10.1.1.2 (0x03060A010102)
*Dec 16 15:38:03.455: Vi1 IPCP: I CONFREJ [ACKsent] id 5 len 10
*Dec 16 15:38:03.455: Vi1 IPCP: Type20 (0x900600000000)
*Dec 16 15:38:03.455: Vi1 IPCP: O CONFREQ [ACKsent] id 6 len 10
*Dec 16 15:38:03.455: Vi1 IPCP: Address 10.1.1.1 (0x03060A010101)
*Dec 16 15:38:03.463: Vi1 IPCP: I CONFACK [ACKsent] id 6 len 10
*Dec 16 15:38:03.463: Vi1 IPCP: Address 10.1.1.1 (0x03060A010101) 
*Dec 16 15:38:03.463: Vi1 IPCP: State is Open
*Dec 16 15:38:03.463: Vi1 IPCP: Install route to 10.1.1.2

show Command Output

Access-6400-NRP1# show user
Line       User      Host(s)            Idle Location
* 0        con 0     idle               00:00:00
Vi1                  Virtual PPP (ATM)  00:06:45
Interface  User      Mode               Idle Peer Address


Access-6400-NRP1# show interface atm 0/0/0 accounting
ATM0/0/0 
Protocol       Pkts In    Chars In  Pkts Out   Chars Out
Trans. Bridge        0           0         3         222
Spanning Tree        0           0      1384       65048
PPP over ATM       358        6646       605       11657


Access-6400-NRP1# show interface atm 0/0/0
ATM0/0/0 is up, line protocol is up
Hardware is ATM-SAR
MTU 4470 bytes, sub MTU 4470, BW 156250 Kbit, DLY 80 usec, 
 reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not supported
Keepalive not supported
Encapsulation(s): AAL5, PVC mode
2047 maximum active VCs, 3 current VCCs
VC idle disconnect time: 300 seconds
Last input 00:09:37, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
  1307 packets input, 57832 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  2876 packets output, 123055 bytes, 0 underruns 
  0 output errors, 0 collisions, 3 interface resets
  0 output buffer failures, 0 output buffers swapped out
Access-6400-NRP1# 
Access-6400-NRP1#
Access-6400-NRP1# 


Access-6400-NRP1# show interface atm 0/0/0.1
ATM0/0/0.1 is up, line protocol is up
Hardware is ATM-SAR
MTU 4470 bytes, BW 156250 Kbit, DLY 80 usec,
  reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM 
0 packets input, 0 bytes
1392 packets output, 59937 bytes
0 OAM cells input, 0 OAM cells output


Access-6400-NRP1# show interface atm 0/0/0.4
ATM0/0/0.4 is up, line protocol is up
Hardware is ATM-SAR
MTU 4470 bytes, BW 156250 Kbit, DLY 80 usec, 
 reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM 
705 packets input, 11705 bytes
615 packets output, 9415 bytes
0 OAM cells input, 0 OAM cells output


Access-6400-NRP1# show atm vc 15
ATM0/0/0.1: VCD: 15, VPI: 1, VCI: 34 
UBR, PeakRate: 155000
AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0
OAM frequency: 0 second(s)
InARP frequency: 15 minutes(s)
InPkts: 0, OutPkts: 321, InBytes: 0, OutBytes: 13803
InPRoc: 0, OutPRoc: 321, Broadcasts: 0
InFast: 0, OutFast: 0, InAS: 0, OutAS: 0 
OAM cells received: 0
OAM cells sent: 0
Status: UP
Access-6400-NRP1# 


Access-6400-NRP1# show atm vc 16
ATM0/0/0.4: VCD: 16, VPI: 4, VCI: 33
UBR, PeakRate: 155000
AAL5-MUX, etype:0x9, Flags: 0xC23, VCmode: 0x0
OAM frequency: 0 second(s)
InARP DISABLED
InPkts: 6, OutPkts: 143, InBytes: 48, OutBytes: 2420
InPRoc: 3, OutPRoc: 143
InFast: 0, OutFast: 0, InAS: 3, OutAS: 0
OAM cells received: 0
OAM cells sent: 0
Status: UP
PPP: Virtual-Access1 from Virtual-Template1
Access-6400-NRP1#


Access-6400-NRP1# show interface virtual-access 1
Virtual-Access1 is up, line protocol is down
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Loopback1 (10.1.1.1)
MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec, 
 reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
LCP REQsent
Closed: IPCP
Bound to ATM0/0/0.4 VCD: 16, VPI: 4, VCI: 33
Cloned from virtual-template: 1
Last input 00:12:07, output never, output hang never
Last clearing of "show interface" counters 00:12:18
Queueing strategy: fifo > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
 3 packets input, 18 bytes, 0 no buffer 
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 158 packets output, 2675 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets 
 0 output buffer failures, 0 output buffers swapped out 
 0 carrier transitions
Access-6400-NRP1#

Related Information

Updated: Nov 23, 2007
Document ID: 12855