Guest

Cisco 6400 Series Broadband Aggregators

Configuring PVC and PVP Cross Connections for the Cisco 6400 NRP/NSP

Document ID: 12848

Updated: Feb 26, 2008

   Print

Introduction

This document contains examples of Permanent Virtual Circuit (PVC) and Permanent Virtual Path (PVP) internal cross-connections of a 6400 Universal Access Concentrator (UAC) that has one Node Route Processor (NRP) adapter and one Node Switch Processor (NSP) adapter installed. Also discussed in this document are direct encapsulation and class-int types of encapsulation methods for bridging and routing.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco 6400 UAC with NRP/NSP installed

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

Configuring PVCs

A PVC is a permanent logical connection that you must configure manually, from source to destination, through the ATM network. After it is configured, the ATM network maintains the connection at all times; that is, the connection is always up whether or not there is traffic to send.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

The Cisco 6400 uses PVCs to pass traffic between the node line card (NLC) ATM interfaces via the NSPs and NRPs. Typically, each subscriber is bound to a specific NRP and should be configured as a separate PVC.

Note: PVC-DISCOVERY is not supported with this type of setup.

The following is an example of PVC Internal Cross-Connections on a 6400 NSP card:

interface ATM8/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 34 interface ATM1/0/0 1 34

Configuring PVPs

A PVP, or VP tunnel, allows you to connect two ATM switch routers at different locations across a public ATM network that does not support ATM signaling. Signaling traffic is mapped into the PVP, and the switches allocate a virtual channel connection (VCC) on that VP instead of the default VP 0. This mapping allows the signaling traffic to pass transparently through the public network.

Note: Configuring "PVC-DISCOVERY" is not supported with this type of setup.

The following is an example of PVP Internal Cross-Connections on a 6400 NSP card:

NSP Adapter
--------------- 
 interface ATM8/0/0
  no ip address
  no ip directed-broadcast
  no atm ilmi-keepalive
  atm pvp 1 interface ATM1/0/0 1

Note: Any traffic that comes in from the DSLAM on interface ATM8/0/0 with a value of VPI=1 will be forwarded to interface ATM1/0/0 with VPI=1. The VCI value will not be configured on the NSP. The NRP and the network side of the DSLAM will each have a VPI/VCI configured.

Configuration Using PVCs and Bridging Using the class-int Option

Cisco 6400 NRP
!
bridge irb
 interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
 no ip directed-broadcast
 pvc 1/34
 
!--- VPI/VCI must match the NSP configuration

 !
 class-int <class-name> 
 
!--- class-int option

 bridge-group 1
!
interface BVI1
 ip address 10.10.33.1 255.255.255.0
 no ip directed-broadcast
 vc-class atm <class-name>
  encapsulation aal5snap
 !
 bridge 1 protocol ieee
 bridge 1 route ip
!

Cisco 6400 NSP
!

interface ATM8/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 34 interface ATM1/0/0 1 34
 
!--- must match the NRP

!

Configuring PVC and Bridging Using Direct Encapsulation

Cisco 6400 NRP
!
bridge irb
!
interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
 no ip directed-broadcast
 pvc 1/34
 
!--- VPI/VCI must match the NSP configuration

  encapsulation aal5snap
 
!--- encapsulation

 !
 bridge-group 1
 !
 interface BVI1
  ip address 10.10.33.1 255.255.255.0
  no ip directed-broadcast
 !
 bridge 1 protocol ieee
  bridge 1 route ip
!

Cisco 6400 NSP
!

interface ATM8/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 34  interface  ATM1/0/0 1 34
 
!--- must match the NRP

!

Configuring PVC and Routing Using the class-int Option

Cisco 6400 NRP
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/0/0.4 point-to-point
 no ip directed-broadcast
 pvc 4/33
 
!--- must match the NSP

 !
  class-int <class-name> 
  
!--- class-int option

!
interface Virtual-Template1
 ip unnumbered Loopback1
 no ip directed-broadcast
 ppp authentication chap
!
vc-class atm <class-name>
 encapsulation aal5mux ppp Virtual-Template1
!

Cisco 6400 NSP
!

interface ATM8/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 33 interface ATM1/0/0 4 33
 
!--- must match the NRP

!

Configuring PVC and Routing Using Direct Encapsulation

Cisco 6400 NRP
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/0/0.4 point-to-point
 no ip directed-broadcast
 pvc 4/33
  encapsulation aal5mux ppp Virtual-Template1
  
!--- direct encapsulation

!
interface Virtual-Template1
 ip unnumbered Loopback1
 no ip directed-broadcast
 ppp authentication chap


Cisco 6400 NSP
interface ATM8/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 33 interface ATM1/0/0 4 33

!--- must match the NRP

Configuring PVC, Routing, and Bridging

The following configuration supports connections for two Cisco DSL devices (CPE/modem/router). One device uses bridging, the other device uses routing.

Cisco 6400 NRP
bridge irb
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
 no ip directed-broadcast
 pvc 1/34  
 
!--- DSLAM traffic with network side VPI=1, 
!--- VCI=34 will use this PVC

  encapsulation aal5snap
  !
  bridge-group 1
!
interface ATM0/0/0.4 point-to-point
 no ip directed-broadcast
 pvc 4/33
 
!--- DSLAM traffic with network side VPI=1, 
!--- VCI=33 will use this PVC

  encapsulation aal5mux ppp Virtual-Template1
!
interface Ethernet0/0/0
 no ip directed-broadcast
!
interface Virtual-Template1
 ip unnumbered Loopback1
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication chap
!
interface BVI1
 ip address 10.10.33.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool <pool name> 10.1.1.2 10.1.1.200
!
bridge 1 protocol ieee
 bridge 1 route ip
!

Cisco 6400 NSP
!
interface ATM1/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM8/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 33  interface  ATM1/0/0 4 33  
 atm pvc 1 34  interface  ATM1/0/0 1 34  
!

Configuring PVP, Routing, and Bridging

6400brdg_rtng_1.gif

The following configuration supports connections for two Cisco DSL devices (CPE/modem/router). The Cisco 6400 NSP is configured for PVP internal cross-connections and the Cisco 6400 NRP is configured for PVC VPI/VCI pairs.

Note: All traffic that comes in from the DSLAM on interface ATM8/0/0 with a value of VPI=1 will be forwarded to interface ATM1/0/0 with VPI=1. The VCI remains the same. The NRP needs to be configured with proper VPI/VCI values.

Cisco 6400 NRP
!

interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
 no ip directed-broadcast
 pvc 1/34
 
!--- DSLAM traffic with network side VPI=1, 
!--- VCI=34 will connect using this PVC

  encapsulation aal5snap
  !
  bridge-group 1
!
interface ATM0/0/0.4 point-to-point
 no ip directed-broadcast
 pvc 1/33
 
!--- DSLAM traffic with network side VPI=1, 
!--- VCI=33 will connect using this PVC

  encapsulation aal5mux ppp Virtual-Template1
!

Cisco 6400 NSP
!

interface ATM1/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM8/0/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 1 interface ATM1/0/0 1
 
!--- PVP configuration

!

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 12848