Guest

Cisco 600 Series DSL Customer Premises Equipment Routers

Configuring a Cisco 675 CPE With PPPoA, DHCP, NAT, and Terminating on a 6400 UAC (aal5mux ppp)

Cisco - Configuring a Cisco 675 CPE With PPPoA, DHCP, NAT, and Terminating on a 6400 UAC (aal5mux ppp)

Document ID: 9242

Updated: Oct 04, 2006

   Print

Introduction

This document describes two sample configurations. Configuration 1 shows a Cisco 675 Router configured with Network Address Translation (NAT) and as a Dynamic Host Configuration Protocol (DHCP) server for its local Ethernet clients. The DSL interface WAN0-0 is configured with an IP address and connects to a Cisco 6400 Universal Access Concentrator (UAC) configured with aal5mux ppp.

Configuration 2 shows a Cisco 675 Router configured with NAT and as a DHCP server for its local Ethernet clients. The DSL interface WAN0-0 is configured in order to accept an IP address from a pool of addresses configured on the Cisco 6400.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco 675 CPE Cisco Broadband Operating System (CBOS) Release 2.2.0.000

  • Cisco 6400 UAC-NRP IOS® Software Release 12.0(7)DC

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) in order to obtain more information on the commands used in this section.

Network Diagram - Configuration 1

This document uses this network setup:

675cpe_1.gif

Network Diagram - Configuration 2

This document uses this network setup:

675cpe_2.gif

Configurations 1

The Cisco 675 is configured as a DHCP server for its local Ethernet clients (address range from 10.0.0.2 to 10.0.0.4).

The Ethernet0 interface is assigned an IP address of 10.0.0.1 (the default). The Wan0-0 interface is configured with an IP address of 172.18.0.1.

You must enable NAT on the Cisco 675 in order to support this configuration. Otherwise, the WAN0-0 IP address of 172.18.0.1 overwrites the Ethernet IP address of 10.0.0.1.

Cisco 675
R1#set dhcp server enabled 
DHCP Server enabled

R1#set dhcp server pool 0 ip 10.0.0.2

!--- This is the first ip address to be assigned to Clients.

Pool 0 IP parameter is now 10.0.0.2

R1#set dhcp server pool 0 size 3 

!--- This starts from 10.0.0.2 and ends at 10.0.0.4.

Pool 0 size parameter is now 3

R1#set dhcp server pool 0 netmask 255.0.0.0
Pool 0 netmask parameter is now 255.0.0.0

R1#set dhcp server pool 0 gateway 10.0.0.1

!--- This address is given to clients as the default gateway.

Pool 0 gateway parameter is now 10.0.0.1

R1#set int eth0 address 10.0.0.1

!--- Set IP address for Ethernet.

eth0 ip address changed from 9.9.9.9 to 10.0.0.1

R1#set int eth0 mask 255.0.0.0
eth0 netmask changed from 255.255.0.0 to 255.0.0.0

R1#set ppp wan0-0 ipcp 172.18.0.1

!--- Set IP address for WAN DSL interface.

PPP wan0-0 IPCP Address set to 172.18.0.1

R1#set ppp wan0-0 authen enabled

!--- This enables authentication <pap chap negotiated>.

PAP and CHAP Authentication is now enabled on specified port

R1#set ppp wan0-0 login <username>


!--- This is used for authentication
.
User name for wan0-0 has been set to 
<username>


R1#set ppp wan0-0 password <password>


!--- This is used for authentication.

Password for wan0-0 has been set to 
<password>


R1#set nat enable

!--- This enables NAT.

NAT is now enabled


!--- You must use "write" then reboot in order for the changes to take effect.

Cisco 6400 NRP
hostname NRP
!
username 
<username>
 password 
<password>

!
ssg disable
!
interface Loopback1
ip address 172.18.0.2 255.255.0.0
!
interface ATM0/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0/0/0.4 point-to-point
no ip directed-broadcast
no ip mroute-cache
pvc 3/33
!
class-int 
<class name>

!
interface Ethernet0/0/1
no ip address
no ip directed-broadcast
!
!
interface Virtual-Template1
ip unnumbered Loopback1
ip directed-broadcast
no peer default ip address
ppp authentication chap
!
ip route 10.0.0.1 255.255.255.255 172.18.0.1
no ip http server
!
!
vc-class atm 
<class name>

encapsulation aal5mux ppp Virtual-Template1
!
line con 0
transport input none
end

Configurations 2

The WAN0-0 interface might be configured in order to negotiate an IP address from its host located across the WAN0-0 interface. In this case the host is a Cisco 6400 NRP configured with a local ip address pool.

The Cisco 6400 assigns an address from this local ip address pool to the WAN0-0 interface of the Cisco 675. The Cisco 675 continues to function as a DHCP server for its local Ethernet clients.

Use the Cisco 675 configuration in Configuration 1 and make the change shown in this example.

Cisco 675
R1#set ppp wan0-0 ipcp 0.0.0.0

!--- IP address is assigned to WAN0-0 interface 
!--- by remote host located across WAN-DSL link.

PPP wan0-0 IPCP Address set to 0.0.0.0

R1#write
NVRAM written.

R1#reboot

Cisco 6400 NRP
version 12.0
!
hostname NRP
!
username 
<username>
 password 
<password>

ip address-pool local
ssg disable
!
interface Loopback1
 ip address 172.18.0.2 255.255.0.0
!
interface ATM0/0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM0/0/0.4 point-to-point
 no ip directed-broadcast
 no ip mroute-cache
 pvc 3/33 
 !
 class-int 
<class name>

!
interface Ethernet0/0/1
 no ip address
 no ip directed-broadcast
!
interface Ethernet0/0/0
 no ip address
 ip directed-broadcast
 no ip mroute-cache
!
interface FastEthernet0/0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Virtual-Template1
 ip unnumbered Loopback1
 ip directed-broadcast
 no ip route-cache
 peer default ip address pool 
<pool name>

 ppp authentication chap
!
ip local pool 
<pool name>
 172.18.0.10 172.18.0.20
ip classless
no ip http server
!
!
vc-class atm 
<class name>

encapsulation aal5mux ppp Virtual-Template1
!
line con 0
 transport input none
line aux 0
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Oct 04, 2006
Document ID: 9242