Guest

Cisco 2600 Series Multiservice Platforms

Understanding Support for Voice and Data on 2600/3600 Series Routers

Document ID: 23525

Updated: Feb 02, 2006

   Print

Introduction

This document outlines the many uses of the High Density Voice Network Module (NM-HDV) with the one- or two-port T1/E1 Multiflex Voice/WAN Interface Cards (VWICs). The Multiflex VWICs combine WIC and Voice Interface Card (VIC) functionality to provide support for a variety of voice and data applications in Cisco 2600 and 3600 multiservice routers.

Prerequisites

Requirements

Readers of this document should have knowledge of these topics:

  • Telephony concepts

  • Voice over IP (VoIP) dial peers

  • E1/T1 concepts

Components Used

The information in this document is based on these software versions:

  • Cisco IOS® Software Release 12.0(7)T for voice support on the NM-HDV

  • Cisco IOS Software Release 12.1.3T for WAN data support on the NM-HDV

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

The Cisco 2600/3600 series IOS gateways initially supported ISDN, also known as PRI, for data connectivity on a number of network modules, including these:

  • NM-1CT1

  • NM-1CT1-CSU

  • NM-2CT1

  • NM-2CT1-CSU

  • NM-1CE1B

  • NM-2CE1B

  • NM-1CE1U

  • NM-2CE1U

  • NM-1FE1CT1

  • NM-1FE1CT1-CSU

  • NM-1FE2CT1

  • NM-1FE2CT1-CSU

  • NM-1FE1CE1B

  • NM-1FE1CE1U

  • NM-1FE2CE1B

  • NM-1FE2CE1U

In Cisco IOS Software Release 12.0(7)T, NM-HDV was introduced to support voice connectivity on T1/E1 interfaces from Cisco 2600/3600 series IOS gateways to a PBX or the Public Switched Telephone Network (PSTN). Signaling support on digital and analog interfaces on the Cisco 2600/3600 series gateways now includes:

  • T1-PRI

  • E1-PRI

  • T1-channel associated signaling (CAS)

  • E1-R2

  • T1/E1 Q Signaling (QSIG)

  • T1 Feature Group D (FGD)

  • BRI, Foreign Exchange Office (FXO)

  • recEive and transMit (E&M)

  • Foreign Exchange Station (FXS)

In Cisco IOS Software Release 12.1.2XH, which merged into Cisco IOS Software Release 12.1.3T, WAN data connectivity was also introduced on the NM-HDV.

Digital Signaling Zero (DS0) channels on a T1/E1 can be grouped and assigned to carry either voice or data traffic and both types of traffic can be carried at the same time. This capability provides a solution for connecting to an Integrated Access provider that splits the voice channels off to the PSTN, and the data channels to an IP or Frame Relay data backbone. This capability does not extend to modem data calls, which can only be handled by the traditional data network modules listed.

For more information on the NM-HDV module, refer to these documents:

For more information on the Multiflex VWICs, refer to these documents:

Time Slot Groups Supported on NM-HDV

There are four different types of time slot groupings that can be defined on a Multiflex T1/E1 housed in an NM-HDV. Each has a specific purpose and supports a specific feature.

Note: For the ds0-group and pri-group, modem call termination on the router is not supported on the NM-HDV module.

This table summarizes the use and support of the different types of groups on the Multiflex T1/E1s housed in data network modules (or 2600 WIC slots) in comparison with the Multiflex T1/E1s housed in an NM-HDV.

Time Slot Grouping Description T1/E1 in a Data Network Module or WIC slot T1/E1 in an NM-HDV
tdm-group Supports PRI/QSIG signaling for voice connectivity to the PBX/PSTN. Yes (D&I) Yes (D&I)
pri-group Supports cross connect drop-and-insert (D&I) applications. No (no Digital Signal Processor [DSP] access) Voice only (no data)
ds0-group Supports CAS signaling for voice connectivity to PBX/PSTN. No (no DSP access) Yes
channel-group Supports data WAN connectivity on the NM-HDV. Yes Yes

Combining Time Slot Groups

Combinations of these groups can be defined on the same T1/E1 interface within these guidelines:

  • Maximum number of ds0 or tdm-groups: number of channels on the T1/E1 (24/31).

  • Maximum number of channel-groups: subject to memory availability (approximately two to three).

  • Maximum number of pri-groups: one (must have channel 24 on a T1, or channel 16 on an E1).

This is an example T1 controller configuration that implements both CAS and channel-groups on interface 2/0:

  controller T1 2/0
  ds0-group 1 timeslots 1-4 type e&m-wink-start
  channel-group 5 timeslots 5-10
  channel-group 6 timeslots 11-15

Note: The ds0-group cannot be configured along with the pri-group on the same T1/E1 controller.

PRI (pri-group)

This section summarizes various concepts from Cisco IOS Software support for PRI on the NM-HDV.

Network- and User-Side PRI

Both ISDN network-side and user-side Q.931 PRI signaling is supported by Cisco IOS Software with NM-HDV. Cisco IOS Software currently supports network-side signaling for these switch types:

  • Primary-QSIG

  • Primary-NI

  • Primary-NET5

The default configuration is always user-side. To change it to network-side signaling, issue this command:

isdn protocol-emulate network

This command must be specified on the serial interface created for the D-channel to make it operate as network-side PRI signaling. For example:

controller T1 1/1
  framing ESF
  linecode B8ZS
  pri-group timeslots 1-24

interface Serial1/1:23
  isdn protocol-emulate network

Q.931 ISDN PRI signaling is an asymmetric protocol. Network-side PRI is typically implemented by the service provider side (the PSTN switch side), while user-side PRI is implemented by the customer premises equipment (CPE) (the PBX or router side). For more information on ISDN PRI network-side signaling, refer to these documents:

Cisco IOS Software supports these user-side signaling switch types as displayed in the Cisco IOS command-line interface (CLI) help on the router:

router(config-if)# isdn switch-type ? 
  primary-4ess                  AT&T 4ESS switch type for the U.S.
  primary-5ess                  AT&T 5ESS switch type for the U.S.
  primary-dms100                Northern Telecom switch type for North America
  primary-net5                  NET5 switch type for UK, Europe and Asia
  primary-ni                    National ISDN Switch type for North America
  primary-ntt                   Japan switch type
  primary-qsig                  QSIG switch type
  primary-ts014                 Australia switch type

Switch types are specified either globally or on the serial interface created for the D-channel. The global setting must be specified before the controller can become available for ISDN PRI usage. If the global setting is not specified, it is not possible to configure a pri-group in the NM-HDV controller.

The global setting is used by the router as the default setting for all of its E1/T1 ISDN PRI interfaces. If certain PRI interfaces need to use a different switch type, then the appropriate type must be specified at the D-channel interface level. The interface switch-type command overrides the global switch-type command. This feature was introduced in Cisco IOS Software Release 12.1(3)T to allow a router to connect to different ISDN switches that use different switch types.

For example, this T1 controller uses the primary-net5 switch type on interface 1/1.

 isdn switch-type primary-qsig

  controller T1 1/1
  pri-group timeslots 1-24

  interface Serial1/1:23
  isdn switch-type primary-net5
  isdn protocol-emulate network
  isdn incoming-voice voice
  no cdp enable

Here is another example where the T1 controller uses the primary-qsig switch type on interface 1/1 because it is defined globally.

isdn switch-type primary-qsig

  controller T1 1/1
  pri-group timeslots 1-24

  interface Serial1/1:23
  isdn protocol-emulate network
  isdn incoming-voice voice
  no cdp enable

Fractional PRI

The term fractional PRI has different meanings in different parts of the world. One meaning indicates multiple PRI groups (B-channels and associated D-channel) on the same T1/E1 interface. Because the NM-HDV supports only a single D-channel per T1/E1, the PRI feature does not support this definition of fractional PRI. However, the other version of the term indicates the ability to define a single D-channel for each interface with fewer than 23/31 B-channels associated with it. As shown earlier in this document, this definition of fractional PRI is supported.

For example, this configuration shows a PRI interface with five B-channels defined:

  controller T1 2/0
  channel-group 5 timeslots 5-10
  channel-group 6 timeslots 11-15
  pri-group timeslots 16-20,24

Note: A single D-channel per T1/E1 interface is supported. On a T1 controller the D-channel is always on channel 24, and on an E1 controller the D-channel is always on channel 16. This association cannot be changed through software configuration on the router. Currently, Non-Facility Associated Signaling (NFAS), which allows more than 1 T1/E1s worth of B-channels to be mapped to a single D-channel, is supported on the 26/36 platforms using the NM-HDV module with Cisco IOS Software Release 12.2(8)T and later. For more information on ISDN NFAS, refer to this document:

Voice versus Data PRI

Two terms have been coined to clarify support for voice and data and modem calls on the Cisco 2600/3600 series routers. These terms are voice PRI and data PRI. Voice PRI refers to a T1/E1 interface connected to a PBX or the PSTN where the PRI B-channels carry time-division multiplexing (TDM) voice traffic. Data PRI refers to a WAN connection, and carries packetized (data or voice) traffic such as ISDN High-Level Data Link Control (HDLC) data or Modem Data. The NM-HDV only supports A-channel voice PRI. It does not support ISDN DATA and MODEM calls. Data network modules are required to support a data PRI.

How an incoming call on a PRI is treated by Cisco 2600/2300 series IOS routers depends on these variables:

  • Where the T1/E1 is housed (in an NM-HDV or in a data network module)

  • The bearer capabilities (Bearer CAP field in the Q.931 Set-up message)

  • The Cisco IOS construct to which the called number is matched and translated

Data PRI (CT1/CE1 Module)

Data PRI connectivity, or channelized T1/E1 for data traffic, has been supported on the Cisco 2600/3600 series routers since Cisco IOS Software Release 11.x. Support for data PRI connectivity requires:

  • The PRI interface is housed in a data network module mentioned at the beginning of this document rather than inside the NM-HDV.

  • Bearer capability (bearer cap) in the call setup is data.

  • The called number is matched by a dialer group.

A data PRI cannot support voice calls because there is no access to the DSPs. Therefore, a call that arrives on a data PRI should not be configured to match a voice dial peer. An example configuration for a data PRI is as follows:

controller T1 1/0
  framing esf
  linecode b8zs
  pri-group timeslots 1-24

  interface Serial1/0:23
  encapsulation ppp
  no logging event link-status

  dialer rotary-group 1
  isdn switch-type primary-5ess
  no fair-queue

  interface Dialer1
  ip address 6.6.6.2 255.255.255.0
  no ip directed-broadcast
  encapsulation ppp
  dialer in-band
  no logging event link-status
  dialer idle-timeout 2147483 either
  dialer-group 1
  no fair-queue
  ppp authentication chap
  ppp multilink
  peer default ip address pool ISDN

Voice PRI (NM-HDV T1/E1 Module)

Voice PRI support was introduced for the first time in Cisco IOS Software Release 12.1.3T and requires these statements to be true:

  • The PRI interface is housed in an NM-HDV with DSP.

  • Bearer cap in the call setup is voice.

  • The called number is matched by a voice dial peer.

A voice PRI cannot support data calls. Therefore, a call that arrives on a voice PRI must always be configured to match a voice dial peer (and should not match a dialer group). This is an example configuration for a voice PRI:

controller T1 2/0
  framing esf
  linecode b8zs
  pri-group timeslots 1-24

  interface Serial2/0:23
  isdn switch-type primary-net5
  isdn incoming-voice voice
  isdn T309-enable
  no cdp enable

  voice-port 2/0:23
  no modem passthrough

  dial-peer voice 1 pots
  destination-pattern 4...
  port 2/0:23
  prefix 4

  dial-peer voice 3 voip
  destination-pattern 6...
  session target ipv4:141.245.41.2
  dtmf-rely h225-signal
  ip precedence 5

Modem Calls on PRI Interfaces

Modem traffic falls somewhere between the two concepts just illustrated. It can be thought of as a voice call that carries data traffic. On the 5300, a modem call can be handled on a voice PRI by the called number (Dialed Number Identification Service [DNIS]) matching a modem-pool configuration. On the Cisco 2600/3600 series router, this capability is not supported. If the intent of the configuration is to terminate the modem call on a modem card within the platform, then modem traffic must be handled on a data PRI with the data network module instead of the NM-HDV.

If a modem call arrives on a Cisco 2600/3600 voice PRI (T1/E1 in an NM-HDV), it is handled with a clear-channel codec. The modem connection is passed end-to-end between Cisco IOS gateways as if it were a regular voice call. This call cannot be terminated on modem cards in the gateways, but rather gets switched through the router. This configuration to support modem calls is not recommended because:

  • Clear-channel codec-based transparent support is sensitive to timing. For instance, buffer underruns cause the DSP to execute its voice autofill algorithm, which confuses the data application.

  • There is no error or loss detection in the traffic, so any IP packet loss in the network causes the modem connection to fail and retrain.

voice-data-nm-hdv-1.gif

ISDN Circuit Switching

There is no true ISDN circuit switching supported in the Cisco IOS implementation of voice PRI. However, it can be approximated in two different ways. The method considered in this section makes use of pri-group on incoming and outgoing interfaces and POTS-to-POTS dial peers. The other makes use of tdm-group and D&I, and is considered in the next section.

Whenf POTS-to-POTS dial peers are used to switch calls in and out on PRI, these are the characteristics:

  • It is equivalent to any other POTS-to-POTS call (E&M, T1 CAS, and so forth).

  • PRI signaling is interpreted (terminated and regenerated).

  • DSPs are used.

  • Digit manipulation can be done.

  • Some received calls can be sent out on PRI, others can be carried by Voice-operated eXchange (VoX). There is no relation between the inbound time slot and the outbound time slot.

  • It is possible across any PRI voice trunk on the platform.

  • Only PRI voice calls can be handled.

Here is an example configuration for switching a voice call in and out on the T1 PRI line for any four digits dialed with a 4 or 5 as the prefix. If the dialed number starts with a "6", it converts the call to VoIP and sends it to the 10.1.1.1 terminating gateway for termination. The configuration matches this diagram:

voice-data-nm-hdv-2.gif

controller E1 1/0<
  pri-group timeslots 1-31

  controller E1 2/1
  pri-group timeslots 1-10,16

  interface Serial1/0:15
  isdn switch-type primary-net5
  isdn protocol-emulate network
  isdn incoming-voice voice

  interface Serial2/1:15
  isdn switch-type primary-net5
  isdn incoming-voice voice

  dial-peer voice 1 pots
  destination-pattern 4...
  port 1/0:15
  prefix 4 

  dial-peer voice 2 pots
  destination-pattern 5...
  port 2/1:15
  prefix 5 

  dial-peer voice 3 voip
  destination-pattern 6...
  session target ipv4:10.1.1.2

PRI Configuration Differences Between the Cisco 2600/3600 Series and the Cisco AS5300 Series Router

These points highlight key differences in the configuration between the Cisco 2600/3600 series platforms and the Cisco AS5300:

  1. For the D-channel serial interface:

    • Cisco2600/3600 requires this command: isdn incoming-voice voice

    • Cisco AS5300 requires this command: isdn incoming-voice modem

  2. D-channel voice port:

    • Cisco 2600/3600 automatically creates: port 2/0:23 (T1) or 2/0:15 (E1).

    • Cisco AS5300 automatically creates: port 1:D.

  3. Cisco AS5300 can terminate ISDN data and modem voice calls to modem cards on the PRI. The Cisco 2600/3600 series router cannot; these routers need to use two different network modules.

  4. Clear-channel codec is supported on Cisco 2600/3600 series routers. The AS5300 does not support this capability.

  5. Transparent Common Channel Signaling (T-CCS) and D&I features are support on the Cisco 2600/3600 for PRI. The AS5300 does not support this capability.

  6. ISDN NFAS signaling is supported on the Cisco AS5300 and also on the 2600/3600 series routers.

    Note: On the 2600/3600 series routers, support is restricted to the ISDN switch-types dms100, 4ess and 5ess. Also, note that only user-side NFAS is supported on the 2600/3600 series platforms.

CAS Signaling using NM-HDV and the T1/E1 Multiflex Voice/WAN Interface Cards (DS0-Group)

The T1 CAS enables these network modules to support voice call transmission with channelized T1 lines. CAS is a form of signaling used on a T1 line. With CAS, a signaling element is dedicated to each channel in the T1 frame. This type of signaling is sometimes called Robbed Bit Signaling (RBS) because a bit is taken out (or robbed) from the user's data stream to provide signaling information to and from the switch.

Here is a list of all the possible CAS signaling support on the Multiflex T1 module:

3640router# configure t
Enter configuration commands, one per line. 
End with CNTL/Z.
3640route(config)# controller t1 2/0
3640router(config-controller)# ds0-group 1 timeslots 1-24 type ?
  e&m-delay-dial       E & M Delay Dial
  e&m-fgd              E & M Type II FGD
  e&m-immediate-start  E & M Immediate Start
  e&m-wink-start       E & M Wink Start
  ext-sig              External Signaling
  fgd-eana             FGD-EANA BOC side
  fxo-ground-start     FXO Ground Start
  fxo-loop-start       FXO Loop Start
  fxs-ground-start     FXS Ground Start
  fxs-loop-start       FXS Loop Start
  none                 Null Signaling for External Call Control
3640router(config-controller)# ds0-group 1 timeslots 1-24 type e&m-wink-start

Once the command is issued, an associated voice-port is created.

For example:

    controller T1 2/0 
         framing esf 
         linecode b8zs 
         ds0-group 1 timeslots 1-4 type e&m-wink-start 
  
      voice-port 2/1:1 � where the "2/1" is the controller # and ":1" is the ds0-group

For more information on T1 CAS signaling configuration and troubleshooting, refer to this document:

For E1 CAS signaling, it is completely different. For E1 CAS, time slot 16 is used completely for the CAS signaling, similar to ISDN. However, the format is different. For more information on E1 CAS, refer to these documents:

Transparent Common Channel Signaling (T-CCS) versus Native PRI

The Cisco 2600/3600 series routers with the PRI can also support T-CCS. T-CCS allows the connection of two PBXs with digital interfaces that use a proprietary or unsupported CCS protocol without the need for interpretation of CCS signaling for call processing. T1/E1 traffic is transported transparently through the data network and the feature preserves proprietary signaling. From the PBX standpoint, the signaling is performed through a point-to-point connection. Calls from the PBXs are not routed, but follow a preconfigured route to the destination. This feature allows PBX feature transparency across a WAN and permits PBX networks to provide advanced features, such as calling name and number display, camp-on and callback, network call forwarding, centralized attendant, and centralized message waiting.

Native PRI support means that the D-channel signaling is interpreted and terminated locally by the Cisco IOS gateway. The router can then make call-routing decisions based on the called number (DNIS) matched with the outgoing dial-peer. The voice interface on the other side of the network may be PRI or another voice trunk protocol (for instance, QSIG, E&M, or FXS/FXO). This configuration supports fully switched calls between all locations.

With T-CCS, on the other hand, the signaling is transparently tunneled across the IP/Frame Relay/ATM cloud in a point-to-point manner between two PBXs. The PBXs are configured as if they are connected directly to one another and must run the same voice trunk protocol. Voice calls cannot be switched, and are set up in a static manner through a connection trunk between locations with one-to-one mapping. The signaling channel defined between the PBX and the router must use the clear codec setting. The voice traffic can be encoded by any codecs defined on the dial peers between the two routers.

These diagrams and table show a sample configuration of T-CCS.

voice-data-nm-hdv-3.gif

voice-data-nm-hdv-4.gif

3640_1 Router Configuration 3640_2 Router Configuration
controller T1 1/0  
  framing esf   
  linecode b8zs   
  ds0-group 0 timeslots 24 type ext-sig   
  ds0-group 1 timeslots 1 type ext-sig   
  . 
  . 
  (continue up to max time slot required)  
  . 
  ds0-group 23 timeslots 23 type ext-sig 
! 
interface Serial0/0   
  ip address 172.16.1.2 255.255.255.252 
! 
voice-port 1/0:0 
!--- signaling channel

 connection trunk 1000 answer-mode 
! 
voice-port 1/0:10 
!--- bearer channel

  connection trunk 2001 answer-mode 
! 
. 
.  
(continue onward for every voice-port setup) 
. 
voice-port 1/0:23 
!--- bearer channel

connection trunk 2023 answer-mode 
! 
dial-peer voice 1000 voip   
  description Signaling Channel    
  destination-pattern 1000 
  session target ipv4:172.16.1.1 
  codec clear-channel   
  no vad 
! 
dial-peer voice 2000 voip 
  description Voice Bearer Channels 
  destination-pattern 2... 
  session target ipv4:172.16.1.1 
! 
dial-peer voice 3000 pots 
  description Signaling Channel   
  destination-pattern 3000 
  port 1/0:0 
! 
dial-peer voice 4001 pots 
  description Voice Bearer Channel   
  destination-pattern 4001   
  port 1/0:1 
. 
. 
(continue onward…one for every ds0/voice port setup) 
. 
! 
dial-peer voice 4023 pots 
  description Voice Bearer Channel   
  destination-pattern 4023   
  port 1/0:23
controller T1 1/0  
  framing esf   
  linecode b8zs   
  ds0-group 0 timeslots 24 type ext-sig   
  ds0-group 1 timeslots 1 type ext-sig   
  . 
  . 
  (continue up to max time slot required)  
  . 
  ds0-group 23 timeslots 23 type ext-sig 
! 
interface Serial0/0   
  ip address 172.16.1.1 255.255.255.252 
! 
voice-port 1/0:0 
!--- signaling channel

 connection trunk 3000  
! 
voice-port 1/0:10 
!--- bearer channel

  connection trunk 4001  
! 
. 
.  
(continue onward for every voice-port setup) 
. 
voice-port 1/0:23 
!--- bearer channel
 
connection trunk 4023  
! 
dial-peer voice 3000 voip   
  description Signaling Channel    
  destination-pattern 3000 
  session target ipv4:172.16.1.2 
  codec clear-channel   
  no vad 
! 
dial-peer voice 4000 voip 
  description Voice Bearer Channels 
  destination-pattern 4... 
  session target ipv4:172.16.1.2 
! 
dial-peer voice 1000 pots 
  description Signaling Channel   
  destination-pattern 1000 
  port 1/0:0 
! 
dial-peer voice 2001 pots 
  description Voice Bearer Channel   
  destination-pattern 2001   
  port 1/0:1 
. 
. 
(continue onward…one for every ds0/voice port setup) 
. 
! 
dial-peer voice 2023 pots 
  description Voice Bearer Channel   
  destination-pattern 2023   
  port 1/0:23

For more information on T-CCS, refer to these documents:

TDM Cross Connect (tdm-group)

This section discusses the second method of how to provide ISDN circuit switching, as noted in the previous section. It has limited practical value, but could be used to eliminate some external multiplexer (MUX) equipment and rack space for a customer without fundamentally changing the way the customer's application is operates. It is used in this context to show an example of the use of tdm-group.

Another name for this feature is D&I. D&I refers to the cross connecting of TDM circuits. When you use Cisco routers for voice traffic, the term refers to the cross connecting of a TDM stream from one port to another port on the router. D&I allows you to take 64Kb DS0 channels from one T1 and digitally cross connect them to 64Kb DS0 channels on another T1. Individual 64Kb DS0 channels can be transparently passed, uncompressed, between T1/E1 ports without DSP processing. This is because D&I uses circuit switching, which does not require the DSPs that packet switching employs. Basically, the router does not terminate or interpret the voice signaling used by the switch or pbx. It simply provides a TDM backplane and connects the two controller DS0 time slots together.

Connecting with D&I is one way to integrate traditional circuit-based PBX technologies with VoIP. Channel traffic is sent between a PBX and central office (CO) switch or other telephony device, which allows the use, for example, of some PBX channels for long-distance service through the PSTN while the router compresses others for interoffice VoIP calls. In addition, D&I can cross connect a telephony switch (from the CO) to a channel bank to provide external analog connectivity. It also provides a way to interconnect PBXs, key systems (KTs), and COs when the Private Integrated Services Network eXchange (PINX) does not support QSIG, or when the PINX uses a proprietary solution. This allows the connection between two PBXs without the need for interpretation of the voice signaling for call processing. Basically, the signaling messages are carried within a dedicated time slot, and these time slots are cross connected from one T1/E1 controller to another T1/E1 controller within the VWIC module.

Traditionally, the TDM cross connection can only be done between the two controllers on the same VWIC. With 12.2(4)T and above, the Cisco 2600 series routers allow connection of TDM streams between two VWICs on the same zero-LAN two-slot network module (NM-2W). On Cisco 3600 series routers, it allows connection of TDM streams between two VWICs on the same Fast Ethernet network module (NM-xFE2W). On Cisco 3660 multiservice platforms equipped with a MIX module (MIX-3660-64), you can also connect ports on different MIX-enabled network modules to each other.

For more information on the MIX, refer to these documents:

When you use tdm-group to cross connect an entire or partial T1/E1, these characteristics apply:

  • PRI signaling is not interpreted (in fact the signaling is irrelevant).

  • No DSPs are used.

  • No digit manipulation can be done.

  • All calls that are received are sent out on the cross-connected time slot according to a one-to-one relationship between the input and output time slots.

  • This mechanism is only possible across T1/E1s on the same VWIC.

  • Any type of PRI call can be handled (data, voice, modem, or video).

  • The same framing type needs to be used on both T1 controllers involved in the D&I.

An example configuration for TDM cross connect is shown to match this diagram:

voice-data-nm-hdv-5.gif

Note: The ISDN PRI signaling is between the PBX and the PSTN. The router is transparent in this case, in that it just performs the TDM cross connect between the two T1 lines. TDM cross connect can be implemented independently of the signaling to be used.

  controller T1 2/0
  framing esf
  linecode b8zs
  tdm-group 1 timeslots 1-24 type e&m

  controller T1 2/1
  framing esf
  linecode b8zs
  tdm-group 2 timeslots 1-24 type e&m

  connect pri-di T1 2/0 1 T1 2/1 2

Note: When you configure D&I, the T1 framing under the controllers involved (where the tdm-groups are configured), needs to be the same. If different framing types were used, the signaling bits may not be understood properly when a channel from one controller is dropped and inserted into a channel from another controller. In the TDM cross connect example, Extended Superframe (ESF) framing has been used in both instances.

For more information on TDM cross connect, refer to these documents:

Data WAN Feature (channel-group)

The Data WAN connectivity feature adds the ability to define a group of time slots for data on a T1/E1 housed in an NM-HDV by use of the channel-group command. The syntax is:

(config)# controller {T1 | E1} slot/port
(config-controller)# channel-group channel-group-no timeslots timeslot-list [speed [48|56|64]]
(config)# interface serial slot/port:channel-group

If you define a channel group automatically, you create a serial port with the controller number, followed by a colon, followed by the channel group number. For example:

  controller T1 2/1
  channel-group 10 timeslots 1-15

  interface serial 2/1:10
  encapsulation ...

Channel-group Bandwidth

The maximum bandwidth of a channel group is the aggregate bandwidth of the number of individual time slots included in the group (n*DS0-speed) . The capability to group time slots in any number up to the full number is referred to as fractional E1/T1. For example, this configuration would have a maximum bandwidth of 960K. The DS0 speed defaults to 56K for T1 and 64K for E1, if not specified explicitly. Speeds of 48K, 56K, and 64K are supported.

controller T1 2/1
  channel-group 10 timeslots 1-15 speed 64

Encapsulations Supported

These encapsulations are supported on the serial interface as shown by the Cisco IOS CLI help on the router:

 controller T1 2/1
  channel-group 2 timeslots 1-4
  lab2(config)# interface s2/1:2
  lab2(config-if)# encapsulation ?

       atm-dxi            ATM-DXI encapsulation
       bstun              Block Serial tunneling (BSTUN)
       frame-relay        Frame Relay networks
       hdlc Serial        HDLC synchronous
       lapb               LAPB (X.25 Level 2)
       ppp                Point-to-Point protocol
       sdlc               SDLC
       sdlc-primary       SDLC (primary)
       sdlc-secondary     SDLC (secondary)
       smds               Switched Megabit Data Service (SMDS)
       stun               Serial tunneling (STUN)
       x25                X.25

voice-data-nm-hdv-6.gif

controller T1 2/1        
  framing esf        
  linecode b8zs        
  channel-group 1 timeslots 1-24     
! 
interface serial 2/1:1        
  ip address 10.1.1.1 255.255.255.0        
  encapsulation PPP
controller T1 2/1        
  framing esf        
  linecode b8zs        
  channel-group 1 timeslots 1-24     
! 
interface serial 2/1:1        
  ip address 10.1.1.2 255.255.255.0        
  encapsulation PPP

Supported Scenarios

Scenario 1: One Voice T1/E1 and One Data T1/E1 on the same NM-HDV

The two-port VWIC in an NM-HDV is set up as follows:

  • One voice T1/E1 to PBX

  • One data T1/E1 to WAN

All voice calls received from the PBX are matched to VoIP or Voice over Frame Relay (VoFR) dial peers and can be directed to an IP address or Frame Relay data-link connection identifier (DLCI) on the WAN link defined as a channel-group on the other T1/E1 port on the same network module.

Note: ATM is not supported in this configuration.

This configuration shows how this feature allows a customer to make more efficient use of port slots, especially important for a Cisco 2600 that has only a single network module slot.

voice-data-nm-hdv-7.gif

This is a sample configuration:

    controller T1 1/0
      description Voice signaling with the PBX
      framing esf
      linecode b8zs
      ds0-group 1 timeslots 1-24 type e&m-wink
    !
    controller T1 1/1
      description DATA link to the WAN cloud
      framing esf
      linecode b8zs
      channel-group 4 timeslots 1-24
    !
    interface serial 1/1:4
      no ip address
      encapsulation frame-relay
    !
    interface serial 1/1:4.1 point-to-point
      ip address 192.168.100.1 255.255.255.0
      frame-relay interface-dlci 100
    !
    voice-port 1

Scenario 2: D&I for PSTN Calls and VoIP/FR for On-net Calls on the Same NM-HDV

The two-port VWIC in an NM-HDV is set up as such:

  • One VWIC T1/E1 is connected to the PBX.

  • The other VWIC T1/E1 port is connected to an integrated access carrier for PSTN and WAN access.

  • PSTN calls on certain time slots from the PBX are circuit-switched using D&I.

  • On-net calls use other time slots. These are carried over the WAN by way of VoIP or VoFR.

In this scenario the PBX splits the PSTN destined calls from the on-net (branch-to-branch/headquarters [HQ]) calls onto different groups of channels on the T1/E1:

  • Calls received from the PBX on channels 1 through 12 (controller 1/0 and tdm-group 1) are D&I cross-connected to 12 voice channels which go to the PSTN on controller 1/1, tdm-group 4.

  • Calls received from the PBX on channels 13 through 24 (controller 1/0 ds0-group) are on-net calls. These calls get terminated on the router and then matched to VoIP or VoFR dial-peers which are directed to an IP address or Frame Relay DLCI on the WAN link (controller 1/1, channel group 13).

voice-data-nm-hdv-8.gif

A sample configuration is as follows:

    controller T1 1/0
      description PBX connection
      framing esf
      linecode b8zs
      tdm-group 1 timeslots 1-12
      ds0-group 13 timeslots 13-24 type e&m-wink
    !
    controller T1 1/1
      description PSTN connection 
      framing esf
      linecode b8zs
      tdm-group 4 timeslots 1-12
      channel-group 13 timeslots 13-24
    !
    interface serial 1/1:13
      no ip address
      encapsulation frame-relay
    !
    interface serial 1/1:13.1 point-to-point
      ip address 192.168.100.1 255.255.255.0
      frame-relay interface-dlci 100
    !
    voice-port 1/0:13
    !
    connect tdm1 T1 1/0 1 T1 1/1

Scenario 3: PSTN Calls and VoIP/FR for On-net Calls on the Same NM-HDV

The two-port VWIC in an NM-HDV is set up as such:

  • Full T1/E1 from PBX for on-net voice calls.

  • Single T1/E1 from an integrated access provider for voice calls to the PSTN and for data to the WAN link.

In this scenario, calls from the PBX to the PSTN must be distinguished from on-net calls through the dialing plan. For this reason, the D&I feature cannot be used. All calls from the PBX must be matched by a dial peer to determine the destination of the call (PSTN or on-net). PSTN calls are POTS-to-POTS dial-peer calls, and are directed to the ds0-group (controller 1/1, ds0-group 2) to the PSTN. The same scenario occurs for inbound calls from the PSTN. Calls must be distinguished through the dialing plan defined on the router.

On-net calls match VoIP or VoFR dial peers that can be directed to an IP address or Frame Relay DLCI on the WAN link (controller 1/1, channel-group 7).

voice-data-nm-hdv-9.gif

A sample configuration is as such:

    controller T1 1/0
      framing esf
      linecode b8zs
      ds0-group 1 timeslots 1-24 type e&m-wink
    !
    controller T1 1/1
      framing esf
      linecode b8zs
      ds0-group 2 timeslots 1-6 type type e&m-wink
      channel-group 7 timeslots 7-24
    !
    interface serial 1/1:7
      no ip address
      encapsulation frame-relay
    !
    interface serial 1/1:7.1 point-to-point
      ip address 192.168.100.1 255.255.255.0
      frame-relay interface-dlci 100
    !
    voice-port 1/0:1
    !
    voice-port 1/1:2
!

Warnings and Design Considerations Summary

  • A single, fixed D-channel for each T1/E1 is supported, with channel 24 (T1) or channel 16 (E1). Multiple D-channels for each T1/E1 is not supported. This fact implies that a single PRI group can be configured for each T1/E1. Notice that the pri-group command is not followed by a numerical argument.

  • ISDN NFAS signaling is not supported on the Cisco 2600/3600 series routers with the NM-HDV. The command is visible through the CLI, however, because other platforms support NFAS. NFAS is supported for the data network module.

  • The voice port must be shut down along with the controller before the pri-group can be removed from the controller. It is not sufficient to shut down the controller, the D-channel serial interface, or both.

  • The switch type specified on the interface, if present, overrides the switch type specified at the global level.

  • Voice PRIs must be configured with the command isdn incoming-voice voice on the Cisco 2600/3600 in order to support voice on the PRI interface. The modem and data options that appear in the CLI are applicable to other platforms only.

  • Modem calls received on a PRI T1/E1 on an NM-HDV are treated as voice calls with a clear-channel codec. This configuration is discouraged, as packet loss is not detected and jitter could give rise to DSP buffer underrun or overrun at the destination. If this happens, it causes the modems to retrain.

  • Data WAN connectivity on the NM-HDV cannot be done with the pri-group command. This fact means that ISDN data calls are not supported on the NM-HDV module. It can only support data WAN connections with the channel-group command.

  • The channel-group and pri-group commands use the NM-HDV memory. The ds0-group and tdm-group commands do not.

  • The channel-group and tdm-group commands do not use the voice DSPs. The ds0-group and pri-group commands do use the voice DSPs.

  • If the NM-HDV T1/E1 does both voice and data access, it is possible that there are more DSP resources on the card than can be used by the voice channels defined. These DSPs cannot be shared by any other voice interface or activity in the router until an upcoming Cisco IOS Software featurette enables TDM switching across the router backplane. This feature is available only on the Cisco 3660 platform.

  • The maximum number of channel groups on an NM-HDV is bounded by the NM-HDV memory. This is a network module limitation with the NM-HDV, not an individual T1/E1 limitation.

  • Different types of time slot groups can be mixed and matched in any combination on the same T1/E1 within the memory limitation for channel groups and provided the PRI groups have the D-channel time slot (24 on a T1, and 16 on an E1) available to them.

  • TDM D&I is only possible between the two T1/E1 ports on the same NM-HDV.

  • The Data WAN feature can support VoIP and VoFR WAN data connectivity, but not VoATM or VoIPoATM. ATM WAN connectivity still requires an ATM-capable network module, such as the Inverse Multiplexing over ATM (IMA) or OC-3 cards.

Related Information

Updated: Feb 02, 2006
Document ID: 23525